Change Log (v8)

Build 1387 Released 11/28/2016

  1. Fixed issue with SQL server projects not advancing next number when sequence key does not exist in next numbers table.
  2. Modified the Show Me buttons on the SysName and Cable Number edit dialogs to clear search and filters on the open database grids to ensure the record is found.
  3. Fixed issue with XLT signal types not honoring the Default Signal Types database colors.
  4. NOTE: we have discontinued the monthly subscription. The quarterly and yearly subscriptions are still available.

Build 1386 Released 11/18/206

  1. Apply filter pane to cable number assignment dialog CableNo dropdown.
  2. Fixed: Add Multicore dialog Number Base list not sorting.
  3. Fixed: Add Multicore dialog Cable Type Manufacturer field would allow direct input.
  4. Fixed: Add Multicore dialog Cable Type field would allow direct input.
  5. Fixed: Add Multicore dialog Signal Type field would allow direct input.
  6. Fixed: Add Multicore dialog Number Base field now honors Disable Cable No Edit Mask setting.
  7. Fixed: Add Multicore dialog Cable Type field difficult to sort due to display of manufacturer name in field.
  8. Added Show Me button to the Assign Cables dialog when in edit mode to show the database entry.
  9. Added Show Me button to the Assign SysNames dialog when in edit mode to show the database entry.
  10. Fixed select multicore from Assign Cables dialog not populating the correct cable type.
  11. Fixed select multicore cable from Assign Cables dialog but then cancel dialog does not revert the incremented next number.
  12. Modified the Equipment List to allow delayed validation. Added Validate button to the menus.
  13. Added "Automatically validate equipment when I open the Equipment List grid" setting to the User Settings [Basic] form.
  14. Improved the time it takes to switch drawings.
  15. Fixed Autoblock not placing Planview From File blocks.
  16. Fixed Autoblock point selection not working.
  17. Fixed issue with Ctrl+X in a grid form did not Cut but rather closed the form. 
  18. Fixed issue with Aux Text now following a cable end point move.
  19. Fixed issue with moving a cable end point on the destination side and the source side would move as well to form a straight line.
  20. Added Elevation field to the Assign Splice dialog for consistency in the application.
  21. Fixed issue with the Assign Cable edit dialog not showing the QualifySourceLocation and the QualifiedDestLocation in the preview.


Build 1385 Not Released

  1. Fixed ProjectLocations collection not loading in the reporting engine.

Build 1384 Released 11/09/2016

  1. Optimised the Drawings database when using local sql to not store the drawing as a BLOB.
  2. Fixed issue with Aux Text UI causing a cast error on Cable Edit.

Build 1383 Not Released

Internal build for testing. Not Released

Build 1382 Released 10/24/2016

  1. Fixed XREF manager not allowing more than one xref.
  2. Fixed External File browser does not take you to the 2d_elevations folder.


Build 1381 Released 7/22/2016

  1. Added new commandline shortcut for UCS view. You can now enter ucs in the command to align the current view to the UCS.
  2. Modified file base projects to ignore the drawings database blob storage for better drawing deletion experience.
  3. Modified Script Editor/Runner form's Window on Top function to be false by default.
  4. Modified Drawing Cable Error Check to be modeless form. You can now have more than one Error check running.
  5. Modified Drawing SysName Error Check to be modeless form. You can now have more than one Error check running.
  6. Modified the Drawing SysName Error Check to ignore splice points.
  7. Fixed Exception when performing "Drawing Error Check" in a rack layout.
  8. Fixed issue with Available SysNames showing as Forgotten SysNames in the discrepancy report.
  9. Added Scan menu to Discrepancy Report grid.
  10. Modified all grids to clear saved filters on open.
  11. Fixed issue with Edit Block in Place not working with dropbox support paths.
  12. Added function to Signal Types grid > Show Signal Type Usage Report. Shows a list of all Signal Types and the Equipment definitions and I/O that use them.
  13. Added function to Connectors grid > Show Connector Usage Report. Shows a list of all Connectors and the Equipment definitions and I/O that use them.
  14. Modified Reports gallery to show larger previews.


Build 1380 Release included in 1381

  1. Fixed PenColor property not immediately invalidating and updating the entities in the drawing after edit. A regen was required to see the edits.
  2. Modified the community server access on the Equipment Library. It is completely disabled if the Application Setting [Attempt to connect to community server on port 1433]=false.
  3. Added commandline shortcut for the Assign Splice Point function. The default is now AssignSplice, sp. You can edit the shortcut to suit your needs from the Settings dialog.
  4. Fixed issue with find in Equipment Library not properly searching the EquipmentType field.
  5. Added filter pane to global Signal Types grid.
  6. Added filter pane to global Connectors grid.
  7. Modified Rack Builder tool add custom location tool to work with the locations lookup table.
  8. Fixed issue with Equipment Library User1-4 not populating the SysName assignment dialog on a mappable terminal.
  9. Fixed issue with SysName User1-4 not populating the AutoBlock function.
  10. Modified the Recover Cables function to honor changes in SignalType color.


Build 1379 Released 6/27/2016

  1. Fixed New Circuit Next through backbone exception when global equipment reference not found.
  2. Fixed mappable terminal SysName Assignment not utilizing the QualifiedLocation.
  3. Fixed placing a mappable terminal from the equipment library breaks any terminal from then until the drawing is restarted.
  4. Fixed security issue with Project Info form.
  5. Fixed Rename Drawing fails on some projects that are converted from v6, v7.
  6. Fixed update cable shows duplicate cable types in the dropdown.
  7. Added better Related Project support.
  8. Added new project setting to allow showing of duplicate numbers from related projects or not.
  9. Fixed pdf open error that occurred in specific instances.
  10. Some mods to the SDK.

Build 1378 intermediate build. Not Released to public.

Build 1377 intermediate build. Not Released to public.

Build 1376 Released 05/23/2016

  1. Added the ability for the Prewire Cable form to remember the last settings.
  2. Fixed issue with color picker not allowing [By Layer], [By Block], or [Foreground] selection.
  3. Fixed several small issues with the Assigned Splice dialog.
  4. Fixed Sort Cable Type in Assign Cable Number.
  5. Fixed Deleting a manually drawn cable with aux text does not delete the aux text.
  6. Fixed Drawing opens as READ-ONLY when manually refresh project explorer is on.
  7. Fixed Default location not used when "verbose sysname assignment" is off.
  8. Fixed Location in project equipment grid is not sorted on sublocation (rack).
  9. Fixed issue with New Circuit Preview exception with Named Equipment as the source.
  10. Fixed Refresh button doesn't refresh in Bill Of Materials.
  11. Added new user setting to preset the Bill of Materials snapshot name with the current date or whatever text you wish to use.


Build 1375 Released 04/28/2016

Reset Bill of Materials List button or checkbox
  1. Added a user drawing setting to display the OSnap toolbar in the top left corner of the screen when an action is started.
  2. Fixed exception when performing drawing error cable check.
  3. Modified the P-Touch! plugin to allow record selection in addition to filtering.
  4. Fixed issue in P-Touch! plugin where the Refresh button was not pulling new data.
  5. Fixed exception when adding default plan view block file with new project.
  6. Modified the search bar in the Equipment and Cables grid to have the Search button be the Accept key.
  7. Fixed [Reset all cables in drawing] doesn't reset aux text.
  8. Fixed Save button in Pinouts tool disables randomly.
  9. Fixed "Signal Type" Combobox in cable grid filled with Signal Type Description.
  10. Added Reset Bill of Materials List function.
  11. Fixed missing buttons on lower screen resolutions.
  12. Fixed Manufacturer name not filled in plan view files.
  13. Added filter option to the Planview tool panel.
  14. Fixed issue with [Clear Selection After Command Executes] and Ctrl+A.



Build 1374 Released 03/21/2016

  1. We have made significant changes to the cable autorouter.
  2. Fixed issue with terminals placed in a group from the Mappable Terminals section of the equipment library did not present the correct assignment dialog on double-click.
  3. Added two new settings in the Application Menu>Settings[Project][Locations] panel for Default Location and Default Elevation. These values now populate the SysName Assignment dialog on a new assignment.
  4. Fixed issue - Auto blocker doesn't block functions blocks when selected. This was a result of the tool using the last displayed settings. The tool now honors the DisplayAs setting on the Advanced tab.
  5. Fixed minor issue - Allow enter/return on New Sysname window.
  6. Fixed issue with ENT Draw Backbone when locations boundaries are not properly selected.
  7. Fixed issue with Planview Gallery Toolpanel not loading the project planview blocks in certain circumstances.


Build 1372 Released 02/16/2016

  1. Added continuous drop multicopy to Create Block from file merge operation.
  2. Fixed issue with the global equipment grid clearing the DisplayParams field on restart.
  3. Fixed issue with Cable Data Selector grid not selecting when the selection only contains a single record.
  4. Fixed issue with Cable Data Selector grid showing initial project data after switching projects in certain instances.
  5. Fixed issue with multi-core cable needed to be selected twice from the list on some systems.
  6. Fixed issue "Show Me" Button in Equipment List assigned cables sub grid doesn't work.
  7. Added Copy Port Data from Another Device function to the Equipment Library Edit menu.
  8. Fixed issue with Moving end of cable doesn't move Aux Text.
  9. Modified the move assigned cable point function to update attached linked pointers.



Build 1371

  1. Added global database not found fail to default default for a better startup experience when the global database cannot be found.
  2. Added LineType by SignalType.
  3. Fixed issue with Riser Diagram visualization tool not centering text properly in some instances.
  4. Fixed issue with Riser Diagram visualization tool causing exception with null values in some instances.
  5. Fixed issue with the Batch Plotter not printing the last selected record.


Build 1370 

  1. Fixed issue downloading certain entries from the community.
  2. Added Refresh button in Planview Tool Panel.
  3. Added Show Me button to the Equipment List Equipment Name field to take you directly to the Equipment Library entry for that Equipment.
  4. Fixed issue with distribution of the blank database.
  5. Added rename function to Global Pinouts Tool.
  6. Fixed issue with some Pinouts not deleting.
  7. Fixed issue with New Equipment form not accepting images.
  8. Fixed issue with New Manufacturer form not accepting images.
  9. Refresh Manufacturer List when adding new Manufacturer in New Equipment Form
  10. Modified Import Tool to be more responsive and release the UI during import.
  11. Modified the grid forms to better detect modified state and enable Save button when deleting or editing subgrid.


Build 1369 

  1. Fixed issue with 50 character location names not rippling.
  2. Fixed issue with find and replace not opening some drawings for search.
  3. Modified Equipment Name dropdown in Equipment List to sort.


Build 1368

  1. Fixed cables visualization to better handle collapsed multicore cable text.
  2. Modified the visualization settings smarttip to show how to use the User1-12 fields as text in the CableTextFormatString.
  3. Minor bug fixes.


Build 1367

There is a gap in the public build sequence due to internal testing of the following problem:

  1. We discovered a problem with WireCAD v8 that was causing a crash to the desktop on startup. It was maddening. At first we could not recreate the issue in the lab. Finally we came to understand the issue was a result of our new logging system not releasing its threads on shutdown. This only became a problem if you launched WireCAD then launched it again or double-clicking a file icon for a drawing. This would start the application then hand off to the running instance but not fully shut down after the hand off. Maddening. Anyway that's fixed.
  2. We modified the terminal placement function to honor the Repeat Cable button state. If the button is depressed then the drop terminal function will repeat until you click the Escape key.
  3. We modified the automatic updates function  to download faster.
  4. We modified the move cable end point function to reset the line type to By Layer. This will fix any cable that has been marked with the dashed linetype to indicate that it is lost from the Edit Block in Place function.