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1 WireCAD CMS Introduction & Concept

This section of the manual covers topics that will help you better understand the work flow,
background and idea behind WireCAD with CMS Tools.

 

Topic Sub Sections

Introduction
WireCAD Concept
CMS Tools Concept

4
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1.1 New In V7 With CMS Tools

WireCAD v7 is an update to our highly popular software WireCAD V6.
WireCAD v7 is a design and documentation tool that allows you to create Functional Block Diagrams,
manage Cables, print reports and labels as well as installation reports and bills of materials. 

WireCAD v7 introduces many new features including an all new Cable Management System,
Backbone tools, Circuit tools, Find and Replace tools and much more. 

Welcome to WireCAD v7 with CMS tools.
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1.2 Conventions

The following are conventions used throughout this manual:

A Link  to another topic

Topic Headings

Topic Subheadings

Text used to describe a button: [build]

Text used to describe a menu tree: 
File>New

Text used to describe labels:
Source Body Color

Text used to describe field names:
CktNo, CktSrc, CktDst

78
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1.3 CMS Tools Concept

WireCAD v7 with CMS tools has introduced the ability to work in a different manner from previous
versions of WireCAD.

WireCAD v7 CMS allows you to start by entering your SysNames and Cable Numbers into the
Database first, create Backbones and Circuits and then generate a Functional Block Diagram based
on the information set in the Database. 
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2 CMS Basics

The following is a list of How To's for multiple functions in WireCAD v7 including creating Cable Types,
New Equipment definitions, Projects and more.

      

Topic Sub Sections

Creating a New SQL Project
Creating a New Cable Type
How To Create a Backbones
Using The New Circuit Tool
How to Output a Circuit to CAD
How to Output Many Circuits to CAD
Using The Backbone Grid
WireCAD Glossary

59
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29

41

43

9
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2.1 Backbones

Backbones connect one panel to another via a series of cables or cores. Backbones are represented
in the cables database by a collection of cables.
Each cable in the backbone has the same Cable Number Prefix. When you create a new Backbone
you are creating a collection of cables based on the selected Cable Type. If you are documenting
fibers think one fiber equals one core/conductor/cable. backbone cables are flagged with the boolean
value isBackbone = true. Doing so distinguishes a cable as being part of a backbone structure.

Open the Backbones grid by double-clicking the icon in the Project Explorer [Project Databases]
[Backbones]

Command Line Shortcut: bbg

Before You Start

Before creating a Backbone, you will need to make sure you have created your Equipment  and
Cable Types  associated with this project. 

2.1.1 The Backbone Grid

The Backbone Grid will show you a list of all the backbone segments in your project and allow you to
modify their status or delete the entire backbone cable group at once. The status will refer to whether
the backbone is in use, proposed, dead ETC. New backbone status can be created in the project
settings menu. There are 3 default status available; in use, proposed & dead. 

The Backbone Grid is easier to use than the Cables Database if you are looking for basic information
about a backbone such as number or origin and destination information or if you are simply wanting to
change the status of the backbone. 

To access The Backbone Grid, type BBG in the command line.

With The Backbones Grid open, a list of all created backbones and cores will show along numerous
columns of information about each backbone core. 

53
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Menu Commands

Edit

Copy Selection Down Create a selection vertically in the grid and click 
Edit>Copy Selection Down or Ctrl+D and the

topmost cell's data will be copied to all selected
cells below.

Delete Selected Backbone This function will delete ALL cables associated
with the selected Backbone. If you are just trying
to delete a single cable you should do that from
the Cables database.

Refresh Query the database and reload the data into the
grid.

Tools
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Attach Document Useful for storing field survey reports and other
documents associated with this backbone. You
can attach as many documents as you need.
The documents are stored in the database. You
can click on the link provided in the grid to
launch the document into the system document
reader for that file extension (MIME Type).

Rename Source Connecotor(s) Renames the Source Connector (SrcConn) field
and any jumpers or horizontal cables attached
to this backbone.

Rename Destination Connector(s) Renames the Destination Connector
(DestConn) field and any jumpers or horizontal
cables attached to this backbone.

Rename FiberMode Renames the Fiber Mode (FiberMode) field and
any jumpers or horizontal cables attached to
this backbone.
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While a number of fields are shown in The Backbone grid, only the Status field & Owner field are
modifiable.  All other fields are simply shown for reference.

Note: When marking a backbone as dead you must make sure that this cable is no longer used in an
active circuit. If WireCAD detects that this backbone is still in use, you will be presented with a warning
message stating "Cannot mark a cable as DEAD that is part of an existing Circuit. Please remove the
Cable from the Circuit, then change its status. " 

Note: You will also receive a warning message if you try to delete a cable that is part of an existing
circuit. You must remove the cable/backbone from the circuit before deleting. If you wish to delete
individual cores, you can do so from inside the cables database however this information will not
persist back into the CAD drawings. 

Note: When deleting a backbone in The Backbone Grid, the entire group of cables will be deleted
even if you have only selected a single core. Make sure that you want to delete the entire backbone
segment before selecting delete. 

Note: Deleting backbones in The Backbone grid, does not adjust number sequence. If you wish to
reuse deleted backbone numbers, you will need to manually access the Next Numbers Grid and
change the next available number to the one you would like to use. Example, you have created
backbones 1001,1002,1003 & 1004. The next number in the sequence would be 1005. If you then
delete 1002,1003 &1004, the Add Backbone Segment Tool will label the next backbone as 1005. To
reuse 1002, 1003 & 1004, you need to manually select these as next in the sequence by doing so in
the Next Numbers  Grid. 64
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2.1.2 How To Create a New Backbone

Explanation

The following procedure outlines the creation of backbones in the CMS module. Backbones are multi-
core cables in the cables database that interconnect two (or more) patch panels. 

Note: While this tool is open in your window other WireCAD users will be locked out of the Cables
table of the Project database.

1. Make sure you have used the appropriate steps to create your Equipment , Customize
your I/O and create your Cable Types .

2. Access your Equipment Library. 

54
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3.Find the equipment you would like
to use and click [Add to Project
Database Only]. 

Note: You can add as many pieces of
equipment you as you would like at
this time however you will need to
have at least the 2 definitions that the
Backbone are linked to. 

4.  A new SysName window will pop
up asking you to verify information
about this equipment. The next
available SysName will automatically
populate. 

5. Enter in your location for this
equipment. Example: Admin
Basement Telephone Room.

6. If there are multiple pieces of the
same equipment in this location, you
can select the [Add Many] to create

multiple pieces of equipment at the
same time.

 Note: WireCAD will automatically
SysName each piece of equipment
using the next available number in
the sequence.
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7. Once you have added your
equipment into the Project Database,
close your Equipment Library.

8. Enter ABS into the command line
and press enter or click on the [Add
Backbone] button on the homepage.

Alternately open the Backbones Grid
then click File>New

9. The Add Backbone Segment
window should now be open.

10.  First select if you would like to
create a New Backbone or Use Existing
Available. 

   

11.  On the From side, select your
equipment from the Patch Panel ID
field. 

Note: You can filter your results using
the Location Filter field. This allows
you to select only equipment listed in
a location that was specified during
SysName Assignment.
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12. On the To side, select your
equipment from the Patch Panel ID
field. Again, you can filter your results
using the Location Filter Field.  

13. On both sides, ports that are
available will be shown in white while
ports that are currently being used
will show as pink. 

 

14. From the Cable Type field,
select the Cable Type you would like
to use as your backbone. 

Note: If you have not already created
a Cable Type for your backbone, you
can do so by clicking the [+] sign and

following the instructions here .

15. Select the ports you would like to
use on the From side, then select a
starting port on the To side.
 

Note: You will see that WireCAD will
automatically draw a backbone
based on your port selection and
Cable Strand count. NOTE: See *
Below!

48
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16. Click [Apply]. WireCAD will create

this backbone and then revert to an
empty page ready for another
backbone assignment.
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2.1.3 Backbone Visualization Settings

Before You Start:

In order to preview Backbones you will first need to Add Backbones

These settings determine the display of the Backbones Visualize  tool.

Layered Digraph Mode Data Source

Show All Shows all backbones in the database in the Visualize tool

Current Record Allows selection of only those backbones that touch the selected record. 

Search Depth How many branches deep are we going to search. 

13
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Search Width How many backbones per branch.

Appearance

Location Marker
Spacing

Location Marker
Text Height

Location Marker
Color

Junction Dot
Radius

Vertical
Backbone
Spacing(DU)
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Center Label
Format

String used to create the center label. Can make use of the following variables:
{0} = Backbone Number
{1} = Total Count
{2} = Total Available Count
{3} = Total Dead Count
{4} = Single Mode Fiber Count
{5} = Available Single Mode Fiber Count
{6} = Dead Single Mode Fiber Count
{7} = Multimode Fiber Count
{8} = Available Multimode Fiber Count
{9} = Dead Multimode Fiber Count

Example:
assume that our backbone number is 1001 with 12 single mode fibers of which 1
is dead and four are in use.

String:
B{0}-SM COUNT:{4} Avail:{5} Dead:{6}

Output:
B1001-SM COUNT:12 Avail:8 Dead:1

String:
B{0}

Output:
B1001

Center Label
Offset

Offset from center in DU

Show SysNames Shows the SysName labels

Ignore Same
Locations

Hides backbones that originate and terminate in the same location

SysName
Rotation Angle

Sets the rotation angle of the SysName label if shown

SysName Text
Height (100th
DU)

Sets the height of the SysName text if shown

SysName Text
Offset

Offset from the endpoint of the backbone

Riser Diagram Mode
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Campus and
Building

The Campus and Building for which to build the riser diagram

Layout 
Max Columns, 
Column Spacing,
Minimum Row
Height

Determine the layout of the panels in the diagram

Body Color, Body
Width,
Descriptor
Locations

Determines the appearance of the body of the panels in the diagram
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Show Terminals
if Backbone
Leaves the
Building,
Terminal Offset

If the other end of the Backbone is not in the selected building a terminal will be
placed and a backbone drawn to it. The terminal's position from the port on the
panel is determined by the Terminal Offset property.

Apply Jumps

Avoid Other
Cables

Instructs the cable autorouter to attempt to avoid other cables.

Show
Unresolved
Backbones

If the Backbone cannot be placed in the drawing a list is generated. Enabling this
setting shows the list as the function completes.

Title and Comment Block

Show Title Sets the visibility of the title/comment block

Title Position
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Show Time
Stamp

Title Text Height
(100th DU)

Title Offset

Title

Misc.

Backbone Color
by Signal Type

Pulls the backbone color from the global Signal Types database.

Show Directional
Coloring

Shows green dots for the source end of the backbone and red dots for the
destination end if shown.

Backbone Color Sets all backbones to the color defined.

[Reset Default] Button to reset the settings to the defaults.
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2.1.4 Backbone Visualization Layered Digraph Ouput

The Backbone Visualization tool creates a layered digraph (ladder diagram) showing the backbones
horizontally and the locations in which they originate and terminate vertically.

The backbones displayed, and many of the display parameters can be set using the [Visualization
Settings] tab.

2.1.5 Backbone Preview Export

Exporting the CAD preview of the Backbones Visualization tool is as easy as clicking the [Export]
button. 

Note: The current preview will be exported based on the Export Settings found in the Project>Settings
[Project][Export Settings]  tool.

18
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2.2 Circuits

A circuit in WireCAD is defined as a collection of cables. Each circuit may have a Name, Description,
and other meta data. A circuit also has a strand count to indicate the number of connections made
from the originating device on through to the terminating device. Circuits have a one-to-many
relationship with the cables in the Cables database. Each circuit may have many cables but a cable
can belong to only one circuit.



CMS Basics 26

Holbrook Enterprises, Inc. 2000-2014 - dba WireCAD

2.2.1 Circuits Grid

The Circuits Grid presents the overall circuit data in list form with the child cable data attached for
view.

Open the Circuits grid by double-clicking the icon in the Project Explorer [Project Databases][Circuits]
Command Line Shortcut: cmscg

Tools

Attach Document Useful for storing field survey reports and other
documents associated with this circuit. You can
attach as many documents as you need. The
documents are stored in the database. You can
click on the link provided in the grid to launch the
document into the system document reader for
that file extension (MIME Type).

Rename Circuit Renames a circuit and all of its cables

Edit Circuit Opens the selected circuit in the editor.

Combine Circuit See the topic Combining Circuits .

Strand Count and Ordinal Explanation

45
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WireCAD uses the strand and ordinal to know the exact position of a cable in a circuit. Strand 0 will
always be the topmost cable in the circuit with Strand n being the bottommost cable in a circuit.
Ordinal 0 will be the leftmost set of jumpers in the circuit with Ordinal n being the rightmost set of
jumpers in the circuit.

2.2.2 New Circuit Tool

The New Circuit tool is used to connect Field End & Head End Equipment together by adding jumpers
between existing Backbones. Each circuit is comprised of descriptive data, such as Name,
Customer, IT System or Description, source and destination equipment (SysNames); as well as
a collection of cables in the Cable database. You simply select the ports that you wish to jumper from/
to and add the jumpers/back bone segments to the Proposed Cables list. A Path Finder tool helps

you search out possible routes. A [Preview] window presents the functional block view of the

Proposed Cables. Once you are happy with the circuit, simply click [Build] and all Proposed cables

will be added and associated to the named circuit.

To open the New Circuit tool open the Circuits grid and click File>New
Command line shortcut: nc
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Note: While this tool is open in your window other WireCAD users will be locked out of the Cables
table of the Project database.
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2.2.2.1 Create New Circuit

Before you Start

The use of this tool assumes the following:
That you have added Backbones to the project.

That you have added the necessary Cable Types to the global Cable Types Database.

That you have an idea of what you want to connect together and that you know the first bit of
infrastructure to which you will attach.
That you have created your Customer Furnished Equipment(CFE) in the Equipment Library for the
originating and final destination equipment devices and/or that SysNames have been created for
each individual piece of equipment to which you will attach.
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How to create a New Circuit

 
1. Verify that you have created all your Equipment and Cable Types needed for this circuit.

2.  From the Circuits Grid click [File>New] to launch the New Circuit tool.

3. Verify that your Circuit 
Number/Name is correct and
that it is not duplicating an
existing entry.

4. Enter your IT System and
Customer info.

Note: IT System is required.
You will not be able to [Build]
without an entry.

5. Select your Origin(named
equipment) from the drop down
menu on the left. Alternately,
select the Origin CFE
(Customer Furnished
Equipment) and fill in the detail
data in the dropdown.
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6. Select your Final
Destination System (named
equipment) from the drop down
menu on the right. Alternately,
select the Final Destination
CFE(Customer Furnished
Equipment) and fill in the detail
data in the dropdown.

7. Select your Jumper To
Equipment. This will be the first
Patch Panel to which your 
Origin system will connect.

8. Select the ports from your 
Origin equipment and the
Ports on your Jumper To
equipment. You will see that
WireCAD creates a preview
jumper between the 2 for you to
verify correct connections. 

Note: You can only create a
jumper set that matches the 
Cable Strand Count set in
step 3.
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9. Click [Add Jumper].

Note: If you have connector
types that WireCAD believes do
not match, you will be presented
with a window stating
"Connector String Mismatch". If
you want to turn this message
off, you can do so in the 
Project>Settings>UserCMS.

10. Click the [Next>] button. 

11. Verify that a Backbone
exists between the correct
Patch Panels. 

Note: WireCAD will
automatically populate an
available route between Patch
Panels using existing Backbone
structures. 

12. Click [Add Backbone
Segment].

13. Verify the correct cables
have been added to the 
Proposed Cables In Circuit
list. Then click [Next].

14. From this point, you can
create additional Jumper To
equipment, and place jumpers
and backbone segments using
steps 5-11. 
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15. When you are ready to
complete this circuit, select the 
[Last] button. The Final

Destination equipment will
populate the Jumper To the list
for selection of the final set of
jumpers.

16. Select your last set of ports
on both sides and click [Add
Jumper].

17. If you would like to see a 
Functional Block Diagram
preview of this circuit, click the
[Preview] tab.

Note: Preview will be generated
with Project Settings.

 .

18. Click the [Build] button to

finalize this circuit.

Note: If you have not filled in the
required fields or if the circuit
Number/Name is not unique
the [Build] process will not

continue. Look for the  icon
to indicate fields that require
attention
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2.2.2.2 Path Finder Tab

Explanation:

The Path Finder tool can be used to find available ports and backbone segments from a source to a
destination. The Path Finder tool will search the backbone structure for backbones that can be used to
get from the source panel to the destination panel, then once a route is established the route
candidate is checked for available port count. If all criteria are met the route is returned.  If no routes
can be established you will be notified.

2 possible routes returned each with 6 segments. We will use Route 0.

After adding Route 0
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Path Finder 

From Pre populated by your selection with the last
jumper added in the Build tab.

Last Existing Select the last existing piece of infrastructure
that we will search for.

[Find] Start the search.

[Cancel] Cancel the search.

Use Route Number Once routes are returned for selection this
dropdown will be populated with the available
routes.

[Add Selected Route to Circuit] Once you have selected a route this button will
enable for you to add the route to the Proposed
Cables to Add to Circuit list on the[Build] tab.

Search Depth How deep to search more will take longer but
find more routes

Search Width Maximum candidate routes to search

Show All Show all routes found and populated with
jumpers

Show Backbones Only (for research) Show only the backbones without jumpers.
Useful for research.

Show Only First Path Found Stop searching when the first route is resolved.

Show Only Least Link Path Search all then prune the list to the route with
the shortest number of segments.

Found Paths Grid

Cable No Prefix, Cable No, SRC Sys, Dest
Sys, Src Pin, Dest Pin, Src Loc, Dest Loc

Fields pulled from the Cables database or
populated by jumpers that would need to be
created to complete this circuit along this route.

Ckt Strand Number For more information about circuit strand and
ordinal see here .

Ckt Ordinal
26
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Route Number The router may find multiple paths or none. If
paths are found they will be returned with a route
number. You may then select the which, if any,
route to add to the circuit.

Made It Indicates that the route made it to the
destination. All routes shown will show Made It
on the last segment.

2.2.3 Circuits Preview Settings

Appearance

Source, Middle and Destination Shape Choose one of the 16 stock
shapes

Source, Middle and Destination shape Width in (100th DU) How wide is it

Source, Middle and Destination shape Color Set the color of the shape
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Source, Middle and Destination shape Descriptor Locations

Drag the descriptor to the location map or to the Hidden Items
list to hide.

Backbone Color

Sets the colorJumper Color

Horizontal Cable Color

Merge and Center Text in Body

Text Height controls the height of all text in the
visualization.

Layout

Max Columns The maximum number of blocks
placed before a new row is started
below.

Column Spacing The distance between blocks

Row Spacing The Distance between rows

Title and Comment Block

Show Title

Title Position

Show Time Stamp
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Title Text Height (100th DU)

Title Offset

Title You can type whatever you want in
this field. In addition the following
variables are available:
{0} = Circuit Number
{1} = It System

Misc.

Show Attenuation Labels Show field survey labels in the
CAD preview

Show Jumper Length Labels

Show Backbone Length Labels

Show Jumper Numbers

Show Backbone Numbers

Show Length
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2.2.4 Outputting Circuits to CAD

Once a circuit has been defined you can create CAD views of single and multiple circuits. The tools to
do this are contained in the Circuits Grid which you can access from the command line shortcut
CMSCG or by selecting the [CAD Preview/Circuits Grid] on the home page.

Before accessing the Circuits Grid, please make sure to setup your export preferences in the
settings menu. Please refer here  for more information on the settings menu. 

You can also batch output the selected records by clicking Tools>Output Selected. 

Note: All export is governed by settings in the Project>Settings[Project][Export Settings] tool.

Export Output to file based on the Export Settings found
in Project>Settings [Project][Export Settings]

Copy to Clipboard Copies the preview to the clipboard so it can be
pasted into another drawing.

66
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2.2.5 How to Output a Circuit to CAD

This step by step will guide you on exporting a circuit. 

1. Open the Circuit Grid by entering
CMSCG in the command line prompt.

The Circuit Grid Window will open. 

2. Select the Circuit Number you
would like to Export. 
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3. Select the [Preview] Tab.

4. Verify the circuit is the one you
would like use and click [Export].

5. A Windows explorer window will
come up. Enter where you would like
to export to, what you would like this
file to be called and what file type
you would like to export as.

Note: All of these settings can be
automated in the Settings Menu. 

6. Click [Save]. Your exported file will now be created and placed in the location you have specified

of the file type you specified in the Save As Dialog filter. 
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2.2.6 How to Output Many Circuits to CAD

This Step by step will guide you on exporting multiple circuits. 

Note: this is different from the command Tools>Output All Selected Circuits

1. Open the Circuit Grid by entering CMSCG in

the command line prompt. The  Circuit Grid
Window will open. 

2. Select the Circuit Numbers you would like to
Export. 

Note: You can select multiple circuits by
dragging down with your mouse clicked, by
holding [Shift] and selecting a set or by holding

down [CTRL] and selecting multiple records

individually. 

3. Select the [Preview] Tab.
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4. Verify the circuits shown are the ones you
would like use and click [Export].

5. A Windows explorer window will come up.
Enter where you would like to export to, what
you would like this file to be called and what file
type you would like to export as. 

Note: All of these settings can be automated in
the Settings Menu. 

6. Click [Save]. Your exported file will now be

created and placed in the location you have
specified. 
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2.2.7 Combining Circuits

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have
the same Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted
will be discarded.

This Circuit The Circuit Name/Number of the circuit that will be appended or inserted
into another circuit. This circuit Name/Number will be discarded if
successfully appended or inserted.

Appends To The Circuit Name/Number of the circuit that will be appended to.

Inserts Into The Circuit Name/Number of the circuit that will be inserted into

Before Before this SysName

After After this SysName

Insert Jumpers if
Necessary

It is possible to create collections of cables in a circuit that do not
interconnect. If you do not select this option you will create collection of
cables that do not interconnect.
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Preview

[Commit] Do it. 

[Cancel] Dump out without any changes.
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2.3 Cable Types

In order to create a Backbone segment in WireCAD, you will need to create a Cable Type with the
correct amount of Cores.

This will guide you through creating a new Cable Type. 
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2.3.1 How to Create a New Cable Type

Wiki Links:

Cable Management Specific Features and Functions
http://wirecad.com/wiki/index.php?
title=Cable_Management_System_Specific_features_and_functions

1. In your Project Explorer,
double click the Cable Types
Database.

http://wirecad.com/wiki/index.php?title=Cable_Management_System_Specific_features_and_functions
http://wirecad.com/wiki/index.php?title=Cable_Management_System_Specific_features_and_functions
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2. Click the New Icon. (This

is the blank paper icon next
to the diskette save on the
top left of your screen.)

3. A new window will pop up
asking for information on
this cable type. 

4. Fill in all information about
this cable including 
Manufacturer, Cable Type
or P/N & Description. No
other fields are required but
are available to use at your
discretion.
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5. If this cable is a multi core
cable, you will need to check
the Is Multi Core box and
select how many cores are
in this cable.

6. Select the [Default
Core\Fiber Mode]. 

Note: To label specific cores
as SM or MM, see step 8.

7. Click the [Save] icon

(diskette). 

If you need to define SM and
MM, please follow steps 8. 
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8. From your main WireCAD
window, select your Cable
Types database from the 
global database field. 

9. Using the filter icon on the
Cable Type column header, 
select your cable from the
drop down menu. 

10. Use the [+] button to

expand and show all cores.
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11. Double click in the Fiber
Mode field and enter SM or

MM for this strand. 

Note: If a series of cores are
the same Fiber Mode Type,
you can highlight the top
one, drag down, and press
CTRL+D to automatically
populate additional fields.

12. Click the [Save] button

(diskette) to save changes.
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2.4 Equipment

WireCAD v7 for ENTerprise has been pre-populated with devices specific to fiber operations.

If you are unable to find your specific equipment, you will need to create a new Equipment Definition.

This section will guide you through creating a new Equipment Definition, adding & deleting I/O ports
and modifying display preferences. 
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2.4.1 How to Create a New Equipment Definition

Wiki Links:

How To Access Your Equipment Library
http://wirecad.com/wiki/index.php?title=Accessing_Equipment_Library

How To Add a New Manufacturer To Library
http://wirecad.com/wiki/index.php?title=How_To_Add_A_New_Manufacturer_To_Library

How To Create A New Equipment Definition
http://wirecad.com/wiki/index.php?title=HOWTO:New_Equipment_Definition

How To Customize Your Equipment I/O
http://wirecad.com/wiki/index.php?title=Customizing_Equipment_I/O

1. Click Advanced Tools>Equipment Library
OR Database>Equipment Library OR
Command Line shortcut LE.

2. Use the search/find bar to first determine if
your equipment is currently in the library.

http://wirecad.com/wiki/index.php?title=Accessing_Equipment_Library
http://wirecad.com/wiki/index.php?title=How_To_Add_A_New_Manufacturer_To_Library
http://wirecad.com/wiki/index.php?title=HOWTO:New_Equipment_Definition
http://wirecad.com/wiki/index.php?title=Customizing_Equipment_I/O
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3. On the right hand side of the screen, you will
see multiple buttons including [Add
Manufacturer To Library] & [Add Equipment To
Library]. (If your manufacturer is not listed,

please see the section titled Add Manufacturer
to Library.)

4. Click [Add Equipment to Library].

5. In the dialog window, start by selecting the
Manufacturer field and select who makes your
equipment
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6. Enter in the Model/Equipment Name of your
Equipment.

7. In the Description field, enter something that
will describe this type of equipment. Example:
Laptop, Desktop Computer, Router,  LCD
Display etc.

8. The SysName Prefix field is how the
SysName will be shown after a SysName
assignment. Example: Field Laptop = FLD LPT,
Desktop Router = RTR, ect.

9. Click [Next]. 
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10. The wizard will advance to the next page
asking you to add a Front Panel File, Image,
Category & Synonym. None of these fields are
required; however, if you plan to use the Rack
Builder tool it is advised that you select a Front
Panel file.

11. Click [Finish]. 

12. You will now be taken back to the 
Equipment Library with your new equipment in
the grid. 

13. Select the I/O Tab.
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14. In the middle of the screen, Click The [Add
Ports] button.

15. Enter in all port information including Name,
Connector Type, Signal Type, Pin Style, etc.
Do this for all ports on this device. 

Note: You can add multiples of the same port type by clicking the Add Many checkbox and entering

in how many of this specific port you would like. WireCAD will append a port number to the string in
the Name field. Example: with the Inputs radio button selected, enter the value PORT- into the
Name field, check the Add Multiples and set the Starting Number to 1 and the Count to 32. Click

[Apply] and 32 records will be created in the Inputs list. The name field will be populated with the
values PORT-01 through PORT-32.

16. When you are finished, click [Apply] to add

the ports and leave this dialog open or click [Add
Ports and Close] to add the ports and close this

dialog.
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2.5 Projects

This section will guide you on how to create a New Project using a SQL Server Database.

You will need to have your network administrator or IT department set up a SQL Database and create
user access for all WireCAD users who will have access to this Database.

2.5.1 How to Create a New SQL Project

Wiki Links:
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How To Create a New Project
http://wirecad.com/wiki/index.php?title=HOWTO:New_Project

How To Move A Project To A Different SQL Server
http://wirecad.com/wiki/index.php?title=HOWTO:MoveProjectServer

Create a New Project

1. With WireCAD open, click 
Project>New Project.

2. A new window will open saying
“Welcome to the New Project
Wizard”. Click [Next].

http://wirecad.com/wiki/index.php?title=HOWTO:New_Project
http://wirecad.com/wiki/index.php?title=HOWTO:MoveProjectServer
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3. On the next page, select Use
Database Server (SQL Server) and

click [Next].

4. Enter a Project Name,
Description and select a Project
Files Path. This is where your
project files will be saved. This is
different than your Database files
and will not be located in the
same directory. It should be on a
network share visible to other
users of the project. Click [Next].
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5. Enter in your SQL Server
database information and click
[Next]. (

Note: Please contact your IT
department if you are unsure of
any information required on this
page.)

6. Verify that all information looks
correct and click [Next].
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7. Wait for WireCAD to build your
project and then click [Finish]. You

are now ready to start working in
your new SQL Project.
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2.6 Next Numbers Grid

The Next Numbers Grid will show you the next available Cable number based on your Cable number
format. To access the Next Numbers Tool, type NN in the command line prompt. 

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As
you progress through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number
box and fill in the correct number. Be sure that you are not entering a number that is already in use. 

Note: Yours will look different as the Next Numbers grid will automatically create entries for each new
sequence used by the application.
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3 Settings and Options

To access the settings menu, click Project>Settings. Then select one of the three default sets of
settings Application, User or Project by clicking on the down arrow.

Note: Third party plugins may register their own settings categories and panels. Shown are the stock
settings.

 

Topic Sub Sections

User Settings
Project Settings

67

69
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3.1 User Settings

These are the additional user settings that pertain specifically to the CMS module.

Project>Settings[User][CMS User]

Use Stock WireCAD Startup Page

Note: Doing this will remove all buttons and
functionality of the startup page requiring you
to use the command line shortcuts. This will change your Startup page from the CMS

specific page to the default WireCAD page. 

Default New Circuit Strand Count

When creating a new circuit, a default strand
count for jumpers is created. This will change that
strand count to a different value. 
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Warn Of Connector String Mismatch
Having this box checked will allow a warning
message to display anytime WireCAD detects
that 2 ports being connected have a different
connector type. 
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3.2 Project Settings

These are the additional project settings that pertain specifically to the CMS module.

Note: You will need to have an open project in order to access these settings. 

Note: These settings are project specific and will need to be created for each new project. 

Project>Settings[User][CMS User]

Default New Backbone Status
When creating a backbone, you have the ability to
mark a "status" on that backbone such as "In
Use", "Proposed" ETC. Using the [+] button, you
can create new status items. Selecting a status
will cause that to become the default for all
backbones in this project. 

Default New Circuit Status
Just like above, when creating a Circuit, you have
the ability to mark a status on that circuit. Again,
using the [+] button, you can create a new status. 
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Backbone Number Format The variable {0} contains the next number in the

Next Numbers grid for Backbones.
Define the string format of the next Backbone
number. 

Circuit Number Format The variable {0} contains the next number in the

Next Numbers grid for Circuits.
Define the string format of the next Circuit
number. 

Jumper Number Format The variable {0} contains the Circuit base

number.
The variable {1} contains the Strand Number of

the circuit for this jumper
The variable {2} contains the Ordinal Number of

the circuit for this jumper.
Define the string format of the next Jumper
number. 
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3.3 Output Settings

Project>Settings[Project][Export Settings]

Use Template Path to to a template drawing that the output will be exported into. Your
template drawings can contain any page borders or layouts and
settings that you wish.

Always Ask for Filename
and Path

You are involved in the filename selection and path

Circuit File Name Format Sets the file name format for Circuit output.
{0} = Circuit Name

Backbone File Name
Format

Sets the file name format for Backbone output.
{0} = Backbone Number

File Format Presets the output format.

Path Where do we output.

Create Folders for Each IT
System

Create a new folder for each IT System and output the preview to that
folder.
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Automatically Overwrite
Files of Same Name

Self-explanatory

Append Date Stamp to File
Name

Circuit Post Process
Script

Path to a c# file which will be run post export but pre write-to-disk. See
the Post Process Scripts  topic for more information.

Backbone Post Process
Script

3.4 Post Process Scripting

Post Process Scripting of the output of the Visualizers in WireCAD allow you to customize the final
appearance of the created document.

What follows are two example scripts, one for the Circuit output and the other for the Backbone
output. The process is the same for both. Only the method signature is changed.

NOTE: While these scripts can be edited using the Plugins>Script Editor Runner... tool they cannot be
executed (run) by it.

These scripts can be found in c:\users\public\wirecad\wirecad7\scripts\

Circuits Export Script Example

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using System.IO;

using WireCAD;

using WireCAD.Interfaces;

using VectorDraw.Professional.vdObjects;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdPrimaries;

using VectorDraw.Professional.vdCollections;

using WireCAD.ProjectFile.DAL;

using VectorDraw.Geometry;

/// <summary>

/// Circuits Export Post Process Script to fill titleblocks

/// </summary>

public class TitleBlockFiller

{

public static void Run(Workspace ws, Circuits c, vdDocument doc)

{

72
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string drawingName = Path.GetFileName(doc.FileName);

//change this next line to be your titleblock name

string BlockNameToUpdate = "ansi";

//loop through the layouts and search for our insert to update

vdLayout layOut = doc.LayOuts.FindName("ANSI_B");

foreach (vdFigure figure in layOut.Entities)

{

if(figure is vdViewport)

{

vdViewport vp = figure as vdViewport;

vp.ZoomExtents();

vp.Update();

}

if (figure is vdInsert)

{

//cast our base figure into an insert object so we can access its

properties

vdInsert insert = (vdInsert) figure;

//now we will test to see if the insert name is one that 

//we know to be a titleblock

//Modify this to meet your needs

if (insert.Block.Name.ToLower().Contains(BlockNameToUpdate))

{

//need to fix it.

//this next bit makes it insert get the latest version from

the blocks table

insert.Update();

insert.Invalidate();

//we got one so let's set the attributes

//we will use the safeSetAttribute function so that if the

attribute doesn't exist it won't 

//fail

//Modify this to meet your needs

                           

ws.Utilities.SafeSetAttributeValue(insert, "SHEET", layOut.

Name);

ws.Utilities.SafeSetAttributeValue(insert, "Drawing_Name",

Path.GetFileNameWithoutExtension(drawingName));

ws.Utilities.SafeSetAttributeValue(insert, "DWG_Number", c.

CktNO);

ws.Utilities.SafeSetAttributeValue(insert, "COMPANY", "Slate

Gravel Co");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS",

"Number 1 Quary Way");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS2",

"Bedrock - The World");

ws.Utilities.SafeSetAttributeValue(insert, "DATE", DateTime.

Now.ToShortDateString());

ws.Utilities.SafeSetAttributeValue(insert, "Scale", "NTS");

insert.Update();

insert.Invalidate();

doc.Redraw(true);

}

}
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}

vdText t = new vdText(doc);

t.TextString = string.Format("CKT - {0}\n{1}",c.CktNO, c.CktDescription);

t.HorJustify = VectorDraw.Professional.Constants.VdConstHorJust.VdTextHorRight;

Box bb = layOut.Entities.GetBoundingBox(true,true);

t.Height = .25d;

t.InsertionPoint = new gPoint(bb.Right-3,bb.Top-2);

layOut.Entities.AddItem(t);

doc.ActiveLayOut = layOut;

           

}

}

Backbones Export Script Example

The only difference in the two examples is the method signature. Use the code above replacing:
public static void Run(Workspace ws, Circuits c, vdDocument doc)

With:
public static void Run(Workspace ws, CMSSettings settings, vdDocument doc)

As such:

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using System.IO;

using WireCAD;

using WireCAD.Interfaces;

using VectorDraw.Professional.vdObjects;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdPrimaries;

using VectorDraw.Professional.vdCollections;

using WireCAD.ProjectFile.DAL;

using VectorDraw.Geometry;

/// <summary>

/// BB Post Process Script to

/// Fill titleblocks

/// </summary>

public class TitleBlockFiller

{

public static void Run(Workspace ws, string[] exportInfo, vdDocument doc)

{

MessageBox.Show(string.Format("{0}-{1}-{2}",exportInfo));

string drawingName = Path.GetFileName(doc.FileName);

//change this next line to be your titleblock name

string BlockNameToUpdate = "ansi";

//loop through the layouts and search for our insert to update

vdLayout layOut = doc.LayOuts.FindName("ANSI_B");

foreach (vdFigure figure in layOut.Entities)

{
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if(figure is vdViewport)

{

vdViewport vp = figure as vdViewport;

vp.ZoomExtents();

vp.Update();

}

if (figure is vdInsert)

{

//cast our base figure into an insert object so we can access its

properties

vdInsert insert = (vdInsert) figure;

//now we will test to see if the insert name is one that 

//we know to be a titleblock

//Modify this to meet your needs

if (insert.Block.Name.ToLower().Contains(BlockNameToUpdate))

{

//need to fix it.

//this next bit makes it insert get the latest version from

the blocks table

insert.Update();

insert.Invalidate();

//we got one so let's set the attributes

//we will use the safeSetAttribute function so that if the

attribute doesn't exist it won't 

//fail

//Modify this to meet your needs

                           

ws.Utilities.SafeSetAttributeValue(insert, "SHEET", layOut.

Name);

ws.Utilities.SafeSetAttributeValue(insert, "Drawing_Name",

Path.GetFileNameWithoutExtension(drawingName));

ws.Utilities.SafeSetAttributeValue(insert, "DWG_Number",

exportInfo[1] + "-" + exportInfo[2]);

ws.Utilities.SafeSetAttributeValue(insert, "COMPANY", "Slate

Gravel Co");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS",

"Number 1 Quary Way");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS2",

"Bedrock - The World");

ws.Utilities.SafeSetAttributeValue(insert, "DATE", DateTime.

Now.ToShortDateString());

ws.Utilities.SafeSetAttributeValue(insert, "Scale", "NTS");

insert.Update();

insert.Invalidate();

doc.Redraw(true);

}

}

}

vdText t = new vdText(doc);

t.TextString = string.Format("Riser {0}-{1}",exportInfo[1], exportInfo[2]);

t.HorJustify = VectorDraw.Professional.Constants.VdConstHorJust.VdTextHorRight;

Box bb = layOut.Entities.GetBoundingBox(true,true);

t.Height = .25d;

t.InsertionPoint = new gPoint(bb.Right-3,bb.Top-2);
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layOut.Entities.AddItem(t);

doc.ActiveLayOut = layOut;

           

}

}
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4 Glossary

This Glossary contains information on WireCAD nomenclature and definitions that you may not be
accustomed to.

Also included is a description of each term to help you better understand exactly what is being
discussed



WireCAD V7 With CMS Tools Edition79

Holbrook Enterprises, Inc. 2000-2014 - dba WireCAD

Cable: A record in the cables database that describes the connection between two pieces of
equipment. A cable record will have information on the originating (source) equipment and the
terminating (destination) equipment, as well as ports, connectors, signal and Cable Types, etc..

Cable Type: A Cable Type is a definition describing a specific manufacturer's cable. The Cable Type
describes the make, model, description and other meta data about the specific cable. In addition the
Cable Type also describes core or conductor level data. A Cable Type has a one-to-many relation to
its core/conductor data. The core/conductor data describes color codes and fiber modes.

CFE: Customer Furnished Equipment. Alternately, Client Furnished. Also known as Owner Furnished
Equipment. This is equipment to which we must connect but is otherwise not tracked by, or of any
other concern to us.

Circuit: A circuit in WireCAD is defined as a collection of cables. Each circuit may have a Name,
Description, and other meta data. A circuit also has a strand count to indicate the number of
connections made from the originating device on through to the terminating device. Circuits have a
one-to-many relationship with the cables in the Cables database. Each circuit may have many cables
but a cable can belong to only one circuit.

CMS: Cable Management System. WireCAD v7 includes a new feature called the CMS Module. This
is an advanced way to track, manage and edit your cable information within WireCAD. It also allows
you to start your work flow with cable and system data entry rather than the standard flow of functional
diagrams first. 

Core: A core refers to the strands or conductor inside of a cable. A multi-core cable is one in which a
core represents a logical unit. For example: assume we have a 144 strand fiber cable; we will create a
Cable Type with 144 cores. If we have a 50 pair cable (100 conductors) our core count will be 50, one
for each logical unit. In this case each pair.

Database: WireCAD uses "Databases" to store pertinent information required on both a project and
global level. This information is then accessed by WireCAD on an as needed basis. The database is
simply a "storage tank" or file with this information. There are at least two databases running at any
time within WireCAD v7; the Global Equipment Database stores information on device definitions,
Signal Types, Cable Types, etc., and the Project Database contains project specific data like
SysName and Cables, Backbones, Circuits etc.

Equipment Definition: An equipment definition is simply a set of information regarding a piece of
equipment you may use in your project. The equipment definition will include information such as
Make,Model, Part Number, and I/O Port information etc. When you create an "Equipment Definition"
you are simply entering this information into WireCAD so it is later accessible to create Functional
Blocks, reports etc.

Equipment Library: The Equipment Library is the interface in WireCAD that allows you to access and
modify your Equipment Definitions - I/O information and Display preferences for your functional blocks.
 

.EXE: .exe refers to a file being an "executable" file type. This means that when you double-click on
this file, it will open into its own program and run as such. 
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Functional Block Diagram: A functional block diagram is one in which boxes represent equipment
and lines represent cables between equipment. Functional Block Diagrams differ from schematics in
one important way. The concept of a junction in the middle of a cable is unsupported due to the fact
that there is always a piece of equipment that facilitates the junction. Such as a splitter, splice or
terminal block.

Global Database: Your global database is where non project specific information is stored. This
includes information related to Equipment Definitions, Cable Types, Color Codes etc.

I/O: I/O refers to Input and Output Ports on an equipment definition. 

Latest/Newest Build: This refers to the revision number of WireCAD. The higher the number, the
newer the build is. The newest build number is always posted on the WireCAD website.

Project Database: Your Project Database is where any project specific information is stored. This
includes SysName and Cable Numbers, Drawings, SysName & Cable Number formats etc.

Rack Builder: The Rack Builder is a tool in WireCAD that creates a visual representation of a rack
layout based on the location and elevation information that was entered when doing a SysName
assignment.

SQL: Structured Query Language. When referring to SQL in WireCAD, chances are we are referring
to a SQL Server Database. This is simply a database created on a SQL server that is being used to
store WireCAD Databases.  

SysName: In WireCAD you will see "SysName" referred to quite often. A sysName is a unique
identifier for a specific piece of equipment in your project. The reason WireCAD requires a SysName
is because you may have an infinite number of a specific make and model of equipment in your
drawing, however WireCAD needs to distinguish each of those apart. Think of it like a license plate for
your vehicle. Their may be 1000 white Toyota Camrys on the road so to distinguish each apart, you
have a license plate number to uniquely identify yours. 

Wiki: (' w?k?) 
 — n
a. a web application that allows anyone visiting a website to edit content on it.

 b. ( as modifier ): wiki technology
 

[from Hawaiian wiki-wiki  quick, coined by Ward Cunningham (born 1949), US computer
programmer who invented the concept]

 WireCAD has our own Wiki page that we use to share how tos and other documentation
regarding WireCAD. 
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5 Additional Resources

WireCAD Wiki Pages

5.1 WireCAD Wiki Help Pages

Please follow the links below for further information regarding WireCAD topics. You can also view 
www.wirecad.com/wiki for any information not listed in this manual. 

If you have a question on something not found in the Wiki articles, please let us know and we will be
glad to create one.

Use any of the topic text as a search term to find the article without entering the full url.

How To Convert a Vista Project to a SQL Project
http://wirecad.com/wiki/index.php?title=Convert_Vista_Project_To_SQL_Project

How To Create a New Project
http://wirecad.com/wiki/index.php?title=HOWTO:New_Project

Cable Managment Specific Features and Functions
http://wirecad.com/wiki/index.php?
title=Cable_Management_System_Specific_features_and_functions

How To Customize Your Equipment I/O
http://wirecad.com/wiki/index.php?title=Customizing_Equipment_I/O

How To Access Your Equipment Library
http://wirecad.com/wiki/index.php?title=Accessing_Equipment_Library

How To Add a New Manufacturer To Library
http://wirecad.com/wiki/index.php?title=How_To_Add_A_New_Manufacturer_To_Library

How To Create A New Equipment Definition
http://wirecad.com/wiki/index.php?title=HOWTO:New_Equipment_Definition

How To Upload Equipment To Community Server
http://wirecad.com/wiki/index.php?title=Uploading_Equipment_To_Community_Server

How To Move A Project To A Different SQL Server
http://wirecad.com/wiki/index.php?title=HOWTO:MoveProjectServer

WireCAD Support is available Monday through Friday to help with any questions or concerns.

Please feel free to contact us at

U.S. & Canada 1-866-273-5298
International 1-661-253-4370
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