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Foreword
The manual is not an exhaustive study of WireCAD, but rather enough
information to build a foundation upon. We maintain a wiki site with this and
much more information. You can access up-to-the-minute documentation
along with revision and hotfix information online at www.wirecad.com/wiki.
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1 Introduction

Welcome to WireCAD. WireCAD tools aim to decrease the frustration associated with creating accurate, detailed
documentation. WireCAD produces DWG compatible drawings accompanied by either VISTADB or SQL Server
databases containing all pertinent project data. WireCAD is a cable management and facility design tool that
allows you to easily create AutoCAD™ drawings. WireCAD maintains a database of equipment, from which you
can create equipment blocks for your drawings. Equipment blocks are created dynamically from information stored
in the equipment database. Rather than maintaining a large library of equipment blocks or symbols, WireCAD
stores this information in a database and then creates blocks from the equipment definitions contained therein. 
Equipment definitions are easily added to the database. In addition to equipment databases, WireCAD also
provides drawing tools to rapidly create documentation, and database management tools to track:
· Projects
· Drawings
· Revisions
· Cable Types
· Signal Types
· Connectors

Things really start to fly when it is time to assign System Names (unique IDs) and Cable Numbers to the
equipment in your drawing. All you do is double-click on the equipment pieces in the drawing to assign them a
system name. Then double-click on the cable and assign it a cable number. All of the information regarding the
selected cable is extracted from the drawing and placed in the project cables database and the drawing is updated
with a new cable number.
Extensive reporting is available for the project databases including:
· Cable run sheets
· Cable labels
· Project drawings
· Equipment lists
· Bill of Materials
· Power consumption and heat load
In addition, a powerful report designer is included with WireCAD for creating your own reports and labels, or
modifying existing report definition files.
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1.1 New in Version 9

The short list of feature additions and changes in the current release:

Major Changes

· Added expression engine.
· Implemented Expression Builder  on all grids.
· Implemented OSnap Extension tracking on all OSnaps
· Added support for Spare Cables .
· Added support for project level signal types. There is now a Project Signal Types grid to set signal type specific

properties. This will allow you to have different projects with differing signal type structures.
· Modified grids that ripple to only fill the ripple list if fields of consequence are edited.
· Added support for background indexing.
· Added support for automatic indexing on Project Open and Drawing Save.
· Added index view grids .
· Implemented natural sort on all grids and cable specific reports. No more leading zeros to get the sort right.
· Implemented quick index based ripple  (if indexes exist) with option for full ripple.
· Added Sync Equipment Insert  to database function. If the equipment gets out of sync it can easily be

recovered.
· Added Refresh all Pointers on Insert function. Now you can easily update all of the on sheet/off sheet pointers on

a selected insert.
· Added Equipment Swap  function. Now you can select a piece of equipment to replace another and decide

which ports map over.
· Added Link Selected Pointers function. Now you can select a group of pointers and assign them in bulk on the

same sheet or across sheets.
· Modified the Software Development Kit (SDK)  with new examples. Added more samples to the SDK and a

Visual Studio project templates installer. Now it's easy than ever to customize WireCAD to fit your needs!
· Modified the SDK to allow developers to modify their assemblies and recompile without relaunching WireCAD.
· Modified the SDK with 4 new events to apply rules.
· Implemented rules engine using the new expression engine. In addition to the SDK Rules events there is now a

project Rules grid where you can define rules that transform data as assignments are made.
· Modified the help system to tie all dialogs and forms to context sensitive help. Created a Beginner Mode

setting that initiates help to track your moves and provide context sensitive help. You can disable this in the user
settings.

490

463

548

499

107

109

585

372
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Minor Changes

· Added support for pinning forms in the interface.
· Added form state and position persistence. Now pop-up dialogs remember previous position.
· Modified block creation to place block body on a unique layer then set the PenColor to that layer. This will allow

changes in body color after creation.
· Modified all block generated text to honor the TextStyle Height property allowing for changes in text height after

block creation.
· Modified the plugin integration so the wpi files now reside in the common WireCAD folder for easier editing.
· Modified the Application Settings section to allow Enable/Disable Plugins .
· Added Grid, Snap, Polar, Ortho, Extension Tracking to the status bar.

· Added context menu to tab items allowing different close choices: Close This, Close Others, Close All.

· Editing SysName or Terminal now automatically refreshes pointers.
· Modified report cable data selector grid to allow multi-select.
· Modified the Equipment Library dropdowns for units of measure, weight values, power units of measure etc. to

inherit their data from comma separated list values in the translation manager.
· Increased load speed of Link Pointers select drawing form.
· Added setting to show reports in Project Explorer, Reports Gallery or both.
· Removed the Inserts gallery from the CAD Tools toolbar to speed up drawing switching and facilitate loading very

large drawings.
· Introduced a top to bottom sort on all selection sets.
· Enhanced speed of the Reset Selected SysNames function.
· Enhanced speed of the Reset All Cables function.
· Added two new events to the SDK - ActiveDrawingBeforeLinkPointer and ActiveDrawingAfterLinkPointer.
· Added Draw Text dropdowns to the Terminal to Point and Point to Terminal draw cables tool panel.
· Deassign Cable function now crosses Pointers.
· Added new Delete Handling option to delete all attached cables when deleting equipment.
· Added new Delete Handling option when deleting a cable attached to a pointer the other end cable can be reset.
· Added Expert Mode  to avoid common explanatory dialogs during function execution.

362
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1.2 Software Activation

WireCAD v9 offers 2 program levels with two licensing models:
PRO Perpetual License. This license is issued as a replacement to users of WireCAD v8 XLT/PRO with current
Assurance.
PRO Subscription License. This license has an expiration date with a range of 30 days to 3 years.
ENT Perpetual License. ENT fiber management tools only support the perpetual license model.

WireCAD no longer offers the XL Free mode.
An activation key is all that is required to change program levels. If you have questions about the licensing scheme
click here .

Activation
Integral to WireCAD is the ability to have a single authorization key activate multiple concurrent machines if your
organization has paid for more than one seat. By default, when you purchase a seat of WireCAD your license
count for your key will be set to 1 (one).  Operational.

This will allow 1 (one) machine to be active at a time. 
You may install WireCAD on any number of machines throughout your organization; However, only one (or your
license count) machine will be active at any given time.

13
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Floating License Lease
The mechanism by which we float licenses is the license lease. Leases can float or lock to a machine. During the
activation of your software you will be prompted to pick a lease period.

Once activated the application operates until it is shut down whereupon it released the license(if web connected);
thus making the license available to another machine. Upon application startup the license is validated and a lease
is acquired automatically if web connected. If you cannot connect to the web you will need to phone WireCAD
support at:
1 661.253.4370 international.
1 866.273.5298 US and Canada toll free.
NOTE: Subscription keys must be activated via the web at least once per subscription period and cannot
be activated by phone.
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How To: Activate WireCAD

1. Enter your authorization key (it's the really long one that ends in 90. If you fail to enter the key correctly you will
not be able to proceed.

2. If you have successfully entered a valid key and you are web connected you will be able to activate by web. 

3. Select the Float/Lock mode and click [Activate/Deactivate]. If you are successful your screen will look like
this:

If you are not web connected you will need to call us at:
1 661.253.4370 international.
1 866.273.5298 US and Canada toll free.
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If no connection is available you will see the dialog configured like this:

Call the number above. We will need the Machine ID and will read you back an activation code that you will enter in
the box. 
Then click the [Continue] button.

You will receive a message box indicating the success of the activation.

Troubleshooting Activation

The following are a few reasons your activation by web will fail:
1. Not connected
2. Lease already in use by another machine
3. Authorization key abuse
4. Authorization key not found in the database
5. Your machine Date/Time is more than twenty four hours out of sync with our web server (UTC).
6. License count exceeded.
7. Subscription expired (Applies only to subscription keys).

The following are a few reasons your activation by phone will fail:
1. You have provided an incorrect Machine ID.
2. The WireCAD technician has entered an incorrect value.
3. You have entered an incorrect value in the activation field.
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1.3 License Agreement

License Agreement 
YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE OPENING 
THIS PACKAGE AND/OR BY USING THE SOFTWARE. OPENING THIS PACKAGE OR USING THE 
SOFTWARE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO 
NOT AGREE WITH THEM, YOU SHOULD PROMPTLY RETURN THE PACKAGE TO THE LOCATION 
WHERE YOU PURCHASED THE SOFTWARE, UNOPENED WITH PROOF OF PURCHASE, 
AND YOUR MONEY WILL BE REFUNDED. 
 
Holbrook Enterprises, Inc. provides this program and licenses its use. 
Holbrook Enterprises, Inc. retains the ownership of this product.
 
LICENSE 
Permitted Uses/You May: 
* Use the software on any computer provided the software is used on only one 
computer and by one user at a time. 
* Copy the program into any machine readable or printed form for backup or 
modification purposes in support of your use of the program on a single 
machine. 
 
Prohibited Uses/You May not: 
* Make copies of the documentation or software, except as noted above. 
* Distribute, rent, sub-license, transfer, or lease the software or 
documentation. 
* Alter, modify or adapt the software or documentation, including, but not 
limited to, translating, decompiling, disassembling, or creating derivative 
works. 
 
This license and your right to use the software automatically terminate if 
you fail to comply with the provisions of this License Agreement. 
 
TERM 
The license is effective until terminated. You may terminate it at any other 
time by destroying the program together with all copies, modifications and 
merged portions in any form. It will also terminate upon conditions set 
forth elsewhere in this Agreement or if you fail to comply with any term or 
condition of this Agreement. You agree upon such termination to destroy the 
program together with all copies, modifications and merged portions in any 
form. 
 
IF YOU TRANSFER POSSESSION OF ANY COPY, MODIFICATION OR MERGED PORTION OF 
THE PROGRAM TO ANOTHER PARTY, YOUR LICENSE IS AUTOMATICALLY TERMINATED. 
 
TRADE SECRET 
You acknowledge that the software constitutes valuable trade secret 
information that is the exclusive property of Holbrook Enterprises, Inc.. 

Automatic Updates
Holbrook Enterprises, Inc. may periodically check the web for updates. 
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No personal information will be transferred. 

LIMITED WARRANTY 
Holbrook Enterprises, Inc. warrants for a period of 30 days from the date of 
original delivery to you that the program will substantially conform to the 
published specifications and to the documentation, provided that it is used 
on the computer hardware and with the operating system for which it was 
designed. Holbrook Enterprises, Inc. warrants the diskette(s) on which the 
program is furnished, to be free from defects in materials and workmanship 
under normal use for a period of ninety (90) days from the date of delivery 
to you as evidenced by a copy of your receipt. This warranty gives you
specific legal rights. You may have other rights that vary from state to state. 
 
DURING THE WARRANTY PERIOD, IF THE SOFTWARE DOES NOT PERFORM AS WARRANTED, 
YOUR EXCLUSIVE REMEDY SHALL BE TO SEND THE SOFTWARE TO HOLBROOK ENTERPRISES, INC. 
WHICH SHALL, AT ITS OPTION, EITHER REFUND TO YOU THE PRICE PAID OR REPAIR OR 
REPLACE THE SOFTWARE. 
 
To the extent permitted by applicable law, Holbrook Enterprises, Inc. 
disclaims all other warranties, either or implied, including, buy not 
limited to, warranties of merchant ability and fitness for a particular 
purpose. Holbrook Enterprises, Inc. makes no warranty as to title. 
No Holbrook Enterprises, Inc. dealer, distributor, agent, or employee 
is authorized to make any modification or addition to this warranty. 
 
LIMITATION OF LIABILITY 
Because programs are inherently complex and may not be completely free of 
errors, you are advised to validate your work. TO THE EXTENT PERMITTED BY 
APPLICABLE LAW, IN NO EVENT WILL HOLBROOK ENTERPRISES, INC. OR ANY OF ITS 
PRINCIPALS OR AGENTS BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES WHATSOEVER ARISING OUT OF THE USE OF OR INABILITY TO 
USE THE PROGRAM OR DOCUMENTATION, even if advised of the possibility of such 
damages. Specifically, Holbrook Enterprises, Inc. is not responsible for any 
costs or damages including, but not limited to, those incurred as a result of 
lost profits or revenue, loss of use of the computer program, loss of data, 
the costs of recovering such programs or data, the cost of any substitute program, 
claims by third parties, or for other similar costs. IN NO CASE WHATSOEVER SHALL 
HOLBROOK ENTERPRISES, INC.'S LIABILITY EXCEED THE PRICE PAID FOR THE LICENSE TO 
USE THE SOFTWARE. 
 
SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY 
FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION OR 
EXCLUSION MAY NOT APPLY TO YOU. 
 
Should you have any questions concerning this Agreement, you may contact 
Holbrook Enterprises, Inc. by writing to: 
Holbrook Enterprises, Inc. 
1112 6th Street South
Nampa, ID 83651
(866) 273-5298 US and Canada
(661) 253-4370 International
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You acknowledge that you have read this agreement, understand it and agree to be 
bound by its terms and conditions. You further agree that it is the complete and 
exclusive statement of the agreement between us which supersedes any proposal or 
prior agreement, oral or written, and any other communications between us relating 
to the subject matter of this agreement. 
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1.4 Licensing FAQ

The following are some frequently asked questions about the WireCAD licensing scheme.

Q: Does WireCAD support floating licenses
A: Yes, if you choose to use the function it is built in to both PRO and ENT and
for subscription keys. You may disable this feature by selecting the Lock
option on the License Usage section at activation time. Choosing to do so
limits that Authorization Key to that machine only.

Q: How many machines can I install WireCAD on?
A: You may install WireCAD on any number of machines. You will only be able
to launch WireCAD on as many machines as your license count supports. The
default license count is 1. If you wish to purchase additional licenses you may
want to consult with your WireCAD sales professional who will help you
decide the best course of action.

Q: I have a laptop and a desktop WireCAD used to let me install on both. How come I have to choose?
A: You don't. WireCAD will still install on both. It will only run on one at a
time.

Q: What happens if my machine dies?
A: If your machine dies and you are using the floating license scheme, one of
two things will happen:

1.  Install WireCAD on the new machine an wait for your lease to expire in
what ever lease expiration period you selected (not optimum, but
serviceable).

2.  Call the WireCAD sales team. They can manually expire the lease for you.
You will need your authorization key and company name, as well as the
machine name of the machine that died. You will need to fill out and return
an Affidavit of Machine Failure attesting to the fact the the machine cannot
and will not run WireCAD ever again.

Q: I am not connected to the internet very often, can I still use the floating license scheme?
A: We recommend that you use the floating license scheme only if you are
regularly connected to the web.

Q: I am going on-site. How do I ensure that my copy of WireCAD will stay active while I am disconnected from the
web?

A:If you have already activated WireCAD in Float mode the click the
[Activate/Deactivate] button and proceed to deactivate. Then set the License
Usage to Lock and Activate.

Q: What are the benefits of the Assurance Subscription?
A: A current Assurance subscription gives you the following premium
benefits: 

· Free major and minor version upgrades and hotfixes. 

· Priority technical support. 

· New samples, tips and how-to topics from time-to-time.
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· Discounts on training. 

· Access to beta products. 

· Assurance Price Lock guarantees that your annual Assurance rate will not
increase year-to-year as long as you remain current.

Q: Does the license expire if the Assurance Subscription expires?
A: Depends. If you have been issued a perpetual key, your license does not
expire even if your Assurance expires. You can use the products indefinitely
even after the Assurance subscription expires. I you have purchased a
subscription key your key will expire when your subscription expires.

Q: How long does my Assurance Subscription remain valid?
A:Your subscription duration is for 1 year from date of purchase or renewal.

Q: My Assurance Subscription is about to expire. What should I do?
A:You must renew your subscription to continue to receive the latest versions for free along

with all the other benefits of the subscription. To renew your Assurance, contact
sales@wirecad.com.

Note that you may or may not receive notifications from Holbrook Enterprises, Inc. dba WireCAD about the
pending expiration of your subscription. It is your responsibility to renew your subscription when it is about to
expire. You can renew your subscription as early as you want or opt for a monthly credit card payment. 

Q: When can I renew my subscription? 
A:You must renew your subscription before the expiration of your current subscription You

can renew your subscription anytime before your current subscription has expired; you will not lose
any days as the new subscription will come into effect on the day your current subscription ends. In
effect, your current subscription will be extended by 1 year. 

If you do not renew your subscription before the expiry of your current
subscription, your subscription is considered as lapsed and you will not be
eligible for free upgrades and other benefits anymore.

Q: My Assurance subscription has lapsed. How can I get the latest version? 
A:Maintaining your Assurance subscription and renewing your subscription each year to
keep it current is the best and the most cost-effective way to receive all new major and
minor versions as they are released. In case your subscription has lapsed and you want to
upgrade to the latest version you may simply renew your Assurance subscription at the

current rates. 

Q: Do you offer academic discounts? 
A: We do have academic discounts if WireCAD will be used for education/research purposes.

Please contact sales@wirecad.com for more information. 
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1.5 Context Sensitive Help

WireCAD v9 is tightly coupled to the help file. 

When you first start WireCAD we enable Beginner Mode. In this mode your moves are reflected
in the help system. As you launch functions the help system will display context sensitive
help for forms and dialogs.

You can enable/disable Beginner Mode from:
Application Menu>Settings... [User][Expert Mode]

You can get context sensitive help in the following ways from within the application:
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1.5.1 Dialog Based Help

Each dialog in WireCAD 9 has a ? in the upper right-hand corner. 

Clicking this will open the help file to a section specific to that dialog.
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1.5.2 Form Based Help

To display context help for the active form click F1 or the Help menu item
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For example clicking the Help menu when the Cables database is the active form. Displays the following help
topic.
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1.5.3 Tool Panel Based Help

The same follows for tool panels. Click the ? icon to show a help topic specific to that tool panel.
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1.5.4 Settings Panel Based Help

When the Settings dialog is shown you can get help for each panel by clicking the [Help] button.

Clicking the help button will show context specific help for the current settings panel.
In the case below we see the help for the [User][Basic] panel.
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2 WireCAD PRO Manual
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2.1 Getting Started
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2.1.1 Grid Basics

Menu: various
Default command line shortcut: various

WireCAD displays data from the various databases in grid form. WireCAD grids support the following:
· Searching
· Sorting
· Column re-ordering
· Column hiding/showing
· Column grouping
· Column resizing
· Column filtering
· Copy Selection Down
· Increment Selection Down
· Hierarchical display
· Export to PDF, EXCEL, TXT, HTML, XML and more In addition, several grids support WireCAD Visualization

Tools. 
· Expression Execution.

Grid Parts
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2.1.1.1 How To: Grid Functions

· Grid Searching - Enter your search text in the Search box and click [Search]. WireCAD will search all fields
in the table for the search term. The % character is the wild card.

· Sort - Clicking on a column header will cause a sort. Clicking it again will reverse the sort order.
· Column re-ordering/resizing - Drag a column from its center to initiate a move. Drop it where you want it to

display. To resize a column, drag its edge left or right.
· Column hiding/showing - To hide a column: right-click the column header and choose [Remove this

Column] from the context menu.
To show a column:
1. Right-click any column header
2. Click the [Column Chooser] context menu item

The Customization form displays
hidden column headers

3. Drag the column header you wish to display and drop it on the header bar with the other column headers.
· Column grouping - If the grid supports grouping the grid will display a GroupBy panel at the top indicating that

column headers may be dropped there to group.

Grid grouped by Manufacturer and EquipmentName fields

To un-group simply drag the column header back to the header bar.
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· Column filtering - Columns may be filtered in one of three ways:

1. Click the column header filter icon on the column header. You will be presented with a list of unique values
found in that column.

2. Click the (Custom) menu item presented in the column filter list.
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3. If the grid supports it, a filter pane will appear as the top row of the grid. Entering filter criteria in the desired
column will cause filtering.

· Clearing Filter Criteria - If a filter has been applied to a grid, a filter panel will display on the grid in the lower
left hand corner.

You may clear the filter by closing [X] the filter panel.

· Copy Selection Down - If the grid supports it you will be able to copy the top item in a selection down into all
of the selected cells below it. Follow these steps:

1. Create your selection
2. Click Edit>Copy Selection Down or press [Ctrl]+[D] on your keyboard.
3. Be sure to click File>Save to commit your changes to the database.

· Increment Selection Down - If the grid supports it you will be able to increment the top item in a selection
down into all of the selected cells below it. Follow these steps:

1. Create your selection
2. Click Edit>Increment Selection Down or press [Ctrl]+[I] on your keyboard.
3. Be sure to click File>Save to commit your changes to the database.
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· Deleting Cell Data - To delete the contents of the selected cells simply click the [Del] key on your keyboard.

· Deleting Selected Rows - To remove the rows from the grid:
1. Select the rows to delete by clicking on the Record Selector (left-most column without data).
2. Click Edit>Delete Selected Rows or click [Ctrl]+[Del] on your keyboard.
3. Be sure to click File>Save to commit your changes to the database.

· Display Hierarchical Detail Data - If the grid supports it and there is detail data to display you can click the
[+] button in the left-most row. 

· Export - Click File>Export>[File Type]. WireCAD will then export the data with your current grouping, sorting,
and filtering applied to the selected format.
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· Execute Expression - Manipulate data using the expression engine:
1. Open the grid on which you want to manipulate or transform data.
2. Click [Function] button to show the Expression Builder.

3. Enter an expression to evaluate. You can test it against a prototype Test Object on which you can set the data
before testing.

4. Once happy with the expression click [OK] to execute the expression against the grid data.
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2.1.2 Setting Up Your Global Data

Menu: Several
Default command line shortcut: le

WireCAD maintains a global database with tables representing Manufacturers, Equipment, Signal Types,
Connectors, Etc. 
Getting started with WireCAD entails setting up the global databases to fit your needs. While the database is
populated with data you may find that it suits your needs to purge the data and start fresh. If this is the case we
can provide empty databases. At the very least you will want to set up the Signal Types grid with your defaults. 
Next you will customize the Equipment Library with the products and IO that you use. In order to do this, you may
either download existing products from the WireCAD Community Server or enter your own .

Structure:

o Manufacturers - The topmost table in the hierarchy

o Equipment - The Equipment description

o Inputs - inputs of a device

o Outputs - outputs of a device

o Signal Types - signal types and a bunch of defaults.

o Connectors - connector types.

o Pinouts - pin out definitions (data).

o Color Codes - color code look-up. Used by Cable Types.

o Cable Types - cable type information.

o Cable Cores - cores or conductor data for a cable type.

39
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Global Equipment Library Schema (abrv)
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2.1.2.1 Signal Types

Menu: Database > Default Signal Types
Menu: Database > Project Signal Types
Default command line shortcut: st
Default command line shortcut: ShowProjectSignalTypesGrid
Related Settings:

None

The Signal Types grids contain many defaults:
· Pen Color
· Line Type
· Layer mapping
· Cable Type Manufacturer
· Cable Type
· Cable Number Prefix

We cannot stress the importance of this data collection. You should probably start here and define your defaults.

There are two Signal Types collections:
1. Default Signal Types is contained in the Global Database. 
2. The Project Signal Types grid is generated dynamically as you go. 

WireCAD first looks to the Project Signal Types collection for information. If not found the Default Signal Types
collection is queried. If found the Project Signal Types collection is updated with the defaults and the Project
Signal Types collection is returned to the requesting function.
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2.1.2.2 Cable Types

Menu: Database > Cable Types.
Default command line shortcut: ShowCableTypesGrid
Related Settings:

None

This look-up grid contains the global list of Cable Types.
The list is hierarchical and shows the relation of a Cable Type to its Conductors Collection.
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2.1.2.2.1  How  To: Create a New  Cable Type

1. Click Database > Cable Types.
2. Click File > New.

3. Fill in all information about this cable including Manufacturer, Cable Type or P/N & Description. If you are
working in the CMS tools you will need to define multi-core core configuration.
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4.  If this cable is a multi core cable, you will need to check the Is Multi Core checkbox and set how many cores
are in this cable.

5. Select the Default Core\Fiber Mode. To label specific cores as SM or MM, see step 8.
6. Click File > Save.
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2.1.2.3 How To: Open the Equipment Library

The Project Explorer

The Project Explorer allows access to some of the global data grids.
You can also access all of the these grids from the Database menu.

Project Explorer Showing
Equipment Library Access

Menu Commands to Access The Equipment Library

· Database>Equipment Library
· With an active drawing the Equipment Library can also be opened from: Advanced Tools>Equipment Library
· Commandline shortcut: le
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2.1.3 Equipment Library

Menu: Database>Equipment Library
Menu: Advanced Tools>Equipment Library
Default command line shortcut: LE

The WireCAD Equipment Library is where you will spend a fair amount of time as you get define equipment that
you will use in your designs. This is also where we come to create CAD blocks in our drawings. There are many
settings here that let you customize appearance. This chapter is the basics.

Find Tab

Find equipment definitions in the global database or the Community Server.
Preview the block before adding  to drawing.48
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2.1.3.1 Detail  Tab

Edit details. Associate with external files.

2.1.3.2 I/O Tab

Add , edit, select IO to display in created block

Related Topics:
How To: Add Some Inputs and Outputs

434

41
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2.1.3.3 Display Preferences Tab

Controls the appearance of the created block.

Related Topics:
How To: Add Equipment to Drawings

2.1.4 Creating a New Equipment Definition

Menu: Database>Equipment Library[Add Equipment to Library]
Default command line shortcut: le

Equipment definitions are at the heart of WireCAD. They describe equipment down to the I/O.
Create a new equipment definition from which to create functional blocks, rack panels, etc.

50
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2.1.4.1 How To: Add Equipment to the Library

1. Click Database>Equipment Library
2. Click [Add Equipment to Library]

3. Select or add a Manufacturer.

4. Enter model/pn/name, description, etc. 
5. Click [Next >]

There is always some confusion about the SysName Prefix (Equipment Type) field. Consider
the following: 

We have two types of video server -model A and model B - that use similar wiring. We may
consider using the SysName Prefix - SRVR. Anytime we create an instance of one of these we
they will be SRVR-01, SRVR-02, and SRVR-0n. Now consider that model A is not available to
use and that we have to install model b instead. No problem. Because they "harness" is named
SRVR-n we can interchange Make and Model as needed.
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6. This page is optional, but we recommend filling in the Front Panel File field.

Filling in the Front Panel File field will make the Rack Builder tool work. Leave it empty
and you may be frustrated later.

7. Click [Next >] to add the new definition.
The wizard completes and you are taken to the Equipment Library to edit the newly added equipment definition.

2.1.4.2 How To: Add Some Inputs and Outputs

1. Open the Equipment Library
2. Find the equipment which we will add I/O.
3. Select the I/O tab.
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4. Click [Add Ports]. The Add Ports dialog will appear.

5. Enter a port name, connector, signal type.
6. Select Inputs, Outputs table or Both.
7. Click [Add Ports and Close] or [Apply] (if you want to leave the form open).

Your port(s) will be added to the selected list(s):

Try adding multiple ports. Enter "PORT-" (leave off the quotes). Select any Connector
and Signal Type. Select the BOTH radio button to add to both lists. Now Check the Add

Multiple Ports box and enter a Count of 8. Click [Add Ports and Close]. See below.
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2.1.5 Creating a New Project

Menu: Application Menu > New Project
Default command line shortcut: np

Create a new WireCAD Project structure. This involves folder structures on your operating system as well as
databases and support files. 
WireCAD can create projects with a number of different database formats. 
You may choose to create a new project using file based databases for their zero admin capabilities, or SQL
Server for an enterprise installation.

2.1.5.1 How To: Create a New Project

1. Click Application Menu > New Project

2. Click [Next >]
3. Select the type of database you wish to use and Click [Next >]
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4. Enter the Name for the new project. This must follow file naming conventions because we are going to make a
folder out of the name and in the Project Path that you choose. 

NOTE: We recommend NOT using the possessive ' ie Bob's Project. The ' character is the SQL
escape character and though we rarely use it in WireCAD it can cause some queries to fail.

5. Enter a Description. 

6. Click [Next >]
7. If using SQL databases enter the host information. Click [Next >]

SQL names cannot begin with a number
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8. Define some of your project preferences. Here you set your base Starting Cable Number for all sequences. 

9. Click [Next >]
10. By default the Next Numbers table will suggest and test the next number. If that number is in use, the Next

Numbers table is incremented and tested until an available number is found. This behavior can be overridden to
force the usage of the number in the Next Numbers table without testing for existence. To do this Check the 
Disable Find Next Available ......
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11. Click [Next >]
12. Enabling  Locations Look-up causes a subtle change in the SysName Assignment process. You will no

longer be able to just type a location but rather will select your predefined locations from a drop-down list. If you
wish to work as you have in previous versions of WireCAD disable Locations Look-up.

13. Click [Next >]
14.  Review and click [Finish]
WireCAD will then create files and folders on the OS and create a new database on the SQL server if you have
elected to use SQL server databases. Otherwise the blank project database will be copied to your project
databases folder.

2.1.6 Creating a New Drawing

Menu: File>New Drawing, Project Explorer\Current Project\New Drawing
Default command line shortcut: nd
Related Settings:

Show New Drawing Wizard = true

Create a new drawing based on a drawing template, with or without model space boundaries.
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2.1.6.1 How To: Create a New Drawing

1. Click File>New Drawing

2. Select a template drawing from which to start. 
Template drawings are drawings that have been saved in the template drawings folder and already have

entities such as page borders, layouts and viewports added to them.
3. Click [Next >]

4. Select boundary settings. Create Model Space Boundaries. The Model Space Boundaries function takes

two arguments, the Model Space Text Height and the desired Printed Output Text Height. Using these
two variables in conjunction with the size of the Viewports in each Layout to create  boundary rectangles in the
Model space. Each boundary is accompanied by a text description that describes the Viewport and  to which

the boundary applies as well as the text heights and scale factor. 

Note: You can add Model Space Boundaries later using the Drawing>Format>Model Space Boundaries ... function

5. Click [Next >] to finish and name your drawing.

WireCAD creates the drawing in the project drawings folder tree.
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2.1.7 Adding Equipment to Drawings

Menu: Database>Equipment Library [Add to Drawing]
Default command line shortcut: le

Create a new equipment block from the library and add it to the current drawing.

You can create equipment in one of these modes:

· Functional I/O

· Conceptual I/O (low detail) - Collapses to the I/O type

· Conceptual I/O (high detail)
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· Front Panel (File Merge)

· Front Panel (From Dims)

· Plan View (File Merge)

· Plan View (From Dims) - Not Yet Implemented
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2.1.7.1 How To: Add Equipment to Drawings

1. Create and open a drawing.
2. Find and select the equipment definition from the Equipment Library.

3. Select the IO you want to display in the drawing

4. Select the Display mode
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5. Select the Display Preferences. Everything is parametric. There are settings for Body Width, Pin Spacing,
Color, etc.

6. If the Auto Preview function is not set, you may wish to click the Refresh button (either above the preview
window or on the IO tab).

 or
7. Click [Add to Drawing] (requires an active drawing).
8. Place the newly created block in the drawing. You will be able to place any number of copies. Just keep left-

clicking to place. When you are done right-click and click done or click the [Enter] key.

2.1.8 Drawing Cables

WireCAD provides a series of tools to draw cables. 
Normally we draw from one WireCAD device to another.
If you need to draw spare cables see the Spare Cables tool.
WireCAD provides a cable auto-routing tool that automatically routes the cable around other devices and, if
selected, avoids other cables. The auto-router will always find a path for the cable, even if it means that the cable
is drawn through another device or must overlay another cable. 

If you do not like the way a cable is routed, you have two choices:
1. Manually draw the cable by selecting Manual Draw and place every point from source to destination.
2. Select the cable as drawn and grab a grip on the cable and move it around. You can use Ctrl+Shft+Click to add

vertexes and Ctrl+Click to remove vertexes.

If you manually draw cables or otherwise put them where you want them and then move
a device, the auto-router will be invoked and re-route all your changes.
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WireCAD Cable Terminology
Devices have inputs and outputs, Cables have sources and destinations.
For purposes of this manual we will refer to Jacks, Junction Boxes, Router Crosspoints, Bulkhead connectors, and
On-Sheet/Off-Sheet Pointers, Adapters and Splice Points collectively as terminals.

Terminals
Draw Cable Toolbar

Common Controls
These controls effect the behavior of all of the available options.
· Start Cable button - Starts the cable drawing function based on the current setting (one-to-one, one-to-many,

etc.). The Start Cable function is disabled when you are drawing Source to Terminal or Terminal as Source.
· Avoid Other Cables - Determines whether cables will avoid other cables. Toggling this button will not affect

any existing cable but will from that point forward determine the behavior of cable drawing and device moving.
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True False

· Tidy Cables - After moving a grip on a cable the cable is forced ortho.

Before Tidy
After Tidy

· Repeat - Repeat drawing cables until esc is pressed.
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2.1.8.1 One to One Cables

· Cable Text Height -The Cable# text entity height in 100/DU.

· Replace Cable with Pointers checkbox- When checked this function will place linked pointers between the
source and destination ports based on the Default Pointer selection.

Automatically draw Pointers instead of cables.

· Manual Draw checkbox - Draw every point in the cable.

· Aux Text Enable - Enable the placement of Aux Text.

Aux Text Shown
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· Aux Text Height - The height in 100/DU of the Aux Text.
· Location - The position of the Aux Text relative to the cable polyline. 

Over - positioned over the cable polyline.

Under - positioned under the cable polyline.

Bubble - Not yet supported.

· Variable - You may choose to populate the Aux Text with the following variables:
CircuitNumber - The Circuit Number as entered in the Cable Edit Dialog.
IPAddreess - Not yet implemented.
Length - The Length field as entered in the Cable Edit Dialog.
User1 - The User1 as entered in the Cable Edit Dialog.
User2 - The User2 as entered in the Cable Edit Dialog.
User3 - The User3 as entered in the Cable Edit Dialog.
User4 - The User4 as entered in the Cable Edit Dialog.

· Format - Used to apply string formatting to the Variable selected. {0} represents the data from the selected
variable.

Example: the incoming data from the selected variable is 300 and you want to format it to represent
meters to the reader. Your format field would be {0}m. The output would be formatted as 300m.

· X Offset - Horizontal auto-router offset. When drawing cables, WireCAD uses an auto-routing algorithm. The X
Offset determines how far away horizontally from other equipment and cables a new cable will rout.

· Y Offset - Vertical auto-router offset. When drawing cables, WireCAD uses an auto-routing algorithm. The Y
Offset determines how far away Vertically from other equipment and cables a new cable will route.

· Default Pointer - Select the pointer to use when replacing cable with pointers.
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2.1.8.2 One to Many Cables

one-to-many cable

Use this set of controls to place a cable from one output to many inputs.
· Feeder selection - Determines the display of the Y point(s).



WireCAD PRO Manual 57

© 2017 Holbrook Enterprises, Inc. dba WireCAD

· Count - Destination count.

Count=3

· Y offset, Y Spacing, Hor Extension in 100/DU
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· Feeder distances in 100/DU

· One Cable Database Entry - Adds a single entry in the cables database and one Cable# text entity at the Y
point.

· Many Cable Database Entries - Adds a many entries in the cables database and many Cable# text entity at
the connection points. 

Note: One-to-Many and Many-to-One cables set to Many Cable Database Entries will assign the connection point
closest to the cursor when the cable is double-clicked. The first assignment on the cable will enter the database
as expected, subsequent assignments will display the Existing Ports dialog prompting you to decide how to
number the cables.
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2.1.8.3 Many to One Cables

Many-to-One Cable

Use this set of controls to place a cable from many outputs to one input.
· Count - Source count.

count=3

The remainder of the controls have been explained above.
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2.1.8.4 Many to Many Cables

Many-to-Many Cable

Many-to-Many cables behave like a buss. They are a collection of one-to-one cables drawn as a single polyline.
When assigning cable numbers the connection point closest to the cursor is used.
See the above descriptions for more information about settings.
Related User Settings - When I double-click a Many-to-Many Cable Assign them All. This setting overrides
the default "point-nearest" behavior.

· Count - Source and destination count.

Count = 2
Y feeder
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The remainder of the controls have been explained above.

2.1.8.5 Terminal as Source

Displays the available Terminals sorted by Terminal style (Jack,Terminal, Pointer).

Note: Terminal file suffixes determine whether the file will be displayed in this window. Files stored in the %
BLOCKS%\WireCAD Terminals support path having a _SD.DWG, or _S.DWG suffix will appear in this view.
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· Terminal, Pointer, Jack, Splice, Adapter Gallery - Displays a gallery of items to click and place in the active
drawing.

· Refresh Button - Reloads the galleries.
· Wire Length in 1/100 Drawing Unit(DU). - The length of the attaching cable or the terminal offset from the

attached port.

2.1.8.6 How To: Place a Terminal as a Source

1. Create and open a drawing.
2. Place a standard block with ports in the drawing.
3. Click the Terminal as Source Window icon.
4. Click the item in the gallery that you wish to place. This will add it to the drawing for placement including the

attaching cable.



WireCAD PRO Manual 63

© 2017 Holbrook Enterprises, Inc. dba WireCAD

2.1.8.7 Terminal as a Destination

Terminal as Destination Window
Displays the available Terminals sorted by Terminal style (Jack,Terminal, Pointer).

Note: Terminal file suffixes determine whether the file will be displayed in this window. Files stored in the %
BLOCKS%\WireCAD Terminals support path a _SD.DWG, or _D.DWG suffix will appear in this view.
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2.1.8.8 Splice Points

WireCAD supports splice points. If you need a junction in the cable/wire/fiber then use a Splice Point. Splice
Points can be found in the Terminals tool panels and are placed like any other Terminal. 
To Assign a Splice Point you just double-click it and fill in the data.

NOTE: if the SysName contains the text SPLICE then the duplicate checks and other validations against the

Cables and Equipment Lists are ignored. This allows you to have any number of Splice Points all with the same
name
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2.1.8.9 Adapters

WireCAD supports the use of Adapters. Adapters are typically used to convert from one connector to another and
may also involve the conversion of signal type. Adapters are found in the Terminals tool panels and are placed
similar to other terminals. The difference is that instead of a wire being placed between the port and the terminal
the Adapter is placed directly on the port. Once placed, the adapter reads the block to which it is being attached
and gets the SysName and Port information. It then asks you for the new connector type. Finally it populates the
Adapter with the extracted information.

NOTE: if the functional block to which you are attaching the adapter is not yet assigned a SysName you will be
prompted that the operation cannot complete until you have assigned a SysName to the device. You will then
need to double-click each attached adapter to get the information into the adapter.
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2.1.8.10 Working w ith Pointers (on-sheet/off-sheet reference)

Pointers in WireCAD are a class of Terminal that allows linking two pointers on the same sheet or across sheets.

Unlike other terminals in WireCAD, pointers must be used in pairs.

The process of relating one pointer to another is referred to as linking.

There are two pointer families:
1. Pointer_S.dwg and Pointer_D.dwg are the old style pointers. They are still supported but not editable. 
2. WC3_<SOMENAME>_S.DWG and WC3_<SOMENAME>_D.dwg are the WC3 family. These are editable. You

can change, rename, edit the geometry, etc.

Usage

Pointer pairs that reside on the same sheet can be created and linked automatically by invoking the [Start Cable]
function while the Replace Cable with Pointers checkbox checked.

Automatically draw Pointers instead of cables.
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In this case the pointer pairs are placed and linked.

Pointer pairs that must be linked across sheets must follow this process:
1. Place the pointer on the source sheet.
2. Place the pointer on the destination sheet.
3. Double-click the pointer on the source sheet. You must start on the source side.
4. You will be presented with a list of project drawings. Select the one where the destination pointer resides
5. You will be switched to the other drawing. If it is not open it will be first.
6. Find the destination pointer and click it.
7. The pointers will be updated with the complimentary end data.

Flipped Pointers

Occasionally you may find the need to point out of an Input or into an Output.

In order to do this, WireCAD provides a set of pointers that have a reversed geometry.
The naming convention used is <SomePointerName>_FLIPPED_S.DWG or
<SomePointerName>_FLIPPED_D.DWG.
The same process applies as a normal pointer set. Start with the pointer that represents the source side
of the cable and double-click that. Then move to the other side as usual.
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2.1.8.10.1  How  To: Link Many Pointers at Once

Explanation

This process links multiple pointers across sheets or on the same sheet at once.

1. Place the pointers on the source sheet.
2. Place the pointers on the destination sheet.
3. Select the pointers on the source sheet. You must start on the source side.
4. You will presented with a list of project drawings. Select the one where the destination pointer resides.
5. You will be switched to the other drawing. If it is not open it will be first.
6. Select the same amount of pointers on the destination sheet.
7. The pointers will be updated with the complimentary end data.

The process will fail if:
· The counts do not match.
· The pointer families are found to be different.
· The process is not started on the source side.

2.1.9 Defining Locations

Menu: Project Explorer>Project Databases>Locations
Default command line shortcut: none
Related Settings:

Enable Locations Look-up Table = true

You can enable the Locations Look-up table. Here you can predefine your locations; thus maintaining referential
integrity across all of your locations. In order to use this function you must set Application Menu > Settings >
Project [Locations] Enable Locations Look-up = true. If this setting is false, WireCAD behaves as it did in
previous versions allowing you to type any value in the Location field of the SysName Assignment dialog. 

When using the Locations Look-up setting you will need to add locations before you can make use of them in the
SysName Assignment dialog.

There is one other ramification of using  the Locations Look-up: in the Cables table are two new fields SRCEL and
DESTEL (Source Elevation, Destination Elevation). These are now populated as you assign cables. This provides
an additional level of control as you create reports.
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2.1.9.1 How To: Add a New Location

1. Click Project Explorer>Project Databases>Locations. This opens the Locations table.
2. Click File>New.

3. Enter your data and click [Add]. This will add a single location to the Locations table.
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2.1.9.2 How To: Add Multiple Locations

1. Click Project Explorer>Project Databases>Locations. This opens the Locations table.
2. Click File>New.

3. Increment the Count field for the location that you want to add multiple of. 
For example, let's say we have 10 racks in the location: LA.THE FACTORY.FL-01.RM-101

4. Enter LA in the Campus field.
5. Enter THE FACTORY in the Building field.
6. Enter FL-01 in the Floor field.
7. Enter RM-101 in the Room field.
8. Enter RK- in the Rack field
9. Enter 10 in the Rack Count field.
10. Click [Add]. This will add 10 locations to the Locations table:

LA.THE FACTORY.FL-01.RM-101.RK-01
LA.THE FACTORY.FL-01.RM-101.RK-02
...
LA.THE FACTORY.FL-01.RM-101.RK-10
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2.1.10 Assigning Unique IDs (SysNames)

Menu: Advanced Tools>Equipment Functions>Assign SysName
Default command line shortcut: as
Alternately: double-click the equipment block in the drawing.
Related Project Settings:

SysName Format
Leading Zeros
Next Numbers Database

WireCAD allows you to provide unique names for each piece of equipment in the project. We refer to this name as
a SysName. SysNames must be unique by location. WireCAD can enforce a SysName format or allow free form
input.

Edit SysNames Dialog Controls

· Manufacturer - The manufacturer of the device. This field is usually disabled as the dialog has received the
Manufacturer information from an upstream process.

· EquipmentName - The model/pn/item number of the device being assigned. This field is usually disabled as the
dialog has received the EquipmentName information from an upstream process.

· SysName - This is our unique-by-location id. If you manually enter a SysName it must follow the format defined
in the SysName Format tool. The SysName textbox will be masked to help you follow the format.

· Alias - A functional name for the device. Think of it like the friendly name. The SysName is the unique ID the
Alias can be duplicated if desired

· Location / Elevation - We recommend that you enter a Location and Elevation. Take your best guess. The
Rack Builder tool will use your guesses to create a preliminary rack layout that can easily be modified to suit
your final design.

· User 1-4 - For you. You can change these captions from the Plugins>Translation Manager. Search for the
key SysNameUser1 - SysNameUser4 and modify the translated field to be what you want.

· IP Address / Subnet Mask - For the IP stuff if any.
· Power Consumption / Weight - Prepopulated from the Global Equipment database if exists.
· Flags - Various flags to help you sort the equipment in your Systems table.

93
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2.1.10.1 How To: Assign a SysName

This function performs the following steps:
1. Gets the next number in the sequence (based on the SysName Format ) from the Next Numbers table.
2. Prompts the user for input.
3. Updates the drawing
4. Updates the project systems database.

Note: if the project contains related projects, you will be notified of duplicate SysNames in related projects

1. Create and open a project.
2. Create and open a drawing.
3. Add equipment to the drawing.
4. Set the Verbose SysName Assignment checkbox = true. Advanced Tools>Equipment Functions.
5. Double-click the equipment in the drawing.
6. The SysName and Alias field will be populated with the next SysName in the sequence based in the Number

Format and the Next Numbers table.
7. Enter any additional data and take your best guess at Location and Elevation.
8. Click [OK].
The drawing will be updated and a new record will be added to the Project Equipment List.

2.1.10.2 How To: Assign Multiple SysNames

1. Create and open a project.
2. Create and open a drawing.
3. Add equipment to the drawing.
4. Set the Verbose SysName Assignment checkbox = false. Advanced Tools>Equipment Functions.
5. Set the Default Project Location and Elevation in the Application Menu > Settings [Project][Locations].
6. Create a selection set of devices to assign.
7. Click Advanced Tools > Equipment Functions > Assign SysName.
8. The SysName and Alias field will be populated with the next SysName in the sequence based in the Number

Format and the Next Numbers table.
9. The Location and Elevation fields will be populated with the defaults in the Project Settings.

The drawing will be updated and new record(s) will be added to the Project Equipment List.

93
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2.1.11 Assigning Terminals

Menu: Advanced Tools>Equipment Functions>Assign Terminals
Default command line shortcut: ats
Alternately: Double-click the terminal in the drawing.
Assumptions:

 At least one SysName  has been assigned.

Terminals are one or two port devices. The dwg file defines the geometry.
WireCAD treats terminal assignment slightly differently from a normal SysName assignment.
During a Terminal Assignment we map the existing SysName ID AND I/O port info onto the selected terminal.

71



WireCAD v9.1 User Manual74

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Assign Terminal(s) Dialog

· SysName - Select the SysName or press the [+] button to add a new SysName
· I am Just Changing a SysName - Leaves all port data as currently displayed on a terminal, just changes the

SysName. This is useful for modifying existing terminal assignments.
· Remember this equipment - Remembers the selected SysName and returns to it on the next terminal

assignment.
· Outputs track inputs - When you select an input that has a corresponding output of the exact same name, that

output will also be selected.
· Inputs grid - Active only if the selected terminal(s) have input connection points.
· Outputs grid - Active only if the selected terminal(s) have output connection points.

2.1.11.1 How To: Assign Terminals

This function performs the following steps:
1. Opens a port selection dialog based on SysName.
2. Prompts the user to select the SysName and the port or ports to display(or range of ports of multiple terminals

are selected).
3. Updates the terminal(s) in the drawing.

1. Create and open a project.
2. Create and open a drawing.
3. Add a terminal to the drawing.
4. Double-click the terminal.
5. Select the SysName from the SysNames dropdown.
6. Select the Input port to apply to the terminal input.
7. Select the Output port to apply to the terminal output.
8. Click [OK].
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2.1.11.2 How To: Assign Multiple Terminals

This function performs the following steps:
1. Opens a port selection dialog based on SysName.
2. Prompts the user to select the SysName and the port or ports to display(or range of ports of multiple terminals

are selected). The order the terminals are added to the selection set is the order that they will be assigned
numbers.

3. Updates the terminal(s) in the drawing.

1. Create and open a project.
2. Create and open a drawing.
3. Add terminals to the drawing.
4. Select the terminals to assign.
5. Click Advanced Tools > Equipment Functions > Assign Terminal(s) or enter ats in the Commandline and

click [Enter].
6. Select the SysName from the SysNames dropdown.
7. Select the top Input port to apply to the terminal input.
8. Select the top Output port to apply to the terminal output.
9. Click [OK].

WireCAD will assign the terminals from top to bottom in the grid and based on the selection set order.

2.1.12 Assigning Cable Numbers

Menu: Advanced Tools>Cable Functions>Assign Cable Number
Default command line shortcut: ac
Alternately: Double-click the cable in the drawing.
Related Settings:

Cable Number Format
Project Settings

Provides a number for a cable in the drawing and Cables table of the project database.
Assumes that the devices on both sides of the cable have first been assigned SysNames.
To assign multiple cables at once, create a selection of cables. 
The order the cables are added to the select set is the order that they will be assigned numbers. Once you have
created a selection of cables, click: Advanced Tools>Cable Functions>Assign Cable Number, or type ac into
the command line followed by the [Enter] key.

The Assign Cables function performs the following steps:
1. Gets the next number in the sequence (based on the Cable Number Format ).
2. Prompts the user for input.
3. Updates the drawing.
4. Updates the project systems database.

96
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Edit Cable Numbers Dialog Controls

· Preview - This area displays the connection info as found in the drawing.

· CableNo - CableNo is a direct entry field as well as a drop down that displays all available cables. When
double-clicking an assigned cable, the form will be shown in edit mode. The [New +] button will allow the cable
number to be fully edited. This field is auto populated with the next number based on the Cable Number
Format and the Next Numbers table.

· CableTypeManu, CableType - Select the Cable Type Manufacturer and Cable Type. These are populated
by the SignalType if found. If not, then the project default Cable Manufacturer and Cable Type.

· Signal Type - The incoming signal type. Changing this value may cause a recalculation of the CableNo base
on the Cable Number Format.

· Integrator - A user field for assigning the responsibility of the cable.
· Users1-4 - For you.
· Sheet - The drawing file name where the assignment is being made from.
· Pinout - If Pinouts are used select the Pinout that matches the two connector types.
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2.1.12.1 How To: Assign a Cable Number

1. Create and open a project.
2. Create and open a drawing.
3. Add equipment to the drawing.
4. Add cables to the drawing.
5. Assign SysNames to the equipment in the drawing.
6. Set the Verbose Cable Assignment checkbox = true. Advanced Tools>Cable Functions. This will display the

edit dialog.
7. Double-click a cable. 
8. The dialog above will appear with a preformatted cable number in the CableNo field.
9. Add any additional data.
10. Click [OK].
The drawing will be updated and a new record will be added to the Project Cables table.

Prerequisites
Two SysNamed devices and one cable.

Related Topics:
Cable Connection Exists

2.1.12.2 How To: Assign Multiple Cable Numbers

1. Create and open a project.
2. Create and open a drawing.
3. Add equipment to the drawing.
4. Add cables to the drawing.
5. Assign SysNames to the equipment in the drawing.
6. Set the Verbose Cable Assignment checkbox = false. Advanced Tools>Cable Functions. This will not display

the edit dialog.
7. Create a selection set of cables.
8. Click Advanced Tools > Cable Functions > Assign Cable Number.

The drawing will be updated and new record(s) will be added to the Project Cables table.

Prerequisites
All selected cables must be attached to devices with SysNames.

Related Topics:
Cable Connection Exists

461
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2.1.13 Rack Builder Tool

Menu: Advanced Tools>Rack Functions>Rack Builder
Default command line shortcut: rb
Related Settings:

Default Rack Height
Top Down Racks

The Rack Builder tool utilizes information in the Project Systems table and the global equipment library to place
and populate rack elevation views. This process may be run repeatedly as the project progresses.

374
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Rack Builder Dialog

· The [Basic] tab allows you to select the locations to include in the Rack Building function. As you select each
location, the Systems Involved list will populate.

· Systems Involved - Displays a list of all the systems that will be placed in the created drawing.
· Chassis Width - Sets the width of the chassis in DU.
· Height in RU - Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm).
· Slot Count - Sets the number of slots per locator grid. This is used to position items that may not be located

at the insertion point of the rack unit.
· Slot Delimiter - WireCAD searches the Elevation field for numeric values first then for the slot delimiter if

found it parses the data into two values the elevation and the slot, or in other words how far up in the rack and
how far over.

· Insertion Point - Where to start the whole process.
· Attribute Height - If view rule is not Front Panel (file merge), sets the attribute height of the displayed text.

· Create As - 
Front Panel (file merge) = use the dwg file found in the equipment definition BlockRef (Front Panel

File).
Front Panel (from dims) = use the dimension data from the equipment definition to create a 3D rack

block.
From Dims if file not found = Use dimension data if the BlockRef is not found.



WireCAD v9.1 User Manual80

© 2017 Holbrook Enterprises, Inc. dba WireCAD

· Place Text If Item Cannot Be Created - If the item cannot be created due to lacking data, place a text marker
in the drawing at the location.

· Include Grid Hash Marks - This will normally be checked unless you are rebuilding a drawing that already has
the locator grids.

· Spacing DU - Sets the location grid spacing in Drawing Units. Measures from left edge to left edge.

2.1.13.1 How It Works

The Rack Builder tool relies on three key pieces of information. First we need the SysName of the device to add to
the rack. From the SysName we retrieve the equipment manufacturer and model. Second, using the equipment
manufacturer and model, we get the global equipment definition from the global equipment database. If the global
equipment definition is complete it will contain either a reference to a front panel dwg file (BlockRef) or dimensional
data. If either of these are missing the Rack Builder tool will flag that equipment definition as requiring more
information. The Rack Builder tool will perform a pre flight check of all data and let you know what you are missing.
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Assuming all of the data fiddly-bits are in the right place, the Rack Builder tool will populate the drawing with one
locator grid per location selected. A locator grid is an array of point entities that are spaced horizontally and
vertically based upon your selection in the preferences.

Next the Rack Builder tool, based on the Mechanical View Rule, will place either the front panel file or a block
created from the dimensional data at the location point defined in the Project System entry.

The locator grids facilitate location aware movement of the devices placed on the grid.
You may manually place devices created from the equipment library in Front Panel mode on the locator grids.
To move a device within the rack elevations, select the device, grab it by its grip and move it to the desired
location. 
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Note: It is desirable to turn on End Point snap and possibly Node Snap while moving devices

WireCAD will notify you of the location change and update the databases immediately to reflect the change.

It will not update the remainder of the drawing set until you click File > Save. You will then be given the
opportunity to Ripple your changes. Though you are offered the choice you should ALWAYS select [Yes] when
working in the Rack Builder drawings.
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Once changes are made across the drawing set you will be notified of the changed drawings.
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2.1.14 Next Numbers Grid

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None
Product Level: ALL

The Next Numbers Grid will show you the next available Cable number based on your Cable Number Format .
To access the Next Numbers Tool, type NN in the command line prompt. 

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As you progress
through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number box and fill in
the desired number. Be sure that you are not entering a number that is already in use. 

Note: Yours will look different as the Next Numbers grid will automatically create entries for each new sequence
used by the application.

96
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2.2 Advanced Topics

The following sections cover more advanced topics in WireCAD.

2.2.1 Equipment List Visualizer

Menu: Database>Project Systems>Equipment List (SysNames)
Default command line shortcut: sys
Related Settings:

See the Settings Tab

The Equipment List Visualization tool utilizes information in the Project Systems table and the Global
Equipment Library and the Project Cables database to create a view of all cables attached to the selected item.
These details are useful for error checking and in the field as an installation aid.

System Snapshot of all ports and
connections
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Controls

· Settings Tab - Control the output of the Visualizer.
· Use Last Display Order if Set - Sorts the ports of the block based on the saved display order if any.
· Terminal - The terminal to display.
· Use Last Saved Appearance - If there are device level settings saved, use them.
· Body Width and Pin Spacing - Appearance settings in 100/DU.
· Port Data Source -

Pull the port data from the Equipment Library. This will show ALL ports associated with this device
definition.

Pull the port data from the Cables table. This will show only those ports to which cables have been
attached and assigned.
· Title Block - Describes the visualization. Salt to taste.
· Visualization tab - Does it.

2.2.1.1 How To: Use the Equipment Visualizer

1. Create a project.
2. Add equipment.
3. Assign SysNames.
4. Draw cables.
5. Assign Cable Numbers.
6. Open the project Equipment List.
7. Select the SysName record to visualize.
8. Click the Settings tab.
9. Set the Terminal. This is the item that will be displayed as the source and destination of each cable.
10. Click the Visualize tab.
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2.2.2 Cables Visualizer

Menu: Database>Project Cables>Project Cables Grid
Default command line shortcut: cg
Related Settings:

See the Settings tab

The Cables Visualization tool creates a layered diagraph (ladder diagram) showing the Locations (vertically) and
the cables between them (horizontally).
Use this output for:
· Pre-wires.
· Spare inventory.
· General overview.
· Enlighten and amaze your friends.
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Visualization without SysNames

Visualization with SysNames
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2.2.2.1 How To: Use the Cables Visualizer

1. Create a project.
2. Add equipment.
3. Assign SysNames.
4. Draw cables.
5. Assign Cable Numbers.
6. Open the project Cables grid.
7. Select a group of records to visualize.
8. Click the Settings tab. 
9. Adjust settings to suit.
10. Click the Visualize tab.

2.2.3 AutoScheme Tools

The AutoScheme tools create functional drawings or parts thereof from the data in the project systems and
cables databases. This is useful to create detail or overall views. 
The AutoScheme tools consist of two utilities. The Auto Block tool automatically places blocks in the drawing on
a grid. The Ratsnest tool checks the project cables database against the drawing. If connections defined in the
cables database can be reproduced in the drawing because the SysNames and Ports exist, a cable is placed. 

Prerequisites
SysNames and Cable Numbers in the project database.

Auto Blocked drawing. Blocks have been created and placed.
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After running the Ratsnest tool. This supplies the drawing with cable data and provides a positional reference to
help you decide where to move block to better display the drawing.

After running the Cleanup tool from the Ratsnest utility.
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2.2.3.1 Auto Block

Menu: Advanced Tools>AutoScheme Tools>Auto Block
Default command line shortcut: ab
Related Settings:

None

The Auto Block tool automatically places functional blocks in the drawing. This tool requires that the Project
Systems table be populated. 

Controls

· The [Basic] tab allows you to determine which systems to add to the drawing.
· Filter - Filters the list by your criteria.
· The [Advanced] tab allows you to refine the behavior of the utility.
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· Insertion Point - The point we start from. 
· Horizontal Spacing DU - How far apart horizontally. The vertical spacing is defined by the height of the highest

block in the row.
· Maximum Column Count - How many columns horizontally.
· Get Port Data From Cables Database - Select this option to search the cables database for port info instead

of the global equipment database. This will effectively show only those ports to which we have attached cables.
· Display As - How to display the blocks.
· Display Preferences - If Functional Block or Concept block is selected then set basic display parameters. 
· Signal Types to Display - Filter ports by the selected signal types.

2.2.3.2 RatsNest

Menu: Advanced Tools>AutoScheme Tools>RatsNest
Default command line shortcut: rn
Related Settings:

None

The RatsNest tool checks the project cables database against the drawing. If connections defined in the cables
database can be reproduced in the drawing because the SysNames and Ports exist, a cable is placed. 
This tool requires that the Project Cables table be populated. 



WireCAD PRO Manual 93

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Controls

· This tool has three sections. The RatsNest section does the work of placing the cables in the drawing as defined
in the Cables database.

· [Ratsnest] - Run the utility to place the cables.
· Show Cable Numbers - With or without cable numbers.
· [Clear All Cables] - Removes ALL cables from the drawing. Not just ratsnested cables. This will remove ALL.
· [Cleanup] - Applies the auto-router to all cables in the drawing.
· Avoid Other Cables - Auto-router avoids other cables on cleanup.
· [Fillet] - Applies fillets to ALL cables in the drawing.
· Distance - Fillet distance in 100/DU.

2.2.4 SysName Formatting

Menu: Project Explorer>Project Databases>Project SysName Format
Default command line shortcut: fsys
Related Settings:

None

Allows control of the SysName numbering scheme. Using the SysName Format dialog you can select any field
that is associated with the SysName and concatenate it into your own numbering scheme. Each of the fields
selected can be formatted and the numbers can be set to sequence off of another field.

How it Works
The SysName Format Tool is used to generate regular expressions that are then used to parse SysName info as
well as provide formatting information to masked text boxes. 

A note on regular expressions: WireCAD makes extensive use of regular expressions (Regex). Regular
expressions are a well documented string parsing tool. Much has been written on them. It is not within the scope
of this quick start guide to fully explain regular expressions; however, a Google search will tell you more than you
ever wanted to know. 
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Two forms of regular expression are generated: a simplified form that is used as a mask in both the Systems
database and in textboxes, and a complex form that aids in the generation of queries to determine the next
number in a sequence. The following are both the simplified and complex Regex for the default format:

\w{1,6}-\d{1,5}

(?<EQUIPMENTTYPE>\w{1,6})-(?<NUMERICSEQUENCE>\d{1,5})

Controls
· Selected Format - Selected the current SysName format. Allows addition and deletion of formats as well.

· Variable List - Displays the sequence of variables in grid view that will be concatenated into the final
SysName. 

· SeqOn - This variable should sequence on another variable's value. 
· Order - The order in the list of the variable.
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· Available Variables - 

Variable Description Can Sequence On Default Format (Regex)
MANUFACTURER Manufacturer Name X \w{1,6}

EQUIPMENTNAME Equipment
Name/PN/Model Number

X \w{1,6}

DESCRIPTION The device description as
contained in the global
equipment library

X \w{1,6}

EQUIPMENTTYPE The Equipment Type as
contained in the global
equipment library

X \w{1,6}

LOCATION The location typed in the
SysName edit dialog

X \w{1,6}

ELEVATION The location typed in the
SysName edit dialog

X \w{1,6}

STRING any string (usually used
for delimiters like dashes
(-))

-

NUMERICSEQUENCE a numeric sequence that
starts with the project
starting number

\d{1,5}

ALPHASEQUENCE an alpha sequence that
starts at the letter 'a'

\w{4}

USER1 the global equipment
library device definition
user1 field

\w{1,6}

USER2 " \w{1,6}

USER3 " \w{1,6}

USER4 " \w{1,6}

More About Regex

The Format field uses regular expressions. The following are some simple examples:
\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters
\d{1,5} Digits 1 to 5 digits in length
\d* Digits any length
\\ a slash "\". The \ is the escape character so you need two
- a dash except when in [] or {} then a range.
[a-zA-Z0-9_\-\,]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.
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2.2.5 Cable Number Formatting

Menu: Project Explorer>Project Databases>Project Cable Number Format
Default command line shortcut: fcab
Related Settings:

None

Allows control of the Cable numbering scheme. Using the Cable Number Format dialog you can select any field
that is associated with the Cable Number and concatenate it into your own numbering scheme. Each of the fields
selected can be formatted and the numbers can be set to sequence off of another field.

How it Works

The Cable Number format tool is used to generate regular expressions that are then used to parse Cable Number
info as well as provide formatting information to masked text boxes. 

A note on regular expressions: WireCAD makes extensive use of regular expressions (Regex). Regular
expressions are a well documented string parsing tool. Much has been written on them. It is not within the scope
of this quick start guide to fully explain regular expressions; however, a Google search will tell you more than you
ever wanted to know. 

Two forms of regular expression are generated: a simplified form that is used as a mask in both the Cables
database and in text boxes, and a complex form that aids in the generation of queries to determine the next
number in a sequence. The following are both the simplified and complex Regex for the default cable number
format:

\w{1,6}-\d{1,5}-\w*

(?<SIGNALTYPEPREFIX>\w{1,6})-(?<NUMERICSEQUENCE>\d{1,5})-(?<MULTICOREDATA>\w*)
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Controls
· Selected Format - Selected the current Cable Number format. Allows addition and deletion of formats as well.

· Variable List - Displays the sequence of variables in grid view that will be concatenated into the final Cable
Number. 

· SeqOn - This variable should sequence on another variable's value. 
· Order - The order in the list of the variable.
· Test Sequence - Performs a basic syntax test on the regular expressions.
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· Available Variables - 

Variable Description Can Sequence On Default Format (Regex)
SIGNALTYPE The signal type

associated with the cable
X \w{1,4}

SIGNALTYPEPREFIX the signal type prefix
associated with the signal
type of the cable

X \w{1,4}

SOURCESYSTEM The source SysName X \w{1,6}

SOURCEPIN The source port or pin
name

X \w{1,6}

SOURCEALIAS The source Alias X \w{1,6}

SOURCELOCATION The source location X \w{1,6}

DESTSYSTEM The destination SysName \w{1,6}

DESTPIN The destination port or pin
name

\w{1,6}

DESTALIAS The destination alias \w{1,6}

DESTLOCATION The destination alias \w{1,6}

SOURCE_OR_DEST_PIN_I
F_JACKFIELD

Not Yet Implemented \w{1,6}

MULTICOREDATA Core data as defined in
the associated cable type
if any

\w*

STRING any string (usually used
for delimiters like dashes
(-))

-

NUMERICSEQUENCE a numeric sequence that
starts with the project
starting number

\d{1,5}

ALPHASEQUENCE an alpha sequence that
starts at the letter 'a'

\w{4}

USER1 the global equipment
library device definition
user1 field

\w{1,6}

USER2 " \w{1,6}

USER3 " \w{1,6}

USER4 " \w{1,6}

More About Regex

The Format field uses regular expressions. The following are some simple examples:
\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters
\d{1,5} Digits 1 to 5 digits in length
\d* Digits any length
\\ a slash "\". The \ is the escape character so you need two
- a dash except when in [] or {} then a range.
[a-zA-Z0-9_\-\,]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.
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2.2.6 Using Your CAD Drawings With WireCAD

With WireCAD you can now WireCADify your existing non-WireCAD CAD blocks to include WireCAD intelligence;
thus making them work with WireCAD. Pretty cool huh?

The process requires at least two steps:
1.  WireCADify the block.
2.  Add ports to the block.
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2.2.6.1 How To: Customize Your CAD Blocks to Work w ith WireCAD

Menu: Advanced Tools>WireCADify>WireCADify Block
Default command line shortcut: wc

Requires an active drawing with a CAD block.
Adds the base WireCAD attribute set to the selected block, mapping your attribute data into our attributes if you
choose.
1. Open a drawing with a non-WireCAD CAD block that you want to make work with WireCAD.
2. Click Advanced Tools>WireCADify>WireCADify Block.
3. You will be prompted to select a CAD block.

Here we have a CAD block with the displayed
attributes (Yours).

4. Select your CAD block. It must be a block and not raw entities.

5. Map your attribute to our attributes.
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6. Select the [Descriptor Locations] button.

- Drag to reposition

Preview after repositioning

7. Click [OK] to do it.
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2.2.6.2 How To: Add a Port to an Ex isting CAD Block

Menu: Advanced Tools>WireCADify>Add Connection Point
Default command line shortcut: none
Related Settings:

None

Adds a connection point to the selected block.

1. Open a drawing with a WireCAD block.
2. Click Advanced Tools>WireCADify>Add Connection Point
3. You will be prompted to select a WireCAD block.

Here we have a WireCADified
block
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4. You will be prompted for the point at which to add the Connection Point.

Here will will choose the arc
quandrant

5. Enter your port info into the dialog that is presented.

Here we will say that the port is an input
called IN 10.

We will show the labels and include a small
circle to snap to.
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6. Click [OK] to finish.
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2.2.7 Understanding Indexes

Related Topics:
Unassigned Cables
Unassigned SysNames
Cables by Drawing
SysNames by Drawing
Cables by SysName
Orphaned Cables
Orphaned SysNames

WireCAD keeps track of two classes of data.

1. Primary - examples of primary data include: SysNames, Cable Numbers, Locations, Drawings. This data is of
cardinal importance. We always want this data to accurately portray what goes on in the drawing/database.
2. Secondary - Indexes are secondary or transient data.
The indexes are link data relating the primary data bits to each other. 

Index data is transient in nature.

WireCAD consists of a drawing interface with undo/redo and a database which does not. With that as our
framework let's discuss a scenario which will put the indexes out of sync quickly.
1. You add a cable to a drawing. A record is added to the Unassigned Cables index. 
2. You undo. The cable is removed from the drawing but the database does not have an undo function (nor should

it but that's a discussion for another day).
3. We now have a record in the Unassigned Cables index that is in error. It only took two steps to create an

inconsistency in the index table.
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So rather than trying unsuccessfully to keep every move in sync, we routinely scan the drawing and rebuild the
index tables as a background process.
The indexes can be destroyed, rebuilt, and at any given time - out of sync. Deleting all indexes has no effect on
primary data.
To insure the most current indexes, run the Rebuild Indexes command.

You can view the indexed data in the primary data grids as sub grids with the [+] button.
You can also view the indexed data in individual grids.

There are seven indexes:

1. Unassigned Cables by Drawing. We search the drawing and add any cable that does not yet have a number
to this index.
2. Unassigned SysNames (equipment) by drawing. We search the drawing for any equipment that does not yet
have a SysName and add it to this index.
3. Equipment by Drawing. Any equipment that has a SysName and corresponding entry in the Equipment List is
added to this index by drawing.
4. Cables by Drawing. Any cable that has a number and corresponding entry in the Cables database is added to
this index by drawing.
5. Cables by Equipment. Any cable that has a number and corresponding entry in the cables database and
where both ends of the cable have valid entries in the Equipment list will be added to this index.
6. Orphaned Cables. Any cable with a number but no corresponding entry in the Cables database will be added
to this index by drawing.
7. Orphaned SysNames. Any equipment with a SysName but no corresponding entry in the Equipment list will be
added to this index by drawing.

Settings that affect Indexing

The Auto Index setting will scan the project in the background upon project open and any drawing save.
The Show Index Progress setting turns on the main progress bar in the status bar to indicate progress.
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2.2.8 Sync Equipment with Database

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Sync Equipment with
Database
Default command line shortcut: SyncInsertWithDatabase

Occasionally you will make a decision that puts the data on an insert out of sync with the corresponding record in
the Equipment List. 
This will be manifest by an Orphaned SysName record. To remedy the error use the following steps:

1. Select the insert in the drawing that is orphaned. If you are unsure you can always start this function and if the
insert matches the database you will be informed so.

2. Right-click to show the context menu.
3. Click Equipment>Sync Insert with Database.

These are the possible outcomes:
1. The insert matches the database. At which point you will be informed as such.
2. The insert partially matches the database. The SysName and Location match but other fields do not. You will

be given a choice as to which record to use as the update source.
3. The insert cannot be matched with a record in the database. This results in two other options:

a. You will be given the choice to add a new record, or:
b. The database is queried for like Manufacturer and EquipmentName records from which you can

select to apply to the insert. Note: only SysNames of the same Manufacturer and EquipmentName will be
shown for selection.



WireCAD v9.1 User Manual108

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Depending on your selection the following will happen:

Outcome Update Insert in
Drawing

Update
Database Data

Update Cable
Data

Add New
Record

Update
Attached
Pointers

Item Matches
Database

- - - - -

Item Matches
SysName and
Location
Choice to use
Insert Data

X

Item Matches
SysName and
Location
Choice to use
Database Data

X X X

Item not found
in Database
Choice is Add

X

Item not found
in database
choice is select
other existing

X X X
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2.2.9 Swap Equipment

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Swap Equipment
Default command line shortcut: none

The Swap Equipment function allows you to swap Manufacturer, Model, and port data on an existing functional
block or concept block.

Applies To:
Functional Blocks
Concept (High Detail) Blocks.

Used For:
Switching from one make/model to another.

Controls

· Manufacturer - Select the Manufacturer to replace the outgoing device with.
· Equipment Name - Select the Equipment Name / Model / PN to replace the outgoing device with.
· Inputs grid, Outputs grid - Select the ports to replace.
· Find Matches - Matches incoming ports to outgoing ports.
· OK - Do it!
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2.2.9.1 How To: Swap Equipment

1. Open a drawing.
2. Select one of the block types in the Applies To section.
3. Right-click to show the context menu.
4. Click Equipment Functions > Swap Equipment.
5. Fill in the Equipment Switcher form data.
6. Click OK.

2.2.10 Edit Block in Place

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Edit Block in Place
Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Edit Block in Place Ignore
Attached Cables
Default command line shortcut: ebip, EditBlockinPlaceIgnoreAttachedCables
Related Settings:

None

Edit Block in Place allows you to modify an existing insert that was created from the Equipment Library. There are
two variants of the function. One that attempts to keep all cables attached to the ports from which they started.
The other does not.

Because blocks in the CAD file are immutable the function actually creates a replacement block and inserts it into
the drawing in place of the other.

Prerequisites
A WireCAD created functional block

Overview
1. The port information is read from the block.
2. The display information is read from the block.
3. Cable information is read from the block.
4. The Equipment Library is queried for the incoming device and the Library is placed in Edit Mode.
5. The drawing information is used to create a matching block in the Equipment Library.
6. Edit to suit.
7. Update the insert in the drawing.
8. Re-route all cables to find their starting ports or not depending on the variant.
9. Cables that cannot find their starting ports are modified to show a dashed LineType.
10. Show a dialog indicating cables that cannot find home.

NOTE: While the port information is being read into the Equipment Library if a port exists on the drawing that does
not exist in the Equipment Library it will be added.
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2.2.10.1 How To: Edit a Block In Place

1. Open a drawing with a WireCAD created functional block.
2. Select the block. It must be the only thing in the selection.
3. Right-click and select Equipment>Edit Block in Place.

4. The block is loaded into the Equipment Library for edit.

Edit initiated
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5. Make changes. Here will move the top SDI port to the bottom.

List re-ordered

6. Click [Update Insert in Drawing].

Port moved and cable reattached

7. Done.
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2.2.11 Rereference Pointers

Explanation

Occasionally you will save pointers to another sheet. This can be because you have done a SaveAs or Copy /
Paste.
At that point you will want to change the sheet reference on the pointers. Those pointers that point to the new
sheet from other drawings as well as the pointers on this sheet that point to the old drawing will need to be
renamed to the new sheet.

Usage

1. Click Advanced Tools > Rereference Drawing Pointers (Change SheetRef Names).
2. Fill in the dialog - Set the rename From/To names and where you want to search.
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2.2.12 Save and Ripple

Occasionally throughout normal program execution you will be presented with the Ripple Choice  dialog.

Something has changed that potentially effects data in other drawings and databases. This is your chance to
update those other entities in other places.

Applies To:
Equipment List
Cables  database
Locations  database
Rack Builder  drawings

Related Topics:
Understanding Indexes
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2.2.13 Spare Cables

Menu: Advanced Tools > Add Spare Cable(s)
Default command line shortcut: AddSpareCables
Related Settings:

None

Place geometry in the drawing and cable(s) in the Cables database that represent spare cables.

The following images represent the above settings in both drawing and the Cables database.

This function adds Count number of cable records to the Cables database. The number is 
automatically formatted in accordance with the Cable Number Format  tool and the
Next Numbers  table.

Applies To:

Used For:
Adding geometry and cable entries in the project Cables database.

Controls

· Cable Type - Select the CableType.
· Left Side, Right Side - set the location and the connector.
· Count - how many cable records to enter.
· Geometry - What to include in the drawing.

96
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2.2.13.1 How To: Add a Spare Cable

1. Open a project.
2. Open a drawing.
3. Click Advanced Tools > Add Spare Cable(s).
4. Fill in the dialog.

5. Click [Draw Polyline].
6. The dialog will be dismissed. You are prompted to draw a polyline.
7. Click the points to enter in the polyline. 
8. Right-click to finish.
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2.2.14 Understanding Terminals

Terminals in WireCAD represent a one or two port device and are used draw compact inline signal flows.

The terminal is a standard CAD block with specific WireCAD attributes. The geometry of the terminal
is defined in the CAD drawing file.

In order to be a WireCAD Terminal the following criteria must be met:
· WireCAD Attribute set which includes:

SysName
EquipmentName
ManufacturerName
Location
Alias
SheetRef
Created With:
EquipmentID
WC_TYPE
EquipmentDescription

In addition a Terminal must have at least one invisible Connection Point attribute with the Tag:
CP_IN or CP_OUT.

The CP_IN should be placed on geometry that represents the input connection point. Or the point to which we will
connect our cable destination.
The CP_OUT should be placed on geometry that represents the output connection point. Or the point to which we
will connect our cable source.

If a CP_IN is defined. The follow display attributes may also be used:
INPUT_CONN - optional input connector display name.
INPUT_NAME - optional input display name.
INPUT_TYPE - optional input signal type display name.

If a CP_OUT is defined. The follow display attributes may also be used:
OUTPUT_CONN - optional output connector display name.
OUTPUT_NAME - optional output display name.
OUTPUT_TYPE - optional output signal type display name.
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2.2.14.1 How To: Customize a Terminal

1. Open the base CAD file. The terminals are in the %BLOCKS%\WireCAD Terminals path.
2. Modify the geometry and or attributes to suit.
3. Click File > Save As. Remember to keep the _S.DWG and the _D.DWG naming convention intact.
4. Open a drawing that you want to use your shiny new terminal in.
5. Refresh the Terminals tool panel. This will display your new terminal in the place terminals galleries.

6. Click to use as any other terminal.

If the terminal needs changes you will have to do the following:
1. Delete all instances of the offending terminal insert from the drawing.
2. Click File > Purge.
3. Verify that your file name is in the purge blocks list.
4. Purge the drawing of unused entities.
5. Open the base CAD file again and edit and save.
6. Repeat steps 4 - 6 above.
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2.3 Plan View and Layout Tools Dialogs

The following set of tools is targeted at the plan view space.
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2.3.1 Take Offs

Menu: Drawing > Plan View and Layout Tools > Take Offs
Default Commandline shortcut: showtakeoffs
Related Settings:

None

Often we need to count items in the plan view space for quoting or other purposes. The Take Offs tool facilitates
this process by filtering the drawing for specific entity types on specific layers then counting those instances.

Possible Uses
· Quote preparation.
· Trouble-shooting.

Dialog Options

· Print - Print the grid.
· Export - Export the grid.
· Layer - What layer are we searching for the selected entity type(s).
· Entity Types - What entity type(s) are we searching for.
· Generate - Do It! The results will be displayed in the grid.
· Count - Count the items in the list. The results will be displayed in the right-hand list.
· Grid Columns

ItemHandle ShowMe - Zooms to show the item in the drawing.
Block Name or Entity Type - obvious.
IgnoreInCount - Ignore me when counting.
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2.3.1.1 How To: Pull a Take-Off from a Drawing

1. Open a plan view drawing.
2. Click Plan View Tools > Take-Offs.
3. Select the Insert check-button. 
4. Then click [Generate]. This generates a list of all Inserts in the drawing.
5. Click [Count]. This counts the different inserts in the drawing. The results appear in the list on the right.
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Now let's say we want to count all circles on the CEIL_SPKR layer.

1. Open a plan view drawing.
2. Click Plan View Tools > Take-Offs.
3. Select the Circles check-button, and select the Layer on which to search.

4. Click [Generate]. This produces a list of all the circle entities found on the selected layer.
5. Click [Count]. This counts them and outputs the result in the right-hand list.

As you can see we have 20 circles that appear on the CEIL_SPKR layer.
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2.3.2 Location Boundary

Menu: Plan View and Layout Tools > Location Boundaries from Text
Default Commandline shortcut: DrawLocationBoundaryRectangle
Related Settings:

None

Define geometric boundaries for locations important to the design. For example we would want to know where on
the drawing the Machine Room is but not necessarily the kitchen (unless part of our cable ends up in the kitchen).
Boundaries can be nested in other boundaries. It is common practice to create the Campus boundary and then
nest the Building boundary then the Floor boundary then the Room and Racks boundaries.

Location Boundary for the room ISO 111

Prerequisites
A plan view drawing.
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Dialog Options

· Name - The location name.
· Location Kind - You will need to tell us the kind.
· Automatically Nest Locations - Default is true.
· Boundary Entity - Rectangle, Closed Polyline, Circle.
· Show Name in LineType - Renders the entity with the location name as the linetype.
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2.3.2.1 How To: Place a Location Boundary

Method 1
Use the selected text entity to populate the dialog.

1. Open a plan view drawing.
2. Select a text entity that represents the location name of the location for which we will create the boundary. This

text will populate the dialog Name field.
3. Click Plan View and Layout Tools > Location Boundaries from Text.
4. Set the Location Kind.
5. Set the Boundary Entity.
6. Click [OK]. The dialog is dismissed and you are prompted to draw the boundary entity.
7. Draw the boundary.

Method 2

Manually populate the Name field.

1. Open a plan view drawing.
2. Click Plan View and Layout Tools > Location Boundaries from Text.
3. Enter the Name.
4. Set the Location Kind.
5. Set the Boundary Entity.
6. Click [OK]. The dialog is dismissed and you are prompted to draw the boundary entity.
7. Draw the boundary.
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2.3.3 Draw Backbone

Menu: Drawing > PlanView and Layout Tools > Draw Backbone
Default Commandline shortcut: 
Related Settings:

None
Product Level: ENT

Backbones are collections of cable/fiber that are contained in a single jacket that run from one location to another
and are typically sized for growth. An example might be a fiber optic cable that contains 288 fiber cores that runs
from building A to building B. We know that initially we will not use all 288 fibers and have planned for growth. As
the facility needs change the usage of the backbone's fibers change.

WireCAD maintains backbones just like any multi-core cable with the exception that the Cables table record is
flagged IsBackBone = true.
WireCAD will create a cable record for every core in the Cable Type used.

Prerequisites
1. SysNames assigned to the panels/equipment to which you will attach the ends of the Backbone.
2. Multi-core Cable Type representative of the Backbone.

Operation
This tool allows you to draw geometry in the Plan View space that represents the path of the Backbone. The
process requires the following steps:
1. Draw the polyline that represents the backbone.
2. If locations boundaries are found in the drawing the source and destination locations will be used. Otherwise

you will be prompted to define a location for each end.
3. Next you will be presented with the New Backbone tool where you will select the source and destination

panels/ports and the cable type.
4. Clicking [OK] will build a record in the Cables table for each core in the multi-core cable type.
5. The polyline length populate the cable record Length field.
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Dialog Options

· New Backbone - Select whether we are creating a new number or assigning an existing, unused core.
· Backbone ID - The number.
· Use Existing Available - Select an already assigned Backbone with available strands to populate the

remaining available strands of fiber.
· Location Filter - Filter the list by location.
· From Panel Info - Select the panel. The ports will be shown in the list.
· To Panel Info - Select the panel. The ports will be shown in the list.
· Cable Type - Select the Cable Type.
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2.3.3.1 How To: Draw a Backbone in Planview

1. Open a plan view drawing where you want to draw a plan view polyline.
2. Place source and destination Plan View Equipment or source and destination Plan View Location Boundaries.
3. Click Plan View and Layout Tools > Draw Backbone.
4. As prompted select the source equipment or location boundary.
5. Draw the points in the polyline.
6. The New Backbone tool is shown.

7. Select the source, destination, cable type and ports.
8. Click [OK] to finish.
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2.3.4 Draw Cable

Menu: Drawing > PlanView and Layout Tools > Draw Cable
Default Commandline shortcut: pwdc
Related Settings:

None
Product Level: ALL

This tool allows you to draw a cable in Plan View space that is assigned to the Cables table.

Related Topics:
Draw Cables

Dialog Options

· Cable Type - Select the Cable Type.
· Source Information - The source SysName is pulled from the drawing. You will need to select the Src Pin and

such.
· Destination Information - The destination SysName is pulled from the drawing. You will need to select the

Dest Pin and such.
· Other Stuff - Enter user information.
· Cable No - Click the [...] button to generate a cable number.

51
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2.3.4.1 How To: Draw a Cable in Planview

This tool allows you to draw geometry in the Plan View space that represents the path of the cable.
Prerequisites
1. SysNamed source and destination equipment placed in the Plan View space or:
2. Source and destination Location Boundaries placed in the Plan View space.

1. Open a plan view drawing.
2. Click Plan View and Layout Tools>Draw Cable
3. Select the source SysNamed equipment.
4. Select the destination SysNamed equipment.
5. Place the points in the polyline to finalize the appearance.

2.3.5 Populate Cables

Menu: Drawing > PlanView and Layout Tools > Populate Cables
Default Commandline shortcut: popc
Related Settings:

None
Product Level: ALL

This tool pulls the cables from the Cables table into the drawing. The assumption with this tool is that you will use
it after you have done your functional drawings and assigned Cable Numbers and SysNames.

Related Topics:
Draw Cables

Dialog Options

51
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· Group Cables - Place a single polyline with hash marks to indicate count. All cables that come and go from a
single Location or SysName will be grouped. Otherwise a single polyline for each cable will be added.

Grouped Cable

· Must connect to equipment in the drawing - The population will fail if the connected equipment SysName is
not found. Otherwise the cable will be populated to the drawing based on Location Boundary.

· Ignore cables that come and go to the same location - Keeps the drawing cleaner.
· Flag if other is not found - If both Locations or SysNames are not found in the drawing a flag will be placed

pointing to the other end.
· Polyline Bulge Factor - The bulge factor to create an arc instead of a straight line.
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2.3.5.1 How To: Populate Cables in Planveiw

Prerequisites
1. SysNamed source and destination equipment placed in the Plan View space or:
2. Source and destination Location Boundaries placed in the Plan View space.
3. Cable data in the Cables table that matches the placed equipment or locations.

Operation

1. Open a plan view drawing.
2. Place Location Boundaries.
3. Place plan view equipment and SysName - Optional.
4. Click Plan View and Layout Tools > Populate Cables.
5. Click [OK].

Planview Populate Cables
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2.3.6 Draw Prewire

Menu: PlanView and Layout Tools > Draw Prewire Cable
Default Commandline shortcut: pw
Related Project Settings:

Automatically Consume Prewire Cables
Product Level: ALL

This tool allows you to draw geometry in the drawing that represents cables that have not yet had their functions
assigned. The only thing we know about these cables is the locations from which they start and end and the Cable
Type. A record will be added to the Cables table based on the count defined. The record is marked Available and
PreWIRE. Prewire cables can be automatically consumed later if the Automatically Consume Prewire  setting is
checked.

Prerequisites
1. Source and destination Location Boundaries placed in the Plan View space.

Related Topics:
Draw Cables

Dialog Options

· Cable Type, Signal Type
· How Many - How many wires of this type take this path. A record will be created for each.
· Length Divisor - We will divide the length of the polyline by this value and place that info in the Length field of

the record. For example, say your Drawing Unit = 1 inch and you want the length in the Length field to be
displayed in feet. Your Length Divisor would be 12.

· Create Named Path - Create an entry in the Named Paths table with the name provided and length of the
polyline.

375

51
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2.3.6.1 How To: Draw a Prewire Cable in Planview

Operation

1. Open a plan view drawing.
2. Click PlanView and Layout Tools > Draw Prewire Cable.

3. Fill in the form.
4. Click [OK]. This will dismiss the dialog and prompt you to draw a polyline.
5. Draw the cable path.
6. n Cables will be added to the project Cables table with a formatted number based on the project Cable

Number Format and the Next Numbers table.
7. The polyline length will be divided by the Length Divisor field and added to the cable record Length field.
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2.3.7 Populate Equipment

Menu: PlanView and Layout Tools > Populate Equipment
Default Commandline shortcut: pope
Related Project Settings:

None
Product Level: ALL

There is no UI for this tool.
This tool pulls the Plan View version of the equipment from the Equipment List. 
The assumption with this tool is that you will use it after you have done your functional drawings and assigned
cable numbers and SysNames.
This tool relies on the Plan View File in the device definition to know what to place. 

It relies on Location Boundaries in the drawing to know where to place it.

If the Plan View File is blank the Project Default Plan View File will be placed if the Location Boundary is found:
Application Menu > Settings [Project][Basic][Default Plan View Block File]
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2.3.7.1 How To: Populate Equipment in Planview

Prerequisites
1. SysNamed equipment preferably with an associated Plan View File in the global Equipment Library.
2. Location Boundaries placed in the drawing.

Operation

1. Open a plan view drawing.
2. Place Location Boundaries.
3. Click PlanView and Layout Tools > Populate Equipment.
4. A message box will explain the operation of the function. Click [OK]. The tool will run.
5. At completion the tool will report the number of placed items.

2.4 Reporting

Menu: double-click the report in the Project Explorer or Click the report in the Reports > Reports gallery
Default command line shortcut: none 
Related User Settings:

Report Show Mode - Determines where the reports will be shown:
Project Explorer
Ribbon Menu Gallery
Both

Opens a report for preview, printing or export. Reports are designed to connect to the WireCAD DataAccess object
that provides access to the entire data model both Global and Project data.
There are four tabs presented when a report is loaded:
1. Preview - Shows the print preview that will be output to the selected system printer.
2. HTML - Shows the report rendered to HTML for use in web pages.
3. Design - Shows the report designer.
4. Cable Data Selector - Shows a selector grid for use with the ProjectCables collection. This grid is not

implemented for any other data collection.
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2.4.1 How To: Print Reports

1. Double-click the report in the Project Explorer or Click the report in the Reports > Reports gallery.
2. The report will load in Preview Mode.

3. Click File > Print and select a printer.



WireCAD v9.1 User Manual138

© 2017 Holbrook Enterprises, Inc. dba WireCAD

2.4.2 How To: Print Reports with Parameters

Parameters allow the report designer a way to collect input from the user before the report is rendered. 
Parameters may be used in the report for several purposes:
· Replace title and descriptive text.
· Provide data to filters.
· Provide data to scripts.

The report designer may force the user to submit parameter data or allow the report to render with default data.
If the report has no parameters defined the Parameters menu item will be disabled.

1. Open a report - Double-click the report in the Project Explorer or Click the report in the Reports > Reports
gallery.

2. The report will load in Preview Mode.
3. If the report has parameters the Parameters menu item will be enabled. If the report designer determined the

report must gather parameters first, the report will not render until you click the [Submit] button on the
Parameters tool panel.

Report preview with Parameters tool panel shown

4. Enter parameter data.
5. Click [Submit]. The report will render with the submitted data.
6. Click File > Print and select a printer.
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2.4.3 How To: Filter Reports

By default a report will query the database for all records in the selected collection. For example if the report
displays the project CablesCollection, all records will be displayed. This may or may not be desirable. If you wish
to filter the record set to show a specific set of records you have two choices:
1. If the collection being displayed is the CablesCollection you may use the Cable Data Selector tab and make

a manual selection there.
2. Otherwise you must create a filter.

How To:

1. Open a report.
2. Switch to the Report Designer tab.
3. Locate the Property window. Make sure that the Property window is displayed. If not click: Report

Designer>Windows>Property Grid
4. From the Property grid object selector, select XRReport1

5. From the Property grid select the Filter String [...] ellipsis button.
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6. This opens the filter dialog from which you may select a number of different filters.

7. Select a field to filter on.

8. Select a filter operator.
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9. Enter a value.

10. Click [OK] to commit the filter. This filter with show only cables where the CableNo field begins with V-.
11. Select the Print Preview tab to render the report with the filter.

2.4.4 How To: Filter a Report Using Parameters

Filters may also contain parameters that the user must enter before the report is generated. In order to make use
of this function you must follow these steps:
1. Add a parameter to the report while in Design view. Click the Parameters (...) ellipsis button to view the

Parameters collection.

2. Click the [Add] button to add a parameter to the collection.
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3. Enter description and default value information.
4. Open the filter editor (see above)
5. Add a Field and Operator, then click on the icon to the right of the field to select parameters.

6. Select your parameter from the parameters list. Above we are selecting parameter1.
7. Click [OK] to submit the filter.
8. Now let's make sure that the parameters are submitted before the report renders. Set the Request

Parameters property = Yes.
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9. Click the [Print Preview] tab to preview the report. You will see a Parameters pane on the left hand side
with a submit button.

10. Enter a value and click [Submit].

11. Your report will be rendered with parameter1 applied to the filter.

2.4.5 Report Design

Menu: Report>New Report with Wizard
Default command line shortcut: rw 
Related User Settings:

Report Show Mode - Determines where the reports will be shown:
Project Explorer
Ribbon Menu Gallery
Both
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2.4.5.1 How To: Create a Standard Report

1. Click Reports>New Report with Wizard.
2. Select the Standard Report option. 

3. Click [Next >].
4. Select a data collection. Data collections access both the global and project databases. For example: say you

wanted to show a list of all manufacturers. You would select the GlobalManufacturersCollection.

Note: collections are hierarchical to aid in the creation of sub-reports. All collections are populated with data when
the report is previewed.
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5. Select the fields (columns) you wish to display in the report.

6. Apply any grouping. Each set of records with the same value will become a "group" with its own header.

7. Select a Layout and Orientation for your report. The Adjust field width to fit function will force all selected
fields on to a single page possibly rendering some of the data unreadable. If you have lots of fields to display,
consider using a Justified report.
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8. Select a Report Style. There are several predefine report styles. You can always modify the look and feel later.

9. Title your report.

10. Click [Finish] to create your shiny new report.

11. Click File>Save and save your work to your reports support path. It can be saved anywhere in the %REPORTS
% support path folder tree.
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2.4.5.2 How To: Create a Label Report

1. Click Reports>New Report with Wizard.
2. Select the Label Report option. 

3. Click [Next >].
4. Select a data collection. Data collections access both the global and project databases. Note: In the case of

labels we probably want to use the CablesCollection.
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5. Select a label format. WireCAD comes stock with over 1000 label formats from 15 manufacturers including
Panduit, Hellerman Tyton and Brady.

6. Modify height and width of each label and its printable area and margins.

7. Click [Finish] to create your shiny new report.
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8. Select the Field List and drag any fields that you wish to display on to the report design surface. Avoid placing
field on the light and dark gray areas. The light gray area will not print and the dark gray is indicative of the clear
laminating portion of a cable label.

9. Here we have three fields that we have dragged and positioned on the design surface. We then edited the Src
and Dest fields to concatenate the Pin data as well. Then we edited the font property of the CableNo entity to
bold it.

10. Final output looks like this:

11. Click File>Save and save your work to your reports support path. It can be saved anywhere in the %REPORTS
% support path folder tree.
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2.4.5.3 Report Design Basics

The following topic assumes that you have either opened a new blank report or that you have run the New Report
Wizard.

If you open a new report without running the wizard you will need to set the report Data Member variable. 
Click in the dark gray area to load the general properties. Select the Data Member from the drop down.

You can drag fields from the Field List directly to the report designer.

If you want to concatenate multiple fields in a single label you can drag multiple fields onto the same label or edit it
directly. 
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To edit a label double-click it to enter edit mode.

Type directly into the label. Field names must be enclosed in [] brackets.

2.5 Frequently Asked Questions

2.5.1 How To: Place Custom Titleblocks (Page Borders)

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: insert
Related Settings:

None

This tutorials assumes you have a custom titleblock in dwg format and that it occupies the Model Space of the
dwg file. Further that you know the path to the file containing the titleblock file.

1. Open the drawing where you want to place a custom titleblock.
2. Switch to the Layout in which you intend to place your custom page border.

3. Click CAD Tools>Blocks and Inserts>Insert  Block into Drawing.

4. Select [Browse].
5. Browse to the dwg that contains your custom title block in the Model Space.
6. Check Insertion Point - Specify Later. This will let us manually place the inserted block in the layout

space.
7. Uncheck Scale - Specify Later and set the X,Y,Z scale to 1.
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8. Uncheck Rotation - Specify Later and set the Angle to 0.
9. Click [Insert It].

10. The dialog will be dismissed so you can drop the insert in the drawing space.
11. Now you will need to place a Viewport so you can see the model space.
12. Click View>New Viewport and select the logical boundaries of the viewport within the titleblock you placed

earlier.

13. Double-click the viewport to activate it for zooming and panning and use the mouse wheel or zoom commands
to position the viewport over the model space.
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2.5.2 How To: Create Custom Titleblocks

Menu: CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: insert
Related Settings:

None

1. Create a new drawing with no template.
2. Draw your titleblock in Model space scaling it 1:1 with your printed page size, ie an 11x17 page border would

be 11x17 minus your margins.
3. Place any images and attribute definitions.
4. Save the drawing.
5. Follow the steps here  for placing your title block drawing in any other drawing.151
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2.5.3 Moving Projects (Pack Up/Check-Out)

Menu: Application Menu > Project Utilities>Packup / Check-out
Menu: Application Menu > Project Utilities>Unpack
Menu: Application Menu > Project Utilities>Check In

Default command line shortcut: packup
Default command line shortcut: checkinproject

When moving projects from machine to machine there are external items upon which the project depends. These
are referred to as project and drawing dependencies. The main project dependency is the global equipment
database. Drawings may have image, Xref, and font dependencies. When we Pack Up a project we are grabbing
all of those dependencies (fonts are and exception and are not included) and placing them in the Project folder. We
may choose to Check Out the project at the same time. This flags the project as read only until such time as the
project is Checked In.
Once Packed Up and/or zipped up you are ready to move the project to another machine. Simply copy the Project
folder or the zipped file and move it to the new machine. Then use the Unpack function.
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To Unpack or Check In - That is the Question

The two functions are practically identical with the exception that the Check In function won't launch without an
active project and once unpacked will mark the active project as Checked In.
Whether you Unpack or Check In a project depends on whether you are moving a project to a machine on which
that project already resides and whether you have Checked Out the Project.

If you have not Checked Out the project then there is no need to Check In the project.
If you are moving a project to another machine, use the Unpack function.
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2.5.3.1 How To: Packup/Check-out

Decide whether you are going to Check Out the project before starting.
1. Open the project to Pack Up/Check Out.
2. Click Application Menu > Check In/Out > Pack Up/Check Out.
3. Click [Next] after reading the explanatory text.
4. If you opt to Check Out the project you will be prompted to enter an Expected Return Date. This will let

anyone opening the project subsequent to its Check Out who checked it out and approximately when it will be
back. In the mean time it will be opened READ ONLY.

5. If you opt to Compress Output the final operation will be to create a zipped file of the project folder and place it
in the FileName and Path location.

6. Click [Next]. You will be presented with the progress page.
7. Click [Finish].

2.5.3.2 How To: Check In a Project

To Check In a project you must first have the project that we are checking into open.
The incoming project should be in a file location that is not the current project path.

1. Open the project into which we will check in the incoming project.
2. Click Application Menu > Check In/Out > Check In Project.
3. Click [Next] after reading the explanatory text.
4. Browse to the incoming project's .wpi file by clicking the [...] ellipsis button.
5. Click [Next]. This presents the progress page.
6. Click [Finish]. Wait for the process to finish.

2.5.3.3 How To: Unpack a Project

To Unpack a project you must not have an open project.
The incoming project should be in a file location WILL BECOME the current project path.

1. Close the current project if any.
2. Click Application Menu > Check In/Out > Unpack Project ...
3. Click [Next] after reading the explanatory text.
4. Browse to the incoming project's .wpi file by clicking the [...] ellipsis button.
5. Click [Next]. This presents the progress page.
6. Click [Finish]. Wait for the process to finish.
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2.5.4 Synchronizing with Another Equipment Database

Menu: Database>Synchronize Global Database ...
Default command line shortcut: sync
Related Settings:

None

Occasionally you may experience the need to sync with another user's global database. This will copy all of their
equipment to your Global Equipment Database. The sync includes manufacturers, equipment, inputs, outputs,
signal types, connectors, cable types, cable core data, relational tables, etc. 

You may choose within the tool to perform an import, export or bidirectional sync.

Demystifying Synchronization
Synchronizing data in two tables of the same structure is really very simple. In its most basic form, records that do
not exist in one table are added. Records that exist in both tables receive the most current data based on a time
stamp. In order that records deleted from one table do not get added back in, a special table is employed to track
deleted keys. If the delete is the most current action then the record will likewise be deleted from the other table. In
the unlikely event that the records have the exact same time stamp, yet the data is different, those records are
flagged as conflict records from which you must pick the most correct. 

Controls

Basic tab
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Advanced tab

· Database Location - Select either a VistaDB file based database or a SQL Server host. If server based you will
need to provide host and credentials. If you do not know them contact your SQL Server database administrator.

· Import, Export, Bidirectional - Sync direction. Our current global database is the reference. An Import will
import records into our current global database.

· Remember Settings - Remember database location information.
· Sync - Initiates the synchronization with the top progress bar showing the overall progress and the bottom

showing detail progress. 
· Status Bar - Displays status of the sync.
· Advanced Tab - Select the collections to be synchronized.
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2.5.4.1 How To: Sync Equipment Databases

Remember that the Sync Direction is with respect to the current Global Database.

1. Click Database > Sync Global Databases ...
2. Browse to the remote WireCADGlobalEquipment.vdb3 file or enter the SQL host and login for the other SQL

server.
3. Set the Sync Direction.
4. Click [Sync].
5. Wait for the process to finish.
6. When done you will be presented with a status report. Examine it to make sure that all collections

synchronized properly.
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2.5.5 Setting Up On a Network

What follows is a discussion of several different network topologies and work flows that WireCAD can employ.
Regardless of topology or work flow, the following steps should be taken for each WireCAD machine. For purposes
of this discussion, we will distinguish between a Windows user (operating under group policy or not) and the
WireCAD user. The Windows users will be referred to as OS users. WireCAD users will be referred to as WC
users.

1. Install WireCAD
2. Create a network share that is visible to all WireCAD users. Group policy for the OS user of WireCAD should

allow the user to read and write the registry (restriction of the registry editor is acceptable), as well as, read and
write files on the selected shares, the WireCAD9 folder on the client machine, the OS user's temp directory,
the OS user's All Users documents and settings folder trees.

3. Pick one WireCAD client machine from which to copy the global databases and copy from ...
\WireCAD9\WireCADGlobalEquipment.vdb3 to \
\YourNetworkShare\FolderForWireCADGlobalDatabases\WireCADGlobalEquipment.vdb3

4. Launch WireCAD on the client machine.
5. Click Application Menu > Settings{Support Paths}
6. Modify the support paths for the Global Equipment database, and any blocks or reports that you wish to

share among all users.
7. Click [Done] and relaunch WireCAD.
8. Click Application Menu > Security>View Permissions. If you are an administrator or rather if your WireCAD
identity is that of an Administrator, you will have edit abilities on this grid.
9. WireCAD uses your Windows groups. You assign permissions to the group. The current user Identity is set to
the group thus determining their access level.
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2.5.6 Upgrading from v8

If you are upgrading from v8 you will need to take the following steps:
1. Install WireCAD v9
2. Setup your global databases (file based or SQL Server)
3. Click Database > Sync Equipment Libraries
4. Click the ellipsis (...) and enter the path to the v8 WireCADGlobalEquipment.vdb3 file or set the SQL Server

Host info.
5. Click the Import radio button.
6. Click [Sync] to sync the two databases.
7. Next convert any projects that you want to work with in v9
8. Click Application Menu > Open Project and browse to your v8 <YOURPROJECTNAME>.wc6plf file.

WireCAD will open and convert the project. When WireCAD converts projects no drawings are touched. The
database schema is modified.

Note: this may take some time 

WireCAD can no longer upgrade a v5 or earlier project. Key data access components
needed to open and import data from the Microsoft Access databases are no longer
available for modern 64bit operating systems.

If you need to bring a v5 or earlier project forward we recommend using a 32bit XP virtual
machine with WireCAD v6 installed. Convert the project to v6. Then open it in v9 once
converted.

We offer this service if you get in trouble. Call us.
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2.6 Choosing a Database Format

WireCAD v9 PRO and ENT allows the use of file based and server based databases for the project and global
databases. The choice of which to use requires some forethought. Listed here are some basic considerations:

SQL Azure SQL Server VistaDB (File Based)

Zero Administration X

Portable X

ACID Compliant (atomicity,
consistency, isolation,
durability)

X X X

Database Size 2 Gig Theoretically unlimited Theoretical limit is 16
Exabytes (uint64). 

Practical limit is based
upon machine resources. 
Files are not limited by the

database engine, but
loading very large

databases will require large
system resources. 

In Process Processing X

Cloud Based X

At first glance that the table above it would seem that the proper choice would be the file based solution.
However, take note of the item - In Process Processing means that the WireCAD processes must read and write
all data to and from the file based database. Using SQL Server allows us to hand those processes off to the
database server creating, in many instances, a significant (read 10X) increase in speed.

Before selecting a database format consider the following questions:
· Will I be moving the project from machine to machine? If yes, consider staying file based on the project.
· Do I have the chops to manage a SQL Server? If no, stay file based. SQL Server requires care and feeding.
· Am I away from my network when I work on WireCAD projects? If you lose connection, WireCAD will become

hampered.
· Do I really need the speed enhancements? If you are working on projects with hundreds of thousands of

cables, SQL Server is a must.

When you move a project using the Application Menu > Utilities>Pack Up/Check Out function and you are
using SQL Server databases, the database is converted to a file based version and will remain file based from
that point forward.

To set up SQL Server see here

Need help with SQL Azure? Contact us we can help.

163
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2.6.1 How To: Setup a SQL Server

It is not within the scope of this manual to provide an in depth discussion of SQL Server. We will touch on the
basics required for use with WireCAD. 

The WireCAD distribution includes SQL Server database files for the Global Equipment database. You will need to
attach these to the running server. You will then configure WireCAD to look at the SQL Server for the Global
Equipment database. WireCAD projects will create a new database (catalog) for every new project.

You will need to set up permissions for each user to allow them dbcreator privileges. This is the default for
localhosts but not remote servers.

SQL Server can be set up on a server or on a local machine. WireCAD requires the 2005 version or newer and can
use the Express versions.

SQL Server does not provide a graphical user interface so you will want to download the SQL Server
Management Studio Express as well. Both are free.

The following assumes that you are installing WireCAD on a local machine. If you are installing on a server you will
want to copy the global database files in Step 6 below to the server before you attach them to the server.

1. Install SQL Server. You can download from the following links:

https://www.microsoft.com/en-us/download/details.aspx?id=21844

Be sure to download SQL Server Management Studio Express as well. Both are free.
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-

5a0f62bf7796&DisplayLang=en

2. You will be prompted for an instance name. Instance names allow you to have multiple SQL Servers running on
the same machine. In addition you will be prompted for a security mode (Windows or SQL), Windows uses
your Windows users and groups, SQL ignores these and allows you to manage different users and groups from
within SQL Server.

3. Install SQL Server Management Studio(SQLSMS).
4. Launch SQLSMS and log in to the server. If the server is on your local machine you can use the shorthand [.

\INSTANCENAME] (eliminate the square braces) for the Localhost.
5. Setup a proper login for WireCAD. You may elect to use Windows logins or not. It is beyond the scope of this

manual to describe the pros and cons of each authentication method.
6. Attach the WireCADGlobalDatabase.mdf file to the server.
7. You will now need to configure each WireCAD client to look at the SQL Server
8. Launch WireCAD.
9. Click Application Menu > Application Setup and follow the steps for SQL Server.

See Also

www.wirecad.com/wiki search SQL Server

msdn.microsoft.com search SQL Server

https://www.microsoft.com/en-us/download/details.aspx?id=21844
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-5a0f62bf7796&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-5a0f62bf7796&DisplayLang=en
http://www.wirecad.com/wiki
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2.7 Included Plugins

WireCAD includes a number of Plugins that provide additional functionality.

Each plugin will load and register its own command line commands if the plugin provides command functionality. 

For information on customizing WireCAD with your own Plugins see the SDK  documentation and the SDK
samples.

2.7.1 Pinouts

Menu: Database>Pinouts
Default command line shortcut: po
Related Settings:

None

The Pinout utility serves two functions. The first is to generate pinout detail drawings.

The second is to generate data that can be used in the conductors table under any cable that we wish to attach
the data to.

585
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2.7.2 Find and Replace

Menu: View>Tool Panels - Find
Default command line shortcut: none
Related Settings:

None

The Find and Replace tool window allows you to search all of the data collections and drawing. You may then
replace found text with that of your choosing.

The Find and Replace tool shows you the context in which the text was found. You can select from the results list
which items to replace.

· Find - The text to search for.
· [X] - Clear the Find text.
· Search Active Drawing - Only look in the active drawing.
· Search All Project Drawings - Search every project drawing.
· Show File - Show file name if any of the context in which the item is found.
· Show Item Type - Is it a text entity in a drawing or a field in a database.
· [Select All] - Selects all items in the results window.
· [Clear Selection] - De-selects all items in the results window.
· Replace With - The text to replace the found text with.
· [Replace Selected] - Initiate the replacement.
· [Cancel] - Cancels the current search.
· [Find] - Initiate the search.
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2.7.2.1 How To: Find and Replace a Port Name

In this section we will discuss the finer points of finding and replacing text in WireCAD blocks.

Before You Start
When you see a WireCAD block in a drawing it is referred to as an Insert. WireCAD blocks employ Attributes to
display the text values you see. These Attributes are editable. For every port you see in a WireCAD block there is
at least one invisible attribute at the connection point. This attribute contains a pipe | delimited string formatted as:
PORTNAME|SIGNALTYPE|CONNECTOR
In addition to the connection point attribute there may be a Port Name display attribute.

If you change the display attribute WITHOUT changing the connection point attribute you
WILL have grief later. So ALWAYS changed both the display attribute and the connection
point attribute concurrently.

1. Let's say we want to replace SDI IN on our device with SDI IN A. Further that we have assigned cable
numbers to the port in question. We will only look in the active drawing so click the appropriate radio button.

2. Enter SDI IN in the Find field and click [Find]. Wait for it....
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3. Notice that we have two attributes and a cable all associated with the port SDI IN. If we don't change all of
these we will have data integrity issues later.

4. Click [Replace Selected].
5. Done.
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2.7.3 Translation Manager

Menu: Plugins>Translation Manager
Default command line shortcut: 
Related Settings:

None

All strings in the application are stored in a dictionary with a key and current culture translation.
The translation utility provides a means by which all strings, captions, and messages may be translated to a
different language.

You can right-click a column header and select the KeyString column to see the base English string that the
program searches from.

Controls

Here we see the Translation manager with the
English version on the left and the French

version on the right. The pane on the
right-hand side shows statistics.

· Current Culture is: - The culture of your machine. If no translation exists, WireCAD defaults to the en (English)
language.

· Select Language To Translate - Selects the language to edit in the right-hand column.
· Show Context - Select to display a column showing the primary context in which the string or message

appears.
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2.7.3.1 How To: Translate a Form Caption

Here we will use the Translation Manager to change the User1 field on the SysName Assignment dialog to display
Serial Number.
We are starting with:

1. Click Plugins > Translation Manager.
2. Enter sysnameuser1 in the KeyString filter field.

3. Change User1 to Serial Number in the en field.

4. Click File > Save.
5. Now let's check the result by showing the form.
6. Open a drawing with a functional block.



WireCAD v9.1 User Manual170

© 2017 Holbrook Enterprises, Inc. dba WireCAD

7. Double-click a block.
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2.7.4 Block Extractor

Menu: Plugins>Extract All Blocks
Default command line shortcut: exall
Related Settings:

None

Requires an active drawing.

· Extracts all blocks in the current drawing to the folder of your choosing. 

· Files are written out of the drawing as individual dwg files with the name of the block. 
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· The basepoint of the drawing (origin) is the insertion point of the block.

2.7.5 Bulk Block Fixer

Menu: Plugins>Bulk Block Fixer
Default command line shortcut: blkf

The Bulk Block Fixer utility provides a means by which dwg files may be easily converted for use with WireCAD.
The fixer will convert a single drawing or all drawings in a folder.

Bulk Block Fixer Dialog
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· Bulk Convert All Files In Folder - Checked performs selected options on all files in selected folder.
· Basepoint Position - 

Don't Move - Do nothing.
   Move All Entities To Lower Left Basepoint.

Before After

Move All Entities To Center Basepoint. 

Before After

· Scaling - Scales all drawing objects based on the selection.
· Intelligence/Appearance

Add WireCAD Attributes. - Use this function to add the standard WireCAD attribute set to the dwg file.
This makes inserted items double-click-able. This is not required, and should not be used, if you are using the dwg
file as a DWGIcon or Custom Shape file.

Create Bounding Box - Creates a rectangle around the entities in the dwg file of the color selected. This
is useful for DWGIcons or Custom Shape files

· Copy - Copies fixed block files to the selected directories. \Subfolder and Prepend allow you to modify the
location and filename upon copy.
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2.7.5.1 How To: Use a Manufacturer Front Panel

1. Obtain the manufacturer's front panel dwg file.
2. Open the file in WireCAD and delete anything that is not related to the front panel view.
3. Close the drawing.
4. Click Plugins > Bulk Block Fixer ...
5. Uncheck Bulk Convert All Files in Folder.
6. Click the Single File Path [...] and browse to the manufacturer's front panel file.

7. Select Move All Entities to Lower Left Basepoint.
8. Select Add WireCAD Attributes.
9. Click [OK].
10. Open the Equipment Library.
11. Find the equipment that we want to use our shiny new front panel
12. Set the Front Panel File to point to our file.
13. Click File > Save.
14. Now you can use it.
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2.7.6 Batch Plot

Menu: Plugins>Batch Plotter
Default command line shortcut: bp
Related Settings:

None

The Batch Plot plugin allows you to select any number of layouts to print from project drawings.
The first step is to click the [Rescan] button. This populates the list with all drawings and layouts.
The Plot This checkbox determines which layouts to send to the printer.
The [Plot/Print] button is the same as the File>Plot/Print menu command and sends all selected layouts to their
respective printers.
The [UP] and [Down] buttons move the selected layout up or down in the list thereby reordering their output order.
 
If you want to delete a layout. Select the layout in the list and click the minus [-] button in the navigation window in
the lower left hand corner of the grid

 
Clicking the [Preview] button will preview the selected layout in the Preview Pane regardless of whether it is
selected to in the Plot This column

What it Does

· Batch Plot lets you select the drawings and layouts that you want to send to the printer and print them as a
batch. 

· You may print any layout in any drawing in the current WireCAD project. 
· You may also specify how many copies and in what order to print.
· Batch Plot allows you to save Batch Plot files for reuse at a future time.
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What's New in V9

· Batch Plot now supports output to multi-page PDF.
· Batch Plot now saves the selected print settings with the plot file.

What it Doesn't Do

· Batch Plot does not print project reports.
· Batch Plot does not collate layouts with multiple copies set.

Controls
· Full Preview - Render actual output. Otherwise show margin box.
· Preview On Plot - Render the full preview (full or not) on output to the printer/plotter.
· Use Layout Settings - Ignore the Batch Plotter settings and use those stored with the drawing layout. Selecting

this disables printer, paper, and margin settings in favor of those in the layout.
· Paper - Printer paper size. If this dropdown is empty, select a printer first.
· Margins - Set your margin unit of measure first, then the left, right, top and bottom.
· Black and White - Output in black and white.
· Scale to Fit - Force all entities in the selected layout onto the page.
· Extents - Print the extents of the layout.
· Landscape - Landscape output.
· Select Printer - Choose the printer that all selected layouts will be sent to.
· New Batch Plot File - Creates a new file scanning the project drawing set and adding all drawing and all

layouts.
· Open Batch Plot File - Opens a saved Batch Plot file.
· Save - Saves your settings to a Batch Plot File. This is helpful if you change the default order of the list or the

number of copies, etc.
· Save As - Save your setting as a new file name.
· Print/Plot Selected - Prints the selected (Plot This) layouts to the printer settings determined in the layout. So

be sure to Print Preview (from the drawing layout) your layouts first and set up all of your output settings.
· Export Multipage PDF - Output the selected (Plot This) layouts with the selected printer settings to a

multipage PDF document.
· Cancel Queue - Stops the function. Does not purge any print jobs already in the windows print queue.
· Exit - Done.
· Rescan - Clears the list and re-scans the project drawings for all layouts. This function is like the File>New

function but differs in that it does not create a new file name.
· Add Drawing - It may be desirable to keep all of your settings and add an additional drawing to the list.
· Remove Layout - Removes the selected layout.
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2.7.7 Archive Project

Menu: Project>Archive Project
Default command line shortcut: ap
Related Settings:

None

The Archive tool copies all of the project data except the drawings in the Project\Archive folder to a new folder. The
tool can also create a new CurrentProjectRevision at the same time.

The archived version of the project:
· Copies the drawings and databases.
· SQL databases are archived as VISTADB databases.
· Global and Project databases are included.
· The Project\Archive\ drawings folder is ignored.
· Gives you the choice to increment the CurrentProjectRevision .

The associated settings panel controls:
· The Archive path.
· The Archive name.
· Automatic naming or user involvement.
· CurrentProjectRevision inclusion.

The output of the archive tool creates a Packed-Up Project that can be unpacked or checked-in.

Restoring an archived project can be done using the UnPack function or the Check-In function.

Related Topics:
Project Archive Tool Settings
Unpack Project
Check-In Project

519

384

344

345
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2.7.8 DWG Diff

Welcome to the DWG Diff Help File
 
DWG Diff is a utility that displays the differences (and commonalities) between two dwg drawings.
 

Features:
 
· Open, View, Print dwg files.
· Difference the selected layout.
· Display Common, A not B, B not A drawing elements.
· Displays not only the drawing entity differences but also lists difference in the drawing structure such as:
       Layers
       Layouts
       Text Styles
       Blocks
       Dimension Styles
 
· Save the differenced drawings as dwg or pdf.
· Print the differenced drawings.
· Control the layers.        
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2.7.8.1 Screen Shots

Drawing A

Drawing B



WireCAD v9.1 User Manual180

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Common to Both

Entities in A but not B

Entities in B but not A
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2.7.8.2 Functions

Menu Items
File>Open A: Open the A drawing.
File>Open B: Open the B drawing.
 
Tools>Calculate Differences: Does the work.
       
Compares the selected drawing space eg: Model or Layout.

 
View>Zoom Extents: Zoom the selected space to the extents of all entities.
 
Help>Help: Displays this file.
Help>Software Activation... : Displays the activation screen.
Help>About: Displays the about screen that show version information etc.
 
 

Right-click Context Menus
The following menus are available from all drawing spaces:
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2.7.8.3 Command Line Instructions

You can call DWG Diff from a command line or script and pass in filenames for the A and B
drawings as well as output filenames.

The following is the command line usage:

dwgdiff.exe a="<Your A DrawingFilePath>" b="<Your B DrawingFilePath>" m=[i]mmediate | m=[w]ait

| m=[s]ilent

a="<Your A DrawingFilePath>" - this is required if you are passing in variables to the command
line.
b="<Your B DrawingFilePath>" - this is required if you are passing in variables to the command
line.
m=[i]mmediate | m=[w]ait | m=[s]ilent - required.
opA="<Diffed Output Filename and Path A not B>" - Optional Output File.
opB="<Diffed Output Filename and Path B not A>" - Optional Output File.
opC="<Diffed Output Filename and Path Common>" - Optional Output File.

a=, b=, op=A, opB=, opC= should be quoted strings if the file paths contain spaces. They
should also contain fully qualified file names with extensions.

The variable order is not important.

MODES
m=s opens drawings calculates differences and outputs any of opA, opB, or opC if any; also
runs silently without the user interface being shown.
m=i will immediately calculate differences.
m=w will wait for you to click Tools>Calculate Differences once DWG Diff is open.
both m=i or m=w show the user interface.

EXAMPLES

Open two drawings and calculate the differences:
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=i 

Open two drawings and show the user interface and wait for you to press Tools>Calculate
Differences:
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=w

Open two drawings, calc diffs and write out the AnotB differences. Does not show UI.
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=s opA="c:\my Output A

Drawing.dwg"

Open two drawings, calc diffs and write out the AnotB, BnotA and Common drawings. Does not
show UI.
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=s opA="c:\my Output A

Drawing.dwg" opB="c:\my Output B Drawing.dwg" opC="c:\my Output Common Drawing.dwg"
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2.7.9 Brother P-Touch!

Welcome to the WireCAD plugin for Brother P-touch Electronic Label printers. This plugin supports
any of the P-touch printer drivers for Windows, and works in conjunction with the stock P-touch .lbl
template formats.

For best results this plugin should be installed in conjunction with at least one P-touch printer driver
(follow the instructions with the printer) and the P-touch editor v4.1 or better. For the latest drivers and
software, visit the Brother website at www.brother.com

 

In order to work properly the Brother_PTouch.Plugin.dll file and support folders must be installed in the
WireCAD6\bin folder. Place the BrotherPTouch.wpi file in C:
\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins folder.

 

The minimum WireCAD build version to work with this plugin is 6.0.1400

 

This plugin assumes that you have data in your Project Cables or Project Systems database.

http://www.brother.com
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2.7.9.1 Data Page

This plugin has the ability to pull from either the Project Systems database or the Project Cables
database. Upon selection of the desired database, you have the ability to apply filters to narrow the
selection set. These filters work like the other filters in WireCAD. Click the <Edit Filter> button and the
filter dialog will be displayed; then select the field, conditional operator and value. Next click the <Apply
Filter> button.
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Table: Combo. Selects either the Cables database or the Systems database.

Note: the data grid is read only.
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2.7.9.2 Print Cable Labels and Port Tags

From this page you select the template file into which you will print the selected data.

 

 

Template File: listbox enumerates all *.lbl files in the {WireCAD Common App Data}\Plugins\Brother
Ptouch\Templates\ folder.

<Preview>: Load the selected record into the selected template file and display it.

<Print All>: Prints the entire recordset to the printer.

<Print This>: Prints the selected record.

<Edit>: Launches the P-touch editor (if installed).

Copies: Textbox: Enter the number of copies to print.

Preview: Pane. Displays a preview of the selected record.

Record Selectors:

Navigate through the recordset.
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Printer Options:

Half Cut: If supported on the printer, will only cut through half of the label creating a roll of labels that
can be torn off in the field. This is available on the industrial series printers like the PT-9500 and is
really slick.

Chain Print: No space between label prints, nor feed or cut at the end.

Cut Mark: Prints a cut mark.

Mirroring: Inverts text.

 

 

Note: the .lbl file contains the info for the printer for which it was created. If you have multiple P-touch
units attached to your computer, the report will attempt to print to the unit defined in the .lbl file.

2.7.9.3 Database Field Rules

This plugin extends the capabilities of the .lbl file. The plugin will evaluate field expressions and
insert(merge) text values from any of the database fields into the label.

In order to evaluate properly, the field name must be enclosed in square braces [fieldname].

Text that is not to be replaced is entered normally.

Text that is to be evaluated and replaced is contained in a string that starts with the = symbol and
contains at least one field definition.
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In the above example, the text strings "Alias:" and "SysName:" will print as shown. The text strings
starting with the = symbol will be replaced by the data from the fields in the current record.

 

Further, assuming that the field [alias] contains the data "3/4-01" and the field [sysname] contains
"3/4-01", the label will print as follows:

Any characters not enclosed in square braces "[ ]" will be printed as shown.
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2.7.9.3.1  Cable Number Fields

The following is a list of the available Cable Number fields that are available for use in the label:

· Available - True/False. True = the cable number is available and will show up in the available cables
list of the Verify Settings dialog.

· AvailableCores - True/False. Depreciated. Not used.

· CableID - Unique Key. If this is visible, do not change it. Depreciated. Not used.

· CableGUID - Unique Key (GUID)

· CableNo - The cable number. See the Project Cable Number Format Dialog.

· CableNoPrefix - Used with V3 cable number format.

· CableNoSuffix - Depreciated. Not used.

· CableType - Cable part number

· CableTypeManu - Cable manufacturer

· CktDst - Future. Do not use

· CktID - Future. Do not use

· CktNo - Future. Do not use

· CktSrc - Future. Do not use

· CreatedBy - Who made the cable.

· DateModified - When entry was modified last.

· DateOriginated - When entry was first created.

· DestConn - Destination Connector

· DestLoc - Destination Location

· Destpin - Destination Port

· DestSys - Destination SysName

· DstAlias - Destination Alias

· Integrator - User field.

· Length - Manually enter a length or assign a named path and automatically generate a length.

· Multicore - True/False. Is it a Multicore cable

· NamedPath - A named path. See the Named Paths database.

· ProjectRevision - Inherited from the Global Projects database.

· ReplacedBY - Not used.

· SHEET - The drawing file name.

· SignalType - Signal Type

· SRCAlias - Source Alias

· SrcConn - Source Connector

· SrcLoc - Source Location

· SrcPin - Source Port



WireCAD v9.1 User Manual190

© 2017 Holbrook Enterprises, Inc. dba WireCAD

· SrcSys - Source SysName

· User1 - It's up to you.

· User2 - It's up to you.

· User3 - It's up to you.

· User4 - It's up to you.

2.7.9.3.2  SysName Fields

The following is a list of the available SysName fields that are available for use in the label:

· Alias - The friendly or functional name for this device

· CurrentProjectRevision - Inherited from the Global Projects database.

· DateAdded - The date created.

· DateModified - Last Modified.

· Elevation - The Elevation element of the location data.

· EquipmentName - Equipment Name

· IsSequential - Reserve a sequential number for each input and output regardless of connection
state. Not currently used.

· Location - The Location element of the location data. The Location and Elevation fields will be
concatenated together using the System Location Delimiter to create the Location data. ex Room
101.Wall, or 101-11.12

· Manufacturer - Manufacturer name.

· SysName - The name element of the sysname.

· User1 - For you.

· User2 - For you.

· User3 - For you.

· User4 - For you.
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2.7.9.3.3  More about the .LBL f ile

The lbl file is Brother's template file for the P-touch electronic labeling systems for PC. Therein you
define the look of the printed output.

 

Some important points to remember:
1. The lbl file contains printer specific information.
2. If the printer for which the lbl file was created is not found on your machine and you have only one P-

touch printer driver on your machine, the label will print to that machine.
3. If you have multiple P-touch device drivers installed on your machine and the one for which the lbl

file was created is not found you will receive an error stating that the printer cannot be found. Switch
to the P-touch editor and change the printer settings to one of the installed drivers.
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2.8 Project Rules

WireCAD 9 allows you to define project specific rules.
There are four contexts in which rules will be evaluated. Rules are contained in the Project Rules grid.
Rules can be enabled/disabled by use of the Project>Settings[Project Rules] Enable Project Rules setting.

A Rule consists of:
1. The Expression to evaluate.
2. The Context in which to evaluate the expression.
3. The ExecutionOrder. If multiple rules are defined to evaluate within the same Context they will be evaluated in

the ExecutionOrder order.
4. A Description of the rule.

Rule Contexts:

1. AssignCableNoAssignBeforeEdit - executed during a new Cable Number Assignment or existing Cable
Number Edit before the dialog is shown.

2. AssignCableNoAssignAfterEdit - as above but after the user has clicked Save on the dialog or if Verbose
Cable No Assignment = false then during the Cable save process.

3. AssignSysNameAssignBeforeEdit - executed during a new SysName Assignment or existing SysName Edit
before the dialog is shown.

4. AssignSysNameAssidnAfterEdit - as above but after the user has clicked Save on the dialog or if Verbose
SysName Assignment = false then during the SysName save process.

Example

Let's assume that you have the following requirements:
1. SDI SignalType where the Length > 100 should use a different CableType than the default defined in the Project

Signal Types Default Cable Type grid.
2. We want to modify the connector type from BNC to KINGS 2065-10-9 if the CableType is 1694

For requirement number 1 we will create a new rule as follows:
· Context - AssignCableNoAssignAfterEdit. We use this so that we can get the Length from the user.
· Expression - (SignalType = 'SDI' && Length >=100) then set CableType = '1694'
· Description - My First Rule. Change cable type for SDI if over 100. This is descriptive text for you and your

team. It can be whatever.
· ExecutionOrder - 0. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0 will not

execute.

For requirement number 2 we will create two rules as follows:
· Context - AssignCableNoAssignBeforeEdit. We use this so we can see our changes in the edit dialog.
· Expression - (SRCConn = 'BNC' && CableType = '1694') then set SRCConn = 'KINGS 2065-10-9'
· Description - BNC to Kings
· ExecutionOrder - 0. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0 will not

execute.

· Context - AssignCableNoAssignBeforeEdit. We use this so we can see our changes in the edit dialog.
· Expression - (DestConn = 'BNC' && CableType = '1694') then set DestConn = 'KINGS 2065-10-9'
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· Description - BNC to Kings
· ExecutionOrder - 1. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0 will not

execute.

2.8.1 Expression Syntax

(true part [ boolean other true part ]) then set SomeProperty = 'SomeStringValue' [else set

SomeProperty = 'SomeOtherStringValue']

syntax in [] is optional

Description Syntax Example

Single part boolean
that sets a property
if true

(1=1) then

set

PropertyNa

me =

'string

value'

Assume the property we want to test is the SignalType field and if true then
change the CableType to equal 1505
(SignalType = 'SDI') then set CableType = '1505'

Multipart boolean
AND that sets a
property if true

(1=1 &&

2=2) then

set

PropertyNa

me =

'string

value'

Assume the property we want to test is the SignalType field AND the Length
field and if true then change the CableType to equal 1505
(SignalType = 'SDI' && Length > 100) then set CableType = '1505A'

Strings 'some

string'

Numbers 1001

Boolean AND && this and that then (1=1 && 2=2) then ...

Boolean OR || this or that then (1=1 || 2=2) then ...

Equality =

Test Null is null (SomeProperty is null) then ...

Set a Property
(Assignment)

set

PropertyNa

me = 

(1=1) then set NumericPropertyName = 1000 or  (1=1) then set

StringPropertyName = 'string value'

Wildcard (any from
here)

% Used in conjunction with the LIKE operator (CableType LIKE '1505%') then
... will evaluate to true for any value that starts with 1505

Wildcard (any one) ? Used in conjunction with the LIKE operator (CableType LIKE '1505?') then
... will evaluate to true for any value that starts with 1505 and has one and only
one additional character.

Limitations

This syntax has no block structure. If you need to execute multiple set property operations you will need to create
multiple rules.
Illustration
The following is NOT supported:
(true) then 

something;
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something else;

some other thing;

else

another thing

or another thing

Consider creating a plugin in the SDK if you need to create very complex rules. There is a Project Rules Events
project template to use as a prototype to get you started.
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The WireCAD ENT CMS tools are built upon and extend the WireCAD PRO tool set for
the documentation of large scale management of the fiber systems.
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3 WireCAD ENT Tools Manual

This section pertains to the ENT product level.
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3.1 ENT Tools Concept

WireCAD v9 with ENT tools has introduced the ability to work in a different manner from previous versions of
WireCAD.

The standard work flow for WireCAD users has been to create your Functional Block Diagrams first, then assign
SysNames and Cable Numbers and lastly, generate reports based on this information. 

WireCAD v9 ENT allows you to start by entering your SysNames and Cable Numbers into the Database first,
create Backbones and Circuits and then generate a Functional Block Diagram based on the information set in the
Database. 

The ENT tools work on a declare then visualize approach. You tell the database that the thing exists and WireCAD
provides different ways to visualize the data in the database.

If the database item of interest is a fiber patch panel you can visualize all connections to and from that panel.

If the database item of interest is a fiber backbone you can visualize as one of the following:
· Riser Diagram
· Ladder Diagram
· Map
· GPS Calibrated (Geo-Referenced) DWG drawing

If the database item of interest is a circuit you can visualize as:
· Circuit Functional Block Diagram
· Map

WireCAD ENT also provides the capability to view your fiber infrastructure in Map view. Using GPS coordinates you
can view your plant fiber layout, where fiber patches and panels reside as well as path data for run way-points such
as manholes and pull-boxes. You can use the built in Map tool or use your dwg plant drawings (you must 
calibrate  the drawing to the GPS coordinate system first).

You can use WireCAD ENT to manage your fiber and copper infrastructures. WireCAD tracks every strand of fiber
and every CATx cable and jumper/cross-connect.

265
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3.2 ENT Basics

The following subjects assume that you understand basic WireCAD procedures:
· Adding Equipment to the Equipment Library
· Adding Signal Types.
· Adding Cable Types.
· Assigning SysNames.
· Adding Locations.
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3.2.1 Backbones

This is a step by step guide on how to create Backbones. Backbones are represented in the cables database by a
collection of cables.
Each cable in the backbone has the same Cable Number Prefix. When you create a new Backbone you are
creating a collection of cables based on the selected Cable Type. If you are documenting fibers think one fiber
equals one core/conductor/cable. backbone cables are flagged with the boolean value isBackbone = true. Doing so
distinguishes a cable as being part of a backbone structure.

Open the Backbones grid by double-clicking the icon in the Project Explorer [Project Databases][Backbones]
Command Line Shortcut: bbg

Before You Start

Before creating a Backbone, you will need to make sure you have created your Equipment and Cable Types
associated with this project. 



WireCAD v9.1 User Manual200

© 2017 Holbrook Enterprises, Inc. dba WireCAD

3.2.1.1 The Backbone Grid

Menu: Database > Backbones
Default command line shortcut: bbg
Related Project Settings:

Backbone Status Items
Product Level: ENT

The Backbone Grid will show you a list of all the backbone segments in your project and allow you to modify their
status or delete the entire backbone cable group at once. The status will refer to whether the backbone is in use,
proposed, dead ETC. New backbone status can be created in the project settings menu. There are 3 default status
available; in use, proposed & dead. 

The Backbone Grid is easier to use than the Cables Database if you are looking for basic information about a
backbone such as number or origin and destination information or if you are simply wanting to change the status of
the backbone. 

To access The Backbone Grid, type BBG in the command line.

With The Backbones Grid open, a list of all created backbones and cores will show along numerous columns of
information about each backbone core. 
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Controls
· Copy Selection Down - Create a selection vertically in the grid and click Edit>Copy Selection Down or

Ctrl+D and the topmost cell's data will be copied to all selected cells below.
· Delete Selected Backbone - This function will delete ALL cables associated with the selected Backbone. If

you are just trying to delete a single cable you should do that from the Cables databases.
· Refresh - Query the database and reload the data into the grid.
· Attach Document - Useful for storing field survey reports and other documents associated with this backbone.

You can attach as many documents as you need. The documents are stored in the database. You can click on
the link provided in the grid to launch the document into the system document reader for that file extension
(MIME Type).

· Rename Source Connector(s) - Renames the Source Connector (SrcConn) field and any jumpers or horizontal
cables attached to this backbone.

· Rename Destination Connector(s) - Renames the Destination Connector (DestConn) field and any jumpers or
horizontal cables attached to this backbone.

· Rename FiberMode - Renames the Fiber Mode (FiberMode) field and any jumpers or horizontal cables
attached to this backbone.

While a number of fields are shown in The Backbone grid, only the Statusfield & Owner field are modifiable.  All
other fields are simply shown for reference.
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Note: When marking a backbone as a status that is blocking you must make sure that this cable is no longer
used in an active circuit. If WireCAD detects that this backbone is still in use, you will be presented with a warning
message stating "Cannot mark a cable as <Blocking Status Name> that is part of an existing Circuit. Please
remove the Cable from the Circuit, then change its status. " 

Note: You will also receive a warning message if you try to delete a cable that is part of an existing circuit. You
must remove the cable/backbone from the circuit before deleting. If you wish to delete individual cores, you can do
so from inside the cables database however this information will not persist back into the CAD drawings. 

Note: When deleting a backbone in The Backbone Grid, the entire group of cables will be deleted even if you
have only selected a single core. Make sure that you want to delete the entire backbone segment before selecting
delete. 

Note: Deleting backbones in The Backbone grid, does not adjust number sequence. If you wish to reuse deleted
backbone numbers, you will need to manually access the Next Numbers Grid and change the next available
number to the one you would like to use. Example, you have created backbones 1001,1002,1003 & 1004. The next
number in the sequence would be 1005. If you then delete 1002,1003 &1004, the Add Backbone Segment Tool will
label the next backbone as 1005. To reuse 1002, 1003 & 1004, you need to manually select these as next in the
sequence by doing so in the Next Numbers  Grid. 245
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3.2.1.2 How To: Create a New Backbone

The following procedure details the creation of backbones in the CMS module. Backbones are multi-core cables in
the cables database that interconnect two (or more) patch panels. 

Note: While this tool is open in your window other WireCAD users will be locked out of the Cables table of the
Project database.

1. Make sure you have used the steps above to create your Equipment, Customize your I/O and create your
Cable Types.

2. Open the Equipment Library . 
3. Find the equipment you would like to use.
4. Click [Add to Project Database Only].  You can add as many pieces of equipment you as you would like at

this time however you will need to have at least the 2 definitions that the Backbone are linked to.

5. If there are multiple pieces of the same equipment in this location, you can select the [Add Many] to create
multiple pieces of equipment at the same time. Note: WireCAD will automatically SysName each piece of
equipment using the next available number in the sequence.

6. Enter in your location for this equipment.
7. Click [Add] or [Add Many].
8. Once you have added your equipment into the Project Database, close your Equipment Library .
9. Enter ABS into the command line and press enter or click on the [Add Backbone] button on the homepage.
10. The Add Backbone Segment window should now be open.

420

420
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11. First select if you would like to create a New Backbone or Use Existing Available. 

    
12.  On the From side, select your equipment from the Patch Panel ID field. 

13. On the To side, select your equipment from the Patch Panel ID field. Again, you can filter your results using
the Location Filter Field.  
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14. On both sides, ports that are available will be shown in white while ports that are currently being used will show
as pink. 

15. From the Cable Type field, select the Cable Type you would like to use as your backbone. If you have not
already created a Cable Type for your backbone, you can do so by clicking the [+] sign and following the
instructions here .34
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16. Select the ports you would like to use on the From side, then select a starting port on the To side. You will
see that WireCAD will automatically draw a backbone based on your port selection and Cable Strand count.
NOTE: See * Below!

17. Click [Apply]. WireCAD will create this backbone and then revert to an empty page ready for another backbone
assignment.

*Note: Always make sure that you are not overlaying on used ports and that the ports coming in are not the same
as the ports going out. Example: If you have a Patch Panel with 24 Ports in and 24 Ports out,  you could use ports
1-12 as your incoming ports and 13-24 as your output ports. This allows the other 12 ports on each side to be
used for jumpers to other equipment while maintaining a backbone infrastructure.
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3.2.1.3 Backbone Visualization Settings

These settings are available on the Backbones Grid [Visualization Settings] tab.
In order to preview Backbones you will first need to Add Backbones
These settings determine the display of the Backbones Visualize tool.
There are three variants:

1. Layered Digraph (ladder diagram).

2. Riser Diagram

3. Map

Map Tool - within the Backbones Visualizer

203
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This mode is only viable if you have associated GPS coordinate data in your Locations table. For more information 
see this topic . In Map view the backbones returned by the Filter Settings are shown on the Map tool. The
backbones honor the Backbones Color, and Line Width settings . The Map may be printed or exported through
the print preview dialog.

Layered Digraph Mode Data Source
· Show All - Shows all backbones in the database in the Visualize tool.
· Current Record - Allows selection of only those backbones that touch the selected record. 

· Search Depth - How many branches deep are we going to search. 
· Search Width - How many backbones per branch.

Appearance
· Location Marker Spacing, Location Marker Text Height, Location Marker Color, Junction Dot Radius,

Vertical Backbone Spacing(DU).

268

382
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· Center Label Format - String used to create the center label. Can make use of the following variables:
{0} = Backbone Number
{1} = Total Count
{2} = Total Available Count
{3} = Total Dead Count
{4} = Single Mode Fiber Count
{5} = Available Single Mode Fiber Count
{6} = Dead Single Mode Fiber Count
{7} = Multimode Fiber Count
{8} = Available Multimode Fiber Count
{9} = Dead Multimode Fiber Count

Example:
Assume that our backbone number is 1001 with 12 single mode fibers of which 1 is dead and four are in

use.

String:
B{0}-SM COUNT:{4} Avail:{5} Dead:{6}

Output:
B1001-SM COUNT:12 Avail:8 Dead:1

String:
B{0}

Output:
B1001

· Center Label Offset - Offset from center in DU.
· Show SysNames - Shows the SysName labels.
· Ignore Same Locations - Hides backbones that originate and terminate in the same location.
· SysName Rotation Angle - Sets the rotation angle of the SysName label if shown.
· SysName Text Height (100th DU) - Sets the height of the SysName text if shown.
· SysName Text Offset - Offset from the endpoint of the backbone.
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Riser Diagram Mode
· Campus and Building - The Campus and Building for which to build the riser diagram.
· Layout Max Columns, Column Spacing,Minimum Row Height - Determine the layout of the panels in the

diagram.

· Body Color, Body Width, Descriptor Locations - Determines the appearance of the body of the panels in the
diagram.

· Show Terminals if Backbone Leaves the Building, Terminal Offset - If the other end of the Backbone is not
in the selected building a terminal will be placed and a backbone drawn to it. The terminal's position from the
port on the panel is determined by the Terminal Offset property.

· Apply Jumps - 

· Avoid Other Cables - Instructs the cable autorouter to attempt to avoid other cables.
· Show Unresolved Backbones - If the Backbone cannot be placed in the drawing a list is generated. Enabling

this setting shows the list as the function completes.
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Map Mode
· Location Filter - Filter the displayed backbones by location.
· Panels Filter - This filter relies on the Locations Filter and provides further filtering by SysName.
· Backbones Filter - This filter relies on the Locations Filter  and the Panels Filter and provides further filtering by

Backbone number.

The map relies on the Locations table GPS fields. If you have not assigned GPS Lat and Lon to the Location the
backbones map will not display any data.
To Assign GPS Lat and Lon you can use the Map tool or your GPS calibrated drawing.

Title and Comment Block
· Show Title - Sets the visibility of the title/comment block.

MISC.
· Backbone Color by Signal Type - Pulls the backbone color from the global Signal Types database.
· Show Directional Coloring - Shows green dots for the source end of the backbone and red dots for the

destination end if shown.
· Backbone Color - Sets all backbones to the color defined.
· [Reset Default] - Button to reset the settings to the defaults.

3.2.1.4 Backbone Preview Export

Exporting the CAD preview of the Backbones Visualization tool is as easy as clicking the [Export] button. 

The current preview will be exported based on the Export Settings found in the Application Menu > Settings
[Project][Export Settings]  tool.284
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3.2.1.5 Import Backbone Data

Menu: Database > Backbones
Default command line shortcut: bbg
Related Project Settings:

Backbone Status Items

We have provided an import template that can be found at:
c:\users\public\documents\WireCAD\WireCAD9\Import Templates\import_backbone_template.xlsx.

Command:
Open the Backbones Grid. Then click File>Import Backbones.

Prerequisites
You should have a Backbones import template excel file filled in with your backbone data.

Related Topics:
Import Circuits
Backbones Grid

This document, when properly filled out will not only import a single line of data that expands to many cables
database entries as a backbone but will do the following as well:
· Create global Cable Type and Manufacturer.
· Create global panel data and Manufacturer.
· Create Project SysName data.
· Create Project Location data.

The import tool will perform several checks on the incoming data to ensure that it does not conflict with existing
data. Some of these checks include:
· Basic template data check to make sure all required fields are filled in.
· Preflight queries to check against the existing project data. At this point in the import no data has actually been

imported. If any errors are found the template row number is returned with error text describing the problem and
the import is stopped.

· Post-flight queries to ensure no duplicates were created during the import. If found the error is reported with the
opportunity to roll back the import.

239

200
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3.2.2 Blind Patch Tool

Menu: Project Explorer > Project Databases > Blind Patches
Default command line shortcut: ShowBlindPatchTool
Related Project Settings:

Status Behavior CMS

Explanation

Unlike the normal WireCAD New Circuit  tool which requires that you know the complete circuit end-to-end, the
Blind Patch Tool allows you to document your existing patches and then discover circuits from those patches.

You will use the Blind Patch Tool to document patches between panels. It is not necessary that you know the
whole circuit. Simply create patches from panel to panel as you go. You can use the [Discover] tool to find
circuits from the blind patches. Once the Blind Patch Circuits are discovered you can use the [Make Circuit]
function to create real Circuits.

As you add Blind Patches the Status of the connected Backbone(s) will be mark BLIND_PATCH. This status
item is a blocking status item. Meaning that other operations will not be able to use or delete this segment of the 
Patch Panel or Backbone.

Prerequisites:
Backbones

Related Topics:
Blind Patch Tool  form.
New Blind Patch  dialog.

381
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3.2.2.1 How To: Create a Blind Patch

The follow procedure describes creating a Blind Patch. Blind Patches are connections between two panels. We
only know the two ends of the patch. We will discover circuits after adding more Blind Patches.

Prerequisites:
At least two backbones.

Procedure:
1. Open the Blind Patches tool: Click Project Explorer>Project Databases>Blind Patches.
2. Select the Patch Panel (SysName) from the drop-down. This will populate the ToSys in the grid.
3. Select the row in the grid representing the port that you want to patch to on the ToSys.
4. Select either Simplex or Duplex Jumper. Duplex will require two rows and that the row below the selected

row be empty to receive data as well.
5. Click File>New.

6. Select either Named Equipment (SysName) or new CFE. Click OK.
7. The new Blind Patch is added. Backbones that touch the Blind Patch will have their Status field set to

Blind_Patch.
8. Done.
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3.2.2.2 How To: Discover Circuits From Blind Patches

The following procedure describes discovering circuits from Blind Patches.

Prerequisites:
More than one Blind Patch.

Procedure:
1. Open the Blind Patches tool: Click Project Explorer>Project Databases>Blind Patches.
2. Switch to the Discover Circuits from Blind Patches tab. 
3. Click [Discover Circuits].
4. The grid will be populated.
5. Select a row and the found circuit will be presented in the Preview pane (if the [Preview Selected] check

item is checked).

3.2.2.3 How To: Make a Real Circuit From Blind Patches

The following procedure describes making real circuits from discovered circuits.

Prerequisites:
Blind Patches

Procedure:
1. Follow the steps above to Discover Circuits.
2. Select the circuit in the grid that you wish to make real.
3. Edit the CktNo and CktDescription fields.
4. Click [Make Circuit].
5. The circuit will be added to the Circuits table and removed from the Blind Patches list.
6. Done.
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3.2.3 Circuits

A circuit in WireCAD is defined as a collection of cables. Each circuit may have a Name, Description, and other
meta data. A circuit also has a strand count to indicate the number of connections made from the originating
device on through to the terminating device. Circuits have a one-to-many relationship with the cables in the Cables
database. Each circuit may have many cables but a cable can belong to only one circuit.
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3.2.3.1 Circuits Grid

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

The Circuits Grid presents the overall circuit data in list form with the child cable data attached for view.

· Attach Document - Useful for storing field survey reports and other documents associated with this circuit. You
can attach as many documents as you need. The documents are stored in the database. You can click on the
link provided in the grid to launch the document into the system document reader for that file extension (MIME
Type).

· Rename Circuit - Renames a circuit and all of its cables.
· Combine Circuit - See the topic Combining Circuits .236
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Strand Count and Ordinal Explanation

WireCAD uses the strand and ordinal to know the exact position of a cable in a circuit. Strand 0 will always be the
topmost cable in the circuit with Strand n being the bottommost cable in a circuit. Ordinal 0 will be the leftmost set
of cables in the circuit with Ordinal n being the rightmost set of cables in the circuit.
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3.2.3.2 Circuits Preview Settings

These settings are available on the Circuits Grid [Visualization Settings] tab.
In order to preview Circuits you will first need to Add Circuits
These settings determine the display of the Circuits Visualization tool.
There are two variants:
1. Functional Block Diagram.

 Displays a CAD representation of the circuit as a functional block diagram. The master source and destination are
show with a series of equipment panels, jumpers, and backbones.
2. Map View. 

Map Tool - within the Circuit Visualizer

229
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This mode is only viable if you have associated GPS coordinate data in your Locations table. For more information 
see this topic . In Map view the backbones of the selected circuit(s) are shown on the Map tool. The backbones
honor the Backbones Color, and Line Width settings . The Map may be printed or exported through the print
preview dialog.

Appearance
· Source, Middle and Destination Shape - Choose one of the 16 stock shapes.
· Source, Middle and Destination shape Width in (100th DU) - How wide is it.
· Source, Middle and Destination shape Color - Set the color of the shape.
· Source, Middle and Destination shape Descriptor Locations - Drag the descriptor to the location map or to

the Hidden Items list to hide.

· Backbone Color - Sets the color.
· Jumper Color - Sets the color.
· Horizontal Cable Color - Sets the color.
· Merge and Center Text in Body

· Text Height - Sets the height of all text in the visualization.
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Layout
· Max Columns - The maximum number of blocks placed before a new row is started below.
· Column Spacing - The distance between blocks.
· Row Spacing - The Distance between rows.

Title and Comment Block
· Show Title - Sets the visibility of the title/comment block.
· Title - You can type whatever you want in this field. In addition the following variables are available:

{0} = Circuit Number
{1} = It System

MISC.
· Show Attenuation Labels, Show Jumper Length Labels, Show Backbone Length Labels

· Show Jumper Numbers, Show Backbone Numbers, Show Length
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3.2.3.3 Outputting Circuits to CAD

Once a circuit has been defined you can create CAD views of single and multiple circuits. The tools to do this are
contained in the Circuits Grid which you can access from the command line shortcut CMSCG or by selecting the
[CAD Preview/Circuits Grid] on the home page.

Before accessing the Circuits Grid, please make sure to setup your export preferences in the settings menu. 
Please refer here  for more information on the settings menu. 

You can also batch output the selected records by clicking Tools>Output Selected. 
All export is governed by settings in the Application Menu > Settings[Project][Export Settings] tool.

· [Export] - Output to file based on the Export Settings found in Application Menu > Settings [Project][Export
Settings]

· [Copy to Clipboard] - Copies the preview to the clipboard so it can be pasted into another drawing.

281
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3.2.3.4 How To: Output a Circuit to CAD

This step by step will guide you on exporting a circuit. 

1. Enter CMSCG in the command line prompt. The Circuit Grid Window will open. 

2. Select the Circuit Number you would like to Export. 
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3. Select the [Preview] Tab.

4. Verify the circuit is the one you would like to use and click [Export]. A Windows explorer window will come up.
Enter the path to export to, what you would like this file to be called and what file type you would like to export
as. Note: All of these settings can be automated in the Settings Menu.

5. Click [Save]. Your exported file will now be created and placed in the location you have specified of the file
type you specified in the Save As Dialog filter.
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3.2.3.5 How To: Output Many Circuits to CAD

This Step by step will guide you on exporting multiple circuits. 

Note: this is different from the command Tools>Output All Selected Circuits

1. Enter CMSCG in the command line prompt. The  Circuit Grid Window will open.

2. Select the Circuit Numbers you would like to Export. You can select multiple circuits by dragging down with
your mouse clicked, by holding [Shift] and selecting a set or by holding down [CTRL] and selecting multiple
records individually.
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3. Select the [Preview] Tab.

4. Verify the circuits shown are the ones you would like to use and click [Export]. A Windows explorer window
will come up. Enter the path to export to, what you would like this file to be called and what file type you would
like to export as. Note: All of these settings can be automated in the Settings Menu.

5. Click [Save]. Your exported file will now be created and placed in the location you have specified of the file
type you specified in the Save As Dialog filter.
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3.2.3.6 New Circuit Tool

The New Circuit tool is used to connect Field End & Head End Equipment together by adding jumpers between
existing Backbones. Each circuit is comprised of descriptive data, such as Name, Customer, IT System or
Description, source and destination equipment (SysNames); as well as a collection of cables in the Cable
database. You simply select the ports that you wish to jumper from/to and add the jumpers/back bone segments
to the Proposed Cables list. A Path Finder tool helps you search out possible routes. A [Preview] window
presents the functional block view of the Proposed Cables. Once you are happy with the circuit, simply click
[Build] and all Proposed cables will be added and associated to the named circuit.

To open the New Circuit tool open the Circuits grid and click File>New
Command line shortcut: nc

Note: While this tool is open in your window other WireCAD users will be locked out of the Cables table of the
Project database.
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3.2.3.6.1  How  To: Create a New  Circuit

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

Click File > New.

Before you Start
The use of this tool assumes the following:
· That you have added Backbones to the project.
· That you have added the necessary Cable Types to the global Cable Types .
· That you have an idea of what you want to connect together and that you know the first bit of infrastructure to

which you will attach.
· That you have created your Customer Furnished Equipment(CFE) in the Equipment Library  for the originating

and final destination equipment devices and/or that SysNames have been created for each individual piece of
equipment to which you will attach.

1. Verify that you have created all your Equipment and Cable Types needed for this circuit.
2. From the Circuits Grid click [File>New] to launch the New Circuit tool.
3. Verify that your Circuit Number/Name is correct and that it is not duplicating an existing entry.
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4. Enter your IT System and Customer info. IT System is a descriptive name.
5. Select your Origin(named equipment) from the drop down menu on the left. Alternately, select the Origin CFE

(Customer Furnished Equipment) and fill in the detail data in the dropdown.

6. Select your Final Destination System (named equipment) from the drop down menu on the right. Alternately,
select the Final Destination CFE(Customer Furnished Equipment) and fill in the detail data in the dropdown.

7. Select your Jumper To Equipment. This will be the first Patch Panel to which your Origin system will
connect.

8. Select the ports from your Origin equipment and the Ports on your Jumper To equipment. You will see that
WireCAD creates a preview jumper between the 2 for you to verify correct connections. 
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9. Click [Add Jumper]. Note: If you have connector types that WireCAD believes do not match, you will be
presented with a window stating "Connector String Mismatch". If you want to turn this message off, you can do
so in the Application Menu > Settings>UserCMS.
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10.  Click the [Next>] button. Note: WireCAD will automatically populate an available route between Patch Panels
using existing Backbone structures.

11. Click [Add Backbone Segment].
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12. Verify the correct cables have been added to the Proposed Cables In Circuit list. 
13. Then click [Next]. 
14. Select the Jumper To Equipment to populate the To Ports list. Alternately you can click the [Last] button to

populate the To Ports list with the ports of the Final Destination Equipment. That's what we will do here.
15. Click [Last].
16. Select the top two records.

17. Click [Add Jumper]. This places the final jumper in the list.
18. Click [Preview]. 

19. If everything looks correct, Click Build Circuit tab.
20. Click [Build Circuit].
21. Done.
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3.2.3.6.2  Path Finder Tab

Explanation:

The Path Finder tool can be used to find available ports and backbone segments from a source to a destination.
The Path Finder tool will search the backbone structure for backbones that can be used to get from the source
panel to the destination panel, then once a route is established the route candidate is checked for available port
count. If all criteria are met the route is returned.  If no routes can be established you will be notified.

2 possible routes returned each with 6 segments. We will use Route 0.

After adding Route 0
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Controls
· From - Prepopulated by your selection with the last jumper added in the Build tab.
· Last Existing - Select the last existing piece of infrastructure that we will search for.
· [Find] - Start the search.
· [Cancel] - Cancel the search.
· Use Route Number - Once routes are returned for selection this dropdown will be populated with the available

routes.
· [Add Selected Route to Circuit] - Once you have selected a route this button will enable for you to add the

route to the Proposed Cables to Add to Circuit list on the[Build] tab.
· Search Depth - How deep to search more will take longer but find more routes.
· Search Width - Maximum candidate routes to search.
· Show All - Show all routes found and populated with jumpers.
· Show Backbones Only (for research) - Show only the backbones without jumpers. Useful for research.
· Show Only First Path Found - Stop searching when the first route is resolved.
· Show Only Least Link Path - Search all then prune the list to the route with the shortest number of segments.
· Cable No Prefix, Cable No, SRC Sys, Dest Sys, Src Pin, Dest Pin, Src Loc, Dest Loc - Fields pulled from

the Cables database or populated by jumpers that would need to be created to complete this circuit along this
route.

· Ckt Strand Number - For more information about circuit strand and ordinal see here .
· Ckt Ordinal - For more information about circuit strand and ordinal see here .
· Route Number - The router may find multiple paths or none. If paths are found they will be returned with a route

number. You may then select the which, if any, route to add to the circuit.
· Made It - Indicates that the route made it to the destination. All routes shown will show Made It on the last

segment.
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3.2.3.7 Combining Circuits

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

Click Tools > Combine Circuits.

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have the same
Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted will be discarded.
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· This Circuit - The Circuit Name/Number of the circuit that will be appended or inserted into another circuit. This
circuit Name/Number will be discarded if successfully appended or inserted.

· Appends To - The Circuit Name/Number of the circuit that will be appended to.
· Inserts Into - The Circuit Name/Number of the circuit that will be inserted into.
· Before - Before this SysName.
· After - After this SysName.
· Insert Jumpers if Necessary - It is possible to create collections of cables in a circuit that do not interconnect.

If you do not select this option you will create collection of cables that do not interconnect.
· Preview

· [Commit] - Do it.
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3.2.3.8 How To: UnMake a Real Circuit Into Blind Patches

The follow procedure describes the process to turn a real circuit into a collection of Blind Patches. 

Prerequisites:
At least one Circuit.

Procedure:
1. Open the Circuits grid.
2. Select the Circuit to remove.
3. Click Tools>UnMake Circuit.

The jumpers associated with the circuit will be marked as IsBlindPatch = true.
The backbones associated with the circuit will have their Status field = Blind_Patch.
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3.2.3.9 Import Circuit Data

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

Click Tools > Import Circuits.

Command:
Open the Circuits Grid. Then click: File>Create Import Template.
Open the Circuits Grid. Then click: File>Import Circuits.
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Limitations
Simplex, duplex or n-strand/core count can be imported. You are limited to 82 rows of circuit data. If you are
importing more than 82 rows start another file.
The import template will only accommodate circuits with a maximum of 6 backbones/risers, or in other words a
simplex/duplex/n-plex circuit with a maximum of 8 jumpers.

Prerequisites
You must have created backbone data in order to establish circuits.

Related Topics:
Import Backbones
Circuits Grid

Prerequisites

You will need to have entered or imported backbone data in order to create circuits.

This is a multi-step process. 
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Step 1:

Create the import template:
Open the Circuits Grid. Then click: File>Create Import Template.
This will export the data from your project to the import template. This makes the use of drop downs with project-
specific data possible. Without this you will likely get errors if you were to just type the data manually into the
import template.
c:\users\public\documents\WireCAD\WireCAD9\Import
Templates\SomeImportTemplateNameWithADateCode.xlsx

NOTE: Be sure to use the most current import template.

Step 2:

Open the import template in MSExcel and enter your data into the Circuit Import Template created in Step 1
above.
Be sure to fill in all fields. 

NOTE: If you leave the Circuit Number field blank one will be assigned on import.

A circuit in its simplest form will consist of source and destination equipment with at least one backbone and two
jumpers:
The following is a n-plex simple circuit:



WireCAD v9.1 User Manual242

© 2017 Holbrook Enterprises, Inc. dba WireCAD

This import would require 4 rows in the import template. One row for each horizontal strand/core.

When completing the import template you will need to type the source and destination equipment
manufacturers/name and port info. 
You will then need to select the first jumper action. The jumper will either jumper to the next backbone or to the
final destination.
You will then select the first panel into which we will apply a jumper and the port we will use. 

NOTE: The ports displayed in the drop downs are available ports. If you are trying to use a port that is not listed
check to see why that port is not listed. 

Port and System ID fields are strictly validated. You cannot enter field data in the generated template that is not
allowed.

Once you have the first row of the circuit defined you will need to select the Final Action in Column BN. Your
choices are:
· CKT CONTINUES ON NEXT LINE
· CKT COMPLETE. NEW CKT NEXT LINE
· CKT COMPLETE. END OF FILE

There can only be one  and only one CKT COMPLETE. END OF FILE row in the template.

Once you have entered all of your data. Save the file and proceed to the next step.
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Step 3:

Import your data using the Import Circuits tool.

The Import Circuits tool performs several data integrity checks before the data is actually imported:
· Is the import template the proper format.
· Is all of the necessary data in place.

Then the data is validated against existing data in a preflight check.
· Do the backbones exist.
· Are the ports already assigned to another circuit.
· Is the circuit number available.
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3.2.3.10 Exporting Circuit Data to Excel

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

Click Tools > Export Circuit to Excel

This function exports the selected circuit(s) to excel. In addition this function also creates a full circuit import
template in the same file.

Limitations:
This function will fill up to line 100 in the excel file starting at row 18. If you have selected circuits that expand to
more than 82 rows the function will fail.
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3.2.4 Next Numbers Grid

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None
Product Level: ALL

The Next Numbers Grid will show you the next available Cable number based on your Cable Number Format .
To access the Next Numbers Tool, type NN in the command line prompt. 

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As you progress
through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number box and fill in
the desired number. Be sure that you are not entering a number that is already in use. 

Note: Yours will look different as the Next Numbers grid will automatically create entries for each new sequence
used by the application.

96



WireCAD v9.1 User Manual246

© 2017 Holbrook Enterprises, Inc. dba WireCAD

3.2.5 GPS Mapping Tools

WireCAD v9 ENT provides several ways for you to visualize your locations, panels, backbones and circuits with
relation to their GPS coordinates:

1. GPS calibrate (georeference) your dwg drawing and use the tools to pick GPS coordinates from the drawing
and display graphical representations of your Locations, Panels and Backbones.

2. You can also set up isometric drawings to show your riser interconnect.

Isometric View Showing Backbone Interconnect
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3. Use the Project Map. The functions are the same but the map detail will be less than that of a specific drawing.
For example the map may show your building(s) but your CAD drawings will show the detail inside the
buildings.

Map Tool  - showing Location, Panels and Backbones

4. The Map Tool is available as a visualization  in the Backbones grid to show you your Backbones in map
view.

Map Tool - within the Backbones Visualizer

207
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5. The Map Tool is available as a visualization  in the Circuits grid to show you the GPS path of a selected
circuit.

Map Tool - within the Circuit Visualizer

The WireCAD Locations table within the project database contains fields for named locations within your plant. In
addition, those named locations can be associated with GPS coordinates. 

Once the project Locations table has associated GPS coordinates you can visualize your data:
1. From your GPS calibrated dwg drawing.
2. From the Project Map tool.
3. From the Backbones grid Visualizer.
4. From the Circuits grid Visualizer.

Related Topics:
GPS Mapping Tools For Drawings
GPS Mapping Tools for Map Tool

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.

Accuracy and Precision

There are several factors that effect the accuracy of the GPS coordinate system alignment:
· The accuracy of the drawing.
· The accuracy of the control points.
· The accuracy of the GPS coordinate provided.
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From the wikipedia page on decimal precision:

The radius of the semi-major axis of the Earth at the equator is 6,378,137.0 meters resulting in a
circumference of 40,075,161.2 meters. The equator is divided into 360 degrees of longitude, so each
degree at the equator represents 111,319.9 meters or approximately 111.32 km. As one moves away
from the equator towards a pole, however, one degree of longitude is multiplied by the cosine of the
latitude, decreasing the distance, approaching zero at the pole. The number of decimal places
required for a particular precision at the equator is:

Degree precision versus length

decimal
places

decimal
degrees

DMS

qualitative
scale that

can be
identified

N/S or E/W
at equator

E/W at
23N/S

E/W at
45N/S

E/W at
67N/S

0 1.0 1° 00' 0?
country or
large region

111.32 km 102.47 km 78.71 km 43.496 km

1 0.1 0° 06' 0?
large city or
district

11.132 km 10.247 km 7.871 km 4.3496 km

2 0.01 0° 00' 36?
town or
village

1.1132 km 1.0247 km 787.1 m 434.96 m

3 0.001 0° 00' 3.6?
neighborhoo
d, street

111.32 m 102.47 m 78.71 m 43.496 m

4 0.0001 0° 00' 0.36?
individual
street, land
parcel

11.132 m 10.247 m 7.871 m 4.3496 m

5 0.00001
0° 00'
0.036?

individual
trees

1.1132 m 1.0247 m 787.1 mm 434.96 mm

6 0.000001
0° 00'
0.0036?

individual
humans

111.32 mm 102.47 mm 78.71 mm 43.496 mm

7 0.0000001
0° 00'
0.00036?

practical
limit of
commercial
surveying

11.132 mm 10.247 mm 7.871 mm 4.3496 mm

8 0.00000001
0° 00'
0.000036?

specialized
surveying
(e.g.
tectonic
plate
mapping)

1.1132 mm 1.0247 mm 787.1 µm 434.96 µm
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A value in decimal degrees to a precision of 4 decimal places is precise to 11.132 meters at the
equator. A value in decimal degrees to 5 decimal places is precise to 1.1132 meter at the equator.
Elevation also introduces a small error. At 6,378 m elevation, the radius and surface distance is
increased by 0.001 or 0.1%. Because the earth is not flat, the precision of the longitude part of the
coordinates increases the further from the equator you get. The precision of the latitude part does not
increase so much, more strictly however, a meridian arc length per 1 second depends on latitude at
point concerned. The discrepancy of 1 second meridian arc length between equator and pole is about
0.3 metres because the earth is an oblate spheroid.
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3.2.5.1 Using the Map Tool

WireCAD Enterprise provides a world map tool. The Map Tool can be opened with the link on the Project
Explorer  under the Project Database section.

Concept

The Map tool within WireCAD can be used to associate your Locations table entries to specific GPS coordinates. 
Once the Locations table entries have been associated with corresponding GPS coordinates we can automatically
place:
· Location Markers
· Panel Markers
· Backbone Markers

Note that the Map Tool requires an internet connection. We are grateful to the folks at OpenStreetMaps for
providing the map image data. The map images are © OpenStreetMap contributors.

575
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Pseudo Procedure
The following is a rough procedure for automatically creating a grapic that shows all locations in the Locations
table, all SysNames in the Project Equipment List, and all Backbones in the Backbones grid.

1. Use the Map>Tools>ID GPS Location Coord tool  to specifically associate your named locations to GPS
coordinates.

2. Use the Map>Display>Location Markers tool to display all of the Locations in the Locations  table that
have GPS coordinates.

3. Use the Map>Display>Panel Markers tool to display all of the SysNames in the Project Equipment List
that have Locations in the Locations  table that have GPS coordinates.
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4. Use the Map>Display>Backbone Markers tool to display a polyline representing the Backbone  between
location/panels that have Locations in the Locations  table that have GPS coordinates.

Related Topics:
Map Display  tab
GPS Settings  panel

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.1.1  How  To: Associate GPS LAT, LON w ith your Locations

This topic focuses on the procedure to identify GPS Lat, Lon point from the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see here .

Explanation
The WireCAD Locations table within the project database contains fields for named locations within your plant. In
addition, those named locations can be associated with GPS coordinates. 

There are four fields to contain the GPS data:
· GPSLat - Latitude decimal precision 18 decimals.
· GPSLon - Longitude decimal precision 18 decimals.
· GPSEl - Elevation decimal precision 18 decimals.
· GPSLocation - text convenience field of the Lat,Lon.

Note: We realize that 18 decimal places is far beyond the capabilities of any non-stationary GPS receiver. We just
want to be thorough.

Related Topics:
ID GPS Locations  dialog reference.

The Map Tool does not give us specific detail of the rooms within our building so some guessing is required if we
are going to use this tool to identify Locations within a building. If you have dwg drawing of your building you may
be better served to Calibrate  those and use the same tool within the drawing to pick location point .

WireCAD provides a tool to identify the GPS coordinates from the Map Tool and fill the GPS field data
appropriately.

1. Open the Map tool.
2. Click Tools > ID GPS Location Coords. This will open a dialog from which to select the Location of interest.
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3. Select the row(s) of interest within the Locations grid. Here we will define the GPS coordinates for the Location
"AMU.COM CTR CORE SWITCH.ROOM 120.5".

4. Click Pick > . The ID dialog is temporarily dismissed to allow you to pick the coordinate from the Map Tool.

5. Pick the coordinate by moving your cursor to the coordinate in the Map Tool and left-click. Here we will select a
location in the corner of the building where we estimate the AMU.COM CTR CORE SWITCH.ROOM 120.5 to
be. If you have selected [Leave Location Marker] as we have here you will leave behind a location marker at
the point you have picked.
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6. The ID dialog will be shown with the coordinate data in the selected row(s).

7. Click File > Save.
8. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.1.2  How  To: Show  Location Markers in the Map Tool

This topic focuses on the procedure to display Locations in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic .

Explanation
The WireCAD Map Tool  can show your Locations for which you have entered GPS coordinate data. Only
Locations that have GPS data will be considered.
The text displayed in the Location Marker is determined by the Display Format String of the Location section
of the GPS Settings  panel. 

Related Topics:
Display Tab  of the Map Tool interface.
Map Tool Dialogs
GPS Settings

1. Open the Map Tool. It can be found in the Project Explorer  under the Project Databases section.

2. Enter any Filter  data that you would like to limit the display of Locations by.
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3. Click Display > Locations. This will display all locations for which GPS data has been entered. If you have an
empty filter all Locations will be shown.

4. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.1.3  How  To: Show  Panel Markers in the Map Tool

This topic focuses on the procedure to display Panels or Equipment in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic .

Explanation
The WireCAD Map Tool  can show your Panels (SysNames). The Location of the SysName will be referenced
to the Locations table entry. If the Locations record has GPS data the SysName will be placed. Only Locations
that have GPS data will be considered.
The text displayed in the Panel Marker is determined by the Display Format String of the Panles section of the
GPS Settings  panel. 

Related Topics:
Display Tab  of the Map Tool interface.
Map Tool Dialogs
GPS Settings

1. Open the Map Tool. It can be found in the Project Explorer  under the Project Databases section.

2. Enter any Filter  data that you would like to limit the display of Panels (SysNames) by.
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3. Click Display > Panels. This will display all Panels (SysName) for which GPS data can be found. If you have
an empty filter all Panels with Locations with GPS data will be shown.

4. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.1.4  How  To: Show  Backbone Markers in the Map Tool

This topic focuses on the procedure to display Backbones in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic .

Explanation
The WireCAD Map Tool  can show your Backbones for which you have entered GPS coordinate data. Only
Backbones with Locations that have GPS data will be considered.
The Backbone Marker color and Line Width is set in the Backbones section of the GPS Settings  panel. 

Related Topics:
Display Tab  of the Map Tool interface.
Map Tool Dialogs
GPS Settings

1. Open the Map Tool. It can be found in the Project Explorer  under the Project Databases section.

2. Enter any Filter  data that you would like to limit the display of Backbones by.
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3. Click Display > Backbones. This will display all Backbone for which GPS data can be found. If you have an
empty filter all Backbone with Location data will be shown.

4. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.

3.2.5.1.5  Using Filters

The filter section is cascading. Selecting a Location will cascade to the Panels filter by limiting the Panels
shown to those that appear at the selected Location(s). In the same way, the Panels filter will cascade to the
Backbones filter. You may select as many of the filterable items you wish.
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3.2.5.2 Using Your DWG Drawings as Maps

WireCAD ENT supports the use of DWG maps to display equipment and backbones.

Concept
WireCAD can calibrate or georeference any properly scaled drawing to two known control points. These control
points typically reference survey markers in the drawing with their associated GPS coordinates. Control points can
be any geometry in the drawing for which you know the GPS latitude and longitude. In other words, the control
points can be any two points as long as they have known coordinates in both systems.

Note WireCAD uses the term Calibrate synonymous with georeference. Calibration or georeferencing is the
process of aligning the WCS (world coordinate system) of the drawing with the GPS coordinate system.

Coordinate System Alignment Showing Four Control Points for
Illustration. WireCAD Requires Only Two Control Points

Once the drawing has been calibrated, the cursor location is displayed in both Drawing and GPS coordinates.

Further, WireCAD can then be used to associate your Locations table entries to specific GPS coordinates. 
Once the Locations table entries have been associated with corresponding GPS coordinates we can use that data
to automatically draw:
· Location Markers. Location markers can be any CAD Block of your choice.
· Panel Markers. Panel markers can be any CAD Block of your choice.
· Backbone Markers. Backbones will be represented using polylines with the vertexes defined by the GPS

coordinates of the end point locations as well as Via locations.

Related Topics:
Display Tab  of the Drawing Mapping Tools interface.

Pseudo Procedure

The following is a rough procedure for automatically creating a drawing that shows all locations in the Locations
table,all SysNames in the Project Equipment List, and all Backbones in the Backbones grid.

324
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Prerequisites
You will need a DWG drawing of your plant or campus that is drawn to scale. The scale used does not matter as
long as it is applied consistently. You will need the GPS coordinates of two control points in the drawing.

1. Calibrate the drawing using Mapping Tools>GPS>Calibrate.
2. Use the Mapping Tools>Tools>ID GPS Location Coord  tool to specifically associate your named locations

to GPS coordinates.
3. Use the Mapping Tools>Display>Location Markers tool to display all of the Locations in the Locations table

that have GPS coordinates.
4. Use the Mapping Tools>Display>Panel Markers tool to display all of the SysNames in the Project Equipment

List that have Locations in the Locations table that have GPS coordinates.
5. Use the Mapping Tools>Display>Backbone Markers tool to display a polyline representing the backbone

between location/panels that have Locations in the Locations table that have GPS coordinates.

514
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3.2.5.2.1  How  To: Calibrate (Geo-Reference) Your DWG to the GPS Coordinate System

Prerequisites
This topic assumes that you have a scaled drawing of your plant.
Further that there exists in the drawing two control points. Control points are typically survey markers for which
you have the GPS coordinate data. However, they can be any geometry in your drawing such as the corners of
buildings or manhole covers as long as you have reliable GPS data for that point.

Procedure
1. Open your plant or campus drawing. If the your plant drawing is very large you may want to consider Externally

Referencing  (XREF) it into a new drawing. This is done to keep the save operation lightweight. Externally
referenced drawings do not get saved, only the base drawing.

2. Click Mapping Tools > GPS > Calibrate.

3. You will be prompted in the Command Prompt to pick the first point, or lower left point, from the drawing. Do
so.

4. Enter the GPS point data for the lower left point. The control point does not necessarily have to be the lower left
corner. We just need points opposite.

 
Please note that the coordinate is expected in decimal lat,lon form. Do not Crtl+V to paste your coordinate data
as this will initiate the paste function in the drawing not the command line. Use the Right-Click context menu and
select Paste there.
5. Pick the upper right point in the drawing.
6. Enter its GPS coordinate.

When done the drawing will display GPS in the lower right-hand corner to indicate that it is calibrated.

407
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You will be able to use the GPS tools to pick location points from the drawing.
The statusbar text will show you the GPS coordinate of the current cursor position.

Once the drawing is calibrated you can use the Mapping Tools > GPS > Show Calibration Marks tool to place
a marker in the drawing at your calibration points.

Related Topics:
Display Tab  of the Drawing Mapping Tools interface.324
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3.2.5.2.2  How  To: Copy Calibration Data from another Draw ing

WireCAD provides a tool to copy calibration or georeference data from another drawing. This assumes the
following:
· The drawing you are copying from has been Calibrated. You can tell if the drawing has been calibrated if you

open it and it displays the text GPS in the lower right-hand corner.
· The geometry in the two drawings shares the same WCS origin point. This is crucial. If the geometry in the two

drawings does not share the same origin point the GPS coordinate system will be off.

Procedure
1. Open the drawing that you want to copy Calibration data into.

2. Click Mapping Tools > GPS >Copy From Other Drawing. This will open a file browser dialog.

3. Browse to the Calibrated drawing and select it.
4. Click [Open]. This will initiate the process. If the drawing has been calibrated the process will proceed and the

commandline history will indicate that the process has been completed.
5. Click File > Save to save the calibration data with the drawing.
6. You are done.
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3.2.5.2.3  How  To: Associate GPS LAT, LON w ith your Locations

This topic focuses on the procedure to identify GPS Lat, Lon point from a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic .

Prerequisites
This topic assumes that you have a GPS Calibrated drawing of your plant.
For more information on calibrating your drawing see this topic .

Explanation
The WireCAD Locations table within the project database contains fields for named locations within your plant. In
addition, those named locations can be associated with GPS coordinates. 

There are four fields to contain the GPS data:
· GPSLat - Latitude decimal precision 18 decimals.
· GPSLon - Longitude decimal precision 18 decimals.
· GPSEl - Elevation decimal precision 18 decimals.
· GPSLocation - text convenience field of the Lat,Lon.

Note: We realize that 18 decimal places is far beyond the capabilities of any non-stationary GPS receiver. We just
want to be thorough.

Related Topics:
ID GPS Locations  dialog reference.

WireCAD provides a tool to identify the GPS coordinates from your GPS calibrated drawing and fill the field data
appropriately.

1. Open your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand corner, stop.
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2. Click Mapping Tools > Tools > ID GPS Location Coords. This will open a dialog from which to select the
Location of interest.

 
3. Select the row(s) of interest within the Locations grid. Here we will define the GPS coordinates for the Location

"AMU.COM CTR CORE SWITCH.ROOM 120.5".

4. Click Pick > . The ID dialog is temporarily dismissed to allow you to pick the coordinate from the drawing.
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5. Pick the coordinate by moving your cursor to the coordinate in the drawing and left-click. If you have selected
[Leave Location Marker] as we have here you will leave behind a location marker at the point you have
picked.

6. The ID dialog will be shown with the coordinate data in the selected row(s).

7. Click File > Save.
8. You are done.
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3.2.5.2.4  How  To: Show  Location Markers in your Draw ing

This topic focuses on the procedure to place Location Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic .

Prerequisites
This topic assumes that you have a GPS calibrated drawing of your plant.
For more information on calibrating your drawing see here .
Further, this topic assumes that you have identified GPS coordinates for your Locations in your Locations table.
For more information on this topic see here .

Explanation
WireCAD has the ability to place a marker for every location in the Locations table for which GPS coordinate data
exists. The markers placed are based on the current filter settings. For more information on setting filters see 
here .
The type of marker placed, its scale, and Overlay Mode can be determined in the menu structure. 
The marker text, color and Overlay Mode settings can be controlled in the GPS Settings  panel.

Related Topics:
GPS Settings
Display  Tab

Procedure
1. Open your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand corner, stop.

2. Select the Geometry and Scale. Geometry sets the block to insert as a Location Marker.  For more
information on the Geometry see this topic .

3. Select the Overlay Mode. For more information on the Overlay Mode see this topic .
4. Enter any Filter  data that you would like to limit the display of Locations by.  For more information on the

Filters see this topic .
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Here we have selected a block that has the appearance of a Location pin

5. Click Mapping Tools > Display > Locations. This will display all locations for which GPS data has been
entered. If you have an empty filter all Locations will be shown.

6. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.2.5  How  To: Show  Panel Markers in your Draw ing

This topic focuses on the procedure to place Panel Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic .

Prerequisites
This topic assumes that you have a GPS calibrated drawing of your plant.
For more information on calibrating your drawing see here .
Further, this topic assumes that you have identified GPS coordinates for your Locations in your Locations table.
For more information on this topic see here .

Explanation
WireCAD has the ability to place a marker for every Panel in the Locations table for which GPS coordinate data
exists. The markers placed are based on the current filter settings. For more information on setting filters see 
here .
The type of marker placed, its scale, and Overlay Mode can be determined in the menu structure. 
The marker text, color and Overlay Mode settings can be controlled in the GPS Settings  panel.

Related Topics:
GPS Settings
Display  Tab

Procedure
1. Open your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand corner, stop.

2. Select the Geometry and Scale. Geometry sets the block to insert as a Panel Marker.  For more
information on the Geometry see this topic .

Here we have selected a block that has the appearance of a simple rectangle with an angled line.
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3. Select the Overlay Mode. For more information on the Overlay Mode see this topic .
4. Enter any Filter  data that you would like to limit the display of Panels by.  For more information on the

Filters see this topic .

5. Click Mapping Tools > Display > Locations. This will display all locations for which GPS data has been
entered. If you have an empty filter all Panels with found GPS data will be shown.

Here we see the panels displayed with the Radial Overlay mode

6. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.
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3.2.5.2.6  How  To: Show  Backbone Markers in your Draw ing

This topic focuses on the procedure to place Panel Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic .

Prerequisites
This topic assumes that you have a GPS calibrated drawing of your plant.
For more information on calibrating your drawing see here .
Further, this topic assumes that you have identified GPS coordinates for your Locations in your Locations table.
For more information on this topic see here .

Explanation
WireCAD has the ability to place a polyline for every Backbone in the Backbones  table for which GPS location
coordinate data exists. The markers placed are based on the current filter settings. For more information on setting
filters see here .

The Arc Distance, Self-Connect Arc Distance and the Show Mode can be determined in the menu. For more
information on these settings see this topic .

The marker text, color and other settings can be controlled in the GPS Settings  panel.

The tool can [Show Backbone Stats] such as the fiber count, availability, and blocked fiber count. This data, if
generated, is displayed in the tooltip of the Backbone when the mouse hovers over it. 
The statistics are presented in the form: Backbone Number FiberMode\Count\Available\Blocked

You can also see Backbone stats with or without having the [Show Backbone Stats] checkbox checked by
double-clicking a Backbone. Doing so will present a message box with the stats.

261

265

268

530

277

326

382



WireCAD v9.1 User Manual276

© 2017 Holbrook Enterprises, Inc. dba WireCAD

The polyline can be made to show only its end points or if the Show Vias is checked it will jump from the starting
location through every Via location until it reaches the ending location.

Backbone from panel to panel Via Manhole 1 and
Manhole 2

The polyline can also be made to show the Backbone number as the polyline LineType

Backbone showing number as Line Type

Related Topics:
GPS Settings
Display  Tab

Procedure
1. Open your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand corner, stop.

2. Select the Arc Distance and Self-Connect Arc Dist. Arc Distance sets the polyline bulge factor. An Arc
Distance of 1 creates an arc of 180°.  For more information see this topic .
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3. Select the Overlay Mode. For more information on the Overlay Mode see this topic .
4. Enter any Filter  data that you would like to limit the display of Backbones by.  For more information on the

Filters see this topic .

5. Click Mapping Tools > Display > Backbones. This will display all locations for which GPS data has been
entered. If you have an empty filter all Panels with found GPS data will be shown.

Here we see the Backbones displayed by GPS Location and we are
showing Vias

6. You are done.

Note: Although we are showing a real world location in these examples the data is completely fictitious. Any
resemblance to any data living or dead is purely coincidental.

3.2.5.2.7  Using Filters

The filter section is cascading. Selecting a Location will cascade to the Panels filter by limiting the Panels
shown to those that appear at the selected Location(s). In the same way, the Panels filter will cascade to the
Backbones filter. You may select as many of the filterable items you wish.
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3.2.5.2.8  HOW TO: Create a Multistory Isometric Draw ing to Display GPS Data

Prerequisites
We will need a new drawing. We will also need the floor plans for each floor one per file all aligned to the same X,Y
origin.

Concept
We can use the different floor plans of a structure stacked one on top of another along the Z axis to display our
interconnect in an isometric view.

Isometric View Showing Backbone Interconnect

Here we have created a new drawing called map.dwg and Externally Referenced each floor on the same X,Y origin

but at a different Z axis location.

Pseudo Procedure
1. Create a new drawing.
2. XREF the first floor inserting it at 0,0,0.
3. XREF the next floor inserting it at 0,0,n where n is some value along the Z axis far enough away from the origin

that when we rotate the drawing into isometric view the two floors do not interfere with each other.
4. Lather, rinse, repeat for each floor inserting the floor at 0,0,n*f where n is the distance along the Z axis and f

is the floor number.
5. For ease of use we recommend creating a layer for each floor and assigning the floor to the layer in order to

control visibility.
6. Calibrate  the drawing.265



WireCAD ENT Tools Manual 279

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Procedure
Before you start. Collect all of your floor plan files into a known location. We recommend in the same folder as the
new drawing you are about to create.
1. Create a New Drawing . Name it map.dwg or some-such.
2. Make sure you are in Model space.
3. With the map.dwg drawing as the active form. Click CAD Tools > External Reference Manager (XREF). This

will open the XREF Manager dialog .

4. Click the [Attach] button. This will open a file browser dialog.

5. Browse to your floor plan file and click [OK]. This will display the Insert dialog.
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6. For the first floor use the default settings for all other floor enter a Z axis insertion point.  Click [OK].

You may need to play with this to find a number that works for the structure you are trying to show. You don't have
to reinsert it every time you want to modify the Z axis. Just open the Drawing Properties  tool panel and with the
XREF selected in the drawing find the Insertion Point property and modify the Z Axis there.

7. This will load the drawing. Note that you may not see the drawing in the current view of Model space until you
dismiss all dialogs and click Zoom Extents.

8. Repeat steps 4-7 until you have added all floors.
9. Calibrate  the map.dwg drawing.
10. Click File > Save.
11. You are done.
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3.3 CMS Settings and Options

Menu: Application Menu > Settings
Default Commandline Shortcut: set

To access the settings menu, click Application Menu > Settings. Then select one of the three default sets of
settings Application, User or Project by clicking on the down arrow.

Note: Third party Plugins may register their own settings categories and panels. Shown are the stock settings.
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3.3.1 User Settings

Menu: Application Menu > Settings[User][CMS User]

These are the additional user settings that pertain specifically to the CMS module.

· Use Stock WireCAD Startup Page - Not used anymore.
· Default New Circuit Strand Count - When creating a new circuit, a default strand count for jumpers is created.

This will change that strand count to a different value.
· Warn Of Connector String Mismatch - Having this box checked will allow a warning message to display

anytime WireCAD detects that 2 ports being connected have a different connector type. 
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3.3.2 Project Settings

Menu: Application Menu > Settings[User][CMS User]
These are the additional project settings that pertain specifically to the CMS module.

Note: You will need to have an open project in order to access these settings. 

Note: These settings are project specific and will need to be created for each new project. 

· Default New Backbone Status - When creating a backbone, you have the ability to mark a "status" on that
backbone such as "In Use", "Proposed" ETC. Selecting a status will cause that to become the default for all
backbones in this project. Status Items are defined in the Status Behavior Project Settings panel.

· Default New Circuit Status - Just like above, when creating a Circuit, you have the ability to mark a status on
that circuit.

· Backbone Number Format - The variable {0} contains the next number in the Next Numbers grid for
Backbones. 

· Circuit Number Format - The variable {0} contains the next number in the Next Numbers grid for Circuits.
· Jumper Number Format - 

The variable {0} contains the Circuit base number.
The variable {1} contains the Strand Number of the circuit for this jumper
The variable {2} contains the Ordinal Number of the circuit for this jumper.
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3.3.3 Output Settings

Menu: Application Menu > Settings[Project][Export Settings]

· Use Template - Path to a template drawing that the output will be exported into. Your template drawings can
contain any page borders or layouts and settings that you wish.

· Always Ask for Filename and Path - You are involved in the file name selection and path.
· Circuit File Name Format - Sets the file name format for Circuit output. {0} = Circuit Name.
· Backbone File Name Format - Sets the file name format for Backbone output. {0} = Backbone Number.
· File Format - Presets the output format.
· Path - Where do we output.
· Create Folders for Each IT System - Create a new folder for each IT System and output the preview to that

folder.
· Automatically Overwrite Files of Same Name - Self-explanatory.
· Append Date Stamp to File Name - Self-explanatory.
· Circuit Post Process Script - Path to a c# file which will be run post export but pre write-to-disk. See the Post

Process Scripts  topic for more information.
· Backbone Post Process Script - Path to a c# file which will be run post export but pre write-to-disk. See the

Post Process Scripts  topic for more information.
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3.3.4 Status Behaviour

Menu: Application Menu > Settings[Project][Status Behavior]

· Assigned to Circuit Color - The color to display in the Backbones grid if the record is assigned to a circuit.
Here we see circuit 0232 using the backbone B000003.41.

· Context - Backbones_grid or Circuits_grid.
· Display Name - The name of our status.
· Background Color - Self-explanatory.
· Is Blocking - A blocking status is one that blocks operations from proceeding. For example: if we mark a

backbone fiber as DEAD we would not want to use that in a Circuit. If the status item is set as Is Blocking = true
then the New Circuit tool will not allow a circuit to involve that strand of fiber.
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3.3.5 Post Process Scripting

Post Process Scripting of the output of the Visualizers in WireCAD allow you to customize the final appearance of
the created document.

What follows are two example scripts, one for the Circuit output and the other for the Backbone output. The
process is the same for both. Only the method signature is changed.

Circuits Export Script Example

//////////////////////////////////////////////////////////////////////////////////

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using System.IO;

using WireCAD;

using WireCAD.Interfaces;

using VectorDraw.Professional.vdObjects;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdPrimaries;

using VectorDraw.Professional.vdCollections;

using WireCAD.ProjectFile.DAL;

using VectorDraw.Geometry;

/// <summary>

/// Fill your titleblock with your data

/// </summary>

//Your class name

public class TitleBlockFiller

{

//the method signature is key so this next line must appear as shown

public static void Run(Workspace ws, Circuits c, vdDocument doc)

{

string drawingName = Path.GetFileName(doc.FileName);

//change this next line to be your titleblock name

string BlockNameToUpdate = "ansi";

//Get the layout by name that we want to update

vdLayout layOut = doc.LayOuts.FindName("ANSI_B");

//loop through the entities in the layout

foreach (vdFigure figure in layOut.Entities)

{

//if we find a viewport let zoom it to the extents of our model

if(figure is vdViewport)

{

vdViewport vp = figure as vdViewport;

vp.ZoomExtents();

vp.Update();
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}

//now look for our titleblock

if (figure is vdInsert)

{

//cast our base figure into an insert object so we can access its

properties

vdInsert insert = (vdInsert) figure;

//now we will test to see if the insert name is one that 

//we know to be a titleblock

//Modify this to meet your needs

if (insert.Block.Name.ToLower().Contains(BlockNameToUpdate))

{

//need to fix it.

//this next bit makes it insert get the latest version from

the blocks table

insert.Update();

insert.Invalidate();

//we got one so let's set the attributes

//we will use the safeSetAttribute function so that if the

attribute doesn't exist it won't 

//fail

//Modify this to meet your needs

//Enter your Attribute names and the values you want to fill

them with

                           

ws.Utilities.SafeSetAttributeValue(insert, "SHEET",

layOut.Name);

ws.Utilities.SafeSetAttributeValue(insert, "Drawing_Name",

Path.GetFileNameWithoutExtension(drawingName));

ws.Utilities.SafeSetAttributeValue(insert, "DWG_Number",

c.CktNO);

ws.Utilities.SafeSetAttributeValue(insert, "COMPANY", "Slate

Gravel Co");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS",

"Number 1 Quary Way");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS2",

"Bedrock - The World");

ws.Utilities.SafeSetAttributeValue(insert, "DATE",

DateTime.Now.ToShortDateString());

ws.Utilities.SafeSetAttributeValue(insert, "Scale", "NTS");

insert.Update();

insert.Invalidate();

doc.Redraw(true);

}

}

}

//Now create a text item that displays our circuit number in the upper righthand

corner

vdText t = new vdText(doc);

t.TextString = string.Format("CKT - {0}\n{1}",c.CktNO, c.CktDescription);

t.HorJustify = VectorDraw.Professional.Constants.VdConstHorJust.VdTextHorRight;

Box bb = layOut.Entities.GetBoundingBox(true,true);
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t.Height = .25d;

t.InsertionPoint = new gPoint(bb.Right-3,bb.Top-2);

layOut.Entities.AddItem(t);

doc.ActiveLayOut = layOut;

           

}

}

Backbones Export Script Example

The only difference in the two examples is the method signature. Use the code above replacing:
public static void Run(Workspace ws, Circuits c, vdDocument doc)

With:
public static void Run(Workspace ws, CMSSettings settings, vdDocument doc)

3.3.6 GPS Settings

Menu: Application Menu > Settings[Project][GPS Settings]

See the Reference section regarding the GPS Settings  panel.382



Reference

Here you will find a listing of all menu functions, forms, and dialogs.
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4 Reference

4.1 Ribbon Tabs and Dialogs

This section provides a reference to the individual controls in the dialogs accessed in the Ribbon Toolbar. 

Only dialogs that need explaining are documented

Please note that although this reference is quite complete, only dialogs that really need explaining are
documented. For example, we assume that you can figure out what menu entries like Save and Save As do for
yourself. 
This also applies to simple dialogs whose functions are explained elsewhere. Some of these dialogs are listed, but
only with references to the relevant topics in the Procedures sections.
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4.1.1 The Workspace

The WireCAD workspace has four main components: The Application Menu at the top of the screen, the Ribbon
Toolbar where you access all program functions, the Tool Panels collection for navigating and managing your
projects and the Main Window where you edit the content of your projects. The Main Window can display four
distinct environments:

1. The Drawing environment

2. The Data environment
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3. The Reporting environment

4. The PDF viewer environment

The Application Menu and Quick Access Toolbar

The Application Button in the top left corner of the Help & Manual window is one of the most important

controls. It provides access to the functions normally accessed in the File menu in menu-based programs. This is
where you open existing projects, create new projects, save your projects under other names and so on.

The Quick Access Toolbar next to the Application Button is a place for frequently-used tools.
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 The Ribbon Toolbar

The Ribbon Toolbar is the control center where you access virtually all of WireCAD's functions. If you use
Microsoft Office 2007 you will already be familiar with the Ribbon interface. It is context-sensitive, automatically
displaying functions relevant to what you are currently doing.

Tip: The Ribbon can also be operated almost entirely via the keyboard. To display the accelerator keys just press
and release the ALT key once – the keys will be displayed in icons superimposed on the Ribbon.

Tool Panels

Tool Panels are organizations of controls. There are different Tool Panels depending on the current
environment.
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The Project Explorer Tool Panel

The Project Explorer is like Windows Explorer for WireCAD projects. When you load or create a
project all its contents are displayed here, including both the Global Equipment tables and the Project
Databases  and files.

Note: This tool panel is active at all times.
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The Draw Cables Tool Panel

The Draw Cables Tool Panel  contains all the tools for drawing cables. You can draw cables with
different relationships. You can also set the drawing behavior of cables.

Note: This tool panel is only active when the current environment contains a drawing.
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The Drawing Properties Tool Panel

The Drawing Properties Tool Panel allows editing of granular drawing settings. If no entity selection
exists in the drawing the Drawing Properties window will display the general document properties.

Note: This tool panel is only active when the current environment contains a drawing.
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The Find and Replace Tool Panel

The Find and Replace Tool Panel allows you to search the current drawing, all drawings and the
project databases for text and replace that text with your entered values.

Note: This tool panel is active at all times.
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The Plan View Tool Panel

The Plan View Tool Panel allows you to place plan view symbols in your drawing.

Note: This tool panel is only active when the current environment contains a drawing.
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The Favorites Tool Panel

The Favorites Tool Panel holds blocks that you have saved as favorites (right-click entity in
drawing>Add to Favorites).

Note: This tool panel is only active when the current environment contains a drawing.

The Command Line Interface

The Command Line Interface allows you to see the command history, receive prompts from the application and
execute commands directly. For a full list of command line command you can view/edit the Application
Menu>Settings[User][Commandline Shortcuts] grid.
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4.1.2 Ribbon Tabs

4.1.2.1 Application Menu

The Application Menu contains the following static menu functions:
· New Project... - Displays the New Project Wizard.
· Open Project - Display a file open dialog. Browse to and select a *.wc6plf file to open the WireCAD Project.
· Save Project As... - Displays the Save Project As  dialog. Use this to create a copy of the current project in

a different location.
· Close Project - Closes the current project.
· Frequently Used Folders >

Project Folder - Opens the root folder of the current project in a window explorer window.
Global Data Folder - Opens the global data folder. C:\Users\Public\WireCAD\WireCADx
User App Data Folder - Opens C:\Users\<YOUR USER NAME>\AppData\Local\WireCAD\WireCADx

· Security Tools >
View Permissions - Shows the permissions grid.
Manage Security... - Shows the Users Groups and Permissions dialog .

· Check In/Out >
Pack Up / Check Out - Packup/check  out utility. Collects all info for the project and makes is

portable.
Unpack Project ... - Unpack a project.
Check In Project - Check in a Checked Out project .

· Project Info - Project specific info  like the current revision and related projects list.
· Account Info - Who is the project for .
· Application Setup - Displays the Application Setup Wizard . This is shown once on startup but you can

review and change settings here.
· Settings - Displays the main Settings  dialog.
· Exit - Exits the program.
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4.1.2.2 Project

The Project Ribbon Tab is a static menu structure. It does not change with environment changes.
The Project Ribbon Tab contains the following menu items:
· New Project ... - Display the New Project Wizard .
· Open Project - Display a file open dialog. Browse to and select a *.wc6plf file to open the WireCAD Project.
· Close Project - Close the current project.
· Recent Projects - Most recently used projects list. This selection is based on the Project List setting in the

Application Menu>Settings[Project List].
· Batch Plotter - Launch the Batch Plotter  tool.
· Archive Project - Launch the Archive tool.

Other

While WireCAD does not currently merge any other tools with the Project menu, authors of WireCAD plugins have
the ability to merge their own tools onto this ribbon tab. Consult their documentation for information.
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4.1.2.3 File

The File Ribbon Tab is a dynamic menu that changes its structure with the current environment.

Drawing Environment

Again, we will not explain the obvious ones.
· New Drawing ... - Shows the New Drawing Wizard .
· Save As Template Drawing - Any drawing may be used as a template from which other drawings may be

created. Simply Save As Template Drawing to make your drawing usable in the New Drawing Wizard as a
starter drawing.

· Print Preview ... - Display the Print Preview  dialog.
· PDF Export ... - Display the PDF Export  dialog.
· Export to Visio - Create smart Visio drawings  where the WireCAD cable becomes live active Visio

connections. 
· Settings ... - Display the main Settings  dialog. Same as clicking Application Menu>Settings.
· Purge ... - Purge  unused entities from the drawing.
· Todo - Create a New Todo  linked to this drawing.

Data Environment

For an general discussion on grid basics see this topic .
· New - Create a new item on the collection. The dialog presented will differ based on the collection.
· Clear Data [Del] - 
· Delete Selected Rows [Ctrl + Del] - 
· Copy Down [Ctrl]+[D] - 
· Increment Down [Ctrl]+[I] -
· Find and Replace - 
· Function - Displays the Expression Builder  dialog so you can manipulate data using the Expression engine.
· Tools - See Grid Specific Functions for a listing of the tools available to each data grid.

Other

While WireCAD does not currently merge any other tools with the File menu, authors of WireCAD Plugins have the
ability to merge their own tools onto this ribbon tab. Consult their documentation for information.
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4.1.2.4 Drawing

Active only when the current environment is a drawing.

· Grid Mode - Toggle the visible grid [F7]. Note: the visible grid is rendered only for the Drawing Limits which
can be set in the Drawing Properties Tool Panel.

· Snap Mode - Toggle the invisible snap grid [F9]. The invisible snap grid is based on the SnapX and SnapY
settings in the Drawing Properties Tool Panel.

· Polar Track Mode - Toggle PT mode. When enabled and in a function requesting a point from the drawing the
selectable polar angle will be restricted to the Polar Track Angle in the Drawing Properties Tool Panel.

· Extension Tracking - 
· Ortho Mode - Toggle restrict movement to horizontal/vertical only.
· Coordinate - Displays the cursor position in current coordinates. Coordinates are expressed in drawing units

(DU).Drawing units do not express particular units(meters,inches etc).
In this part user have to make some assumptions in order to define that the coordinates of the drawing mean
particular units(meters,inches etc).

For example:
For a mechanical drawing we can make the assumption for example: where one drawing unit defines one

millimeter(1 D.U=1mm).
For a architectural/technical drawing we can make the assumption for example: where one drawing unit

defines one meter(1 D.U=1m) or one foot.
This can be very helpful in designing,dimensioning,retrieving information from the drawing(distances,area

calculations).
· GripBlockStd - Show only one grip per insert.
· GripBlockAtts - Show one grip per attribute in the selected insert.

· Layers ... - Shows the Layers  dialog.
· Layouts ... - Shows the Layouts  dialog.
· Point Styles ... - Shows the Point Styles  dialog.
· Text Styles ... - Shows the Text Styles  dialog.
· Dim Styles ... - Shows the Dimension Styles  dialog.
· Model Space Bounds - Shows the Model Space Boundaries  dialog.
· Groups ... - Shows the Groups  dialog.
· Images ... - Shows the Images  dialog.

· UnSelect - Clears the current selection. Same as pressing {esc}.
· Select - Start a selection.
· Erase - Erase the current selection. If no selection then you will first be prompted to select entities.
· Copy - Copy the current selection. This is a base-point or offset copy and is preferred over [Ctrl][C] then [Ctrl][V]

if copying in the same drawing as it is lighter weight. If no selection then you will first be prompted to select
entities.

· Move - Move the current selection. If no selection then you will first be prompted to select entities.
· Scale - Scale the current selection. If no selection then you will first be prompted to select entities.
· Rotate - Rotate the current selection. If no selection then you will first be prompted to select entities.
· Mirror - Mirror the current selection. If no selection then you will first be prompted to select entities.
· Stretch - Stretch polylines in the current selection. If no selection then you will first be prompted to select

entities.
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· Explode - Explode the current selection. This function will reduce complex object to their primitive constituent
parts. For example; exploding an insert unlinks all of the entities back one level. Exploding a polyline reduces
the polyline to a collection of line segments. If no selection then you will first be prompted to select entities. 

Entities that can been exploded:
vdDimension explode to vdLines, vdText(s), and vdInserts (the arrows).
vdInsert explode to the entities that is consist of. (If there are Inserts inside Blocks then you may need to

apply more than 1 explode to get the base entities).
vdPolyHatch explode to vdPolyline(s).
vdPolyline explode to vdLine(s) and/or vdArc(s).
vdRect explode to vdPolyline.
vdText explode to vdPolylines(only texts with fontfile SHX).TTF(true type font) texts are not exploded.

· Trim - Trim objects at a cutting edge defined by other objects the current selection. First select the objects that
define the cutting edges at which you want to trim an object and then the object.

Objects that can be trimmed include arcs, circles, elliptical arcs, lines. Notice that the trim command do not
function if the objects do not intersect.
· Extend - Extend lines,arcs,polylines until they intersect with some other object which is used as limit of the

extension. Firstly you have to select the objects that consist the limits of the extension. Then you have to
choose a point at an object that you want to extend. If the object you want to extend does not intersect with
above objects then nothing will happen.

· Fillet - Connect two lines , two arcs, or one arc with a line(these two objects must have at least one common
point either visible, or in their extension) , with an arc with a specific radius. The value of the radius has some
restrictions depending the position of the objects. If radius=0 then simply the objects are either extended until
they intersect each other in one point (if there was not an intersection point) either trimmed (if an intersection
point is visible).

· Offset - Create a new object in parallel direction and in a specified distance from the original object which is
used as pattern for the new object. When you execute an offset command, you are prompted to select an
object. Then you have to specify the offset distance which is the distance that the new object will be drawn from
the original object. Then you have to set the side that the object will be drawn because there are two sides.

· R Array - Creates multiple copies of objects in a rectangular pattern. Shows the Rectangular Array  dialog.
With the rectangular array you can create an array defined by a number of rows and columns of copies of the
selected object. First you have to select the objects. Then you have to define number of rows and number of
columns of the rectangle, the distance between rows and the distance between columns. If no selection then
you will first be prompted to select entities.

· P Array - Same as R Array but copies radially around a center point. Select the objects to copy. Then set the
center point and next define the numbers of the copy objects that will be created and the fill angle. Lastly
choose if the object will be rotated or not.

· BTF - Bring to front. This changes the Z order of the objects in the render engine bringing the current selection to
the front. If no selection then you will first be prompted to select entities.

· STB - Send the current selection to the back of the Z order. If no selection then you will first be prompted to
select entities.

· Corner - Causes lines that can intersect to intersect. Start the command then select the first line then the
second line.
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4.1.2.5 CAD Tools

Active only when the current environment is a drawing.

Entities Page Group

· Line - A single line segment. Lines can be one segment or a series of connected segments, but each segment
is a separate line object.

· Polyline - 2D/3D line composed of line and arc (bulges) segments. Polyline is specified by an array of Vertexes
(points). When the Polyline has thickness then the extrusion vector of the polyline defines the direction of the
thickness. Polylines can be Open or Closed, can be SPLine and be filled with a color or a hatch.
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· Circle - A full circle is defined by its CenterPoint and its Radius. Circle is drawn in the plane that is defined by
CenterPoint and ExtrusionVector.

· Point - An object which occupies a single point in the coordinate system. The display of the point is inherited
from the document Point Style property and can be set by clicking Drawing>Point Styles...

· Rectangle - A rectangular object defined by an insertion point, height and width.
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· Text > 
Single Line of Text - Text inherits its style from the document Text Styles collection which can be

edited by clicking Drawing>Text Styles... Text entities do not have font properties directly but inherit the font and
font properties from the associated Text Style.

Multiline Text (MTEXT) - A multiline text entity.

· Image Frame - Used to render images in the document. Images may either be linked or imbedded in the
drawing file. The image frame defines the location and size of the displayed image. To imbed an image you must
edit the document Images collection Drawing>Images.
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· Construction Ray - A line entity defined by its starting point and an angle.

· 2 or 3 Pt Arc - A circular arc defined by the center point, the radius, the start angle and the end angle. An arc is
always drawn anti-clockwise from the StartAngle to the EndAngle. The StartPoint and EndPoint properties of an
arc are calculated through the StartAngle, EndAngle and Radius properties. The ExtrusionVector is always
vertical to the arc. Arc is drawn in the plane that is defined by CenterPoint and ExtrusionVector.

· Ellipse - Draw an Ellipse.
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· Cloud - Draw a cloud.

Blocks and Inserts Page Group

· Insert Block Into Drawing - Opens the Inserts  dialog. You can then insert an existing block into the
drawing or browse to another file to insert in the drawing.

· Write Block to File - Writes the selected insert out to its own file prompting you for the file save as name and
location as well as the new basepoint for the drawing.

· Create Attribute Definition - A tag/value data pair that can be included in a block to display editable text.
· Make a Block - Select entities and group them into a unit called a block. The block resides in the document

Blocks table. To display a block we Insert an instance of the block into the drawing at some point, scale, and
rotation.

· External Reference Manager - Other drawings may be displayed within the drawing space and maintained as
separate files. These are called Externally Referenced (XREFS) drawings. The externally referenced drawing
cannot be edited in the current drawing, only viewed, positioned, scaled and rotated. This function opens the 
External Reference Manager  dialog.

· Edit Attributes - Allows editing of the attributes of the selected insert of a block.
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Dimensions Page Group

Dimensioning is the process of adding measurement annotation to a drawing. There are many ways to dimension
objects and many ways to format dimensions. You can create dimensions for a wide variety of object shapes in
many different orientations. You can create dimension styles to format dimensions quickly and ensure that
dimensions in your drawing conform to industry or project standards. Dimensions show the measurements of
objects, the distances or angles between objects, or the distance of a feature from an origin you specify. There are
three basic types of dimensioning: linear, radial, and angular. Dimensions can be horizontal, vertical, aligned,
rotated, and angular. A linear dimension measures the distance between two points which is displayed parallel to
the points being measured. In aligned dimensions, the dimension line is parallel to the extension line origins. The
extension line origins are specified using the DefPoint1 and DefPoint2 properties.
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4.1.2.6 Advanced Tools

Active only when the current environment is a drawing.

Equipment Library page group

· Equipment Library - Opens the Equipment Library .

Rack Tools page group

· Rack Builder - Opens the Rack Builder  tool.

Equipment Functions page group

· Assign SysName - Assigns a SysName  to all selected inserts that are assignable.
· Error Check - Shows the Drawing SysName Error Check  dialog.
· Sync Insert with Database - Checks the selected insert to see if the SysName, Alias, Manufacturer,

EquipmentName, Location and User fields match the Equipment List. If they do not you will be presented with
the Sync Equipment Decision  dialog.

· Verbose SysName Assignment - When checked displays the SysName Assignment  dialog. Otherwise the
assignment proceeds with all default information.

· De-Assign SysName - De-Assign will remove the SysName data from the insert and mark the record in the
database deleted/available.

See also: Project Delete Handling  settings.
· Reset Selected SysNames, Reset All SysNames  - Reset will remove the SysName data from the insert and

do nothing with the database. The Reset functions are useful if you need to reuse a drawing and reassign new
numbers.

· Slurp SysNames - Gets all of the SysName data from the drawing and adds it to the database if not found in
the database. 

· Assign Terminal(s) - Starts the terminal assignment dialog for the current selection of assignable terminals.
· Link Selected Pointers - Allows you to link a selection of pointers with another selection of pointers.
· Rereference Drawing Pointers (change sheet reference name) - Allows you to change the name of the

sheet to which pointer(s) are pointed.

Cable Functions page group

· Assign Cable Number - Assigns the cable  a number based on several factors:
The Project Settings[Starting Number] .
Project Cable Number Format  tool.
Next Number  sequence.
Verbose Cable Assignment - See below.

The process of assignment will update drawing with the number as well as place an entry in the project Cables
table.
· Error Check - Shows the Error Check  dialog.
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· Verbose Cable Assignment - When checked displays the Cable Assignment  dialog. Otherwise the
assignment proceeds with all default information.

· Add Multicore Cable - Displays the Add Multi-core Cable  dialog. There you select the cable type number
base, etc. and build an entry in the Cables table for every core in the associated cable type marking the records
available.

· Draw Cable - Starts the Draw Cable  function.
· De-Assign Cable Number - De-Assign will remove the Cable data from the drawing and mark the record in the

database deleted/available. This function works across pointers. In other words if the cable that is being de-
assigned is pointed to another cable/drawing the complementary pointer is de-assigned as well.

See also: Project Delete Handling  settings.
· Reset All, Reset Selected Cables - Removes the Cable data from the drawing and do nothing to the database.

The Reset functions are useful if you need to reuse a drawing and reassign new numbers. This function does not
work across pointers.

· Recover Cables - The Recover Cables function does the following:
Gets all cable data from the drawing.
Compares it to the Cables table of the project.
Updates the Cable Number information in the drawing for matches. A match is found when the source and

destination SysNames, Locations, and Port names match.
· Tidy Cable - Forces the selected cable to be orthogonal (horizontal or vertical only).
· Slurp Cables - Gets all of the Cable data from the drawing and adds it to the Cables table if not found in the

database. 

AutoScheme Tools page group

· Auto Block - Shows the Auto Block  dialog. With Auto Block you can place functional blocks in the drawing
on a grid simply by selecting which SysName to place.

· Ratsnest - Shows the Ratsnest  dialog. Used in conjunction with Auto Block to wire the placed blocks. Pulls
cable data from the Cables table, searches the drawings for matches and when found places a cable.

WireCADify Tool page group

· WireCADify Block - Shows the WireCADify Block  dialog. Add the WireCAD attribute set to your CAD
blocks. You do not need to use this command on any WireCAD generated block.

· Add Connection Point - Shows the Add Connection Point  dialog. Add WireCAD Connection Points to
blocks that you have WireCADified. You do not need to use this command on any WireCAD generated block.
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4.1.2.7 View

The View tab is dynamic. It merges tools from the current environment. 

Static View

· Tool Panels >
Project Explorer - Toggle the visibility of the Project Explorer  Tool Panel.
Draw Cables - Toggle the visibility of the Draw Cables  Tool Panel.
Drawing Properties - Toggle the visibility of the Drawing Properties  Tool Panel.
Find and Replace - Toggle the visibility of the Find and Replace  Tool Panel.
Plan View Tools - Toggle the visibility of the Plan View Tools  Tool Panel.
Favorites - Toggle the visibility of the Favorites Tool  Panel.
Command Line - Toggle the visibility of the Command Line  Tool Panel.
There may be others depending on the plugins that are loaded. These are the default tool panels.

· Show Start Page - Toggle the visibility of the Start Page.
· Skin Gallery - Select the look and feel of the application.
· Switch Windows - {Current Window Set} - Toggle the active window.

Drawing Environment View

View page group

· Pan - Reposition of the view. This can be better done with the mouse wheel of your mouse. Depress the
mousewheel to click the button underneath it to activate the PAN mode. NOTE: this relies on your mouse driver
middle button set to default.

· Zoom Commands - Zoom command allows the user to increase or decrease the apparent size of objects , so
the user can control the part of the drawing that is included in the screen. Zoom commands are transparent.
Transparent commands are commands that can be invoked when another command is active.

Remarks:
There are several ways to execute the zoom command:
"E"(Extends) Zooms to display the drawing extents
"P"(Previous) Zooms to display the previous view
"W"(Window) Zooms to display an area specified by two opposite corners of a rectangular window. User

must specify these two corners.
"A"(All) zooms to the drawing limits or current extents, whichever is greater.

· Zoom Scale - Show the Zoom Scale dialog. Zooms the display at a specified scale factor. For example,
entering 2 doubles the apparent display size of any objects from what it would be if you were zoomed to the
limits of the drawing. Entering 0.5 causes each object to be displayed at half its current size on the screen.
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· Regenerate - Re render the entire drawing.
· New Viewport commands - Viewports are areas that display different views of your model. As you work, you

can split the drawing area into one or more adjacent rectangular views known as model viewports. In large or
complex drawings, displaying different views reduces the time needed to zoom or pan in a single view. Also,
errors you might miss in one view may be apparent into others. ViewPorts are treated as rectangle drawing
objects which display views and can be moved or resized. They can be created only in a layout and not in Model
space. You can also attach viewports to closed polygons (polylines, circles, ellipses, rectangles). 

Object Snaps page group

Object Snaps - OSnaps provide an easy way to pick geometric points from the drawing. 

OSnap Function

End End Point snap

Mid Mid Point snap

Center Center snap

Ins Insertion Point snap

Perp Perpendicular To snap

Near Nearest snap. This one overrides all others.

Inter Intersection snap

Node Point snap

Quad Quadrant snap

Tang Tangential To snap

AppInt Apparent Intersection snap

Disable Toggle currently selected OSnap state

All Enable/Disable all.

Info page group

· Measure Distance - Measure the distance in Drawing Units(DU) between two points selected from the drawing.
· Area - Measure the area of a selected object.
· ID - Get the drawing ID of the selected object.

Other

While WireCAD does not currently merge any other tools with the View menu, authors of WireCAD plugins have
the ability to merge their own tools onto this ribbon tab. Consult their documentation for information.
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4.1.2.8 Database

No environments currently merge with this tab. This is the default view but Plugins may register additional
commands.

Equipment Library page group

· Equipment Library - Show the global Equipment Library .

Global Database Grids page group

· Manufacturers - Show the global Manufacturers  Grid.
· Equipment - Show the global Equipment  Grid.
· Connectors - Show the global Connectors  Grid.
· Cable Types - Show the global Cable Types  Grid.
· Default Signal Types - Show the Default Signal Types  Grid. This grid defines many default behaviors

like cable color and default cable type. For more information see this topic on Signal Types .
· Pinouts - Show the global Pinouts  tool.

Project Database Grids page group

· Equipment List - Show the project Equipment List . This is the collection of all SysNamed equipment across
all drawings in the project.

· Backbones - Show the project Backbones grid. (ENT ONLY). This is the collection of all Backbones in the
project.

· Circuits - Show the project Circuits grid. (ENT ONLY). This is the collection of all Circuits in the project.
· Cables - Show the project Cables  grid. This is the collection of all Cables in the project.
· Index Grids > For more information see this topic . This sub menu will show any or all of the index grids and

allow you to delete and rebuild the indexes.
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· Project Signal Types - Show the Project Signal Types  grid. This grid has priority for Signal Types. If a signal
type is not found in this database it is pulled from the Default Signal Types  grid.

· Locations - Show the project Locations grid. This is the collection of all Locations in the project.
· Named Paths - Show the project Named Paths grid. This is the collection of all Named Paths in the project.
· Todo List - Show the project Todo List.
· Import Project Data Wiz - Show the project Import Data Wizard. This tool allows you to import cable and

equipment data from other sources.
· Add Multicore Cable - Displays the Add Multi-core Cable  dialog. There you select the cable type number

base, etc. and build an entry in the Cables table for every core in the associated cable type marking the records
available.

Utilities page group

· Pack Project Database - This file base database utility will compress and reorganize your project database.
· Pack Global Database - This file base database utility will compress and reorganize your global database. 
· Synchronize Global Database - Show the global database Synchronizer  tool. This tool allows you to

import/export/merge two global databases of either SQL,VISTA, or SQL Azure.
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4.1.2.9 Plugins

This tab is dynamic. Depending on product level and installed third party or WireCAD plugins these menu items
are subject to change.

Plugins page group

· Plugin Manager ... - Shows the Plugin Manager  dialog where you can control which plugins are loaded.
· Script Editor Runner - Shows the Script Editor/Runner  dialog. This tool allows you to create custom scripts

to perform tasks. You can view/edit existing scripts that show how to do a bunch of things by browsing to the
script folder in c:\users\public\wirecad\wirecadx\scripts. Therein you will find many example scripts. Scripts are
written in C# and the editor provides intellisense hints.

· Translation Manager - Shows the Translation Manager . While not technically a plugin we have always
shown it here so why break with tradition. All text (strings) in WireCAD are held in a dictionary. The dictionary is
editable through the Translation Manager. All strings default to English if the machines current culture cannot
find a translation in the dictionary.  You have the ability to change the displayed messages, column headings,
and all other strings.

· Batch Plot - Show the Batch Plot  tool. This tool allows you to scan the drawings for layouts and select the
layouts to print/plot in a batch. You can save/load your settings for the next time around. 

· Brother P-Touch! - Show the Brother P-Touch! plugin to print directly to P-Touch! printer with USB ports that
support direct print. (NOTE: not all P-Touch! printers with USB ports support direct print).

· PatchVerx - If you have installed PatchVerx on your machine this icon will be present so you can run the worlds
best patchbay designation strip tool inside of WireCAD and pull data directly from your Cables table and place in
on your patchbay label.

CAD Tools page group

· Extract All Blocks - Extracts all blocks  from the active drawing and writes them out as individual dwg files to
the selected folder.

· Bulk Block Fixer - If you want to use someone else's CAD blocks you will need to fix them so they work with
WireCAD. This is the tool.

· DWG Diff - Drawing Differencing tool. Compare two similar drawings and create three views A not B, B not A,
and Common to Both. Compares geometry and drawing collections like layers, linetypes, etc.
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4.1.2.10 Reports

Items on this tab are static. Whether or not the gallery displays is based on the Application
Menu>Settings[User][Basic]ReportShowMode.

Reports page group

· New with Wizard... - Create a new report using the New Report Wizard. We recommend that you find a report
in the existing Reports Gallery that is close and save that as your new name then edit your changes there. You
will save a bunch of time.

· Generate Bill of Materials - Shows the BOM generator  which counts equipment, cable, and connectors in
the project. NOTE be sure to run this tool before you run any of the BOM reports or they will be empty.

· Scan Project for Discrepancies - Scan for common problems. Shows the Discrepancy Scanner  dialog.
When it finishes you can see the results in the Project Discrepancy list from the Project Explorer.

· Reports Gallery - Lists all reports in the %REPORTS% support path and its subdirectories. Clicking a gallery
item will load the report into a report form for preview/design/export.
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4.1.2.11 Plan View and Layout Tools

Active only when the current environment is a drawing.

For more information see the Plan View and Layout Tools  topic.

Estimating page group

· Take Offs - Show the Take Offs  tool. This tool assists in counting items in the drawing.

Locations page group

· Add Boundaries from Text - Add Location Boundaries  using a text entity to derive the location name. Once
you select a text entity the Boundaries form is displayed allowing you to set the remainder of the properties.

Cabling page group

· Draw Backbone - ENT only. Draw a polyline representing the backbone in the plan view space. Then assign a
number, cable type, source and destination ports and add that to the database. 

· Draw Cable - Drawing a polyline representing a cable from a location boundary to another location boundary or
from placed equipment to placed equipment. Cable information is then created in the Cables table.

· Populate Cables - Automatically places arched cables from location to location as defined in the Cables table.
· Draw Prewire Cables - Draw a polyline representing prewire cables and add the data to the Cables table

marking the IO as PREWIRE. Later, you can assign cables to those PREWIRE entries.

Equipment page group

· Populate Equipment - Automatically place SysNamed equipment in the drawing in the Location Boundaries
if found.

· Place Equipment - Place unnamed plan view equipment in the drawing. Preferably after Location Boundaries
have been defined.
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4.1.2.12 Print Preview

Visible only when the active environment is a report.

Related Topics:
Print Preview Reports Form

4.1.2.13 HTML View

Visible only when the active environment is a report.

Related Topics:
HTML Preview Reports Form

4.1.2.14 Report Designer

Visible only when the active environment is a report.

Related Topics:
Report Design Form
A discussion on report design can be found here .
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4.1.2.15 Toolbox

Visible only when the Report Designer Tab is active.

Related Topics:
Report Design Toolbox Form

4.1.2.16 Cable Data Selector

Visible only when the active environment is a report.

Related Topics:
Cable Data Selector Form

4.1.2.17 GPS Mapping Tools For Drawings

Active only when the current environment is a drawing.
The GPS Mapping Tools section provides access to the functions necessary to use your DWG plant drawings with
the GPS coordinate system.
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4.1.2.17.1  GPS

Active only when the current environment is a drawing.

Calibrate: Align the world coordinate system of the drawing to the GPS coordinate system.

Delete Calibration: Removes the calibration data from the drawing. Only available if the drawing has current GPS
calibration data.

Copy from Other Drawing: Allows you to copy calibration data from a drawing that shares the same coordinate
data. The drawing you are copying from must have GPS calibration data or this function will fail.

Show Calibration Marks: Place location markers at the two calibration points in the drawing.

Related Topics:
How To: Calibrate Your DWG to the GPS Coordinate System
How To: Copy Calibration Data from another Drawing
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4.1.2.17.2  Tools

Active only when the current environment is a drawing.

Relate Section

ID Location GPS Coord: Associate a Locations table record with a specific GPS coordinate point.

Related Topics:
· How To: Associate GPS LAT, LON with your Locations  Map tool version
· How To: Associate GPS LAT, LON with your Locations  DWG version.
· ID GPS Locations  dialog reference.

Tools Section

Get GPS Point to Clipboard: Allows you to select a point in the drawing. Once a point is selected its GPS lat,
lon are copied to the clipboard as text. You can paste this data into any other application as text.

Show GPS Point in Drawing: Prompts for the GPS Lat,Lon to show. Enter the Lat,Lon in the command line. A
location marker will be placed and zoomed into view.

Draw Section

Panel: Place a new SysNamed Panel or other equipment at a specific location within the drawing using the GPS
Location markers as the location for the equipment. Requires that at least one Location Marker is displayed. For
more information on displaying Location Markers see this topic .

Backbone: Draw a new Backbone between two panels. The panel markers must exist in the drawing.

Related Topics:
· How To: Show Panel Markers in your Drawing .
· How To: Draw a Backbone in your Drawing.
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4.1.2.17.3  Display

Active only when the current environment is a drawing.

Reset Section

Reset All: Removes existing Location, Panel and Backbone markers.

Location Marker Section

Location Marker: Toggle the view of the Location Markers in the GPS calibrated drawing.

Location Markers are inserts that are placed at the GPS coordinates of the drawing. The tooltip of the marker
displays the Location name as defined in the Display Format String of the GPS Settings  tool as well as any
equipment found at that location.

Location Markers are placed in the drawing on a layer named "GPS_LOC_PIN_TEMP". We do not recommend
placing any other entities on this layer. When the Location Marker toggle button is set to unchecked, all layer
entities are deleted without prompting.

Double-clicking a Location Marker in the drawing will show its statistics.

Insert Scale: Sets the scale of the block defined in the Geometry setting. 

Geometry: Sets the block to insert as a Location Marker. The Geometry dropdown is populated by dwg files in the
%BLOCKS% \GPS\Location Markers directory. 
In a stock installation this will be:
C:\users\public\documents\WireCAD\WireCADx\Blocks\GPS\Location Markers.

Overlay Mode: Determines the display behavior of locations that share the same GPS coordinates. The modes
are:
· None: Do nothing. Overlay marker upon marker. In this mode the tooltip data is aggregated to the topmost

marker.
· Offset: Offset the markers based on the OffsetX and OffsetY of the GPS Settings .
· Rotate: Rotate the markers around the point.
· Radial: Rotate the markers based on the Radial Angle and Radial Distance of the GPS Settings .
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Panel Marker Section

Panel: Toggle the view of the Panel Markers in the GPS calibrated drawing.

Panel Markers are inserts that are placed at the GPS coordinates of the drawing. The tooltip of the marker
displays the Sysname as defined in the Display Format String of the GPS Settings  tool as well as any
Backbones found on that SysName.

Panel Markers are placed in the drawing on a layer named "GPS_LOC_PANEL_TEMP". We do not recommend
placing any other entities on this layer. When the Panel toggle button is set to unchecked, all layer entities are
deleted without prompting.

Double-clicking a Panel Marker in the drawing will show its statistics.

Insert Scale: Sets the scale of the block defined in the Geometry setting. 

Geometry: Sets the block to insert as a Panel Marker. The Geometry dropdown is populated by dwg files in the %
BLOCKS% \GPS\Panel Markers directory. 

In a stock installation this will be:
C:\users\public\documents\WireCAD\WireCADx\Blocks\GPS\Panel Markers.

Overlay Mode: Determines the display behavior of panels that share the same GPS coordinates. The modes are:
· None: Do nothing. Overlay marker upon marker. In this mode the tooltip data is aggregated to the topmost

marker.
· Offset: Offset the markers based on the OffsetX and OffsetY of the GPS Settings .
· Rotate: Rotate the markers around the point.
· Radial: Rotate the markers based on the Radial Angle and Radial Distance of the GPS Settings . 
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Backbones Section

Backbones: Toggle the view of the Backbones Markers in the GPS calibrated drawing.

Backbone Markers are polylines that are placed at the GPS coordinates of the drawing. The tooltip of the marker
displays the Backbone either the basic data of the first strand of fiber in the Backbone or the full Backbone
statistics if the Show Backbone Stats checkbox is checked.

Backbone Markers are placed in the drawing on a layer named "GPS_LOC_BB_TEMP". We do not recommend
placing any other entities on this layer. When the Backbone toggle button is set to unchecked, all layer entities
are deleted without prompting.

Double-clicking a Backbone Marker in the drawing will show its statistics.

Arc Distance: Sets the polyline bulge factor of the Backbone. A bulge factor of 1 will create an arc of 180°. 

Arc Distance of .1

Self-Connect Arc Distance: Sets the polyline bulge factor of polyline that share the same source and destination
location GPS coordinates.

Show Mode: Determines the display behavior of backbones. The modes are:
· ByGPSLocation: Place the source and destination points of the polyline based on GPS coordinates.
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· ByLocationMarker: Place the source and destination points of the polyline based on the GPS coordinates of
Location Markers found in the drawing. This can be used to limit the display of Backbones.

· ByPanelMarker: Place the source and destination points of the polyline based on the GPS coordinates of
Panel Markers found in the drawing. This can be used to limit the display of Backbones.

ByPanelMarker

Show Backbone Stats: Generate the backbone statistics such as total fiber count, available fiber count and
blocked fibers. This data is then displayed in the tooltip when the mouse hovers over the Backbone polyline.

Show Vias: If the Backbone contains related Via data with Locations (with GPS data) the polyline traverse from
source to destination and every Via point.

Filter Section

The filter section is cascading. Selecting a location will cascade to the Panels filter by limiting the Panels shown
to those that appear at the selected Location(s). In the same way, the Panels filter will cascade to the Backbones
filter.

Locations: Filter by Location.
Panels: Filter by Panels.
Backbones: Filter by Backbones.

Settings Section

Settings: Display the GPS Settings .382
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4.1.2.18 GPS Mapping Tools for Map Tool

Active only when the current environment is the Map Tool.

4.1.2.18.1  File

Active only when the current environment is the Map tool.

Print Preview: Show the Print Preview dialog. From the Print Preview dialog you can set the paper size, scale,
orientation, and printer. You can also export to several formats from here.

Print Setup: Show the printer setup dialog where you can set the printer and print preferences.

Related Topics:
Print Preview  

4.1.2.18.2  Tools

Active only when the current environment is the Map tool.

ID GPS Location Coord: Show the ID GPS Location Coordinate dialog. 

Copy Point to Clipboard: Select a point and the GPS coordinates are copied as text to the clipboard. The text
format is: Lat,Lon in decimal form.

Related Topics:
ID GPS Locations  

320
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4.1.2.18.3  Display

Active only when the current environment is the Map tool.

Reset All: Removes all Location, Panel and Backbone Markers from the map.
Locations: Toggle the display of Location Markers in the map.

Panels: Toggle the display of Panel Markers in the map. Panel text is determined by the Display String Format of
the GPS Settings  panel.382
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Backbones: Toggle the display of Backbone Markers in the map. Backbone color and line width can be controlled
from the GPS Settings  panel

Filters: 
The filter section is cascading. Selecting a location will cascade to the Panels filter by limiting the Panels shown
to those that appear at the selected Location(s). In the same way, the Panels filter will cascade to the Backbones
filter.

Locations: Filter by Location.
Panels: Filter by Panels.
Backbones: Filter by Backbones.

Zoom Extents: Show all entities in the map.

Settings: Show the Settings dialog with the GPS Settings  panel shown.

Related Topics:
GPS Settings

4.2 Dialogs

Dialogs differ from Forms in that they do not occupy the full client docking area of the main window. Dialogs can be
floating or modal. When a dialog is modal no other interaction with elements outside the modal dialog can take
place.

Dialogs will remember their position and size unless you enable the setting : 
Application [Basic] Disable Form State Tracking.

Related Topics:
None
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4.2.1 Application Menu Dialogs

The following is a set of dialogs associated with Application Menu.
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4.2.1.1 New Project Wizard

Application Menu >  New Project...
Commandline: np

Explanation

WireCAD Projects are a loosely coupled collection of files, folders and databases. The New Project Wizard will
guide you through the steps of creating a new Project with several different options for different database types.
For a more extensive discussion see the How To: Create a New Project  topic.

Related Topics:
Create a new Project

Dialog Options

· Navigate Forward, Navigate Backward

43
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Explanation

Related Topics:
Choose your Database Type

Choose Database Page Options

· Use File Based Local or Network Share Database (VISTADB) - File based databases.
· Use Database Server (SQL Server) - You will need the host name and log in info to proceed.
· Use SQL Azure (cloud storage) - You will need a Microsoft Azure account for this option. Don't have one?

Contact us. We can help.

162
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Explanation

Name, describe and locate the project.

NOTE: SQL, and SQL Azure do not like project names that start with a number.

Related Topics:
Default Project Location

Name, Description, Location Page Options

· Name - 50 Characters max. Must not have any operating system illegal characters. We also recommend not
using the ['] apostrophe.

· Description - Required.
· Project Files Path - Pulled from the Settings, you can change it here.
· Project Lead Person - Who is in charge here.

360
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Explanation

How do we log in to the SQL Server. There is a subtle distinction to be made between SQL And SQL Azure:
· SQL Server the database name will be the Project Name.
· SQL Azure the database name will be the name you gave your SQL Azure database. We will create a schema

on that database with the project name as the schema name.

Related Topics:
Choose your Database Type

Database Host Page Options

· Host Name - The host name and instance of your SQL Server.
· Database Name - The database name. See the explanation above.
· Use Windows Security - Not valid on SQL Azure.
· User Name and Password
· Test - Can we connect?

There are several pages of project settings that can also be found in the Application Menu>Settings[Project]
dialog.

162
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Finalization

Clicking Finish starts the project creation process. Make sure that at the end the log tells you that it finished. If not
the project was not properly created and you may experience errors later.
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4.2.1.2 Project Save As

Application Menu >  Save Project As ...
Commandline: save project as

Explanation

This tool allows you to save a project as a new name in a new location. SQL projects may be saved as new SQL
databases or file based databases. A File Based database may only be saved as a file based database.
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Dialog Options

· Navigate Forward, Navigate Backward

· Create a New Server Database - Only if source project is SQL.
· Create as File Based (local) Database - Only if source project is SQL.

Explanation

Select the location and whether we copy the data from the database or create a new empty database.
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4.2.1.3 Manage Security

Application Menu > Security Tools > Manage Security ...
Commandline: security

Explanation

Administrators can manage users, groups and permissions. If WireCAD Security is enabled (see related topics).
The person that enabled the Security option is the Administrator (the Great and Powerful Oz). All other users will
be added automatically to the Users (mere mortals) group. Oz may:
· Change the group to which the user belongs.
· Create new groups.
· Modified group permissions.
· Create other Ozes. 

So to be clear. Users belong to Groups. Groups have Permissions.

NOTE: No action is required to add a user. They simply need to open WireCAD. If their user profile does not yet
exist in the WireCAD Security database, it will be added to the Users group.

NOTE: Oz can proactively add users by searching the Active Directory and adding the user to the group of his
choosing.

Related Topics:
Application Setting - WireCAD Security
Application Setup Wizard

358
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Users and Groups Tab Options

· New User - Create a new user and assign to a group.
· New Group - Create a new Group and associate Permissions set. After creating the new Group, switch to the

Permissions tab and set the permissions on the collections and drawings.
· Search Active Directory - Using the standard AD search box.

· User Grid - Assign the User to a Group.

Permissions Tab Options
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Explanation

Each data collection in WireCAD has Edit, Delete, and Create permissions. This grid enumerates each collection
for each group. 

Related Topics:
Grid Basics

· Collection Name - This is usually the table name in the database.
· Permissions. - Edit, Delete, AddNew.
· GroupName - You may find it handy to filter by group name then set the permissions for the group.

· Select All and Clear Selection.

24
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4.2.1.4 Packup / Checkout

Application Menu > Check In/Out > Pack up /Check Out ...
Commandline: packup

Explanation

A WireCAD project is a loosely coupled group of files, databases and settings. The global database is maintained
separately from the project database, and drawings may have linked images. In order to move the project to
another machine we will need to gather all of the resources used to create the project into a central location (the
project folder).
The Packup / Checkout Tool performs the following functions:
· Copy a file based version of the Global Database into the Project\Project Databases folder and sync it with the

SQL Server version if necessary.
· Copy all linked images to the drawings directories.
· If [Check-out] then flag the project as read only.
· If [Compress Ouput] then zip all the project folder items into a single zipped file with the name:

[PROJECT_NAME.ZIP]

NOTE: This process can take some time on large projects.

Related Topics:
Moving Projects 154
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Dialog Options

· Check Out Project - Flag the Project Read Only. This is useful if the project is going out into the field for
commissioning. The version that stays in the office should not be edited.

· Expected Return Date - Let the people in the office know when you think you will have the project checked in.
· Compress Output - Zip it.
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4.2.1.5 Unpack Project

Application Menu > Check In/Out > Un Pack ...
Commandline: unpack

Explanation

The complementary function to the Pack Up is the Un Pack. This function performs the following:
· Unzip the compressed file (if necessary).
· Sync the local Global Database with the one found in the incoming Project Databases folder.
· Open the project for use.

NOTE: This process can take some time on large projects.

Prerequisites
A project that has been Packed Up. Using the Pack Up / Check Out tool.
No project can be open or the tool will not run.

Related Topics:
Pack Up / Check Out
Moving Projects

Dialog Options

· Project Path - Browse to the zipped file or the .wc6plf file.
· Open project after unpack - Of course.

342
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4.2.1.6 Check in Project

Application Menu > Check In/Out > Check In...
Commandline: packup

Explanation

The complementary function to the Check Out is Check In. This function performs the following:
· Unzip the compressed file (if necessary).
· Sync the local Global Database with the one found in the incoming Project Databases folder.
· Syncs the Project Database of the incoming project with the location database.
· Overwrite all drawings with the incoming ones.
· Remove Read Only flag.

NOTE: This process can take some time on large projects.

Prerequisites
A project that has been Checked Out. Using the Pack Up / Check Out tool.
The Checked Out local project must be open before this tool will run. 
The project names of the local and incoming projects must match or the tool will fail.

Related Topics:
Pack Up / Check Out
Moving Projects

Dialog Options

· Project Path - Browse to the zipped file or the .wc6plf file.
· Open project after unpack - Of course.
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4.2.1.7 Account Info

Application Menu > Account Info
Commandline: Edit Account Info

Explanation

This dialog allows you to enter account specific data for use in reports.
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4.2.1.8 Application Setup Wizard

Application Menu > Application Setup Wizard...
Commandline: showappsettings

Explanation

This wizard runs once at the start of WireCAD. You can always run it again to change the settings, but most of the
settings in the wizard are contained in the Settings dialog.
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Dialog Options

· Navigate Forward, Navigate Backward

· Show This Again - Show this dialog again.

Global Database Location Page Options

· Local Machine - The default location is c:\users\public\WireCAD\WireCADx\WireCADGlobalEquipment.vdb3.
You may rename the file in order to better organize your global data by client. See this topic on the Global
Database Location .

· Remote Network Storage - This is not recommended but is possible. Why do we do this? Well we hate to
limit you. Here are the ramifications of using file based storage over a network:

The file is not network fault tolerant like SQL Server.
Data can become locked and in some cases corrupt.
You may find yourself having to Pack (compact and repair) the database if you get locked out of it.

· SQL Server - This is the best option for shared storage, but you lose portability.

359
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Database Path Page Options

· Path to Shared Global Database - Show if the first selection is Remote Network Storage. Enter the Path to
the WireCADGlobalEquipment.vdb3
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Show only if the initial selection is SQL Server.

Database Host Info Page Options

· Create stand-alone database - Use this option if you are installing on an internal network.
· Use existing database. Create global db using schema name. - Use this option if you are installing on a

SQL Azure database. The schema name is used to separate different data structures on the same database.
· Host - The hostname\instance name or IP address\instance name.
· Global Database Name - Either the name of the existing global database or the name of the SQL Azure

database on which we will create our global database schema.
· Schema Name - Name this something like WireCADGlobalData.
· Use Windows Security - Not available on SQL Azure.
· User Name, Password - 
· Test - See if we can connect.
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Shown only if the SQL Server Option is selected.

Create Tables and Add Data Page Options

· Add default global data - Create the database on the host and add the selected default data.
· Create empty database - Create the database on the host with no data.
· Create Database and Add Data - Do it!
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WireCAD Community Server Contribution Mode Page Options

· Yes I want to contribute
· Yes but wait until I check the Approved field
· No Thanks - You can still manually upload from the Equipment Library in this mode.
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Explanation

WireCAD Security is used to restrict user access to key application sections and functions. If enabled, the user
launching WireCAD will be subject to the rules of the group to which they belong. The user that initiates WireCAD
security will be the only Administrator and will need to assign all other user permissions. This is managed through
the Manage Security  dialog.

Use WireCAD Security Setting Page Options

· Use Security - 
· Database Type - 

VISTADB - while you can use VISTADB as the security database it is only application to this machine.
SQL - we will create the permissions database on your SQL Server using the SQL host and login

information.
Create SQL Permissions Database - Do It!

339
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Explanation

We found a WireCAD previous version. In order to use the work that you have already done you will need to
synchronize with the previous version Global Database. There are many variables that can be configured to locate
the Global Database elsewhere. When you finish the Application Setup Wizard restart WireCAD then launch the
Database >Sync Global Database tool and set the remote database to look at your previous instance.

Related Topics:
Synchronizing with Another Global Database
Sync Global Database dialog

157
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4.2.1.9 The Settings Dialog

Application Menu > Settings
Commandline: set

Explanation

The Settings dialog is comprised of the following sections:
· Application - settings that determine the behavior of WireCAD for this machine. These settings are stored in the

Global Application Data folder as ApplicationSettingsX.xml.
Basic
WireCAD Security
Global Database Location
Support Paths
Organization
Enable/Disable Plugins
Todo List

· User - settings specific to your user profile on this machine as UserSettingsX.xml.
Basic
Projects List
Drawing
Drawing (advanced)
Command Line Shortcuts
Enterprise CMS (ENT Only)
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Expert Mode
· Project - settings specific to the current project. These settings are stored in the project folder as

ProjectSettingsX.xml.
Basic
Advanced
Locations
Delete Handling
Enterprise CMS
Export Settings
Project Rules
Status Behavior

NOTE: These are the stock basic settings panels. Third party developers may register their own settings panels.
See their documentation.

Prerequisites
None

Dialog Options

· Save - Commit your changes and issue a SettingsChanged command to the application.
· Close - Do nothing and discard your changes.
· Restore Defaults - Restore the defaults of the current settings panel.

4.2.1.9.1  Application Settings

Application settings that determine the behavior of WireCAD for this machine. These settings are stored in the
Global Application Data folder as ApplicationSettingsX.xml.
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4.2.1.9.1.1  Application Basic

Basic Panel Options

· Check for Program Updates Automatically on Startup - If updates are available you will see a banner pop up
in the lower right-hand corner of the screen.

· Show Application Setup Wizard on Startup - This is usually unchecked except the first run of the
application. You can always start the Application Setup Wizard by clicking Application Menu > Application
Setup Wizard.

· Community Server Contribution - How will you contribute to the WireCAD Community?
· Customer Experience Improvement Program - You must opt in to the CEIP. We will then gather usage and

error data. The generic data will be uploaded to our servers and aggregated so we can bring you a better
application.

· Silent Plugin Load - Hide all error messages on startup.
· Default Project Database Host - Applies only to SQL projects. Presets the New Project Wizard.
· Use SQL Server Project Databases by Default - Presets the New Project Wizard.
· Users (mere mortals) can select Project Database Mode - Some organizations may wish to limit selection of

project database type.
· Disable Form State Tracking - The setting disables the functions that remember form position and sizing. This

can be helpful if you are experiencing trouble with different resolution monitors in a multi-monitor setup.
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4.2.1.9.1.2  WireCAD Security

WireCAD Security Panel Options

· Use WireCAD Security - Enable Security. When enabled the WireCAD security system uses the current login
to determine program access. If your user is a member of the Administrators group you will be able to control
the access of other users via the Application Menu > Security > Manage Security... dialog.

· Database Type - Typically you will only use security in a multi-user environment with a SQL host, but the
capability exists to use file based VistaDB databases.
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4.2.1.9.1.3  Global Database Location

Global Database Location Panel Options

· Database Mode - VISTA/SQL. NOTE: SQL will work for SQL AZURE as well. We will need the database name
and schema name.

· VISTADB Location - Path to the VISTADB file that is your WireCADGlobalEquipment.vdb3 file.
· Global DB File Name - Note that this is the default name given to the global database file but you may change

it.
· Host Name and Instance - This can be a fully qualified path, ip address, or host name.
· Database Name - The name of the global database to connect to. This is WireCADGlobalEquipment by default

but you may choose to rename it.
· Use Schema, Schema Name - WireCAD supports multiple schema in the same database file. This is useful if

you are using a cloud based SQL Server service that charges by the database. You can have a schema for your
global database and one for each of your project databases. All contained within the same database file.

· Use Window Security - Use this if you wish Windows security to manage the login. This will not work with SQL
Azure.

· User Name, Password
· Test Connection - Test to see if you can connect and have the appropriate privileges.
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4.2.1.9.1.4  Support Paths

Application - Support Paths Panel Options

· Block %BLOCKS% - The path that will replace the %BLOCKS% variable in the equipment library.
· Images %IMAGES% - The path that will replace the %IMAGES% variable in the equipment library.
· Documents %DOCUMENTS% - The path that will replace the %DOCUMENTS% variable in the equipment

library.
· Icons %ICONS% - The path that will replace the %ICONS% variable in the equipment library.
· Template Drawings - The path to the Template Drawings folder. This is the folder where Template

Drawings are saved when using the File > Save As Template Drawing function is used and the folder that
the New Drawing Wizard searches to fill the Templates list:
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· Reports - The path to the top reports folder. This is a recursive search and will enumerate all subfolders and
files.

· Default New Project Location - Presets the New Project Wizard.

4.2.1.9.1.5  Organization

Application - Organization Panel Options
This one's self-explanatory
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4.2.1.9.1.6  Enable/Disable Plugins

Enable/Disable Plugins Panel Options

Move items to the left-hand list to disable.
Move items to the right-hand list to enable.
This panel only works with Plugins that support the wpi manifest file. Auto-discovered Plugins cannot be disabled
from here.
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4.2.1.9.1.7  Todo List

Explanation
Sets the drop downs in the Project Todo List

Application - Todo Panel Options
· Assignees - List of people to whom a task may be assigned.
· Statuses - List of Todo item statuses. Modify this to suit your needs.
· Priorities - List of priorities. Again, make it fit your needs.

4.2.1.9.2  User Settings

User settings specific to your user profile on this machine. The path to these settings is usually:
C:\Users\<YOUR_USER_NAME>\AppData\Local\WireCAD\WireCAD9\UserSettings.xml.

Your system administrator has the ability to modify this.
You can use:
Application Menu > Frequently Used Folders > User Application Data Folder
To know the path we are using.
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4.2.1.9.2.1  User Basic

These are settings for your user profile on this machine.

Basic Panel Options

· Open New Drawing Upon Application Startup - Opens a blank new drawing when WireCAD starts.
· Use the New Drawing Wizard - Shows the New Drawing Wizard when you click File > New. Allows the

use of template drawings. If set to false, just creates a new drawing without a template.
· Open My Last Project When I Start WireCAD - Behaves like earlier versions of WireCAD that opened the last

project automatically on startup.
· Show Library Tips - This shows the Tips and Tricks form in front of the Equipment Library.
· Show the WireCAD Startup Page
· Warn of Signal Type Mismatch - When you finish drawing a cable WireCAD will check the source and

destination port signal types and let you know if they don't match. You can use the new status panel to know
the port type if you are confused.
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· When I Double-click a Many-to-Many Cable Assign All of Them - Many-to-Many cables that are set for
Multiple Database Entries can either be assigned all at once by a single double-click, or if this setting is turned
off a double-click will find the closest port to the cursor and assign that.

· Keep Equipment Library Open - This is useful if you are using dual monitors and want to have the Equipment
Library stay open on the other monitor.

· When I Link Pointers Go Back to the Starting Drawing When Finished - The default Link Pointer function
will leave you on the second sheet. If you set this to true it will jump you back to the first sheet.

· My Spacebar is my Enter Key - This is helpful when executing command line commands.
· MouseWheel Double-click Zooms Extents
· Library Multiple Port Add Leading Zero Count
· I Will Manually Refresh the Project Explorer - True to disable autorefresh on the Project Explorer. This

may be helpful if your project grows to have hundreds of drawings.
· When a Drawing Opens Don't Show the Draw Cables Tool Panel
· Lazy Load my drawings in the Project Explorer - True to disable recursive search of all drawing subfolders.

This may be helpful if your project grows to have hundreds of drawings.
· Default BOM Snapshot Name - Presets the BOM Generator. The {0} represents the current date.
· Report Show Mode - Where are we seeing the reports. 

Project Explorer - appends the reports tree after the project.
Reports Gallery - populates the Reports Gallery with thumbnails and descriptions from the accompanying

report manifest xml files (if any).
· Automatically validate my equipment when I open the Equipment List grid - Default = true but can be

expensive on large projects.
· Automatically Index Project and Drawings - For more information see the Understanding Indexes  topic.

True will re-index the project on open and drawings on save.
· Show Index Operation Progress - Displays the progress bar during index operations.

105
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4.2.1.9.2.2  Projects List

The Most Recently Used (MRU) projects list. The depth of the list is set. As soon as the list count is exceeded the
oldest item is discarded.

Projects List Panel Options

· Most Recently Use Projects List Count - How many items allowed in the list.
· Projects List - displays the name path and whether the project can be reached.
· Clear - Reset the list.
· Remove Missing Items - Remove items that cannot be found because the path has changed or is currently

unavailable.
· Remove Item - Remove the selected row.



Reference 367

© 2017 Holbrook Enterprises, Inc. dba WireCAD

4.2.1.9.2.3  Draw ing

Common user specific drawing environment settings.

User - Drawing Panel Options

· Auto Save Duration - Sets the Auto Save Duration. Auto Save saves only drawings that are modified but not
currently involved in a function.

· Arrow Move Nudge Distance - When nudging a selection how far do we move in the direction.
· Grip Color, Grip Size, Cross Hair Size
· Show UCS Axis - Shows the UCS Axis:
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· Show Paper Space Paper - When a layout is selected, show the current page size as returned by the
selected printer as a white "page."

True

False

· Save Drawing After Every Cable Number Assignment - Setting this to true is not recommended but will
speed the assignment process. You are responsible then for saving the drawing to ensure drawing/database
parity.

· Touchscreen Mouse Logic
· Clear Selection After Command Executes - Overrides the default behavior of leaving the selection set in tact

after an operation. 
· Drawing Background Follows Skin Theme, Background Color, OSnap Color
· Pick Size - Sets the pick size in pixels. The pick determines the search window aperture when clicking the

cursor.
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4.2.1.9.2.4  Draw ing (advanced)

These are really granular controls of the render engine. It is beyond the scope of this manual to explain each we
will hit some, but play with them if you are interested and see how they behave.

User - Drawing Advanced Panel Options

· BackupOnSave - Saves the file with the ~.bak extension before overwriting the existing file.
· DisableShowPrinterPaper - Same as Show Paper Space Paper.
· DisableXrefTooltips - Sometimes XREF tool-tips can be annoying.
· EnableTooltips - Show tool-tips or not.
· EnableURLs - URLs of object will be opened.
· MirrorText - Controls how the Mirror command deals with text.
· CurveResolution - How many segments to a circle.
· PickAdd - Sets whether a user selection action replaces the current selection or adds to it.
· SelectActionKey - Set a key value used in combination with mouse-down to add or remove selected item(s)

from a selection.
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4.2.1.9.2.5  Command Line Shortcuts

User - Command Line Shortcuts Panel Options

· Register Your Own Command, Remove Command - Developer function.
· Check - Checks the shortcuts to see if you have any duplicates.
· Commands List - You may freely edit any of the columns:

CommandName
Alias
ShortCut

Even though the grid allows you to edit the following fields if you are not a developer you should NOT edit any of
the columns:

Assembly
NameSpaceAndClass
MethodName
You will break WireCAD. 
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4.2.1.9.2.6  Enterprise CMS

Enterprise CMS Panel Options

· Use Stock WireCAD Startup Page - No longer active. Has no effect.
· Default New Circuit Strand Count - When creating a new circuit, a default strand count for jumpers is created.

This will change that strand count to a different value.
· Warn of Connector String Mismatch - Having this box checked will allow a warning message to display

anytime WireCAD detects that 2 ports being connected have a different connector type. 
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4.2.1.9.2.7  Expert Mode

User - Export Mode Panel Options

Explanation

Fine tune WireCAD for you.

· Beginner Mode - tightly couples the help system with your actions in the application. The help system will
display topics based on the current form or dialog.

· Enable Expert Mode - Once you learn WireCAD functions, the explanatory dialogs that show before a function
executes can be disabled.

The functions that will execute without explanation are:
· Rack Builder tool.
· De-assign Cable.
· De-assign SysName.
· Reset All SysNames.
· Reset Selected SysNames.
· Reset All Cables.
· Reset Selected Cables.
· Project switching will not inform you that the current project needs to be closed.
· Equipment Library tips will not be shown.
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4.2.1.9.3  Project Settings

Settings specific to the current project. These settings are stored in the project folder as ProjectSettings9.xml.
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4.2.1.9.3.1  Project Basic

Basic Panel Options

· Starting Cable Number - The default starting number of ALL sequences.
· Leading Zero Count - How many leading zeros in SysNames and Cable Numbers.
· Ignore Cable # Text Color - Does not color the Cable Number text entities.
· I Build My Racks From the Top Down, Default Rack Height
· Default Cable Type - This is the default of defaults. The Project Signal Types table can override this.
· Default Plan View Block File - If no Plan View File is defined on the Equipment definition then this will be

used by the Populate Equipment function in the Plan View Tools.
· Users (mere mortals) Can Modify These Project Settings - If you can see and edit this you are a WireCAD

Administrator or have not set up WireCAD Security.
· Add Pinout Data to Each Cable - Allow pinout data to be attached to a cable as it is being assigned. The

pinout criteria must match in order to be a candidate for inclusion in the list of available pinouts for a cable.
· Use the device display settings - This setting prioritizes any Equipment Library device settings saved with the

device over the settings saved for the project.
· Show duplicate numbers from related projects - Only if Verbose assignments are being done.
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4.2.1.9.3.2  Advanced

Project - Advanced Panel Options

· Disable Find Next Available SysName, Disable Find Next Available Cable Number - The default behavior
is for WireCAD to look-up the next number from the Next Numbers table, then check to see if that number is in
use - if so keep incrementing until an available number is found.  Disabling this functionality will use the number
in the Next Numbers table without checking its availability.

· Automatically Consume Prewire Cables - This will use those numbers applied to the PreWire Cable instead
of producing a new number.

· Strict Multi-core Assignment - Enforces a policy that all cores in each end of a multi-core cable must originate
from the same location. 

· IP Mask
· Maintain Relational Data - See this discussion on Understanding Indexes. Disabling this will not disable the

indexing function if you call Re-index but will not attempt to initiate the data in real time.
· Disable Cable Number Edit Dialog Mask - If you find the masking of the Edit Cable Data Cable Number

textbox to be cumbersome you can disable it here. This also disables the mask on the SysName assignment
dialog.
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4.2.1.9.3.3  Locations

Project - Locations Panel Options

· Location Delimiter - Settable on project creation only this is the delimiter that separates CAMPUS from
BUILDING, BUILDING from FLOOR, etc. The default is a [.]. This will create Qualified Locations in the form of:
Campus.Building.Floor.Room.Rack.

· Elevation-Slot Delimiter - The delimiter that separates the elevation numeric from the slot numeric. For
example: a device located in elevation 20 at slot 5 with a delimiter of a dash [-] would be typed and 20-5.

· Enable Locations Look-up - If disabled the locations field may be typed into directly. This may lead to
confusion or referential issues, ie; user a calls something Rack 1 and user b calls the same thing RK 01.

· Locations Table Fields - Enable those that you will use and call them what you will.
· Start Numbering at 1 - Only applies if you are auto generating locations.
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4.2.1.9.3.4  Delete Handling

Delete Handling Panel Options

· Hard Delete  - Overrides the default behavior which is to mark a deleted cable Available=true and place the
Deleted Text in key fields. Enabled this removes the row from the table upon deletion.

· Deleted Text - If deleted and not Hard Deleting the text to place in fields. Leave empty to leave existing text in
place.

· Deleting Equipment Deletes ALL Connected Cables - Works with functional blocks, concept blocks, and
terminals.

· Deleting a cable on a pointer resets the cable on the other side of the pointer - The other sheet will be
opened and updated. This can take some time.
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4.2.1.9.3.5  Enterprise CMS

Enterprise CMS Panel Options

· Manage Status Items - When creating a backbone, you have the ability to mark a "status" on that backbone
such as "In Use", "Proposed" ETC. The Status Behavior settings panel defines the Status Items in the list.

· Backbone Number Format - The variable {0} contains the next number in the Next Numbers grid for
Backbones. Define the string format of the next Backbone number. 

· Jumper Number Format - 
The variable {0} contains the Circuit base number.
The variable {1} contains the Strand Number of the circuit for this jumper
The variable {2} contains the Ordinal Number of the circuit for this jumper.
Define the string format of the next Jumper number. 

· Default Jumper Manufacturer and P/N, Default Horizontal Cable Manufacturer and P/N
· Circuit Number Format - The variable {0} contains the next number in the Next Numbers grid for Circuits.

Define the string format of the next Circuit number. 
· Horizontal Cable Number Format - The variable {0} contains the next number in the Next Numbers grid for

Horizontal Cables. Define the string format of the next Horizontal Cable number. 
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4.2.1.9.3.6  Export Settings CMS

Project - Export Settings Panel Options

· Use Template - Path to a template drawing that the output will be exported into. Your template drawings can
contain any page borders or layouts and settings that you wish.

· Always Ask for FileName and Path - You will be involved in the filename selection and path.
· Circuit FileName Format - Sets the file name format for Circuit output. {0} = Circuit Name.
· Backbone FileName Format - Sets the file name format for Backbone output. {0} = Backbone Number.
· File Format - Presets the output format.
· Path - Where do we output.
· Create Folder for Each IT Systems
· Automatically Overwrite Files of Same Name
· Append Date Stamp to FileName
· Circuit Post Process Script, Backbone Post Process Script - Path to a c# file which will be run post export

but pre write-to-disk. See the Post Process Scripts  topic for more information.286
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4.2.1.9.3.7  Project Rules

Project - Project Rules Panel Options

Explanation

Rules allow you to modify data during the SysName and Cable Number assignment processes. There are four
events or contexts
in which rules may execute:
SysName assignment pre and post dialog show/dismiss.
Cable Number assignment pre and post dialog show/dismiss.

Related Topics:
Project Rules
Expression Syntax

· Enable Rule Execution  - Enable/Disable all rule and rule event execution.

192

193
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4.2.1.9.3.8  Status Behaviour CMS

Project - Status Behavior Panel Options

· Assigned to Circuit Color - The color to display in the Backbones grid if the record is assigned to a circuit.
Here we see circuit 0232 using the backbone B000003.41.

· Context - Backbones_grid or Circuits_grid.
· Display Name - The name of our status.
· Background Color - Self-explanatory.
· Is Blocking - A blocking status is one that blocks operations from proceeding. For example: if we mark a

backbone fiber as DEAD we would not want to use that in a Circuit. If the status item is set as Is Blocking = true
then the New Circuit tool will not allow a circuit to involve that strand of fiber.
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4.2.1.9.3.9  GPS Settings CMS

Menu: Application Menu > Settings[Project][GPS Settings]

Location Marker Settings

Offset X, Y: Used by the Location Overlay Mode = Offset.
Layer Color: sets the color the location marker will paint.
Radial Distance: Used in conjunction with the Location Overlay Mode = Radial and the Show Radial Project
Lines to paint a line from the radial arc center to the location marker.
Display String Format: Sets the variable used to display the name of the location on the marker in the drawing or
map.
The following variables can be used:
{0} = Campus.
{1} = Building.
{2} = Floor.
{3} = Room.
{4} = Rack.
{5} = Qualified Location.

Show Radial Project Lines: Used in conjunction with the Location Overlay Mode = Radial. Sets the display of
a projection line from the arc center to the Radial Distance and location marker.
Radial Angle: Used in conjunction with the Location Overlay Mode = Radial. Sets the rotation angle of the
radially displayed location markers.
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Panel (Equipment) Marker Settings

Offset X, Y: Used by the Panel Overlay Mode = Offset.
Layer Color: sets the color the panel marker will paint.
Radial Distance: Used in conjunction with the Panel Overlay Mode = Radial and the Show Radial Project
Lines to paint a line from the radial arc center to the panel marker.
Display String Format: Sets the variable used to display the name of the panel on the marker in the drawing or
map.
The following variables can be used:
{0} = All.
{1} = SysName.
{2} = Alias.
{3} = Location.
{4} = Manufacturer.
{5} = Equipment Name/Model.

Show Radial Project Lines: Used in conjunction with the Panel Overlay Mode = Radial. Sets the display of a
projection line from the arc center to the Radial Distance and panel marker.
Radial Angle: Used in conjunction with the Panel Overlay Mode = Radial. Sets the rotation angle of the radially
displayed panel markers.

Backbone Marker Settings

Offset X, Y: Used by the Backbone Show Mode not =  ByGPSLocation to offset the flyoffs.
Text Height and Style: Sets the appearance of flyoff text.
Backbone Color: sets the color the backbone marker will paint.
Backbone Text Color: sets the color the backbone flyoff marker will paint.
Line Width: Sets the pen stroke width of the backbone.
Flyoff Geometry: Sets the block to use when a flyoff is created.
Flyoff Scale: Sets the scale factor of the Flyoff Geometry.
Show Backbone Number as Linetype: Creates a new linetype with the backbone text as part of the linetype.

General Settings

Remember Filter Settings: Persist the filter data across forms and sessions.
Display Error Messages: Show a list of the problems found when showing Panels and Backbones.
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4.2.1.9.3.10  Archive Project

Project - Archive Project Panel Options

Settings that affect the Archive tool.
· Archive Path - path to the archive root folder. The Archive Name will be used to create a folder within this root

folder. Use {0} for the current project path.
· Show New Project Revision Dialog - Set whether the New Project Revision dialog is shown and populated

during the archive process. If the New Project Revision dialog is canceled the CurrentProjectRevision will
not be incremented.

· Always Ask for Archive Name - Sets whether you are asked for the archive name or whether the archive is
automatically named using the Archive Name Format String.

· Archive Name Format String - The name of the folder the project is contained within as well as the archived
project name.

{0} = Current Project Name.
{1} = UTC short date string.
{2} = UTC short time string.

Related Topics:
Archive Project 177
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4.2.1.9.3.11  Cable Text Search Window

Project - Cable Text Search Window Options

WireCAD uses standard text entities placed in a specific point near the end of the cable. If you reduce the Vertical
Pin Spacing of your created blocks you may find that WireCAD selects the wrong text when assigning a cable
number. If that is the case reduce the size of the search window.

· Search Window X - Sets the x offset from the end of the cable that we search for text.
· Search Window Y - Sets the y offset from the end of the cable that we search for text.
· Show Search Calibration Window - Renders a red rectangle representing the search window. Be sure to turn

this off before doing actual work in the application.

Search Calibration Window
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· Placement Offset X - Sets the x offset of the Cable Number text placement. This setting interacts with the
Search Window X. If you set the Placement Offset X outside the Search Window X you will need to modify
the Search Window X to accommodate the new placement.

· Placement Offset Y - Sets the y offset of the Cable Number text placement. This setting interacts with the
Search Window Y. If you set the Placement Offset Y outside the Search Window Y you will need to modify
the Search Window Y to accommodate the new placement.

4.2.2 Drawing Dialogs

The following is a set of dialogs associated with Drawing Form.

4.2.2.1 CAD Dialogs
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4.2.2.1.1  New  Draw ing Wizard

Drawing > File > New
Commandline: nd

Explanation

Create a new drawing for the project somewhere in the project\drawings\ folder tree.

· Select a template drawing. Template drawings are drawings that are placed in the Template Drawings Support
Path . They typically contain layouts and page borders, but may also be populated with barebones systems.

· Set whether to display Model Space Boundaries. These are bounding rectangles based on a scale factor of the
Model Space text height used and the desired output text height of the viewport.

Related Topics:
How To: Create a New Drawing
Model Space Boundaries

360

47

400
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Dialog Options

· Template Drawings List - Drawings placed in the %TEMPLATEDRAWINGS% support path. Any drawing is a
candidate for saving as a template.

· Model Space Boundaries - Your selected template may already have Model Space Boundaries in which case
it is unnecessary to include them.

4.2.2.1.2  Print Preview

Drawing > File > Print Preview
[Cntrl]+[P]
Commandline: print
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Dialog Options

· Selected Printer - Make sure that you select a printer first.

· Plot Margins - Set the unit of measure and the Top, Bottom, Left and Right margins. NOTE: the printer driver
will return the hard margins of the printer. These are represented by the black dashed line in the Partial Preview
mode. Setting the margins less than the hard margin values will have no effect.

· Center - Adjusts the left and top margins to center the entities in the given space.
· Upside Down - Rotate the output to the plotter.
· Orientation - Portrait/Landscape.
· Paper Size
· Scale - Numerical scaling of the entities to the paper.
· Scale to Fit - Fit the entities to the paper.
· 1:1 - Scale 1:1.
· Black and White
· Out as Bitmap - Render to a bitmap then output that. Has different effect on quality depending on printer/plotter.
· Copies
· Pen Assignment - Shows the Pen Assignment dialog. You can assign a different line thickness to each of the

255 indexed colors.
· Print Area - Pick a window or print the extents.
· Preview Mode - Full preview or partial view to show margins.
· Update Preview - Refresh the preview.
· Print
· Select Printer
· Cancel
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4.2.2.1.3  PDF Export

Drawing > File > PDF Export
Commandline: pdf
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Dialog Options

· Selected Printer - Make sure that you select a printer first.

· Plot Margins - Set the unit of measure and the Top, Bottom, Left and Right margins. NOTE: the printer driver
will return the hard margins of the printer. These are represented by the black dashed line in the Partial Preview
mode. Setting the margins less than the hard margin values will have no effect.

· Center - Adjusts the left and top margins to center the entities in the given space.
· Upside Down - Rotate the output to the plotter.
· Orientation - Portrait/Landscape.
· Paper Size
· Scale - Numerical scaling of the entities to the paper.
· Scale to Fit - Fit the entities to the paper.
· Black and White
· Out as Bitmap - Render to a bitmap then output that. Has different effect on quality depending on printer/plotter.
· Copies
· Pen Assignment - Shows the Pen Assignment dialog. You can assign a different line thickness to each of the

255 indexed colors.
· Print Area - Pick a window or print the extents.
· Preview Mode - Full preview or partial view to show margins.
· Update Preview - Refresh the preview.
· Save to File
· Select Printer
· Cancel
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4.2.2.1.4  Export to Visio

Drawing > File > Export to Visio
Commandline: visio

Explanation

The WireCAD to Visio converter is an intelligent converter. It creates active working Visio drawings from you
WireCAD drawings. What this means is that it is not just a dumb geometric import but rather entities are
examined and functioning Visio entities are created. Cables in WireCAD become Visio Connectors allowing
movement of blocks while keeping the wires attached.

Dialog Options

· Page Size - Set the Visio page size.
· Output File Name
· Landscape
· Overwrite File if Exists
· Scale to Fit - Fit the WireCAD dwg entities onto the selected page size.
· Scale Factor - Manually scale the WireCAD entities to the Visio page size.
· Cable Routing - Here is the magic. You can either let Vision route the cables or you can attempt to keep the

appearance of your WireCAD routes.
· Convert - Do IT!
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4.2.2.1.5  Layers

Drawing > Drawing > Layers
Commandline: lay

Explanation

The Layers dialog controls the document Layers collection.
A Layer is the equivalent of the overlay used in paper-based drafting. It is the primary organizational tool in the
WireCAD CAD space, and you can use it to group information by function and to enforce linetype, color, and other
standards.
Organizing Layers and the objects on Layers make it easier to manage the information in your Drawings.
When you put one layer over another the result is the complete drawing.
Having kindred objects on the same layer it is very helpful in order to organize the drawing.
When you begin a new drawing, WireCAD creates a special layer named 0. By default, layer 0 is assigned color
number 7 (white or black depending upon your background color), the CONTINUOUS linetype and a lineweight of
Default (the default setting is .01 inch or .25 mm). Layer 0 cannot be deleted or renamed.
All new objects are added to the active layer if no layer is specified.
Using the Layers editor you can Freeze (Hide), Thaw (Show) and Lock layers.
By controlling whether a Layer's state is Thaw or Frozen you can change the appearance of your drawing to
display only the information on the Layers that are visible. Freezing unused Layers will help the performance of
WireCAD.
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Dialog Options

· Document Tree - Lists the document's external references. By selecting an item in the document tree you can
control the layers of XREF drawings within the current drawing.

· New Layer
· Delete Layer - Deletes the selected layer as long as it is not the current layer or layer 0.
· Set Current - Set's the current layer. All entities added to the drawing are added to the current layer.
· Status - The one and only current layer.
· Name
· On - Is it visible.
· Frozen - Is it visible. The difference between Thawed/Frozen and On/Off is a very subtle distinction. Turning a

layer off using the ON/OFF setting makes the objects on that layer hidden, but these objects will still be
considered part of the drawing. For example, objects that have been turned off are still selectable in the drawing.
Selecting it directly on screen of course still isn’t possible, as you’ve nothing to click on. But other ways of
selecting objects will still pick it up – try a SELECTALL for example, and your objects that are turned off will be
selected. Frozen layers on the other hand are completely off. They are not considered part of the drawing at all,
and are therefore not selectable.

· Lock - Make the layer unselectable.
· Pen Color - Set the pen color for the layer. Only entities that have their PenColor property set to ByLayer will

receive this value.
· Line Type - Set the Line Type for the layer. Only entities that have their Line Type property set to ByLayer will

receive this value.
· Line Weight - Set the Line Weight for the layer. Only entities that have their Line Weight property set to

ByLayer will receive this value.
· OK
· Cancel
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4.2.2.1.6  Layouts

Drawing > Drawing > Layouts
Commandline: layouts

Explanation

A Layout is used to compose or lay out your model drawing for printing. A layout may consist of a title block, one
or more viewports, and annotations. As you create a layout, you can design floating Viewport configurations to
visualize different details in your drawing.
A layout is a paper space environment that simulates a sheet of paper. In a layout, you can create and position
viewport objects, and you can add a title block or other geometry. You can create multiple layouts in a drawing to
display various views. Each layout displays the drawing as it will be printed on the sheet of paper.
Typically, when you begin designing a layout environment, you step through the following process:
1. Create a model drawing.
2. Activate or create a layout.
3. Insert a title block.
4. Create floating viewports and position them in the layout.
5. Set the view scale of the floating viewports.
6. Print your layout.
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Dialog Options

· Layout List
· Set Current - Set the selected item to be the current view.
· New, Remove, Rename
· Copy - Copy all entities from the selected layout to a new layout with the name of your choosing.
· Move Up/Down - Reorder the list.

4.2.2.1.7  Point Styles

Drawing > Drawing > Point Styles
Commandline: pointstyles

Explanation

All point entities inserted into the drawings space will render based on the settings here. 
NOTE: if you are using the Rack Builder tool WireCAD uses point entities to generate the positioning grids and
sets this value programmatically.
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4.2.2.1.8  Text Styles

Drawing > Drawing > Text Styles
Commandline: ts

Explanation

TextStyle is a named, saved collection of settings that determines the appearance of text strings.
You can create your own text styles which can have specific fonts and text height. You can also specify if the text
will be underlined,bold etc.
There is no limit to the number of text styles you can create in your drawing. 
The active text style determines the appearance of new text created in the drawing. StyleName of text object will
get the value of ActiveTextStyle property.
When you enter text, it uses the current text style, which sets the font, size, and other text characteristics. If you
want to create text using a different text style, you can make another text style active.

Dialog Options

· Style Name, Add, Rename, Delete
· Font - Set the font family of the Text Style.
· Style - Style attributes.
· Preview, Preview Text Edit - Preview of Text Style applied to the Preview Text Edit.
· Advance Settings - The advance tab displays a property grid with all of the basic settings and a few more.
· CodePage - Sets the character set used to display text.
· DrawOutline - 
· Flag - LeftToRight, Backwards, UpsideDown, etc.
· ObliqueAngle - in degrees.
· WidthFactor - Value used to stretch text by changing its width.
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4.2.2.1.9  Dimension Styles

Drawing > Drawing > Dimension Styles
Commandline: dimstyles

Explanation

A Dimension Style is a group of dimension settings that determines the appearance of a dimension . 
The active Dimension Style determines the appearance of new dimensions created in the drawing.
To change the style of an existing dimension, use the StyleName property found on the dimension.
When you create a dimension, the current dimension style is associated with that dimension. The dimension
retains this dimension style unless you apply a new dimension style to it.
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Dialog Options

· Style Name, Add, Rename, Delete
· Preview Pane - Displays the results of the current settings.
· Settings - 
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4.2.2.1.10  Model Space Boundaries

Drawing > Drawing > Model Space Boundaries
Commandline: bo

Explanation

It's a big model space in there. We can, if we are not careful, create a drawing that is so big that it can't be
effectively printed or plotted. In order to have some Idea of where the fences are WireCAD can place boundaries in
the model space. The boundary is created from the viewport. We use the text height as the terms for our equation.
We do this because a drawing is considered readable if we can read the text. If we can't read the text the drawing
becomes useless.
Each boundary will be placed on its own layer and named bound_layout_name where layout_name is replaced
with the name of the layout.

Dialog Options

· Layout - Select the layout from which we will create the boundary.
· Text Height that you used in Model Space - The default is .25 DU or as given in 1/100th of a Drawing Unit:

25.
· Height of the text that you want to print - Here we want the printed output height in 1/100th of a printer unit. 
· Color
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4.2.2.1.11  Groups

Drawing > Drawing > Groups
Commandline: formatgroups

Explanation

Create groups of entities in order to better organize your drawings. Groups can be named and described as well as
disabled and edited later.
To create a Group select some entities and right-click then click Group

Dialog Options

· Ignore Groups - Disable grouping.
· Name - The default Group name will be a GUID. You can rename it if you like.
· Description
· Selectable - Is the group selectable as a group. If selectable = true then when one object in the group is

selected all objects are selected.
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· Item Count
· Edit Entities - Add or remove entities to the group.
· Apply Properties - Send the value of the Group Properties fields to the group.
· Delete - Deleting the Group does not delete the entities.
· New - New from the Group Properties.

4.2.2.1.12  Images

Drawing > Drawing > Images
Commandline: formatimages

Explanation

Embed images in the drawing as well as to edit the properties of those images. The document now contains an 
Images collection from which images may be inherited throughout the drawing.
Using the Images collection you may now either link or embed an image.

Dialog Options

· Images Gallery
· Attach - Browse to an image file to attach to the document.
· Edit Image - Display the Image Editor  dialog for the selected image.
· Detach - Remove the selected image if no instances exist in the drawing.
· Image Path - Path to the linked file.
· Bind to Document - Check this box to embed the image in the document.
· Choose Transparency Color
· Place - Place an instance of the image in the drawing space.

403
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4.2.2.1.13  Image Editor

Double-click an Image
Commandline: none

Explanation

Image editor. You are editing the Image Definition of the document images collection not the instance. All
instances will follow the definition.
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4.2.2.1.14  Rectangular Array

Drawing > Drawing > Rectangular Array
Commandline: ar

Explanation

Creates multiple copies of objects in a pattern. 
With the rectangular array you can create an array defined by a number of rows and columns of copies of the
selected object.
First you have to select the objects. Then you have to define number of rows and number of columns of the
rectangle, the distance between rows and the distance between columns.

Dialog Options

· Rows - The number of rows in the array including the source elements.
· Columns - The number of columns in the array including the source elements.
· Row Spacing - Row spacing in DU.
· Column Spacing - Column spacing in DU.
· Pick >> - Momentarily dismiss this dialog so you can pick the spacing out of the drawing.
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4.2.2.1.15  Purge

Drawing > File > Purge
Commandline: purge

Explanation

Remove unused entities from the drawing. Only unused entities and object appear here. For an item to be purgable
it must not appear in any drawing space or by used by another entity or object.

Dialog Options

· Collection Tree - The document collections.
· Collection to Purge - The collections to purge.
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4.2.2.1.16  Inserts Dialog

Drawing > CAD Tools > Insert Block into Drawing
Commandline: insert

Explanation

Insert blocks in to the drawing. This is the collection of Blocks in the drawing. You may also browse to any .dwg
file and insert it into the file.

Dialog Options

· Blocks - Select an existing block or browse to a dwg file and add it to the drawing.
· Preview - 

The selected block

· Insertion Point, Scale, Rotation - Pick here or on the drawing.
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4.2.2.1.17  XREF Manager

Drawing > CAD Tools > XREF Manager
Commandline: xref

Explanation

Manage externally referenced drawings. These are drawings that are visible in the current Model space but
maintained in separate files. They are linked here read only. This allows base drawings to be managed separately
yet display in the current drawing. Because they are linked they are not editable. 
You can bind a previously Externally Referenced drawing to the current document if you desire that it be editable in
the current view. You can control the visibility of XREF layers from the Layers dialog.

Related Topics:
Layers Dialog 393
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Dialog Options

· Attach - Browse to the file. After which you will be presented with the standard Insert dialog to position the
incoming file on the screen.

· Detach - Remove the XREF.
· Reload - Get any changes to the XREF file and display them.
· Bind - Make it a Block in this drawing file. It is no longer linked and changes in the source file will no longer

reflect in the current drawing.
· Unload - Get rid of it.
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4.2.2.1.18  Sw ap Equipment

Context Menu with Equipment Insert Selected>Equipment Functions>Swap Equipment
Default command line shortcut: none

The Swap Equipment function allows you to swap Manufacturer, Model, and port data on an existing functional
block or concept block.

Applies To:
Functional Blocks
Concept (High Detail) Blocks.

Used For:
Switching from one make/model to another.

Dialog Options

· Manufacturer - Select the Manufacturer to replace the outgoing device with.
· Equipment Name - Select the Equipment Name / Model / PN to replace the outgoing device with.
· Inputs grid, Outputs grid - Select the ports to replace.
· Find Matches - Matches incoming ports to outgoing ports.
· OK - Do it!
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4.2.2.1.19  Edit Attributes

CAD Tools > Edit Attributes
Default command line shortcut: EditAttributes

If an insert has Attributes they can be edited using this tool.

Be careful using this on WireCAD generated blocks as there is usually a tool that will update the attributes and the
database concurrently.

Applies To:
Standard CAD Blocks.

Used For:
Editing text in a Insert entity.

Dialog Options

· Tag - Descriptive text.
· Value - The data that renders as text in the insert.
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4.2.2.1.20  Add Attribute Definition

CAD Tools > Create Attribute Definitions
Default command line shortcut: none

Used to create an Attribute Definition. Attributes exist in two states. 
1. Before a block is created an Attribute is referred to as an Attribute Definition or AttribDef.
2. After a block is created with an AttribDef it becomes an Attribute.
3. AttribDefs are editable and easily modified. Once added to a block they are harder to change.

Blocks do not limit the number of AttribDefs.

Applies To:
Standard CAD Blocks.

Used For:
Creating editable text in a Insert entity.

Dialog Options

· Tag - Descriptive text. This is what renders when not included in a block.
· Value - The data that renders as text in the insert.
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4.2.2.1.21  X Properties Grid

Not directly callable.
Default command line shortcut: none

This dialog allows you to add edit and delete extended properties on an entity. This is generally done in code.
This dialog can be shown by clicking the [...] button on the XProperties row of the drawing Properties Tool Panel.

We recommend that you not edit any of this data.

Applies To:
All entities.
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Dialog Options

· Type - Variable type.
· Name - Descriptive text.
· Value - The data.
· Add, Edit Delete - obvious.

4.2.2.1.22  Edit X Properties

Not directly callable.
Default command line shortcut: none

This dialog allows you to edit existing extended properties on an entity. This is generally done in code.
This dialog can be shown by clicking the [Edit] button on the Extended Properties  grid.

We recommend that you not edit any of this data.

Applies To:
Select Extended Property of the selected item(s).

Dialog Options

· Type - Variable type.
· Name - Descriptive text.
· Value - The data.
· X, Y, Z - If the data one of the point types.

412
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4.2.2.1.23  Singleline Text Editor

Double-click text entity
Default command line shortcut: none

This dialog allows you to edit existing single line text entities.

Applies To:
Selected Single Line Text entity

Related Topics:
Text Styles
Layers

Dialog Options

· Bold, Italics, Underline, Strikethrough
· Text Style - Text entities do not have fonts but rather document based TextStyles. The TextStyle associates

the font.
· Text Height - In drawing units.
· Layer - The Layer on which the entity resides.
· Color - The pencolor of the text entity
· Rotation - Angle in degrees.
· Justification - Sets the horizontal and vertical justification.

397

393
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4.2.2.1.24  Multi-line Text Editor

Double-click MText entity
Default command line shortcut: none

This dialog allows you to edit existing MText multi-line text entities.
MText entities display multiple lines of text with the ability to format selections within the MText entity.

MText Preview

MTEXT Control Codes

\0...\o Turns overline on and off 

       \L...\l Turns underline on and off 

       \\ Inserts a backslash 

       \{...\} Inserts an opening and closing brace 

       \Cindex; Changes to the  specified color 

       \Hvalue; Changes to the text height specified in drawing units 

       \Hvaluex;     Changes the text height  to a multiple of the current text height 

       \Tvalue;    Adjusts the space between characters, from .75 to 4 times 

       \Qangle;      Changes obliquing angle 

       \Wvalue;     Changes width factor to produce wide text 

       \Ffile name; Changes to the specified font file  

       \A           Sets the alignment value; valid values: 0, 1, 2 

       \P            Ends paragraph 

       \S...^...;    Stacks the subsequent text at the \, #, or ^ symbol 

Applies To:
Selected MText text entity.
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Related Topics:
Text Styles
Layers

Dialog Options

· Italics, Underline, Overline 
· Characters - Insert control codes for the selected character.
· Colors - Insert control codes for the selected color. We have provided named colors but the control code \C can

be followed by any of the index colors 0-127
· Text Style - Text entities do not have fonts but rather document based TextStyles. The TextStyle associates

the font.
· Text Height - In drawing units.
· Layer - The Layer on which the entity resides.
· Color - The pencolor of the text entity
· Rotation - Angle in degrees.
· Justification - Sets the horizontal and vertical justification.

397

393



Reference 417

© 2017 Holbrook Enterprises, Inc. dba WireCAD

4.2.2.1.25  Sync Insert Decision

Right-click a Functional Block then Equipment > Sync with Database
Default command line shortcut: none

If the block information does not match the database information you are presented with this choice.
Yellow background cells represent fields that do not match. 
You must choose which data to use.

Applies To:
Selected Functional or Concept Block.

Related Topics:
None
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4.2.2.1.26  Validate Deletion

Delete or Erase
Default command line shortcut: e

When deleting an entity in the Applies To list you will be presented with this decision.
This indicates that the entity you are deleting has an matching record in one of the databases.
It is your choice as to whether to keep or delete the associated database record.

Example
Assume you have a device called SRVR-01. Further that SRVR-01 has appearances in the video drawing and the
audio drawing.
When you decide to delete the instance that is in the video drawing, you will be shown this dialog and need to
decide whether to delete the database entry as well.
The appropriate response in this case is not to delete the database record since we still have the instance in the
audio drawing.

Applies To:
Blocks with SysNames
Terminals with SysNames
Cables with Cable Numbers.

Related Topics:
Delete Handling Setting 377
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4.2.2.1.27  Zoom Scale

View > Zoom Scale
Default command line shortcut: ZoomScale

This function is used to numerically zoom the currently active viewport to the underlying Model Space.

Usage

1. Open a drawing.
2. Switch to a layout with a viewport.
3. Double-click the viewport to activate it. You will see the crosshair is constrained to the viewport. 
4. Click View>Zoom Scale ...
5. Enter a scale factor.
6. Click [OK].

Applies To:
A layout with an activated Viewport.

4.2.2.2 Advanced Tools Dialogs

The following is a set of dialogs that may be presented while using the advance tools in the drawing environment.
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4.2.2.2.1  Equipment Library

Database > Equipment Library
Drawing > Advanced Tools > Equipment Library
Commandline: le
Several Others

Explanation

The WireCAD Equipment Library is where you will spend a fair amount of time as you define equipment that you
will use in your designs. The Equipment Library is a presentation of the global Manufacturers table and its
hierarchy. The Equipment Library contains no CAD blocks just equipment definitions. These equipment definitions
describe a piece of equipment its make, model, and IO. 

This is also where we come to create CAD blocks in our drawings. There are many settings here that let you
customize appearance.
The interface is tabbed. The [Find] tab sets the current item. The current item will be enumerated in the [Detail]
and [I/O] tabs. This topic covers the right-hand column of controls that is visible from all tabs.

Dialog Options

· Big Preview - 

· Refresh Preview - 
· Preview - Displays the currently selected equipment definition based on the Display As: setting.
· Display As:



Reference 421

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Setting Preview

Functiona
l I/O

Conceptu
al I/O

Conceptu
al I/O
(high
detail)

Front
Panel
(File
Merge)

Front
Panel
(From
Dims)

Plan View
(File
Merge)
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Plan View
(From
Dims)

 Not yet implemented.

· Add Manufacturer - Shows the Add Manufacturer dialog.
· Add Equipment - Shows the Add Equipment Wizard.
· Delete Equipment - Deletes the selected record.
· Add to Drawing - Add the selected item to the drawing based on the current preview.
· Add to Project Database Only (Assign SysName) - Shows the SysName Assignment dialog.
· Attach Document - Attach any document to the current record. This is useful for storing data sheets or

specification documents with the equipment definition.

4.2.2.2.1.1  Find

Database > Equipment Library
Drawing > Advanced Tools > Equipment Library [Find]
Commandline: le
Several Others
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Explanation

The [Find] tab allows you to search the local global database as well as the Community Server. When searching
locally all records are returned by default. When searching the Community Server you will need to enter a search
term. The results will be returned in pages based on your Results Page Size value. 

Search Term Hints:
When searching the databases for items, less is more. You want to enter a value that can be found in a single field. 
For example: say we are looking for a Sony DVW A-500. The following is a list of terms and their results:
Search: Sony - Result: All Sony products and any products from other manufacturers that have Sony in their
description fields.
Search: DVW - Result: All products with DVW somewhere in the name or description.
Search: SONY DVW - Result: None. There are no products with the manufacturer name and the product name in a
single field.

Find Tab Options

· Find - Enter the search term here.
· Find button - Do the search.
· Find All button - Clear and find all records. (Local only).
· Local / Community Server - Switch between your local database and the Community server.
· Test Connection button - Test your connection to the Community. If this fails you may need to open your

firewall to community.wirecad.com port: 1433.
· Download From Community - Before any edits can be made to the device you will need to download it to your

local database.
· Upload to Community - You can upload manually by clicking this button.
· Grid - found items.
· Community Rating System - The Community Server is completely open. All device definitions have been

created by your peers. If something is wildly inaccurate then post your opinion. Conversely if something is wildly
brilliant then do the same.

· Results Paging - You can navigate the page results with these controls.
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4.2.2.2.1.2  Detail

Database > Equipment Library
Drawing > Advanced Tools > Equipment Library [Detail]
Commandline: le
Several Others

Explanation

This is the detail page for the currently selected record. The fields are self explanatory. 

NOTE: Be sure to save your changes if you edit this grid manually by clicking File>Save.
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4.2.2.2.1.3  Inputs/Outputs

Database > Equipment Library [I/O]
Drawing > Advanced Tools > Equipment Library [I/O]
Commandline: le
Several Others

Explanation

This is the Inputs and Outputs page. It represents the I/O of the currently selected device. Inputs are displayed in
the left-hand grid and outputs are displayed in the right-hand grid. This is by convention only. You are free to place
inputs on the right-hand side and vice-versa. Each port record consists of a Name, Type, Connector and a Pin
Type. Selected records will be included in the preview of any Function I/O and Concept blocks that you create. 

If you are using connector genders be sure to enter the cable-end gender not the chassis side.

I/O Tab Options

· Inputs Grid, Outputs Grid - NOTE: Be sure to save your changes if you edit these grids manually by clicking
File>Save.

· Select All, Clear Selection, All Inputs, All Outputs - Manipulate the selection.
· Select by Signal Type - Ten buttons in this frame will populate with the first ten signal types from the I/O

records. Clicking the button will select all records in both grids of that signal type.
· Reorder - Move selection up/down.
· Copy - Copy side-to-side.
· Add Ports - Show the Add Ports dialog .
· Delete Ports - Delete the selected ports. You will be prompted for each grid. No save is necessary.
· Refresh - Refresh the preview.
· Display Order - Set and sort by the Display Order column. This allows you to rearrange the lists and be able

to return later to your work.

432
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4.2.2.2.1.4  Display Preferences

Database > Equipment Library
Drawing > Advanced Tools > Equipment Library
Commandline: le
Several Others

Explanation

This is where we determine the look of the block we are about to add to the drawing.
There are four tabs in this view that allow you to customize the appearance of the block you are about to create.
1. Stock Shapes
2. Mappable Terminals
3. User Defined Shapes
4. Mechanical Forms

430
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Understanding the Settings Mechanism

Settings store the appearance and display mode of the Equipment Library. These settings determine the look of
the created block. You can tell which settings were used to create the block by looking at the Equipment Library
status bar:

WireCAD stores the settings used to create blocks in three different locations:
1. Device settings. If you create a block in a drawing we store the settings used to make the block with the

device definition in the Equipment Library. These settings have priority.
2. Project settings. If you like the display of a block you can click the:

 
Doing so will set the current display settings as the Project default. All devices that do not currently have stored
settings will then use the Project defaults.
3. Default settings. When no other settings are found we use the defaults.

Several controls are common to all tabs. We will go into those first.

Common Controls Options

· Body Color - Sets the color of Functional I/O and Concept block bodies. Has no effect on User Defined Shapes
or Terminals. The geometry of the file determines the look.

· Creation Mode - Set by the UI. Leave it alone.
· Descriptor Locations - Shows the Descriptor Locations Map. Applies to Functional, Concept, and User Defined

Shapes.

Drag to reposition
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· Image Display Mode - Applies to Applies to Functional and Concept blocks.
None - no image or cad block is inserted in the created block.
Image - insert the image that is pointed to in the Image File Path of the Details tab for this device.
DWGIcon - insert the DWG Icon in the DWG Icon File Path of the Details tab for this device.

· Image Position, Image Scale Factor

Image inserted and
scaled at MiddleCenter

· Merge and Center - Centers identical text in the block. Applies to Functional and Concept blocks.

· Text Height - The height of all generated text.
· Spacing and other dimensional info:
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· Vertically Center Pins

· Body Pen Width - The thickness of the line that represents the block body.
· Nudge Positions - Use to nudge the various text around.
· Tears and Bulge Factors - Tears are visual elements that represent to the reader of the document that the

device does not display all of its available I/O. Tears use bulges. The greater the bulge factor the more dramatic
the tear.

Bottom edge torn bulge
factor .15 or 15/100

Bottom edge torn bulge
factor .5 or 50/100

· Set Current Display Properties as Project Default
· Reset Project Default
· Reset Device Settings
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Stock Shapes Options

Here you choose from 18 stock shapes. We will not enumerate them here. Try clicking on them to see what they
do.

Mappable Terminals Options

Here you can map the selected I/O on to terminals. Terminals are one or two port inline devices. If you select more
than one record in the I/O tables we will continue to add terminals to accommodate the selection. If you select a
terminal that has only an input port then any selected output records will be ignored.

Example showing multiple I/O selected and mapped on to a terminal that represents a full normal jack:
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User Defined Shapes Options

Any CAD file can be used as a User Defined Shape. It just needs to be placed in the Shape Files folder:
%BLOCKS%\Shapes Files

The Display Properties will then scale and stretch the object while applying port data.
Example showing User Defined Shape with four ports applied:

Mechanical Forms Options

Mechanical Forms are hard-coded objects that get their dimensional data from the device definition and use it to
render objects.

Item Description

Rack Enclosure

Select a form. Only available when Front Panel (from Dims) is selected.
Rack Tray

Cube

Half Rack Left
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Half Rack Right

4.2.2.2.1.5  Add Ports

Database > Equipment Library [I/O] [Add Ports]
Drawing > Advanced Tools > Equipment Library [I/O] [Add Ports]
Commandline: le
Several Others

Related Topics:
How To: Add Some Inputs and Outputs
How To: Add Ports

Explanation

This is the Port Adder dialog. With it you add a single record, two records, or multiple records to the I/O grids.
Here are some things to consider when naming your ports:
1. For feed-through connections or bulkhead panels set the input and output Name the same.
2. Consider naming patchbay ports A-# and B-# for the top and bottom rows.
3. It doesn't matter which side you place a port on. You can always move it later.
4. For bi-directional signals such as Ethernet or RS-422 consider your document flow when determining the list to

which you will add these ports.
5. When selecting the connector gender always consider that WireCAD needs the CABLE END of the

connection, not the chassis side.

41
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Dialog Options

· Add to Which List
· Port Name - Enter the port name here. This may be a partial name if the Add I/O dialog is set to append either

multiple records or the Finally Append field contains the remainder of the string.
· Connector (Cable End) - From the global Connectors table.
· Signal Type - From the Project Signal Types table.
· Input Pin Style - Straight pin (Normal) or looped (two connection points).
· Output Pin Style - Straight pin (Normal) or bridged (two connection points).
· Add Multiples - If checked a record will be created for each Count. The number will be appended to the Port

Name info and formatted based on the Leading Zeros format.
· Finally Append Characters - Useful if you want to add characters after the multiple count number has been

appended. See the How to Add Ports  topic for more info.434



WireCAD v9.1 User Manual434

© 2017 Holbrook Enterprises, Inc. dba WireCAD

4.2.2.2.1.6  How  To: Add Ports

1. Open the Equipment Library.
2. Find an equipment definition to which we will add ports.
3. Select the I/O tab.
4. Click [Add Ports] button.
5. Add a single port to the Inputs table.

6. Add a single port to the Inputs and Outputs list at the same time.
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7. Add 10 ports to each grid appending a port number to each record.

8. Now let's create the 8 left line inputs of a stereo mixer. We will use the Finally Append Characters field to
append the characters -LEFT after the number is created and appended to the Port Name.
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4.2.2.2.1.7  Copy Port Data

Database > Equipment Library [Edit > Copy Port Data]
Commandline: le
Several Others

Related Topics:
None

Explanation

Allows you to copy port data from another device definition into the currently selected device definition.

Dialog Options

· Select Manufacturer and Model - to copy from.
· Which Ports to Copy - obvious.
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4.2.2.2.1.8  Incoming Signal Types Map

Database > Equipment Library [Download From Community]
Commandline: le
Several Others

Related Topics:
None

Explanation

When downloading from the community server you will use this dialog to map from the Signal Types used in the
incoming device definition to your Signal Types.

Dialog Options

· Rename From This - Incoming Signal Types.
· To This - Map to your Signal Types.
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4.2.2.2.1.9  Save Equipment As

Database > Equipment Library [File > Save As]
Commandline: le
Several Others

Related Topics:
None

Explanation

Allows you to copy the current device definition as a new device definition with a new Manufacturer and Model.

Dialog Options

· Manufacturer - Select Manufacturer.
· Equipment Model - The new name.
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4.2.2.2.1.10  Descriptor Map

Database > Equipment Library [Display Preferences] Descriptor Locations
Commandline: le
Several Others

Related Topics:
How To: Add Equipment to Drawings

Explanation

Change the locations and visibility of the various block descriptors:
· SysName
· Manufacturer
· EquipmentName
· Location
· Alias
· Description
· User1 - 4
· IPAddress
· Subnet Mask

50
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Operation

Drag the named descriptor to the target on the map. 
To hide a descriptor drag it to the Hidden Items frame.

4.2.2.2.2  Rack Builder Tool

Drawing > Advanced Tools > Rack Builder
Commandline: rb

Explanation

For more information see How the Rack Builder Works .

Automatically generate rack layout. Technically speaking we are populating rack locator grids. They may or may
not display an actual rack depending on whether you have assigned a SysName to a rack. 
The [Basic] tab allows you to select the locations to include in the Rack Building function. As you select each
location, the Systems Involved list will populate. 

80
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Dialog Options

· Advanced tab - exposes properties that control the behavior of the utility.

· Chassis Width - Sets the width of the chassis in DU.
·  Height in RU - Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm).
· Slot Count - Sets the number of slots per locator grid. This is used to position items that may not be located at

the insertion point of the rack unit. 
·  Slot Delimiter - WireCAD searches the Elevation field for numeric values first then for the slot delimiter if found

it parses the data into two values: the elevation and the slot, or in other words how far up in the rack and how far
over.

·  Insertion Point - Where to start the whole process. Clicking the [...] ellipsis button will temporarily dismiss the
dialog so you can pick a point from the active drawing.

· Attribute Height - If view rule is not Front Panel (file merge), sets the attribute height of the displayed text.
· Create As - 

Front Panel (file merge) = use the dwg file found in the equipment definition BlockRef (Front Panel
File).

Front Panel (from dims) = use the dimension data from the equipment definition to create a 3D rack
block.

From Dims if file not found = Use dimension data if the BlockRef is not found.
· Place Text If Item Cannot Be Created - If the item cannot be created due to lacking data, place a text marker

in the drawing at the location.
· Include Grid Hash Marks - This will normally be checked unless you are rebuilding a drawing that already has

the locator grids.
· Spacing DU - Sets the location grid spacing in Drawing Units. Measures from left edge to left edge.
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4.2.2.2.3  Assign Sysname

Drawing > Advanced Tools > Equipment Library [Add to Project Database Only (Assign SysName)]
Double-click WireCAD Block
Commandline: le

Explanation

This dialog is presented when assigning a SysName. The SysName field is automatically generated based on the
project SysName Format and the Next Numbers table.

Prerequisites
This dialog is only shown when Verbose SysName Assignment is checked.

Related Topics:
How To: Assign a SysName 72
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Dialog Options

· Manufacturer and Model - Filled automatically in most cases.
· SysName - This number is automatically generated based on the project SysName Format and the Next

Numbers table. WireCAD will always present the next number though you do not have to use it. In fact, there
are times when you should select the existing SysName from the dropdown list. For example say you have
shown the video ports of VTR-01 in one drawing and the audio ports of VTR-01 in another drawing. When you
assign the first instance you will get VTR-01 as the suggested SysName. The second instance will suggest
VTR-02. You will then click the dropdown and select VTR-01 thus ensuring that the two representations of the
same device have the same name.

· Alias - Friendly, functional, or descriptive name for the device.
· Location - of the device. For more information see the Locations Grid . Clicking the [+] button shows the

New Locations  dialog.
· Elevation - If numeric then WireCAD assumes RU. If not numeric it does not matter. There is one special

circumstance where the data will be non-numeric but WireCAD will understand how to parse it. That is the
situation when we want to locate something in a slot in a frame in a rack. We will need to use the form
[elevation][slot delimiter][slot]. For example let's say that I have a DA that needs to go in slot 5 of a frame
located at elevation 20 and my project slot delimiter  is a dash [-]. I would type into the Elevation field 20-5.

· User Fields - 50 characters max. You can define these captions in the Translation Manager - Plugins >
Translation Manager. Search for SysNameUser in the key field.

· IP Address Subnet Mask - Masked to either IPv4 or IPv6 based on the Project Settings  dialog.
· Power Consumption - Pulled from the global Equipment definition or typed manually here.
· Weight - Pulled from the global Equipment definition or typed manually here.
· Vendor 1 / Vendor 2 - Pulled from the global Equipment definition or typed manually here.
· Flags - Sort, query, filter flags. You can define these flags in the Translation Manager - Plugins >

Translation Manager. Search for SysNameFlagItem in the key field.
· BTU - Heat load in British Thermal Units. Pulled from the global Equipment definition or typed manually here.

544
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4.2.2.2.4  Assign Cable Number

Double-click WireCAD Cable
Commandline: ac

Explanation

This dialog is presented when assigning a Cable number if the Verbose Cable Assignment is checked. The
Cable Number field is automatically generated based on the project Cable Number Format and the Next
Numbers table.

Prerequisites
This dialog is show only when the Verbose Cable Assignment option is checked on the Advanced Tools ribbon
tab.

Related Topics:
How to Assign a Cable Number  
How to Assign Multiple Cable Numbers

77
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Dialog Options

· CableNo - This number is automatically generated based on the project Cable Number Format and the Next
Numbers table. WireCAD will always present the next number though you do not have to use it.

· Cable Type Manu, Cable Type*, Signal Type*
· Named Path - List of Named Paths . See the documentation on the Named Paths table. Selecting a

Named Path will cause the Length field to change.
· Length - Manually enter the cable length or select a Named Path.
· Integrator - Who is responsible for the installation of this cable.
· User Fields - You can define these captions in the Translation Manager - Plugins > Translation Manager.

Search for CableUser in the key field.
· Sheet - Automatically filled with the current drawing name.
· Replaced By - A housekeeping field that you may choose to use.
· Pinout - If the Enable Pinouts setting is checked then select the Pinout to apply to this cable.
· Vendor 1 / Vendor 2 - Pulled from the global Cable Type definition or typed manually here.

* changes to these fields may cause the number to recalculate.

545
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4.2.2.2.5  Assign Terminals

Double-click Terminal or Select Terminal and Click Advanced Tools > Assign Terminal(s)
Commandline: ats
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Explanation

This dialog is presented when assigning a terminal or a selection of terminals. The process is to first select the
SysName to use, then select the Inputs and Outputs port.

Note that the Inputs or Outputs grid may be disabled if the terminal to which we are assigning this information
does not have a CP_IN or CP_OUT to receive the data.

Record Highlighting
Red - Port assigned to a cable. The Source Info and Destination Info contains the CableNo : SysName>Port
info.
Yellow - A cable has been attached to this port somewhere in the project. The Source Info and Destination Info
contains the SysName>Port info.

Prerequisites
In order to assign a terminal you must first assign a SysName from which you will select ports.

Related Topics:
Understanding Terminals

Dialog Options

· Select a SysName - The SysName from which we will select ports.
· I am just changing a SysName (all existing ports stay the same) - Use this if you have already assigned a

SysName to a terminal but you want to switch with another SysName.
· Remember this equipment on next assignment - Persist the selected SysName on next Terminal

Assignment.
· Outputs Track Inputs (if matching) - Select a matching record from the Outputs list if the string matches the

record in the Inputs Name field. The Names must match exactly.
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4.2.2.2.6  Assign Terminal No Database Reference

[Ctrl] + Double-click Terminal
Commandline: none

Explanation

Occasionally you will need to land a cable on a device that is not your responsibility. The cable is yours but the
equipment is not.
You can use a Terminal to do this.
Using this method the data in the Terminal will not have a matching entry in the Equipment List.

Note that the Inputs or Outputs section may be disabled if the terminal to which we are assigning this information
does not have a CP_IN or CP_OUT to receive the data.

Prerequisites
None.

Related Topics:
Understanding Terminals 117
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4.2.2.2.7  Assign Splice

Double-click Splice Point Terminal
Commandline: none

Explanation

Occasionally you will need to splice a cable through a connection point of some sort such as:
· Terminal blocks.
· Punch downs.
· Butt splices.

You can use a Splice to do this.
Using this method the data in the Splice will not have a matching entry in the Equipment List.

Note that the Inputs or Outputs section may be disabled if the terminal to which we are assigning this information
does not have a CP_IN or CP_OUT to receive the data.

Using the string "SPLICE" in the SysName will cause the cable assignment function to ignore duplicate port
checks.

Prerequisites
None.

Related Topics:
Understanding Terminals 117
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4.2.2.2.8  SysName Error Check

Drawing > Advanced Tools > Drawing SysName Error Check
Commandline: drawingsysnameerrorcheck

Explanation

Check the drawing against the database. Checks the following:
· Retrieves all equipment from the drawing.
· Checks the drawing SysName against the database.
· If matched the record is shown normally. If orphaned or not assigned the background color will be changed.

Dialog Options

· Show Me - Zooms to the selected entity.
· Check for Errors - Scans then fills the grid.
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4.2.2.2.9  Add Multi-core Cable

Drawing > Advanced Tools > Add Multi-core Cable
Commandline: mc
Several Others

Explanation

Often times we install bundled cables - cables with multiple cores. The outside jacket gets a number and each
inner core an extension identifier like: A-1001-RED. Where A-1001 is the number that goes on the outer jacket and
 A-1001-RED goes on the RED core. Use the Add Multi-core Cable tool to create a record in the database for
each core in the Cable Type. The CableNo field will have the full number and the CableNoPrefix field will have
the number base. All cores will be marked Available for use. You can then assign one or all or any of them during
the normal Cable Number Assignment process. You must have Verbose Cable Assignment checked in order to
assign cores in a multi-core cable. Otherwise you will get the next number default.

Dialog Options

· Number Base - This is the part that goes into the Cable No Prefix field.
· Cable Type - Only Cable Types that are flagged as Multi-core will show here.
· Signal Type
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4.2.2.2.10  Cable Error Check

Drawing > Advanced Tools > Drawing Error Check
Commandline: dec

Explanation

Check the drawing against the database. Checks the following:
· Retrieves all cables from the drawing.
· Checks the drawing Cable against the database.
· If matched the record is shown normally. If orphaned or not assigned the background color will be changed.

Dialog Options

Item Description

Show Me Zooms to the selected entity

Check for Errors Scans then fills the grid.
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4.2.2.2.11  Auto Block

Drawing > Advanced Tools > Auto Block
Commandline: ab

Explanation

The Auto Block tool automatically places functional blocks in the drawing. This tool requires that the Project
Systems table be populated. 

Possible Uses
· Add functional blocks after creating SysNames from Rack Builder drawings.
· Create overall systems views.
· Create drawings from imported data.

Related Topics:
Auto Block tool. 91
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Dialog Options

· The [Basic] tab allows you  to determine which systems to add to the drawing.

· Filter - Filters the list by your criteria.
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The Advanced Tab

· Insertion Point - The point we start from. 
· Horizontal Spacing DU - How far apart horizontally. The vertical spacing is defined by the height of the highest

block in the row.
· Maximum Column Count - How many columns horizontally.
· Get Port Data From Cables Database - Select this option to search the cables database for port info instead

of the global equipment database. This will effectively show only those ports to which we have attached cables.
· Display As - How to display the blocks.
· Display Preferences - If Functional Block or Concept block is selected then set basic display parameters. 
· Signal Types to Display - Filter ports by the selected signal types.
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4.2.2.2.12  Ratsnest

Drawing > Advanced Tools > Ratsnest
Commandline: rn

Explanation

The Ratsnest tool works in conjunction with the Auto Block tool. How it works:
· Get the cables collection.
· Get the SysName>Port info from the drawing.
· Find matches.
· Drawing straight-line cables.

Possible Uses
· Create overall systems views.
· Create drawings from imported data.
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Dialog Options

· This tool has three sections. The Rats Nest section does the work of placing the cables in the drawing as
defined in the Cables database.

· [Ratsnest] - Run the utility to place the cables.
· Show Cable Numbers - With or without cable numbers.
· [Clear All Cables] - Removes ALL cables from the drawing. Not just ratsnested cables. This will remove ALL.
· [Cleanup] - Applies the auto-router to all cables in the drawing.
· Avoid Other Cables - Auto-router avoids other cables on cleanup.
· [Fillet] - Applies fillets to ALL cables in the drawing.
· Distance - Fillet distance in 100/DU.
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4.2.2.2.13  WireCADify Block

Drawing > Advanced Tools > WireCADify Block
Commandline: wirecadifyblock

Explanation

Occasionally you will want to use the geometry of a non-WireCAD generated CAD block. In order to do this you
will need to give the necessary attribute set to the CAD block so that it can function in WireCAD as a working
assignable entity.

Steps
· Start the command.
· Select a standard CAD block. It must be a block and not exploded entities.
· Follow the directions in the dialog to complete the process of adding the WireCAD attribute set to the CAD

block.

Possible Uses
· Use existing CAD drawings and work with WireCAD to move the drawing forward.
· Create custom appearance. 

Dialog Options

· Attribute Map Grid - Map your attribute to WireCAD's.
· Descriptor Locations - Reposition the base WireCAD attributes using the Descriptor Locations map.
· Hide All - Add all the WireCAD attributes but hide them from view.
· Show Default - Show the default attribute set.
· Preview - Preview of the merged block.
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4.2.2.2.14  Add Connection Point

Drawing > Advanced Tools > Add Connection Point
Commandline: addconnectionpoint

Explanation

If you need to place a connection point (a point to which you can connect a WireCAD cable). You can use this
tool.
You must use this tool on blocks that have the WireCAD attribute set.

Steps
· Start the command.
· Select a WireCAD block or a block that you have run the WireCADify command on.
· Select the geometric point at which the connection point will appear. This should be something that is easy to

snap a WireCAD wire to.
· Follow the directions in the dialog to complete the process of adding the WireCAD attribute set to the CAD

block.
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Possible Uses
· Use existing CAD drawings and work with WireCAD to move the drawing forward.
· Create custom appearance. 

Dialog Options

· Port Name, Signal Type, Connector (Cable End), Label Text Height, Show Labels
· Port is Input - This will determine which side the label appears on.
· Include Geometry - Display something to snap to.
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4.2.2.2.15  Cable Connection Exists

Not directly callable
Commandline: none

Explanation

The standard cable number assignment process is a multi-step process. One of the checks that is performed is to
see if the ports to which we have attached our cable are already assigned to some other cable in the database. If
they are found to exist in the database this dialog is shown indicating whether it is the source or the destination
that is in question. Bear in mind that multiple records might meet this criteria; hence the grid.

There are legitimate instances where this dialog will be shown and your choice requested:
· Y cable - The first assignment will proceed without error. The second will show this dialog indicating that the

source exists. As it should. You have a choice regarding numbering in this case. Do you duplicate the existing
number with a new record in the database or request the new number.

· One-To-Many - see above.
· Many-To-One - Inverse of above. You will see the destination exists.
· If you land multiple cable on the same port to parallel the connection.

Pay close attention if you are presented with this dialog. It is catching a common mistake before it gets to your run
sheet.

Prerequisites
At least one cable record in the Cables database.
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Related Topics:
How To: Assign a Cable
How To: Assign Multiple Cables
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4.2.2.2.16  Spare Cable

Advanced Tools > Add Spare Cable(s)
Commandline: AddSpareCables

Explanation

Place geometry in the drawing and cable(s) in the Cables database that represent spare cables.

The following images represent the above settings in both drawing and the Cables database.
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Prerequisites
At least one drawing

Related Topics:
How To: Add a Spare Cable

4.2.2.3 Plan View and Layout Tools Dialogs

The following set of tools is targeted at the plan view space.
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4.2.2.3.1  Take Offs

Drawing > Plan View and Layout Tools > Take Offs
Commandline: showtakeoffs

Explanation

Often we need to count items in the plan view space for quoting or other purposes. The Take Offs tool facilitates
this process by filtering the drawing for specific entity types on specific layers then counting those instances.

Possible Uses
· Quote preparation.
· Trouble-shooting.

Related Topics:
How to Pull a Take-off

Dialog Options

· Print - Print the grid.
· Export - Export the grid.
· Layer - What layer are we searching for the selected entity type(s).
· Entity Types - What entity type(s) are we searching for.
· Generate - Do It! The results will be displayed in the grid.
· Count - Count the items in the list. The results will be displayed in the right-hand list.
· ItemHandle ShowMe - Zooms to show the item in the drawing.
· IgnoreInCount - Ignore me when counting.
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4.2.2.3.2  Location Boundary

Drawing > PlanView and Layout Tools > Location Boundary
Commandline: pw

Explanation

Define geometric boundaries for locations important to the design. For example we would want to know where on
the drawing the Machine Room is but not necessarily the kitchen (unless part of our cable ends up in the kitchen).

Prerequisites
1. Source and destination Location Boundaries placed in the Plan View space.

Related Topics:
How To: Place a Location Boundary

Operation

1. Start the tool.
2. Select a text entity with the name of the location to pre populate the dialog.
3. Set the location type and geometry type.
4. Draw the boundary
5. Done. Lather , rinse, repeat.

125
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Related Topics:
None

Dialog Options

· Name - The location name. Either from the selected entity or entered directly or selected.
· Location Kind - Select the level of the location that you are drawing a boundary for.
· Automatically Nest Locations - Searches the drawing for containing boundaries and formats a nested location

string. The creates an entry in the Locations table if not found. 
· Boundary Entity - Boundaries must be a closed polyline of some sort.
· Show Name in LineType - Creates a new LineType with the name of the location and renders boundary entity

with the new LineType.
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4.2.2.3.3  Draw  Backbone (ENT Only)

Drawing > PlanView and Layout Tools > Draw Backbone
Commandline: none

Explanation

Backbones are collections of cable/fiber that are contained in a single jacket that run from one location to another
and are typically sized for growth. An example might be a fiber optic cable that contains 288 fiber cores that runs
from building A to building B. We know that initially we will not use all 288 fibers and have planned for growth. As
the facility needs change the usage of the backbone's fibers change.

WireCAD maintains backbones just like any multi-core cable with the exception that the Cables table record is
flagged IsBackBone = true.
WireCAD will create a cable record for every core in the Cable Type used.
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Prerequisites
1. SysNames assigned to the panels/equipment to which you will attach the ends of the Backbone.
2. Multi-core Cable Type representative of the Backbone.

Operation
This tool allows you to draw geometry in the Plan View space that represents the path of the Backbone. The
process requires the following steps:
1. Draw the polyline that represents the backbone.
2. If locations boundaries are found in the drawing the source and destination locations will be used. Otherwise

you will be prompted to define a location for each end.
3. Next you will be presented with the New Backbone tool where you will select the source and destination

panels/ports and the cable type.
4. Clicking [OK] will build a record in the Cables table for each core in the multi-core cable type.
5. The polyline length populate the cable record Length field.

Related Topics:
How To: Create a New Backbone

Dialog Options

· New Backbone - Select whether we are creating a new number or assigning existing unused core.
· Backbone ID - The Backbone number. This will be formatted based on the Project Backbone Format setting.
· Use Existing Available - Pick a Backbone that has available cores.
· Location Filter - Filter the list by location if the list is long and noisy.
· From Panel Info, To Panel Info - Select the panel. The ports will be shown in the list.
· Cable Type - Select the Cable Type.
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4.2.2.3.4  Draw  Cable

Drawing > PlanView and Layout Tools > Draw Backbone
Commandline: pwdc

Explanation

This tool allows you to draw a cable in Plan View space that is assigned to the Cables table.

Prerequisites
1. SysNamed source and destination equipment placed in the Plan View space or:
2. Source and destination Location Boundaries placed in the Plan View space.

Operation
This tool allows you to draw geometry in the Plan View space that represents the path of the cable. The process
requires the following steps:
1. Start the tool.
2. Select the source SysNamed equipment.
3. Select the destination SysNamed equipment.
4. Place the points in the polyline to finalize the appearance.

Related Topics:
Draw Cables

Dialog Options

· Cable No - Click the [...] button to generate a cable number.
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4.2.2.3.5  Populate Cables

Drawing > PlanView and Layout Tools > Populate Cables
Commandline: popc

Explanation

This tool pulls the cables from the Cables table into the drawing. The assumption with this tool is that you will use
it after you have done your functional drawings and assigned cable numbers and SysNames.
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Prerequisites
1. SysNamed source and destination equipment placed in the Plan View space or:
2. Source and destination Location Boundaries placed in the Plan View space.
3. Cable data in the Cables table that matches the placed equipment or locations.

Operation

1. Start the tool.
2. Select options.
3. Click [OK] to run.

Related Topics:
How To: Populate Cables in Plan View

Dialog Options

· Group Cables - Collapse cables that go from the same source and destination SysName or Location into a
single polyline with hash marks to indicate how many cables are represented by the one polyline.

· Must connect to equipment in the drawing - Only connect to plan view SysNamed equipment.
· Ignore cables that come and go to the same location
· Flag if other is not found - Draw a pointer out to the un-found equipment.
· Polyline Bulge Factor - Non zero for arced cables.

132
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4.2.2.3.6  Draw  Prew ire

Drawing > PlanView and Layout Tools > Draw Prewire Cable
Commandline: pw

Explanation

This tool allows you to draw geometry in the drawing that represents cables that have not yet had their functions
assigned. The only thing we know about these cables is the locations from which they start and end and the Cable
Type. A record will be added to the Cables table based on the count defined. The record is marked Available and
PreWIRE. Prewire cables can be automatically consumed later if the Automatically Consume Prewire  setting is
checked.

Prerequisites
1. Source and destination Location Boundaries placed in the Plan View space.

Operation

1. Start the tool.
2. Fill in the form.
3. Draw the cable path.

Related Topics:
How To: Draw a Prewire Cable in PlanView

375
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Dialog Options

· Cable Type - Select the Cable Type.
· Signal Type - Select the Signal Type.
· How Many - How many wires of this type take this path. A record will be created for each.
· Length Divisor - We will divide the length of the polyline by this value and place that info in the Length field of

the record. For example, say your Drawing Unit = 1 inch and you want the length in the Length field to be
displayed in feet. Your Length Divisor would be 12.

· Create Named Path - Create an entry in the Named Paths table with the name provided and length of the
polyline.
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4.2.2.3.7  Populate Equipment

There is no UI for this function

Drawing > PlanView and Layout Tools > Populate Equipment
Commandline: pope

Explanation

This tool pulls the Plan View version of the equipment from the Equipment List. The assumption with this tool is
that you will use it after you have done your functional drawings and assigned cable numbers and SysNames.
This tool relies on the Plan View File in the device definition to know what to place. 

It relies on Location Boundaries in the drawing to know where to place it.

If the Plan View File is blank the Project Default Plan View File will be placed if the Location Boundary is found:
Application Menu > Settings [Project][Basic][Default Plan View Block File]
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Prerequisites
1. SysNamed equipment preferably with an associated Plan View File in the global Equipment Library.
2. Location Boundaries placed in the drawing.

Operation

1. Start the tool.
2. A message box will explain the operation of the function. Click [OK]. The tool will run.
3. At completion the tool will report the number of placed items.

Related Topics:
None

4.2.3 Data Dialogs

The following is a collection of dialogs that may be presented while in the Data or Grid environment.
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4.2.3.1 New Location

Database > Locations [New]
Commandline: none

Explanation

This tool is used to create entries in the project Locations look-up table.

Prerequisites
1. None

Operation

1. Start the tool.
2. Enter the data in the fields as desired.
3. Verify the Qualified Location looks acceptable (its the part that the rest of WireCAD uses).
4. Click [Add].

Related Topics:
Locations Look-up table
Locations form reference
Defining Locations

544
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Dialog Options

· Campus - Enter the Campus name if applicable. If there are multiple numbered campuses you can increment
the Count field to append a number and create multiple records for each. 

· Building - Enter the Building name if applicable. If there are multiple numbered buildings you can increment
the Count field to append a number and create multiple records for each. 

· Floor - Enter the Floor name if applicable. If there are multiple numbered Floors you can increment the Count
field to append a number and create multiple records for each. 

· Room - Enter the Room name if applicable. If there are multiple numbered Rooms you can increment the
Count field to append a number and create multiple records for each. 

· Rack - Enter the Rack name if applicable. If there are multiple numbered Racks you can increment the Count
field to append a number and create multiple records for each. 

· Qualified Location - This is the important part. The Qualified Location is a concatenation of all the used
fields. The fields are merely and organizational construct for you. WireCAD will use the Qualified Location
throughout the application.

Example

In the following example we will add two locations using different approaches to achieve the same result.
· Enter the data across all fields:
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· Enter the data in a single field:

As you can see from the above examples the Qualified Location is the same for both. It does not matter which
approach you take.
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4.2.3.2 New Cable

Database > Cables
Commandline: cg

Explanation

This tool allows you to manually create a Cable in the Cables table.

Prerequisites
1. SysNamed source and destination equipment in the Equipment List.

Operation
1. Start the tool.
2. Select the source SysNamed equipment.
3. Select the destination SysNamed equipment.
4. Click the [...] button on the Cable No field to generate a Cable Number.

Dialog Options

· Cable Type
· Source Information - Set the source info.
· Destination Information - Set the destination info.
· Cable No - Click the [...] button to generate a cable number.
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4.2.3.3 Save Cable Type As

Database > Cable Type - File > Save As
Commandline: showcabletypesgrid

Explanation

Create another entry in the CableTypes database record by copying the source record into a new destination
record with a new Manufacturer and Cable Type.

Controls

· Manufacturer -  Select a Manufacturer.
· New Cable Type - Name the new Cable Type.
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4.2.3.4 New Manufacturer

Database > Manufacturers [File > New]
Commandline: none

Explanation

This tool allows you to create a new Manufacturer in the Global Equipment database.

Dialog Options

· Manufacturer Name
· ManufacturerID - Should match the Manufacturer Name field. 
· DisplayInEquipment - Show this Manufacturer in the Equipment Library.
· DisplayInCableTypes - Show this Manufacturer in the Cable Types grid.
· Website
· Image - Right-click and select Load from the context menu to add a Manufacturer logo.
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4.2.3.5 New Equipment Wizard

Database > Equipment [File > New]
Commandline: none

Explanation

This tool allows you to create a new Equipment definition in the Global Equipment database.

Related Topics:
How to Add Equipment

Dialog Options

· Manufacturer - Select the Manufacturer. Clicking the [...] button opens the New Manufacturer  dialog.
· EquipmentName/Model/Part Number - Name it.
· Description - Describe it.
· SysName Prefix - Be brief.

· Front Panel File - Pointer to the front panel file. Must reside in the %BLOCKS% support path.
· Plan View File - Pointer to the Plan View file. Must reside in the %BLOCKS% support path.
· Image -  Right-click and select Load from the context menu to add a image.
· Categories, Synonyms - This is for you. Create categories and synonyms.
· Abbreviation, Accessory Of - Not really used yet.

39
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4.2.3.6 New Cable Type

Database > Cable Types [File > New]
Commandline: showcabletypesgrid

Explanation

This tool adds a new Cable Type to the Global Equipment database. Cable Types may be either single or
multi-core and have different shielding configurations. WireCAD projects use the multi-core core color code if any
as the descriptor when identifying multi-core cables. The Cable Type Name and Manufacturer are used in the
Cable record. All other fields are maintained for reference of the designing engineer.

More About Multi-core Cable Types
WireCAD can create multi-core cable types at two different levels of detail:
· Core level.
· Conductor level.

Cores have conductors. Conductors being the base unit. Most people using WireCAD will not document down to
the conductor level but rather the Core level.
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Prerequisites
1. None

Related Topics:
Create a New Cable Type

Dialog Options

· Save
· ManufactureID - Select a manufacturer. Only Manufacturers that are flagged as DisplayInCabletypes appear

in this list.
· Cable Type or P/N - The name by which this cable type shall be known.
· Description - A description for posterity.
· Cable Char Z - Characteristic Impedance.
· Cable OD - Outside Diameter.
· Cable Gauge - Gauge.
· Cable Rating - Rating.
· Cable Weight, Standard Length - Standard put up length and weight.

Core/Conductor Configuration
· Shielding - Shielding determines how many conductors.
·  Is Multi-core - Flag this Cable Type as multi-core.
· Core Count - How many cores.
· Conductors per Core - Usually one.
· Conductor Count Including Shield(s) - Set automatically based on the core/conductor counts and the

Shielding configuration.
· Default Core/Fiber Mode - SM/MM.
· Color Code Applies To - Apply a color code to the conductors, cores or not.

34
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4.2.3.7 Synchronize Global Databases

Database > Sync Global Database ..
Commandline: sync

Explanation

This tool allows you to sync two Global Databases. The current Global Database will be synchronized with the
database you select in this dialog. The local and remote database may be either SQL Server of VISTADB. You
may import, export or sync with respect to the current Global Database. An Import would collect data from the
remote database and import it to the local Global Database.

Prerequisites
1. Two Global Databases. The currently active one and a remote one.

Related Topics:
Sync Basics 157
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Dialog Options

· External Database Location
· Database is Server Based - Enter the host information and login. Otherwise browse to the location of the

WireCADGlobalEquipment.vdb3 file.
· Import - With respect to the current Global Database. This would import data into the current Global

Database.
· Export - With respect to the current Global Database. This would export data into the external Global

Database.
· Bidirectional - Sync the two.

Advanced Settings
· Which collections to include - By default you would want to sync all collections.
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4.2.3.8 Combine Circuits (ENT Only)

Menu: Database > Circuits
Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items
Product Level: ENT

Click Tools > Combine Circuits.

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have the same
Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted will be discarded.

· This Circuit - The Circuit Name/Number of the circuit that will be appended or inserted into another circuit. This
circuit Name/Number will be discarded if successfully appended or inserted.

· Appends To - The Circuit Name/Number of the circuit that will be appended to.
· Inserts Into - The Circuit Name/Number of the circuit that will be inserted into.
· Before - Before this SysName.
· After - After this SysName.
· Insert Jumpers if Necessary - It is possible to create collections of cables in a circuit that do not interconnect.

If you do not select this option you will create collection of cables that do not interconnect.
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· Preview
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4.2.3.9 Expression Builder

Database > Any
Commandline: varies

Explanation

This tool allows you to manipulate data using the Expression Engine.

For more information on Expression Syntax .193
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Expression Tab
· Prototypes - Select from a number of pre-formatted expressions. Then replace the variables as appropriate.
· Expression - Enter your expression to evaluate here.
· [Clear] - Clears the Expression.
· [Apply to Test Object] - A prototype collection object is loaded into the property window of the Test Object tab.

Clicking this button applies the Expression to the test object data. You will want to edit the Test Object data
before executing this command so that you have a meaningful test.

· Left List - Variables, operators and fields to apply to the expression.
· Right List - Detail variables, operators and fields. Double-clicking a item here will insert it into the Expression

window at the caret.
· [OK] - Do it to the data in the grid.

Test Object Tab
· Property Window - Displays a prototype of the grid collection item. Edit this to have test data on which to

apply your Expression when the [Apply to Test Object] button is clicked.
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4.2.3.10 Find and Replace

Database > Any
Commandline: varies

Explanation

This tool allows you to find and replace string within the open grid.
Searches the current selection if any. If not, searches the whole grid.

Related Topics:
Grid Basics

Controls

· Find - Search Text.
· Find Options - 

Contains - Any or whole Find string exists.
MatchCase - Any or whole Find string matches case sensitive.
Exact - Whole string matches exactly.

· Ignore Read Only Columns - Searches only columns that can be edited.
· Replace With - Replace the found part with this.
· Find - Search and highlight the first found instance.
· Replace - Do the replace the found instance.
· Find and Replace All - Do it to all found instances.

24
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4.2.3.11 New Next Number

Database > Next Numbers - File > New
Commandline: nn

Explanation

Add a new Next Number item. Next Numbers are normally added automatically but if you need to take control and
add your own.
Next Numbers use a Sequence Key and an integer within a context.

Example
Say our cable number is V-1001. V is the Sequence Key and 1001 is the integer Next Number in the Context of
Cables.
or:
Our SysName is SRVR-101. SRVR becomes the Sequence Key and 101 the Next Number in the Context of
SysNames.

Related Topics:
Grid Basics
Next Numbers

Controls

· Sequence Key - What is the part we are sequencing on.
· Next Number - Integer next number.
· Context - 

All
Backbones
Circuits
Cables
SysNames

24
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4.2.3.12 Attach Document

Database > Most
Commandline: varies

Explanation

Many of the grids in WireCAD support Attached Documents. The document can be of any file type. The document
is stored in the database as a Binary Large Object (BLOB). Attached document can be launched from the grid by
clicking the hyperlink. The document will be opened by the system reader of the stored file type.

Related Topics:
Grid Basics
Next Numbers

Controls

· File - Browse to the file to attach by clicking the [...] button.
· Description - More words.

24
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4.2.3.13 Database Host Settings

Project > Open Project Fails
Commandline: op

Explanation

The only reason you will see this dialog is that you have attempted to open a SQL project where the database
server is unreachable or has actively refused our connection.
Here you have a chance to fix Host and User login Info.

· [Test Connection] - make sure that this returns that you can successfully connect to the database before
clicking [OK].
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4.2.3.14 Filter Editor

Various
Commandline: none

Explanation

The filter editor allows you to create filter criteria base on the collection fields combined with a logical operator and
a value.

Click the [+] button to add another complex condition.

Related Topic
BOM Generator
AutoBlock
How To: Filter Reports

568
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4.2.3.15 New Todo

Database > Project > Todo - File > New
Database > Project > Equipment List - Todo
Database > Project > Cables - Todo
Database > Project > Drawings - Todo
Commandline: varies

Explanation

Create a new Todo List item. When launched from the following grids it will associate the Todo List item with the
selected record(s):
· Equipment List.
· Cables.
· Drawings.

Related Topics:
Todo List  Settings
Todo List Grid
Grid Basics

363
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Controls

· Item -  Words.
· Description - More words.
· Assigned To - Who is to do it.
· Priority - Set the urgency.
· Status - Where are we at in the process.
· Expected Completion Date - When are we expecting this done by.
· Completed Date - When did we get it done.

You can see the Todo List items in the Todo List grid and in the associated grids:
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4.2.3.16 Ripple Choice

Post Save - Rackbuilder Drawings, Equipment List, Cables table, Locations table
Commandline: varies

Explanation

Something has changed that potentially effects data in other drawings and databases. This is your chance to
update those other entities in other places.

Controls

· Full Ripple -  Search all drawings for the changed items and update.
· Quick Ripple - Search only indexed drawings. If the indexes are up to date this can significantly reduce ripple

time.
· Yes - Do it!
· No - Don't Do It!
· Cancel - Do nothing.
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4.2.3.17 Add/Edit Via (ENT Only)

Database > Backbones then Tools > New Via
Commandline: none

Explanation

WireCAD ENT supports the concept of VIAS. Vias are waypoints or appearances of Backbones as they make
their way from starting point to ending point. VIAS can be used to list all of the pullboxes or manholes that a
backbone appears in. They can also be used to indicate splice points.

VIAS are an ordered list that is attached to the Backbone. The Idx field determines list order.

VIAS can be shown in the the following visualizations:

VIAS shown in the Circuits visualizer
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VIAS shown in the Riser visualization

VIAS shown in Ladder Visualization

Backbone from panel to panel Via Manhole 1 and Manhole 2

Prerequisites
1. At least one Backbone in the database.
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Related Topics:
New Backbones
Backbones Visualization Settings
Circuits Visualization Settings
Backbone Display  in Calibrated Drawing

Dialog Options

All of the following are optional except the Idx field.
· Idx - the position in the list of VIAS.
· Name - Optional name of the VIA.
· Description - Optional description of the VIA.
· Type -  Optional type of the VIA.
· Location -  Optional location of the VIA.
· Elevation -  Optional elevation of the VIA.
· Ports -  Optional ports of the VIA.

203
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220

326
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4.2.3.18 New Blind Patch

File > New from the Blind Patches Tool
Commandline: none

Explanation

Used to select the FromSys value in the Blind Patches tool. Select either a named piece of equipment or create a
new CFE piece of equipment with a Manufacturer and Model name. 

NOTE: CFE equipment will not appear in the Equipment List.

Prerequisites
1. At least two Backbones in the database.
2. You must first select a ToSys from the dropdown.
3. Select the row to add a Blind Patch to or if Duplex Jumper is selected click the top row.

Related Topics:
Blind Patch Tool Explanation
How To: Create a Blind Patch
How To: Discover Circuits from Blind Patches
How To: Make a Real Circuit from Blind Patches
Blind Patch form

214
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4.2.4 Report Dialogs

Dialogs associated with report designer.
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4.2.4.1 New Report Wizard

Reports > New with Wizard ...
Commandline: rw

Explanation

Create a new report using the New Report Wizard.

NOTE: We recommend that you find an existing report that is close to what you are looking for and modify that
after saving it with your name. It will save you time and effort.

Prerequisites
1. Open Project

Operation
1. Start the tool.
2. Step through the wizard
3. Finish the wizard.
4. Edit the report in the designer to finalize it.

Related Topics:
Creating Reports 143
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4.2.4.2 Scan for Discrepancies

See the section on Index Grids 548
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4.2.4.3 Report Manifest Editor

Report > Smart Tag
Commandline: none

Explanation

If your Report Show Mode = Gallery the gallery items will display:
· Preview bitmap.
· Large bitmap when hovering over the gallery item.
· Caption text.
· Descriptive text.
· Tooltip text.

When the gallery loads it searches for a manifest file with the same name as the report file.
Example:
MyReport.repx - report file.
MyReport.xml - manifest file.
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Make sure that the manifest file name matches the report name and that they are in the same directory.

If the manifest file does not exist the stock bitmap is shown and the file name is used as a caption.

Prerequisites
A custom report.

Related Topics:
Report Show Mode = Gallery

· File Name - the name of the report repx file.
· Caption - gallery item caption.
· Description - gallery item description.
· Tooltip - text when hovering over the gallery item.
· Small Image - 
· Large Image - displayed when the gallery is expanded and the item is hovered.

4.2.5 Plugins Dialogs

The following sections relate to plugins that register dialogs for editing. These are plugins included with WireCAD.
Other plugins may register dialogs that do not appear here. 

364
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4.2.5.1 Plugin Manager

Plugins>Plugin Manager
Commandline: pim

Explanation

The WireCAD Plugin Manager shows:
· Loaded plugins.
· Unloaded plugins.
· Automatically Discovered plugins.

Only Enabled plugins are eligible to load/unload. Disabled plugins will not show here.

WireCAD Plugin Types
WireCAD has facility for two types of plugin:
1. Auto-discovered plugins. These plugins register themselves on application startup. They may or may not

include a graphical user interface element.
2. Registered plugins. These plugins register themselves via a plugin manifest file located in the C:

\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins\*.wpi. Registered plugins may place a
button somewhere in the WireCAD workspace, register a corresponding Commandline shortcut, and may
respond to WireCAD events.
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Related Topics:
Included Plugins
WireCAD Software Development Kit (SDK)
Enable/Disable Plugins

Dialog Options

· Load - Loads the selected plugin from the Unloaded Plugins grid. This function does not apply to the
Automatically Discovered plugins.

· Unload - Unloads the selected plugin from the Loaded Plugins grid. This function does not apply to the
Automatically Discovered plugins.

· Rescan and Reload All - Unloads then rescans and reloads all plugins. Applies to all plugins.

Plugin Creation
· Add/Edit PI info (*.wpi) - Show the Add or Edit Plugins dialog to work with WireCAD Plugin Info files

(wpi).

· Edit Plugin Code - Open your IDE to edit code. You will be prompted to enter a path to the IDE exe file.

164

585
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4.2.5.2 Script Editor/Runner

Explanation

Often times there are operations that you find yourself repeating some thing or process endlessly. Scripts are a
good way to automate those processes. There are many example scripts to browse through and see how they
work. Example scripts can be found at:
c:\users\public\documents\WireCAD\WireCAD9\scripts\*.cs

NOTE: Scripts that run in WireCAD MUST have the following method signature or they will not execute:

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using WireCAD;

using WireCAD.Interfaces;

//You may add additional using statements as needed but the listed ones are the minimum.

public class Script

{

public static void Run(Workspace ws)

{

//do your stuff here

}

}
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Possible Uses
1. Title block filling.
2. New Drawing creation.
3. Database cleanup.

Usages
1. Launch the tool.
2. File>Open an example script. (c:\users\public\documents\WireCAD\WireCADx\Scripts\).
3. Read the comments (they are the ones proceeded by //).
4. Tweak the script to suit your needs.
5. Run it by clicking the [RUN] button

 
6. Fix any compiler errors. Lather, rinse, repeat.

Dialog Options

· New - Creates a new script with the necessary method signature.
· Open - Opens a .cs file to run.
· Comment - Comment out your selection. Useful for hiding code from the compiler without deleting it.
· Un Comment - Un comment your selection.
· Indent, Out dent
· Run - If the Error List is empty then Do It. If it fails it will tell you why in the Compiler Output window.

· Window On Top - Make this the topmost window always.
· Error List - Design time scripting syntax errors.
· Compiler Output - Run time compiler and script execution errors, as well as Trace messages.

4.2.6 PDF Viewer Dialogs

The following is dialogs associated with PDF Viewer.
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4.2.6.1 PDF Print Preview

Project Explorer > Double-click PDF File [Print]
Commandline: None

Explanation

This is the Print Preview Dialog for the PDF Viewer. It's pretty standard so we won't enumerate all the controls
here.

Prerequisites
1. At least one pdf file saved in the project drawings path.

4.2.7 Map Tool Dialogs

For information on the Map tool see this topic .572
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4.2.7.1 ID GPS Locations

Mapping Tools > Tools > ID GPS Locations
Commandline: none

Alternately from the Map tool:
Tools > ID GPS Locations

Explanation

This form is used to pick points from a drawing or map and associate them with the select Location record.
This tool only works with DWG drawings that have been calibrated to the GPS coordinate system or with the Map
tool .572
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Controls

New: Open the New Locations  dialog.
Save: Commit your changes to the Locations  table of the project database.
Close: Close this form without saving.
Copy Selected Down: Copy the data from the top cell(s) down overwriting any data in the cell(s) below.
Pick >: Dismiss this dialog and select a point from the drawing or map. The GPS coordinate will be entered in
each of the selected rows.
Zoom Show Selected Text: (drawings only) text entities in the drawing that match the text of the currently
focused cell. 
Show Me: Finds the GPS coordinate in the drawing and places a Location Marker. Then zooms the marker into
view.
Leave Location Marker: Sets whether a location marker as determined by the settings is placed at the pick
point.

Related Topics:
How To: Show Location Markers in the Map Tool
How To: Associate GPS LAT, LON with your Locations

477
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4.2.7.2 Print Preview

Menu: File > Print

Explanation
The print preview dialog can be used to send the current map view to the printer or exported to several file formats.

Controls

Document Section

Open - Open a saved *.prnx file for printing.
Save - Save a *.prnx file for printing later.

Print Section

Print - Open the Printer dialog to set the current printer, page size, number of copies, etc.
Quick Print - Do it now.
Options - Open a dialog to set the image fit properties and what visual elements to include in the printed output.
Header / Footer - Open a dialog to set the document header and footer.

Page Setup Section

Scale - Set the scale of the document or fit it to a number of pages.
Margins - Set the document margins. Alternately you can drag a margin indicator line to resize it.
Orientation - Set portrait or landscape mode.
Size - Set the page size. Sizes are based on the current printer.

Navigation Section

Find - Find text within the document.
Thumbnails - Show the Thumbnails tool panel.
Page Navigation - First, Previous, Next, Last. Move around the pages.
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Zoom Section

Mouse Pointer Tool - Enable the mouse pointer.
Pan Hand Tool - Enable the panning tool.
Magnifier Tool - Enable the magnifier tool.

Many Page Selector - Set the number of pages in the viewer.
Zoom Out - Zoom the display out.
Zoom Numeric - Zoom to a specific numeric percentage value.
Zoom In - Zoom the display in.

Page Background Section

Page Color - Set the color of the background.
Watermark - Open a dialog to set a watermark for the document. The watermark can be text, image, or both.

Export Section

Both the [Export To] function and the [Email As] functions support the following formats:
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4.3 Forms

Forms differ from dialogs in that they occupy the full client docking area of the main window. Only one form may be
active at a time. That form may host other dialogs.

4.3.1 Application Menu Forms

The forms in this section are specific to the Application Menu.
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4.3.1.1 Project Information

Application Menu > Project Info
Commandline: Project Info

Explanation

This form contains the basic project information and status. Project name and description here will show up in the
reporting engine and can be used elsewhere. The CurrentProjectRevision field populates the Cables and
SysNames grid when an edit is made or a new record added the value here will populate there.

The Project Checked-out status can be shown modified here.

Project File Info Tab

Read only look at the PROJECT_NAME.wc6plf file.

Related Projects Tab

Here you can Add/Edit/Remove related projects. Related projects show in the Project Explorer (read-only) and can
warn if duplicate SysNames and Cable Numbers are about to be used.
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4.3.1.2 Permissions Grid

Application Menu > Security Tools > Permissions Viewer
Commandline: none

Explanation

This grid shows the different permissions groups and collection permissions.
This grid is read only and only visible if you are a member of a group with administrator privileges.

4.3.2 Global Data Forms

The forms in this section are specific to the Global Equipment Database.
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4.3.2.1 Manufacturers Grid

Database > Manufacturers
Commandline: man

Explanation

This tool provides access to the Manufacturers table of the Global Equipment database. The grid is hierarchical.
The [+] buttons may be expanded to show related equipment.
Deletes here cascade, deleting any equipment that is associated with the Manufacturer.

Prerequisites
1. There is at least one Manufacturer added to the Global Equipment database.

Related Topics:
Grid Basics
How To: Add Manufacturers

Form Options

· New - Show the New Manufacturers dialog
· Attach Document ... - Any document may be attached to any record. This is a handy place to store

manufacturer data sheets, images and such.
· Remove Duplicates - This function scans the table for duplicate Manufacturer Names. If found the following

occurs:
All equipment is rolled up under the top instance of the manufacturer.
All other instances are deleted.
The collection is saved.

NOTE: a safety valve exists where if the Manufacturer is flagged to DisplayInCableTypes the function is ignored.

24

482

482
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4.3.2.2 Equipment Grid

Database > Equipment
Commandline: eg

Explanation

This tool provides access to the Equipment table of the Global Equipment database. The grid is hierarchical.
The [+] buttons may be expanded to show related Inputs and Outputs.
Deletes here cascade, deleting any I/O associated with the Equipment.

Prerequisites
1. There is at least one Manufacturer added to the Global Equipment database.
2. There is at least one Equipment definition added to the Equipment table.

Related Topics:
Grid Basics
How To: Add Equipment

24

39



Reference 523

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Form Options

· New - Show the New Equipment Wizard .
· Attach Document ... - Any document may be attached to any record. This is a handy place to store

manufacturer data sheets, images and such.
· Clean - This function scans the table for Equipment with no I/O. If found the following occurs:

The Equipment definition is deleted.
The collection is saved.

· Transfer to Different Manufacturer - Allows movement of the selected device to a different Manufacturer.

483
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4.3.2.3 Default Signal Types Grid

Database > Default Signal Types
Commandline: st

Explanation

This tool provides access to the Default Signal Types table of the Global Equipment database. Many of the default
display behaviors originate here, for instance:
· The color of pins on a block.
· The color of cables.
· The Cable Type associated with the Signal Type.
· The Cable Number prefix.

These values are preempted by the Project Signal Types  grid which has priority. If signal type information is
required by the application it first looks to the project, then to the default.

Prerequisites
1. None

Related Topics:
Signal Types
Grid Basics

Form Options

· New - There is no New button on this grid. The New Record Row appears at the top of the grid:

· Rename I/O Signal Types - Rename the Signal Type in this grid and all I/O in the global database.
· Rebuild Signal Types from I/O - This function scans the Inputs and Output for Signal Types then:

536

32

24
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Checks existing in this grid.
Add if not found.
Collection is saved.

4.3.2.4 Connectors Grid

Database > Connectors
Commandline: cn

Explanation

This tool provides access to the Connectors table of the Global Equipment database. 

Prerequisites
1. None

Related Topics:
Grid Basics

Form Options

· New - There is no New button on this grid. The New Record Row appears at the top of the grid:

· Rename I/O Connector Types - Rename the Connector in this grid and all I/O in the database.

24
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4.3.2.5 Cable Types Grid

Database > Cable Types
Commandline: ShowCableTypesGrid

Explanation

This tool provides access to the Cable Types table of the Global Equipment database. The grid is hierarchical.
Clicking the [+] button will display a child grid of the ConductorsCollection for that record if any.

Prerequisites
1. None

Related Topics:
Grid Basics
How to Add a New Cable Type

Form Options

· New - Shows the New Cable Type  dialog.

24

34

484
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4.3.2.6 Color Codes Grid

Project Explorer > Color Codes
Commandline: showcolorcodesgrid

Explanation

This tool provides access to the Color Codes table of the Global Equipment database. 

Prerequisites
1. None

Related Topics:
Grid Basics 24



WireCAD v9.1 User Manual528

© 2017 Holbrook Enterprises, Inc. dba WireCAD

4.3.2.7 Pinouts

Database > Pinouts
Commandline: po

Explanation

This tool provides access to the Pinouts table of the Global Equipment database. The concept of the Pinouts
tool is to create a data set that describes two connectors and the conductors between them. The Cable Type
data needs to have conductor level data. The data may be attached at the project level to a cable. The data can
also be churned into a preview.

Prerequisites
1. None

Related Topics:
Grid Basics 24
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Form Detail Tab Options

· Select Existing Pinout Profile - Select a named pinout to fill the grid and subsequent preview.
· Show More Detail
· Preserve Pin Order When Creating Preview, Ortho Conductors - How is the Preview created.
· Pinout Grid

Clicking the File > New button enables the New tab. From here you enter the overall data for the pinout. The Left-
hand and Right-hand connectors conductor counts, etc. Once the pinout is created you can edit the detail in the 
Detail tab.

Form New Tab Options

· Left hand Connector Info -Enter the connector type, pin profile (if any) and count.
· Cable Type - Select the Cable Type. Remember this type must have conductor level data. Core Level data

alone will not suffice here.
· Right hand Connector Info - Enter the connector type, pin profile (if any) and count.

Click File > Save to commit your changes and switch back to the grid view.

4.3.3 Project Data Forms

The forms in this section are specific to the Project Database.
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4.3.3.1 Backbone Grid (ENT ONLY)

Databases > Backbones
Commandline: bbg

Explanation

This is the Backbones view and includes a visualizer that can produce both ladder diagrams and riser diagrams. 
Here you can view and search Backbone data. You can also set the Status of a Backbone.

Prerequisites
Backbones created in the project database.

Related Topics:
New Backbone
Backbone Preview Settings
Backbones
Grid Basics

203

207

199

24
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4.3.3.2 Blind Patch Form (ENT ONLY)

Project Explorer > Project Databases > Blind Patches
Commandline: ShowBlindPatchTool

Explanation

This is the Blind Patch tool that allows you to document your patches without knowing the whole circuit. Once
the patches (jumpers) are documented you can use the Discover tool to find what is patched to what. If you find a
discovered circuit to be complete you can use the Make Circuit command to create a real circuit and remove the
Blind Patches from this list.

The form is tabbed. The [Blind Patch] tab (shown above)  provides a data entry grid where you can add/edit/delete
Blind Patches. The second tab (shown below) is used to Discover/Preview/Make Circuit(s) from your Blind
Patches.

Discovered Circuit
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Prerequisites
At least two Backbones

Related Topics:
Blind Patch Tool Explanation
How To: Create a Blind Patch
How To: Discover Circuits from Blind Patches
How To: Make a Real Circuit from Blind Patches

Form Options:
Menus
New: Create a new From SysName for the selected record based on the Simplex/Duplex option and the
selected ToSys.
Save: Commit the changes to the database.
Delete: Delete the selected record(s). This function will delete single records for Simplex patches and two records
for Duplex patches.

Discover Circuits: Search the blind patches and find all possible connections to make a circuit.
Preview Selected: When checked will cause a preview to be generated whenever the discovered circuit grid
record is changed.
Make Circuit: Creates a real circuit from the data of the selected record. 

Blind Patch tab
Select Patch Panel (SysName): Select the patch panel that you will jumper to.
Simplex/Duplex Jumper: Select whether the jumper needs one record or two.
Data Grid: Use this grid to select/add/edit/delete Blind Patches

Discover Circuits from Blind Patches tab
Preview: Shows the circuit preview of the selected circuit.
Discovered Blind Patch Circuits Grid: Shows the found circuits.
Status: Shows the counts of Blind Patches and found circuits.

214

215

216

216
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4.3.3.3 Circuits Grid (ENT ONLY)

Databases > Circuits
Commandline: circ

Explanation

This is the Circuits view. Circuits are collections of cables. In most cases they include jumpers between panels
and Backbones. Circuits consist of a set of ordered elements and a strand count. 
This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this grid
will create a functional diagram of the selected Circuit.

Prerequisites
Creation of at least one Circuit

Related Topics:
Circuits
Circuits Preview Settings
Combine Circuits
Grid Basics

217

220

236

24
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4.3.3.4 New Circuit (ENT ONLY)

Database > Circuits [File > New]
Commandline: none

Explanation

This tool provides a means by which to create a new circuit. Circuits can either be assembled manually or
automatically. Creating circuits manually involves selecting each jumper and backbone segment. To create a
circuit automatically you define the first and last jumper and hand it off to the Path Finder tool which will find and
present candidate routes. 

Prerequisites
1. Backbones added.

Related Topics:
New Circuit 228
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4.3.3.5 New Backbone (ENT ONLY)

Database > Backbones [File > New]
Commandline: none

Explanation

Create a new Backbone.

Prerequisites
1. None

Related Topics:
Backbones Grid
Backbones
Grid Basics

530

199

24
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4.3.3.6 Project Signal Types Grid

Database > Project Signal Types
Commandline: st

Explanation

This tool provides access to the Project Signal Types table of the Project database. Many of the default display
behaviors originate here, for instance:
· The color of pins on a block.
· The color of cables.
· The Cable Type associated with the Signal Type.
· The Cable Number prefix.

These values preempt the Default Signal Types  grid. This grid has priority. If signal type information is required
by the application it first looks to the project, then to the default.

Prerequisites
1. None

Related Topics:
Signal Types
Grid Basics

524
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Form Options

· New - There is no New button on this grid. The New Record Row appears at the top of the grid:

· Rename I/O Signal Types - Rename the Signal Type in this grid and all I/O in the global database.
· Rebuild Signal Types from I/O - This function scans the Inputs and Output for Signal Types then:

Checks existing in this grid.
Add if not found.
Collection is saved.
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4.3.3.7 Equipment List

Databases > Equipment List
Commandline: sys

Explanation

This is the main Equipment List of all SysNames in the project. You can edit and ripple your changes from here.
This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this
grid will create a system snapshot of the selected SysName.

Prerequisites
Assigned SysNames

Related Topics:
Assign SysName
Grid Basics
How To: Use the Equipment List Visualizer

442

24

86
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Data Tab Options

· Search - Search the collection for the search term.
· Find All - Clear the search field and return all records.
· Ripple List - Changes you have made that may need to be rippled across the drawing set. The ripple will occur

after you save the grid to the database.

Tools
· Attach Document - Any document can be attached to any record. This is useful for storing data sheets, test

data, and images.
· Slurp Locations - Collect all location data from the Equipment List and populate the Locations table with it.
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Visualization Tab Options

· Terminal - Select the terminal to which we will attach the cables.
· Vertical Pin Spacing 1/100 DU - How far apart vertically are the ports.
· Use Last Display Order if Set
· Use Last Saved Appearance - Where is the SysName label positioned with reference to the end points of the

polyline that represents the cable.
· Body Width - 
· Port Data Source - Pull the port data from the Equipment Library which will show all available ports as

defined in the Equipment Library or pull port data from the Cable table which will show only ports which have
cables attached.
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4.3.3.8 Cables

Databases > Cables
Commandline: cg

Explanation

This is the main Cables table view. You can print, export and edit this view. Some fields are marked read only
because they inherit their data from other tables. Changes to those fields should be done in the other tables then
rippled into this table.
This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this grid
will create a Ladder diagram of the selected cables.

Prerequisites
Cable numbers assigned in a drawing.

Related Topics:
New Cable 480
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Grid Basics

Data Tab Options

· Search - Search the collection for the search term.
· Find All - Clear the search field and return all records.
· Ripple List - Changes you have made that may need to be rippled across the drawing set. The ripple will occur

after you save the grid to the database.

· Expert Mode - Removes the read-only flags and puts the grid in a completely editable state. Not for beginners.
· Add Many - Only available in Expert Mode this tool adds blank records to the table that you can edit as a

spreadsheet.

Tools
· Repair Equipment List - Scans the Cables table for SysNames then compares with the Equipment List.

Missing SysNames are then added to the Equipment List.
· Attach Document - Any document can be attached to any record. This is useful for storing data sheets, test

data, and images.

Visualization Tab Options

· Terminal - Not yet implemented.
· Cable Number Text Height
· Vertical Spacing 1/100 DU - How far apart vertically are the cables.
· Center Label Offset - Where is the center label positioned with reference to the center of the polyline that

represents the cable.
· SysName Label Offset - Where is the SysName label positioned with reference to the end points of the

polyline that represents the cable.
· SysName Text Height - The text height of the SysName label.

24
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· Port Info Format String - The following variables can be used along with the /n new line character to format the
port info:

{0}SysName
{1}Port
{2}Location
{3}Alias
{4}Connector
{5}Cable Number
{6}Cable Manufacturer
{7}Cable Type

Example:
Assume that the SysName is VTR-01. The PortName is VID-OUT and the Location is RK-10 The following

Port Info Format string:
{0}>{1}@{2}
Will produce the result:
VTR-01>VID-OUT@RK-10

· Cable Text Format String - The following variables can be used along with the /n new line character to format
the Cable Text:

{0}Cable Number
{1}Cable Manufacturer
{2}Cable Type
{3}Length
{4}Sheet

· Location Marker Spacing - How far apart horizontally the vertical location markers are spaced.
· Location Marker Text Hit, Location Marker Color, Location Marker Pen Width, SysName Rotation

Angle
· Show Dot Direction Color - Display a green dot on the source side and a red dot on the destination side of the

cable.
· Show SysNames
· Color By Signal Type - Inherit cable color by Signal Type or set a single color for all cables.
· Collapse Multi-core Cables to Single Line - Multi-core cables are represented by many records in the Cables

table. You can choose to display a cable for each or collapse to a single cable.
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4.3.3.9 Locations

Databases > Locations
Commandline: showprojectlocationsgrid

Explanation

This is the main Locations table view. You can print, export and edit this view. Changes to this grid can be rippled
throughout the project.
Remember that the only bit of data WireCAD actually uses from this grid is the QualifiedLocation.

Prerequisites
None

Related Topics:
New Location Dialog
Grid Basics

477
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4.3.3.10 Named Paths

Databases > Named Paths
Commandline: shownamedpathsgrid

Explanation

The Named Paths grid is an organizational tool to keep track of key distances. We name a path and give it a
distance and other factors to determine. You can use it as a reference, as well as a length calculator in the Assign
Cable Numbers dialog.

Prerequisites
None

Related Topics:
Assign Cables
Grid Basics

445

24
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4.3.3.11 ToDo

Databases > Todo List
Commandline: tdl

Explanation

A To Do list. You can define the data that fills the following drop downs in the Todo List Settings  panel:
· Assignees
· Statuses
· Priorities

Prerequisites
An active project.

Related Topics:
Todo List Settings  
Grid Basics

363

363
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4.3.3.12 Drawings

Project Explorer> Project Databases > Drawings
Commandline: sdg

Explanation

This is the list of drawings in the Project\Drawings folder tree. The following changes in the Drawings table have
occurred in WireCAD v8 and forward:
· The DrawingsPath has changed from absolute to relative.
· The tool now scans for and lists pdf files.
· If the project database is SQLAzure the dwg and pdf files are embedded in the database for portability.

NOTE: to rename a drawing use the function in the Project Explorer. Right-click a closed drawing and select the
context menu item Rename Drawing.

Prerequisites
An active project.

Related Topics:
Grid Basics 24
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4.3.3.13 Index Grids

More Information
Understanding Indexes

4.3.3.13.1  Unassigned Cables

Database > Index Grids > Unassigned Cables
Commandline: ShowUnassignedCablesGrid

Explanation

Any Cable that does not yet have a number to this index by drawing.
As you approach the end of a project this grid should be empty.

105
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4.3.3.13.2  Unassigned SysNames

Database > Index Grids > Unassigned SysNames
Commandline: ShowUnassignedSysNamedGrid

Explanation

Any equipment that does not yet have a SysName and add it to this index by drawing.
As you approach the end of a project this grid should be empty.
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4.3.3.13.3  Cables by Draw ing

Database > Index Grids > Cables by Drawing
Commandline: ShowCablesbyDrawingGrid

Explanation

Any Cable that has a number and corresponding entry in the Cables database is added to this index by drawing.
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4.3.3.13.4  SysNames by Draw ing

Database > Index Grids > SysNames by Drawing
Commandline: ShowSysNamesbyDrawingGrid

Explanation

Any equipment that has a SysName and corresponding entry in the Equipment List is added to this index by
drawing.
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4.3.3.13.5  Cables by SysName

Database > Index Grids > Cables by SysName
Commandline: ShowCablesbySysNameGrid

Explanation

Any Cable that has a number and corresponding entry in the Cables database and where both ends of the Cable
have valid entries in the Equipment List will be added to this index.
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4.3.3.13.6  Orphaned Cables

Database > Index Grids > Orphaned Cables
Commandline: ShowOrphanedCablesGrid

Explanation

Any Cable with a number but no corresponding entry in the Cables database will be added to this index by
drawing.
As you approach the end of a project this grid should be empty.
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4.3.3.13.7  Orphaned SysNames

Database > Index Grids > Orphaned SysNames
Commandline: ShowOrphanedSysNamesGrid

Explanation

Any equipment with a SysName but no corresponding entry in the Equipment List will be added to this index by
drawing.
As you approach the end of a project this grid should be empty.
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4.3.3.14 Import Project Data

Database > Import Tool
Commandline: it

Explanation

This tool imports data from a text delimited file into the various databases based on your initial selection.

There are three modes available for selection in this form:
1. Import SysName data. This tool attempts to import data into the project Equipment List and the Global

Equipment Library.
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2. Import Cables data. This tool attempts to import data into the Cables table and the Equipment List.

3. Hybrid import. This tool attempts to import data into the Cables, Equipment List and Global Equipment Library.

The process leads you through file selection
Column Mapping 
Data validation
Import.

Prerequisites
One of the import templates with your incoming data.

Related Topics:
None
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4.3.3.15 Discrepancies

Project Explorer > Project > Discrepancies
Commandline: dr

Explanation

This function is provided for legacy purposes. These functions have been replaced by the index grids.
There is one instance where the discrepancy report is used.
If a ripple is initiated in a multi-user install and another user has the drawing open. The ripple cannot update the
drawing.
A record is added to the discrepancy report. Use the Sync Equipment function. 

Prerequisites

Related Topics:
Sync Equipment with Database 107
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4.3.3.16 Next Numbers Grid

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None
Product Level: ALL

The Next Numbers Grid will show you the next available Cable number based on your Cable Number Format .
To access the Next Numbers Tool, type NN in the command line prompt. 

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As you progress
through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number box and fill in
the desired number. Be sure that you are not entering a number that is already in use. 

Note: Yours will look different as the Next Numbers grid will automatically create entries for each new sequence
used by the application.

96
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4.3.3.17 Project Rules

Menu: Project Explorer - Project Databases > Rules
Default command line shortcut: ShowProjectRules
Related Project Settings:

Project>Settings[Project Rules] Enable Project Rules
Product Level: ALL

WireCAD 9 allows you to define project specific rules.
There are four contexts in which rules will be evaluated. Rules are contained in the Project Rules grid.

A Rule consists of:
1. The Expression to evaluate.
2. The Context in which to evaluate the expression.
3. The ExecutionOrder. If multiple rules are defined to evaluate within the same Context they will be evaluated in

the ExecutionOrder order.
4. A Description of the rule.

Rule Contexts:

1. AssignCableNoAssignBeforeEdit - executed during a new Cable Number Assignment or existing Cable
Number Edit before the dialog is shown.

2. AssignCableNoAssignAfterEdit - as above but after the user has clicked Save on the dialog or if Verbose
Cable No Assignment = false then during the Cable save process.

3. AssignSysNameAssignBeforeEdit - executed during a new SysName Assignment or existing SysName Edit
before the dialog is shown.

4. AssignSysNameAssidnAfterEdit - as above but after the user has clicked Save on the dialog or if Verbose
SysName Assignment = false then during the SysName save process.

Related Topics:
Project Rules
Rule Syntax

192

193
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4.3.4 Report Forms

The forms in this section are specific to the Reporting Engine.

4.3.4.1 Print Preview

Visible only when the active environment is a report.

Explanation

This is the default view that loads when a report is loaded. From here you can determine the number of pages to
print and to which device. 

Form Options

· Save -  Save the rendered document to the native print document format (.prnx). NOTE: this is the rendered
document not the report design. The report design can only be saved from the Report Designer tab.

The remainder of the controls are obvious.
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4.3.4.2 HTML View

Visible only when the active environment is a report.

Explanation

This is the report rendered to html. The controls are self-explanatory.
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4.3.4.3 Report Designer

Visible only when the active environment is a report.

Explanation

Here we design the report. The menus are obvious so we won't bother. What may not be obvious the Banded
Report design and the Smart Tag. Smart Tags will be displayed on entities that are selected (if available) like so:
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Smart tags can be expanded to show entity specify settings. Here we see properties specific to the Detail Band:

Related Topics:
 A discussion on report design can be found here .143
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4.3.4.4 Toolbox

Visible only when the Report Designer Tab is active.

Any of these tools can be added to the report under design.

Controls

· Pointer - Stop drawing  and revert the mouse to a Selection tool.
· Label - The most common tool. Can be used to display static text or if the text is held in square braces[]. For

example: a label with the caption S:[SRCSys]>[SRCPin] will render S:SomeSrcSys>SomeSrcPin once for every
record in the collection.

· Check Box - A Check Box is used to display True/False or Checked/Unchecked/Indeterminate values in a
report.

· Rich Text - The Rich Text control allows you to display formatted text in your report. It can represent static or
dynamic text, or both. In addition to the capability to embed plain text into your report (using the Label control),
you may need to display RTF or HTML content as well. WireCAD does not use RTF or HTML natively but there
is no reason you could not put formatted text in a user field.

· Picture Box - Picture Box is used to embed static (stored along with the report definition) or dynamic (obtained
from a data source) images into a report. It can display images of various file formats: BMP, JPG, JPEG, GIF,
TIF, TIFF, PNG, ICO, DIB, RLE, JPE, JFIF, EMF, WMF.

· Panel - The Panel control is a container that frames separate report controls to allow them to be easily moved,
copied and pasted, and visually unites them in the report preview (with borders or a uniform color background).

· Table - The Table is used to display tabular information in a report. Note: Table reports should not be confused
with hierarchical master-detail reports or cross-tab reports. You can create two tables simultaneously, e.g., one
for showing column titles in the Page Header, and the other for showing regular information in the Detail band.

· Line - The Line control draws a line of a specified direction, style, width and color. It can be used for both
decoration and visual separation of a report's sections. Note that the Line cannot cross bands.
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· Shape - The reporting engine provides you with the capability to embed shapes into your reports. You can
simply add any Shape control to a report, choose one of the available shape types, and then print or export this
report. The following shapes are available:

Arrow
Brace
Bracket
Cross
Ellipse
Line
Polygon
Rectangle
Star

· Bar Code - A Bar Code object. The supported bar code types are:

1D Barcode Types 2D Barcode Types

Codabar ECC200 - Data Matrix

Code 11 (USD-8) GS1- Data Matrix

Code 39 (USD-3) Intelligent Mail

Code 39 Extended PDF417

Code 93 QR Code

Code 93 Extended

Code 128

EAN 8

EAN 13

GS1-128 - EAN-128 (UCC)

GS1 - DataBar

Industrial 2 of 5

Interleaved 2 of 5

Matrix 2 of 5

MSI - Plessey

PostNet

UPC Shipping Container

Symbol (ITF-14)

UPC Supplemental 2

UPC Supplemental 5

UPC-A

UPC-E0

UPC-E1
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· Zip Code - The Zip Code control transforms its content into a zip code. To specify the text for the control, use
the ZipCode. Text property. Note that the Zip Code control can only display numeric characters and dashes.
Other characters are displayed as empty zip boxes.

· Chart - The Chart control visualizes the series of points using the available 2D chart types or 3D chart types.
The chart type is defined via the View property of a series. And, a single chart can display multiple series, if their
view types are compatible. A Chart contains multiple visual elements (diagram, axes, titles, labels, strips,
constant lines, etc.) and, when any of these elements is selected, its properties are shown in the Property
Grid.

· Gauge - The Gauge control provides you with the capability to embed graphical gauges into your report.
· Sparkline - The Sparkline control displays a compact chart that is commonly used to reflect the flow of data

for every row in a report.
· Pivot Grid - The Pivot Grid allows you to create a pivot table, an Excel-inspired data visualization application

for multi-dimensional data analysis. Using the Pivot Grid, large amounts of data can be summarized and
represented in a cross-tabular format that can be sorted and filtered. Also, since the Pivot Grid provides
customization you can freely change the layout of the report based on your analysis requirements, using simple
drag-and-drop operations. It also supports drill-down (to view the underlying data for calculated cells).

· Sub-Report - The Sub-Report control is used to embed reports into each other; this allows you to create
Master/Detail reports (reports with hierarchically linked data).

· Table of Contents - The Table of Contents control allows you to provide your report with a table of contents
that reflects the hierarchical structure of the report bookmarks.

· Page Info - The Page Info is used to display auxiliary information on report pages, such as date, time, page
numbers or user name.

· Page Break - The Page Break control's sole purpose is to insert a page delimiter at any point within a report.
This control is visually represented by a short line, attached to the report's left margin. The Page Break control
is useful when you need to insert a page break between controls within a report band - for example, to divide
subreports, so that the second subreport starts printing on a new page. You can also insert a Page Break
before or after a specific report band using the Band.PageBreak property.

· Cross-band Line, Cross-band Box - Cross-band controls are used to draw lines and rectangles through several
bands, as opposed to Line and Shape controls that can be used only within a single band. The following two
cross-band controls are available:

Cross-band Line allows for the drawing of vertical lines, which are not restricted to a particular band. For
example, it can be used to emphasize a report section consisting of multiple band areas.

Cross-band Box allows for the drawing of rectangles through several bands. It can be used to encompass
a report section consisting of multiple band areas.
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4.3.4.5 Cable Data Selector

Visible only when the active environment is a report.

Explanation

This tool allows you to pick and choose which cable records to print without having to create a complex filter.
Simply select the records to print in the Select This field and set the number of copies to print then click the 
[Apply] button.

Controls

· Reload - Reloads the data. All current selections are cleared then the data is reloaded from the Cables table.
· Clear All - Uncheck all.
· Select All - Check all.
· Copies - Number of copies to print.
· Pad with Empty Records - Useful when trying to use a label on a sheet of labels that has already had some

use.
· Apply - Do it!
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4.3.4.6 Bil l  of Materials Generator

Reports > Generate Bill of Materials
Commandline: bom

Explanation

Before a Bill of Materials (BOM) report can display data, that data must first be generated. We generate Bill of
Materials data with a Snapshot Name. The report that you run will group by Snapshot Name.

You can choose which items to count in the BOM and refine your counts by creating filters.

One of the most common misunderstandings with the BOM generator is how it deals with cable lengths. The
generator sums all lengths of a given Cable Type. But what if you have specified a pre made cable of 2 meter
length? In this case we don't want to total the length but rather the quantity. To handle pre-made cables take the
following steps:
1. Create a new Cable Type  with the cable length in the name. For example: an off the shelf 2 meter HDMI

cable might be named: OTS HDMI 2m. This will show up in the Cable Type field of the Cables table and
further in your BOM.

2. When entering the cable Length for pre made cables enter the Length as 1. 

In the BOM you will then see a count of your OTS HDMI 2m cables.

Prerequisites
1. You will need an active project with SysNames and Cable data.

Related Topics:
Grid Basics

484

24
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Form Options

· Snapshot Name - Name is something unique that you will remember. Preset by the Default BOM Snapshot
Name in the Project Settings panel.

· Include Equipment, Include Cable Types, Include Connector Types - What to include.
· Filter Equipment - Apply a filter to the set. Click the [...]
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4.3.5 PDF Viewer

Visible only when the active environment is a pdf document.

Explanation

This is the built in PDF viewer. Any pdf file placed in the project\Drawings\ folder tree can easily be previewed by
double-clicking it in the Project Explorer.

Controls

· Open PDF - Open another pdf.
· Print - Shows the PDF preview dialog.
· Page Navigation
· Find - Shows the find text panel.

4.3.6 Plugins Forms

The following sections relate to plugins that register forms for editing. These are plugins included with WireCAD.
Other plugins may register forms that do not appear here. 

513
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4.3.6.1 Translation Manager

Explanation

All visible text strings in WireCAD are contained in dictionary that is editable via the Translation Manager. The
current UI culture is queried for a string. If not found the English (en) version is returned.
You can right-click a column header and select the KeyString column to show the base en string that the program
searches from.

NOTE: Some forms and dialogs only get their text strings on program start so changes here will not be visible to
all areas of the application until you restart WireCAD.

Possible Uses
1. Translate WireCAD into a different language.
2. Change user column names and labels in the application to aid your process.

See Also
How to Translate a Form Caption

Form Options

· Current Culture is - The culture of your machine. If no translation exists, WireCAD defaults to the en (English)
language.

· Select Language To Translate - Selects the language to edit in the right-hand column.
· Show Context - Select to display a column showing the primary context in which the string or message

appears.

169
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4.3.7 Map Tool

WireCAD Enterprise provides a world map tool.

Explanation

The Map tool within WireCAD can be used to associate your Locations table entries to specific GPS coordinates. 
Once the Locations table entries have been associated with corresponding GPS coordinates we can automatically
place:
· Location Markers
· Panel Markers
· Backbone Markers

To associate the Location records with specific points on the map use the Tools > ID GPS Locations  tool.514
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4.4 Tool Panels

Tool Panels differ from Forms and Dialogs in that they are windows that can be docked to the edges of the main
application window.

Tool panels are used to present logical groups of controls. Tool panels can be shown/hidden from the View>Tool
Panels>Pane Name menu. 

Tool panels can be docked together or undocked. To Undock a tool panel drag its tab page. As you move near a
docking target a hint will be shown. Tool Panels will dock based on the hint you click.
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4.4.1 Project Explorer

View > Tool Panels > Project Explorer
Commandline: none

Explanation

This is the main access point to the project. From here you can:
· Open global database grids.
· Open drawing(s).
· Open Project Database grids.
· Open the Map Tool. (ENT only).
· Rename drawings.

Related Topics:
New Project
Show Report Mode

Prerequisites
In order to see project related information you will first have to open a project.

Tool Panel Options

Open Project Folder - Show the current project folder in a windows folder browser.
Project Properties - Show the Project Info  form.
Refresh - Refresh the Project Explorer.
Equipment Library - Show the Equipment Library .

47

364
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420
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4.4.2 Draw Cables

View > Tool Panels > Draw Cables
Commandline: none

Explanation

The Draw Cables tool panel is only active when the current environment is a drawing. This tool allows you draw
several different types of cables:
· One-to-One  - One output to one input.
· One-to-Many  - One outputs to many inputs.
· Many-to-One  - Many outputs to one input.
· Many-to-Many  - Many outputs to many inputs.
· Terminal to Point  - Drag a Terminal into the drawing and drop it on a connection point in the drawing. This will

place the terminal on the left hand side of the block.
· Point to Terminal - Drag a Terminal into the drawing and drop it on a connection point in the drawing. This will

place the terminal on the right hand side of the block.
· Working with Pointers .

Prerequisites
Requires and open drawing.

Related Topics:
Draw Cables

54
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4.4.3 Drawing Properties

View > Tool Panels > Drawing Properties
Commandline: none

Explanation

Provides access to the drawing properties. If no selection set exists in the drawing the general document
properties are presented. If a selection exists then the common properties of all items in the selection set are
displayed for edit. You may also select a single item from the selection set and edit all of its properties.

Prerequisites
An open drawing.

Related Topics:
None
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Tool Panel Options

· Selected Object - This combo box displays the selected object and allows you to select individual items from
the drop down.

· Property grid - The properties displayed here will all have property editors that are specific to the entity type.
· Sort/Group/Display Descriptions/Search toolbar buttons
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4.4.4 Find

View > Tool Panels > Find and Replace
Commandline: none

Explanation

Find and replace text found in any drawing and in editable fields of the project databases. The found list will tell you
the context in which the searched text appears.

NOTE: found text may occur in an invisible attribute. 

Changing a port name on a device using the Find and Replace tool requires that you change the text in the
following contexts:
· The visible attribute.
· The invisible CP_IN or CP_OUT attribute string. This is a pipe delimited string that contains the name|conn|type.

You must change the name portion of this.
· Any records that exist in the Project Cables table that reference that port.

Prerequisites
An active project

Related Topics:
None
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Tool Panel Options

· Find - The text to search for.
· [X] - Clear the Find text.
· Search Active Drawing - Only look in the active drawing.
· Search All Project Drawings - Search every project drawing.
· Show File - Show file name if any of the context in which the item is found.
· Show Item Type - Is it a text entity in a drawing or a field in a database.
· Results -  

· [Select All] - Selects all items in the results window.
· [Clear Selection] - De-selects all items in the results window.
· Replace With - The text to replace the found text with.
· [Replace Selected] - Initiate the replacement.
· [Cancel] - Cancels the current search.
· [Find] - Initiate the search.
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4.4.5 Plan View

View > Tool Panels > Plan View
Commandline: none

Explanation

This tool panel provides three tabs. Each tab houses a gallery of Plan View blocks. The tabs are:
· All Plan View Files - Enumerates the %BLOCKS%\Plan View Files\ folder tree presenting a preview of each

dwg file. Each sub folder will be added as a gallery group and items in that folder added to the group.
· Project Plan View Items - Provides a gallery item for each SysName in the Equipment List. If the SysName's

equipment definition has an empty Plan View File, the project Default Plan View File is presented.
· Equipment Library Plan View Files - Shows all Equipment Library items that have data in the Plan View

File field. 

Prerequisites
An open project.
An open drawing.

Tool Panel Options

· Place with Rotation and Scale - If checked then when placing the selected item in the drawing you will be
prompted to scale the X, Y, Z and set the Rotation angle.

· Plan View Galleries - Click an item to add it to the drawing. Then place (and scale/rotate).
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4.4.6 Favorites

View > Tool Panels > Favorites
Commandline: none

Explanation

Often times we find ourselves creating the same block or circuit configuration over and over. These times are a
great candidate for a Favorite. Creating a Favorite stores the item(s) as a block in the OS in one of three places:
· Global - Saves in the %BLOCKS%\Favorites path and may be visible to other user with the same support path.
· User - Saves to your user profile. Visible only to you.
· Project - Saves in the Project\Favorites folder for use by anyone with access to the project.

Prerequisites
A drawing with the block or configuration you want to save as a Favorite.
A drawing into which you wish to place a Favorite.

Tool Panel Options

· Explode - If you have grouped a system together that includes multiple blocks and cables into a single block. It
will need to be exploded back one level to expose the individual WireCAD objects.

· Scale
· List - Double-click to add to the current drawing.
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4.4.7 Command Line

View > Tool Panels > Command Line
Commandline: none

Explanation

The Command Line interface to the application. Here you can view a history of commands and enter commands
directly. All commands entered must be executed by clicking the [Enter] key.

Prerequisites
None

Related Topics:
My Space Bar is my Enter Key

Dialog Options

· Command History - What went before.
· Command Prompt - What the application is expecting of you. If no job is running or no input is expected from

you it will read: Command:

Otherwise it will prompt you for some action:

· Command Line - Enter the command here.
· Calculator

365



Writing Plugins



Writing Plugins 585

© 2017 Holbrook Enterprises, Inc. dba WireCAD

5 Writing Plugins

INTRODUCTION

The examples can be found at:
C:\users\public\documents\WireCAD\WireCAD9\WireCAD SDK\Examples

Welcome to the WireCAD SDK examples. These examples show you how to 
interact, via your own code, with WireCAD. These examples assume that
you understand the basics of C# programming syntax and structure 
(the examples are in C# but you may use any .NET programming language
that you are comfortable with). 
If you do not understand it don't let that deter you. It is really
very easy to understand. Microsoft has tons of examples. Just get on
the web. 

If you have WireCAD SDK specific questions email support@wirecad.com
along with as much code as you can and an explanation of what you are
trying to do. We will try to help. If you need more help or if you are
developing a commercial plugin for WireCAD you may want to consider
purchasing custom programming services from us.
Please call the office for more information.

Getting Started

You will want to download a .net ready integrated development environment(IDE)
like Visual Studio for c# or SharpDevelop. Visual Studio has free versions.
SharpDevelop is an open source.
We recommend the Visual Studio for the ability to attach a debugger to your 
running process. Also use the WireCADv9TemplateInstaller.vsix to install several
starter projects in Visual Studio that you can use from the File>New Project wizard.

The first place to go with any programming effort is the ubiquitous
"Hello World" example in the Basic folder.

NOTE: there are two types of WireCAD plugin. 
1. The automatically discovered (AD) plugin that loads silently 
and may or may not interact with the user.
2. Plugins that require a WireCAD .wpi manifest file that describes
where the plugin can be found, how to call it, what icon to display and on
which toolbar or menu, etc. Both plugins implement the WireCAD.IPlugin interface.

AD plugins are named YourPluginName.Plugin.Dll and are placed in the 
C:\users\public\documents\WireCAD\WireCAD9\\bin folder. 

Standard WireCAD plugins have no naming requirements
but must be accompanied by a .wpi file in the 
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C:\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins folder.

To create a wpi file you can use the utility in Plugins>Plugin Manager [New PI Info]  

Take some time to read through the code. The interface is very simple,
yet you can access most of the WireCAD object model including drawing,
data access, grids, GUI, reports, etc.

You can also create your own forms and functions to interact with the
WireCAD objects.

THIRD PARTY LIBRARIES

WIRECAD USES THIRD PARTY LIBRARIES THAT MAY REQUIRE YOU TO PURCHASE DEVELOPER
COPIES. PLEASE DO NOT IGNORE THIS STATEMENT. THESE ARE GREAT LIBRARIES AND
IF YOU ARE PLANNING TO DEVELOP A COMMERCIAL PLUGIN FOR WIRECAD YOU WILL WANT
TO HAVE THEM. If you are developing a small project or line of business function
for your own use you may not need to purchase licenses. Here is an example:
If you want your plugin to have the same look and feel, or create a custom form
with the same gridview or treeview as WireCAD you will need
to purchase the Developer Express library. If you are developing a custom form
that needs to show its own drawing engine you will need to purchase the
VectorDraw developer framework. If, on the other hand, you are able to use
the WireCAD baseforms object, are happy with the WinForms controls and can
develop using the WireCAD drawing engine then you can get started without
spending a dime.  

BUILDING YOUR FIRST PLUGIN

STEPS:
1. Open your IDE
2. Click File>Open Project or Solution and browse to the basic hello world.csproj 

project file in the examples\basic\hello world folder
3. Click Build>Build Solution (Ctrl+Shft+B) to build the project.
4. Check that the file C:\Users\Public\Documents\WireCAD\WireCAD9\bin\helloworld.plugin.dll 

exists. If it does not then you need to check the project build path in the project properties
section and point it to the WireCAD bin folder above.

If you get any reference errors check Project>Hello World Properties... [Reference Paths] section
points to C:\Users\Public\Documents\WireCAD\WireCAD9\bin\. If it does not then modify
it and make sure that your reference errors disappear.

5. You now need to force WireCAD to load the shiny new plugin. 
Either relaunch WireCAD (tedious) or click Plugins>Plugin Manager ... then 
click the [Rescan and Reload All Plugins] button. Make sure that the helloworld.plugin 
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appears in the Auto Discovered Plugins list.
6. Now enter hw in the commandline and click [Enter]. This will launch the command that

the plugin registered in its Load() method.
7. Make some changes and click Build>Build Solution (Ctrl+Shft+B) to build the project again.

If your changes are outside the load() method you will not need to force a reload.
Just call the command again by typing hw in the commandline and click [Enter].

There you have it. You have just built your first WireCAD plugin. Now go forth and do more!

DEBUGGING YOUR PLUGIN

Invariably you will need to stop the execution of your plugin and examine the variables
and logic structure to figure out why it is not working as you expect.

The following instructions assume you are using the Visual Studio IDE for C#. Further, that
you have built your project and made sure it is loading in the WireCAD plugin framework by
looking at the loaded plugins list in Plugins>Plugin Manager...

NOTE: The following will work for anything other than the initial Load() method. To debug that
read on.

Steps:
1. Open your project in the Visual Studio IDE.
2. Run WireCAD.
3. In VS click Debug>Attach to Process...
4. Select WireCAD9.exe.
5. Place a breakpoint in the code where you want to stop execution. Do this by clicking in the

gutter of the text editor(very left hand edge. A red dot will appear).
6. Execute your command. The debugger will pause at the line and highlight the paused line.

In the interface you will find two very helpful tool windows - Locals and Autos. These windows
list the variables in play at the time of the breakpoint. 

7. On the IDE Debug menu you will find commands to continue execution:
1. Continue - runs from the break point until it hits the next breakpoint if any.
2. Step Into - continues execution of the next line. If the next line calls another function

you will be stepped into that function.
3. Step Over - continues execution of the next line. If the next line calls another function

that function will execute in its entirety and you will step to the next line in the current
code block.

While you cannot edit and continue you will be able to understand the changes you need to make
to fix the issue you are having. 

8. Stop the debugger. Fix your code. Lather, rinse, repeat.

DEBUGGING THE LOAD() METHOD OF THE IPLUGINCORE INTERFACE
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The load method or the HasPermissionToRun methods of the IPluginCore interface require some
special consideration if we are to debug them. The reason for this is that the WireCAD loading
process will call these methods before we have a chance to attach the debugger to the process.

This section will outline two approaches:

1 - PAUSE EXECUTION USING MESSAGEBOX

Place a MessageBox.Show("Pause"); command in the Load or the HasPermissionToRun method. 
This modal dialog will pause execution for you to attach the debugger as shown above.
like this:
         /// <summary>

        /// This is called when the plugin is loaded at application start

        /// </summary>

        /// <param name="ws">Singleton WireCAD Workspace object</param>

        public void Load(IWorkspace ws)

        {

MessageBox.Show("Pausing plugin load so you can attach the debugger");

....... Your code here

        }
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2 - START WIRECAD IN THE DEBUGGER PROCESS

The other approach is to start WireCAD in the debugger from your project. While this seams like a 
good approach it suffers from a major drawback. When you want to fix your code you must stop the
debugging session. Since WireCAD is running in the same process it will stop as well. Thus requiring
you to start WireCAD every time you want to make a fix.

Steps:
1. Open your project in the IDE.
2. Close WireCAD.
3. Open the Project Properties window - Project>YourProjectName Properties...
4. Select the Debug section.
5. Select the Start External Program radio button.
6. Browse to the WireCAD9.exe at: C:\Users\Public\Documents\WireCAD\WireCAD9\bin\WireCAD9.exe
7. Place your breakpoint.
8. Click Debug>Start Debugging (F5).

This will start the debugging session by launching WireCAD first. As WireCAD loads it will eventually
come to your Load() method and hit your breakpoint.

When you are finished with your examination close WireCAD and let it shutdown. Ending the debugging
session with the Debug>Stop Debugging (Shift+F5) acts like Kill Process and will not allow WireCAD 
to store session state.

ADDITIONAL RESOURCES

C# is the language of choice for developing in WireCAD. There are tons of resources 
online to learn this language. 

For WireCAD specific issues:
www.wirecad.com/wiki
support@wirecad.com
Please don't submit support tickets for SDK issues. Use the support email.

Developer Express is the library we use for many of the UI elements. They have
a brilliant web site with documentation and support. If you are going to go
deep on WireCAD development you will probably want to purchase a license.
www.developerexpress.com

VectorDraw is the drawing engine we use. While their site is minimal they do offer
registered developers lots of sample code.
www.vdraw.com

for a full api listing visit:
for the main WireCAD9.exe:
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https://www.wirecad.com/api/90/exe/index.html

for the global data access layer:
http://www.wirecad.com/api/90/globaldal/index.html

for the project data access layer:
http://www.wirecad.com/api/90/projectdal/index.html
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5.1 Hello World

Every programming effort starts with the ubiquitous "Hello World" example. This example is meant to provide just
enough information to show the framework and produce an output.

Please note that in C# comments are preceded by //.

//////////////////////////////////////////////////////////////////////

//WireCAD Plugin

//Contents:

// Basic WireCAD Plugin Framework

//

//Instructions:

// 1.This project assumes that you installed WireCAD in the default

// location. If you did not, you will need to change the reference

// path and the build path to that of your install path 

// ..\WireCADx\bin folder. You can do that byclicking:

// Application Menu > Project Options [Reference Paths]  Reference path

// Application Menu > Project Options [Compiling Tab] Output Path

// 3.Add your code and build

// 4.Create a wpi file (from within WireCAD click Plugins>Plugin Manager [New]) that points to your assembly and method and

// place it in the ..WireCADx\bin\plugins folder

//

//////////////////////////////////////////////////////////////////////

//Explanation:

//This heloworld example demonstrates a number of different WireCAD SDK

//concepts. This is WireCAD Automatically Discovered (AD) plugin and

//therefore does not require a .wpi file in the /plugins folder. As such,

//it will load silently and can only be executed from the commandline since

//it does not add any other GUI elements.

//

//TESTING:

//First familiarize yourself with the code below and try to understand

//what will happen before testing.

//1. Build the project and ensure that the helloworld.plugin.dll is located

// in the ..WireCADx\bin folder.

//2. if WireCAD is running click Plugins>Plugin Manager[Rescan and Load Plugins]

//3. Type hw into the WireCAD commandline.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows.Forms;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdObjects;

using WireCAD;

using WireCAD.Interfaces;

using WireCAD.Translation;

namespace hello_world

{

    public class MyPlugin: IPluginCore
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    {

        #region Fields

//Place your field level variables here

       CommandInfo ci = null;

        #endregion

#region Properties

//Place your Properties Here

       

        #endregion

        #region IPluginCore Members

        /// <summary>

        /// Called before plugin is loaded to make sure that this plugin

        /// has permission to run at this application mode level and

        /// for this person(Identity)

        /// </summary>

        /// <param name="ws">The Singleton Workspace object</param>

        /// <param name="id">Current user identity</param>

        /// <returns>should return true if the plug can load</returns>

        public bool HasPermissionToRun(IWorkspace ws, Identity id)

        {

            return true;

        }

        /// <summary>

        /// This is called when the plugin is loaded at application start

        /// </summary>

        /// <param name="ws">Singleton WireCAD Workspace object</param>

        public void Load(IWorkspace ws)

        {

        //We pass an IWorkspace object exposing most if the WireCAD

        //object model

        

        

            //on load we will register a commandInfo object with our

            //commands so that our static method can be invoked from 

            //the command line in WireCAD

            ci = new CommandInfo();

            //The name of our dll

            ci.Assembly = "helloworld.plugin.dll";

            //The NameSpace and Class of our function

            ci.NameSpaceAndClass = "hello_world.MyPlugin";

            //Our function's name

            ci.MethodName = "HelloWorld";

            //The long descriptive name of our function

            ci.CommandLongName = "Hello World Demo";

            //An alternative name for our function. You can type this text into the WireCAD command line

            //to call the function

            ci.CommandAlt = "hello";

 //The shortcut 

            ci.ShortCut = "hw";

            //this registers the command so that the commandline knows how to parse the information

            //and call our function

            ws.Commands.RegisterCommand(ci);
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        }

        /// <summary>

        /// Unload code for your plugin

        /// </summary>

        /// <param name="ws"></param>

        public void Unload(IWorkspace ws)

        {

            //here we place any code to unload our plugin.

            

            //Unregistering the commandInfo prohibits the command from

            //being persisted. This is more a development function.

            //once you are ready to distribute your plugin you will

            //probably want your user to be able to save his own shortcuts

            //and therefore not unregister the command.

            ws.Commands.UnRegisterCommand(ci);

        }

        #endregion

#region Static Methods

        /// <summary>

        /// Static method that can be called from the WireCAD command line

/// It's a good idea to rename this to something meaningful

        /// </summary>

        /// <param name="ws">WireCAD is expecting to find this parameter</param>

        public static void HelloWorld(Workspace ws)

        {

           //This hello world function demostrates a number of different 

           //areas of the WireCAD SDK

           

           //this is a winForms messagebox

           MessageBox.Show("Hello World");

           

           //now we'll show an instance of form1(defined elsewhere in this project);

           Form1 f = new Form1();

           f.ShowDialog();

           

           //now let's send a message to the Command Line History

           ws.MainForm.CommandLine.AppendHistory("Hello World");

           

           //let's check to make sure that we have an open drawing

           if(!Commands.IsActiveDrawing(ws,true))

           {

           //no active drawing so return

           return;

           }

           

           //Get some user input on the next step

           if(DialogResult.No == MessageBox.Show(

           "Would you like us to add some text to the active drawing?",

           "WireCAD SDK",MessageBoxButtons.YesNo)) return;

           

           //First we create a vdText object

           vdText text = new vdText();

           //register it with the active document

           text.SetUnRegisterDocument(ws.ActiveDrawing);

           //give it the document defaults
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           text.setDocumentDefaults();

           //Set the string

           text.TextString = "hello world";

           //locate it in the coordinate space

           text.InsertionPoint = new VectorDraw.Geometry.gPoint(0,0,0);

           //Set the textHeight

           text.Height = .25;

           //Set the color

           vdColor colorRed = new vdColor();

           colorRed.SetUnRegisterDocument(ws.ActiveDrawing);

           colorRed.Palette = ws.ActiveDrawing.Palette;

           colorRed.FromRGB(255,0,0);

           

           text.PenColor = colorRed;

           

           //alternately you could do this

           //text.PenColor.ColorIndex = 1;

           

           

           //our text will be added to the drawing on the ActiveLayer and with 

           //the ActiveTextStyle if you want to change those you can by setting

           //those properties on the text object

           

           ws.ActiveDrawing.ActiveLayOut.Entities.AddItem(text);

           

           //now refresh the drawing

           ws.ActiveDrawing.Redraw(true);

     //alternately you can just invalidate the text object(less expensive)

     //like this:

     //text.Invalidate();

        }

#endregion

    }

}
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5.2 Getting Started

The following assumes that you have installed either Visual Studio 2013 or 2015.
Run the WireCADv9ProjectTemplate.vsix template installer from C:
\Users\Public\Documents\WireCAD\WireCAD9\WireCAD SDK\Visual Studio Templates
Installer\WireCADv9ProjectTemplatesInstaller.vsix.
Launch Visual Studio

Study the examples by loading the All Project solution:
C:\Users\Public\Documents\WireCAD\WireCAD9\WireCAD SDK\Examples\All Projects.sln

When you want to create a new project to start your own plugin follow these steps:

Your First Plugin Project

1. Click File>New Project

2. Select one of the C# WireCAD Project Templates
3. Name it something meaningful.
4. Click [OK] and a new solution will be created for you with all the necessary references and interface files.
5. Now start coding!
6. Click F5 to build your project and make sure that it builds and copies to c:

\users\public\documents\WireCAD\WireCAD9\bin\YourPluginName.dll. If it does not build check to make sure
that the Project Properties - Reference Paths section has a pointer to the above path.

7. If you are using a wpi file make sure that it is edited to point it to your dll and method and that you have copied
it to  c:\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins folder. Relaunch WireCAD or click
[Rescan and Reload] from the WireCAD Plugin Manager to make WireCAD load your plugin.



WireCAD v9.1 User Manual596

© 2017 Holbrook Enterprises, Inc. dba WireCAD

5.3 Registering Your Plugin

Menu: Plugins>Plugin Manager[Add/Edit PI Info]
Default command line shortcut: none

Assuming your plugin requires user input to launch it, ie. it does not respond to an event. You will want to register
your command with the application.
WireCAD uses an information file (wpi - WireCAD Plugin Info) to describe a command and to tell the application
how to execute the command.
WireCAD looks for these files in the c:\users\public\documents\WireCAD\WireCAD9\plugins\Active Plugins
Commands can be executed directly from the Commandline or from a button on a menu bar. 
In order to register your command you must, at minimum, set up the Commandline arguments. Toolbar buttons are
optional. To edit a wpi file use the editor.



Writing Plugins 597

© 2017 Holbrook Enterprises, Inc. dba WireCAD

Controls

· Name, Description, Author, Website, Copyright - Self explanatory.

Button Info

· Tool Tip - Text displayed when mouse hovers over the button.
· Caption - The button caption.
· Ribbon Page - Select a page or create your own.
· Ribbon Page Group - Select a page group or create your own.
· Button Bitmap - bitmap image. 16x16 for a small button 32x32 for a large one.

Command Line and Assembly Info

· Long Name - The display name of your command.
· Short Name - The shortcut.
· Alt - Shorter less descriptive.
· Assembly Name - The name and fully qualified path of your dll. If no path we will search the \WireCADx\bin

directory.
· Namespace Dot Class - YourNameSpace.YourClass where your function is located.
· Static Method Name - The static void method name of your function. This must have the proper signature as

follows:

public static void YourFunctionName(WorkSpace ws)

{

.....

}

Using the above example the Static Method Name would be: YourFunctionName

NOTE: if you use the WireCAD Plugin template  a static method with the proper signature will be created for
you. You will need to rename it to be something meaningful.

595
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The following index is generated from the online text and as
such the page numbers may represent a sub chapter
heading instead of the actual page.

The key word you are searching for will be in the sub
chapter.

A Note About the Index
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