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Foreword
The manual is not an exhaustive study of WireCAD, but rather enough
information to build a foundation upon. We maintain a wiki site with this and
much more information. You can access up-to-the-minute documentation
along with revision and hotfix information online at www.wirecad.com/wiki.
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1 Introduction

Welcome to WireCAD. WireCAD tools aim to decrease the frustration associated with creating accurate, detailed

documentation. WireCAD produces DWG compatible drawings accompanied by either VISTADB or SQL Server

databases containing all pertinent project data. WireCAD is a cable management and facility design tool that

allows you to easily create AutoCAD™ drawings. WireCAD maintains a database of equipment, from which you

can create equipment blocks for your drawings. Equipment blocks are created dynamically from information stored

in the equipment database. Rather than maintaining a large library of equipment blocks or symbols, WireCAD

stores this information in a database and then creates blocks from the equipment definitions contained therein. 

Equipment definitions are easily added to the database. In addition to equipment databases, WireCAD also

provides drawing tools to rapidly create documentation, and database management tools to track:

Projects

Drawings

Revisions

Cable Types

Signal Types

Connectors

Things really start to fly when it is time to assign System Names (unique IDs) and Cable Numbers to the

equipment in your drawing. All you do is double-click on the equipment pieces in the drawing to assign them a

system name. Then double-click on the cable and assign it a cable number. All of the information regarding the

selected cable is extracted from the drawing and placed in the project cables database and the drawing is updated

with a new cable number.

Extensive reporting is available for the project databases including:

Cable run sheets

Cable labels

Project drawings

Equipment lists

Bill of Materials

Power consumption and heat load

In addition, a powerful report designer is included with WireCAD for creating your own reports and labels, or

modifying existing report definition files.
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Contents

New in 8

Software Activation

License Agreement

Licensing FAQ

1.1 New in Version 8

The short list of feature additions and changes in the current release:

Headlines:

Plan view tools

Cloud storage

Faster drawing engine

Faster data access

Support for Splice Points and Adapters

New Features

4

13

23

23
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Ribbon interface.

We have enhanced

the user

experience with

the addition of the

ribbon menu and

gallery controls.

Support for DWG

2015.

We now support dwg 2000-2015

Groups in

drawings. 

Now you can group ungroup entities.

Nudge position

command. 

Use the Up/Down/Left/Right arrows to move entities in the drawing.

Built-in PDF viewer.

Now pdf files are

enumerated in the

project drawings

folder. Double-

clicking them now

invokes the built-in

pdf viewer.
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Better docking. You

can now tear away

a drawing or any

other window and

place it on your

other monitor.

Splice Points We have added support for Splice Points. Splice Points are a means by which to

terminate cables. Splice Points are not tracked in the Equipment List. 
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Adapters Adapters are placed directly on functional block ports and inherit the port name and

SysName from the device on which they are placed.

Details

We have modified the project database to store the drawing file as binary data in the database and to sync with

files on difference machines.

We have modified the drawings table to work with relative paths in support of the previous item.

We have added plan view fields to the Equipment Library.
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1.2 Conventions and Terminology

This manual attempts to follow these conventions. We use the word attempts because we are human and

therefore fallible.

Topic Header

Menu: Databases>Projects

Default command line shortcut: None
Function:

A description of the function goes here.

Applies To:

All product levels

Related Settings:

None

Chapter Heading

Menu: Databases>Projects
Default command line shortcut: None

Function:

A description of the function goes here.

Noteworthy Changes

Items or functions that are significantly different from previous versions will be flagged with this symbol

Normal Paragraph Text

Normal paragraph text appears like this.
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Text You Must Type or Enter

In the event that you are required to enter text the instruction will be formatted as follows:

Please enter the path to the project in the textbox.

 

How To Topics

How to do something
1 You must do something..

2. Then something else.

 

 

Notes

Please Note: Notes will look like this.

 

Text That Identifies or Explains a Graphic

This is the Command Line Interface

 

Button Presses

When you are Instructed to press a button and the button graphic is
not shown the text will be formatted as in the following example:

Press the [Start Cable] button to continue.
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Menu Button Presses

Menu button presses will be formatted using the > symbol to indicate subsequent menu levels. If you are

required to select a specific function or tab the ~ character will be used to indicate a selection to make once the

form, dialog, or function executes.

Example: Click Tools>Inserts>Insert... ~ <OK> Then follow the directions...

 

Field Names or Other Program Labels

Field Names and Labels.

 

Warnings

In the event that we feel something is important or could possibly damage a project or drawing we will issue

warnings as follows:

Please do not press this [button]. Bad things will happen!

Tips

Tips are displayed as follows:

Try pressing this [button]. It might be good!
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What we Call Things

Item Image

Button

Text Box, textbox, text
edit or entry field.

Combo box or

dropdown:  Clicking
the arrow on the
right will drop a
scrollable list.

Tabs or tab

collection:  When

prompted to select a
tab the caption text
will appear as follows:

Select the Find
Equipment tab.

Property List:

Information about the
active property is
displayed at the
bottom of the list.
Highlighting a
property causes it to
enter edit mode. You
can then enter data in
the field on the right.

Please Note: the
field on the right-
hand side of the
property list may be
referred to as a
textbox, combo or
dropdown
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depending on its
type and function.

Ellipsis button:
Pressing this button
in what ever the
current context will
bring up a context
sensitive dialog.

Checkbox

Listbox
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1.3 Software Activation

WireCAD v8 offers 4 program levels:

XL FREE, XLT, PRO, and ENTerprise.  XLT,  PRO and ENTerprise require authorization keys in order to activate

that level of the software. An activation key is all that is required to change program levels. If you have questions

about the licensing scheme click here .

Floating Licenses

Floating License Leases

How To

Troubleshooting Activation

23

14

14

15

17



WireCAD v8 User Manual14

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Activation

Integral to WireCAD is

the ability to have a

single authorization key

activate multiple

concurrent machines if

your organization has

paid for more than one

seat. By default, when

you purchase a seat of

WireCAD your license

count for your key will

be set to 1 (one). 

operational.

This will allow 1 (one) machine to be active at a time. You may install WireCAD on any number of

machines throughout your organization; However, only one (or your license count) machine will be active at

any given time.

Floating License Lease
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Activation

The mechanism by

which we float licenses

is the license lease.

Leases have expiration

periods of 24, 48, 72,

168 hours and Never.

During the activation of

your software you will

be prompted to pick a

lease period. The lease

period is period during

which the software will

run while being

disconnected from the

web. When you

activate the software

you are prompted for a

lease length. 

Once activated the application will run for the lease period. If you close the application while connected to the

internet you will expire the lease; thus making it available to another machine. Upon application startup the

license is validated and a lease is acquired automatically if web connected. If you cannot connect to the web

you will need to phone WireCAD support at:

1 661.253.4370 international.

1 866.273.5298 US and Canada toll free.

How To: Activate WireCAD
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Activation

Enter your

authorization key (it's

the really long one that

ends in 70. If you fail to

enter the key correctly

you will not be able to

proceed.

If you are web

connected click the 

[Register By Web]

button. If everything

goes well you will see

this message in the 

Status window.

If you are not web

connected you will

need to call us at:

1 661.253.4370

international.

1 866.273.5298 US and

Canada toll free.

Click the [Register by

Phone] button.
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Activation

You will be prompted

by the WireCAD

technician to set 

Lease Period to

Never.

The WireCAD

technician will ask for

your authorization key

(it's the long one) and

your Machine ID.
Yours will be different

The WireCAD

technician will then

read a series of

numbers to you. Enter

these in the Register

by Phone text box.

Next click the 

[Continue] button. You

will receive a message

box indicating the

success of the

activation.

Troubleshooting Activation
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Activation

The following are a few reasons your activation by web will fail:

1. Not connected

2. Lease already in use by another machine

3. Authorization key abuse

4. Authorization key not found in the database

5. Your machine Date/Time is more than twenty four hours out of sync with our web server (UTC).

If you wish to avoid the floating license scheme simply select Never as the lease length during

activation. You will then lock the authorization key to that machine.
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1.4 License Agreement

License Agreement 

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE OPENING 

THIS PACKAGE AND/OR BY USING THE SOFTWARE. OPENING THIS PACKAGE OR USING THE 

SOFTWARE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO 

NOT AGREE WITH THEM, YOU SHOULD PROMPTLY RETURN THE PACKAGE TO THE LOCATION 

WHERE YOU PURCHASED THE SOFTWARE, UNOPENED WITH PROOF OF PURCHASE, 

AND YOUR MONEY WILL BE REFUNDED. 

 

Holbrook Enterprises, Inc. provides this program and licenses its use. 

Holbrook Enterprises, Inc. retains the ownership of this product.

 

LICENSE 

Permitted Uses/You May: 

* Use the software on any computer provided the software is used on only one 

computer and by one user at a time. 

* Copy the program into any machine readable or printed form for backup or 

modification purposes in support of your use of the program on a single 

machine. 

 

Prohibited Uses/You May not: 

* Make copies of the documentation or software, except as noted above. 

* Distribute, rent, sub-license, transfer, or lease the software or 

documentation. 

* Alter, modify or adapt the software or documentation, including, but not 

limited to, translating, decompiling, disassembling, or creating derivative 

works. 

 

This license and your right to use the software automatically terminate if 

you fail to comply with the provisions of this License Agreement. 

 

TERM 

The license is effective until terminated. You may terminate it at any other 
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time by destroying the program together with all copies, modifications and 

merged portions in any form. It will also terminate upon conditions set 

forth elsewhere in this Agreement or if you fail to comply with any term or 

condition of this Agreement. You agree upon such termination to destroy the 

program together with all copies, modifications and merged portions in any 

form. 

 

IF YOU TRANSFER POSSESSION OF ANY COPY, MODIFICATION OR MERGED PORTION OF 

THE PROGRAM TO ANOTHER PARTY, YOUR LICENSE IS AUTOMATICALLY TERMINATED. 

 

TRADE SECRET 

You acknowledge that the software constitutes valuable trade secret 

information that is the exclusive property of Holbrook Enterprises, Inc.. 

Automatic Updates

Holbrook Enterprises, Inc. may periodically check the web for updates. 

No personal information will be transferred. 

LIMITED WARRANTY 

Holbrook Enterprises, Inc. warrants for a period of 30 days from the date of 

original delivery to you that the program will substantially conform to the 

published specifications and to the documentation, provided that it is used 

on the computer hardware and with the operating system for which it was 

designed. Holbrook Enterprises, Inc. warrants the diskette(s) on which the 

program is furnished, to be free from defects in materials and workmanship 

under normal use for a period of ninety (90) days from the date of delivery 

to you as evidenced by a copy of your receipt. This warranty gives you

specific legal rights. You may have other rights that vary from state to state. 

 

DURING THE WARRANTY PERIOD, IF THE SOFTWARE DOES NOT PERFORM AS WARRANTED, 

YOUR EXCLUSIVE REMEDY SHALL BE TO SEND THE SOFTWARE TO HOLBROOK ENTERPRISES, INC. 

WHICH SHALL, AT ITS OPTION, EITHER REFUND TO YOU THE PRICE PAID OR REPAIR OR 

REPLACE THE SOFTWARE. 
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To the extent permitted by applicable law, Holbrook Enterprises, Inc. 

disclaims all other warranties, either or implied, including, buy not 

limited to, warranties of merchant ability and fitness for a particular 

purpose. Holbrook Enterprises, Inc. makes no warranty as to title. 

No Holbrook Enterprises, Inc. dealer, distributor, agent, or employee 

is authorized to make any modification or addition to this warranty. 

 

LIMITATION OF LIABILITY 

Because programs are inherently complex and may not be completely free of 

errors, you are advised to validate your work. TO THE EXTENT PERMITTED BY 

APPLICABLE LAW, IN NO EVENT WILL HOLBROOK ENTERPRISES, INC. OR ANY OF ITS 

PRINCIPALS OR AGENTS BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR 

CONSEQUENTIAL DAMAGES WHATSOEVER ARISING OUT OF THE USE OF OR INABILITY TO 

USE THE PROGRAM OR OCUMENTATION, even if advised of the possibility of such 

damages. Specifically, Holbrook Enterprises, Inc. is not responsible for any 

costs or damages including, but not limited to, those incurred as a result of 

lost profits or revenue, loss of use of the computer program, loss of data, 

the costs of recovering such programs or data, the cost of any substitute program, 

claims by third parties, or for other similar costs. IN NO CASE WHATSOEVER SHALL 

HOLBROOK ENTERPRISES, INC.'S LIABILITY EXCEED THE PRICE PAID FOR THE LICENSE TO 

USE THE SOFTWARE. 

 

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY 

FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION OR 

EXCLUSION MAY NOT APPLY TO YOU. 

 

Should you have any questions concerning this Agreement, you may contact 

Holbrook Enterprises, Inc. by writing to: 

Holbrook Enterprises, Inc. 

1112 6th Street South

Nampa, ID 83651

(866) 273-5298 US and Canada

(661) 253-4370 International

You acknowledge that you have read this agreement, understand it and agree to be 
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bound by its terms and conditions. You further agree that it is the complete and 

exclusive statement of the agreement between us which supersedes any proposal or 

prior agreement, oral or written, and any other communications between us relating 

to the subject matter of this agreement. 
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1.5 Licensing FAQ

The following are some frequently asked questions about the WireCAD licensing scheme.

Q: Does WireCAD support floating licenses

A: Yes, if you choose to use the function it is built in to both XLT, PRO and

ENT. You may disable this feature by selecting the Never expire option on the

License Lease Period dropdown at activation time. Choosing to do so limits

that Authorization Key to that machine only.

Q: How many machines can I install WireCAD on?

A: You may install WireCAD on any number of machines. You will only be able

to launch WireCAD on as many machines as your license count supports. The

default license count is 1. If you wish to purchase additional licenses you may

want to consult with your WireCAD sales professional who will help you

decide the best course of action.

Q: I have a laptop and a desktop WireCAD used to let me install on both. How come I have to choose?

A: You don't. WireCAD will still install on both. It will only run on one at a

time.

Q: What happens if my machine dies?

A: If your machine dies and you are using the floating license scheme, one of

two things will happen:

1. Install WireCAD on the new machine an wait for your lease to expire in

what ever lease expiration period you selected (not optimum, but

serviceable).

2. Call the WireCAD sales team. They can manually expire the lease for you.

You will need your authorization key and company name, as well as the

machine name of the machine that died.

Q: I am not connected to the internet very often, can I still use the floating license scheme?

A: We recommend that you use the floating license scheme only if you are

regularly connected to the web
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Q: I am going on-site. How to I ensure that my copy of WireCAD will stay active while I am disconnected from the

web?

A: If you are using the floating license scheme and you know that you will

need to be occasionally connected for a short period of time (one week or

less). Click Application Menu > Settings[Application Settings] set the Release

License on Shutdown to false. This will ensure that only your machine has the

license for up to the lease period. If you are not sure how long you will be

gone, follow this procedure:

1. Click Help>Control Software Activation.

2. Click [De-activate this Copy of WireCAD]. You need to be web connected.

Make sure that the server responds that the license has been successfully

released.

3. Set the License Lease Period dropdown to Never.

4. Click [Register by Web].

WireCAD will not require a web connection to start.

Q: What are the benefits of the Assurance Subscription?

A: A current Assurance subscription gives you the following premium

benefits : 

Free major and minor version upgrades and hotfixes. 

Priority technical support. 

New samples, tips and how-to topics from time-to-time.

Discounts on training. 

Access to beta products. 

Assurance Price Lock guarantees that your annual Assurance rate will not

increase year-to-year as long as you remain current.

Q: Does the license expire if the Assurance Subscription expires?

A: No. Your licence does not expire even if your Assurance expires. You can

use the products indefinitely even after the Assurance subscription expires.

Q: How long does my Assurance Subscription remain valid?
A:Your subscription duration is for 1 year from date of purchase or renewal.

Q: My Assurance Subscription is about to expire. What should I do?
A:You must renew your subscription to continue to receive the latest versions for free along
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with all the other benefits of the subscription. To renew your Assurance, contact sales@wirecad.
com.

Note that you may or may not receive notifications from Holbrook Enterprises, Inc. dba WireCAD about the
pending expiration of your subscription. It is your responsibility to renew your subscription when it is about to
expire. You can renew your subscription as early as you want or opt for a monthly credit card payment. 

Q: When can I renew my subscription? 
A:You must renew your subscription before the expiration of your current subscription You

can renew your subscription anytime before your current subscription has expired; you will not lose
any days as the new subscription will come into effect on the day your current subscription ends.
In effect, your current subscription will be extended by 1 year. 

If you do not renew your subscription before the expiry of your current

subscription, your subscription is considered as   lapsed and you will not be

eligible for free upgrades and other benefits anymore.

Q: My Assurance subscription has lapsed. How can I get the latest version? 
A:Maintaining your Assurance subscription and renewing your subscription each year to
keep it current is the best and the most cost-effective way to receive all new major and
minor versions as they are released. In case your subscription has lapsed and you want to
upgrade to the latest version you may simply renew your Assurance subscription at the

current rates. 

Q: Do you offer academic discounts? 
A: We do have academic discounts if WireCAD will be used for education/research

purposes. Please contact sales@wirecad.com for more information. 
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2.1.1 Setting Up Your Global Data

Menu: Several

Default command line shortcut: le

WireCAD maintains a global database with tables representing

Manufacturers, Equipment, Signal Types, Connectors, Etc. 

Getting started with WireCAD entails setting up the global databases to fit

your needs. While the database is populated with data you may find that it

suits your needs to purge the data and start fresh. If this is the case we can

provide empty databases. At the very least you will want to set up the

Signal Types grid with your defaults. 

Next you will customize the Equipment Library with the products and IO

that you use. In order to do this, you may either download existing products

from the WireCAD Community Server or enter your own .

Applies To:

All product levels

Related Settings:

None

Manufacturers - The topmost table in the heirarchy
Equipment - The Equipment description

Inputs - inputs of a device
Outputs - outputs of a device

Signal Types - signal types and a bunch of defaults.
Connectors - connector types.
Pinouts - pin out definitions (data).
Color Codes - color code lookup. Used by Cable Types.
Cable Types - cable type information.

Cable Cores - cores or conductor data for a cable type.

34
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Global Equipment Library Schema (abrv)
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How to Access the Equipment Library

Equipment Library Access

The Project Explorer

The Project Explorer allows access to some of the global data

grids.

You can also access all of the these grids from the Database

menu.

Database>Equipment Library Opens the Equipment Library where you will

do most of your work.

With an active drawing the Equipment Library can also be opened

from: Advanced Tools>Equipment Library

2.1.2 Equipment Library

Menu: Database>Equipment Library

Menu: Advanced Tools>Equipment Library

Default command line shortcut: LE

Applies To:

All product levels

Related Settings:

None
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The WireCAD Equipment Library is where you will spend a fair amount of

time as you get define equipment that you will use in your designs. This is

also where we come to create CAD blocks in our drawings. There are many

settings here that let you customize appearance. This chapter is the

basics.

Equipment Library

Find Tab

Find equipment

definitions in the global

database or the

Community Server.

Preview the block

before adding  to

drawing.

43
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Equipment Library

Detail Tab

Edit details. Associate

with external files.

IO Tab

Add , edit, select IO

to display in created

block.

37
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Equipment Library

Display Preferences

Controls the

appearance of the

created block.

2.1.3 Creating a New Equipment Definition

Menu: Database>Equipment Library[Add Equipment to Library]

Default command line shortcut: le
Create a new equipment definition from which to create functional blocks,

rack panels, etc.

Applies To:

All product levels

Related Settings:

None

How To: Add Equipment to the Library



WireCAD XL, XLT, PRO 35

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Add Equipment to Library

Click 

Database>Equipmen

t Library

Click [Add

Equipment to

Library]

Select or add a 

Manufacturer.

Enter model/pn/

name, description,

etc. 

Click [Next >]

There is always some confusion about the SysName Prefix (Equipment Type) field. Consider
the following: 
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Add Equipment to Library

We have two types of video server -model A and model B - that use similar wiring. We may

consider using the SysName Prefix - SRVR. Anytime we create an instance of one of these

we they will be SRVR-01, SRVR-02, and SRVR-0n. Now consider that model A is not available

to use and that we have to install model b instead. No problem. Because they "harness" is

named SRVR-n we can interchange Make and Model as needed.

This page is optional,

but we recommend

filling in the Front

Panel File field

Click [Next >] to add

the new definition

Filling in the Front Panel File field will make the Rack Builder tool work. Leave it
empty and you may be frustrated later.

Next we will add

some Inputs and

Outputs

Add the I/O by

selecting the I/O tab
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Add Equipment to Library

Click [Add Ports]. The

Add Ports dialog will

appear.

Enter a port name,

connector, signal type

Select Inputs,

Outputs table or Both

Click [Add Ports and

Close] or [Apply] (if

you want to leave the

form open).

Try adding multiple ports. Enter "PORT-" (leave off the quotes). Select any
Connector and Signal Type. Select the BOTH radio button to add to both lists. Now
Check the Add Multiple Ports box and enter a Count of 8. Click [Add Ports and
Close]. See below.
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2.1.4 Creating a New Project

Menu: Application Menu > New Project

Default command line shortcut: np
Create a new WireCAD Project structure. This involves folder structures on

your operating system as well as databases and support files. 

Applies To:

All product levels

Related Settings:

None

WireCAD can create projects with a number of different database formats. You may choose to create a new
project using file based databases for their zero admin capabilities, or SQL Server for an enterprise installation. 

How To: Create a New Project

Create a New Project

Click Application Menu > New Project
Click [Next >]

Select the type of database you wish to use and Click 

[Next >]
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Create a New Project

Enter the Name for the new project. This must follow file

naming conventions because we are going to make a

folder out of the name and in the Project Path that you

choose. Click [Next >]

NOTE: We recommend NOT using the possessive ' ie Bob's Project. The ' character is the

SQL escape character and though we rarely use it in WireCAD it can cause some queries to

fail.

If using SQL databases enter the host information. Click 

[Next >]

NOTE: SQL project names cannot begin with a numeral.
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Create a New Project

Define some of your project preferences. Here you set

your base Starting Cable Number for all sequences.

Click [Next >]

By default the Next Numbers table will suggest and test

the next number. If that number is in use, the Next

Numbers table is incremented and tested until an

available number is found. This behaviour can be

overridden to force the usage of the number in the Next

Numbers table without testing for existence. To do this

Check the Disable Find Next Available ......Click

[Next >]

Enabling  Locations Lookup causes a subtle change in

the SysName Assignment process. You will no longer be

able to just type a location but rather will select your

predefined locations from a drop-down list. If you wish to

work as you have in previous versions of WireCAD

disable Locations Locations Lookup.Click [Next >]

Click [Next >]. Review and click [Finish]
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2.1.5 Creating a New Drawing

Menu: File>New Drawing, Project Explorer\Current Project\New
Drawing

Default command line shortcut: nd
Create a new drawing based on a drawing template, with or without model

space boundaries.

Applies To:

All product levels

Related Settings:

Show New Drawing

Wizard = true

How To: Create a new drawing using the wizard

New Drawing Wizard

1. Click File>New
Drawing

2. Select a template
drawing from which
to start

3. Click [Next >]
4. Select boundary

settings
5. Click [Next >] to

finish

Template drawings are

drawings that have

been saved in the

template drawings

folder and already have

entities such as page

borders, layouts and

viewports added to

them.
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New Drawing Wizard

Create Model
Space

Boundaries. The
Model Space
Boundaries
function takes two

arguments, the
Model Space

Text Height and

the desired
Printed Output

Text Height.
Using these two
variables in
conjunction with
the size of the
Viewports in each
Layout to create 
boundary
rectangles in the
Model space.
Each boundary is
accompanied by a
text description
that describes the
Viewport and  to
which the
boundary applies

as well as the text

heights and scale
factor.

 

Note: You can add

 Model Space
Boundaries later

using the
Format>Boundar
ies function

The final step is to

name the

drawing. 
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2.1.6 Adding Equipment to Drawings

Menu: Database>Equipment Library [Add to Drawing]
Default command line shortcut: le

Create a new equipment block from the library and add it to the current

drawing.

Applies To:

All product levels

Related Settings:

None

How To: Add Equipment to Drawings

Adding Equipment to the Drawing

Find and select the equipment definition from
the Equipment Library.

Select the IO you want to display in the
drawing

Select the Display mode
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Adding Equipment to the Drawing

Select the Display Preferences. Everything is
parametric. There are settings for Body Width,
Pin Spacing, Color, etc.

If the Auto Preview function is not set, you
may wish to click the Refresh button (either
above the preview window or on the IO tab).

 or 

Click [Add to Drawing] (requires an active
drawing).

Place the newly created block in the drawing.
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2.1.7 Drawing Cables

WireCAD provides a series of tools to draw cables. The only rule that this version of WireCAD imposes is that you

must draw from one WireCAD device to another. You cannot draw a cable representing a spare that connects to

nothing.

WireCAD provides a cable auto-routing tool that automatically routes the cable around other devices and, if

selected, avoids other cables. The auto-router will always find a path for the cable, even if it means that the cable

is drawn through another device or must overlay another cable. If you do not like the way a cable is routed, you

have two choices; first: manually drawing the cable by selecting Manual Draw, second: select the cable and grab

a grip on the cable and move it around.

If you manually draw cables or otherwise put them where you want them and them move
a device, the auto-router will be invoked and re-route all your changes.

Topics

WireCAD Cable Terminology

Draw Cables Toolbar

One-to-One Cable

Aux Text

Manual Draw Cables

Cable Router X Offset

Cable Router Y Offset

Default Pointer

One-to-Many Cable

Many-to-One Cable

Many-to-Many Cable

Terminal as Source

Terminal as Destination
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WireCAD Cable Terminology

Devices have inputs and

outputs, Cables have sources

and destinations.

For purposes of this manual

we will refer to Jacks, Junction

Boxes, Router Crosspoints,

Bulkhead connectors, and On-

Sheet/Off-Sheet Pointers

collectively as terminals

Terminals:

Terminals

Draw Cables Control Descriptions

Item Description

Draw Cable Toolbar
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Item Description

One-to-One Cable Used to draw from one output to one input

Cable Text Height The Cable# text entity height in 100/DU.

Replace Cable with Pointers

checkbox
Automatically draw Pointers instead of cables.

 

Manual Draw checkbox Draw every point in the cable.

Avoid Other Cables checkbox Allows cables to overlay each other. True =
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Item Description

False =

Aux Text Enable Enable the placement of Aux Text.

Aux Text Height The height in 100/DU of the Aux Text.

Location The position of the Aux Text relative to the cable polyline. 

Over - positioned over the cable polyline.

Under - positioned under the cable polyline.

Bubble - Not yet supported.
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Item Description

Variable You may choose to populate the Aux Text with the following variables:

CircuitNumber - The Circuit Number as entered in the Cable Edit Dialog.
IPAddreess - Not yet implemented.
Length - The Length field as entered in the Cable Edit Dialog.
User1 - The User1 as entered in the Cable Edit Dialog.
User2 - The User2 as entered in the Cable Edit Dialog.
User3 - The User3 as entered in the Cable Edit Dialog.
User4 - The User4 as entered in the Cable Edit Dialog.

Format {0} represents the data from the selected variable.
Example: the incoming data from the selected variable is 300 and you
want to format it to represent meters to the reader. Your format field would
be {0}m. The output would be formatted as 300m.
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Item Description

X Offset Horizontal auto-router offset. When drawing cables, WireCAD uses an

auto-routine algorithm. The X Offset determines how far away horizontally

from other equipment and cables a new cable will rout.

Y Offset Vertical auto-router offset. When drawing cables, WireCAD uses an auto-

routine algorithm. The Y Offset determines how far away Vertically from

other equipment and cables a new cable will rout.

Default Pointer Select the pointer to use when replacing cable with pointers

One-to-Many Cable

Explanation Used to indicate one output to many inputs
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Item Description

Feeder selection

Count Destination count

Count=3
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Item Description

Y offset, Y Spacing, Hor

Extension in 100/DU

Feeder distances in 100/DU

One Cable Database Entry Adds a single entry in the cables database and one Cable# text entity at

the Y point.
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Item Description

Many Cable Database Entries Adds a many entries in the cables database and many Cable# text entity

at the connection points. 

Note: One-to-Many and Many-to-One cables set to Many Cable Database

Entries will assign the connection point closest to the cursor when the

cable is double-clicked. The first assignment on the cable will enter the

database as expected, subsequent assignments will display the Existing

Ports dialog prompting you to decide how to number the cables.

Many-to-One Cable

Explanation Multiple outputs to one input
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Item Description

Count Source count

count=3

More information See above for a description of other settings

Many-to-Many Cable

Explanation Many-to-Many cables behave like a buss. They are a collection of one-to-

one cable drawn as a single polyline. When assigning cable numbers the

connection point closest to the cursor is used.

 See the above descriptions for more information about settings.

Count Source and destination count
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Item Description

Count = 2
Y feeder

Terminal as Source Window
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Item Description

Displays the available Terminals

sorted by Terminal style (Jack,

Terminal, Pointer).

 
Note: Terminal file suffixes
determine whether the file will
be displayed in this window.
Files having a _SD.DWG, or
_S.DWG suffix will appear in
this view.
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Item Description

Terminal Offset Sets the distance between the connection point and the terminal

basepoint

Terminal as Destination
Window
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Item Description

Displays the available Terminals

sorted by Terminal style (Jack,

Terminal, Pointer).

 

Note: Terminal file suffixes
determine whether the file will
be displayed in this window.
Files having a _SD.DWG, or
_D.DWG suffix will appear in
this view.

Terminal Offset see above

Avoid Other Calbles instructs the cable auto-router to avoid other cables.
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Item Description

Tidy Cables After moving a grip on a cable the cable is forced ortho.

Before Tidy

Tidy After
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Splice Points

Explanation

Item Description

WireCAD
supports
splice points.
If you need a
junction in the
cable/wire/
fiber then use
a Splice Point.
Splice Points
can be found
in the
Terminals tool
panels and
are placed like
any other
Terminal. 

To Assign a
Splice Point
you just
double-click it
and fill in the
data.
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NOTE: if the

SysName

contains the text 

SPLICE then the

duplicate checks

and other

validations

against the

Cables and

Equipment Lists

are ignored. This

allows you to

have any number

of Splice Points

all with the same

name.

Adapters

Explanation

WireCAD supports the use of Adapters. Adapters are typically used to convert from one connector to
another and may also involve the conversion of signal type. Adapters are found in the Terminals tool
panels and are placed similar to other terminals. The difference is that instead of a wire being placed
between the port and the terminal the Adapter is placed directly on the port. Once placed, the
adapter reads the block to which it is being attached and gets the SysName and Port information. It
then asks you for the connector new connector type. Finally it populates the Adapter with the
extracted information.
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NOTE: if the functional block to which you are attaching the adapter is not yet assigned a SysName you will be

prompted that the operation cannot complete until you have assigned a SysName to the device. You will then

need to double-click each attached adapter to get the information into the adapter.

 

 

2.1.8 Defining Locations

Menu: Project Explorer>Project Databases>Locations

Default command line shortcut: none

Define locations for use in assigning SysNames

Applies To:

All Product Levels

Related Settings:

Enable Locations

Lookup Table

Explanation
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You can enable the Locations Lookup table. Here you can predefine your locations; thus maintaining referential
integrity across all of your locations. In order to use this function you must set Application Menu > Settings >
Project [Locations] Enable Locations Lookup = true. If this setting is false, WireCAD behaves as it did in
previous versions allowing you to type any value in the Location field of the SysName Assignment dialog. 

When using the Locations Lookup setting you will need to add locations before you can make use of them in
the SysName Assignment dialog.

There is one other ramification of using  the Locations Lookup: in the Cables table are two new fields SRCEL
and DESTEL (Source Elevation, Destination Elevation). These are now populated as you assign cables. This
provides an additional level of control as you create reports.

HOW TO: Add a New Location

Step Description

Click Project Explorer>Project

Databases>Locations

This opens the Locations table

Click File>New

Enter your data and click [Add]
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2.1.9 Assigning Unique IDs (SysNames)

Menu: Advanced Tools>Equipment Functions>Assign SysName

Default command line shortcut: as
Alternately: double-click the equipment block in the drawing.

Assign a unique ID to blocks in a drawing. 

Applies To:

All Product Levels

Related Settings:

SysName Format

Leading Zeros

Next Numbers Database

This function performs the following steps:
1. Gets the next number in the sequence (based on the SysName Format) from the Next Numbers table.
2. Prompts the user for input.
3. Updates the drawing
4. Updates the project systems database.

Note: if the project contains related projects, you will be notified of duplicate SysNames in related projects

Edit SysNames Dialog

SysName

If you manually enter a

SysName it must follow the

format defined in the

SysName Format tool. The

SysName textbox will be

masked to help you follow

the format

Alias

Alias is functional name for

the device. Think of it like the

friendly name. The SysName

is the unique ID the Alias

can be duplicated if desired.

Example: If the device is a distribution amp and its SysName is DA-120 and it is
fed by SVR-01, you may choose to alias it as its source SVR-01.
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Edit SysNames Dialog

Location / Elevation We recommend that you enter a Location and Elevation. Take your best
guess. The Rack Builder tool will use your guesses to create a preliminary
rack layout that can easily be modified to suit your final design

User 1 - 4 For you

IP Address / Subnet Mask For the IP stuff if any

Power Consumption /

Weight

Pre populated from the Global Equipment database if exists

Flags Various flags to help you sort the equipment in your Systems table.

2.1.10 Assigning Cable Numbers

Menu: Advanced Tools>Cable Functions>Assign Cable Number

Default command line shortcut: ac
Alternately: Double-click the cable in the drawing

Assumes that the devices on both sides of the cable have first been

assigned SysNames.

To assign multiple cables at once, create a selection of cables. The order

the cables are added to the select set is the order that they will be

assigned numbers. Once you have created a selection of cables, click:

Advanced Tools>Cable Functions>Assign Cable Number, or type ac

into the command line followed by the [Enter] key.

Applies To:

All product levels

Related Settings:

Cable Number Format

Project Settings

This function performs the following steps:
1. Gets the next number in the sequence (based on the Cable Number Format)
2. Prompts the user for input
3. Updates the drawing
4. Updates the project systems database
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Note: if the project contains related projects, you will be notified of duplicate Cable numbers in related projects

Edit Cable Numbers Dialog

CableNo

If you manually enter a

Cable Number it must follow

the format defined in the

Cable Number Format tool.

The CableNo textbox will be

masked to help you follow

the format

CableNo, New +

CableNo is a direct entry field as well as a dropdown that displays all available,

available cables within the      current sequence, filling gaps if so desired.

When double-clicking an assigned cable, the form will be shown in edit mode.

The [New +] button will allow the cable number to be fully edited. This requires

some caution. Be sure to check the database to be sure that the edits and

deletions have been committed.

CableTypeManu,

CableType Select the Cable Type Manufacturer and Cable Type. 

SignalType,Multicore

Data, Add All Cores
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Edit Cable Numbers Dialog

Select the Signal Type. 

If you have selected a multicore cable from the CableType dropdown, the core

data will be shown. If you are assigning a single core in the core structure, select

that core. If you wish to assign all cores and have selected enough cables to

apply all core number to, select the Add All Cores checkbox.

Source and Destination

info

2.1.11 Assigning Terminals

Menu: Advanced Tools>Equipment Functions>Assign Terminals

Default command line shortcut: ats
Alternately: Double-click the terminal in the drawing

Assumes that at least one SysName  has been assigned.

To assign multiple terminals at once, create a selection of like terminals.
The order the terminals are added to the selection set is the order that they
will be assigned numbers. Once you have created a selection of terminals,
click: Advanced Tools>Equipment Functions>Assign Terminal(s), or
type ats into the command line followed by the [Enter] key.

Applies To:

All product levels

Related Settings:

None

This function performs the following steps:
1. Opens a port selection dialog based on SysName.
2. Prompts the user to select the SysName and the port or ports to display(or range of ports of multiple

terminals are selected).
3. Updates the terminal(s) in the drawing.

64



WireCAD v8 User Manual68

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Assign Terminal(s) Dialog

SysName

Select the SysName or press the [+] button to add

a new SysName

I am Just Changing a SysName Leaves all port data as currently displayed on a terminal,
just changes the SysName. This is useful for modifying
existing terminal assignments.

Remember this equipment Remembers the selected SysName and returns to it on
the next terminal assignment

Outputs track inputs When you select an input that has a corresponding
output of the exact same name, that output will also be
selected.

Inputs grid Active only if the selected terminal(s) have input
connection points
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Assign Terminal(s) Dialog

Outputs grid Active only if the selected terminal(s) have output
connection points

2.1.12 Rack Builder Tool

Menu: Advanced Tools>Rack Functions>Rack Builder

Default command line shortcut: rb

   The Rack Builder tool is not available in XL Free mode

The Rack Builder tool utilizes information in the Project Systems table and

the global equipment library to place and populate rack elevation views. This

process may be run repeatedly as the project progresses.

Applies To:

XLT PRO

Related Settings:

Default Rack Height

Top Down Racks

Topics
How it Works
Controls

70
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How it Works

The Rack Builder tool relies on three key
pieces of information. First we need the
SysName of the device to add to the rack.
From the SysName we retrieve the equipment
manufacturer and model. Second, using the
equipment manufacturer and model, we get
the global equipment definition from the global
equipment database. If the global equipment
definition is complete it will contain either a
reference to a front panel dwg file (BlockRef) or
dimensional data. If either of these are missing
the Rack Builder tool will flag that equipment
definition as requiring more information. The
Rack Builder tool will perform a preflight check
of all data and let you know what you are
missing.

Assuming all of the data fiddly-bits are in the
right place, the Rack Builder tool will populate
the drawing with one locator grid per location
selected. A locator grid is an array of point
entities that are spaced horizontally and
vertically based upon your selection in the
preferences.

Next the Rack Builder tool, based on the
Mechanical View Rule, will place either the
front panel file or a block created from the
dimensional data at the location point defined
in the Project System entry.

The locator grids facilitate location aware
movement of the devices placed on the grid
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How it Works

You may manually place devices created from
the equipment library in Front Panel mode on
the locator grids

To move a device within the rack elevations,
select the device, grab it by its grip and move
it to the desired location. 

Note: It is desirable to turn on End Point snap

and possibly Node Snap while moving devices

WireCAD will notify you of the location change
and update the databases immediately to
reflect the change.

 It will not update the remainder of the drawing
set until you click save.
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How it Works

Once changes are made across the drawing
set you will be notified of the changed
drawings

 

Controls

The [Basic] tab allows you to
select the locations to include
in the Rack Building function.
As you select each location,
the Systems Involved list will
populate. 

Systems Involved list Displays a list of all the systems that will be placed in the created drawing.
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Controls

The [Advanced] tab exposes
properties that control the
behavior of the utility.

 Chassis Width Sets the width of the chassis in DU

 Height in RU Sets the height of the locator grid in Rack Units (RU = 1.75 inches or
4.445cm)

 Slot Count Sets the number of slots per locator grid. This is used to position items that
may not be located at the insertion point of the rack unit. 

 Slot Delimiter WireCAD searches the Elevation field for numeric values first then for the
slot delimiter if found it parses the the data into two values the elevation and
the slot, or in other words how far up in the rack and how far over.

 Insertion Point Where to start the whole process

 Attribute Height If view rule is not ShowDWGInPath, sets the attribute height of the
displayed text.

 View Rule ShowDWGInPath = use the dwg file found in the equipment definition
BlockRef (Front Panel File).
CreateFromDimensions = use the dimension data from the equipment
definition to create a 3D rack block.
CreateFromDimensionsIfNotFound = Use dimension data if the
BlockRef is not found.

Place Text If Item Cannot Be

Created

If the item cannot be created due to lacking data, place a text marker in the
drawing at the location.

Include hashes This will normally be checked unless you are rebuilding a drawing that

already has the locator grids.
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Controls

Spacing DU Sets the location grid spacing in Drawing Units

2.1.13 Equipment List Visualizer

Menu: Database>Project Systems>Equipment List (SysNames)

Default command line shortcut: sys

The Equipment List Visualization tool utilizes information in the Project

Systems table and the Global Equipment Library and the Project Cables

database to create a view of all cables attached to the selected item.

These details are useful for error checking and in the field as an installation

aid.

Applies To:

PRO, ENT

Related Settings:

See the Settings Tab

Controls

The Equipment List with RTR-01

selected

Settings Tab Control the output of the Visualizer.
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Controls

Use Last Display Order if Set Sorts the ports of the block based on the saved display order if any.

Terminal The terminal to display 

Use Last Saved Appearance If there are device level setting saved, use them.

Body Width and Pin Spacing Appearance settings in 100/DU

Port Data Source Pull the port data from the Equipment Library. This will show ALL ports

associated with this device definition.

Pull the port data from the Cables table. This will show only those ports

to which cables have been attached and assigned.

Title Block Describes the visualization. Salt to taste.

Visualization tab Does it.
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2.1.14 Cables Visualizer

Menu: Database>Project Cables>Project Cables Grid

Default command line shortcut: cg

The Cables Visualization tool creates a layered digraph showing the

Locations (vertically) and the cables between them (horizontally).

Use this output for:

Pre-wires

Spare inventory

General overview

Enlighten and amaze your friends

Applies To:

PRO, ENT

Related Settings:

See the Settings tab
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Visualization without SysNames
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Visualization with SysNames
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2.1.15 Grid Basics

Menu: various

Default command line shortcut: various

WireCAD displays data from the various databases in grid form. WireCAD

grids support the following:

Searching

Sorting

Column re-ordering

Column hiding/showing

Column grouping

Column resizing

Column filtering

Copy Selection Down

Increment Selection Down

Hierarchical display

Export to PDF, EXCEL, TXT, HTML, XML and more

In addition, several grids support WireCAD Visualization Tools mentioned

earlier in this text.

Applies To:

ALL

Related Settings:

Various
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Grid Parts

How To

Search Enter your search text in the Search box and click [Search]. WireCAD will search all

fields in the table for the search term. These are wildcard searches.

Sort Clicking on a column header will cause a sort. Clicking it again will reverse the sort

order.

Column re-ordering/

resizing

Drag a column from its center to initiate a move. Drop it where you want it to display.

To resize a column, drag its edge left or right.
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How To

Column hiding/

showing

To hide a column: right-click the column header and choose [Remove this Column]

from the context menu.

To show a column:

1. Right-click any column header

2. Click the [Column Chooser] context menu item

The Customization form displays
hidden column headers

3. Drag the column header you wish to display and drop it on the header bar with the

other column headers.

Column grouping If the grid supports grouping the grid will display a GroupBy panel at the top indicating

that column headers may be dropped there to group.

Grid grouped by Manufacturer and EquipmentName fields

To un-group simply drag the column header back to the header bar.
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How To

Column filtering Columns may be filtered in one of three ways:

1. Click the column header filter icon on the column header. You will be presented

with a list of unique values found in that column.
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How To

2. Click the (Custom) menu item presented in the column filter list.

3. If the grid supports it a filter pane will appear as the top row of the grid. It is

symbolized by . Entering filter criteria in the desired column will cause filtering.

NOTE: Filters will persist across closing a grid and re-opening. Don't panic. Simply
clear the filter criteria as explained below.
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How To

Clearing Filter Criteria If a filter has been applied to a grid, a filter panel will display on the grid in the lower

left hand corner.

You may clear the filter by closing [X] the filter panel.

Copy Selection Down If the grid supports it you will be able to copy the top item in a selection down into all

of the selected cells below it. Follow these steps:

1. Create your selection

2. Click Edit>Copy Selection Down or press [Ctrl]+[D] on your keyboard.

3. Be sure to click File>Save to commit your changes to the database.

Increment Selection

Down

If the grid supports it you will be able to increment the top item in a selection down

into all of the selected cells below it. Follow these steps:

1. Create your selection

2. Click Edit>Increment Selection Down or press [Ctrl]+[I] on your keyboard.

3. Be sure to click File>Save to commit your changes to the database.

Deleting Cell Data To delete the contents of the selected cells simply click the [Del] key on your

keyboard.
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How To

Deleting Selected

Rows

To remove the rows from the grid:

1. Select the rows to delete by click on the Record Selector (left-most column without

data).

2. Click Edit>Delete Selected Rows or click [Ctrl]+[Del] on your keyboard.

3. Be sure to click File>Save to commit your changes to the database.
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How To

Display Hierarchical

Detail Data

If the grid supports it and there is detail data to display you can click the [+] button in

the left-most row. 

Export Click File>Export>[File Type]. WireCAD will then export the data with your current

grouping, sorting, and filtering applied to the selected format.
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2.2 Personalizing WireCAD

The Settings Dialog  Reference

Template Drawings

2.2.1 Template Drawings

Menu: File>Save As Template Drawing

Menu: File>Open Drawing

Default command line shortcut: fo (File Open)

Applies To:

All

Related Settings:

Show New Drawing

Wizard

Template Drawings

Support Path

Template drawings are drawings that are preset with items that you don't want to add every time, such as

page borders (titleblocks) and viewports. It is not uncommon to create a template for each project by starting

with an existing drawing and adding your titleblock data etc. Some WireCAD users go so far as to create

templates for their frequently used designs. 

Template drawings are saved in the Template Drawings Support Path. You can pick template drawings from
the New Drawing Wizard.

Creating Template Drawings

Create the base template drawing Customize your drawing to include the desired title

blocks, layouts, text, logos, etc.You may go so far as

to fill in title blocks with specific project data such as

client name and draftsmen.

261

87
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Save it to the Template Drawings support path This is normally c:

\users\public\documents\WireCAD\WireCAD[#]

\TemplateDrawings\. 

Note: this will be different if you are installed and

working on a network with others. To check your %

TemplateDrawings% support path, click Application

Menu > Settings~Application[Support Paths] and

check the path entered in the Template Drawings

field.

Usage

Create a new drawing Click File>New Drawing. If your default settings have

not changed you will be presented with the New

Drawing Wizard. The first window should now display

your shiny new template drawing. Select it and

continue through the wizard.

2.3 Reporting

Contents

Printing Reports

Filtering Reports

Creating Reports

89

90

93
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2.3.1 Printing Reports

Menu: double-click the report in the Project Explorer
  Default command line shortcut: none 

Opens a report for preview, printing or export

Applies To:

XLT PRO ENT

Related Settings:

None

Printing Reports

Reports display in design
view by default (XL mode
excepted). 

Clicking the [Preview]
button renders the report
unless the report defines
parameters that the user
must enter followed by the 
[Submit] button on the
parameter pane.
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2.3.2 Filtering Reports

Menu: double-click the report in the Project Explorer

Default command line shortcut: none

Report filtering is not available in XL free mode.

Applies To:

XLT PRO

Related Settings:

None

Filtering Reports

In order to filter a report the report must
be in design mode

Make sure that the Property window is
displayed. If not click:
View>Windows>Property Grid

From the Property grid object selector,
select XRReport1
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Filtering Reports

From the Property grid select the Filter
String ... ellipsis button

This opens the filter dialog from which
you may select a number of different
filters
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Filtering Reports

Filters may also contain parameters that
the user must enter before the report is
generated. In order to make use of this
function you must follow these steps:
1. Add a parameter to the report while in

Design view. Click the Parameters
(...) ellipsis button to view the
Parameters collection.

2. Click the [Add] button to add a
parameter to the collection.

3. Enter description and default value
information.

4. Open the filter editor (see above)
5. Add a condition and edit the

comparison, then click on the icon to
the right of the field to select
parameters.

6. Click [Preview] to preview the report.
You will see a Parameters pane on
the left hand side with a submit
button.

7. Enter a value and click [Submit].

Step 5.



WireCAD XL, XLT, PRO 93

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Filtering Reports

2.3.3 Creating Reports

Contents

Standard

Labels

Report Design Basics

94

98

103
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2.3.3.1 Standard

Menu: Report>New Report with Wizard

Default command line shortcut: rw 
Create a new report

Applies To:

XLT PRO

Related Settings:

None

How To: Create a New Report

Create a Standard Report

Click Reports>New Report with
Wizard. Alternately: from the Project
Explorer - click New Report with
Wizard

Select the Standard Report option.
Click [Next >]
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Create a Standard Report

Select a data collection. Data collections
access both the global and project
databases. For example: say you wanted
to show a list of all manufacturers. You
would select the 
GlobalManufacturersCollection. 

Note: collections are hierarchical to aid in

the creation of subreports. All collections

are populated with data when the report is

previewed.

Select the fields (columns) you wish to
display in the report.

Note: use the > >> < << buttons in the

center of the two lists to move items

between the lists
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Create a Standard Report

Apply any grouping

Select a Layout and Orientation for
your report.

Note: the Adjust field width to fit
function will force all selected fields on to
a single page possibly rendering some of
the data unreadable. If you have lots of
fields to display, consider using a 
Justified report



WireCAD XL, XLT, PRO 97

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Create a Standard Report

Select a Report Style

Title your report
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Create a Standard Report

Click [Finish] to create your shiny new
report.

Click File>Save and save your work to
your reports support path

2.3.3.2 Labels

Menu: Report>New Report with Wizard

Default command line shortcut: rw 
Create a new label report

Applies To:

XLT PRO

Related Settings:

None

How To: Create a New Label Report
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Create a New Label Report

Click Reports>New Report with
Wizard. Alternately: from the Project
Explorer - click New Report with
Wizard

Select the Label Report option. Click
[Next >]

Select a data collection. Data collections
access both the global and project
databases. 

Note: In the case of labels we probably

want to use the CablesCollection
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Create a New Label Report

Select a label format. WireCAD comes
stock with over 1000 label formats from
15 manufacturers including Panduit,
Hellerman Tyton and Brady.

Modify and of the nudge factors and
select the sheet size
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Create a New Label Report

Click [Finish] to create your shiny new
report.

Select the Field List and drag any fields
that you wish to display on to the report
design surface.

Note: avoid placing field on the light and

dark grey areas. The light grey area will not

print and the dark grey is indicative of the

clear laminating portion of a cable label.

Here we have three fields that we have
dragged and positioned on the design
surface. We then edited the Src and Dest
fields to concatenate the Pin data as
well. Then we edited the font property of
the CableNo entity to bold it.
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Create a New Label Report

Final output looks like this

Click File>Save and save your work to
your reports support path
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2.3.3.3 Report Design Basics

The following topic assumes that you have either opened a new blank report or that you have run the New Report

Wizard.

Navigating the Designer

If you open a new report without running the wizard you will need to set the report Data Member variable. 

Click in the dark grey area to load the general properties. Select the Data Member from the drop down.
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You can drag fields from the Field List directly to the report designer.

If you want to concatenate multiple fields in a single label you can drag multiple fields onto the same label or edit it

directly. 

To edit a label double-click it to enter edit mode.

Type directly into the label. Field names must be enclosed in [] brackets.
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2.4 Frequently Asked Questions

Contents

Placing Custom Titleblocks (Page Borders)

Creating Custom Titleblocks

Moving Projects

Synchronizing with Another Equipment Library

Setting Up on a Network

Upgrading From v6

2.4.1 Placing Custom Titleblocks (Page Borders)

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: 

Applies To:

All Product Levels

Related Settings:

None

How to Place Custom Titleblocks into Your Drawing

Step Description

Switch to the Layout in which you intend to

place your custom page border

Open the Insert block into Drawing dialog.

  Basic CAD Tools>Blocks>Insert  Block

into Drawing

105
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Step Description

Select [From File]

Browse to the dwg that contains your
custom title block in the Model Space 

Click [OK] to place the insert into the
drawing.

Now you will need to place a Viewport to the model space

Click View>New Viewport and select the
logical boundaries of the viewport within the
titleblock you placed earlier.

Now double-click the viewport to activate it for zooming and panning and use the mouse wheel or zoom
commands to position the viewport over the model space.
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2.4.2 Creating Custom Titleblocks

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: 

Applies To:

All Product Levels

Related Settings:

None

How To: Create Your Own Custom Titleblocks

1. Create a new drawing with no template.
2. Draw your titleblock in Model space scaling it 1:1 with your printed page size, ie an 11x17 page border would

be 11x17 minus your margins.
3. Place any images and attribute definitions.
4. Save the drawing.
5. Follow the steps here  for placing your title block drawing in any other drawing.105
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2.4.3 Moving Projects (Pack Up/Check-Out)

Menu: Application Menu > Project Utilities>Packup / Check-out

Menu: Application Menu > Project Utilities>Unpack

Menu: Application Menu > Project Utilities>Check In

Default command line shortcut: 

XL FREE does not support this function

Applies To:

XLT PRO

Related Settings:

None
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Moving Proejcts

The Basics

When moving projects from

machine to machine there

are external items upon

which the project depends.

These are referred to as

project and drawing

dependencies. The main

project dependency is the

global equipment database.

Drawings may have image,

XRef, and font

dependencies. When we

Pack Up a project we are

grabbing all of those

dependencies (fonts are

and exception and are not

included) and placing them

in the Project folder. We

may choose to Check Out

the project at the same

time (PRO only). This flags

the project rendering read

only until such time as the

project is checked back in.



WireCAD v8 User Manual110

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Moving Proejcts

Once packed up and/or

zipped up you are ready to

move the project to another

machine. Simply copy the

Project folder or the zipped

file and move it to the new

machine. 

Please note that it is

beyond the scope of this

manual to tell you how to

copy and move files in your

operating system.
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Moving Proejcts

To Unpack or

Check In - That is

the Question

The two functions are

practically identical with

the exception that the

Check In function won't

launch without an active

project and once unpacked

will mark the active project

as Checked In.

Whether you Unpack or

Check In a project depends

on whether you are moving

a project to a machine on

which that project already

resides and whether you

have Checked Out the

Project.

If you have not Checked

Out the project then there

is no need to Check In the

project.

If you are moving a project

to another machine, use

the Unpack function.
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2.4.4 Synchronizing with Another Equipment Database

Menu: Database>Sync Equipment Libraries...
Default command line shortcut: 

XL FREE does not support synchronizing another Equipment
Database.

Occasionally you may experience the need to sync with another user's

global database. This will copy all of their equipment to your Global

Equipment Database. The sync includes manufacturers, equipment, inputs,

outputs, signal types, connectors, cable types, cable core data, relational

tables, etc. 

You may choose within the tool to perform an import, export or

bidirectional sync.

Applies To:

XLT PRO

Related Settings:

Syncs the incoming

global equipment

database to the

connected Global

Equipment Database

Demystifying Synchronization

Synchronizing data in two tables of the same structure is really very simple. In its most basic form, records

that do not exist in one table are added. Records that exist in both tables receive the most current data based

on a timestamp. In order that records deleted from one table do not get added back in, a special table is

employed to track deleted keys. If the delete is the most current action then the record will likewise be deleted

from the other table. In the unlikely event that the records have the exact same timestamp, yet the data is

different, those records are flagged as conflict records from which you must pick the most correct. 
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Controls

Database Location

Select either a VistaDB file based
database or a SQL Server host. If server
based you will need to provide host and
credentials. If you do not know them
contact your SQL Server database
administrator.

Import, Export, Bidirectional Self explanatory

Remember Settings Remember database location information

Sync Initiates the synchronization with the top progress bar showing
the overall progress and the bottom showing detail progress. 

Status Bar Displays status of the sync.

At the conclusion of the sync you will be
presented with a report that details the
records updated here and there.
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2.4.5 Setting Up On a Network

What follows is a discussion of several different network topologies and work flows that WireCAD can employ.

Regardless of topology or work flow the following steps should be taken for each WireCAD machine. For purposes

of this discussion we will distinguish between and Windows user operating under group policy and  WireCAD user.

The Windows user will be referred to as a OS user. WireCAD users will be referred to as WC users.

1. Install WireCAD

2. Create a network share that is visible to all WireCAD users. Group policy for the OS user of WireCAD should

allow the user to read and write the registry (restriction of the registry editor is acceptable), as well as, read and

write files on the selected shares, the WireCAD7 folder on the client machine, the OS user's temp directory, the

OS user's All Users documents and settings folder trees.

3. Pick one WireCAD client machine from which to copy the global databases and copy from ...\WireCAD7

\WireCADGlobalEquipment.vdb3 to \

\YourNetworkShare\FolderForWireCADGlobalDatabases\WireCADGlobalEquipment.vdb3

4. Launch WireCAD on the client machine.

5. Click Application Menu > Settings{Support Paths}

6. Modify the support paths for the Global Equipment database, and any blocks or reports that you wish to share

among all users.

7. Click [Done] and relaunch WireCAD.

Note: The use of mapped network drives is not recommended. Rather use UNC (\
\ShareName\Path\) drive paths to specify network shares. This will avoid problems with the same
share mapped to different drives.

8. Click Application Menu > Security>View Permissions. If you are an administrator or rather if your WireCAD

identity is that of Administrator, you will have edit ability on this grid.

9. WireCAD uses your Windows groups. You assign permissions to the group. The current user Identity is set to

the group thus determining their access level.
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2.4.6 Upgrading from v7

Menu: Various

Default command line shortcut: none

Applies To:

All product levels

Related Settings:

None
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If you are upgrading from v7 you will need to take the following steps:

Upgrading from v7

1. Install WireCAD v8

2. Setup your global databases (file based or SQL Server)

3. Click Database > Sync Equipment Libraries

4. Click the ellipsis (...) and enter the path to the v6 WireCADGlobalEquipment.vdb3 file

or set the SQL Server Host info.

5. Click the Import radio button.

6. Click [Sync] to sync the two databases.

Note: this may take some time 

6. Next convert any projects that you want to work with in v8

7. Click Application Menu > Open Project and browse to your v7

<YOURPROJECTNAME>.wc6plf file. WireCAD will open and convert the project.

*When WireCAD converts projects no drawings are touched. The database schema is modified.

WireCAD can no longer upgrade a v5 or earlier project. Key data access components
needed to open and import data from the Microsoft Access databases are no longer
available for modern 64bit operating systems.

If you need to bring a v5 or earlier project forward we recommend using a 32bit XP virtual
machine with WireCAD v6 installed. Convert the project to v6. Then open it in v8 once
converted.

We offer this service if you get in trouble. Call us.
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2.5 Choosing a Database Format

Menu: None

Default command line shortcut: none

Applies To:

PRO

Related Settings:

None

WireCAD v8 PRO and ENT allows the use of file based and server based databases for the project and global
databases. The choice of which to use requires some forethought. Listed here are some basic considerations:

SQL Azure SQL Server VistaDB (File Based)

Zero Administration X

Portable X

ACID Compliant

(atomicity, consistency,

isolation, durability)

X X X

Database Size 2 Gig Theoretically unlimited Theoretical limit is 16

Exabytes (uint64). 

Practical limit is based

upon machine resources. 

Files are not limited by the

database engine, but

loading very large

databases will require large

system resources. 

In Process Processing X

Cloud Based X

At first glance that the table above it would seem that the proper choice would be the file based solution.
However, take note of the item - In Process Processing means that the WireCAD processes must read and write
all data to and from the file based database. Using SQL Server allows us to hand those processes off to the
database server creating, in many instances, a significant (read 10X) increase in speed.

Before selecting a database format consider the following questions:
Will I be moving the project from machine to machine? If yes, consider staying file based on the project.
Do I have the chops to manage a SQL Server? If no, stay file based. SQL Server requires care and feeding.
Am I away from my network when I work on WireCAD projects? If you lose connection, WireCAD will become
hampered.
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Do I really need the speed enhancements? If you are working on projects with hundreds of thousands of
cables, SQL Server is a must.

When you move a project using the Application Menu > Utilities>Pack Up/Check Out function and you are
using SQL Server databases the database in converted to a file based version and will remain file based from that
point forward.

To set up SQL Server see here

Need help with SQL Azure? Contact us we can help.

119
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2.5.1 SQL Server Setup

It is not within the scope of this manual to provide an in depth discussion of SQL Server. We will touch on the

basics required for use with WireCAD. 

Basics

The WireCAD distribution includes SQL Server database files for the Global Equipment database. You will need to

attach these to the the running server. You will then configure WireCAD to look at the SQL Server for the Global

Equipment database. WireCAD projects will create a new database (catalog) for every new project.

You will need to set up permissions for each user to allow them dbcreator privileges. This is the default for

localhosts but not remote servers.

There is no further requirement to attach databases once the Global Equipment database.

SQL Server can be set up on a server or on a local machine. WireCAD requires the 2005 version or newer and can

use the Express versions.

Be sure to download SQL Server Management Studio Express as well. Both are free.

SQL Server does not provide a graphical user interface so you will want to download the management studio listed

above. 

Setting Up the WireCAD Global Databases on SQL Server

The following assumes that you are installing WireCAD on a local machine. If you are installing on a server you will

want to copy the global database files in Step 6 below to the server before you attach them to the server.

1. Install SQL Server. You will be prompted for an instance name. Instance names allow you to have multiple SQL

Servers running on the same machine. In addition you will be prompted for a security mode (Windows or SQL),

Windows uses your Windows users and groups, SQL ignores these and allows you to manages different users

and groups from within SQL Server.

2. Install SQL Server Management Studio(SQLSMS).
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3. Launch SQLSMS and log in to the server. If the server is on your local machine you can use the shorthand .

\INSTANCENAME for the host.

4. Setup a proper login for WireCAD.

5. You will now need to configure each WireCAD client to look at the SQL Serverl

6. Launch WireCAD

7. Click Applcation Men > Application Setup and follow the steps for SQL Server.



Part

III
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3 WireCAD ENTerprise CMS Tools

3.1 WireCAD CMS Introduction & Concept

This section of the manual covers topics that will help you better understand the work flow, background and idea

behind <%APPNAME%> with CMS Tools.

 

Topic Sub Sections

WireCAD Concept Before CMS Tools

CMS Tools Concept 123
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3.1.1 CMS Tools Concept

<%APPVER%> with CMS tools has introduced the ability to work in a different manner from previous versions of

WireCAD.

The standard work flow for WireCAD users has been to create your Functional Block Diagrams first, then assign

SysNames and Cable Numbers and lastly, generate reports based on this information. 

<%APPVER%> CMS allows you to start by entering your SysNames and Cable Numbers into the Database first,

create Backbones and Circuits and then generate a Functional Block Diagram based on the information set in the

Database. 
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3.2 CMS Basics

The following is a list of How To's for multiple functions in <%APPVER%> including creating Cable Types , New

Equipment Definitions, Creating Projects and more.

      

Topic Sub Sections

Creating a New SQL Project

Creating a New Cable Type

How To Create a Backbones

Using The New Circuit Tool

How to Output a Circuit to CAD

How to Output Many Circuits to CAD

Using The Backbone Grid

419

183

170

130

147

162

164

126
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3.2.1 Backbones

This is a step by step guide on how to create Backbones. Backbones are represented in the cables database by a

collection of cables.

Each cable in the backbone has the same Cable Number Prefix. When you create a new Backbone you are

creating a collection of cables based on the selected Cable Type. If you are documenting fibers think one fiber

equals one core/conductor/cable. backbone cables are flagged with the boolean value isBackbone = true. Doing

so distinguishes a cable as being part of a backbone structure.

Open the Backbones grid by double-clicking the icon in the Project Explorer [Project Databases][Backbones]

Command Line Shortcut: bbg

Before You Start

Before creating a Backbone, you will need to make sure you have created your Equipment  and Cable Types

 associated with this project. 

176

169



WireCAD v8 User Manual126

© 2015 Holbrook Enterprises, Inc. dba WireCAD

3.2.1.1 The Backbone Grid

The Backbone Grid will show you a list of all the backbone segments in your project and allow you to modify their

status or delete the entire backbone cable group at once. The status will refer to whether the backbone is in use,

proposed, dead ETC. New backbone status can be created in the project settings menu. There are 3 default

status available; in use, proposed & dead. 

The Backbone Grid is easier to use than the Cables Database if you are looking for basic information about a

backbone such as number or origin and destination information or if you are simply wanting to change the status

of the backbone. 

To access The Backbone Grid, type BBG in the command line.

With The Backbones Grid open, a list of all created backbones and cores will show along numerous columns of

information about each backbone core. 
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Edit

Copy Selection Down Create a selection vertically in the grid and click 

Edit>Copy Selection Down or Ctrl+D and the

topmost cell's data will be copied to all selected cells

below.

Delete Selected Backbone This function will delete ALL cables associated with the

selected Backbone. If you are just trying to delete a

single cable you should do that from the Cables

database.

Refresh Query the database and reload the data into the grid.

Tools

Attach Document Useful for storing field survey reports and other

documents associated with this backbone. You can

attach as many documents as you need. The

documents are stored in the database. You can click

on the link provided in the grid to launch the document

into the system document reader for that file extension

(MIME Type).

Rename Source Connecotor(s) Renames the Source Connector (SrcConn) field and

any jumpers or horizontal cables attached to this

backbone.

Rename Destination Connector(s) Renames the Destination Connector (DestConn) field

and any jumpers or horizontal cables attached to this

backbone.

Rename FiberMode Renames the Fiber Mode (FiberMode) field and any

jumpers or horizontal cables attached to this

backbone.
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While a number of fields are shown in The Backbone grid, only the Statusfield & Owner field are modifiable.  All

other fields are simply shown for reference.

Note: When marking a backbone as dead you must make sure that this cable is no longer used in an active

circuit. If WireCAD detects that this backbone is still in use, you will be presented with a warning message stating

"Cannot mark a cable as DEAD that is part of an existing Circuit. Please remove the Cable from the Circuit, then

change its status. " 

Note: You will also receive a warning message if you try to delete a cable that is part of an existing circuit. You

must remove the cable/backbone from the circuit before deleting. If you wish to delete individual cores, you can do

so from inside the cables database however this information will not persist back into the CAD drawings. 

Note: When deleting a backbone in The Backbone Grid, the entire group of cables will be deleted even if you

have only selected a single core. Make sure that you want to delete the entire backbone segment before selecting

delete. 
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Note: Deleting backbones in The Backbone grid, does not adjust number sequence. If you wish to reuse deleted

backbone numbers, you will need to manually access the Next Numbers Grid and change the next available

number to the one you would like to use. Example, you have created backbones 1001,1002,1003 & 1004. The

next number in the sequence would be 1005. If you then delete 1002,1003 &1004, the Add Backbone Segment

Tool will label the next backbone as 1005. To reuse 1002, 1003 & 1004, you need to manually select these as

next in the sequence by doing so in the Next Numbers  Grid. 

3.2.1.2 How To Create a New Backbone

Explanation

The following procedure details the creation of backbones in the CMS module. Backbones are multi-core cables in

the cables database that interconnect two (or more) patch panels. 

Note: While this tool is open in your window other WireCAD users will be locked out of the Cables table of the

Project database.

1. Make sure you have used the steps above to create your Equipment , Customize your I/O and create your Cable Types

.

187

177

169
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2. Access your Equipment Library . 

3.Find the equipment you would like to use

and click [Add to Project Database Only]. 

Note: You can add as many pieces of

equipment you as you would like at this time

however you will need to have at least the 2

definitions that the Backbone are linked to. 

323
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4.  A new SysName window will pop up asking

you to verify information about this equipment.

The next available SysName will automatically

populate. 

5. Enter in your location for this equipment.

Example: Admin Basement Telephone Room.

6. If there are multiple pieces of the same

equipment in this location, you can select the

[Add Many] to create multiple pieces of

equipment at the same time.

 Note: WireCAD will automatically SysName

each piece of equipment using the next

available number in the sequence.
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7. Once you have added your equipment into

the Project Database, close your Equipment

Library .

8. Enter ABS into the command line and

press enter or click on the [Add Backbone]

button on the homepage.

9. The Add Backbone Segment window

should now be open.

10.  First select if you would like to create a 

New Backbone or Use Existing Available. 
    

323
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11.  On the From side, select your equipment

from the Patch Panel ID field. 

Note: You can filter your results using the

Location Filter field. This allows you to select

only equipment listed in a location that was

specified during SysName Assignment.

12. On the To side, select your equipment

from the Patch Panel ID field. Again, you can

filter your results using the Location Filter

Field.  

13. On both sides, ports that are available will

be shown in white while ports that are

currently being used will show as pink. 
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14. From the Cable Type field, select the

Cable Type you would like to use as your

backbone. 

Note: If you have not already created a Cable

Type for your backbone, you can do so by

clicking the [+] sign and following the

instructions here .

15. Select the ports you would like to use on

the From side, then select a starting port on

the To side.

 

Note: You will see that WireCAD will

automatically draw a backbone based on your

port selection and Cable Strand count. NOTE:

See * Below!

16. Click [Apply]. WireCAD will create this

backbone and then revert to an empty page

ready for another backbone assignment.

 

*Note: Always make sure that you are not overlaying on used ports and that the ports coming in are not the same as the ports

going out. Example: If you have a Patch Panel with 24 Ports in and 24 Ports out,  you could use ports 1-12 as your incoming

ports and 13-24 as your output ports. This allows the other 12 ports on each side to be used for jumpers to other equipment

while maintaining a backbone infrastructure. 

170
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3.2.1.3 Backbone Visualization Settings

Before You Start:

In order to preview Backbones you will first need to Add Backbones

These settings determine the display of the Backbones Visualize  tool.

Layered Digraph Mode Data Source

Show All Shows all backbones in the database in the Visualize tool

130

142
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Current Record Allows selection of only those backbones that touch the selected record. 

Search Depth How many branches deep are we going to search. 

Search Width How many backbones per branch.

Appearance

Location Marker

Spacing

Location Marker

Text Height

Location Marker

Color

Junction Dot

Radius

Vertical

Backbone

Spacing(DU)
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Center Label

Format

String used to create the center label. Can make use of the following variables:

{0} = Backbone Number

{1} = Total Count

{2} = Total Available Count

{3} = Total Dead Count

{4} = Single Mode Fiber Count

{5} = Available Single Mode Fiber Count

{6} = Dead Single Mode Fiber Count

{7} = Multimode Fiber Count

{8} = Available Multimode Fiber Count

{9} = Dead Multimode Fiber Count

Example:

assume that our backbone number is 1001 with 12 single mode fibers of which 1 is dead and

four are in use.

String:

B{0}-SM COUNT:{4} Avail:{5} Dead:{6}

Output:

B1001-SM COUNT:12 Avail:8 Dead:1

String:

B{0}

Output:

B1001

Center Label

Offset

Offset from center in DU

Show

SysNames

Shows the SysName labels
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Ignore Same

Locations

Hides backbones that originate and terminate in the same location

SysName

Rotation Angle

Sets the rotation angle of the SysName label if shown

SysName Text

Height (100th

DU)

Sets the height of the SysName text if shown

SysName Text

Offset

Offset from the endpoint of the backbone

Riser Diagram Mode

Campus and

Building

The Campus and Building for which to build the riser diagram



WireCAD v8 User Manual140

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Layout 

Max Columns, 

Column

Spacing,

Minimum Row

Height

Determine the layout of the panels in the diagram

Body Color,

Body Width,

Descriptor

Locations

Determines the appearance of the body of the panels in the diagram

Show Terminals

if Backbone

Leaves the

Building,

Terminal Offset

If the other end of the Backbone is not in the selected building a terminal will be placed and a

backbone drawn to it. The terminal's position from the port on the panel is determined by the 

Terminal Offset property.
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Apply Jumps

Avoid Other

Cables

Instructs the cable autorouter to attempt to avoid other cables.

Show

Unresolved

Backbones

If the Backbone cannot be placed in the drawing a list is generated. Enabling this setting

shows the list as the function completes.

Title and Comment Block

Show Title Sets the visibility of the title/comment block

Title Position

Show Time

Stamp

Title Text

Height (100th

DU)

Title Offset

Title
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Misc.

Backbone Color

by Signal Type

Pulls the backbone color from the global Signal Types database.

Show

Directional

Coloring

Shows green dots for the source end of the backbone and red dots for the destination end if

shown.

Backbone Color Sets all backbones to the color defined.

[Reset Default] Button to reset the settings to the defaults.

3.2.1.4 Backbone Visualization Layered Digraph Ouput

The Backbone Visualization tool creates a layered digraph showing the backbones horizontally and the locations

in which they originate and terminate vertically.

The backbones displayed, and many of the display parameters can be set using the [Visualization Settings] 

tab.

136
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3.2.1.5 Backbone Preview Export

Exporting the CAD preview of the Backbones Visualization tool is as easy as clicking the [Export] button. 

Note: The current preview will be exported based on the Export Settings found in the Application Menu > Settings

[Project][Export Settings]  tool.

3.2.2 Circuits

A circuit in WireCAD is defined as a collection of cables. Each circuit may have a Name, Description, and other

meta data. A circuit also has a strand count to indicate the number of connections made from the originating

device on through to the terminating device. Circuits have a one-to-many relationship with the cables in the Cables

database. Each circuit may have many cables but a cable can belong to only one circuit.

193
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3.2.2.1 Circuits Grid

The Circuits Grid presents the overall circuit data in list form with the child cable data attached for view.

Open the Circuits grid by double-clicking the icon in the Project Explorer [Project Databases][Circuits]

Command Line Shortcut: cmscg

Tools

Attach Document Useful for storing field survey reports and other

documents associated with this circuit. You can attach

as many documents as you need. The documents are

stored in the database. You can click on the link

provided in the grid to launch the document into the

system document reader for that file extension (MIME

Type).

Rename Circuit Renames a circuit and all of its cables

Combine Circuit See the topic Combining Circuits .167
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Strand Count and Ordinal Explanation

WireCAD uses the strand and ordinal to know the exact position of a cable in a circuit. Strand 0 will always be the

topmost cable in the circuit with Strand n being the bottommost cable in a circuit. Ordinal 0 will be the leftmost set

of cables in the circuit with Ordinal n being the rightmost set of cables in the circuit.

3.2.2.2 New Circuit Tool

The New Circuit tool is used to connect Field End & Head End Equipment together by adding jumpers between

existing Backbones. Each circuit is comprised of descriptive data, such as Name, Customer, IT System or

Description, source and destination equipment (SysNames); as well as a collection of cables in the Cable

database. You simply select the ports that you wish to jumper from/to and add the jumpers/back bone segments

to the Proposed Cables list. A Path Finder tool helps you search out possible routes. A [Preview] window

presents the functional block view of the Proposed Cables. Once you are happy with the circuit, simply click

[Build] and all Proposed cables will be added and associated to the named circuit.

To open the New Circuit tool open the Circuits grid and click File>New

Command line shortcut: nc
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Note: While this tool is open in your window other WireCAD users will be locked out of the Cables table of the

Project database.
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3.2.2.2.1  Create New  Circuit

Before you Start

The use of this tool assumes the following:

That you have added Backbones to the project.

That you have added the necessary Cable Types to the global Cable Types .

That you have an idea of what you want to connect together and that you know the first bit of infrastructure to

which you will attach.

That you have created your Customer Furnished Equipment(CFE) in the Equipment Library  for the originating

and final destination equipment devices and/or that SysNames have been created for each individual piece of

equipment to which you will attach.

419
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How to create a New Circuit

 

1. Verify that you have created all your Equipment and Cable Types needed for this circuit.

2.  From the Circuits Grid click [File>New] to launch the New Circuit tool.

3. Verify that your

Circuit Number/

Name is correct and

that it is not

duplicating an

existing entry.

4. Enter your IT

System and

Customer info.

Note: IT System is

required. You will

not be able to 

[Build] without an

entry.
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5. Select your 

Origin(named

equipment) from the

drop down menu on

the left. Alternately,

select the Origin

CFE (Customer

Furnished

Equipment) and fill

in the detail data in

the dropdown.

6. Select your Final

Destination

System (named

equipment) from the

drop down menu on

the right.

Alternately, select

the Final

Destination CFE

(Customer

Furnished

Equipment) and fill

in the detail data in

the dropdown.
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7. Select your 

Jumper To

Equipment. This

will be the first

Patch Panel to

which your Origin

system will connect.

8. Select the ports

from your Origin

equipment and the

Ports on your

Jumper To

equipment. You will

see that WireCAD

creates a preview

jumper between the

2 for you to verify

correct

connections. 

Note: You can only

create a jumper set

that matches the 

Cable Strand

Count set in step 3.
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9. Click [Add

Jumper].

Note: If you have

connector types that

WireCAD believes

do not match, you

will be presented

with a window

stating "Connector

String Mismatch". If

you want to turn this

message off, you

can do so in the 

Application Menu

>

Settings>UserCMS.

10. Click the

[Next>] button. 
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11. Verify that a

Backbone exists

between the correct

Patch Panels. 

Note: WireCAD will

automatically

populate an available

route between Patch

Panels using

existing Backbone

structures. 

12. Click [Add

Backbone

Segment].

13. Verify the

correct cables have

been added to the 

Proposed Cables

In Circuit list. Then

click [Next].



WireCAD ENTerprise CMS Tools 153

© 2015 Holbrook Enterprises, Inc. dba WireCAD

14. From this point,

you can create

additional Jumper

To equipment, and

place jumpers and

backbone segments

using steps 5-11. 

15. When you are

ready to complete

this circuit, select

the [Last] button.

The Final

Destination

equipment will

populate the 

Jumper To the list

for selection of the

final set of jumpers.

16. Select your last

set of ports on both

sides and click [Add

Jumper].
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17. If you would like

to see a Functional

Block Diagram

preview of this

circuit, click the

[Preview] tab.

Note: Preview will be

generated with 

Project Settings.

 .

18. Click the [Build]

button to finalize this

circuit.

Note: If you have not

filled in the required

fields or if the circuit

Number/Name is

not unique the

[Build] process will

not continue. Look

for the  icon to

indicate fields that

require attention
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3.2.2.2.2  Path Finder Tab

Explanation:

The Path Finder tool can be used to find available ports and backbone segments from a source to a destination.

The Path Finder tool will search the backbone structure for backbones that can be used to get from the source

panel to the destination panel, then once a route is established the route candidate is checked for available port

count. If all criteria are met the route is returned.  If no routes can be established you will be notified.

2 possible routes returned each with 6 segments. We will use Route 0.
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After adding Route 0

Path Finder 

From Pre populated by your selection with the last jumper

added in the Build tab.

Last Existing Select the last existing piece of infrastructure that we

will search for.

[Find] Start the search.

[Cancel] Cancel the search.

Use Route Number Once routes are returned for selection this dropdown

will be populated with the available routes.

[Add Selected Route to Circuit] Once you have selected a route this button will enable

for you to add the route to the Proposed Cables to Add

to Circuit list on the[Build] tab.

Search Depth How deep to search more will take longer but find more

routes
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Search Width Maximum candidate routes to search

Show All Show all routes found and populated with jumpers

Show Backbones Only (for research) Show only the backbones without jumpers. Useful for

research.

Show Only First Path Found Stop searching when the first route is resolved.

Show Only Least Link Path Search all then prune the list to the route with the

shortest number of segments.

Found Paths Grid

Cable No Prefix, Cable No, SRC Sys, Dest Sys, Src

Pin, Dest Pin, Src Loc, Dest Loc

Fields pulled from the Cables database or populated by

jumpers that would need to be created to complete this

circuit along this route.

Ckt Strand Number For more information about circuit strand and ordinal 

see here .Ckt Ordinal

Route Number The router may find multiple paths or none. If paths are

found they will be returned with a route number. You

may then select the which, if any, route to add to the

circuit.

Made It Indicates that the route made it to the destination. All

routes shown will show Made It on the last segment.

145
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3.2.2.3 Circuits Preview Settings

Appearance

Source, Middle and

Destination Shape

Choose one of the 16 stock shapes

Source, Middle and

Destination shape Width in

(100th DU)

How wide is it

Source, Middle and

Destination shape Color

Set the color of the shape
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Source, Middle and

Destination shape Descriptor

Locations

Drag the descriptor to the

location map or to the Hidden

Items list to hide.

Backbone Color

Sets the colorJumper Color

Horizontal Cable Color

Merge and Center Text in

Body

Text Height controls the height of all text in the visualization.

Layout

Max Columns The maximum number of blocks placed before a new row is started below.

Column Spacing The distance between blocks

Row Spacing The Distance between rows
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Title and Comment Block

Show Title

Title Position

Show Time Stamp

Title Text Height (100th DU)

Title Offset

Title You can type whatever you want in this field. In addition the following

variables are available:

{0} = Circuit Number

{1} = It System

Misc.

Show Attenuation Labels Show field survey labels in the CAD preview

Show Jumper Length Labels

Show Backbone Length

Labels

Show Jumper Numbers

Show Backbone Numbers

Show Length
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3.2.2.4 Outputting Circuits to CAD

Once a circuit has been defined you can create CAD views of single and multiple circuits. The tools to do this are

contained in the Circuits Grid which you can access from the command line shortcut CMSCG or by selecting

the [CAD Preview/Circuits Grid] on the home page.

Before accessing the Circuits Grid, please make sure to setup your export preferences in the settings menu.

Please refer here  for more information on the settings menu. 

You can also batch output the selected records by clicking Tools>Output Selected. 

Note: All export is governed by settings in the Application Menu > Settings[Project][Export Settings] tool.

Export Output to file based on the Export Settings found in 

Application Menu > Settings [Project][Export

Settings]

Copy to Clipboard Copies the preview to the clipboard so it can be pasted

into another drawing.

188
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3.2.2.5 How to Output a Circuit to CAD

This step by step will guide you on exporting a circuit. 

1. Open the Circuit Grid by entering

CMSCG in the command line prompt.

The Circuit Grid Window will open. 

2. Select the Circuit Number you would

like to Export. 
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3. Select the [Preview] Tab.

4. Verify the circuit is the one you would

like use and click [Export].

5. A Windows explorer window will come

up. Enter where you would like to export

to, what you would like this file to be

called and what file type you would like to

export as.

Note: All of these settings can be

automated in the Settings Menu. 
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6. Click [Save]. Your exported file will now be created and placed in the location you have specified of the file

type you specified in the Save As Dialog filter. 

3.2.2.6 How to Output Many Circuits to CAD

This Step by step will guide you on exporting multiple circuits. 

Note: this is different from the command Tools>Output All Selected Circuits

1. Open the Circuit Grid by entering CMSCG in the

command line prompt. The  Circuit Grid Window will

open. 
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2. Select the Circuit Numbers you would like to

Export. 

Note: You can select multiple circuits by dragging

down with your mouse clicked, by holding [Shift] and

selecting a set or by holding down [CTRL] and

selecting multiple records individually. 

3. Select the [Preview] Tab.

4. Verify the circuits shown are the ones you would like

use and click [Export].
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5. A Windows explorer window will come up. Enter

where you would like to export to, what you would like

this file to be called and what file type you would like to

export as. 

Note: All of these settings can be automated in the 

Settings Menu. 

6. Click [Save]. Your exported file will now be created

and placed in the location you have specified. 
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3.2.2.7 Combining Circuits

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have the same

Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted will be discarded.

This Circuit The Circuit Name/Number of the circuit that will be appended or inserted into another circuit. This

circuit Name/Number will be discarded if successfully appended or inserted.

Appends To The Circuit Name/Number of the circuit that will be appended to.

Inserts Into The Circuit Name/Number of the circuit that will be inserted into

Before Before this SysName

After After this SysName
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Insert Jumpers if

Necessary

It is possible to create collections of cables in a circuit that do not interconnect. If you do not

select this option you will create collection of cables that do not interconnect.

Preview

[Commit] Do it. 

[Cancel] Dump out without any changes.
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3.2.3 Cable Types

In order to create a Backbone segment in WireCAD, you will need to create a Cable Type with the correct amount

of Cores.

This will guide you through creating a new Cable Type . 419
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3.2.3.1 Creating a New Cable Type

Wiki Links:

Cable Management Specific Features and Functions

http://wirecad.com/wiki/index.php?title=Cable_Management_System_Specific_features_and_functions

http://wirecad.com/wiki/index.php?title=Cable_Management_System_Specific_features_and_functions
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1. In your Project Explorer,

double click the Cable Types

Database.

2. Click the New Icon. (This is

the blank paper icon next to the

diskette save on the top left of

your screen.)
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3. A new window will pop up

asking for information on this

cable type. 

4. Fill in all information about this

cable including Manufacturer,

Cable Type or P/N &

Description. No other fields are

required but are available to use

at your discretion.
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5. If this cable is a multi core

cable, you will need to check

the Is Multi Core box and select

how many cores are in this

cable.

6. Select the [Default

Core\Fiber Mode]. 

Note: To label specific cores as

SM or MM, see step 8.

7. Click the [Save] icon

(diskette). 

If you need to define SM and

MM, please follow steps 8. 
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8. From your main WireCAD

window, select your Cable Types

database from the global

database field. 

9. Using the filter icon on the

Cable Type column header, 

select your cable from the drop

down menu. 

10. Use the [+] button to expand

and show all cores.
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11. Double click in the Fiber

Mode field and enter SM or MM

for this strand. 

Note: If a series of cores are the

same Fiber Mode Type, you can

highlight the top one, drag down,

and press CTRL+D to

automatically populate additional

fields.

12. Click the [Save] button

(diskette) to save changes.
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3.2.4 Equipment

<%APPVER%> for ENTerprise has been pre-populated with devices specific to fiber operations.

If you are unable to find your specific equipment, you will need to create a new Equipment Definition.

This section will guide you through creating a new Equipment Definition, adding & deleting I/O ports and modifying

display preferences. 
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3.2.4.1 Creating a New Equipment Definition

Wiki Links:

How To Access Your Equipment Library

http://wirecad.com/wiki/index.php?title=Accessing_Equipment_Library

How To Add a New Manufacturer To Library

http://wirecad.com/wiki/index.php?title=How_To_Add_A_New_Manufacturer_To_Library

How To Create A New Equipment Definition

http://wirecad.com/wiki/index.php?title=HOWTO:New_Equipment_Definition

How To Customize Your Equipment I/O

http://wirecad.com/wiki/index.php?title=Customizing_Equipment_I/O

1. Click Advanced Tools>Equipment Library OR

Database>Equipment Library OR Command Line

shortcut LE.

2. Use the search/find bar to first determine if your

equipment is currently in the library.

http://wirecad.com/wiki/index.php?title=Accessing_Equipment_Library
http://wirecad.com/wiki/index.php?title=How_To_Add_A_New_Manufacturer_To_Library
http://wirecad.com/wiki/index.php?title=HOWTO:New_Equipment_Definition
http://wirecad.com/wiki/index.php?title=Customizing_Equipment_I/O
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3. On the right hand side of the screen, you will see

multiple buttons including [Add Manufacturer To

Library] & [Add Equipment To Library]. (If your

manufacturer is not listed, please see the section

titled Add Manufacturer to Library.)

4. Click [Add Equipment to Library].

5. In the dialog window, start by selecting the

Manufacturer field and select who makes your

equipment
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6. Enter in the Model/Equipment Name of your

Equipment.

7. In the Description field, enter something that will

describe this type of equipment. Example: Laptop,

Desktop Computer, Router,  LCD Display etc.

8. The SysName Prefix field is how the SysName will

be shown after a SysName assignment. Example:

Field Laptop = FLD LPT, Desktop Router = RTR, ect.

9. Click [Next]. 



WireCAD v8 User Manual180

© 2015 Holbrook Enterprises, Inc. dba WireCAD

10. The wizard will advance to the next page asking

you to add a Front Panel File, Image, Category &

Synonym. None of these fields are required; however, if

you plan to use the Rack Builder  tool it is advised

that you enter a Front Panel file.

11. Click [Finish]. 

12. You will now be taken back to the Equipment

Library  with your new equipment in the grid. 

13. Select the I/O Tab.

345

323
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14. In the middle of the screen, Click The [Add Ports]

button.

15. Enter in all port information including Name,

Connector Type, Signal Type, Pin Style, etc. Do

this for all ports on this device. 

Note: You can add multiples of the same port type by clicking the Add Many checkbox and entering in how

many of this specific port you would like. WireCAD will append a port number to the string in the Name field.

Example: with the Inputs radio button selected, enter the value PORT- into the Name field, check the Add

Multiples and set the Starting Number to 1 and the Count to 32. Click [Apply] and 32 records will be created in

the Inputs list. The name field will be populated with the values PORT-01 through PORT-32.

16. When you are finished, click [Apply] to add the

ports and leave this dialog open or click [Add Ports

and Close] to add the ports and close this dialog.
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3.2.5 Projects

This section will guide you on how to create a New Project using a SQL Server Database.

You will need to have your network administrator or IT department set up a SQL Database and create user access

for all WireCAD users who will have access to this Database.
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3.2.5.1 Creating a New SQL Project

Wiki Links:

How To Create a New Project

http://wirecad.com/wiki/index.php?title=HOWTO:New_Project

How To Move A Project To A Different SQL Server

http://wirecad.com/wiki/index.php?title=HOWTO:MoveProjectServer

Create a New Project

1. With WireCAD open, click 

Application Menu > New Project.

http://wirecad.com/wiki/index.php?title=HOWTO:New_Project
http://wirecad.com/wiki/index.php?title=HOWTO:MoveProjectServer
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2. A new window will open saying

“Welcome to the New Project Wizard”.

Click [Next].

3. On the next page, select Use

Database Server (SQL Server) and

click [Next].
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4. Enter a Project Name, Description

and select a Project Files Path. This

is where your project files will be

saved. This is different than your

Database files and will not be located

in the same directory. It should be on a

network share visible to other users of

the project. Click [Next].

5. Enter in your SQL Server database

information and click [Next].

Note: Please contact your IT

department if you are unsure of any

information required on this page.
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6. Verify that all information looks

correct and click [Next].

7. Wait for WireCAD to build your

project and then click [Finish]. You are

now ready to start working in your new

SQL Project.
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3.2.6 Next Numbers Grid

The Next Numbers Grid will show you the next available Cable number based on your Cable Number Format. To

access the Next Numbers Tool, type NN in the command line prompt. 

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As you progress

through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number box and fill in

the desired number. Be sure that you are not entering a number that is already in use. 

Note: Yours will look different as the Next Numbers grid will automatically create entries for each new sequence

used by the application.
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3.3 Settings and Options

The following settings are specific to WireCAD ENTerprise.

To access the settings menu, click Application Menu > Settings. Then select one of the three default sets of

settings Application, User or Project by clicking on the down arrow.

Note: Third party plugins may register their own settings categories and panels. Shown are the stock settings.
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Topic Sub Sections

User Settings

Project Settings

3.3.1 User Settings

These are the additional user settings that pertain specifically to the CMS module.

Application Menu > Settings[User][CMS User]

189

191
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Use Stock WireCAD Startup Page

Note: Doing this will remove all buttons and

functionality of the startup page requiring you to use

the command line shortcuts. 

This will change your Startup page from the CMS specific

page to the default WireCAD page. 

Default New Circuit Strand Count

When creating a new circuit, a default strand count for

jumpers is created. This will change that strand count to

a different value. 

Warn Of Connector String Mismatch Having this box checked will allow a warning message to

display anytime WireCAD detects that 2 ports being

connected have a different connector type. 
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3.3.2 Project Settings

These are the additional project settings that pertain specifically to the CMS module.

Note: You will need to have an open project in order to access these settings. 

Note: These settings are project specific and will need to be created for each new project. 

Application Menu > Settings[User][CMS User]

Default New Backbone Status
When creating a backbone, you have the ability to mark a

"status" on that backbone such as "In Use", "Proposed"

ETC. Using the [+] button, you can create new status

items. Selecting a status will cause that to become the

default for all backbones in this project. 
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Default New Circuit Status
Just like above, when creating a Circuit, you have the

ability to mark a status on that circuit. Again, using the

[+] button, you can create a new status. 

Backbone Number Format The variable {0} contains the next number in the Next

Numbers grid for Backbones.

Define the string format of the next Backbone number. 

Circuit Number Format The variable {0} contains the next number in the Next

Numbers grid for Circuits.

Define the string format of the next Circuit number. 

Jumper Number Format The variable {0} contains the Circuit base number.

The variable {1} contains the Strand Number of the circuit

for this jumper

The variable {2} contains the Ordinal Number of the circuit

for this jumper.

Define the string format of the next Jumper number. 
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3.3.3 Output Settings

Application Menu > Settings[Project][Export Settings]

Use Template Path to to a template drawing that the output will be exported into. Your template

drawings can contain any page borders or layouts and settings that you wish.

Always Ask for Filename

and Path

You are involved in the filename selection and path

Circuit File Name Format Sets the file name format for Circuit output.

{0} = Circuit Name

Backbone File Name

Format

Sets the file name format for Backbone output.

{0} = Backbone Number

File Format Presets the output format.

Path Where do we output.
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Create Folders for Each IT

System

Create a new folder for each IT System and output the preview to that folder.

Automatically Overwrite

Files of Same Name

Self-explanatory

Append Date Stamp to

File Name

Circuit Post Process Script Path to a c# file which will be run post export but pre write-to-disk. See the Post 

Process Scripts  topic for more information.
Backbone Post Process

Script

3.3.4 Post Process Scripting

Post Process Scripting of the output of the Visualizers in WireCAD allow you to customize the final appearance of

the created document.

What follows are two example scripts, one for the Circuit output and the other for the Backbone output. The

process is the same for both. Only the method signature is changed.

Circuits Export Script Example

//////////////////////////////////////////////////////////////////////////////////

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using System.IO;

using WireCAD;

using WireCAD.Interfaces;

using VectorDraw.Professional.vdObjects;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdPrimaries;

using VectorDraw.Professional.vdCollections;

using WireCAD.ProjectFile.DAL;

using VectorDraw.Geometry;

/// <summary>

/// Fill your titleblock with your data

194
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/// </summary>

//Your class name

public class TitleBlockFiller

{

//the method signature is key so this next line must appear as shown

public static void Run(Workspace ws, Circuits c, vdDocument doc)

{

string drawingName = Path.GetFileName(doc.FileName);

//change this next line to be your titleblock name

string BlockNameToUpdate = "ansi";

//Get the layout by name that we want to update

vdLayout layOut = doc.LayOuts.FindName("ANSI_B");

//loop through the entities in the layout

foreach (vdFigure figure in layOut.Entities)

{

//if we find a viewport let zoom it to the extents of our model

if(figure is vdViewport)

{

vdViewport vp = figure as vdViewport;

vp.ZoomExtents();

vp.Update();

}

//now look for our titleblock

if (figure is vdInsert)

{

//cast our base figure into an insert object so we can access its

properties

vdInsert insert = (vdInsert) figure;

//now we will test to see if the insert name is one that 

//we know to be a titleblock

//Modify this to meet your needs

if (insert.Block.Name.ToLower().Contains(BlockNameToUpdate))

{

//need to fix it.

//this next bit makes it insert get the latest version from

the blocks table

insert.Update();

insert.Invalidate();

//we got one so let's set the attributes

//we will use the safeSetAttribute function so that if the

attribute doesn't exist it won't 

//fail

//Modify this to meet your needs

//Enter your Attribute names and the values you want to fill

them with

                           

ws.Utilities.SafeSetAttributeValue(insert, "SHEET", layOut.

Name);

ws.Utilities.SafeSetAttributeValue(insert, "Drawing_Name",

Path.GetFileNameWithoutExtension(drawingName));

ws.Utilities.SafeSetAttributeValue(insert, "DWG_Number", c.
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CktNO);

ws.Utilities.SafeSetAttributeValue(insert, "COMPANY", "Slate

Gravel Co");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS",

"Number 1 Quary Way");

ws.Utilities.SafeSetAttributeValue(insert, "ADDRESS2",

"Bedrock - The World");

ws.Utilities.SafeSetAttributeValue(insert, "DATE", DateTime.

Now.ToShortDateString());

ws.Utilities.SafeSetAttributeValue(insert, "Scale", "NTS");

insert.Update();

insert.Invalidate();

doc.Redraw(true);

}

}

}

//Now create a text item that displays our circuit number in the upper righthand

corner

vdText t = new vdText(doc);

t.TextString = string.Format("CKT - {0}\n{1}",c.CktNO, c.CktDescription);

t.HorJustify = VectorDraw.Professional.Constants.VdConstHorJust.VdTextHorRight;

Box bb = layOut.Entities.GetBoundingBox(true,true);

t.Height = .25d;

t.InsertionPoint = new gPoint(bb.Right-3,bb.Top-2);

layOut.Entities.AddItem(t);

doc.ActiveLayOut = layOut;

           

}

}

Backbones Export Script Example

The only difference in the two examples is the method signature. Use the code above replacing:

public static void Run(Workspace ws, Circuits c, vdDocument doc)

With:

public static void Run(Workspace ws, CMSSettings settings, vdDocument doc)



Part

IV
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4 Reference

4.1 Ribbon Tabs and Dialogs

This section provides a reference to the individual controls in the dialogs accessed in the Ribbon Toolbar. 

Only dialogs that need explaining are documented

Please note that although this reference is quite complete, only dialogs that really need explaining are

documented. For example, we assume that you can figure out what menu entries like Save and Save As do for

yourself. 

This also applies to simple dialogs whose functions are explained elsewhere. Some of these dialogs are listed, but

only with references to the relevant topics in the Procedures sections.
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4.1.1 The Workspace

The WireCAD workspace has four main components: The Application Menu at the top of the screen, the Ribbon

Toolbar where you access all program functions, the Tool Panels collection for navigating and managing your

projects and the Main Window where you edit the content of your projects. The Main Window can display four

distinct environments:

1. The Drawing environment

2. The Data environment

3. The Reporting environment
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4. The PDF viewer environment

The Application Menu and Quick Access Toolbar

The Application Button in the top left corner of the Help & Manual window is one of the most important

controls. It provides access to the functions normally accessed in the File menu in menu-based programs. This is
where you open existing projects, create new projects, save your projects under other names and so on.

The Quick Access Toolbar next to the Application Button is a place for frequently-used tools.
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 The Ribbon Toolbar

The Ribbon Toolbar is the control center where you access virtually all of WireCAD's functions. If you use
Microsoft Office 2007 you will already be familiar with the Ribbon interface. It is context-sensitive, automatically
displaying functions relevant to what you are currently doing.

Tip: The Ribbon can also be operated almost entirely via the keyboard. To display the accelerator keys just press
and release the ALT key once – the keys will be displayed in icons superimposed on the Ribbon.

Tool Panels
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Tool Panels are organizations of controls. There are different Tool Panels depending on the current
environment.

The Project Explorer Tool Panel

The Project Explorer is like Windows Explorer for WireCAD projects. When you load or create a

project all its contents are displayed here, including both the Global Equipment tables and the Project

Databases  and files.

Note: This tool panel is active at all times.
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The Draw Cables Tool Panel

The Draw Cables Tool Panel  contains all the tools for drawing cables. You can draw cables with

different relationships. You can also set the drawing behaviour of cables.

Note: This tool panel is only active when the current environment contains a drawing.
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The Drawing Properties Tool Panel

The Drawing Properties Tool Panel allows editing of granular drawing settings. If no entity selection

exists in the drawing the Drawing Properties window will display the general document properties.

Note: This tool panel is only active when the current environment contains a drawing.
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The Find and Replace Tool Panel

The Find and Replace Tool Panel allows you to search the current drawing, all drawings and the

project databases for text and replace that text with your entered values.

Note: This tool panel is active at all times.
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The Plan View Tool Panel

The Plan View Tool Panel allows you to place plan view symbols in your drawing.

Note: This tool panel is only active when the current environment contains a drawing.
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The Favorites Tool Panel

The Favorites Tool Panel holds blocks that you have saved as favorites (right-click entity in

drawing>Add to Favorites).

Note: This tool panel is only active when the current environment contains a drawing.

The Command Line Interface

The Command Line Interface allows you to see the command history, receive prompts from the application and

execute commands directly. For a full list of command line command you can view/edit the Application

Menu>Settings[User][Commandline Shortcuts] grid.
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4.1.2 Ribbon Tabs

4.1.2.1 Application Menu

The Application Menu contains the following static menu functions:

Top Menu Sub Menu Description

New Project... Displays the New Project Wizard.

Open Project Display a file open dialog. Browse to and select a *.wc6plf file to open the

WireCAD Project.

Save Project

As...

Displays the Save Project As  dialog. Use this to create a copy of the

current project in a different location.

Close Project Closes the current project.

Frequently

Used Folders

Project Folder Opens the root folder of the current project in a window explorer window.

Global Data

Folder

Opens the global data folder. C:\Users\Public\WireCAD\WireCADx

User App Data

Folder

Opens C:\Users\<YOUR USER NAME>\AppData\Local\WireCAD\WireCADx

Security Tools View

Permissions

Shows the permissions grid.

Manage

Security...

Shows the Users Groups and Permissions dialog .

Check In/Out Pack Up /

Check Out

Packup/check  out utility. Collects all info for the project and makes is

portable.

Unpack

Project ...

Unpack a project.

233

239

242

246

248
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Check In

Project

Check in a Checked Out project .

Project Info Project specific info  like the current revision and related projects list.

Account Info Who is the project for .

Application

Setup

Displays the Application Setup Wizard . This is show once on startup but

you can review and change settings here.

Settings Displays the main Settings  dialog.

Exit Exits the program.

4.1.2.2 Project

The Project Ribbon Tab is a static menu structure. It does not change with environment changes.

The Project Ribbon Tab contains the following menu items:

Menu Item Sub Menu Description

New

Project ...

Display the New Project Wizard

Open Project Display a file open dialog. Browse to and select a *.wc6plf file to open the

WireCAD Project.

Close Project Close the current project

Recent

Projects

Most recently used projects list. This is selection is based on the Project

List setting in the Application Menu>Settings[Project List]

Other

While WireCAD does not currently merge any other tools with the Project menu, authors of WireCAD plugins have

the ability to merge their own tools onto this ribbon tab. Consult their documentation for information.

250

410

410

252

261

233
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4.1.2.3 File

The File Ribbon Tab is a dynamic menu that changes its structure with the current environment.

Drawing Environment

Again, we will not explain the obvious ones.

Menu Item Sub Menu Description

New

Drawing ...

Shows the New Drawing Wizard

Save Drawing

Open Drawing Browse to a drawing.

Save Drawing

As

Close

Drawing

Close All

Drawings

Save As

Template

Drawing

Any drawing may be used as a template from which other drawings may be

created. Simply Save As Template Drawing to make your drawing usable in

the New Drawing Wizard as a starter drawing.

Print

Preview ...

Display the Print Preview  dialog.
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PDF Export ... Display the PDF Export  dialog.

Export to

Visio

Create smart Visio drawings  where the WireCAD cable become live active

Visio connections. 

Undo

Redo

Clip Copy

Clip Cut

Clip Paste

Settings ... Display the main Settings  dialog. Same as clicking Application

Menu>Settings.

Purge ... Purge  unused entities from the drawing.

Data Environment

Menu Item Sub Menu Description

New A new item in the collection.

Save

Print

Export XML

HTML

TEXT

XLS

Exit
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Undo

Redo

Refresh

Clear Data

[Del]

Delete

Selected

Rows

Copy Down

[Ctrl]+[D]

Increment

Down [Ctrl]+[I]

Find and

Replace

Tool1 See Grid Specific Functions for a listing of the tools available to each data

grid.

Tool2

Tool3

Tool4

Other

While WireCAD does not currently merge any other tools with the File menu, authors of WireCAD plugins have the

ability to merge their own tools onto this ribbon tab. Consult their documentation for information.
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4.1.2.4 Drawing

Active only when the current environment is a drawing.

Menu Item Sub Menu Description

Grid Mode Toggle the visible grid [F7]. Note: the visible grid is rendered only for the

Drawing Limits which can be set in the Drawing Properties Tool Panel.

Snap Mode Toggle the invisible snap grid [F9]. The invisible snap grid is based on the

SnapX and SnapY settings in the Drawing Properties Tool Panel.

Polar Track

Mode

Toggle PT mode. When enabled and in a function requesting a point from the

drawing the selectable polar angle will be restricted to the Polar Track Angle

in the Drawing Properties Tool Panel.

Ortho Mode Toggle restrict movement to horizontal/vertical only.

Coordinate Displays the cursor position in current coordinates. Coordinates are

expressed in drawing units (DU).Drawing units do not express particular units

(meters,inches etc).

In this part user have to make some assumptions in order to define that the

coordinates of the drawing mean particular units(meters,inches etc).

For example:

For a mechanical drawing we can make the assumption for example: where

one drawing unit defines one millimeter(1 D.U=1mm)

For a architectural/technical drawing we can make the assumption for

example: where one drawing unit defines one meter(1 D.U=1m) or one foot.

This can be very helpful in designing,dimensioning,retrieving information from

the drawing(distances,area calculations)

GripBlockStd Show only one grip per insert.

GripBlockAtts Show one grip per attribute in the selected insert.

Layers ... Shows the Layers  dialog.299
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Layouts ... Shows the Layouts  dialog.

Point

Styles ...

Shows the Point Styles  dialog.

Text Styles ... Shows the Text Styles  dialog.

Dim Styles ... Shows the Dimension Styles  dialog.

Model Space

Bounds

Shows the Model Space Boundaries  dialog.

Groups ... Shows the Groups  dialog.

Images ... Shows the Images  dialog.

UnSelect Clears the current selection. Same as pressing {esc}

Select Start a selection

Erase Erase the current selection. If no selection then you will first be prompted to

select entities.

Copy Copy the current selection. This is a base-point or offset copy and is preferred

over [Ctrl][C] then [Ctrl][V] if copying in the same drawing as it is lighter

weight. If no selection then you will first be prompted to select entities.

Move Move the current selection. If no selection then you will first be prompted to

select entities.

Scale Scale the current selection. If no selection then you will first be prompted to

select entities.

Rotate Erase the current selection. If no selection then you will first be prompted to

select entities.

Mirror Mirror the current selection. If no selection then you will first be prompted to

select entities.

Stretch Stretch polylines in the current selection. If no selection then you will first be

prompted to select entities.
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Explode Explode the current selection. This function will reduce complex object to their

primitive constituent parts. For example; exploding an insert unlinks all of the

entities back one level. Exploding a polyline reduces the polyline to a

collection of line segements. If no selection then you will first be prompted to

select entities. 

Entities that can been exploded:

vdDimension explode to vdLines, vdText(s), and vdInserts (the arrows).

vdInsert explode to the entities that is consist of. (If there are Inserts inside

Blocks then you may need to apply more than 1 explode to get the base

entities).

vdPolyHatch explode to vdPolyline(s).

vdPolyline explode to vdLine(s) and/or vdArc(s).

vdRect explode to vdPolyline.

vdText explode to vdPolylines(only texts with fontfile SHX).TTF(true type

font) texts are not exploded

Trim Trim objects at a cutting edge defined by other objects the current selection.

First select the objects that define the cutting edges at which you want to trim

an object and then the object.

Objects that can be trimmed include arcs, circles, elliptical arcs, lines.

Notice that the trim command do not function if the objects do not intersect.

At the example below there are some lines that were trimmed.

Extend Extend lines,arcs,polylines until they intersect with some other object which

is used as limit of the extension.

Firstly you have to select the objects that consist the limits of the extension.

Then you have to choose a point at an object that you want to extend. If the

object you want to extend does not intersect with above objects then nothing

will happen.
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Fillet Connect two lines , two arcs, or one arc with a line(these two objects must

have at least one common point either visible, or in their extension) , with an

arc with a specific radius. The value of the radius has some restrictions

depending the position of the objects. If radius=0 then simply the objects are

either extended until they intersect each other in one point(if there was not an

intersection point) either trimmed(if an intersection point is visible).

Offset Create a new object in parallel direction and in specified distance from the

original object which is used as pattern for the new object.

When you execute offset command , you are prompted to select an object.

Then you have to specify the offset distance which is the distance that the

new object will be drawn from the original object. Then you have to set the

side that the object will be draw because there are two sides.

R Array Creates multiple copies of objects in a rectangular pattern. Shows the

Rectangular Array  dialog.

With the rectangular array you can create an array defined by a number of

rows and columns of copies of the selected object.

First you have to select the objects.Then you have to define number of rows

and number of columns of the rectangle, the distance between rows and the

distance between columns. If no selection then you will first be prompted to

select entities.

P Array Same as R Array but copies radially around a center point.

Select the objects to copy.Then set the center point and next define the

numbers of the copy objects that will be created and the fill angle. Lastly

choose if the object will be rotated or not.

BTF Bring to front. This changes the Z order of the objects in the render engine

bringing the current selection to the front. If no selection then you will first be

prompted to select entities.

STB Send the current selection to the back of the Z order. If no selection then you

will first be prompted to select entities.

Corner Causes lines that can intersect to intersect. Start the command then select

the first line then the second line.

318
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4.1.2.5 CAD Tools

Active only when the current environment is a drawing.

Menu Item Sub Menu Description

Line A single line segment.

Lines can be one segment or a series of connected segments, but each

segment is a separate line object.

Polyline 2D/3D line composed of line and arc (bulges) segments. Polyline is specified

by an array of Vertexes (points). When the Polyline has thickness then the

extrusion vector of the polyline defines the direction of the thickness.

Polylines can be Open or Closed, can be SPLine and be filled with a color or

a hatch.

Circle A full circle is defined by its CenterPoint and its Radius.

Circle is drawn in the plane that is defined by CenterPoint and

ExtrusionVector.

Point An object which occupies a single point in the coordinate system. The display

of the point is inherited from the document Point Style property and can be

set by clicking Drawing>Point Styles...

Rectangle A rectangular object defined by an insertion point, height and width.

Text Single Line of

Text

Text inherits its style from the document Text Styles collection which can be

edited by clicking Drawing>Text Styles... Text entities do not have font

properties directly but inherit the font and font properties from the associated

Text Style.

Multiline Text

(MTEXT)
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Image Frame Used to render images in the document. Images may either be linked or

imbedded in the drawing file. The image frame defines the location and size of

the displayed image. To imbed an image you must edit the document Images

collection Drawing>Images.

Construction

Ray

2 or 3 Pt Arc A circular arc defined by the center point, the radius, the start angle and the

end angle. An arc is always drawn anti-clockwise from the StartAngle to the

EndAngle.

The StartPoint and EndPoint properties of an arc are calculated through the

StartAngle, EndAngle and Radius properties.

The ExtrusionVector is always vertical to the arc. Arc is drawn in the plane

that is defined by CenterPoint and ExtrusionVector

Ellipse Draw an Ellipse.

Cloud Draw a cloud

Insert Block

Into Drawing

Opens the Inserts  dialog. You can then insert an existing block into the

drawing or browse to another file to insert in the drawing.

Write Block to

File

Writes the selected insert out to its own file prompting you for the file save as

name and location as well as the new basepoint for the drawing.

Create

Attribute

Definition

A tag/value data pair that can be included in a block to display editable text.

Make a Block Select entities and group them into a unit called a block. The block resides in

the document Blocks table. To display a block we Insert an instance of the

block into the drawing at some point, scale, and rotation.
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External

Reference

Manager

Other drawings may be displayed within the drawing space and maintained as

separate files. These are called Externally Referenced (XREFS) drawings. The

externally referenced drawing cannot be edited in the current drawing, only

viewed, positioned, scaled and rotated. 

This function opens the External Reference Manager  dialog.

Edit Attributes Allows editing of the attributes of the selected insert of a block

Blocks

Gallery

Visual gallery of the document Blocks collection. Clicking on an item starts

the Insert process.

Horizontal

Dimension

Dimensioning is the process of adding measurement annotation to a drawing.

There are many ways to dimension objects and many ways to format

dimensions. You can create dimensions for a wide variety of object shapes in

many different orientations. You can create dimension styles to format

dimensions quickly and ensure that dimensions in your drawing conform to

industry or project standards.

Dimensions show the measurements of objects, the distances or angles

between objects, or the distance of a feature from an origin you specify. There

are three basic types of dimensioning: linear, radial, and angular. Dimensions

can be horizontal, vertical, aligned, rotated,angular. A linear dimension

measuring the distance between two points which is displayed parallel to the

points being measured. In aligned dimensions, the dimension line is parallel

to the extension line origins. The extension line origins are specified using the

DefPoint1 and DefPoint2 properties.

Vertical

Dimension

Aligned

Dimension

Radius

Dimension

Diameter

Dimension

Angle

Dimension

321
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4.1.2.6 Advanced Tools

Active only when the current environment is a drawing.

Menu Item Sub Menu Description

Equipment

Library

Opens the Equipment Library .

Rack Builder Opens the Rack Builder  tool.

Assign

SysName

Assigns a SysName  to all selected inserts that are assignable.

Verbose

SysName

Assignment

When checked displays the SysName Assignment  dialog. Otherwise the

assignment proceeds with all default information.

De-Assign

SysName

De-Assign will remove the SysName data from the insert and mark the record

in the database deleted/available.

Reset

Selected

SysName

Reset will remove the SysName data from the insert and do nothing with the

database. The Reset functions are useful if you need to reuse a drawing and

reassign new numbers.Reset All

SysNames

Slurp

SysNames

Gets all of the SysName data from the drawing and adds it to the database if

not found in the database. 

Assign

Terminal(s)

Starts the terminal assignment dialog for the current selection of assignable

terminals

Drawing

SysName

Error Check

Shows the Drawing SysName Error Check  dialog.
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Assign Cable

Number

Assigns the cable  a number based on several factors:

The Project Settings[Starting Number]

Project Cable Number Format tool

Next Number sequence

The process of assignment will update drawing with the number as well as

place an entry in the project Cables table

Verbose

Cable

Assignment

When checked displays the Cable Assignment  dialog. Otherwise the

assignment proceeds with all default information.

Add Multicore

Cable

Displays the Add Multi-core Cable  dialog. There you select the cable type

number base, etc. and build an entry in the Cables table for every core in the

associated cable type marking the records available.

Draw Cable Starts the Draw Cable  function.

De-Assign

Cable Number

De-Assign will remove the Cable data from the drawing and mark the record in

the database deleted/available.

Reset All Reset All Cable Numbers in Drawing will remove the Cable data from the

drawing and do nothing to the database. The Reset functions are useful if you

need to reuse a drawing and reassign new numbers.

Recover

Cables

The Recover Cables function does the following:

Gets all cable data from the drawing

Compares it to the Cables table of the project

Updates the Cable Number information in the drawing for matches. A match

is found when the source and destination SysNames, Locations, and

Portnames match.

Drawing Error

Check

Shows the Error Check  dialog.

Tidy Cable Forces the selected cable to be orthogonal (horizontal or vertical only).

Slurp Cables Gets all of the Cable data from the drawing and adds it to the Cables table if

not found in the database. 
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Auto Block Shows the Auto Block  dialog. With Auto Block you can place functional

blocks in the drawing on a grid simply by selecting which SysName to place.

Ratsnest Shows the Ratsnest  dialog. Used in conjunction with Auto Block to wire

the placed blocks. Pulls cable data from the Cables table, searches the

drawings for matches and when found places a cable.

WireCADify

Block

Shows the WireCADify Block  dialog. Add the WireCAD attribute set to

your CAD blocks. You do not need to use this command on any WireCAD

generated block.

Add

Connection

Point

Shows the Add Connection Point  dialog. Add WireCAD Connection Points

you blocks that you have WireCADified. You do not need to use this

command on any WireCAD generated block.

4.1.2.7 View

The View tab is dynamic. It merges tools from the current environment. 

Static View

Menu Item Sub Menu Description

Tool Panels Project

Explorer
Toggle the visibility of the Project Explorer  Tool Panel

Draw Cables Toggle the visibility of the Draw Cables  Tool Panel
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Drawing

Properties
Toggle the visibility of the Drawing Properties  Tool Panel

Find and

Replace
Toggle the visibility of the Find and Replace  Tool Panel

Plan View

Tools
Toggle the visibility of the Plan View Tools Tool Panel

Favorites Toggle the visibility of the Favorites Tool  Panel

Command

Line
Toggle the visibility of the Command Line  Tool Panel

Show Start

Page

Toggle the visibility of the Start Page

Skin Gallery Select the look and feel of the application

Switch

Windows

{Current

Window Set}

Toggle the active window

Drawing Environment View

Menu Item Sub Menu Description

Pan Reposition of the view. This can be better done with the mouse wheel of your

mouse. Depress the mousewheel to click the button underneath it to activate

the PAN mode. 

NOTE: this relies on your mouse driver middle button set to default.

Zoom In
Zoom command allows the user to increase or decrease the apparent size of

objects , so the user can control the part of the drawing that is included in the

screen.

Zoom Out

Zoom Extents
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Zoom

Window

Zoom command is a transparent command.

Transparent commands are commands that can be invoked when another

command is active.

Remarks

There are several ways to execute the zoom command:

"E"(Extends) Zooms to display the drawing extents

"P"(Previous) Zooms to display the previous view

"W"(Window) Zooms to display an area specified by two opposite corners of

a rectangular window. User must specify these two corners.

"A"(All) zooms to the drawing limits or current extents, whichever is greater.

Zoom All

Zoom

Previous

Zoom Scale Show the Zoom Scale dialog. Zooms the display at a specified scale factor.

For example, entering 2 doubles the apparent display size of any objects

from what it would be if you were zoomed to the limits of the drawing.

Entering 0.5 causes each object to be displayed at half its current size on the

screen.

Regenerate Re render the entire drawing.

New Viewport Viewports are areas that display different views of your model. As you work,

you can split the drawing area into one or more adjacent rectangular views

known as model viewports. In large or complex drawings, displaying different

views reduces the time needed to zoom or pan in a single view. Also, errors

you might miss in one view may be apparent into others.

ViewPorts are treated as rectangle drawing objects which display views and

can be moved or resized.

They can be created only a layout and not in Model space.

You can also attach viewports to closed polygons (polylines, circles, ellipses,

rectangles). 

New Viewport

from Polygon

Activate

Viewport

None Turn off all object snaps. An object snap(Osnap) mode specifies a snap point

at an exact location on an object. Osnap specifies running object snap

modes, which remain active until you turn them off.

End End Point snap
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Mid Mid Point snap

Center Center snap

Ins Insertion Point snap

Perp Perpendicular To snap

Near Nearest snap. This one overrides all others.

Inter Intersection snap

Node Point snap

Quad Quadrant snap

Tang Tangential To snap

AppInt Apparent Intersection snap

Disable Toggle currently selected OSnap state

All Enable/Disable all.

Measure

Distance

Measure the distance in Drawing Units(DU) between two points selected from

the drawing.

Area Measure the area of a selected object.

ID Get the drawing ID of the selected object.

Other

While WireCAD does not currently merge any other tools with the View menu, authors of WireCAD plugins have

the ability to merge their own tools onto this ribbon tab. Consult their documentation for information.
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4.1.2.8 Database

No environments currently merge with this tab

Menu Item Sub Menu Description

Equipment

Library
Show the global Equipment Library

Manufacturer

s
Show the global Manufacturers  Grid

Equipment Show the global Equipment  Grid

Connectors Show the global Connectors  Grid

Cable Types Show the global Cable Types  Grid

Signal Types Show the global Signal Types  Grid. This grid defines many default

behaviours like cable color and default cable type.

Pinouts Show the global Pinouts  tool (PRO) and above.

Equipment

List

Show the project Equipment List . This is the collection of all SysNamed

equipment across all drawings in the project.

Backbones Show the project Backbones grid. (ENT ONLY). This is the collection of all

Backbones in the project.

Circuits Show the project Circuits grid. (ENT ONLY). This is the collection of all

Circuits in the project.

Cables Show the project Cables  grid. This is the collection of all Cables in the

project.

Locations Show the project Locations grid. This is the collection of all Locations in the

project.
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Named Paths Show the project Named Paths grid. This is the collection of all Named

Paths in the project.

Todo List Show the project Todo List

Import

Project Data

Wiz

Show the project Import Data Wizard. This tool allows you to import cable

and equipment data from other sources.

Add Multicore

Cable

Displays the Add Multi-core Cable  dialog. There you select the cable type

number base, etc. and build an entry in the Cables table for every core in the

associated cable type marking the records available.

Pack Project

Database

This file base database utility will compress and reorganize your project

database. 

Pack Global

Database

This file base database utility will compress and reorganize your global

database. 

Synchronize

Global

Database

Show the global database Synchronizer  tool. This tool allows you to

import/export/merge two global databases of either SQL,VISTA, or SQL

Azure.

4.1.2.9 Plugins

This tab is dynamic. Depending on product level and installed third party or WireCAD plugins these menu items

are subject to change.

Menu Item Sub Menu Description

Plugin

Manager

Shows the Plugin Manager  dialog where you can control which plugins are

loaded.
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Script Editor

Runner

Shows the Script Editor/Runner  dialog. This tool allows you to create

custom scripts to perform tasks. You can view/edit existing scripts that show

how to do a bunch of things by browsing to the script folder in c:

\users\public\wirecad\wirecadx\scripts. Therein you will find many example

scripts. Scripts are written in C# and the editor provides intellisense hints.

Translation

Manager

Shows the Translation Manager. While not technically a plugin we have

always shown it here so why break with tradition. All text (strings) in

WireCAD are held in a dictionary. The dictionary is editable through the

Translation Manager. All strings default to english if the machines current

culture cannot find a translation in the dictionary. You have the ability to

change the displayed messages, column headings, and all other strings.

Batch Plot Show the Batch Plot tool. This tool allows you to scan the drawings for

layouts and select the layouts to print/plot in a batch. You can save/load your

settings for the next time around. 

Brother P-

Touch!

Show the Brother P-Touch! plugin to print directly to P-Touch! printer with

USB ports that support direct print. (NOTE: not all P-Touch! printers with USB

ports support direct print).

PatchVerx If you have installed PatchVerx on your machine this icon will be present so

you can run the worlds best patchbay designation strip tool inside of

WireCAD and pull data directly from your Cables table and place in on your

patchbay label.

Extract All

Blocks

Extracts all blocks from the active drawing and writes them out as individual

dwg files to the selected folder.

Bulk Block

Fixer

If you want to use someone elses CAD blocks you will need to fix them so

they work with WireCAD. This is the tool.

DWG Diff Drawing Differencing tool. Compare two similar drawings and create three

views A not B, B not A, and Common to Both. Compares geometry and

drawing collections like layers, linetypes, etc.

404
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4.1.2.10 Reports

Items on this tab are static and always display.

Menu Item Sub Menu Description

New with

Wizard...

Create a new report using the New Report Wizard. We recommend that you

find a report in the existing Reports Gallery that is close and save that as your

new name then edit your changes there. You will save a bunch of time.

Generate Bill

of Materials

Shows the BOM generator  which counts equipment, cable, and

connectors in the project. NOTE be sure to run this tool before you run any of

the BOM reports or they will be empty.

Scan Project

for

Discrepancies

Scan for common problems. Shows the Discrepancy Scanner  dialog.

When it finishes you can see the results in the Project Discrepancy list from

the Project Explorer.

Reports

Gallery

Lists all reports in the %REPORTS% support path and its subdirectories.

Clicking a gallery item will load the report into a report form for preview/design/

export.

4.1.2.11 Plan View and Layout Tools

Active only when the current environment is a drawing.

Menu Item Sub Menu Description

Take Offs Show the Take Offs  tool. This tool assists in counting items in the

drawing.

472

400

364



WireCAD v8 User Manual230

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Add

Boundaries

from Text

Add Location Boundaries  using a text entity to derive the location name.

Once you select a text entity the Boundaries form is displayed allowing you

to set the remainder of the properties.

Draw

Backbone

Draw a polyline representing the backbone in the plan view space. Then

assign a number, cable type, source and destination ports and add that to the

database. 

Draw Cable Drawing a polyline representing a cable from a location boundary to another

location boundary or from placed equipment to placed equipment. Cable

information is then created in the Cables table.

Populate

Cables

Automatically places arched cables from location to location as defined in the

Cables table.

Draw Prewire

Cables

Draw a polyline representing prewire cables and add the data to the Cables

table marking the IO as PREWIRE. Later, you can assign cables to those

PREWIRE entries.

Populate

Equipment

Automatically place SysNamed equipment in the drawing in the Location

Boundaries if found.

Place

Equipment

Place unnamed plan view equipment in the drawing. Preferably after Location

Boundaries have been defined.

4.1.2.12 Print Preview

Visible only when the active environment is a report.

Related Topics

Print Preview Reports Form
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4.1.2.13 HTML View

Visible only when the active environment is a report.

Related Topics

HTML Preview Reports Form

4.1.2.14 Report Designer

Visible only when the active environment is a report.

Related Topics

Report Design Form

 A discussion on report design can be found here .

4.1.2.15 Toolbox

Visible only when the Report Designer Tab is active.

Related Topics

Report Design Toolbox Form

461

462

93

465



WireCAD v8 User Manual232

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.2.16 Cable Data Selector

Visible only when the active environment is a report.

Related Topics

Cable Data Selector Form

4.1.3 Dialogs

4.1.3.1 Application Menu Dialogs

470
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4.1.3.1.1  New  Project Wizard

Application Menu >  New Project...

Commandline: np

Explanation

WireCAD Projects are a loosely coupled collection of files, folders and databases. The New Project Wizard will

guide you through the steps of creating a new Project with several different options for different database types.

Choose Database Page Options

Name, Description, Location Page Options

Database Host Page Options

Project Settings - Basic

Project Settings - Advanced
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Project Settings - Locations

Finalization

Related Topics

Create a new Project

Create a new SQL Project

Dialog Options

Item Description

Navigate Forward

Navigate Backward
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Explanation

Related Topics

Choose your Database Type

Choose Database Page Options

Item Description

Use File Based Local or

Network Share Database

(VISTADB)

File based databases.

Use Database Server (SQL

Server)
You will need the host name and log in info to proceed.

Use SQL Azure (cloud

storage)

You will need a Microsoft Azure account for this option. Don't have one? Contact

us. We can help.

117
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Explanation

Name, describe and locate the project.

NOTE: SQL, and SQL Azure do not like project names that start with a number.

Related Topics

Default Project Location

Name, Description, Location Page Options

Item Description

267
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Name 50 Characters max. Must not have any operating system illegal characters. We

also recommend not using the ['] apostrophe.

Description Required

Project Files Path Pulled from the Settings, you can change it here.

Project Lead Person Who is in charge here.

Explanation

How do we log in to the SQL Server. There is a subtle distinction to be made between SQL And SQL Azure:

SQL Server the database name will be the Project Name.

SQL Azure the database name will be the name you gave your SQL Azure database. We will create a schema

on that database with the project name as the schema name.
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Related Topics

Choose your Database Type

Database Host Page Options

Item Description

Host Name The host name and instance of your SQL Server

Database Name The database name. See the explanation above.

Use Windows Security Not valid on SQL Azure.

User Name and Password

Test Can we connect?

Finalization

117
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Clicking Finish starts the project creation process. Make sure that at the end the log tells you that it finished. If

not the project was not properly created and you may experience errors later.

4.1.3.1.2  Project Save As

Application Menu >  Save Project As ...

Commandline: save project as

Explanation

This tool allows you to save a project as a new name in a new location. SQL projects may be saved as new SQL

databases or file based databases. A File Based database may only be saved as a file based database.

Related Topics

Dialog Options

Item Description

Navigate Forward
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Navigate Backward

Create a New Server

Database
SQL Project Only.

Create as File Based

(local) Database

Explanation

Select the location and whether we copy the data from the database.

Related Topics

Dialog Options
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Item Description

Save As
Follow file naming conventions.

Project Path

Create New Empty

Database

Copy All Data
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4.1.3.1.3  Manage Security

Application Menu > Security Tools > Manage Security ...

Commandline: security

Explanation

Administrators can manage users, groups and permissions. If WireCAD Security is enabled (see related topics).

The person that enabled the Security option is the Administrator (the Great and Powerful Oz). All other users will

be added automatically to the Users (mere mortals) group. Oz may:

Change the group to which the user belongs.

Create new groups.

Modified group permissions.

Create other Ozes. 

So to be clear. Users belong to Groups. Groups have Permissions.

NOTE: No action is required to add a user. They simply need to open WireCAD. If their user profile does not yet

exist in the WireCAD Security database it will be add to the Users group.
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NOTE: Oz can proactively add users by searching the Active Directory and adding the user to the group of his

choosing.

Related Topics

Application Setting - WireCAD Security

Application Setup Wizard

Users and Groups Tab Options

Item Description

New User Create a new user and assign to a group

New Group Create a new Group and associate Permissions set. After creating the new

Group, switch to the Permissions tab and set the permissions on the collections

and drawings.

Search Active Directory

The Standard AD Search Box

User Grid Assign the User to a Group

Groups Grid Describe the group

264

258
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Explanation

Each data collection in WireCAD has Edit, Delete, and Create permissions. This grid enumerates each collection

for each group. 

Related Topics

Grid Basics

Permissions Tab Options

Item Description

Collection Name

Obvious.
AllowEdit

AllowDelete

AllowAddNew

79
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GroupName You may find it handy to filter by group name then set the permissions for the

group.

Select All

Clear Selection
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4.1.3.1.4  Packup / Checkout

Application Menu > Check In/Out > Pack up /Check Out ...

Commandline: packup

Explanation

A WireCAD project is a loosely coupled group of files, databases and settings. The global database is maintain

separately from the project database, and drawings may have linked images. In order to move the project to

another machine we will need to gather all of the resources used to create the project into a central location (the

project folder).

The Packup / Checkout Tool performs the following functions:

Copy a file based version of the Global Database into the Project\Project Databases folder and sync it will the

SQL Server version if necessary.

Copy all linked images to the drawings directories.

If check-out the flag the project as read only.

If compress the zip all the project folder items into a single zipped file with the project_name.zip

NOTE: This process can take some time on large projects.
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Related Topics

Moving Projects

Dialog Options

Item Description

Check Out Project Flag the Project Read Only. This is useful if the project is going out into the field

for commissioning. The version that stays in the office should not be edited.

Expected Return Date Let the people in the office know when you think you will have the project checked

in.

Compress Output Zip it.

108



WireCAD v8 User Manual248

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.3.1.5  Unpack Project

Application Menu > Check In/Out > Un Pack ...

Commandline: unpack

Explanation

The complementary function to the Pack Up is the Un Pack. This function performs the following:

Unzip the compressed file (if necessary).

Sync the local Global Database with the one found in the incoming Project Databases folder.

Open the project for use.

NOTE: This process can take some time on large projects.

Prerequisites

A project that has been Packed Up. Using the Pack Up / Check Out tool.

No project can be open or the tool will not run.

Related Topics

Pack Up / Check Out 246
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Moving Projects

Dialog Options

Item Description

Project Path Browse to the zipped file or the .wc6plf file

Open project after unpack

108
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4.1.3.1.6  Check in Project

Application Menu > Check In/Out > Check In...

Commandline: packup

Explanation

The complementary function to the Check Out is Check In. This function performs the following:

Unzip the compressed file (if necessary).

Sync the local Global Database with the one found in the incoming Project Databases folder.

Syncs the Project Database of the incoming project with the location database.

Overwrite all drawings with the incoming ones.

Remove Read Only flag.

NOTE: This process can take some time on large projects.

Prerequisites

A project that has been Checked Out. Using the Pack Up / Check Out tool.

The Checked Out local project must be open before this tool will run. 

The project names of the local and incoming projects must match or the tool will fail.
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Related Topics

Pack Up / Check Out

Moving Projects

Dialog Options

Item Description

Project Path Browse to the zipped file or the .wc6plf file

Open project after unpack

246

108
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4.1.3.1.7  Application Setup Wizard

Application Menu > Application Setup Wizard...

Commandline: showappsettings

Explanation

This wizard runs once at the start of WireCAD. You can always run it again to change the settings, but most of

the settings in the wizard are contained in the Settings dialog.l

Global Database Location Page Options

Database Path Page Options

Database Host Info Page Options

Create Tables and Add Data Page Options

WireCAD Community Server Contribution Mode Page Options

Use WireCAD Security Setting Page Options

Found Previous WireCAD Version

253
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Dialog Options

Item Description

Navigate Forward

Navigate Backward

Show This Again Show this dialog again.

Global Database Location Page Options

Item Description

Local Machine The default location is c:

\users\public\WireCAD\WireCADx\WireCADGlobalEquipment.vdb3. You may

rename the file in order to better organize your global data by client. See this topic

on the Global Database Location .266
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Remote Network Storage This is not recommended but is possible. Why do we do this? Well we hate to

limit you. Here are the ramifications of using file based storage over a network:

The file is not network fault tolerant like SQL Server.

Data can become locked and in some cases corrupt.

You may find yourself having to Pack (compact and repair) the database if you

get locked out of it.

SQL Server This is the best option for shared storage, but you lose portability.

Database Path Page Options

Show if the first selection is Remote Network Storage

Enter the Path to the WireCADGlobalEquipment.vdb3
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Show only if the initial selection is SQL Server.

Database Host Info Page Options

Item Description

Create stand-alone

database

Use existing database.

Create global db using

schema name.

Host

Global Database Name

Schema Name

Use Windows Security

User Name

Password
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Test

Shown only if the SQL Server Option is selected.

Create Tables and Add Data Page Options

Item Description

Add default global data Create the database on the host and add the selected default data.

Create empty database Create the database on the host with no data.

Which data to add

Create Database and Add

Data
Do It!
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WireCAD Community Server Contribution Mode Page Options

Item Description

Yes I want to contribute

Yes but wait until I check

the Approved field

No Thanks You can still manually upload from the Equipment Library in this mode.
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Explanation

WireCAD Security is used to resrict user access to key application sections and functions. If enabled, the user

launching WireCAD will be subject to the rules of the group to which they belong. The user that initiates WireCAD

security will be the only Administrator and will need to assign all other user permissions. This is managed through

the Manage Security  dialog.

Use WireCAD Security Setting Page Options

Item Description

Use Security

Database Type VISTADB - while you can use VISTADB as the security database it is only

application to this machine.

SQL - we will create the permissions database on your SQL Server using the SQL

host and login information.

242
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Create SQL Permissions

Database
Do It!

Explanation

We found a WireCAD previous version. In order to use the work that you have already done you will need to

synchronize with the previous version Global Database. There are many variables that can be configured to locate

the Global Database elsewhere. When you finish the Application Setup Wizard restart WireCAD then launch the

Database >Sync Global Database tool and set the remote database to look at your previous instance.

Related Topics

Synchronizing with Another Global Database

Sync Global Database dialog

Found Previous WireCAD Version Page Options

None

112
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4.1.3.1.8  The Settings Dialog

Application Menu > Settings

Commandline: set

Explanation

The Settings dialog is comprised of the following sections:

Application - settings that determine the behaviour of WireCAD for this machine.

Basic

WireCAD Security

Global Database Location

Support Paths

Organization

Todo List

User - settings specific to your user profile on this machine.

Basic

Projects List

Drawing

Drawing (advanced)

Command Line Shortcuts

Enterprise CMS (ENT Only)

Project - settings specific to the current project.

Basic

Advanced

Locations

Enterprise CMS

Export Settings

NOTE: These are the stock basic settings panels. Third party developers may register their own settings panels.

See their documentation.
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Prerequisites

None

Related Topics

Dialog Options

Item Description

Save Commit your changes and issue a SettingsChanged command to the

application.

Close Do nothing and discard your changes.

Restore Defaults Restore the defaults of the current settings panel.
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Application - Basic Panel Options

Item Description

Check for Program

Updates Automatically on

Startup

If updates are available you will see a banner pop up in the lower right-hand corner

of the screen.

Show Application Setup

Wizard on Startup

This is usually unchecked except the first run of the application. You can always

start the Application Setup Wizard by clicking Application Menu >

Application Setup Wizard.

Community Server

Contribution

How will you contribute to the WireCAD Community?

Customer Experience

Improvement Program

You must opt in to the CEIP. We will then gather usage and error data. The

generic data will be uploaded to our servers and aggregated so we can bring you

a better application.

Silent Plugin Load Hide all error messages on startup.

Default Project Database

Host

Applies only to SQL projects. Presets the New Project Wizard

Use SQL Server Project

Databases by Default

Presets the New Project Wizard

Users (mere mortals) can

select Project Database

Mode

Some organizations may wish to limit selection of project database type.
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Application - WireCAD Security Panel Options
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Item Description

Use WireCAD Security Enable Security. When enabled the WireCAD security system uses the current

login to determine program access.

If your user is a member of the Administrators group you will be able to control

the access of other users via the Application Menu > Security > Manage

Security... dialog.

Database Type Typically you will only use security in a multi-user environment with a SQL host,

but the capability exists to use file based VistaDB databases.
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Application - Global Database Location Panel Options

Item Description

Database Mode VISTA/SQL

NOTE: SQL will work for SQL AZURE as well. We will need the database name

and schema name.

VISTADB Location Path to the VISTADB file that is your WireCADGlobalEquipment.vdb3 file.

Note that this is the default name given to the global database file but you may

change it.

Global DB File Name

SQL Server Login Info

Host Name and Instance This can be a fully qualified path, ip address, or host name.

Database Name The name of the global database to connect to. This is

WireCADGlobalEquipment by default but you may choose to rename it.
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Item Description

Use Schema WireCAD v8 supports multiple schema in the same database file. This is useful

if you are using a cloud based SQL Server service that charges by the

database. You can have a schema for your global database and one for each of

your project databases. All contained within the same database file.

Schema Name

Use Window Security Use this if you wish Windows security to manage the login. This will not work

with SQL Azure.

User Name

Password

Test Connection Test to see if you can connect and have the appropriate privileges.

Application - Support Paths Panel Options
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Item Description

Block %BLOCKS% The path that will replace the %BLOCKS% variable in the equipment library.

Images %IMAGES% The path that will replace the %IMAGES% variable in the equipment library.

Documents %DOCUMENTS

%

The path that will replace the %DOCUMENTS% variable in the equipment library.

Icons %ICONS% The path that will replace the %ICONS% variable in the equipment library.

Template Drawings The path to the Template Drawings folder. This is the folder where Template

Drawings are saved when using the File > Save As Template Drawing

function is used and the folder that the New Drawing Wizard searches to fill

the Templates list:

Reports The path to the top reports folder. This is a recursive search and will enumerate

all subfolders and files.
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Item Description

Default New Project

Location

Presets the New Project Wizard.
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Application - Organization Panel Options

This one's self-explanatory



Reference 271

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Explanation

Sets the dropdowns in the Project Todo List

Application - Todo Panel Options

Item Description

Assignees List of people to whom a task may be assigned.

Statuses List of todo item statuses. Modify this to suit your needs

Priorities List of priorities. Again, make it fit your needs.
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User - Basic Panel Options

Item Description

Open New Drawing Upon

Application Startup

Opens a blank new drawing when WireCAD starts.

Use the New Drawing

Wizard

Shows the New Drawing Wizard when you click File > New. Allows the use of

template drawings. If set to false, just creates a new drawing without a template.

Open My Last Project

When I Start WireCAD

Behaves like earlier versions of WireCAD that opened the last project

automatically on startup.

Show Library Tips This shows the Tips and Tricks form in front of the Equipment Library.

Show the WireCAD Startup

Page

The WireCAD Startup Page shows the latest news from the WireCAD ranch.
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Item Description

Warn of Signal Type

Mismatch

When you finish drawing a cable WireCAD will check the source and destination

port signal types and let you know

if they don't match. You can use the new status panel to know the port type if

you are confused.

When I Double-click a

Many-to-Many Cable Assign

All of Them.

Many-to-Many cables that are set for Multiple Database Entries can either be

assigned all at once by a single 

double-click, or if this setting is turned off a double-click will find the closest port

to the cursor and assign that.

Keep Equipment Library

Open

This is useful if you are using dual monitors and want to have the Equipment

Library stay open on the other monitor.

When I Link Pointers Go

Back to the Starting

Drawing When Finished

The default Link Pointer function will leave you on the second sheet. If you set

this to true it will jump you back to 

the first sheet.

My Spacebar is my Enter

Key

This is helpful when executing command line commands

MouseWheel Double-click

Zooms Extents

Library Multiple Port Add

Leading Zero Count
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Item Description

I Will Manually Refresh the

Project Explorer

True to disable autorefresh on the Project Explorer. This may be helpful if your

project grows to have hundreds of drawings.

When a Drawing Opens

Don't Show the Draw

Cables Tool Panel

Lazy Load my drawings in

the Project Explorer

True to disable recursive search of all drawing subfolders. This may be helpful if

your project grows to have hundreds of drawings.

User - Projects List Panel Options
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Item Description

Most Recently Use Projects

List Count

How many items allowed in the list.

Projects List

Clear Reset the list.

Remove Missing Items Remove items that cannot be found because the path has changed or is

currently unavailable.

Remove Item Remove the selected row.
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User - Drawing Panel Options

Item Description

Auto Save Duration Sets the Auto Save Duration. Auto Save saves only drawings that are not

currently involved in a function.

Arrow Move Nudge

Distance

When nudging a selection how far do we move in the direction.

Grip Color Sets the grip color.

Grip Size Sets the grip size in pixels.

Cross Hair Size Sets the cross hair size in pixels.

Show Layout Tabs Shows the layout tabs at the bottom of the drawing frame

Show UCS Axis Shows the UCS Axis:

Show Paper Space Paper When a layout is selected, show the current page size as returned by the

selected printer as a white "page."

True
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Item Description

False

Save Drawing After Every

Cable Number Assignment

Setting this to true is not recommended but will speed the assignment process.

You are responsible then for saving the drawing to ensure drawing/database

parity.

Touchscreen Mouse Logic

Clear Selection After

Command Executes

Overrides the default behaviour of leaving the selection set in tact after an

operation. 

Drawing Background

Follows Skin Theme

Background Color Sets the background color. 

OSnap Color Sets the Object Snap Color.

Pick Size Sets the pick size in pixels. The pick determines the search window when

clicking the cursor.

Mousewheel Zoom Scale How far do we zoom with every click of the mouse wheel

Show Rulers

Ruler Width In pixels

Default File Save Format
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User - Drawing Advanced Panel Options

These are really granular controls of the render engine. It is beyond the scope of this manual to explain each we

will hit some, but play with them if you are interested and see how they behave.

Item Description

BackupOnSave Saves the file with the ~.bak extension before overwriting the existing file.

DisableShowPrinterPaper Same as Show Paper Space Paper

DisableXrefTooltips Sometimes XREF tooltips can be annoying.

EnableTooltips Show tooltips or not.

EnableURLs URLs of object will be opened.
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Item Description

MirrorText Controls how the Mirror command deals with text.

ShowUCSAxis

ActionHighlightQuality Speed or Quality

ActionProperties Default or HideOnLeave

CrossSize

CursorAxisColor

CursorPickColor

CurveResolution How many segments to a circle.

GridColor

LineDrawQualityMode Speed/Quality

MappedImageBoundWidth Used only in 3D texture mapping.

OSnapSize

PickAdd Sets whether a user selection action replaces the current selection or adds to it.

ReferenceCrossColor

RenderingQuality Speed/Quality

RubberBandColor

SelectActionKey Set a key value used in combination with mouse-down to add or remove

selected item(s) from a selection.

SelectingCrossColor Crossing window select color. 

SelectingWindowColor Containing window select color.

SelectionPreviewFlag Highlight entities that the mouse hovers over.

ShowHatches Show hatches(filled objects).

UseGLDIBBitmap
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Item Description

Tooltip Fiddling Change the appearance and behaviour of the tooltips.

User - Command Line Shortcuts Panel Options

Item Description

Register Your Own

Command

Developer function

Remove Command Developer function

Check Checks the shortcuts to see if you have any duplicates.
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Item Description

Commands List You may freely edit any of the columns:

CommandName

Alias

ShortCut

Even though the grid allows you to edit the following fields if you are not a

developer you should NOT edit any of the columns:

Assembly

NameSpaceAndClass

MethodName

You will break WireCAD. 

User - Enterprise CMS Panel Options
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Item Description

Use Stock WireCAD Startup

Page

This will change your Startup page from the CMS specific page to the default

WireCAD page. 

Default New Circuit Strand

Count

When creating a new circuit, a default strand count for jumpers is created. This

will change that strand count to a different value. 

Warn of Connector String

Mismatch

Having this box checked will allow a warning message to display anytime

WireCAD detects that 2 ports being connected have a different connector type. 

Project - Basic Panel Options

Item Description

Starting Cable Number The default starting number of ALL sequences.



Reference 283

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Item Description

Leading Zero Count How many leading zeros in SysNames and Cable Numbers

Ignore Cable # Text Color Does not color the Cable Number text entities.

I Build My Racks From the

Top Down Probably should read I number my racks from the top down.

Default Rack Height

Default Cable Type This is the default of defaults. The Signal Types table can override this.

Default Plan View Block

File

If no Plan View File is defined on the Equipment definition then this will be used

by the Populate Equipment function in the Plan View Tools.

Users (mere mortals) Can

Modify These Project

Settings

If you can see and edit this you are a WireCAD Administrator or have not set up

WireCAD Security.

Add Pinout Data to Each

Cable

Allow pinout data to be attached to a cable as it is being assigned. The pinout

criteria must match in order to be a candidate for inclusion in the list of available

pinouts for a cable.

Use the device display

settings

This setting prioritizes any Equipment Library device settings saved with the

device over the settings saved for the project.
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Project - Advanced Panel Options

Item Description

Disable Find Next

Available SysName

The default behaviour is for WireCAD to lookup the next number from the Next

Numbers table, then check to see if that number is in use - if so keep

incrementing until an available number is found.  Disabling this functionality will

use the number in the Next Numbers table without checking its availability.

Disable Find Next

Available Cable Number

Automatically Consume

Prewire Cables

This will use those numbers applied to the PreWire Cable instead of producing a

new number.

Hard Delete Cables and

SysNames

Overrides the default behaviour which is to mark a deleted cable Available=true

and place Deleted in key fields. Enabled this removes the row from the table

upon deletion.
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Item Description

Strict Multi-core Assigment Enforces a policy that all cores in each end of a multi-core cable must originate

from the same location. 

IP Mask

Maintain Relational Data By default WireCAD attempts to maintain a series of tables that relate the main

tables to each other. This allows you to see, for example, which drawings a

SysName can be found in etc. The relational data can get out of sync or

otherwise corrupt. You may elect here to not maintain it in the project and your

project will speed up. Your main Equipment List, Cables, Drawings, and Circuits

tables WILL NOT BE EFFECTED.

Disable Cable Number Edit

Dialog Mask

If you find the masking of the Edit Cable Data Cable Number textbox to be

cumbersome you can disable it here.
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Project - Locations Panel Options

Item Description

Location Delimiter Settable on project creation only this is the delimiter that separates CAMPUS

from BUILDING, BUILDING from FLOOR, etc. The default is a [.]. This will create

Qualified Locations in the form of:

Campus.Building.Floor.Room.Rack

Elevation-Slot Delimiter The delimiter that separates the elevation numeric from the slot numeric. For

example: a device located in elevation 20 at slot 5 with a delimiter of a dash [-]

would be typed and 20-5.

Enable Locations Lookup If disabled the locations field may be typed into directly. This may lead to

confusion or referencial issues, ie; user a calls something Rack 1 and user b

calls the same thing RK 01.

Locations Table Fields Enable those that you will use.

Start Numbering at 1 Only applies if you are auto generating locations.
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Project - Enterprise CMS Panel Options

Item Description

Manage Status Items When creating a backbone, you have the ability to mark a "status" on that

backbone such as "In Use", "Proposed" ETC. Using the [+] button, you can

create new status items. Selecting a status will cause that to become the

default for all backbones in this project. 

Backbone Number Format The variable {0} contains the next number in the Next Numbers grid for

Backbones.

Define the string format of the next Backbone number. 
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Item Description

Jumper Number Format The variable {0} contains the Circuit base number.

The variable {1} contains the Strand Number of the circuit for this jumper

The variable {2} contains the Ordinal Number of the circuit for this jumper.

Define the string format of the next Jumper number. 

Default Jumper

Manufacturer and P/N

Default Horizontal Cable

Manufacturer and P/N

Circuit Number Format The variable {0} contains the next number in the Next Numbers grid for Circuits.

Define the string format of the next Circuit number. 

Horizontal Cable Number

Format

The variable {0} contains the next number in the Next Numbers grid for Horizontal

Cables.

Define the string format of the next Horizontal Cable number. 
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Project - Export Settings Panel Options

Item Description

Use Template Path to to a template drawing that the output will be exported into. Your template

drawings can contain any page borders or layouts and settings that you wish.

Always Ask for FileName

and Path

You are involved in the filename selection and path

Circuit FileName Format Sets the file name format for Circuit output.

{0} = Circuit Name

Backbone FileName

Format

Sets the file name format for Backbone output.

{0} = Backbone Number

File Format Presets the output format.

Path Where do we output.
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Item Description

Create Folder for Each IT

Systems

Create a new folder for each IT System and output the preview to that folder.

Automatically Overwrite

Files of Same Name
Self-explanatory.

Append Date Stamp to

FileName

Circuit Post Process Script
Path to a c# file which will be run post export but pre write-to-disk. See the Post

Process Scripts  topic for more information.
Backbone Post Process

Script

4.1.3.2 Drawing Dialogs

4.1.3.2.1  CAD Dialogs

194
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4.1.3.2.1.1  New  Draw ing Wizard

Drawing > File > New

Commandline: nd

Explanation

Create a new drawing for the project.
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Dialog Options

Item Description

Template

Drawings List

Drawings placed in the the %TEMPLATEDRAWINGS% support path. Any drawing is a

candidate for saving as a template.

Model Space

Boundaries
See this topic on Model Space Boundaries

Navigate

Forward

Navigate

Backward

Show This

Again
Show this dialog again.

310
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4.1.3.2.1.2  Print Preview

Drawing > File > Print Preview

[Cntrl]+[P]

Commandline: print

Dialog Options

Item Description

Selected

Printer

Make sure that you select a printer first.
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Plot Margins Set the unit of measure and the Top, Bottom, Left and Right margins. 

NOTE: the printer driver will return the hard margins of the printer. These are represented by

the black dashed line in the Partial Preview mode. Setting the margins less than the hard

margin values will have no effect.

Center Adjusts the left and top margins to center the entities in the given space.

Upside Down Rotate the output to the plotter

Orientation Portrait/Landscape

Paper Size

Scale Numerical scaling of the entities to the paper.

Scale to Fit Fit the entities to the paper

1:1 Scale 1:1

Black and

White

Out as Bitmap Render to a bitmap then output that. Has different effect on quality depending on printer/plotter.

Copies

Pen

Assignment

Shows the Pen Assignment dialog. You can assign a different line thickness to each of the

255 indexed colors.

Print Area Pick a window or print the extents

Preview Mode Full preview or partial view to show margins.

Update

Preview

Refresh the preview

Print Do IT!

Select Printer

Cancel
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4.1.3.2.1.3  PDF Export

Drawing > File > PDF Export

Commandline: pdf

Dialog Options

Item Description

Selected

Printer

Make sure that you select a printer first.
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Plot Margins Set the unit of measure and the Top, Bottom, Left and Right margins. 

NOTE: the printer driver will return the hard margins of the printer. These are represented by

the black dashed line in the Partial Preview mode. Setting the margins less than the hard

margin values will have no effect.

Center Adjusts the left and top margins to center the entities in the given space.

Upside Down Rotate the output to the plotter

Orientation Portrait/Landscape

Paper Size

Scale Numerical scaling of the entities to the paper.

Scale to Fit Fit the entities to the paper

Black and

White

Out as Bitmap Render to a bitmap then output that. Has different effect on quality depending on printer/plotter.

Copies

Pen

Assignment

Shows the Pen Assignment dialog. You can assign a different line thickness to each of the

255 indexed colors.

Print Area Pick a window or print the extents

Preview Mode Full preview or partial view to show margins.

Update

Preview

Refresh the preview

Save to File Do IT!

Select Printer

Cancel
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4.1.3.2.1.4  Export to Visio

Drawing > File > Export to Visio

Commandline: visio

Explanation

The WireCAD to Visio converter is an intelligent converter. It creates active working Visio drawings from you

WireCAD drawings. What this means is that it is not just a dumb geometric import but rather entities are

examined and functioning Visio entities are created. Cables in WireCAD become Visio Connectors allowing

movement of blocks while keeping the wires attached.

Dialog Options
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Item Description

Page Size Set the Visio page size.

Output File

Name

Name the file

Landscape Is Landscape

Overwrite File

if Exists

Scale to Fit Fit the WireCAD dwg entities onto the selected page size.

Scale Factor Manuallly scale the WireCAD entities to the Visio page size.

Cable Routing Here is the magic. You can either let Vision route the cables or you can attempt to keep the

appearance of your WireCAD routes.

Convert Do IT!

Close
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4.1.3.2.1.5  Layers

Drawing > Drawing > Layers

Commandline: lay

Explanation

The Layers dialog controls the document Layers collection.

A Layer is the equivalent of the overlay used in paper-based drafting. It is the primary organizational tool in the

WireCAD CAD space, and you can use it to group information by function and to enforce linetype, color, and other

standards.

Organizing Layers and the objects on Layers make it easier to manage the information in your Drawings.

When you put one layer over another the result is the complete drawing.

Having kindred objects on the same layer it is very helpful in order to organize the drawing.

When you begin a new drawing, WireCAD creates a special layer named 0. By default, layer 0 is assigned color

number 7 (white or black depending upon your background color), the CONTINUOUS linetype and a lineweight of

Default (the default setting is .01 inch or .25 mm). Layer 0 cannot be deleted or renamed.

All new objects are added to the active layer if no layer is specified.

Using the Layers editor you can Freeze (Hide), Thaw (Show) and Lock layers.
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By controlling whether a Layer's state is Thaw or Frozen you can change the appearance of your drawing to

display only the information on the Layers that are visible. Freezing unused Layers will help the performance of

WireCAD.

Dialog Options

Item Description

Document Tree Lists the document's external references. By selecting an item in the document tree

you can control the layers of XREF drawings within the current drawing.

New Layer Creates a new layer with the name entered in the associated text box

Delete Layer Deletes the selected layer as long as it is not the current layer or layer 0.

Set Current Set's the current layer. All entities added to the drawing are added to the current layer.

New Layer Name

field

Status The one and only current layer

Name The name of the layer

On Is it visible

Frozen Is it visible. The difference between Thawed/Frozen and On/Off is a very subtle

distinction. Turning a layer off using the ON/OFF setting makes the objects on that

layer hidden, but these objects will still be considered part of the drawing. For example,

objects that have been turned off are still selectable in the drawing. Selecting it directly

on screen of course still isn’t possible, as you’ve nothing to click on. But other ways of

selecting objects will still pick it up – try a SELECTALL for example, and your objects

that are turned off will be selected.

Frozen layers on the other hand are completely off. They are not considered part of the

drawing at all, and are therefore not selectable.

Lock Make the layer unselectable.

Pen Color Set the pencolor for the layer. Only entities that have their PenColor property set to

ByLayer will receive this value.
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Line Type Set the Line Type for the layer. Only entities that have their Line Type property set to

ByLayer will receive this value.

Line Weight Set the Line Weight for the layer. Only entities that have their Line Weight property set

to ByLayer will receive this value.

OK Commit changes and dismiss

Cancel Dismiss
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4.1.3.2.1.6  Layouts

Drawing > Drawing > Layouts

Commandline: layouts

Explanation

A Layout is used to compose or lay out your model drawing for printing. A layout may consist of a title block, one

or more viewports, and annotations. As you create a layout, you can design floating Viewport configurations to

visualize different details in your drawing.

A layout is a paper space environment that simulates a sheet of paper. In a layout, you can create and position

viewport objects, and you can add a title block or other geometry. You can create multiple layouts in a drawing to

display various views. Each layout displays the drawing as it will be printed on the sheet of paper.

Typically, when you begin designing a layout environment, you step through the following process:

1. Create a model drawing.

2. Activate or create a layout.

3. Insert a title block.
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4. Create floating viewports and position them in the layout.

5. Set the view scale of the floating viewports.

6. Print your layout.

Dialog Options

Item Description

Layout List List the Layouts collection.

Set Current Set the selected item to be the current view.

New Create a new Layout

Remove Remove the selected layout as long as it is not the Model

Rename Rename the seleced layout as long as it is not the Model

Copy Copy all entities from the selected layout to a new layout with the name of your choosing.

Move Up
Reorder the list

Move Down
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4.1.3.2.1.7  Point Styles

Drawing > Drawing > Point Styles

Commandline: pointstyles

Explanation

All point entities inserted into the drawings space will render based on the settings here. 

NOTE: if you are using the Rack Builder tool WireCAD uses point entities to generate the positioning grids and

sets this value programmatically.

Dialog Options

Item Description

Dot Display as a single dot.

None None

Cross Cross

X Mark X

Line Line

Add Circle Add a circle around the above selection.
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Add Square Add a square around the above selection.

Point Size

Set the size in units as definedRelative/

Absolute
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4.1.3.2.1.8  Text Styles

Drawing > Drawing > Text Styles

Commandline: ts

Explanation

TextStyle is a named, saved collection of settings that determines the appearance of text strings.

You can create your own text styles which can have specific fonts and text height. You can also specify if the text

will be underlined,bold etc.

There is no limit to the number of text styles you can create in your drawing. 

The active text style determines the appearance of new text created in the drawing. StyleName of text object will

get the value of ActiveTextStyle property.
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When you enter text, it uses the current text style, which sets the font, size, and other text characteristics. If you

want to create text using a different text style, you can make another text style active.

Dialog Options

Item Description

Style Name,

Add, Rename,

Delete

Create a new Text Style, Rename the selected Text Style or Delete the selected Text Style

Font Set the font family of the Text Style.

Style Style attributes

Preview Preview of Text Style applied to the the Preview Text Edit.

Preview Text

Edit

Advance

Settings
The advance tab displays a property grid with all of the basic settings and a few more.

CodePage Sets the character set used to display text.

DrawOutline

Flag LeftToRight, Backwards, UpsideDown, etc.

ObliqueAngle Oblique angle for the text in degrees.

WidthFactor Value used to stretch text by changing its width.
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4.1.3.2.1.9  Dimension Styles

Drawing > Drawing > Dimension Styles

Commandline: dimstyles

Explanation

A Dimension Style is a group of dimension settings that determines the appearance of a dimension . 

The active Dimension Style determines the appearance of new dimensions created in the drawing.

To change the style of an existing dimension, use the StyleName property found on the dimension.

When you create a dimension, the current dimension style is associated with that dimension. The dimension

retains this dimension style unless you apply a new dimension style to it.

Dialog Options

Item Description

Style Name,

Add, Rename,

Delete

Create a new Dimension Style, Rename the selected Dimension Style or Delete the

Dimension Style.

Preview Pane Displays the results of the current settings.

Settings Play with them.
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4.1.3.2.1.10  Model Space Boundaries

Drawing > Drawing > Model Space Boundaries

Commandline: bo

Explanation

It's a big model space in there. We can, if we are not careful, create a drawing that is so big that it can't be

effectively printed or plotted. In order to have some Idea of where the fences are WireCAD can place boundaries in

the model space. The boundary is created from the viewport. We use the text height as the terms for our equation.

We do this because a drawing is considered readable if we can read the text. If we can't read the text the drawing

becomes useless.

Each boundary will be placed on its own layer an named bound_layout_name where layout_name is replaced with

the name of the layout.

Dialog Options

Item Description

Layout Select the layout from which we will create the boundary

Text Height that you

used in Model

Space

The default is .25 DU or as given in 1/100th of a Drawing Unit: 25.

Height of the text

that you want to

print

Here we want the printed output height in 1/100th of a printer unit. 
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Color
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4.1.3.2.1.11  Groups

Drawing > Drawing > Groups

Commandline: formatgroups

Explanation

New to WireCAD 8 is the ability to create groups of entities in order to better organize your drawings. Groups can

be named and described as well as disabled and edited later.

To create a Group select some entities and right-click then click Group
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Dialog Options

Item Description

Ignore Groups Disable grouping

Name The default Group name will be a GUID. You can rename it if you like.

Description

Selectable Is the group selectable as a group. If selectable = true then when one object in the

group is selected all objects are selected.

Item Count

Edit Entities Add or remove entities to the group.

Apply Properties Send the value of the Group Properties fields to the group.

Delete Deleting the Group does not delete the entities.

Group Properties
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New New from the Group Properties.

4.1.3.2.1.12  Images

Drawing > Drawing > Images

Commandline: formatimages

Explanation

New to WireCAD 8 is the ability to embed images in the drawing as well as to edit the properties of those images.

The document now contains and Images collection from which images may be inherited throughout the drawing.

Using the Images collection you may now either link or embed an image.

Dialog Options

Item Description

Images Gallery

Attach Browse to an image file to attach to the document.

Edit Image Display the Image Editor dialog for the selected image
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Detach Remove the selected image if no instances exist in the drawing.

Properties

Image Path Path to the linked file

Bind to Document Check this box to embed the image in the document.

Choose

Transparency Color

Sets the transparency color for the selected image

Place Place an instance of the image in the drawing space.
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4.1.3.2.1.13  Image Editor

Double-click an Image

Commandline: none

Explanation

Image editor. You are editing the Image Definition of the document images collection not the instance.

Dialog Options

Item Description
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Grayscale

These controls are fairly self explanatory.

Sepia

Invert Colors

Export

Adjustments

Flip

Rotate

Colors

OK

Cancel
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4.1.3.2.1.14  Rectangular Array

Drawing > Drawing > Rectangular Array

Commandline: ar

Explanation

Creates multiple copies of objects in a pattern. 

With the rectangular array you can create an array defined by a number of rows and columns of copies of the

selected object.

First you have to select the objects.Then you have to define number of rows and number of columns of the

rectangle, the distance between rows and the distance between columns.

Dialog Options

Item Description

Rows The number of rows in the array including the source elements.

Columns The number of columns in the array including the source elements

Row Spacing Row spacing in DU.

Column

Spacing
Column spacing in DU.

Pick >> Pick the spacing out of the drawing.
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4.1.3.2.1.15  Purge

Drawing > File > Purge

Commandline: purge

Explanation

Remove unused entities from the drawing. 

Dialog Options

Item Description

Collection Tree The document collections

Collection to

Purge
The collections to purge

Purge Do It!
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4.1.3.2.1.16  Inserts Dialog

Drawing > CAD Tools > Insert Block into Drawing

Commandline: insert

Explanation

Insert blocks in to the drawing. This is the collection of Blocks in the drawing. You may also browse to any .dwg

file and insert it into the file.

Dialog Options

Item Description

Blocks Select an existing block or browse to a dwg file and add it to the drawing.

Preview

the selected block
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Insertion Point

Pick here or on the drawing.Scale

Rotation

4.1.3.2.1.17  XREF Manager

Drawing > CAD Tools > XREF Manager

Commandline: xref

Explanation

Manage externally referenced drawings. These are drawings that are visible in the current Model space but

maintained in separate files. They are linked here until action is taken to bind them to the current drawing.

Dialog Options

Item Description
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Attach Browse to the file. After which you will be presented with the standard Insert dialog to position

the incoming file on the screen.

Detach Remove the XREF

Reload Get any changes to the XREF file and display them

Bind Make it a Block in this drawing.

Unload Get rid of it.

4.1.3.2.2  Advanced Tools Dialogs

The following is a set of dialogs that may be presented while using the advance tools in the drawing environment.
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4.1.3.2.2.1  Equipment Library

Database > Equipment Library

Drawing > Advanced Tools > Equipment Library

Commandline: le

Several Others

Explanation

The WireCAD Equipment Library is where you will spend a fair amount of time as you define equipment that you

will use in your designs. The Equipment Library is a presentation of the global Manufacturers table and its

hierarchy. The Equipment Library contains no CAD blocks just equipment definitions. These equipment definitions

describe a peice of equipment its make, model, and IO. 

This is also where we come to create CAD blocks in our drawings. There are many settings here that let you

customize appearance.

The interface is tabbed. The [Find] tab sets the current item. The current item will be enumerated in the [Detail]

and [I/O] tabs. This topic covers the right-hand column of controls that is visible from all tabs

Dialog Options

Item Description
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Big Preview

Refresh

Preview

Preview Displays the currently selected equipment definition based on the Display As: setting.

Display As:

Setting Preview

Functional I/O

Conceptual I/O
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Conceptual I/O

(high detail)

Front Panel

(File Merge)

Front Panel

(From Dims)
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Plan View (File

Merge)

Plan View

(From Dims)

Not yet implemented.

Add

Manufacturer
Shows the Add Manufacturer dialog.

Add Equipment Shows the Add Equipment Wizard.

Delete

Equipment
Deletes the selected record.

Add to

Drawing
Add the selected item to the drawing based on the current preview.

Add to Project

Database Only

(Assign

SysName)

Shows the SysName Assignment dialog.

Attach

Document

Attach any document to the current record. This is useful for storing cut sheet or specification

documents with the equipment definition.

Exit
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Database > Equipment Library

Drawing > Advanced Tools > Equipment Library [Find]

Commandline: le

Several Others

Explanation

The [Find] tab allows you to search the local global database as well as the Community Server. When

searching locally all records are returned by default. When searching the Community Server you will need to

enter a search term. The results will be returned in pages based on your Results Page Size value. 

Search Term Hints
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When searching the databases for items less is more. You want to enter a value than can be found in a single

field. For example: say we are looking for a Sony DVW A-500. The following is a list of terms and their results:

Search: Sony - Result: All Sony products and any products from other manufacturers that have Sony in their

description fields.

Search: DVW - Result: All products with DVW somewhere in the name or description.

Search: SONY DVW - Result: None. There are no products with the manufacturer name and the product name in a

single field.

Find Tab Options

Item Description

Find Enter the search term here.

Find button Do the search

Find All button Clear and find all records. (Local only)

Local /

Community

Server

Switch between your local database and the Community

Test

Connection

button

Test your connection to the Community. If this fails you may need to open your firewall to

community.wirecad.com port: 1433

Download

From

Community

Before any edits can be made to the device you will need to download it to your local

database.

Upload to

Community
You can upload manually by clicking this button

Image

Database fields associated with the current recordset

Manufacturer

Name

Equipment

Name
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Equipment

Description

Equipment

Type

Community

Rating System

The Community Server is completely open. All device definitions have been created by your

peers. If something is wildly inaccurate then post your opinion. Conversely if something is

wildly brilliant then do the same.

Results Paging You can navigate the page results with these controls.
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Database > Equipment Library

Drawing > Advanced Tools > Equipment Library [Detail]

Commandline: le

Several Others

Explanation

This is the detail page for the currently selection record. The fields are self explanatory. 

NOTE: Be sure to save your changes if you edit this grid manually by clicking File>Save.
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Database > Equipment Library [I/O]

Drawing > Advanced Tools > Equipment Library [I/O]

Commandline: le

Several Others

Explanation

This is the Inputs and Outputs page. It represents the I/O of the currently selected device. Inputs are displayed in

the left-hand grid and outputs are displayed in the right-hand grid. This is by convention only. You are free to place

inputs on the right-hand side and vice versa. Each port record consists of a Name, Type, Connector and a Pin

Type. Selected records will be included in the preview of any Function I/O and Concept blocks that you create.

I/O Tab Options

Item Description

Inputs Grid The I/O grids.

NOTE: Be sure to save your changes if you edit these grids manually by clicking 

File>Save.

Outputs Grid
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Select All

Manipulate the selection.
Clear Selection

All Inputs

All Outputs

Select by Signal

Type

Ten buttons in this frame will populate with the first ten signal types from the I/O

records. Clicking the button will select all records in both grids of that signal type

Reorder Move selection up/down.

Copy Copy side-to-side.

Add Ports Show the Add Ports dialog .

Delete Ports Delete the selected ports. You will be prompted for each grid. No save is necessary

Refresh Refresh the preview.

Display Order Set and sort by the Display Order column. This allows you to rearrange the lists and be

able to return later to your work.

341
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Database > Equipment Library

Drawing > Advanced Tools > Equipment Library

Commandline: le

Several Others

Explanation

This is where we determine the look of the block we are about to add to the drawing.

There are four tabs in this view that allow you to customize the appearance of the block you are about to create.

1. Stock Shapes

2. Mappable Terminals

3. User Defined Shapes

4. Mechanical Forms

Understanding the Settings Mechanism

Settings store the appearance and display mode of the Equipment Library. These settings determine the look of

the created block. You can tell which settings were used to create the block by looking at the Equipoment Library

status bar:

WireCAD stores the settings used to create blocks in three different locations:

1. Device settings. If you create a block in a drawing we store the settings used to make the block with the device

definition in the Equpment Library. These settings have priority.

2. Project settings. If you like the display of a block you can click the:

 

Doing so will set the current display settings as the Project default. All devices that do not currently have stored

settings will then use the Project defaults.

3. Default settings. When no other settings are found we use the defaults.

339

339

339

340
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Several controls are common to all tabs. We will go into those first.

Common Controls Options

Item Description

Body Color Sets the color of Functional I/O and Concept block bodies.

Creation Mode Set by the UI.

Descriptor Locations Shows the Descriptor Locations Map

Here you can reposition the various block

descriptors.

Image Display Mode

None - no image or cad block is inserted in the created block.

Image - insert the image that is pointed to in the Image File Path of the Details tab for this

device.

DWGIcone - insert the DWG Icon in the DWG Icon File Path of the Details tab for this device.

Image Position

Image Scale Factor
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Image inserted and scaled at MiddleCenter
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Merge and Center

This function will only merge identical port names

Shape Mode
Read Only

Shape Path

Stock Shape Number Set by the Stock Shapes tab selection

Text Height The height of all generated text.

Vertical Padding

Vertical Pin Spacing

Pin Width

Body Width

Body Pen Width The thickness of the line that represents the block body.
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Vertically Center Pins

Nudge Positions Use to nudge the various text around.
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Tears and Bulge

Factors

Tears are visual elements that represent to the reader of the document that the device does not

display all of its available I/O. Tears use bulges. The greater the bulge factor the more dramatic

the tear.

Bottom edge torn bulge factor .15 or 15/100

Bottom edge torn bulge factor .5 or 50/100

Set Current Display

Properties as Project

Default

Reset Project Default
Clears any settings

Reset Device Settings
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Stock Shapes Options

Here you choose from 18 stock shapes. We will not enumerate them here. Try clicking on them to see what they

do.

Mappable Terminals Options

Here you can map the selected I/O on to terminals. Terminals are one or two port inline devices. If you select more

that one record in the I/O tables we will continue to add terminals to accomodate the selection. If you select a

terminal that has only an input port then any selected output records will be ignored.

Item Description

Example showing

multiple I/O selected

and mapped on to a

terminal that

represents a full

normal jack

User Defined Shapes Options

Any CAD file can be used as a User Defined Shape. It jsut needs to be placed in the Shape Files folder:
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%BLOCKS%\Shapes Files

The Display Properties with then scale and stretch the object while applying port data.

Item Description

User Defined Shape

with four ports

applied.

Mechanical Forms Options

Mechinal Forms are hardcoded objects that get their dimensional data from the device definition and use it to

render objects

Item Description

Rack Enclosure

Select a form. Only available when Front Panel (from Dims) is selected.

Rack Tray

Cube

Half Rack Left

Half Rack Right
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Database > Equipment Library [I/O] [Add Ports]

Drawing > Advanced Tools > Equipment Library [I/O] [Add Ports]

Commandline: le

Several Others

Explanation

This is the Port Adder dialog. With it you add a single record, two records, or multiple records to the I/O grids.

Here are some things to consider when naming your ports:

1. For feed-through connections or bulkhead panels set the input and output Name the same.

2. Consider naming patchbay ports A-# and B-# for the top and bottom rows.

3. It doesn't matter which side you place a port on. You can always move it later.

4. For bi-directional signals such as Ethernet or RS-422 consider your document flow when determining the list to

which you will add these ports.

5. When selecting the connector gender always consider that WireCAD needs the CABLE END of the connection,
not the chassis side.

Dialog Options

Item Description

Add to Which List

Port Name Enter the port name here.
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Connector (Cable

End)
From the global Connectors table.

Signal Type From the global Signal Types table.

Input Pin Style Straight pin (Normal) or looped (two connection points).

Output Pin Style Straight pin (Normal) or bridged (two connection points).

Add Multiples If checked a record will be created for each Count. The number will be appended to

the Port Name info and formatted based on the Leading Zeros format.

Finally Append

Characters

Useful if you want to add characters after the multiple count number has been

appended. See the example below for more info.

Examples

Example Result

Add a single port to

the Inputs table.
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Add a single port to

the Inputs and

Outputs list at the

same time.

Add 10 ports to each

grid appending a port

number to each

record.
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Now let's create the 8

left line inputs of a

stereo mixer. We will

use the [Finally

Append Characters]

field to append the

characters -LEFT

after the number is

created and

appended to the Port

Name.
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4.1.3.2.2.2  Rack Builder Tool

Drawing > Advanced Tools > Rack Builder

Commandline: rb

Explanation

Automatically generate rack layout. Technically speaking we are populating rack locator grids. They may or may

not display an actual rack depending on whether you have assigned a SysName to a rack.

Dialog Options

Item Description

The [Basic] tab
allows you to select
the locations to
include in the Rack
Building function. As
you select each
location, the
Systems Involved list
will populate. 

Systems Involved 
list

Displays a list of all the systems that will be placed in the created drawing.
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Item Description

The [Advanced] tab
exposes properties
that control the
behavior of the
utility.

 Chassis Width Sets the width of the chassis in DU

 Height in RU Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm)

 Slot Count Sets the number of slots per locator grid. This is used to position items that may not
be located at the insertion point of the rack unit. 

 Slot Delimiter WireCAD searches the Elevation field for numeric values first then for the slot
delimiter if found it parses the the data into two values the elevation and the slot, or
in other words how far up in the rack and how far over.

 Insertion Point Where to start the whole process

 Attribute Height If view rule is not ShowDWGInPath, sets the attribute height of the displayed text.

 View Rule ShowDWGInPath = use the dwg file found in the equipment definition BlockRef
(Front Panel File).
CreateFromDimensions = use the dimension data from the equipment definition to
create a 3D rack block.
CreateFromDimensionsIfNotFound = Use dimension data if the BlockRef is not
found.

Place Text If Item

Cannot Be Created

If the item cannot be created due to lacking data, place a text marker in the drawing
at the location.

Include hashes This will normally be checked unless you are rebuilding a drawing that already has the

locator grids.
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Item Description

Spacing DU Sets the location grid spacing in Drawing Units

4.1.3.2.2.3  Assign Sysname

Drawing > Advanced Tools > Equipment Library [Add to Project Database Only (Assign SysName)]

Double-click WireCAD Block

Commandline: le

Explanation

This dialog is presented when assigning a SysName. The SysName field is automatically generated based on the

project SysName Format and the Next Numbers table.

Dialog Options

Item Description

Manufacturer and

Model
Filled automatically in most cases.
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SysName This number is automatically generated based on the project SysName Format and

the Next Numbers table. WireCAD will always present the next number though you

do not have to use it. In fact, there are times when you should select the exisitng 

SysName from the dropdown list. For example say you have shown the video ports of

VTR-01 in one drawing and the audio ports of VTR-01 in another drawing. When you

assign the first instance you will get VTR-01 as the suggested SysName. The second

instance will suggest VTR-02. You will then click the dropdown and select VTR-01

thus ensuring that the two representations of the same device have the same name.

Alias Friendly, functional, or descriptive name for the device.

Location Location of the device. For more information see the Locations Grid . Clicking the

[+] button shows the New Locations  dialog.

Elevation If numeric then WireCAD assumes RU. If not numeric it does not matter. There is one

special circumstance where the data will be non-numeric but WireCAD will understand

how to parse it. That is the situation when we want to locate something in a slot in a

frame in a rack. We will need to use the form [elevation][slot delimiter][slot]. For

example let's say that I have a DA that needs to go in slot 5 of a frame located at

elevation 20 and my project slot delimiter is a dash [-]. I would type into the Elevation

field 20-5 

User Fields 50 characters max. You can define these captions in the Translation Manager -

Plugins > Translation Manager. Search for SysNameUser in the key field.

IP Address Subnet

Mask
Masked to either IPv4 or IPv6 based on the Project Settings dialog.

Power Consumption Pulled from the global Equipment definition or typed manually here.

Weight Pulled from the global Equipment definition or typed manually here.

Flags Sort, query, filter flags. You can define these flags in the Translation Manager -

Plugins > Translation Manager. Search for SysNameFlagItem in the key field.

453

295
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4.1.3.2.2.4  Assign Cable Number

Double-click WireCAD Cable

Commandline: ac

Explanation

This dialog is presented when assigning a Cable number. The Cable Number field is automatically generated

based on the project Cable Number Format and the Next Numbers table.

This dialog is show only when the Verbose Cable Assignment option is checked on the Advanced Tools ribbon

tab.

Dialog Options

Item Description
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CableNo This number is automatically generated based on the project Cable Number Format

and the Next Numbers table. WireCAD will always present the next number though

you do not have to use it.

Cable Type Manu Cable Type Manufacturer.

Cable Type* Cable Type.

Signal Type* Signal Type.

Named Path List of Named Paths . See the documentation on the Named Paths table.

Selecting a Named Path will cause the Length field to change.

Length Manually enter the cable length or select a Named Path.

Integrator Who is responsible for the installation of this cable.

User Fields You can define these captions in the Translation Manager - Plugins > Translation

Manager. Search for CableUser in the key field.

Sheet Automatically filled with the current drawing name.

Replaced By A housekeeping field that you may choose to use.

Pinout If the Enable Pinouts setting is checked then select the Pinout to apply to this cable.

* changes to these fields may cause the number to recalculate.

455
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4.1.3.2.2.5  SysName Error Check

Drawing > Advanced Tools > Drawing SysName Error Check

Commandline: drawingsysnameerrorcheck

Explanation

Check the drawing against the database. Checks the following:

Retrieves all equipment from the drawing.

Checks the drawing SysName against the database.

If matched the record is shown normally. If orphaned or not assigned the background color will be changed.

Dialog Options

Item Description

Show Me Zooms to the selected entity

Check for Errors Scans then fills the grid.
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4.1.3.2.2.6  Add Multi-core Cable

Drawing > Advanced Tools > Add Multi-core Cable

Commandline: mc

Several Others

Explanation

Often times we install bundled cables - cables with multiple cores. The outside jacket gets a number and each

inner core an extension identifier like: A-1001-RED. Where A-1001 is the number that goes on the outer jacket and

 A-1001-RED goes on the RED core. Use the Add Multi-core Cable tool to create a record in the database for each

core in the Cable Type. The CableNo field will have the full number and the CableNoPrefix field will have the

number base. All cores will be marked Available for use. You can then assign one or all or any of them during the

normal Cable Number Assignment process. You must have Verbose Cable Assignment checked in order to

assign cores in a multi-core cable. Otherwise you will get the next number default.

Dialog Options

Item Description

Number Base This is the part that goes into the Cable No Prefix field

Cable Type Only Cable Types that are flagged as Multi-core will show here.

Signal Type
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4.1.3.2.2.7  Cable Error Check

Drawing > Advanced Tools > Drawing Error Check

Commandline: dec

Explanation

Check the drawing against the database. Checks the following:

Retrieves all cables from the drawing.

Checks the drawing Cable against the database.

If matched the record is shown normally. If orphaned or not assigned the background color will be changed.

Dialog Options

Item Description

Show Me Zooms to the selected entity

Check for Errors Scans then fills the grid.
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4.1.3.2.2.8  Auto Block

Drawing > Advanced Tools > Auto Block

Commandline: ab

Explanation

The Auto Block tool automatically places functional blocks in the drawing. This tool requires that the Project

Systems table be populated. 

Possible Uses

Add functional blocks after creating SysNames from Rack Builder drawings.

Create overall systems views.

Create drawings from imported data.

Fore more information view this topic on the Auto Block tool.

Dialog Options
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Item Description

The [Basic] tab

allows you  to

determine which

systems to add to

the drawing.

Location Filter Filters the left-hand list by location
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Item Description

The [Advanced] tab

allows you to refine

the behavior of the

utility.

Insertion Point The point we start from. 

Horizontal Spacing

DU

How far apart horizontally. The vertical spacing is defined by the height of the highest

block in the row.

Maximum Column

Count

How many columns horizontally

Get Port Data From

Cables Database

Select this option to search the cables database for port info instead of the global

equipment database. This will effectively show only those ports to which we have

attached cables.

Display As How to display the blocks

Display Preferences If Functional Block or Concept block is selected then set basic display parameters. 

Signal Types to

Display

Filter ports by the selected signal types.
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4.1.3.2.2.9  Ratsnest

Drawing > Advanced Tools > Ratsnest

Commandline: rn

Explanation

The Ratsnest tool works in conjunction with the Auto Block tool. How it works:

Get the cables collection.

Get the SysName>Port info from the drawing.

Find matches.

Drawing straight-line cables.

Possible Uses



WireCAD v8 User Manual358

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Create overall systems views.

Create drawings from imported data.

Dialog Options

Item Description

This tool has three

sections. The Rats

Nest section does the

work of placing the

cables in the drawing

as defined in the

Cables database.

[Ratsnest] Run the utility to place the cables.

Show Cable Numbers With or without cable numbers.

[Clear All Cables] Removes ALL cables from the drawing.

[Cleanup] Applies the autorouter to all cables in the drawing.

Avoid Other Cables Autorouter avoids other cables on cleanup.

[Fillet] applies fillets to all cables in the drawing

Distance fillet distance in 100/DU.
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4.1.3.2.2.10  WireCADify Block

Drawing > Advanced Tools > WireCADify Block

Commandline: wirecadifyblock

Explanation

Occassionally you will want to use the geometry of a non-WireCAD generated CAD block. In order to do this you

will need to give the necessary attribute set to the CAD block so that it can function in WireCAD as a working

assignable entity.

Steps

Start the command.

Select a standard CAD block. It must be a block and not exploded entities.

Follow the directions in the dialog to complete the process of adding the WireCAD attribute set to the CAD

block.

Possible Uses

Use existing CAD drawings and work with WireCAD to move the drawing forward.

Create custom appearance. 

Dialog Options
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Item Description

Attribute Map Grid Map your attribute to WireCAD's.

Descriptor Locations Reposition the base WireCAD attributes using the Descriptor Locations map.

Hide All Add all the WireCAD attributes but hide them from view.

Show Default Show the default attribute set

Preview Preview of the merged block.
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4.1.3.2.2.11  Add Connection Point

Drawing > Advanced Tools > Add Connection Point

Commandline: addconnectionpoint

Explanation

If you need to place a connection point (a point to which you can connect a WireCAD cable). You can use this

tool.

You must use this tool on blocks that have the WireCAD attribute set.

Steps

Start the command.

Select a WireCAD block or a block that you have run the WireCADify command on.

Select the geometric point at which the connection point will appear. This should be something that is easy to

snap a WireCAD wire to.

Follow the directions in the dialog to complete the process of adding the WireCAD attribute set to the CAD

block.

Possible Uses
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Use existing CAD drawings and work with WireCAD to move the drawing forward.

Create custom appearance. 

Dialog Options

Item Description

Port Name

Signal Type

Connector (Cable

End)

Port is Input This will determine which side the label appears on.

Label Text Height Label text height if shown

Show Labels

Include Geometry Display something to snap to.
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4.1.3.2.3  Plan View  and Layout Tools Dialogs

The following set of tools is targeted at the plan view space.
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4.1.3.2.3.1  Take Offs

Drawing > Plan View and Layout Tools > Take Offs

Commandline: showtakeoffs

Explanation

Often we need to count items in the plan view space for quoting or other purposes. The Take Offs tool facilitates

this process by filtering the drawing for specific entity types on specific layers then counting those instances.

Possible Uses

Quote preparation.

Trouble-shooting.

Dialog Options

Item Description

Print Print the grid.

Export Export the grid.

Layer What layer are we searching for the selected entity type(s).
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Item Description

Entity Types What entity type(s) are we searching for.

Generate Do It! The results will be displayed in the grid.

Count Count the items in the list. The results will be displayed in the right-hand list.

Grid Columns

   ItemHandle

ShowMe

Zooms to show the item in the drawing.

   Block Name or

Entity Type

   IgnoreInCount Ignore me when counting

Examples

Step Description

This first example

counts all inserts in

the drawing on all

layers.
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Step Description

Our drawing looks

like this

In our Take Offs tool

we select the Insert

button. Then click

[Generate] and

finally click [Count].

Step Description

Now let's count all

circles on the

CEIL_SPKR layer.
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Step Description

Our drawing looks

like this

In our Take Offs tool

we select the Circles

button, and select the

layer on which to

search.
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Step Description

Then click [Generate]

and finally click

[Count].

As you can see we

have 20 circles that

appear on the

CEIL_SPKR layer.
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4.1.3.2.3.2  Draw  Backbone (ENT Only)

Drawing > PlanView and Layout Tools > Draw Backbone

Commandline: none

Explanation

Backbones are collections of cable/fiber that are contained in a single jacket that run from one location to another

and are typically sized for growth. An example might be a fiber optic cable that contains 288 fiber cores that runs

from building A to building B. We know that initially we will not use all 288 fibers and have planned for growth. As

the facility needs change the usage of the backbone's fibers change.

WireCAD maintains backbones just like any multi-core cable with the exception that the Cables table record is

flagged IsBackBone = true.

WireCAD will create a cable record for every core in the Cable Type used.

Prerequisites

1. SysNames assigned to the panels/equipment to which you will attach the ends of the Backbone.

2. Multi-core Cable Type representative of the Backbone.

Operation
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This tool allows you to draw geometry in the Plan View space that represents the path of the Backbone. The

process requires the following steps:

1. Draw the polyline that represents the backbone.

2. If locations boundaries are found in the drawing the source and destination locations will be used. Otherwise

you will be prompted to define a location for each end.

3. Next you will be presented with the New Backbone tool where you will select the source and destination panels/

ports and the cable type.

4. Clicking [OK] will build a record in the Cables table for each core in the multi-core cable type.

5. The polyline length populate the cable record Length field.

Related Topics

Dialog Options

Item Description

New Backbone Select whether we are creating a new number or assigning existing unused core.

Backbone ID The number

Use Existing

Available

Location Filter Filter the list by location

From Panel Info Select the panel. The ports will be shown in the list.

To Panel Info Select the panel. The ports will be shown in the list.

Cable Type Select the Cable Type.
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Examples

Step Description

Our drawing looks

like this

Step Description



WireCAD v8 User Manual372

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.3.2.3.3  Draw  Cable

Drawing > PlanView and Layout Tools > Draw Backbone

Commandline: pwdc

Explanation

This tool allows you to draw a cable in Plan View space that is assigned to the Cables table.

Prerequisites

1. SysNamed source and destination equipment placed in the Plan View space or:

2. Source and destination Location Boundaries placed in the Plan View space.

Operation

This tool allows you to draw geometry in the Plan View space that represents the path of the cable. The process

requires the following steps:

1. Start the tool.

2. Select the source SysNamed equipment.

3. Select the destination SysNamed equipment.

4. Place the points in the polyline to finalize the appearance.

Related Topics
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Draw Cables

Dialog Options

Item Description

Cable Type

Source Information The source SysName is pulled from the drawing. You will need to selection the Src Pin

and such.

Destination

Information

The destination SysName is pulled from the drawing. You will need to selection the

Dest Pin and such.

Other Stuff

Cable No Click the [...] button to generate a cable number.

45
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4.1.3.2.3.4  Populate Cables

Drawing > PlanView and Layout Tools > Populate Cables

Commandline: popc

Explanation

This tool pulls the cables from the Cables table into the drawing. The assumption with this tool is that you will use

it after you have done your functional drawings and assigned cable numbers and SysNames.

Prerequisites

1. SysNamed source and destination equipment placed in the Plan View space or:

2. Source and destination Location Boundaries placed in the Plan View space.

3. Cable data in the Cables table that matches the placed equipment or locations.

Operation

1. Start the tool.

2. Select the source SysNamed equipment.

3. Select the destination SysNamed equipment.

4. Place the points in the polyline to finalize the appearance.

Related Topics
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Draw Cables

Dialog Options

Item Description

Group Cables

Must connect to

equipment in the

drawing

Ignore cables that

come and go to the

same location

Flag if other is is not

found

Polyline Bulge Factor

45
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4.1.3.2.3.5  Draw  Prew ire

Drawing > PlanView and Layout Tools > Draw Prewire Cable

Commandline: pw

Explanation

This tool allows you to draw geometry in the drawing that represents cables that have not yet had their functions

assigned. The only thing we know about these cables is the locations from which they start and end and the Cable

Type. A record will be added to the Cables table based on the count defined. The record is marked Available and

PreWIRE. Prewire cables can be automatically consumed later if the 

Prerequisites

1. Source and destination Location Boundaries placed in the Plan View space.

Operation

1. Start the tool.
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2. Fill in the form.

3. Draw the cable path.

Related Topics

Draw Cables

Dialog Options

Item Description

Cable Type Select the Cable Type

Signal Type Select the Signal Type

How Many How many wires of this type take this path. A record will be created for each.

Length Divisor We will divide the length of the polyline by this value and place that info in the Length

field of the record. For example, say your Drawing Unit = 1 inch and you want the

length in the Length field to be displayed in feet. Your Length Divisor would be 12.

Create Named Path Create an entry in the Named Paths table with the name provided and length of the

polyline.

45
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4.1.3.2.3.6  Populate Equipment

There is no UI for this function

Drawing > PlanView and Layout Tools > Populate Equipment

Commandline: pope

Explanation

This tool pulls the Plan View version of the equipment from the Equipment List. The assumption with this tool is

that you will use it after you have done your functional drawings and assigned cable numbers and SysNames.

This tool relies on the Plan View File in the device definition to know what to place. 

It relies on Location Boundaries in the drawing to know where to place it.

If the Plan View File is blank the Project Default Plan View File will be placed if the Location Boundary is found:
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Application Menu > Settings [Project][Basic][Default Plan View Block File]

Prerequisites

1. SysNamed equipment preferably with an associated Plan View File in the global Equipment Library.

2. Location Boundaries placed in the drawing.

Operation

1. Start the tool.

2. A message box will explain the operation of the function. Click [OK]. The tool will run.

3. At completion the tool will report the number of placed items.

Related Topics



WireCAD v8 User Manual380

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.3.2.3.7  Location Boundary

Drawing > PlanView and Layout Tools > Location Boundary

Commandline: pw

Explanation

Define geometric boundaries for locations important to the design. For example we would want to know where on

the drawing the Machine Room is but not necessarily the kitchen (unless part of our cable ends up in the kitchen).

Prerequisites

1. Source and destination Location Boundaries placed in the Plan View space.

Operation

1. Start the tool.

2. Select a text entity with the name of the location to pre populate the dialog.

3. Set the location type and geometry type.

4. Draw the boundary

5. Done. Lather , rinse, repeat.

Related Topics

Dialog Options

Item Description

Cable Type Select the Cable Type

Signal Type Select the Signal Type
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Item Description

How Many How many wires of this type take this path. A record will be created for each.

Length Divisor We will divide the length of the polyline by this value and place that info in the Length

field of the record. For example, say your Drawing Unit = 1 inch and you want the

length in the Length field to be displayed in feet. Your Length Divisor would be 12.

Create Named Path Create an entry in the Named Paths table with the name provided and length of the

polyline.

Examples

4.1.3.3 Data Dialogs

The following is a collection of dialogs that may be presented while in the Data or Grid environment.
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4.1.3.3.1  New  Location

Database > Locations [New]

Commandline: none

Explanation

This tool is used to create entries in the project Locations lookup table.

Prerequisites

1. None

Operation

1. Start the tool.

2. Enter the data in the fields as desired.

3. Verify the the Qualified Location looks acceptable (its the part that the rest of WireCAD uses).

4. Click [Add].

Related Topics

Locations Lookup table

Locations form reference

Defining Locations

453

453

62
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Dialog Options

Item Description

Campus Enter the Campus name if applicable. If there are multiple numbered campuses you

can increment the Count field to append a number and create multiple records for

each. 

Building Enter the Building name if applicable. If there are multiple numbered buildings you can

increment the Count field to append a number and create multiple records for each. 

Floor Enter the Floor name if applicable. If there are multiple numbered Floors you can

increment the Count field to append a number and create multiple records for each. 

Room Enter the Room name if applicable. If there are multiple numbered Rooms you can

increment the Count field to append a number and create multiple records for each. 

Rack Enter the Rack name if applicable. If there are multiple numbered Racks you can

increment the Count field to append a number and create multiple records for each. 

Qualified Location This is the important part. The Qualified Location is a concatenation of all the used

fields. The fields are merely and organizational construct for you. WireCAD will use

the Qualified Location throughout the application.

Example

In the following example we will add two locations using different approaches to acheive the same result.
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Step Result

Enter the data across

all fields.

Enter the data in a

single field

As you can see from the above examples the Qualified Location is the same for both. It does not matter which
approach you take.
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4.1.3.3.2  New  Cable

Database > Cables

Commandline: cg

Explanation

This tool allows you to manually create a Cable in the Cables table.

Prerequisites

1. SysNamed source and destination equipment in the Equipment List

Operation

1. Start the tool.

2. Select the source SysNamed equipment.

3. Select the destination SysNamed equipment.

4. Click the [...] button on the Cable No field to generate a Cable Number.

Related Topics

Dialog Options
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Item Description

Cable Type

Source Information The source SysName is pulled from the drawing. You will need to selection the Src Pin

and such.

Destination

Information

The destination SysName is pulled from the drawing. You will need to selection the

Dest Pin and such.

Other Stuff

Cable No Click the [...] button to generate a cable number.



Reference 387

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.3.3.3  New  Manufacturer

Database > Manufacturers [File > New]

Commandline: none

Explanation

This tool allows you to create a new Manufacturer in the Global Equipment database.

Related Topics

Dialog Options

Item Description

Manufacturer Name The Manufacturer Name

ManufacturerID Friendly ID

Display Where Where to show this manufacturer.
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Item Description

Website
Optional

Image
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4.1.3.3.4  New  Equipment Wizard

Database > Equipment [File > New]

Commandline: none

Explanation

This tool allows you to create a new Equipment definition in the Global Equipment database.

Related Topics

Dialog Options

Item Description

Manufacturer Select the Manufacturer

EquipmentName/

Model/Part Number

Name it

Description Describe it.

SysName Prefix Be brief.
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Item Description

Front Panel File Pointer to the front panel file.

Image

Categories
This is for you. Create categories and synonyms.

Synonyms

Abbreviation
Not really used yet.

Accessory Of
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4.1.3.3.5  New  Cable Type

Database > Cable Types [File > New]

Commandline: showcabletypesgrid

Explanation

This tool adds a new Cable Type to the Global Equipment database. Cable Types may be either single or multi-

core and have different shielding configurations. WireCAD projects use the multi-core core color code if any as the

descriptor when identifying multi-core cables. The Cable Type Name and Manufacturer are used in the Cable

record. All other fields are maintained for reference of the designing engineer.

More About Multi-core Cable Types

WireCAD can create multi-core cable types at two different levels of detail:

Core level.

Conductor level.

Cores have conductors. Conductors being the base unit. Most people using WireCAD will not document down to

the conductor level but rather the Core level.
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Prerequisites

1. None

Related Topics

Create a New Cable Type

Form Options

Item Description

Save Do It!

ManufactureID Select a manufacturer. Only Manufacturers that are flagged as DisplayInCabletypes

appear in this list.

Cable Type or P/N The name by which this cable type shall be known.

Description A description for posterity

Cable Char Z Characteristic Impedance.

Cable OD Outside Diameter.

Cable Gauge Gauge

Cable Rating Rating

170
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Item Description

Cable Weight
Standard put up length and weight

Standard Length

Core/Conductor Configuration

   Shielding Shielding determines how many conductors.

   Is Multi-core Flag this Cable Type as multi-core.

   Core Count How many cores

   Conductors per

Core

Usually one

   Conductor Count

Including Shield(s)

Set automatically

   Default Core/Fiber

Mode

SM/MM

   Color Code Applies

To:

Apply a color code to the conductors, cores or not.
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4.1.3.3.6  Synchronize Global Databases

Database > Sync Global Database ..

Commandline: sync

Explanation

This tool allows you to sync two Global Databases. The current Global Database will be synchronized with the

database you select in this dialog. The local and remote database may be either SQL Server of VISTADB. You

may import, export or sync with respect to the current Global Database. An Import would collect data from the

remote database and import it to the local Global Database.

Prerequisites

1. Two Global Databases. The currently active one and a remote one.

Related Topics

Sync Basics

Form Options

112
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Item Description

External Database

Location

   Database is Server

Based

Enter the host information and login. 

Else browse to the location of the WireCADGlobalEquipment.vdb3 file.

   

Import With respect to the current Global Database. This would import data into the current

Global Database.

Export With respect to the current Global Database. This would export data into the external

Global Database.

Bidirectional Sync the two.

Advanced Settings

Which collections to

include
By default you would want to sync all tables.
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4.1.3.4 Report Dialogs

Database > Cables

Commandline: cg

Explanation

This tool allows you to manually create a Cable in the Cables table.

Prerequisites

1. SysNamed source and destination equipment in the Equipment List

Operation

1. Start the tool.

2. Select the source SysNamed equipment.

3. Select the destination SysNamed equipment.

4. Click the [...] button on the Cable No field to generate a Cable Number.

Related Topics

Dialog Options
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Item Description

Cable Type

Source Information The source SysName is pulled from the drawing. You will need to selection the Src Pin

and such.

Destination

Information

The destination SysName is pulled from the drawing. You will need to selection the

Dest Pin and such.

Other Stuff

Cable No Click the [...] button to generate a cable number.
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4.1.3.4.1  New  Report Wizard

Reports > New with Wizard ...

Commandline: rw

Explanation

Create a new report using the New Report Wizard.

NOTE: We recommend that you find an existing report that is close to what you are looking for and modify that

after saving it with your name. It will save you time and effort.

Prerequisites

1. Open Project

Operation

1. Start the tool.

2. Step through the wizard

3. Finish the wizard.

4. Edit the report in the designer to finalize it.

Related Topics

Creating Reports 93
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4.1.3.4.2  Scan for Discrepancies

Reports > Scan Project for Discrepancies ...

Commandline: dr

Explanation

Scan for common issues.

This tool will generate data in the project Discrepancies table. You can view it by double-clicking the item in the

Project Explorer.

Prerequisites

1. Open Project

Operation

1. Start the tool.

2. Select items to scan for.

3. Open the project Discrepancy report from the Project Explorer.

Related Topics

Dialog Options

Item Description
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Disconnected Pins This is really noisy as it shows all available ports (from the global database) that do not

have connections to them in the Cable table.

Duplicate Ports If you duplicated a port in two places you will be warned on cable number assignment

this will warn you again.

Duplicate Cable

Numbers

If you duplicated a number here it is.

Duplicate SysNames If you duplicated a SysName here it is.

Forgotten SysNames If the SysName appears in the Equipment List but not in any drawing.

Append/Reset Keep the discrepancy list in tact or reset and start over.

Clear All Data  Reset and start over.

4.1.3.5 Plugins Dialogs



WireCAD v8 User Manual402

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.1.3.5.1  Plugin Manager

Explanation

The WireCAD Plugin Manager shows all loaded plugins.

WireCAD Plugin Types

WireCAD has facility for two types of plugin:

1. Auto-discovered plugins. These plugins register themselves on application startup. They may or may not include

a graphical user interface element.

2. Registered plugins. These plugins register themselves via a plugin manifest file located in the C:\Program

Files\WireCADx\bin\plugins\*.wpi. Registered plugins will place a button somewhere in the WireCAD workspace

and may respond to WireCAD events.

Related Topics

Included Plugins

Dialog Options
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Item Description

Load Loads the selected plugin from the Unloaded Plugins grid.

Unload Unloads the selected plugin from the Loaded Plugins grid.

Rescan and Reload

All

Unloads then rescans and reloads all plugins

Plugin Creation

   Add/Edit PI info (*.

wpi)

Edit a wpi file.

   Edit Plugin Code Open #Develop to edit plugin code.
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4.1.3.5.2  Script Editor/Runner

Explanation

Often times there are operations that you find yourself repeating endlessly. Scripts are a good way to automate

those processes. There are many example scripts to browse through and see how they work.

NOTE: Scripts that run in WireCAD MUST have the following method signature or they will not execute:

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using WireCAD;

using WireCAD.Interfaces;

//You may add additional using statements as needed but the listed ones are the minimum.

public class Script
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{

public static void Run(Workspace ws)

{

//do your stuff here

}

}

Possible Uses

1. Title block filling

2. New Drawing creation

3. Database cleanup

Usages

1. Launch the tool.

2. File>Open an example script. (c:\users\public\WireCAD\WireCADx\Scripts\).

3. Read the comments (they are the ones proceeded by //).

4. Tweak the script to suit your needs.

5. Run it by clicking the [RUN] button 

6. Fix any compiler errors. Lather, rinse, repeat.

Dialog Options

Item Description

New Creates a new script with the necessary signature.

Open Opens a .cs file to run.

Comment Comment out your selection. Useful for hiding code from the compiler without deleting

it.

Un Comment Un comment your selection

Indent

Outdent
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Run If the Error List is empty then Do It. If if fails it will tell you why in the Compiler Output

window.

Window On Top Make this the topmost window always

Error List Design time scripting errors

Compiler Output Run time compiler and script execution errors.

4.1.3.5.3  Translation Manager
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Explanation

All visible text strings in WireCAD are contained in dictionary that is editable via the Translation Manager. The

current UI culture is queried for a string. If not found the English version is returned.

You can right-click a column header and select the KeyString column to should the base English string that the

program searches from.

NOTE: Some forms and dialogs only get their text strings on program start so changes here will not be visible to

all areas of the application until you restart WireCAD.

Possible Uses

1. Translate WireCAD into a different language.

2. Change user column names and labels in the application to aid your process.

Form Options

Item Description

Current Culture is: The culture of your machine. If no translation exists, WireCAD defaults to the en

(English) language.

Select Language To

Translate:

Selects the language to edit in the right-hand column.

Show Context Select to display a column showing the primary context in which the string or

message appears.
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4.1.3.6 PDF Viewer Dialogs
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4.1.3.6.1  PDF Print Preview

Project Explorer > Double-click PDF File [Print]

Commandline: None

Explanation

This is the Print Preview Dialog for the PDF Viewer. It's pretty standard so we won't enumerate all the controls

here.

Prerequisites

1. At least one pdf file saved in the project drawings path.
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4.2 Forms

Enter topic text here.

4.2.1 Application Menu Forms

4.2.1.1 Project Information

4.2.1.2 Account Info

4.2.2 Global Data Forms



Reference 411

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.2.2.1 Manufacturers Grid

Database > Manufacturers

Commandline: man

Explanation

This tool provides access to the Manufacturers table of the Global Equipment database. The grid is hierarchical.

The [+] buttons may be expanded to show related equipment.

Deletes here cascade, deleting any equipment that is associated with the Manufacturer.

Prerequisites

1. There is at least one Manufacturer added to the Global Equipment database.

Related Topics

Grid Basics

Form Options

79



WireCAD v8 User Manual412

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Item Description

New Show the New Manufacturers dialog

Attach Document ... Any document may be attached to any record. This is a handy place to store

manufacturer data sheets, images and such.

Remove Duplicates This function scans the table for duplicate Manufacturer Names. If found the following

occurs:

All equipment is rolled up under the top instance of the manufacturer.

All other instances are deleted.

The collection is saved.

NOTE: a safety valve exists where if the Manufacturer is flagged to

DisplayInCableTypes the function is ignored.

387
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4.2.2.2 Equipment Grid

Database > Equipment

Commandline: eg

Explanation

This tool provides access to the Equipment table of the Global Equipment database. The grid is hierarchical. The

[+] buttons may be expanded to show related Inputs and Outputs.

Deletes here cascade, deleting any I/O associated with the Equipment.

Prerequisites

1. There is at least one Manufacturer added to the Global Equipment database.

Related Topics

Grid Basics

Form Options

79
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Item Description

New Show the New Equipment Wizard

Attach Document ... Any document may be attached to any record. This is a handy place to store

manufacturer data sheets, images and such.

Clean This function scans the table for Equipment with no I/O. If found the following occurs:

The Equipment definition is deleted.

The collection is saved.

Transfer to Different

Manufacturer

Allows movement of the selected device to a different Manufacturer.

389
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4.2.2.3 Signal Types Grid

Database > Signal Types

Commandline: st

Explanation

This tool provides access to the Signal Types table of the Global Equipment database. Many of the default display

behaviors originate here, for instance:

The color of pins on a block

The color of cables

The Cable Type associated with the Signal Type

The Cable Number prefix

Prerequisites

1. None

Related Topics

Grid Basics

Form Options

79
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Item Description

New There is no New button on this grid. The New Record Row appears at the top of the

grid:

Rename I/O Signal

Types

Rename the Signal Type in this grid and all I/O in the database.

Rebuild Signal Types

from I/O

This function scans the Inputs and Output for Signal Types then:

Checks existing in this grid.

Add if not found.

Collection is saved.
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4.2.2.4 Connectors Grid

Database > Connectors

Commandline: cn

Explanation

This tool provides access to the Connectors table of the Global Equipment database. 

Prerequisites

1. None

Related Topics

Grid Basics

Form Options

Item Description

New There is no New button on this grid. The New Record Row appears at the top of the grid:

Rename I/O

Connector Types

Rename the Connector in this grid and all I/O in the database.

79
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4.2.2.5 Cable Types Grid

Database > Signal Types

Commandline: st

Explanation

This tool provides access to the Signal Types table of the Global Equipment database. Many of the default display

behaviors originate here, for instance:

The color of pins on a block

The color of cables

The Cable Type associated with the Signal Type

The Cable Number prefix

Prerequisites

1. None

Related Topics

Grid Basics

Form Options

79
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Item Description

New There is no New button on this grid. The New Record Row appears at the top of the grid:

Rename I/O Signal

Types

Rename the Signal Type in this grid and all I/O in the database.

Rebuild Signal Types

from I/O

This function scans the Inputs and Output for Signal Types then:

Checks existing in this grid.

Add if not found.

Collection is saved.
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4.2.2.6 Color Codes Grid

Project Explorer > Color Codes

Commandline: showcolorcodesgrid

Explanation

This tool provides access to the Color Codes table of the Global Equipment database. 

Prerequisites

1. None

Related Topics

Grid Basics 79
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4.2.2.7 Pinouts

Database > Pinouts

Commandline: po

Explanation

This tool provides access to the Pinouts table of the Global Equipment database. The concept of the Pinouts tool

is to create a data set that describes two connectors and the conductors between them. The Cable Type data

needs to have conductor level data. The data may be attached at the project level to a cable. The data can also be

churned into a preview.
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Prerequisites

1. None

Related Topics

Grid Basics

Form Detail Tab Options

Item Description

Select Existing

Pinout Profile

Select a named pinout to fill the grid and subsequent preview.

Show More Detail Shows more rows of data to edit.

Preserve Pin Order

When Creating

Preview
How is the Preview created.

Ortho Conductors

Pinout Grid Edit the pinout data to assign the conductors to the pins and termination methods and

so on.

79
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Clicking the New button enables the New Tab. From here you enter the overall data for the pinout. The Lefthand
and Righthand connectors conductor counts, etc. Once the pinout is created you can edit the detail in the Detail
tab.

Form New Tab Options

Item Description

Lefthand Connector

Info

Enter the connector type, pin profile (if any) and count.

Cable Type Select the Cable Type. Remember this type must have conductor level data. Core

Level data alone will not suffice here.

Righthand Connector

Info

Enter the connector type, pin profile (if any) and count.
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4.2.3 Project Data Forms
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4.2.3.1 Backbone Grid (ENT ONLY)

Databases > Backbones

Commandline: bbg

Explanation

This is the Backbones view and includes a visualizer that can produce both ladder diagrams and riser diagrams. 

Here you can view and search Backbone data. You can also set the Status of a Backbone.

Prerequisites

Backbones created in the project database.

Related Topics

New Backbone

Backbones

Grid Basics

130

125

79
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Data Tab Options

Item Description

Search Search the collection for the search term.

Find All Clear the search field and return all records.

Tools

   Attach Document Any document can be attached to any record. This is useful for storing cut-sheet data,

test data, and images.

   Rename Source

Connector(s)

Rename all of the connectors on the source side of the cables that comprise the

backbone.

   Rename

Destination

Connector(s)

Rename all of the connectors on the destination side of the cables that comprise the

backbone.

   Rename Fiber

Mode

Rename all of the fiber modes on the cables that comprise the backbone.
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Visualization Tab Options

Item Description

Show All Shows all backbones in the database in the Visualize tool

Current Record Allows selection of only those backbones that touch the selected record. 

Search Depth How many branches deep are we going to search. 

Search Width How many backbones per branch.

Appearance

Location Marker

Spacing



Reference 429

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Location Marker Text

Height

Location Marker Color

Junction Dot Radius

Vertical Backbone

Spacing(DU)
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Center Label Format String used to create the center label. Can make use of the following variables:

{0} = Backbone Number

{1} = Total Count

{2} = Total Available Count

{3} = Total Dead Count

{4} = Single Mode Fiber Count

{5} = Available Single Mode Fiber Count

{6} = Dead Single Mode Fiber Count

{7} = Multimode Fiber Count

{8} = Available Multimode Fiber Count

{9} = Dead Multimode Fiber Count

Example:

assume that our backbone number is 1001 with 12 single mode fibers of which 1 is

dead and four are in use.

String:

B{0}-SM COUNT:{4} Avail:{5} Dead:{6}

Output:

B1001-SM COUNT:12 Avail:8 Dead:1

String:

B{0}

Output:

B1001

Center Label Offset Offset from center in DU

Show SysNames Shows the SysName labels

Ignore Same

Locations

Hides backbones that originate and terminate in the same location
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SysName Rotation

Angle

Sets the rotation angle of the SysName label if shown

SysName Text Height

(100th DU)

Sets the height of the SysName text if shown

SysName Text Offset Offset from the endpoint of the backbone

Riser Diagram Mode

Campus and Building The Campus and Building for which to build the riser diagram

Layout 

Max Columns, 

Column Spacing,

Minimum Row Height

Determine the layout of the panels in the diagram

Body Color, Body

Width, Descriptor

Locations

Determines the appearance of the body of the panels in the diagram
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Show Terminals if

Backbone Leaves the

Building,

Terminal Offset

If the other end of the Backbone is not in the selected building a terminal will be

placed and a backbone drawn to it. The terminal's position from the port on the panel

is determined by the Terminal Offset property.

Apply Jumps

Avoid Other Cables Instructs the cable autorouter to attempt to avoid other cables.

Show Unresolved

Backbones

If the Backbone cannot be placed in the drawing a list is generated. Enabling this

setting shows the list as the function completes.

Title and Comment Block

Show Title Sets the visibility of the title/comment block
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Title Position

Show Time Stamp

Title Text Height

(100th DU)

Title Offset

Title

Misc.

Backbone Color by

Signal Type

Pulls the backbone color from the global Signal Types database.

Show Directional

Coloring

Shows green dots for the source end of the backbone and red dots for the destination

end if shown.

Backbone Color Sets all backbones to the color defined.

[Reset Default] Button to reset the settings to the defaults.

Visualize Tab Options

Item Description
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Export Export to file.

Copy To Clipboard Copy to clipboard

Refresh Refresh the preview.
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4.2.3.2 Circuits Grid (ENT ONLY)

Databases > Circuits

Commandline: circ

Explanation

This is the Circuits view. Circuits are collections of cables. In most cases they include jumpers between panels

and Backbones. Circuits consist of a set of ordered elements and a strand count. 

This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this grid

will create a functional diagram of the selected Circuit.

Prerequisites

Creation of at least one Circuit

Related Topics

Circuits 143



WireCAD v8 User Manual436

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Combine Circuits

Grid Basics

Data Tab Options

Item Description

Search Search the collection for the search term.

Find All Clear the search field and return all records.

Tools

   Attach Document Any document can be attached to any record. This is useful for storing cut-sheet data,

test data, and images.

   Rename Circuit Change the name of the Circuit

   Output All Selected

Circuits

Uses the grid selection to determine which Circuits to write out to files.

   Combine Circuits Displays the Combine Circuits  dialog.

167

79

167
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Visualization Tab Options

Item Description

Source, Middle and

Destination Shape

Choose one of the 16 stock shapes

Source, Middle and

Destination shape

Width in (100th DU)

How wide is it

Source, Middle and

Destination shape

Color

Set the color of the shape

Source, Middle and

Destination shape

Descriptor Locations

Drag the descriptor to

the location map or to

the Hidden Items list

to hide.

Backbone Color

Sets the color
Jumper Color

Horizontal Cable

Color
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Merge and Center

Text in Body

Text Height controls the height of all text in the visualization.

Layout

Max Columns The maximum number of blocks placed before a new row is started below.

Column Spacing The distance between blocks

Row Spacing The Distance between rows

Title and Comment Block

Show Title

Title Position

Show Time Stamp

Title Text Height

(100th DU)

Title Offset

Title You can type whatever you want in this field. In addition the following variables are

available:

{0} = Circuit Number

{1} = It System

Misc.
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Show Attenuation

Labels

Show field survey labels in the CAD preview

Show Jumper Length

Labels

Show Backbone

Length Labels

Show Jumper

Numbers

Show Backbone

Numbers

Show Length

Visualize Tab Options

Item Description

Export Export to file.

Copy To Clipboard Copy to clipboard

Refresh Refresh the preview.
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4.2.3.3 New Circuit (ENT ONLY)

Database > Circuits [File > New]

Commandline: st

Explanation

This tool provides a means but which to create a new circuit. Circuits can either be assembled manually by follow

the paths of panels through Backbones and jumpering to the next element of the first and last elements may be

defined and then handed to the Path Finder tool which will find and present candidate routes. 

Prerequisites

1. Backbones added.

Related Topics

New Circuit 145



Reference 441

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.2.3.4 New Backbone (ENT ONLY)

Database > Backbones [File > New]

Commandline: none

Explanation

Create a new Backbone

Prerequisites

1. None

Related Topics

Backbones Grid

Backbones

Grid Basics

426

125

79
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4.2.3.5 Equipment List

Databases > Equipment List

Commandline: sys

Explanation

This is the main Equipment List of all SysNames in the project. You can edit and ripple your changes from here.

This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this grid

will create a system snapshot of the selected SysName.



Reference 443

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Prerequisites

Assigned SysNames

Related Topics

Assign SysName

Grid Basics

Data Tab Options

Item Description

Search Search the collection for the search term.

Find All Clear the search field and return all records.

Ripple List Changes you have made that may need to be rippled across the drawing set. The

ripple will occur after you save the grid to the database.

Note: you do not need to ripple changes that do not appear in a drawing. For example

if you change the Cable Type Manu and Cable Type fields, neither of those fields

have a corresponding display in a drawing. So no ripple is required to keep the drawing

in sync with the database. If you are unsure - ripple.

Tools

   Attach Document Any document can be attached to any record. This is useful for storing cut-sheet data,

test data, and images.

   Slurp Locations Collect all location data from the Equipment list and populate the Locations table with

it.

347

79
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Visualization Tab Options

Item Description

Terminal Select the terminal to which we will attach the cables.

Vertical Pin Spacing

1/100 DU

How far apart vertically are the ports.

Use Last Display

Order if Set

Use Last Saved

Appearance

Where is the SysName label positioned with reference to the end points of the polyline

that represents the cable.

Body Width The text height of the SysName label.

Port Data Source Pull the port data from the Equipment Library which will show all available ports as

defined in the Equipment Library or pull port data from the Cable table which will show

only ports which have cables attached.

Title Block Enable
Title Block stuff

Text Height 1/100 DU
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Title Location

Title Offset

Title

Data Tab Options

Item Description

Export Export to file.

Copy To Clipboard Copy to clipboard

Refresh Refresh the preview.
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4.2.3.6 Cables

Databases > Cables

Commandline: cg

Explanation

This is the main Cables table view. You can print, export and edit this view. Some fields are marked read only

because they inherit their data from other tables. Changes to those fields should be done in the other tables then

rippled into this table.

This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer associated with this grid

will create a Ladder diagram of the selected cables.
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Prerequisites

Cable numbers assigned in a drawing.

Related Topics

New Cable

Grid Basics

Data Tab Options

Item Description

Search Search the collection for the search term.

Find All Clear the search field and return all records.

385
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Ripple List Changes you have made that may need to be rippled across the drawing set. The ripple

will occur after you save the grid to the database.

Note: you do not need to ripple changes that do not appear in a drawing. For example if

you change the Cable Type Manu and Cable Type fields, neither of those fields have

a corresponding display in a drawing. So no ripple is required to keep the drawing in

sync with the database. If you are unsure - ripple.

Expert Mode Removes the read-only flags and puts the grid in a completely editable state. Not for

beginners.

Add Many Only available in Expert Mode this tool adds blank records to the table that you can

edit as a spreadsheet.

Tools

   Repair Equipment

List

Scans the Cables table for SysNames then compares with the Equipment List.

Missing SysNames are then added to the Equipment List.

   Attach Document Any document can be attached to any record. This is useful for storing cut-sheet data,

test data, and images.
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Visualization Tab Options

Item Description

Terminal Not yet implemented.

Cable Number Text

Height

The text height of the Cable Number element

Vertical Spacing

1/100 DU

How far apart vertically are the cables.

Center Label Offset Where is the center label positioned with reference to the center of the polyline that

represents the cable.

SysName Label

Offset

Where is the SysName label positioned with reference to the end points of the polyline

that represents the cable.

SysName Text Hit The text height of the SysName label.
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Port Info Format

String

The following variables can be used along with the /n new line character to format the

port info:

{0}SysName

{1}Port

{2}Location

{3}Alias

{4}Connector

{5}Cable Number

{6}Cable Manufacturer

{7}Cable Type

Example:

Assume that the SysName is VTR-01. The PortName is VID-OUT and the Location is

RK-10 The following Port Info Format string:

{0}>{1}@{2}

Will produce the result:

VTR-01>VID-OUT@RK-10

Cable Text Format

String

The following variables can be used along with the /n new line character to format the

Cable Text:

{0}Cable Number

{1}Cable Manufacturer

{2}Cable Type

{3}Length

{4}Sheet

Location Marker

Spacing

How far apart horizontally the vertical location markers are spaced.

Location Marker Text

Hit

Location Marker

Color

Location Marker Pen

Width
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SysName Rotation

Angle

Show Dot Direction

Color

Display a green dot on the source side and a red dot on the destination side of the

cable.

Show SysNames Show/Hide the SysName.

Color By Signal Type Inherit cable color by Signal Type or set a single color for all cables.

Collapse Multi-core

Cables to Single Line

Multi-core cables are represented by many records in the Cables table. You can

choose to display a cable for each or collapse to a single cable.

Title Block Enable

Title Block stuff

Text Height 1/100 DU

Title Location

Title Offset

Title

Data Tab Options

Item Description

Export Export to file.
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Copy To Clipboard Copy to clipboard

Refresh Refresh the preview.
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4.2.3.7 Locations

Databases > Locations

Commandline: showprojectlocationsgrid

Explanation

This is the main Locations table view. You can print, export and edit this view. Changes to this grid can be rippled

throughout the project.

Remember that the only bit of data WireCAD actually uses from this grid is the QualifiedLocation.

Prerequisites

None

Related Topics

New Location Dialog

Grid Basics

Form Options

382
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Item Description

Search Search the collection for the search term.

Find All Clear the search field and return all records.

Ripple List Changes you have made that may need to be rippled across the drawing set. The

ripple will occur after you save the grid to the database.
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4.2.3.8 Named Paths

Databases > Named Paths

Commandline: shownamedpathsgrid

Explanation

The Named Paths grid is an organizational tool to keep track of key distances. We name a path and give it a

distance and other factors to determine. You can use it as a reference, as well as a length calculator in the Assign

Cable Numbers dialog.

Prerequisites

None

Related Topics

Assign Cables

Grid Basics

350
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4.2.3.9 ToDo

Databases > Todo List

Commandline: tdl

Explanation

A To Do list. You can define the data that fills the following dropdowns in the Todo List Settings  panel:

Assignees

Statuses

Priorities

Prerequisites

An active project.

Related Topics

Todo List Settings

Grid Basics

271

271
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4.2.3.10 Drawings

Project Explorer> Project Databases > Drawings

Commandline: sdg

Explanation

This is the list of drawings in the Project\Drawings folder tree. The following changes in the Drawings table have

occurred in WireCAD v8:

The DrawingsPath has changed from absolute to relative.

The tool now scans for and lists pdf files.

The dwg and pdf file is embedded in the database for portability.

NOTE: to rename a drawing use the function in the Project Explorer. Right-click a closed drawing and select the

context menu item Rename Drawing.

Prerequisites

An active project.

Related Topics
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Grid Basics

4.2.4 Report Forms

79
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4.2.4.1 Print Preview

Visible only when the active environment is a report.

Explanation

This is the default view that loads when a report is loaded. From here you can determine the number of pages to

print and to which device. 

Form Options

Menu Item Description

Save Save the rendered document to the native print document format (.prnx). NOTE: this is

the rendered document not the report design. The report design can only be saved from

the Report Designer tab.

Print Print with options.



WireCAD v8 User Manual460

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Quick Print Print to the default printer.

Options The Print Options dialog.

Parameters Show the Parameters pane (if applicable to the report).

Header/Footer Edit the Header/Footer if applicable to the report.

Scale

Obvious
Margins

Orientation

Size

Find

Obvious

Bookmarks

First Page

Previous Page

Next Page

Last Page

Select

Obvious

Pan

Zoom

Many Pages

Zoom Out

Zoom Percent

Zoom In

Page Color Set the page background color
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Watermark Define the report Watermark. Not visible at all product levels

Export To
Obvious

E-Mail As

4.2.4.2 HTML View

Visible only when the active environment is a report.

Explanation

This is the report rendered to html. The controls are self-explanatory.
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4.2.4.3 Report Designer

Visible only when the active environment is a report.

Explanation

Here we design the report. The menus are obvious so we won't bother. What may not be obvious the the Banded

Report design and the Smart Tag. Smart Tags will be displayed on entities that are selected (if available) like so:
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Smart tags can be expanded to so entity specify settings. Here we see properties specific to the Detail Band:

Related Topics

 A discussion on report design can be found here .

Menu

Item

Sub

Menu

Description

New

Report

New

Report

A new blank report. You are starting from scratch. 

93
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New

with

Wizard

A new report using the New Report Wizard. We recommend finding an existing report

that is close to the finished product and modifying that after a save as.

Open...

Save Save

Obvious

Save As

Save All

Cut

Copy

Paste

Font The font settings for the currently selected object(s).

Alignme

nt

The alignment settings for the currently selected object(s).

Layout Tools to position and arrange the currently selected object(s).

View Zoom the designer

Scripts A collection of scripts associated with this report.
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4.2.4.4 Toolbox

Visible only when the Report Designer Tab is active.

Any of these tools can be added to the report under design.

Menu Item Description

Pointer Selection tool

Label The most common tool. Can be used to display static text or if the text is held in

square braces[]. For example: a label with the caption S:[SRCSys]>[SRCPin] will

render S:SomeSrcSys>SomeSrcPin once for every record in the collection.

Check Box A Check Box is used to display True/False or Checked/Unchecked/Indeterminate

values in a report.

Rich Text The Rich Text control allows you to display formatted text in your report. It can

represent static or dynamic text, or both.

In addition to the capability to embed plain text into your report (using the Label

control), you may need to display RTF or HTML content as well. WireCAD does not

use RTF or HTML natively but there is no reason you could not put formatted text in a

user field.
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Picture Box Picture Box is used to embed static (stored along with the report definition) or

dynamic (obtained from a data source) images into a report.

It can display images of various file formats: BMP, JPG, JPEG, GIF, TIF, TIFF, PNG,

ICO, DIB, RLE, JPE, JFIF, EMF, WMF.

Panel The Panel control is a container that frames separate report controls to allow them to

be easily moved, copied and pasted, and visually unites them in the report preview (with

borders or a uniform color background).

Table The Table is used to display tabular information in a report.

Note

Table reports should not be confused with hierarchical master-detail reports or cross-

tab reports.

You can create two tables simultaneously, e.g., one for showing column titles in the

Page Header, and the other for showing regular information in the Detail band.

Line The Line control draws a line of a specified direction, style, width and color. It can be

used for both decoration and visual separation of a report's sections. Note that the Line

cannot cross bands.
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Shape The reporting engine provides you with the capability to embed shapes into your

reports. You can simply add an Shape control to a report, choose one of the available

shape types, and then print or export this report.

The following shapes are available:

Arrow

Brace

Bracket

Cross

Ellipse

Line

Polygon

Rectangle

Star

Bar Code A Bar Code object. The supported bar code types are:

1D Barcode Types 2D Barcode Types

Codabar ECC200 - Data Matrix

Code 11 (USD-8) GS1- Data Matrix

Code 39 (USD-3) Intelligent Mail

Code 39 Extended PDF417

Code 93 QR Code

Code 93 Extended

Code 128

EAN 8

EAN 13

GS1-128 - EAN-128 (UCC)

GS1 - DataBar

Industrial 2 of 5

Interleaved 2 of 5
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Matrix 2 of 5

MSI - Plessey

PostNet

UPC Shipping Container

Symbol (ITF-14)

UPC Supplemental 2

UPC Supplemental 5

UPC-A

UPC-E0

UPC-E1

Zip Code The Zip Code control transforms its content into a zip code.

To specify the text for the control, use the ZipCode.Text property.

Note that the Zip Code control can only display numeric characters and dashes. Other

characters are displayed as empty zip boxes.

Chart The Chart control visualizes the series of points using the available 2D chart types or

3D chart types. The chart type is defined via the View property of a series. And, a

single chart can display multiple series, if their view types are compatible.

A Chart contains multiple visual elements (diagram, axes, titles, labels, strips,

constant lines, etc.) and, when any of these elements is selected, its properties are

shown in the Property Grid.

Guage The Gauge control provides you with the capability to embed graphical gauges into

your report.

Sparkline The Sparkline control displays a compact chart that is commonly used to reflect the

flow of data for every row in a report.
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Pivot Grid The Pivot Grid allows you to create a pivot table, an Excel-inspired data visualization

application for multi-dimensional data analysis. Using the Pivot Grid, large amounts of

data can be summarized and represented in a cross-tabular format that can be sorted

and filtered. Also, since the Pivot Grid provides customization you can freely change

the layout of the report based on your analysis requirements, using simple drag-and-

drop operations. It also supports drill-down (to view the underlying data for calculated

cells).

Sub-Report The Sub-Report control is used to embed reports into each other; this allows you to

create Master/Detail reports (reports with hierarchically linked data).

Table of Contents The Table of Contents control allows you to provide your report with a table of

contents that reflects the hierarchical structure of the report bookmarks.

Page Info The Page Info is used to display auxiliary information on report pages, such as date,

time, page numbers or user name.

Page Break The Page Break control's sole purpose is to insert a page delimiter at any point within

a report.

This control is visually represented by a short line, attached to the report's left margin.

The Page Break control is useful when you need to insert a page break between

controls within a report band - for example, to divide subreports, so that the second

subreport starts printing on a new page.

You can also insert a Page Break before or after a specific report band using the

Band.PageBreak property.

Cross-band Line Cross-band controls are used to draw lines and rectangles through several bands, as

opposed to Line and Shape controls that can be used only within a single band.

The following two cross-band controls are available:

Cross-band Line allows for the drawing of vertical lines, which are not restricted to a

particular band. For example, it can be used to emphasize a report section consisting

of multiple band areas.

Cross-band Box allows for the drawing of rectangles through several bands. It can be

used to encompass a report section consisting of multiple band areas.

Cross-band Box
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4.2.4.5 Cable Data Selector

Visible only when the active environment is a report.

Explanation

This tool allows you to pick and choose which cable records to print without having to create a complex filter.

Simply select the records to print in the Select This field and set the number of copies to print then click the 

[Apply] button

Related Topics

Menu Item Description

Reload Reloads the data. All current selections are cleared then the data is reloaded from the

Cables table.

Clear All Uncheck all

Select All Check all

Copies Number of copies to print
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Pad with Empty

Records

Useful when trying to use a label on a sheet of labels that has already had some use.

Apply Do IT!
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4.2.4.6 Bill of Materials Generator

Reports > Generate Bill of Materials

Commandline: bom

Explanation

Before a Bill of Materials (BOM) report can display data, that data must first be generated. We generate Bill of

Materials data with a Snapshot Name. The report that you run will group be Snapshot Name.

You can choose which items to count in the BOM and refine your counts by creating filters.

One of the most common misunderstandings with the BOM generator is how it deals with cable lengths. The

generator sums all lengths of a give Cable Type. But what if you have specified a premade cable of 2 meter length?

In this case we don't want to total the length but rather the quantity. To handle premade cables take the following

steps:

1. Create a new Cable Type  with the cable length in the name. For example an of the shelf 2 meter HDMI cable

might be named: OTS HMDI 2m. This will show up in the Cable Type field of the Cables table and further in your

BOM.

2. When entering the Cable Length for pre made cables enter the Length as 1. 

In the BOM you will then see a count of your OTS HDMI 2m cables.

391



Reference 473

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Prerequisites

1. You will need an active project with SysNames and Cable data.

Related Topics

Grid Basics

Form Options

Item Description

Snapshot Name Name is something unique that you will remember.

Include Equipment

What to include
Include Cable Types

Include Connector

Types

Filter Equipment Apply a filter to the set. Clicking the [...]

Filter Cables

79



WireCAD v8 User Manual474

© 2015 Holbrook Enterprises, Inc. dba WireCAD

4.3 Tool Panels
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4.3.1 Project Explorer

View > Tool Panels > Project Explorer

Commandline: none
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Explanation

This is the main access point to the project. From here you can:

Open global database grids.

Open drawing(s).

Open Project Database grids.

Rename drawings.

Prerequisites

In order to see project related information you will first have to open a project.

Related Topics

Tool Panel Options

Item Description

Open Project Folder
 Show the current project folder in a windows folder browser.

Project Properties
 Show the Project Info  form.

Refresh
 Refresh the Project Explorer.

Equipment Library
 Show the Equipment Library .

410

323
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4.3.2 Draw Cables

View > Tool Panels > Draw Cables

Commandline: none
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Explanation

The Draw Cables tool panel is only active when the current environment is a drawing. This tool allows you draw

several different types of cables:

One-to-One - One output to one input.

One-to-Many - One outputs to many inputs.

Many-to-One - Many outputs to one input.

Many-to-Many - Many outputs to many inputs.

Terminal to Point - Drag a Terminal into the drawing an drop it on a connection point in the drawing. This will

place the terminal on the left hand side of the block.

Point to Terminal - Drag a Terminal into the drawing an drop it on a connection point in the drawing. This will

place the terminal on the right hand side of the block.

Prerequisites

Requires and open drawing.

Related Topics

Draw Cables 45
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4.3.3 Drawing Properties

View > Tool Panels > Drawing Properties

Commandline: none
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Explanation

Provides access to the drawing properties. If no selection set exists in the drawing the general document

properties are presented. If a selection exists then the common properties of all items in the selection set are

displayed for edit. You may also select a single item from the selection set and edit all of its properties.

Prerequisites

An open drawing.

Related Topics

Tool Panel Options

Item Description

Selected Object This combo box displays the selected object and allows you to selected individual

items from the drop down.

Property grid The properties displayed here will all have property editors that are specific to the

entity type.

Sort/Group/Display

Descriptions/Search

toolbar buttons
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4.3.4 Find

View > Tool Panels > Find and Replace

Commandline: none



Reference 483

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Explanation

Find and replace text found in any drawing and in editable fields of the project databases. The found list will tell

you the context in which the searched text appears.

NOTE: found text may occur in an invisible attribute. 

Changiing a port name on a device using the Find and Replace tool requires that you change the text in the

following contexts:

The visible attribute.

The invisible CP_IN or CP_OUT attribute string. This is a pipe delimited string that contains the name|conn|type.

You must change the name portion of this.

Any records that exist in the Project Cables table that reference that port.

Prerequisites

An active project

Related Topics

Tool Panel Options

Item Description

Find

Search Where Only the active drawing.

All project drawings

Project Equipment list, Project Cables, Project Backbones, Project Circuits.

Search Options Show/hide the file name and context

Replace With Some text
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Results

Displays the context in which the text is found

Replace Selected

button

Do the replacement. The drawings and grids will need to be saved to commit the

changes.

Find/Cancel Do it! 

Cancel search.
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4.3.5 Plan View

View > Tool Panels > Plan View

Commandline: none
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Explanation

This tool panel provides three tabs. Each tab houses a gallery of Plan View blocks. The tabs are:

All Plan View Files - Enumerates the %BLOCKS%\Plan View Files\ folder tree presenting a preview of each

dwg file. Each sub folder will be added as a gallery group and items in that folder added to the group.

Project Plan View Items - Provides a gallery item for each SysName in the Equipment List. If the SysName's

equipment definition has an empty Plan View File, the project Default Plan View File is presented.

Equipment Library Plan View Files - Shows all Equipment Library items that have data in the Plan View File

field. 

Prerequisites

An open project.

An open drawing.

Related Topics

Tool Panel Options

Item Description

Place with Rotation

and Scale

If checked then when placing the selected item in the drawing you will be prompted to

scale the X, Y, Z and set the Rotation angle.

Plan View Galleries Click an item to add it to the drawing. Then place (and scale/rotate).
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4.3.6 Favorites

View > Tool Panels > Favorites

Commandline: none
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Explanation

Often times we find ourselves creating the same block or circuit configuration over and over. These times are a

great candidate for a Favorite. Creating a Favorite stores the item(s) as a block in the OS in one of three places:

Global - Saves in the %BLOCKS%\Favorites path and may be visible to other user with the same support path.

User - Saves to your user profile. Visible only to you.

Project - Saves in the Project\Favorites folder for use by anyone with access to the project.

Prerequisites

A drawing with the block or configuration you want to save as a Favorite.

A drawing into which you wish to place a Favorite.

Related Topics

Tool Panel Options

Item Description

Explode If you have grouped a system together that includes multiple blocks and cables into a

single block. It will need to be exploded back one level to expose the individual

WireCAD objects.

Scale

List Double-click to add to the current drawing.
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4.3.7 Command Line

View > Tool Panels > Command Line

Commandline: none

Explanation

The Command Line interface to the application. Here you can view a history of commands and enter commads

directly. All commands entered must be executed by clicking the [Enter] key.

Prerequisites

None

Related Topics

My Space Bar is my Enter Key

Dialog Options

Item Description

Command History What went before

Command Prompt What the application is expecting of you. If no job is running or no input is expected

from you it will read: Command:,

Otherwise it will prompt you for some action:

Command Line Enter the command here

Calculator

273



WireCAD v8 User Manual490

© 2015 Holbrook Enterprises, Inc. dba WireCAD



491

© 2015 Holbrook Enterprises, Inc. dba WireCAD

The following index is generated from the online text and as
such the page numbers may represent a sub chapter
heading instead of the actual page.

The key word you are searching for will be in the sub
chapter.

A Note About the Index
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- C -
Cable     170, 187

cable core data     112

Cable Cores     29

Cable Data Selector     232, 470

Cable Error Check     353

Cable Management Specific Features and Functions  
  170

Cable Numbers     123

Cable Router X Offset     50

Cable Terminology     46

Cable Text Height     45

cable type     130, 169, 170

Cable Types     29, 112, 124, 125, 130, 147

Cable Types Database     147, 170

Cable Types Database.     170

Cable Types Grid     419

CableNo     65, 98

Cables     130, 147, 446

cables database     126, 130

Cables table     74

Cables Visualization tool     76

CablesCollection     98

CableType     65

CableTypeManu     65

CAD Dialogs     290

CAD Tools     217

cg     76

Chassis Width     69

Check In     108

Check in Project     250

Check-out     108

Choosing a Database Format     117

Circuit     147, 164, 189, 191

Circuit Grid     162, 164

Circuit Recursion     74, 76

Circuits Grid     161, 435

CktNo     65

Clearing Filter Criteria     79

CMS     162, 189

CMS module     130, 189, 191

CMS tools     122, 123

CMS Tools Concept     122

collections     94

Color Codes     29

Color Codes Grid     421

Column filtering     79

Column grouping     79

column header     79

Column hiding/showing     79

Column re-ordering     79

Column resizing     79

Combining Circuits     167

Command Line     126, 145, 161, 162, 489

community library     176

Concept     123

Connection Point     361

connectors     29, 112

Connectors Grid     417

Copy Selection Down     79

Core     126, 170

cores     126

Count     45

Create a New Label Report     98

Create a New Project     38

Create a Standard Report     94

Create Model Space Boundaries     41

Create New Circuit     147

CreateFromDimensions     69

CreateFromDimensionsIfNotFound     69

Creating a New Drawing     27

Creating a New Equipment Definition     27

Creating a New Project     27

Creating Template Drawings     87

Current Record     136

- D -
Data Dialogs     381

Data environment     199

Data Member     103

Data Source     136

Database     226

Database Format     117

Database Location     112

Database menu     29

Database>Equipment Library     29

Database>Sync v6-v7 Equipment Libraries     115

Default Pointer     45, 50

Deleting Cell Data     79

Deleting Selected Rows     79

Demystifying Synchronization     112

Description     183

design mode     90



WireCAD v8 User Manual494

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Destination     65

Detail Tab     31

Dialogs     198, 232

Dimension Styles     308

directory     183

Discrepancies     400

Display Hierarchical Detail Data     79

Display mode     43

display preferences     31, 43, 176

drag     103

drag fields     103

Draw Backbone     369

Draw Cable     372

Draw Cable Toolbar     45

Draw Cables     477

Draw Cables Control Descriptions     45

Draw Cables Toolbar     46

Draw Prewire     376

Drawing     213

Drawing Cables     27, 45

Drawing Dialogs     290

Drawing environment     199

Drawing Properties     479

Drawings     457

- E -
Edit Cable Numbers Dialog     65

Edit SysNames Dialog     64

Elevation     64

Enabling v7 Locations     38

Engineering Data tab     64

Equipment     29, 112, 125, 130, 147, 176, 177

equipment definitions     124, 176

Equipment Grid     413

Equipment Library     27, 29, 31, 34, 323

Equipment Library Access     29

Equipment Library.     74, 130

Equipment List     4, 442

Equipment List (SysNames)     74

Example     194

Export     112, 161, 162, 164, 194

Export Settings     193

Export to PDF, EXCEL, TXT, HTML, XML and more    
79

Export to Visio     297

- F -
Favorites     487

feature additions and changes     4

Feeder distances in 100/DU     45

Feeder Selection     45, 51

Fiber Mode     170

Field List     103

File     210

File>Export>[File Type]     79

filter     79

filter dialog     90

filter pane     79

Filtering Reports     90

Find     482

Find Tab     31

Flags     64

Floating License Lease     13, 14

floating licenses     13, 14, 15, 16, 17, 18, 23

Format     45

Front Panel File     34

Functional Block Diagram     147

- G -
global database     29

Global Equipment Database     112

grid     177, 187

GroupBy panel     79

grouping     79, 94

Groups     312

- H -
Height in RU     69

Hellerman Tyton     98

hide a column     79

hierarchical     94

Hierarchical display     79

home page     161

Hor Extension in 100/DU     45

host     38

How Rack Builder Works     70, 71, 72

How to Output a Circuit to CAD     162

How to Place Custom Titleblocks into Your Drawing    
105



Index 495

© 2015 Holbrook Enterprises, Inc. dba WireCAD

HOW TO: Add a New Location     62

How To: Add Equipment to Drawings     43

How To: Add Equipment to the Library     34

How To: Create a new drawing using the wizard     41

How To: Create a New Label Report     98

How To: Create a New Project     38

How To: Create a New Report     94

How To: Create Your Own Custom Titleblocks     107

How To's     124

HTML View     231, 461

- I -
I/O     130, 177

I/O ports     176

Image Editor     316

Images     314

import     112

Include hashes     69

Increment Selection Down     79

inputs     29, 67, 112

Inputs and Outputs     34

Insert     105

Insert Block Into Drawing     105

Insertion Point     69

Inserts Dialog     320

IO     43

IO Tab     31

IP Address     64

IsSequencial     64

- J -
Jumper     145, 147

Jumpers     147

Justified     94

- L -
Label Report     98

layered digraph     76

Layers     299

Layout     94

Layout Tools     363

Layouts     302

Leading Zeros     64

Lease Period     13

library     177

License Agreement     19

license expire     23

Licensing FAQ     23

Location     45, 64

Location Boundary     380

location change     69

Locations     38, 62, 453

- M -
Machine ID     13

Manage Security     242

Manual Draw     45

Manual Draw Cables     47

Manufacturer     34

manufacturers     29, 112

Manufacturers Grid     411

Many Cable Database Entries     45

Many-to-Many Cable     45, 54

Many-to-One Cable     45, 53

masked     65

Misc.     136, 158

model     34

Model Space Boundaries     310

Model Space Text Height     41

Moving Proejcts     108

Multi Core     170

multicore     65, 130

Multi-core     352

Multicore Data     65

- N -
Named Paths     455

New +     65

New Backbone     441

New Cable     385

New Cable Type     391

New Circuit     440

New Circuit tool     145

New Drawing     41

New Drawing Wizard     41, 291

New Equipment     34

new equipment block     43

new equipment definition     176

New Equipment Wizard     389



WireCAD v8 User Manual496

© 2015 Holbrook Enterprises, Inc. dba WireCAD

New Location     382

New Manufacturer     387

New Project     38, 182

New Project Wizard     183, 233

New Report with Wizard     94, 98

New Report Wizard     398

New Viewport     105

Next Numbers     38, 187

Next Numbers Database     64

Next Numbers Grid     187

Next Numbers table     38

- O -
One Cable Database Entry     45

One-to-Many Cable     45, 50

One-to-One Cable     45

Open Drawing     87

Ordinal     144

Orientation     94

outputs     29, 67, 112

Outputs track inputs     67

Outputting Circuits to CAD     161

- P -
Pack Up/Check Out     117

Packup     108

Packup / Checkout     246

Packup / Check-out     108

Panduit     98

parameters     89, 90

Path Finder     155

PDF Export     295

PDF Print Preview     409

PDF Viewer Dialogs     408

PDF viewer environment     199

Persist this equipment     67

Pinouts     29, 422

Place Text If Item Cannot Be Created     69

Plan View     363, 485

Plan View and Layout Tools     229

Plan View and Layout Tools Dialogs     363

Plugin Manager     402

Plugins     227

Plugins Dialogs     401

pn     34

Point Styles     304

Populate Cables     374

Populate Equipment     378

Port Data Source     74

port selection dialog     67

ports     130, 147

Post Process Scripting     194

Power Consumption     64

Prefix     177

Preview     89

Pre-wires     76

Print Preview     230, 293, 459

Printed Output Text Height     41

Printing Reports     89

PRO     13

Project     147, 182, 183, 187, 191, 209

Project Cables Grid     76

Project Database     130

Project Explorer     89, 90, 170, 475

Project Files Path     183

Project Name     183

Project Save As     239

Project Settings     126, 188

Project>New Project     38

Project>Open Project     115

Project>Utilities>Pack Up/Check Out     117

projects     124

Purge     319

- Q -
Quick Access Toolbar     199

- R -
Rack Builder     69, 177

Rack Builder Controls     72, 73, 74

Rack Builder Tool     27, 69, 345

Ratsnest     357

rb     69

Rectangular Array     318

Remember Settings     112

Replace Cable with Pointers     45

Report Design Basics     103

Report Designer     231, 462

Report filtering     90

Report Style     94



Index 497

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Report>New Report with Wizard     94

Reporting     88

Reporting environment     199

Reports     89, 229

Reports>New Report with Wizard     98

Ribbon Tabs     198

- S -
Save As Template Drawing     87

Scan for Discrepancies     400

Script Editor/Runner     404

Search Depth     136

Search Width     136

Searching     79

Security     114

Setting Up On a Network     114

Setting Up the WireCAD Global Databases on SQL
Server     119

Setting Up Your Global Data     27, 29

settings menu     161, 188

Show All     136

Show New Drawing Wizard     87

ShowDWGInPath     69

signal types     29, 112

Signal Types Grid     415

SignalType     65

Slot Count     69

Slot Delimiter     69

Software Activation     13

Software Key     15

Sort I/O By Last Display Order     74, 76

Sorting     79

Source     65

Source and Destination info     65

Spacing DU     69

Splice Points     60

SQL     124

SQL databases     38

SQL Server     117, 119, 182, 183

SQL Server database     182

Starting Cable Number     38

Status     126

Status Bar     112

Strand Count     144

Strand Count and Ordinal Explanation     145

Submit     89

Subnet Mask     64

suggest and test     38

sync     112

Sync Equipment Libraries...     112

Synchronize Global Databases     394

sys     74

SysName     64, 67, 69, 177

SysName Error Check     351

SysName Format     64

SysName Prefix     34

SysNames     64, 65

System Snapshot     74, 76

Systems Involved     69

Systems Involved list     69

- T -
Tabs     208

Take Offs     364

Template Drawings     41, 87

Template Drawings Support Path     87

Terminal     74, 76

Terminal as a Destination Cable     57

Terminal as a Source Cable     55

Terminal as Destination Window     45

Terminal as Source Window     45

Terminal Offset     45

Terminals     45, 67

Text Styles     306

The Application Button     199

The Application Menu     199

The Command Line Interface     199

The Draw Cables Tool Panel     199

The Drawing Properties Tool Panel     199

The Favorites Tool Panel     199

The Find and Replace Tool Panel     199

The Plan View Tool Panel     199

The Project Explorer     29

The Project Explorer Tool Panel     199

The Quick Access Toolbar     199

The Ribbon Toolbar     199

The Settings Dialog     261

Tidy Cables     45

Title and Comment Block     136, 158

Title Block     74

ToDo     456

Tool Panels     199, 474

Toolbox     231, 465

Translation Manager     406



WireCAD v8 User Manual498

© 2015 Holbrook Enterprises, Inc. dba WireCAD

Troubleshooting Activation     17

- U -
UNC     114

un-group     79

Unlock     65

Unpack     108

Unpack Project     248

upgrade a v5 or earlier project     115

Upgrading from v6     115

Use Database Server     183

Use Last Display Order if Set     74

Use Last Saved Appearance     74

Use Location Lookup     62

User 1 - 4     64

User Data tab     64

User Settings     188

Using The Backbone Grid     124

Using The New Circuit Tool     124

- V -
Variable     45

View     222

View Permissions     114

View Rule     69

View>Windows>Property Grid     90

VistaDB     117

Visualization Settings     142

Visualization tab     74

Visualization Tools     79

- W -
Weight     64

Who Is this Manual For     122

Wiki Links     170

WireCAD Cable Terminology     45

WireCAD Community Server     29

WireCAD Concept     122

WireCAD Nomenclature     124

WireCAD Project     38

WireCADify Block     359

work flow     122, 123

Work Flow Diagram     27

Workflow Diagram     27

Workspace     199

- X -
X Offset     45

XL FREE     13

XLT     13

XREF Manager     321

- Y -
Y Offset     45

Y Spacing     45

- Z -
Zero Administration     117




	Introduction
	New in Version 8
	Conventions and Terminology
	Software Activation
	License Agreement
	Licensing FAQ

	WireCAD XL, XLT, PRO
	Getting Started
	Setting Up Your Global Data
	Equipment Library
	Creating a New Equipment Definition
	Creating a New Project
	Creating a New Drawing
	Adding Equipment to Drawings
	Drawing Cables
	Defining Locations
	Assigning Unique IDs (SysNames)
	Assigning Cable Numbers
	Assigning Terminals
	Rack Builder Tool
	Equipment List Visualizer
	Cables Visualizer
	Grid Basics

	Personalizing WireCAD
	Template Drawings

	Reporting
	Printing Reports
	Filtering Reports
	Creating Reports
	Standard
	Labels
	Report Design Basics


	Frequently Asked Questions
	Placing Custom Titleblocks (Page Borders)
	Creating Custom Titleblocks
	Moving Projects (Pack Up/Check-Out)
	Synchronizing with Another Equipment Database
	Setting Up On a Network
	Upgrading from v7

	Choosing a Database Format
	SQL Server Setup


	WireCAD ENTerprise CMS Tools
	WireCAD CMS Introduction & Concept
	CMS Tools Concept

	CMS Basics
	Backbones
	The Backbone Grid
	How To Create a New Backbone
	Backbone Visualization Settings
	Backbone Visualization Layered Digraph Ouput
	Backbone Preview Export

	Circuits
	Circuits Grid
	New Circuit Tool
	Create New Circuit
	Path Finder Tab

	Circuits Preview Settings
	Outputting Circuits to CAD
	How to Output a Circuit to CAD
	How to Output Many Circuits to CAD
	Combining Circuits

	Cable Types
	Creating a New Cable Type

	Equipment
	Creating a New Equipment Definition

	Projects
	Creating a New SQL Project

	Next Numbers Grid

	Settings and Options
	User Settings
	Project Settings
	Output Settings
	Post Process Scripting


	Reference
	Ribbon Tabs and Dialogs
	The Workspace
	Ribbon Tabs
	Application Menu
	Project
	File
	Drawing
	CAD Tools
	Advanced Tools
	View
	Database
	Plugins
	Reports
	Plan View and Layout Tools
	Print Preview
	HTML View
	Report Designer
	Toolbox
	Cable Data Selector

	Dialogs
	Application Menu Dialogs
	New Project Wizard
	Project Save As
	Manage Security
	Packup / Checkout
	Unpack Project
	Check in Project
	Application Setup Wizard
	The Settings Dialog

	Drawing Dialogs
	CAD Dialogs
	New Drawing Wizard
	Print Preview
	PDF Export
	Export to Visio
	Layers
	Layouts
	Point Styles
	Text Styles
	Dimension Styles
	Model Space Boundaries
	Groups
	Images
	Image Editor
	Rectangular Array
	Purge
	Inserts Dialog
	XREF Manager

	Advanced Tools Dialogs
	Equipment Library
	Find
	Detail
	Inputs/Outputs
	Display Preferences
	Add Ports

	Rack Builder Tool
	Assign Sysname
	Assign Cable Number
	SysName Error Check
	Add Multi-core Cable
	Cable Error Check
	Auto Block
	Ratsnest
	WireCADify Block
	Add Connection Point

	Plan View and Layout Tools Dialogs
	Take Offs
	Draw Backbone (ENT Only)
	Draw Cable
	Populate Cables
	Draw Prewire
	Populate Equipment
	Location Boundary


	Data Dialogs
	New Location
	New Cable
	New Manufacturer
	New Equipment Wizard
	New Cable Type
	Synchronize Global Databases

	Report Dialogs
	New Report Wizard
	Scan for Discrepancies

	Plugins Dialogs
	Plugin Manager
	Script Editor/Runner
	Translation Manager

	PDF Viewer Dialogs
	PDF Print Preview



	Forms
	Application Menu Forms
	Project Information
	Account Info

	Global Data Forms
	Manufacturers Grid
	Equipment Grid
	Signal Types Grid
	Connectors Grid
	Cable Types Grid
	Color Codes Grid
	Pinouts

	Project Data Forms
	Backbone Grid (ENT ONLY)
	Circuits Grid (ENT ONLY)
	New Circuit (ENT ONLY)
	New Backbone (ENT ONLY)
	Equipment List
	Cables
	Locations
	Named Paths
	ToDo
	Drawings

	Report Forms
	Print Preview
	HTML View
	Report Designer
	Toolbox
	Cable Data Selector
	Bill of Materials Generator


	Tool Panels
	Project Explorer
	Draw Cables
	Drawing Properties
	Find
	Plan View
	Favorites
	Command Line



