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Foreword
This manual is a work in progress and does not contain all

function and help content information that will be available upon
the official release of WireCAD v7 . While you are viewing the

printed version, you can access up to date documentation along
with revision and hotfix information online at www.wirecad.com.
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1 Introduction

Welcome to WireCAD. WireCAD tools aim to decrease the frustration associated with creating accurate, detailed
documentation. WireCAD produces DWG compatible drawings.

 

What is WireCAD?
WireCAD is a cable management and facility design tool that allows you to easily create AutoCAD™ drawings.
WireCAD maintains a database of equipment, from which you can create equipment blocks for your drawings.
Equipment blocks are created dynamically from information stored in the equipment database. Rather than
maintaining a large library of equipment blocks or symbols, WireCAD stores this information in a database and
then creates blocks from the equipment definitions contained therein.  Equipment definitions are easily added to
the database. In addition to equipment databases, WireCAD also provides drawing tools to rapidly create
documentation, and database management tools to track:
· Projects
· Drawings
· Revisions
· Cable Types
· Signal Types
· Connectors
· Jack Fields
· Jacks

The biggest time saver comes when it is time to assign System Names and Cable Numbers to the equipment in
your drawing. All you do is double-click on the equipment pieces in the drawing to assign them a system name.
Then double-click on the cable and assign it a cable number. All of the information regarding the selected cable is
extracted from the drawing and placed in the project cables database and the drawing is updated with a new cable
number.
Extensive reporting is available for the project databases including:
· Project drawings
· Project revisions
· Cable run sheets
· Cable labels
· Equipment lists
· Bill of Materials
In addition, a powerful report designer is included with WireCAD for creating your own reports and labels, or
modifying existing report definition files.

Contents

New in 7
Software Activation
License Agreement
Licensing FAQ

4

10

16

16
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1.1 New in 7

The short list of feature additions and changes in the current release:

Features:
Added new Enterprise product level with Cable Management System tools. With these tools you can manage
large quantities of cabling in data form then use the visualization tools to create drawings from the data.
Conversion tools to allow you to use existing CAD drawing and add WireCAD attributes to make your CAD
drawings work with WireCAD.
We have replaced the Search tool with a really cool Find and Replace tool which shows the context in which the
search text was found and lets you determine which found items to replace.
The cables database is now bi-directional meaning that changes to the table can be rippled across the project…
Very cool.
Toolbars now remember their position…Yeah!
Faster data access.
Blocks created with v7 now remember their creation settings making for a nicer Edit Block in Place experience.
Renamed the Project Systems grid to Equipment List.
Faster settings access which improves the speed of the application.
Improve Most Recently Used Projects control and functionality.
More granular control of the drawing render settings.
We have changed the community server to allow user comments and ratings.
We have paged the amount of data returned by queries to the community server for faster response.
We have changed the reporting tool to allow cable record selection, count and padding. This allows you to select
(not filter but check a box) from your cables database which cables to print and how many. You can also pad
empty records to push the printed output to remaining labels on your sheet.
We have added batch plot capability.
We have added more user fields to each table in the project database now providing 12 string, 12 boolean and
12 integer fields in each table for user use.
We have finally fixed the decimal separator issue that has plagued us for years. 
You can now have more than one SysName of the same name as long as the SysName/Location pair is unique.
This allows you to create projects that reuse the same IDs as long as they are placed in a different location.
Added visualization tools to most project grids allowing you to see your data in CAD form with export capability.
We have added a recover signal types function that scans the existing IO in the global Equipment library and
adds any signal type found there but not in the master list.
We have added a recover SysNames tool to the project Cables grid to rebuild the project Equipment List from
data found therein but missing in the Equipment List.
We have added an Enterprise message server to keep multi-users aware of what each is doing in the
application.
We have added scripting support. Actually it was there in v6 we just didn’t expose it.
We have added selective sync to the Sync Equipment Libraries function. Now you can choose which collections to
sync or exclude.
We have added a center grip to cable polylines to provide a smoother cable moving experience. In addition, we
have add a cable Tidy tool to snap cables back onto ortho when moved by grips.
Control + Click removes  a vertex, Shift+click adds vertex.

New Plugins:
BatchPlot. Export any or all drawings to a printer/plotter in one pass.

SDK Changes:
We have made the following non-breaking changes to the Software Development Kit :

Added Events

QueryNextSysNameNumber - fired before WireCAD calculates the SysName. Allows
custom formats.

QueryNextCableNumber - fired before WireCAD calculates the next cable number.
Allows customs formats.

ValidateCableNumber - fired before WireCAD closes the Cable Edit dialog. Allows
custom validation of cable data.

165
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1.2 Conventions and Terminology

This manual attempts to follow these conventions. We use the word attempts because we are human and therefore
fallible.

Topic Header

Menu: Databases>Projects

Default command line shortcut: None
Function:
A description of the function goes here.

Applies To:
All product levels
Related Settings:
None

Chapter Heading

Menu: Databases>Projects
Default command line shortcut: None
Function:
A description of the function goes here.

Noteworthy Changes

Items or functions that are significantly different from previous versions will be flagged with this symbol

Normal Paragraph Text

Normal paragraph text appears like this.

 

Text You Must Type or Enter

In the event that you are required to enter text the instruction will be formatted as follows:

Please enter the path to the project in the textbox.

 

How To Topics

How to do something
1 You must do something..
2. Then something else.
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Notes

Please Note: Notes will look like this.

 

Text That Identifies or Explains a Graphic

This is the Command Line Interface

 

Button Presses

When you are Instructed to press a button and the button graphic is

not shown the text will be formatted as in the following example:

Press the [Start Cable] button to continue.

 

Menu Button Presses

Menu button presses will be formatted using the > symbol to indicate subsequent menu levels. If you are

required to select a specific function or tab the ~ character will be used to indicate a selection to make once the

form, dialog, or function executes.

Example: Click Tools>Inserts>Insert... ~ <OK> Then follow the directions...

 

Field Names or Other Program Labels

Field Names and Labels.
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Warnings

In the event that we feel something is important or could possibly damage a project or drawing we will issue
warnings as follows:

Please do not press this [button]. Bad things will happen!

Tips

Tips are displayed as follows:

Try pressing this [button]. It might be good!

 

What we Call Things

 

Button

Text Box, textbox, text edit or entry field.

 

Combo box or dropdown: Clicking the arrow on the right will drop a scrollable list.

Tabs or tab collection: When prompted to select a tab the caption text will appear as follows: Select the Find

Equipment tab.



Introduction 8

© 2013 Holbrook Enterprises, Inc. dba WireCAD

Property List: Information about the active property is displayed at the bottom of the list. Highlighting a property

causes it to enter edit mode. You can then enter data in the field on the right.

Please Note: the field on the right-hand side of the property list may be referred to as a textbox,
combo or dropdown depending on its type and function.

 

Ellipsis button: Pressing this button in what ever the current context will bring up a context sensitive dialog.
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  Checkbox

  
  Listbox
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1.3 Software Activation

WireCAD v7 offers 3 program levels:
XL FREE, XLT and PRO. XLT and PRO require authorization keys in order to activate that level of the software. An
activation key is all that is required to change program levels. If you have questions about the licensing scheme 
click here .

Topics

Floating Licenses
Floating License Leases
How To
Troubleshooting Activation

16

11

11

12

13
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Floating Licenses

Integral to WireCAD v7
is the ability to have a
single authorization key
activate multiple
concurrent machines if
your organization has
paid for more than one
seat. By default, when
you purchase a seat of
WireCAD your license
count for your key will
be set to 1 (one). 
operational.

This will allow 1 (one) machine to be active at a time. You may install WireCAD on any number of machines
throughout your organization; However, only one (or your license count) machine will be

Floating License Lease
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The mechanism by which
we float licenses is the
license lease. Leases
have expiration periods
of 24, 48, 72, 168 hours
and Never. During the
activation of your
software you will be
prompted to pick a lease
period. The lease period
is period during which
the software will run
while being disconnected
from the web. When you
activate the software
you are prompted for a
lease length. 

Once activated the application will run for the lease period. If you close the application while connected to the
internet you will expire the lease; thus making it available to another machine. Upon application startup the license
is validated and a lease is acquired automatically if web connected. If you cannot connect to the web you will need
to phone WireCAD support at:
1 661.253.4370 international.
1 866.273.5298 US and Canada toll free.

How To: Activate WireCAD

Enter your
authorization key (it's
the really long one
that ends in 70. If you
fail to enter the key
correctly you will not
be able to proceed.

If you are web
connected click the 
[Register By Web]
button. If everything
goes well you will see
this message in the 
Status window.

If you are not web
connected you will
need to call us at:

1 661.253.4370
international.
1 866.273.5298 US and
Canada toll free.

Click the [Register
by Phone] button.
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You will be prompted
by the WireCAD
technician to set 
Lease Period to
Never.

The WireCAD
technician will ask for
your authorization key
(it's the long one) and
your Machine ID.

Yours will be different
The WireCAD
technician will then
read a series of
numbers to you. Enter
these in the Register
by Phone text box.
Next click the 
[Continue] button.
You will receive a
message box
indicating the success
of the activation.

Troubleshooting Activation

The following are a few reasons your activation by web will fail:
1.Not connected
2.Lease already in use by another machine
3.Authorization key abuse
4.Authorization key not found in the database
5.Your machine Date/Time is more than twenty four hours out of sync with our web server (UTC).

If you wish to avoid the floating license scheme simply select Never as the lease length during
activation. You will then lock the authorization key to that machine.
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1.4 License Agreement

License Agreement 
YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE OPENING 
THIS PACKAGE AND/OR BY USING THE SOFTWARE. OPENING THIS PACKAGE OR USING THE 
SOFTWARE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO 
NOT AGREE WITH THEM, YOU SHOULD PROMPTLY RETURN THE PACKAGE TO THE LOCATION 
WHERE YOU PURCHASED THE SOFTWARE, UNOPENED WITH PROOF OF PURCHASE, 
AND YOUR MONEY WILL BE REFUNDED. 
 
Holbrook Enterprises, Inc. provides this program and licenses its use. 
Holbrook Enterprises, Inc. retains the ownership of this product.
 
LICENSE 
Permitted Uses/You May: 
* Use the software on any computer provided the software is used on only one 
computer and by one user at a time. 
* Copy the program into any machine readable or printed form for backup or 
modification purposes in support of your use of the program on a single 
machine. 
 
Prohibited Uses/You May not: 
* Make copies of the documentation or software, except as noted above. 
* Distribute, rent, sub-license, transfer, or lease the software or 
documentation. 
* Alter, modify or adapt the software or documentation, including, but not 
limited to, translating, decompiling, disassembling, or creating derivative 
works. 
 
This license and your right to use the software automatically terminate if 
you fail to comply with the provisions of this License Agreement. 
 
TERM 
The license is effective until terminated. You may terminate it at any other 
time by destroying the program together with all copies, modifications and 
merged portions in any form. It will also terminate upon conditions set 
forth elsewhere in this Agreement or if you fail to comply with any term or 
condition of this Agreement. You agree upon such termination to destroy the 
program together with all copies, modifications and merged portions in any 
form. 
 
IF YOU TRANSFER POSSESSION OF ANY COPY, MODIFICATION OR MERGED PORTION OF 
THE PROGRAM TO ANOTHER PARTY, YOUR LICENSE IS AUTOMATICALLY TERMINATED. 
 
TRADE SECRET 
You acknowledge that the software constitutes valuable trade secret 
information that is the exclusive property of Holbrook Enterprises, Inc.. 

Automatic Updates
Holbrook Enterprises, Inc. may periodically check the web for updates. 
No personal information will be transferred. 

LIMITED WARRANTY 
Holbrook Enterprises, Inc. warrants for a period of 30 days from the date of 
original delivery to you that the program will substantially conform to the 
published specifications and to the documentation, provided that it is used 
on the computer hardware and with the operating system for which it was 
designed. Holbrook Enterprises, Inc. warrants the diskette(s) on which the 
program is furnished, to be free from defects in materials and workmanship 
under normal use for a period of ninety (90) days from the date of delivery 
to you as evidenced by a copy of your receipt. This warranty gives you
specific legal rights. You may have other rights that vary from state to state. 
 
DURING THE WARRANTY PERIOD, IF THE SOFTWARE DOES NOT PERFORM AS WARRANTED, 
YOUR EXCLUSIVE REMEDY SHALL BE TO SEND THE SOFTWARE TO HOLBROOK ENTERPRISES, INC. 
WHICH SHALL, AT ITS OPTION, EITHER REFUND TO YOU THE PRICE PAID OR REPAIR OR 
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REPLACE THE SOFTWARE. 
 
To the extent permitted by applicable law, Holbrook Enterprises, Inc. 
disclaims all other warranties, either or implied, including, buy not 
limited to, warranties of merchant ability and fitness for a particular 
purpose. Holbrook Enterprises, Inc. makes no warranty as to title. 
No Holbrook Enterprises, Inc. dealer, distributor, agent, or employee 
is authorized to make any modification or addition to this warranty. 
 
LIMITATION OF LIABILITY 
Because programs are inherently complex and may not be completely free of 
errors, you are advised to validate your work. TO THE EXTENT PERMITTED BY 
APPLICABLE LAW, IN NO EVENT WILL HOLBROOK ENTERPRISES, INC. OR ANY OF ITS 
PRINCIPALS OR AGENTS BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES WHATSOEVER ARISING OUT OF THE USE OF OR INABILITY TO 
USE THE PROGRAM OR OCUMENTATION, even if advised of the possibility of such 
damages. Specifically, Holbrook Enterprises, Inc. is not responsible for any 
costs or damages including, but not limited to, those incurred as a result of 
lost profits or revenue, loss of use of the computer program, loss of data, 
the costs of recovering such programs or data, the cost of any substitute program, 
claims by third parties, or for other similar costs. IN NO CASE WHATSOEVER SHALL 
HOLBROOK ENTERPRISES, INC.'S LIABILITY EXCEED THE PRICE PAID FOR THE LICENSE TO 
USE THE SOFTWARE. 
 
SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY 
FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION OR 
EXCLUSION MAY NOT APPLY TO YOU. 
 
Should you have any questions concerning this Agreement, you may contact 
Holbrook Enterprises, Inc. by writing to: 
Holbrook Enterprises, Inc. 
1112 6th Street South
Nampa, ID 83651
(866) 273-5298 US and Canada
(661) 253-4370 International
You acknowledge that you have read this agreement, understand it and agree to be 
bound by its terms and conditions. You further agree that it is the complete and 
exclusive statement of the agreement between us which supersedes any proposal or 
prior agreement, oral or written, and any other communications between us relating 
to the subject matter of this agreement. 
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1.5 Licensing FAQ

The following are some frequently asked questions about the WireCAD licensing scheme.

Q: Does WireCAD support floating licenses

A: Yes, if you choose to use the function it is built in to both XLT and PRO. You
may disable this feature by selecting the Never expire option on the License
Lease Period dropdown at activation time. Choosing to do so limits that
Authorization Key to that machine only.

Q: How many machines can I install WireCAD on?

A: You may install WireCAD on any number of machines. You will only be able
to launch WireCAD on as many machines as your license count supports. The
default license count is 1. If you wish to purchase additional licenses you may
want to consult with your WireCAD sales professional who will help you
decide the best course of action.

Q: I have a laptop and a desktop WireCAD used to let me install on both. How come I have to choose?

A: You don't. WireCAD will still install on both. It will only run on one at a
time.

Q: What happens if my machine dies?

A: If your machine dies and you are using the floating license scheme, one of
two things will happen:

1. Install WireCAD on the new machine an wait for your lease to expire in
what ever lease expiration period you selected (not optimum, but
serviceable).

2. Call the WireCAD sales team. They can manually expire the lease for you.
You will need your authorization key and company name, as well as the
machine name of the machine that died.

Q: I am not connected to the internet very often, can I still use the floating license scheme?

A: We recommend that you use the floating license scheme only if you are
regularly connected to the web

Q: I am going on-site. How to I ensure that my copy of WireCAD will stay active while I am disconnected from the
web?

A: If you are using the floating license scheme and you know that you will
need to be occasionally connected for a short period of time (one week or
less). Click Project>Settings[Application Settings] set the Release License on
Shutdown to false. This will ensure that only your machine has the license for
up to the lease period. If you are not sure how long you will be gone, follow
this procedure:

1. Click Help>Control Software Activation.

2. Click [De-activate this Copy of WireCAD]. You need to be web connected.
Make sure that the server responds that the license has been successfully
released.

3. Set the License Lease Period dropdown to Never.

4. Click [Register by Web].

WireCAD will not require a web connection to start.

Q: What are the benefits of the Assurance Subscription?

A: A current Assurance subscription gives you the following premium
benefits : 

Free major and minor version upgrades and hotfixes. 
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Priority technical support. 

New samples, tips and how-to topics from time-to-time.

Discounts on training. 

Access to beta products. 

Assurance Price Lock guarantees that your annual Assurance rate will not
increase year-to-year as long as you remain current.

Q: Does the license expire if the Assurance Subscription expires?

A: No. Your licence does not expire even if your Assurance expires. You can
use the products indefinitely even after the Assurance subscription expires.

Q: How long does my Assurance Subscription remain valid?

A:Your subscription duration is for 1 year from date of purchase or renewal.

Q: My Assurance Subscription is about to expire. What should I do?

A:You must renew your subscription to continue to receive the latest versions for free along
with all the other benefits of the subscription. To renew your Assurance, contact sales@wirecad.
com.

Note that you may or may not receive notifications from Holbrook Enterprises, Inc. dba WireCAD about the
pending expiration of your subscription. It is your responsibility to renew your subscription when it is about to
expire. You can renew your subscription as early as you want or opt for a monthly credit card payment. 

Q: When can I renew my subscription? 

A:You must renew your subscription before the expiration of your current subscription You
can renew your subscription anytime before your current subscription has expired; you will not lose
any days as the new subscription will come into effect on the day your current subscription ends.
In effect, your current subscription will be extended by 1 year. 

If you do not renew your subscription before the expiry of your current
subscription, your subscription is considered as   lapsed and you will not be
eligible for free upgrades and other benefits anymore.

Q: My Assurance subscription has lapsed. How can I get the latest version? 

A:Maintaining your Assurance subscription and renewing your subscription each year to
keep it current is the best and the most cost-effective way to receive all new major and
minor versions as they are released. In case your subscription has lapsed and you want to
upgrade to the latest version you may simply renew your Assurance subscription at the

current rates. 

Q: Do you offer academic discounts? 

A: We do have academic discounts if WireCAD will be used for education/research
purposes. Please contact sales@wirecad.com for more information. 
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2.1 Setting Up Your Global Data

Menu: Several

Default command line shortcut: several

WireCAD maintains a global database with tables representing
Manufacturers, Equipment, Signal Types, Connectors, Etc. 

Getting started with WireCAD entails setting up the global databases to fit
your needs. While the database is populated with data you may find that it
suits your needs to purge the data and start fresh. If this is the case we can
provide empty databases. At the very least you will want to set up the Signal
Types grid with your defaults. 

Next you will customize the Equipment Library with the products and IO that
you use. In order to do this, you may either download existing products from
the WireCAD Community Server or enter your own .

Applies To:
All product levels
Related Settings:
None

Manufacturers - The topmost table in the heirarchy
Equipment - The Equipment description

Inputs - inputs of a device
Outputs - outputs of a device

Signal Types - signal types and a bunch of defaults.
Connectors - connector types.
Pinouts - pin out definitions (data).
Color Codes - color code lookup. Used by Cable Types.
Cable Types - cable type information.

Cable Cores - cores or conductor data for a cable type.

24
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Accessing the Global Data

The Project Explorer

The Project Explorer allows
access to the global data
grids.

You can also access these
grids from the Database
menu.

Database>Equipment
Library

Opens the Equipment Library where you will do most of your work.

2.2 Equipment Library

Menu: Database>Equipment Library

Menu: Advanced Tools>Equipment Library

Default command line shortcut: LE

The WireCAD Equipment Library is where you will spend a fair amount of
time as you get define equipment that you will use in your designs. This is
also where we come to create CAD blocks in our drawings. There are many
settings here that let you customize appearance. This chapter is the basics.

Applies To:
All product levels
Related Settings:
None

Equipment Library
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Find Tab

Find equipment
definitions in
the global
database or the
Community
Server.

Preview the
block before 
adding  to
drawing.

Detail Tab

Edit details.
Associate with
external files.

25
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IO Tab

Add , edit,
select IO to
display in
created block.

Display
Preferences

Controls the
appearance of
the created
block.

2.2.1 Creating a New Equipment Definition

Menu: Database>Equipment Library[Add Equipment to Library]

Default command line shortcut: le
Create a new equipment definition from which to create functional blocks,
rack panels, etc.

Applies To:
All product levels
Related Settings:
None

25
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How To: Add Equipment to
the Library

1.Click Database>Equipment
Library

2.Click [Add Equipment to
Library]

3.Select or add a manufacturer.
4.Enter model/pn/name, description,

etc
5.Click [Next >]
6.This page is optional, but we

recommend filling in the Front
Panel File field

7.Click [Next >] to add the new
definition

1.Select the newly added device
from the list. If not found click 
[Find All]

2.Add the IO by selecting the IO tab
3.Click [Add Ports]
4.Enter a port name, connector,

signal type
5.Select Inputs, Outputs table or

Both
6.Click [OK] or [Apply] (if you

want to leave the form open).

2.2.2 Adding Equipment to Drawings

Menu: Database>Equipment Library [Add to Drawing]

Default command line shortcut: le
Create a new equipment block from the library and add it to the current
drawing.

Applies To:
All product levels
Related Settings:
None
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How To: Add Equipment to
Drawings

Find the select the equipment definition
from the Equipment Library.

Select the IO you want to display in the
drawing

Select the Display mode

Select the Display Preferences.
Everything is parametric. There are
settings for Body Width, Pin Spacing,
Color, etc.

If the Auto Preview function is not set,
you may wish to click the Refresh button
(either above the preview window or on
the IO tab).

 or 
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Click [Add to Drawing] (requires an
active drawing).

Place the newly created block in the
drawing.

2.3 Creating a New Project

Menu: Project>New Project

Default command line shortcut: np

Create a new WireCAD Project structure. This involves folder structures on

your operating system as well as databases and support files. 

Applies To:
All product levels
Related Settings:
None

WireCAD v7 can create projects with a number of different database formats. You may choose to create a new
project using file based databases for their zero admin capabilities, or SQL Server for an enterprise installation. 

How To: Create a New Project

1.Click Project>New Project
2.Click [Next >]
3.Select the type of database you wish to use
4.Click [Next >]
5.Enter project info
6.Click [Next >]
7.Enter host info (SQL Server only)
8.Click [Next >] to finish
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2.4 Creating a New Drawing

Menu: File>New Drawing, Project Explorer\Current Project\New
Drawing

Default command line shortcut: nd

Create a new drawing based on a drawing template, with or without model
space boundaries.

Applies To:
All product levels
Related Settings:
None
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How To: Create a new drawing using the
wizard

1.Click File>New Drawing
2.Select a template drawing from which to start
3.Click [Next >]
4.Select boundary settings
5.Click [Next >] to finish

Template drawings are drawings that have been saved in
the template drawings folder and already have entities
such as page borders, layouts and viewports added to
them.

Create Model Space Boundaries. The Model

Space Boundaries function takes two arguments, the

 Model Space Text Height and the desired

Printed Output Text Height. Using these two

variables in conjunction with the size of the
Viewports in each Layout to create  boundary
rectangles in the Model space. Each boundary is
accompanied by a text description that describes the
Viewport and  to which the boundary applies as well

as the text heights and scale factor.

 

Note: You can add Model Space Boundaries

later using the Format>Boundaries function

The final step is to name the drawing. 

2.5 Drawing Cables

WireCAD provides a series of tools to draw cables. The only rule that this version of WireCAD imposes is that you
must draw from one WireCAD device to another. You cannot draw a cable representing a spare that connects to
nothing.

WireCAD provides a cable auto-routing tool that automatically routes the cable around other devices and, if
selected, avoids other cables. The auto-router will always find a path for the cable, even if it means that the cable
is drawn through another device or must overlay another cable. If you do not like the way a cable is routed, you
have two choices; first: manually drawing the cable by selecting Manual Draw, second: select the cable and grab a
grip on the cable and move it around.

If you manually draw cables or otherwise put them where you want them and them move
a device, the auto-router will be invoked and re-route all your changes.
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Topics

WireCAD Cable Terminology
Draw Cables Toolbar
One-to-One Cable
Aux Text
Manual Draw Cables
Cable Router X Offset
Cable Router Y Offset
Default Pointer
One-to-Many Cable
Many-to-One Cable
Many-to-Many Cable
Terminal as Source
Terminal as Destination

WireCAD Cable Terminology
Devices have inputs and outputs, Cables have sources and destinations.
For purposes of this manual we will refer to Jacks, Junction Boxes, Router Crosspoints, Bulkhead connectors, and

On-Sheet/Off-Sheet Pointers collectively as Ter mi nal s:

 

Draw Cables Control Descriptions

Item Description

Draw Cable Toolbar
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One-to-One Cable
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Cable Text Height The Cable# text entity height in DU.
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Replace Cable

with Pointers

checkbox

Automatically draw Pointers instead of cables.

 

Manual Draw

checkbox
Draw every point in the cable.

Avoid Other

Cables checkbox
Allows cables to overlay each other. True =
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False =

Aux Text Enable Enable the placement of Aux Text.

Aux Text Height The height in DU of the Aux Text.

Location The position of the Aux Text relative to the cable polyline. 

Over - positioned over the cable polyline.

Under - positioned under the cable polyline.

Bubble - Not yet supported.
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Variable You may choose to populate the Aux Text with the following variables:

CircuitNumber - The Circuit Number as entered in the Cable Edit Dialog.
IPAddreess - Not yet implemented.
Length - The Length field as entered in the Cable Edit Dialog.
User1 - The User1 as entered in the Cable Edit Dialog.
User2 - The User2 as entered in the Cable Edit Dialog.
User3 - The User3 as entered in the Cable Edit Dialog.
User4 - The User4 as entered in the Cable Edit Dialog.

Format {0} represents the data from the selected variable.
Example: the incoming data from the selected variable is 300 and you want to format it
to represent meters to the reader. Your format field would be {0}m. The output would be
formatted as 300m.

X Offset Horizontal auto-router offset. When drawing cables, WireCAD uses an auto-routine
algorithm. The X Offset determines how far away horizontally from other equipment and
cables a new cable will rout.
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Y Offset Vertical auto-router offset. When drawing cables, WireCAD uses an auto-routine
algorithm. The Y Offset determines how far away Vertically from other equipment and
cables a new cable will rout.

Default Pointer Select the pointer to use when replacing cable with pointers

One-to-Many Cable

Explanation Used to indicate one output to many inputs
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Feeder selection

Count Destination count

Count=3

Y offset, Y
Spacing, Hor
Extension
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Feeder distances

One Cable
Database Entry

Adds a single entry in the cables database and one Cable# text entity at the Y point.

Many Cable
Database Entries

Adds a many entries in the cables database and many Cable# text entity at the
connection points. 

Note: One-to-Many and Many-to-One cables set to Many Cable Database Entries will
assign the connection point closest to the cursor when the cable is double-clicked. The
first assignment on the cable will enter the database as expected, subsequent
assignments will display the Existing Ports dialog prompting you to decide how to number
the cables.

Many-to-One Cable

Explanation Multiple outputs to one input
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Count Source count

count=3

More information See above for a description of other settings

Many-to-Many Cable

Explanation Many-to-Many cables behave like a buss. They are a collection of one-to-one cable
drawn as a single polyline. When assigning cable numbers the connection point closest to
the cursor is used.

 See the above descriptions for more information about settings.

Count Source and destination count

Count = 2
Y feeder

Terminal as Source Window
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Displays the
available Terminals
sorted by Terminal
style (Jack,Terminal,
Pointer).

 
Note: Terminal file
suffixes determine
whether the file
will be displayed in
this window. Files
having a _SD.
DWG, or _S.DWG
suffix will appear
in this view.
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Terminal Offset Sets the distance between the connection point and the terminal basepoint

Terminal as Destination Window

Displays the
available Terminals
sorted by Terminal
style (Jack,Terminal,
Pointer).
 

Note: Terminal file
suffixes determine
whether the file
will be displayed in
this window. Files
having a _SD.
DWG, or _D.
DWG suffix will
appear in this
view.
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Terminal Offset see above

 

 

 

2.6 Assigning Unique IDs (SysNames)

Menu: Advanced Tools>Equipment Functions>Assign SysName

Default command line shortcut: as

Alternately: double-click the equipment block in the drawing.
Assign a unique ID to blocks in a drawing. 

Applies To:
All Product Levels
Related Settings:
SysName Format

This function performs the following steps:
1.Gets the next number in the sequence (based on the SysName Format ).
2.Prompts the user for input.
3.Updates the drawing
4.Updates the project systems database.

Note: if the project contains related projects, you will be notified of duplicate SysNames in related projects

Edit SysNames Dialog

SysName

If you manually enter
a SysName it must
follow the format
defined in the
SysName Format tool.
The SysName textbox
will be masked to help
you follow the format

87
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Fill Gaps ...
Gaps in sequences
can be filled
automatically and
then selected from
the SysName
dropdown

Alias

Alias is functional
name for the device.
Think of it like the
friendly name. The
SysName is the unique
ID the Alias can be
duplicated if desired.

Example: If the device is a distribution amp and its SysName is DA-120 and it is fed by
SVR-01, you may choose to alias it as its source SVR-01.

We recommend that you enter a Location and Elevation. Take your best guess. The
Rack Builder tool will use your guesses to create a preliminary rack layout that can
easily be modified to suit your final design
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Flags Various flags to help you sort the equipment in your Systems table.
IsSequencial Not Yet Implemented
Engineering Data
tab

Various fields to track, IP address, Power Consumption, etc

User Data tab User fields

2.7 Assigning Cable Numbers

Menu: Advanced Tools>Cable Functions>Assign Cable Number

Default command line shortcut: ac

Alternately: Double-click the cable in the drawing
Assumes that the devices on both sides of the cable have first been assigned
SysNames.
To assign multiple cables at once, create a selection of cables. The order the
cables are added to the select set is the order that they will be assigned
numbers. Once you have created a selection of cables, click: Advanced
Tools>Cable Functions>Assign Cable Number, or type ac into the
command line followed by the [Enter] key.

Applies To:
All product levels
Related Settings:
Cable Number Format
Project Settings

This function performs the following steps:
1.Gets the next number in the sequence (based on the Cable Number Format )
2.Prompts the user for input
3.Updates the drawing
4.Updates the project systems database

Note: if the project contains related projects, you will be notified of duplicate Cable numbers in related projects

Edit Cable Numbers Dialog

CableNo

If you manually enter
a Cable Number it
must follow the format
defined in the Cable
Number Format tool.
The CableNo textbox
will be masked to help
you follow the format

CableNo, New +,
Unlock

CableNo is a direct entry field as well as a dropdown that displays all available,
available cables within the      current sequence, filling gaps if so desired.
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When double-clicking an assigned cable, the form will be shown in edit mode. The
[Unlock] button will allow the cable number to be fully edited. This requires some
caution. Be sure to check the database to be sure that the edits and deletions have
been committed.

CableTypeManu,
CableType

Select the Cable Type Manufacturer and Cable Type. 

SignalType,
Multicore Data, Add
All Cores

Select the signal type. 
If you have selected a multicore cable from the CableType dropdown, the core data will
be shown. If you are assigning a single core in the core structure, select that core. If
you wish to assign all cores and have selected enough cables to apply all core number
to, select the Add All Cores checkbox.

Source and
Destination info

CktNo

Circuit Number

2.8 Assigning Terminals

Menu: Advanced Tools>Equipment Functions>Assign Terminals

Default command line shortcut: ats

Alternately: Double-click the terminal in the drawing
Assumes that at least one SysName  has been assigned.

To assign multiple terminals at once, create a selection of like terminals. The
order the terminals are added to the selection set is the order that they will
be assigned numbers. Once you have created a selection of terminals, click: 
Advanced Tools>Equipment Functions>Assign Terminal(s), or type
ats into the command line followed by the [Enter] key.

Applies To:
All product levels
Related Settings:
None

This function performs the following steps:
1.Opens a port selection dialog based on SysName.
2.Prompts the user to select the SysName and the port or ports to display(or range of ports of multiple terminals

are selected).
3.Updates the terminal(s) in the drawing.

Assign Terminal(s) Dialog
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SysName
Select the SysName or press
the [+] button to add a new
SysName

I am Just Changing a
SysName

Leaves all port data as currently displayed on a terminal, just changes the SysName.
This is useful for modifying existing terminal assignments.

Persist this equipment Remembers the selected SysName and returns to it on the next terminal assignment

Outputs track inputs When you select an input that has a corresponding output of the exact same name, that
output will also be selected.

Inputs grid Active only if the selected terminal(s) have input connection points

Outputs grid Active only if the selected terminal(s) have output connection points
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2.9 Rack Builder Tool

Menu: Advanced Tools>Rack Functions>Rack Builder

Default command line shortcut: rb

   The Rack Builder tool is not available in XL Free mode

The Rack Builder tool utilizes information in the Project Systems table and
the global equipment library to place and populate rack elevation views. This
process may be run repeatedly as the project progresses.

Applies To:
XLT PRO
Related Settings:
Default Rack Height
Top Down Racks

Topics
How it Works
Controls

How it Works

The Rack Builder tool relies on three
key pieces of information. First we
need the SysName of the device to
add to the rack. From the SysName
we retrieve the equipment
manufacturer and model. Second,
using the equipment manufacturer
and model, we get the global
equipment definition from the global
equipment database. If the global
equipment definition is complete it will
contain either a reference to a front
panel dwg file (BlockRef) or
dimensional data. If either of these
are missing the Rack Builder tool will
flag that equipment definition as
requiring more information. The Rack
Builder tool will perform a preflight
check of all data and let you know
what you are missing.

Assuming all of the data fiddly-bits
are in the right place, the Rack
Builder tool will populate the drawing
with one locator grid per location
selected. A locator grid is an array of
point entities that are spaced
horizontally and vertically based upon
your selection in the preferences.
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Next the Rack Builder tool, based on
the Mechanical View Rule, will place
either the front panel file or a block
created from the dimensional data at
the location point defined in the
Project System entry.

The locator grids facilitate location
aware movement of the devices
placed on the grid
You may manually place devices
created from the equipment library in 
Front Panel mode on the locator
grids
To move a device within the rack
elevations, select the device, grab it
by its grip and move it to the desired
location. 

Note: It is desirable to turn on End
Point snap and possibly Node Snap
while moving devices

WireCAD will notify you of the
location change and update the
databases immediately to reflect the
change.

 It will not update the remainder of
the drawing set until you click save.
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Once changes are made across the
drawing set you will be notified of the
changed drawings

 

Controls

The [Basic] tab allows
you to select the
locations to include in
the Rack Building
function. Use the > >>
and << selector buttons
to move items from the
left-hand list to the
right-hand list. 

 Include hashes This will normally be checked unless you are rebuilding a drawing that already has the
locator grids.

 Spacing DU Sets the location grid spacing in Drawing Units
Systems Involved list Displays a list of all the systems that will be placed in the created drawing.
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The [Advanced] tab
exposes properties that
control the behavior of
the utility.

 Chassis Width Sets the width of the chassis in DU
 Height in RU Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm)
 Slot Count Sets the number of slots per locator grid. This is used to position items that may not

be located at the insertion point of the rack unit. 
 Slot Delimiter WireCAD searches the Elevation field for numeric values first then for the slot

delimiter if found it parses the the data into two values the elevation and the slot, or
in other words how far up in the rack and how far over.

 Insertion Point Where to start the whole process
 Attribute Height If view rule is not ShowDWGInPath, sets the attribute height of the displayed text.
 View Rule ShowDWGInPath = use the dwg file found in the equipment definition BlockRef.

CreateFromDimensions = use the dimension data from the equipment definition to
create a 3D rack block.
CreateFromDimensionsIfNotFound = Use dimension data if the BlockRef is not
found.

 Place Text If Item   
Cannot Be Created

If the item cannot be created due to lacking data, place a text marker in the drawing
at the location.

2.10 AutoScheme Tools

The AutoScheme tools create functional drawings or parts thereof from the data in the project systems and
cables databases. This is useful to create detail or overall views. 
The AutoScheme tools consist of two utilities. The Auto Block tool automatically places blocks in the drawing on a
grid. The RatsNest tool checks the project cables database against the drawing. If connections defined in the
cables database can be reproduced in the drawing because the SysNames and Ports exist, a cable is placed. 

Auto Block
RatsNest

Auto Blocked
drawing. Blocks have
been created an
placed.
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After running the
RatsNest tool. This
supplies the drawing
with cable data and
provides a positional
reference to help you
decide where to
move block to better
display the drawing.

After running the
Cleanup tool from the
RatsNest utility.

[Auto Block]

2.10.1 Auto Block

Menu: Advanced Tools>AutoScheme Tools>Auto Block

Default command line shortcut: ab

The Auto Block tool automatically places functional blocks in the drawing. This
tool requires that the Project Systems table be populated. 

Applies To:
PRO
Related Settings:
None

Controls
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The [Basic] tab allows you to use the >
>> and << selector buttons to
determine which systems to add to the
drawing.

Location Filter Filters the left-hand list by location

The [Advanced] tab allows you to
refine the behavior of the utility.

Insertion Point The point we start from. 
Horizontal Spacing DU How far apart horizontally. The vertical spacing is defined by the height

of the highest block in the row.
Maximum Column Count How many columns horizontally
Get Port Data From Cables
Database

Select this option to search the cables database for port info instead of
the global equipment database. This will effectively show only those
ports to which we have attached cables.

Display As How to display the blocks
Display Preferences If Functional Block or Concept block is selected then set basic display

parameters. 
Signal Types to Display Filter ports by the selected signal types.

2.10.2 RatsNest

Menu: Advanced Tools>AutoScheme Tools>RatsNest

Default command line shortcut: rn

The RatsNest tool checks the project cables database against the drawing. If
connections defined in the cables database can be reproduced in the drawing
because the SysNames and Ports exist, a cable is placed. 

This tool requires that the Project Cables table be populated. 

Applies To:
PRO
Related Settings:
None
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Controls

This tool has three sections. The
Rats Nest section does the work
of placing the cables in the
drawing as defined in the Cables
database.

[Ratsnest] Run the utility to place the cables.
Show Cable Numbers With or without cable numbers.
[Clear All Cables] Removes ALL cables from the drawing.

[Cleanup] Applies the autorouter to all cables in the drawing.
Avoid Other Cables Autorouter avoids other cables on cleanup.

[Fillet] applies fillets to all cables in the drawing
Distance fillet distance in DU.

2.11 System Snapshot

Menu: Advanced Tools>Equipment Functions>System Snapshot

Default command line shortcut: ss

The System Snapshot tool utilizes information in the Project Systems table
and the Global Equipment Library and the Project Cables database to create
a view of all cables attached to the selected SysName.

These details are useful for error checking and in the field as an installation
aid.

Applies To:
PRO
Related Settings:
None

Controls

The System Snapshot dialog

System The SysName to snapshot
Sort I/O By Last Display
Order

The last display order defined in the equipment library
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Terminal The terminal to display 

Circuit Recursion None = disabled
Get From Circuits Table = Not yet implemented
Guess = search for either a direct string match on the corresponding I/O or a
numeric match of the same signal type.

[Generate] Do It!
[Copy to Clipboard] Copies the snapshot to the clipboard for pasting into another drawing.
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3 Personalizing WireCAD

The Settings Dialog
Setting the Skin
Template Drawings

3.1 The Settings Dialog

Menu: Project>Settings

Default command line shortcut: set

   
The settings dialog hosts panels for several different settings levels:
Applica
tion

Setting occurs once per application install per machine.

User Setting specific to the current user.
Project Setting specific to the current project if any.

Applies To:
All
Related Settings:
None

The following is a listing of the default panels. If your organization is using WireCAD Security your user will require
Administrator privileges in order to edit Application level setting and some Project level settings. The may be a
partial listing depending on the plugins loaded. 

Application Settings Panels

Basic

Check for Updates   Checks for new updates to the application on application startup
Show Application Setup
Wizard

Shows the Application Setup Wizard which walks you through the basics of setting
up the
Application level settings on startup.

Community Library Auto-
Contribute Mode

Your Equipment Library will be automatically contributed to the WireCAD
community unless you opt otherwise.

Release Lease On
Shutdown

If you are floating your license  you will want to set this to true unless you plan
to start WireCAD while you are not web connected.

Default Project Database
Host

Applies only to SQL projects. Presets the New Project Wizard

58
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WireCAD Security

This is typically set via the
Application Setup Wizard.

Use WireCAD Security Enable Security. When enabled the WireCAD security system uses the current
login to determine program access.
If your user is a member of the Administrators group you will be able to control
the access of other users via the Project>Security>Manage Security...
dialog.
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Security Database Type Typically you will only use security in a multiuser environment with a SQL host, but
the capability exists to use file based VistaDB databases.

Support Paths Panel

Support Paths
The support paths allow us to
substitute actual paths for
variables and simply reroute
locations to key files and
folders.  

All Support Paths Can
Reside on Network
Shares and Use UNC
Naming Conventions.

Blocks The path that will replace the %BLOCKS% variable in the equipment library.
Images The path that will replace the %IMAGES% variable in the equipment library.
Documents The path that will replace the %DOCUMENTS% variable in the equipment library.
Icons The path that will replace the %ICONS% variable in the equipment library.
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Template Drawings The path to the Template Drawings folder. This is the folder where Template
Drawings are saved when using the File>Save As Template Drawing function is
used and the folder that the New Drawing Wizard searches to file the Templates
list:

Reports The path to top reports folder. This is a recursive search and will enumerate all
subfolders and files.

Default New Project
Location

Presets the New Project Wizard.
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Organization

Your organization details.
Used by many of the plugins.

User Settings Panels

Basic

Skin Name Change the skin (appearance).
Open New Drawing Upon
Application Startup

Opens a blank new drawing when WireCAD starts.



WireCAD v7 User Manual63

© 2013 Holbrook Enterprises, Inc. dba WireCAD

Use the New Drawing
Wizard

Shows the New Drawing Wizard  when you click File>New. 

Allows the use of template drawings. If set to false, just creates a new drawing
without a template.

Open Last Project When I
Start WireCAD

Behaves like earlier versions of WireCAD that opened the last project automatically
on startup.

Show the WireCAD
Startup Page

The WireCAD Startup Page shows the latest news from the WireCAD ranch.

28
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Warn Me When I
Mismatch a Signal Type

When you finish drawing a cable WireCAD will check the source and destination
port signal types and let you know
if they don't match. You can use the new status panel to know the port type if you
are confused.

When I Double-click a
Many-to-Many Cable
Assign All of Them

Many-to-Many cables  that are set for Multiple Database Entries can either be
assigned all at once by a single 
double-click,or if this setting is turned off a double-click will find the closest port to
the cursor and assign that.

Keep My Equipment
Library Open

This is useful if you are using dual monitors and want to have the Equipment
Library stay open on the other monitor.

When I Link Pointers Go
Back

The default Link Pointer function will leave you on the second sheet. If you set this
to true it will jump you back to 
the first sheet.

Library Multiple Port Add
Leading Zero Count

Presets the Port Adder Dialog

41
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Drawing Settings Panel

Auto Save Duration in
Minutes

Sets the Auto Save Duration. Auto Save saves only drawings that are not currently
involved in a function.

Background Color Sets the background color. 
Grip Color Sets the grip color.
OSnap Color Sets the Object Snap Color.
Grip Size Sets the grip size in pixels.
Pick Size Sets the pick size in pixes. The pick determines the search window when clicking

the cursor.
Cross Hair Size Sets the cross hair size in pixels.
Show Layout Tabs Shows the layout tabs at the bottom of the drawing frame
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Show Paper Space Paper When a layout is selected, show the current page size as returned by the selected
printer as a white "page."

true

false
Show UCS Axis Shows the UCS Axis

Save Drawing After Every
Cable Number
Assignment

Setting this to true is not recommended but will speed the assignment process.
You are responsible then for saving the drawing to ensure drawing/database parity.

Command Line Shortcuts

Execute a command by
typing either Command
Name, Alias, or Shortcut. 



WireCAD v7 User Manual67

© 2013 Holbrook Enterprises, Inc. dba WireCAD

User Settings Panels

Project Settings

Starting cable number This will be the starting number for any new sequence. It is overridden by a range
in the Signal Types global database.

Leading zero count Leading zeros for cable numbers. Affected by the Project Cable Number Format .
Ignore cable# text color True to set the Cable# text entity PenColor = ByLayer.
Location-Elevation
Delimiter

By default this is a "." When the Location and Elevation fields are combined in the
drawing this will be the delimiter. Example: Location: Rack-10 Elevation 10 would
be concatenated with the Location-Elevation Delimiter as follows: Rack-10.10

Elevation-Slot Delimiter By default this is a "-" When parsing the elevation field this variable is used to
identify a slot. Example: Elevation 10 slot 4 would be 10-4.

I Build My Racks From the
Top Down

Numbers from top down. The default is bottom up.

Default Rack Height Default Rack Height in Rack Units. Presets the Rack Builder  dialog.

Default Cable Manu and
Type

If the Signal Type in the global database does not define a default Cable Type and
Manufacturer then this is used as a default. 

User Can Modify These
Settings

Only effective under WireCAD Security
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Add Pinout Data to Each
Cable

Set to true to allow attachment of pinout data to each cable. You must display the
Edit Cable Data dialog in order to pick the pinout. Pinouts are set using the Pinouts
plugin . Once defined, during a cable number assignment you can pick from
pinouts that have the proper connectors defined. If the proper connectors, both src
and dst, do not exist in the pinout it will not be available for choice.

3.2 Setting the Skin

Menu: View>Skin or Project>Settings[User Basic] Skin

Default command line shortcut: set

Applies To:
All
Related Settings:
None
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WireCAD ships with a number of custom skins. Play with them until you find
one that suits you. Some of them are very functional while others are quite
whimsical.
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Caramel

sharp plus

Xmas

3.3 Template Drawings

Menu: File>Save As Template Drawing

Menu: File>Open Drawing

Default command line shortcut: fo (File Open)

Applies To:
All
Related Settings:
Show New Drawing Wizard
Template Drawings Support Path

63

60



WireCAD v7 User Manual71

© 2013 Holbrook Enterprises, Inc. dba WireCAD

  

Template drawings are drawings that are preset with items that you don't
want to add every time, such as page borders (titleblocks) and viewports .
It is not uncommon to create a template for each project by starting with an
existing drawing and adding your titleblock data etc. Some WireCAD users
go so far as to create templates for their frequently used designs. 

Template drawings are saved in the Template Drawings Support Path . You
can pick template drawings from the New Drawing Wizard.
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4 Reporting

Contents

Printing Reports
Filtering Reports
Creating Reports

4.1 Printing Reports

Menu: Reports>Report, Alternately: double-click the report in the Project

Explorer
  Default command line shortcut: 

Opens a report for preview, printing or export

Applies To:
XLT PRO
Related Settings:
None

Reports display in design
view by default (XL
mode excepted). 

Clicking the [Preview]
button renders the
report unless the report
defines parameters that
the user must enter
followed by the 
[Submit] button on the
parameter pane.
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4.2 Filtering Reports

Menu: Reports>Report, Alternately: double-click the report in the Project

Explorer

Default command line shortcut: 
Report filtering is not available in XL free mode.

Applies To:
XLT PRO
Related Settings:
None

In order to filter a report the report
must be in design mode

Make sure that the Property window
is displayed. If not click:
View>Windows>Property Grid
From the Property grid object
selector, select XRReport1
From the Property grid select the
Filter String ... ellipsis button
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This opens the filter dialog from which
you may select a number of different
filters

Filters may also contain parameters
that the user must enter before the
report is generated. In order to make
use of this function you must follow
these steps:
1.Add a parameter to the report while

in Design view. Click the 
Parameters (...) ellipsis button to
view the Parameters collection.

2.Click the [Add] button to add a
parameter to the collection.

3.Enter description and default value
information.

4.Open the filter editor (see above)
5.Add a condition and edit the

comparison, then click on the icon
to the right of the field to select
parameters.

6.Click [Preview] to preview the
report. You will see a Parameters
pane on the left hand side with a
submit button.

7.Enter a value and click [Submit].
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Step 5.

4.3 Creating Reports

Contents

Standard
Labels
Report Design Basics

4.3.1 Standard

Menu: Report>New Report with Wizard

Default command line shortcut: rw 

Applies To:
XLT PRO
Related Settings:
None

76

80

84



WireCAD v7 User Manual77

© 2013 Holbrook Enterprises, Inc. dba WireCAD

Create a new report

How To: Create a New Report

Click Reports>New
Report with Wizard. 
Alternately: from the
Project Explorer - click
New Report with
Wizard

Select the Standard
Report option. Click
[Next >]
Select a data collection.
Data collections access
both the global and
project databases. For
example: say you
wanted to show a list of
all manufacturers. You
would select the 
GlobalManufacturersC
ollection. 

Note: collections are
hierarchical to aid in the
creation of subreports. All
collections are populated with
data when the report is
previewed.
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Select the fields
(columns) you wish to
display in the report.

Note: use the > >> < <<
buttons in the center of the
two lists to move items
between the lists

Apply any grouping
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Select a Layout and
Orientation for your
report.

Note: the Adjust field
width to fit function will
force all selected fields on
to a single page possibly
rendering some of the data
unreadable. If you have
lots of fields to display,
consider using a Justified
report

Select a Report Style
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Title your report

Click [Finish] to create
your shiny new report.

Click File>Save and
save your work to your
reports support path

4.3.2 Labels

Menu: Report>New Report with Wizard

Default command line shortcut: rw 
Create a new label report

Applies To:
XLT PRO
Related Settings:
None

How To: Create a New Label Report
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Click Reports>New
Report with Wizard. 
Alternately: from the
Project Explorer - click
New Report with
Wizard

Select the Label Report
option. Click [Next >]
Select a data collection.
Data collections access
both the global and
project databases. 

Note: In the case of labels
we probably want to use the 
CablesCollection
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Select a label format.
WireCAD comes stock
with over 1000 label
formats from 15
manufacturers including
Panduit, Hellerman Tyton
and Brady.

Modify and of the nudge
factors and select the
sheet size

Click [Finish] to create
your shiny new report.
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Select the Field List and
drag any fields that you
wish to display on to the
report design surface.

Note: avoid placing field on
the light and dark grey
areas. The light grey area
will not print and the dark
grey is indicative of the clear
laminating portion of a cable
label.

Here we have three
fields that we have
dragged and positioned
on the design surface.
We then edited the Src
and Dest fields to
concatenate the Pin data
as well. Then we edited
the font property of the 
CableNo entity to bold
it.

Final output looks like
this

Click File>Save and
save your work to your
reports support path
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4.3.3 Report Design Basics

The following topic assumes that you have either opened a new blank report or that you have run the New Report
Wizard.

Navigating the Designer

If you open a new report without running the wizard you will need to set the report Data Member variable. 
Click in the dark grey area to load the general properties. Select the Data Member from the drop down.



WireCAD v7 User Manual85

© 2013 Holbrook Enterprises, Inc. dba WireCAD

You can drag fields from the Field List directly to the report designer.

If you want to concatenate multiple fields in a single label you can drag multiple fields onto the same label or edit it
directly. 
To edit a label double-click it to enter edit mode.

Type directly into the label. Field names must be enclosed in [] brackets.
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5 Advanced Topics

Contents

SysName Formatting
Cable Number Formatting

5.1 SysName Formatting

Menu: Project Explorer>Project Databases>Project SysName Format

Default command line shortcut: fsys

XL FREE does not support changing the format
Allows control of the SysName numbering scheme. Using the SysName
Format dialog you can select any field that is associated with the SysName
and concatenate it into your own numbering scheme. Each of the fields
selected can be formatted and the numbers can be set to sequence off of
another field.

Applies To:
XLT PRO
Related Settings:
None

Topics

How it Works
Controls Explanation
Available Variables
More About Regex

How it Works

The SysName format tool is used to generate regular expressions that are then used to parse SysName info as
well as provide formatting information to masked text boxes. 

A note on regular expressions: WireCAD v7 makes extensive use of regular expressions (Regex). Regular
expressions are a well documented string parsing tool. Much has been written on them. It is not within the scope of
this quick start guide to fully explain regular expressions; however, a google search will tell you more than you
ever wanted to know. 

Two forms of regular expression are generated: a simplified form that is used as a mask in both the Systems
database and in textboxes, and a complex form that aids in the generation of queries to determine the next
number in a sequence. The following are both the simplified and complex regex for the default format:

\w{1,6}-\d{1,5}

(?<EQUIPMENTTYPE>\w{1,6})-(?<NUMERICSEQUENCE>\d{1,5})

NOTE: WireCAD supports multiple formats in the same database. In order to
accomplish this we use the simplified Regex as a mask. If you have any data in the
Project Systems table and you change ANYTHING in ANY Format field you will change
the mask and therefore the sequence. You must decide if the change is such that it
warrants copying the new simplified Regex to all records in the Project Systems table in
order to keep your sequence.
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Controls
Explanation

Selected Format
Selected the current
SysName format. 
Allows addition and
deletion of formats as
well.

Variable List
Displays the sequence
of variables in grid view
that will be
concatenated into the
final SysName. 

Available Variables

Variable Description Sequencable Default Format (regex)

MANUFACTURER Manufacturer Name X \w{1,6}
EQUIPMENTNAME Equipment Name/PN/

Model Number
X \w{1,6}

DESCRIPTION The device description as
contained in the global
equipment library

X \w{1,6}

EQUIPMENTTYPE The Equipment Type as
contained in the global
equipment library

X \w{1,6}

LOCATION The location typed in the
SysName edit dialog

X \w{1,6}

ELEVATION The location typed in the
SysName edit dialog

X \w{1,6}
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STRING any string (usually used
for delimiters like dashes
(-))

-

NUMERICSEQUENCE a numeric sequence that
starts with the project
starting number

\d{1,5}

ALPHASEQUENCE an alpha sequence that
starts at the letter 'a'

\w{4}

USER1 the global equipment
library device definition
user1 field

\w{1,6}

USER2 " \w{1,6}
USER3 " \w{1,6}
USER4 " \w{1,6}
SeqOn

This variable should
sequence on another
variable's value. 

Order
The order in the list of
the variable

More About Regex

The Format field uses regular expressions. The following are some simple examples:
\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters
\d{1,5} Digits 1 to 5 digits in length
\d* Digits any length
\\ a slash "\". The \ is the escape character so you need two
- a dash except when in [] or {} then a range.
[a-zA-Z0-9_\-\,]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.

5.2 Cable Number Formatting

Menu: Project Explorer>Project Databases>Project Cable Number

Format

Default command line shortcut: fcab

XL FREE does not support changing the format
Allows control of the Cable numbering scheme. Using the Cable Number
Format dialog you can select any field that is associated with the Cable
Number and concatenate it into your own numbering scheme. Each of the
fields selected can be formatted and the numbers can be set to sequence off
of another field.

Applies To:
XLT PRO
Related Settings:
None

Topics

How it Works
Controls Explanation
Available Variables
More About Regex
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How it Works

The Cable Number format tool is used to generate regular expressions that are then used to parse Cable
Number info as well as provide formatting information to masked text boxes. 

A note on regular expressions: WireCAD v7 makes extensive use of regular expressions (Regex). Regular
expressions are a well documented string parsing tool. Much has been written on them. It is not within the scope of
this quick start guide to fully explain regular expressions; however, a google search will tell you more than you
ever wanted to know. 

Two forms of regular expression are generated: a simplified form that is used as a mask in both the Cables
database and in textboxes, and a complex form that aids in the generation of queries to determine the next
number in a sequence. The following are both the simplified and complex regex for the default cable number
format:

\w{1,6}-\d{1,5}-\w*

(?<SIGNALTYPEPREFIX>\w{1,6})-(?<NUMERICSEQUENCE>\d{1,5})-(?<MULTICOREDATA>\w*)

NOTE: WireCAD supports multiple formats in the same database. In order to
accomplish this we use the simplified Regex as a mask. If you have any data in the
Project Cables table and you change ANYTHING in ANY Format field you will change the
mask and therefore the sequence. You must decide if the change is such that it warrants
copying the new simplified Regex to all records in the Project Cables table in order to
keep your sequence.

Controls
Explanation

Selected Format
Selected the current Cable
Number format. 
Allows addition and deletion of
formats as well.
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Variable List
Displays the sequence of
variables in grid view that will
be concatenated into the final
Cable Number. 

Available Variables

Variable Description Sequencable Default Format (regex)

SIGNALTYPE The signal type associated
with the cable

X \w{1,4}

SIGNALTYPEPREFIX the signal type prefix
associated with the signal
type of the cable

X \w{1,4}

SOURCESYSTEM The source SysName X \w{1,6}
SOURCEPIN The source port or pin

name
X \w{1,6}

SOURCEALIAS The source Alias X \w{1,6}
SOURCELOCATION The source location X \w{1,6}
DESTSYSTEM The destination SysName \w{1,6}
DESTPIN The destination port or pin

name
\w{1,6}

DESTALIAS The destination alias \w{1,6}
DESTLOCATION The destination alias \w{1,6}
SOURCE_OR_DEST_PIN_I
F_JACKFIELD

Not Yet Implemented \w{1,6}

MULTICOREDATA Core data as defined in
the associated cable type
if any

\w*

STRING any string (usually used
for delimiters like dashes
(-))

-

NUMERICSEQUENCE a numeric sequence that
starts with the project
starting number

\d{1,5}

ALPHASEQUENCE an alpha sequence that
starts at the letter 'a'

\w{4}

USER1 the global equipment
library device definition
user1 field

\w{1,6}

USER2 " \w{1,6}
USER3 " \w{1,6}
USER4 " \w{1,6}
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SeqOn
This variable should sequence
on another variable's value. 

Order
The order in the list of the
variable

Test Sequence
   Performs a basic syntax test on
the  regular expressions

More About Regex

The Format field uses regular expressions. The following are some simple examples:
\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters
\d{1,5} Digits 1 to 5 digits in length
\d* Digits any length
\\ a slash "\". The \ is the escape character so you need two
- a dash except when in [] or {} then a range.
[a-zA-Z0-9_\-\,]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.
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6 Frequently Asked Questions

Contents

Placing Custom Titleblocks (Page Borders)
Creating Custom Titleblocks
Moving Projects
Synchronizing with Another Equipment Library
Setting Up on a Network

6.1 Placing Custom Titleblocks (Page Borders)

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing

Default command line shortcut: 

Applies To:
All Product Levels
Related Settings:
None

How to Place Custom Titleblocks into Your Drawing

Switch to the Layout in which
you intend to place your
custom page border
Open the Insert block into
Drawing dialog.
  Basic CAD
Tools>Blocks>Insert 
Block into Drawing

Select [From File]
Browse to the dwg that
contains your custom title
block in the Model Space 
Click [OK] to place the
insert into the drawing.

Now you will need to place a Viewport to the model space
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Click View>New Viewport
and select the logical
boundaries of the viewport
within the titleblock you
placed earlier.

Now double-click the viewport to activate it for zooming and panning and use the mouse wheel or zoom
commands to position the viewport over the model space.

6.2 Creating Custom Titleblocks

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing

Default command line shortcut: 

Applies To:
All Product Levels
Related Settings:
None

How To: Create Your Own Custom Titleblocks

1.Create a new drawing with no template.
2.Draw your titleblock in Model space scaling it 1:1 with your printed page size, ie an 11x17 page border would

be 11x17 minus your margins.
3.Place any images and attribute definitions.
4.Save the drawing.
5.Follow the steps here  for placing your title block drawing in any other drawing.94
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6.3 Moving Projects (Pack Up/Check-Out)

Menu: Project>Project Utilities>Packup / Check-out

Menu: Project>Project Utilities>Unpack

Menu: Project>Project Utilities>Check In

Default command line shortcut: 

XL FREE does not support this function

Applies To:
XLT PRO
Related Settings:
None
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The Basics

When moving projects from machine to machine there are external items upon
which the project depends. These are referred to as project and drawing
dependencies. The main project dependency is the global equipment database.
Drawings may have image, XRef, and font dependencies. When we Pack Up a
project we are grabbing all of those dependencies (fonts are and exception and
are not included) and placing them in the Project folder. We may choose to
Check Out the project at the same time (PRO only). This flags the project
rendering read only until such time as the project is checked back in.
Once packed up and/or zipped up you are ready to move the project to
another machine. Simply copy the Project folder or the zipped file and move it
to the new machine. 

Please note that it is beyond the scope of this manual to tell you how to copy
and move files in your operating system.
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To Unpack or Check In - That is the Question

The two functions are practically identical with the exception that the Check In
function won't launch without an active project and once unpacked will mark
the active project as Checked In.
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Whether you Unpack or Check In a project depends on whether you are
moving a project to a machine on which that project already resides and
whether you have Checked Out the Project.

If you have not Checked Out the project then there is no need to Check In the
project.
If you are moving a project to another machine, use the Unpack function.

6.4 Synchronizing with Another Equipment Database

Menu: Database>Sync Equipment Libraries...

Default command line shortcut: 

XL FREE does not support synchronizing another Equipment
Database.

Applies To:
XLT PRO
Related Settings:
Syncs the incoming global
equipment database to the
connected Global Equipment
Database
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Occasionally you may experience the need to sync with another user's global
database. This will copy all of their equipment to your global Equipment
Database. The sync includes manufacturers, equipment, inputs, outputs, signal
types, connectors, cable types, cable core data, relational tables, etc. 

You may choose within the tool to perform an import, export or

bidirectional sync.

Demystifying Synchronization

Synchronizing data in two tables of the same structure is really very simple. In
its most basic form, records that do not exist in one table are added. Records
that exist in both tables receive the most current data based on a timestamp.
In order that records deleted from one table do not get added back in, a
special table is employed to track deleted keys. If the delete is the most
current action then the record will likewise be deleted from the other table. In
the unlikely event that the records have the exact same timestamp, yet the
data is different, those records are flagged as conflict records from which you
must pick the most correct. 

Controls

Database Location
Select either a
VistaDB file based
database or a SQL
Server host. If server
based you will need
to provide host and
credentials. If you do
not know them
contact your SQL
Server database
administrator.

Import, Export,
Bidirectional

Self explanatory

Remember Settings Remember database location information
Sync Initiates the synchronization with the top progress bar showing the overall progress

and the bottom showing detail progress. 
Status Bar Displays status of the sync.
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At the conclusion of
the sync you will be
presented with a
report that details the
records updated here
and there.

6.5 Setting Up On a Network

What follows is a discussion of several different network topologies and work flows that WireCAD can employ.
Regardless of topology or work flow the following steps should be taken for each WireCAD machine. For purposes
of this discussion we will distinguish between and Windows user operating under group policy and  WireCAD user.
The Windows user will be referred to as a OS user. WireCAD users will be referred to as WC users.
1. Install WireCAD
2. Create a network share that is visible to all WireCAD users. Group policy for the OS user of WireCAD should

allow the user to read and write the registry (restriction of the registry editor is acceptable), as well as, read
and write files on the selected shares, the WireCAD6 folder on the client machine, the OS user's temp
directory, the OS user's All Users documents and settings folder trees.

3. Pick one WireCAD client machine from which to copy the global databases and copy from ...\WireCAD7
\WireCADGlobalEquipment.vdb3 to \
\YourNetworkShare\FolderForWireCADGlobalDatabases\WireCADGlobalEquipment.vdb3

4. Launch WireCAD on the client machine.
5. Click Project>Settings{Support Paths}
6. Modify the support paths for both the Global Equipment database, any blocks or reports that you wish to share

among all users.
7. Click <Done> and relaunch WireCAD.

Note: The use of mapped network drives is not recommended. Rather use UNC (\
\ShareName\Path\) drive paths to specify network shares. This will avoid problems with the same
share mapped to different drives.

8. Click Project>Security>View Permissions. If you are an administrator or rather if your WireCAD identity is
that of Administrator, you will have edit ability on this grid.
9. WireCAD v6 uses your Windows groups. You assign permissions to the group. The current user Identity is set to
the group thus determining their access level.
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7 Choosing a Database Format

Menu: None

Default command line shortcut: none

Applies To:
PRO
Related Settings:
None

WireCAD v6 PRO allows the use of both file based and server based databases for the project and global
databases. The choice of which to use requires some forethought. Listed here are some basic considerations:

SQL Server VistaDB (File Based)

Zero Administration X

Portable X

ACID Compliant (atomicity,
consistency, isolation, durability)

X X

Database Size Theoretically unlimited Theoretical limit is 16 Exabytes
(uint64).  Practical limit is based

upon machine resources.  Files are
not limited by the database engine,

but loading very large databases will
require large system resources. 

In Process Processing X

At first glance that the table above it would seem that the proper choice would be the file based solution.
However, take note of the last item - In Process Processing means that the WireCAD processes must read and
write all data to and from the file based database. Using SQL Server allows us to hand those processes off to the
database server creating, in many instances, a significant (read 10X) increase in speed.

Before selecting a database format consider the following questions:
Will I be moving the project from machine to machine? If yes, consider staying file based on the project.
Do I have the chops to manage a SQL Server? If no, stay file based. SQL Server requires care and feeding.
Am I away from my network when I work on WireCAD projects? If you lose connection, WireCAD will become
hampered.
Do I really need the speed enhancements? If you are working on projects with hundreds of thousands of
cables, SQL Server is a must.

When you move a project using the Project>Utilities>Pack Up/Check Out function and you are using SQL
Server databases the database in converted to a file based version and will remain file based from that point
forward.

To set up SQL Server see here 104
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7.1 SQL Server Setup

It is not within the scope of this manual to provide an in depth discussion of SQL Server. We will touch on the
basics required for use with WireCAD. 

Basics

The WireCAD distribution includes SQL Server database files for the Global Equipment database. You will need to
attach these to the the running server. You will then configure WireCAD to look at the SQL Server for the Global
Equipment database. WireCAD projects will create a new database (catalog) for every new project.

You will need to set up permissions for each user to allow them dbcreator privileges. This is the
default for localhosts but not remote servers.

There is no further requirement to attach databases once the Global Equipment database.

SQL Server can be set up on a server or on a local machine. WireCAD requires the 2005 version and can use the
Express versions which can be found here:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=22625

Be sure to download SQL Server Management Studio Express as well. Both are free.
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-
5a0f62bf7796&DisplayLang=en

SQL Server does not provide a graphical user interface so you will want to download the management studio listed
above. 

Setting Up the WireCAD Global Databases on SQL Server

The following assumes that you are installing WireCAD on a local machine. If you are installing on a server you will
want to copy the global database files in Step 6 below to the server before you attach them to the server.

1.Install SQL Server. You will be prompted for an instance name. Instance names allow you to have multiple SQL
Servers running on the same machine. In addition you will be prompted for a security mode (Windows or SQL),
Windows uses your Windows users and groups, SQL ignores these and allows you to manages different users
and groups from within SQL Server.

2.Install SQL Server Management Studio(SQLSMS).
3.Launch SQLSMS and log in to the server. If the server is on your local machine you can use the shorthand .

\INSTANCENAME for the host.
4.The next step is to attach the global databases. 

5. In the Object Explorer
right-click the Databases
node and click Attach...

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=22625
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-5a0f62bf7796&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-5a0f62bf7796&DisplayLang=en
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6. Click the [Add] button on the Attach Databases form and browse to:

XP:
C:\Documents and Settings\All Users\Shared Docs\WireCAD\WireCAD7\WireCAD_Global_Equipment.MDF

VISTA/7
Public\Public Documents\WireCAD\WireCAD7\WireCAD_Global_Equipment.MDF

The form will look for and add the WireCAD_Global_Equipment_log.LDF file. If it can not find it you will have to add
it manually.

7. Click OK to attach the
database. 
8. You will now need to configure each WireCAD client to look at the SQL Serverl
9. Launch WireCAD
10. Click
Project>Application Setup
and follow the steps for
SQL Server.



Part

VIII
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8 Included Plugins

WireCAD includes a number of plugins that provide additional functionality. WireCAD XL FREE does not load plugins
so none of the following information applies to the XL FREE version.

Each plugin will load and register its own command line commands if the plugin provides command functionality. 

For information on customizing WireCAD with your own plugins see the SDK  documentation and the SDK
samples.

8.1 Pinouts

Menu: Database>Pinouts

Default command line shortcut: po

The Pinout utility serves two functions. The first is to generate pinout detail drawings

The second is to generate data that can be used in the conductors table under any cable
that we wish to attach the data to.

Applies To:
PRO
Related Settings:
None

165
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8.2 Search

Menu: None

Default command line shortcut: 

The Search utility provides a search tool window that allows the user to
search all of the data collections. For example, if you wanted to find all
occurrences of the cable number 1001 the search utility could show you.

NOTE: The search utility only searches the data collections not the drawings.

Applies To:
PRO
Related Settings:
None

8.3 Translation Manager

Menu: Plugins>Translation Manager

Default command line shortcut: none

The translation utility provides a means by which all strings, captions, and
messages may be translated to a different language.

Applies To:
PRO
Related Settings:
None
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Here we see the Translation manager with the English version on the left and the French version on the right. The
pane on the right-hand side shows statistics.

You can right-click a column header and select the KeyString column to should the base English string that the
program searches from.

Controls

Current Culture is: The culture of your machine. If no translation exists, WireCAD defaults to the en
(English) language.

Select Language To
Translate:

Selects the language to edit in the right-hand column.

Show Context Select to display a column showing the primary context in which the string or
message appears.

8.4 Block Extractor

Menu: Plugins>Extract All Blocks

Default command line shortcut: exall

Requires an active drawing.

Extracts all blocks in the current drawing to the folder of your choosing. Files
are written out of the drawing as individual dwg files with the name of the
block. The basepoint of the drawing (origin) is the insertion point of the block.

Applies To:
PRO, XLT
Related Settings:
None
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8.5 Bulk Block Fixer

Menu: Plugins>Bulk Block Fixer

Default command line shortcut: blkf

The Bulk Block Fixer utility provides a means by which dwg files may be
easily converted for use with WireCAD. The fixer will convert a single
drawing or all drawings in a folder.

Applies To:
PRO, XLT
Related Settings:
None
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Bulk Block Fixer Dialog

Bulk Convert All
Files In Folder
Checked performs
selected options on
all files in selected
folder

Basepoint Position Don't Move - Do nothing.
   Move All Entities To Lower Left Basepoint. 

Before:
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After:

Move All Entities To Center Basepoint. 
Before:

After:

Scaling Scales all drawing objects based on the selection.

Intelligence/
Appearance

Add WireCAD Attributes. - Use this function to add the standard WireCAD attribute
set to the dwg file. This makes inserted items double-clickable. This is not required, and
should not be used, if you are using the dwg file as a DWGIcon or Custom Shape file.

Create Bounding Box - Creates a rectangle around the entities in the dwg file of the
color selected. This is useful for DWGIcons or Custom Shape files

Copy Copies fixed block files to the selected directories.
\Subfolder and Prepend allow you to modify the location and filename upon copy.
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8.6 Batch Plot

Menu: Plugins>Batch Plotter

Default command line shortcut: bp

The Batch Plot plugin allows you to select any number of layouts to print from project drawings.

Applies
To:
XLT,
PRO,
ENT
Related
Settings
:
None

8.6.1 What Does It Do

What Does It Do Top   Previous   Next

Batch Plot lets you select the drawings and layouts that you want to send to the printer and print them as a
batch. You may print any layout in any drawing in the current WireCAD project. You may also specify how many
copies and in what order to print.
  
Batch Plot allows you to save Batch Plot files for reuse at a future time

8.6.2 What Does It Not Do

What Does It Not Do Top   Previous   Next

Batch Plot does not output to pdf.
 
Batch Plot does not print project reports.
 
Batch Plot does not collate layouts with multiple copies set.
 

113 113 113

113 113 114
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8.6.3 User Interface

User Interface Top   Previous   Next

Batch Plot Plugin User Interface

 
Hopefully the user interface is self explanatory.
 
Here are a few items of interest. The Plot This checkbox determines which layouts to send to the printer.
 
The [Plot/Print] button is the same as the File>Plot/Print menu command and sends all selected layouts to
their respective printers.
 
The [UP] and [Down] buttons move the selected layout up or down in the list thereby reordering their output
order.
 
If you want to delete a layout. Select the layout in the list and click the minus [-] button in the navigation window
in the lower lefthand corner of the grid

 
Clicking the [Preview] button will preview the selected layout in the Preview Pane regardless of whether it is
selected to in the Plot This column

Control Function

Full Preview Render actual output. Otherwise show margin box.

Preview On Plot Render the full preview (full or not) on output to the printer/
plotter.

Use Layout Settings Ignore the Batch Plotter settings and use those stored with
the drawing layout. Selecting this disables printer, paper,
and margin settings in favor of those in the layout.

113 113 115
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Paper Printer paper size. If this dropdown is empty, select a
printer first.

Margins Set your margin unit of measure first, then the left, right,
top and bottom.

Black and White Output in black and white.

Scale to Fit Force all entities in the selected layout onto the page.

Extents Print the extents of the layout.

Landscape Landscape output.

Select Printer Choose the printer that all selected layouts will be sent to.

8.6.4 Menus

Menus Top   Previous   Next

Menu Information

8.6.4.1 File

File Top   Previous   Next

File>New Batch Plot File
Creates a new file scanning the project drawing set and adding all drawing and all layouts.
 
File>Open Batch Plot File
Opens a saved Batch Plot file.
 
File>Save
Saves your settings to a Batch Plot File. This is helpful if you change the default order of the list or the number of
copies, etc.
 
File>Save As
Save your setting as a new file name.
 
 
File>Print/Plot Selected
Prints the selected (Plot This) layouts to the printer settings determined in the layout. So be sure to Print
Preview (from the drawing layout) your layouts first and set up all of your output settings.
 
File>Cancel Queue
Stops the function. Does not purge any print jobs already in the windows print queue.
 
File>Exit
Done

113 114 115
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8.6.4.2 Tools

Tools Top   Previous   Next

Tools>Rescan
Clears the list and re-scans the project drawings for all layouts. This function is like the File>New function but
differs in the it does not create a new file name.
 
Tools>Add Drawing
It may be desirable to keep all of your setting and add an additional drawing to the list.
 
Tools>Remove Layout.
Removes the selected layout.

8.6.4.3 Help

Help Top   Previous  

Help>Contents
Displays this file.
 
Help>About
Displays version and copyright information.

8.7 DWG Diff

8.7.1 Introduction

Welcome to the DWG Diff Help File
 
DWG Diff is a utility the displays the differences (and commonalities) between two dwg drawings.
 

Features:
 

Open, View, Print dwg files.
Difference the selected layout.
Display Common, A not B, B not A drawing elements.
Displays not only the drawing entity differences but also lists difference in the drawing structure such as:

       Layers
       Layouts
       Text Styles
       Blocks
       Dimension Styles
 

Save the differenced drawings as dwg or pdf.
Print the differenced drawings.
Control the layers.        

 

 
 

8.7.1.1 Screen Shots

Drawing A

113 115 116

113 116
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Drawing B

Common to Both

Entities in A but not B
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Entities in B but not A

 
 

8.7.1.2 Functions

Menu Items
File>Open A: Open the A drawing.

File>Open B: Open the B drawing.

 
Tools>Calculate Differences: Does the work.

       
Compares the selected drawing space eg: Model or Layout.

 
View>Zoom Extents: Zoom the selected space to the extents of all entities.

 
Help>Help: Displays this file.

Help>Software Activation... : Displays the activation screen.

Help>About: Displays the about screen that show version information etc.

 
 

Right-click Context Menus
The following menus are available from all drawing spaces:
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8.7.1.3 Command Line Instructions

You can call DWG Diff from a command line or script and pass in filenames for the A and B
drawings as well as output filenames.

The following is the command line usage:

dwgdiff.exe a="<Your A DrawingFilePath>" b="<Your B DrawingFilePath>" m=[i]mmediate | m=[w]ait

| m=[s]ilent

a="<Your A DrawingFilePath>" - this is required if you are passing in variables to the command
line.
b="<Your B DrawingFilePath>" - this is required if you are passing in variables to the command
line.
m=[i]mmediate | m=[w]ait | m=[s]ilent - required.
opA="<Diffed Output Filename and Path A not B>" - Optional Output File.
opB="<Diffed Output Filename and Path B not A>" - Optional Output File.
opC="<Diffed Output Filename and Path Common>" - Optional Output File.

a=, b=, op=A, opB=, opC= should be quoted strings if the file paths contain spaces. They
should also contain fully qualified file names with extensions.

The variable order is not important.

MODES
m=s opens drawings calculates differences and outputs any of opA, opB, or opC if any; also
runs silently without the user interface being shown.
m=i will immediately calculate differences.
m=w will wait for you to click Tools>Calculate Differences once DWG Diff is open.
both m=i or m=w show the user interface.

EXAMPLES

Open two drawings and calculate the differences:
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=i 

Open two drawings and show the user interface and wait for you to press Tools>Calculate
Differences:
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=w

Open two drawings, calc diffs and write out the AnotB differences. Does not show UI.
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=s opA="c:\my Output A Drawing.

dwg"

Open two drawings, calc diffs and write out the AnotB, BnotA and Common drawings. Does not
show UI.
dwgdiff.exe a="c:\my a drawing.dwg" b="c:\my b drawing.dwg" m=s opA="c:\my Output A Drawing.

dwg" opB="c:\my Output B Drawing.dwg" opC="c:\my Output Common Drawing.dwg"
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8.8 Brother P-Touch

8.8.1 Introduction

 

Welcome to the WireCAD plugin for Brother P-touch Electronic Label printers. This
plugin supports any of the P-touch printer drivers for Windows, and works in
conjunction with the stock P-touch .lbl template formats.

For best results this plugin should be installed in conjunction with at least one P-touch printer driver
(follow the instructions with the printer) and the P-touch editor v4.1 or better. For the latest drivers
and software, visit the Brother website at www.brother.com

 

In order to work properly the Brother_PTouch.Plugin.dll file and support folders must be
installed in the WireCAD6\bin folder. Place the BrotherPTouch.wpi file in WireCAD6
\bin\plugins folder.

 

The minimum WireCAD build version to work with this plugin is 6.0.1400

 

This plugin assumes that you have data in your Project Cables or Project
Systems database.

8.8.1.1 Data Page

This plugin has the ability to pull from either the Project Systems database or the
Project Cables database. Upon selection of the desired database, you have the ability
to apply filters to narrow the selection set. These filters work like the other filters in
WireCAD. Click the <Edit Filter> button and the filter dialog will be displayed; then select

the field, conditional operator and value. Next click the <Apply Filter> button.

http://www.brother.com
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Table: Combo. Selects either the Cables database or the Systems database.

Note: the data grid is read only.
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8.8.1.2 Print Cable Labels and Port Tags

From this page you select the template file into which you will print the selected data.

 

 

Template File: listbox enumerates all *.lbl files in the {WireCAD Common App Data}

\Plugins\Brother Ptouch\Templates\ folder.

<Preview>: Load the selected record into the selected template file and display it.

<Print All>: Prints the entire recordset to the printer.

<Print This>: Prints the selected record.

<Edit>: Launches the P-touch editor (if installed).

Copies: textbox: Enter the number of copies to print.

Preview: pane. Displays a preview of the selected record.

Record Selectors:

Navigate through the recordset.

 

Printer Options:
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Half Cut: If supported on the printer, will only cut through half of the label creating a roll

of labels that can be torn off in the field. This is available on the industrial series printers
like the PT-9500 and is really slick.

Chain Print: No space between label prints, nor feed or cut at the end.

Cut Mark: Prints a cut mark.

Mirroring: Inverts text.

 

 

Note: the .lbl file contains the info for the printer for which it was created. If you have multiple P-touch
units attached to your computer, the report will attempt to print to the unit defined in the .lbl file.

8.8.2 Database Field Rules

This plugin extends the capabilities of the .lbl file. The plugin will evaluate field
expressions and insert(merge) text values from any of the database fields into the
label.

In order to evaluate properly, the field name must be enclosed in square braces
[fieldname].

Text that is not to be replaced is entered normally.

Text that is to be evaluated and replaced is contained in a string that starts with the =

symbol and contains at least one field definition.

 

In the above example, the text strings "Alias:" and "SysName:" will print as shown. The

text strings starting with the = symbol will be replaced by the data from the fields in the

current record.
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Further, assuming that the field [alias] contains the data "3/4-01" and the field [sysname]

contains "3/4-01", the label will print as follows:

Any characters not enclosed in square braces "[ ]" will be printed as shown.

8.8.2.1 Cable Number Fields

The following is a list of the available Cable Number fields that are available for use in
the label:

Field Name Description

Avai l abl e True/False. True = the cable number is available and will show
up in the available cables list of the Ver i f y Set t i ngs dialog.

Avai l abl eCor es True/False. Depreciated. Not used.

Cabl eI D Unique Key. If this is visible, do not change it. Depreciated.
Not used.

Cabl eGUI D Unique Key (GUID)

Cabl eNo The cable number. See the Project Cable Number Format
Dialog.

Cabl eNoPr ef i x Used with V3 cable number format.

Cabl eNoSuf f i x Depreciated. Not used.

Cabl eType Cable part number

Cabl eTypeManu Cable manufacturer
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Ckt Dst Future. Do not use

Ckt I D Future. Do not use

Ckt No Future. Do not use

Ckt Sr c Future. Do not use

Cr eat edBy Who made the cable.

Dat eModi f i ed When entry was modified last.

Dat eOr i gi nat ed When entry was first created.

Dest Conn Destination Connector

Dest Loc Destination Location

Dest pi n Destination Port

Dest Sys Destination SysName

Dst Al i as Destination Alias

I nt egr at or User field.

Lengt h Manually enter a length or assign a named path and
automatically generate a length.

Mul t i cor e True/False. Is it a Multicore cable

NamedPat h A named path. See the Named Paths database.

Pr oj ect Revi si on Inherited from the Global Projects database.

Repl acedBY Not used.

SHEET The drawing file name.

Si gnal Type Signal Type

SRCAl i as Source Alias

Sr cConn Source Connector

Sr cLoc Source Location

Sr cPi n Source Port

Sr cSys Source SysName

User 1 It's up to you.

User 2 It's up to you.

User 3 It's up to you.

User 4 It's up to you.

8.8.2.2 SysName Fields

The following is a list of the available SysName fields that are available for use in the
label:
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Field Name Description

Al i as The friendly or functional name for this device

Conf l i ct Conflict resolution mode. Conflicts arise when two devices
that are marked IsSequential are connected together. At this
point we must discard one of the numbers.
 

Cur r ent Pr oj ect Revi
si on

Inherited from the Global Projects database.

Dat eAdded The date created.

Dat eModi f i ed Last Modified.

El evat i on The El evat i on element of the location data.

Equi pment Name Equipment Name

I sSequent i al Reserve a sequential number for each input and output
regardless of connection state. Not currently used.

Locat i on The Locat i on element of the location data. The Location and
Elevation fields will be concatenated together using the
System Location Delimiter to create the Location data. ex
Room 101.Wall, or 101-11.12

Manuf act ur er Manufacturer name.

SysName The name element of the sysname.

User 1 For you.

User 2 For you.

User 3 For you.

User 4 For you.

 

8.8.3 More about the .LBL file

The lbl file is Brother's template file for the P-touch electronic labeling systems for PC.
Therein you define the look of the printed output.

 

Some important points to remember:
1. The lbl file contains printer specific information.
2. If the printer for which the lbl file was created is not found on your machine and you

have only one P-touch printer driver on your machine, the label will print to that
machine.

3. If you have multiple P-touch device drivers installed on your machine and the one for
which the lbl file was created is not found you will receive an error stating that the
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printer cannot be found. Switch to the P-touch editor and change the printer settings
to one of the installed drivers.



Part

IX
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9 CAD Basics

9.1 What is CAD ?

Description

What is CAD/CAM?

CAD Computer Aided Design or Drafting. Inputting lines, arcs, coordinates, dimensions and text for
engineering purposes not onto paper but into a data base. The beauty of this is the ability to manipulate the
data in many ways during and after completion of any job. There are many types of CAD systems and brand
names, but you can break it down into two types, 2D and 3D.

2Dimensional almost like drawing on a drafting board, essentially a flat view usually dimensioned and detailed
to some type of standard but is somewhat limited. 3Dimensional is very popular, and with the ability to
manipulate 3D Models as if they were actual solid objects, very desirable. Each 3D model is an exact replica of
an existing object or idea of an object but in digital format which can be up scaled or down scaled or modified
to any specific tolerance. These digital objects are then ready for multiple views, or cross sections, dimensions
and details, just like 2D drawings. But 3D models have much more to offer, NC programming can be done to
create actual products, see CAM, or even for graphic development for the animation industry, which is also
very popular.

CAM Computer Aided Manufacturing, in some cases the manufacturing of parts, fixture gauges, stamping
dies, prototype models, moulds etc. The relation to Mach9 Technologies Inc. is not so much Manufacturing but
more Computer Aided.

CAM the use of computer generated 3D models,see CAD, to develop specific programs for any particular solid
object. Creating a program, cutter path, for an Numeric Control (NC) machine is the most widely used format
for cutting various forms, shapes and contours into various materials such as steel, aluminum, tool board,
wood, and machinable waxes. There are many other ways to cut materials which are computer controlled as
well, and these processes are highly sophisticated in each of their aspects. NC machines are everywhere
producing products every day.

Remarks

The term CAD/CAM is a shortening of Computer-Aided Design (CAD) and Computer-Aided Manufacturing
(CAM). The term CAD/NC (Numerical Control) is equivalent in some industries.

Well before the development of Computer-aided Design the manufacturing world adopted tools controlled by
numbers and letters to fill the need for manufacturing complex shapes in an accurate and repeatable manner,
especially for aircraft components. During the 1950's these Numerically-Controlled machines used the existing
technology of paper tapes with regularly spaced holes punched in them (think of the paper roll that makes an
old-fashioned player piano work, but only one inch wide) to feed numbers into controller machines that were
wired to the motors positioning the work on machine tools. The electro-mechanical nature of the controllers
allowed digital technologies to be easily incorporated as they were developed.

By the late 1960's Numerically-Controlled machining centers were commercially available incorporating a
variety of machining processes and automatic tool changing. Such tools were capable of doing work on
multiple surfaces of a workpiece, moving the workpiece to positions programmed in advance and using a
variety of tools - all automatically. What is more, the same work could be done over and over again with
extraordinary precision and very little additional human input. NC tools immediately raised automation of
manufacturing to a new level once feedback loops were incorporated (the tool tells the computer where it is,
while the computer tells it where it should be). What finally made NC technology enormously successful was
the development of the universal NC programming language called APT (Automatically Programmed Tools).
Announced at MIT in 1962, APT allowed programmers to develop postprocessors specific to each type of NC
tool so that the output from the APT program could be shared among different parties with different
manufacturing capabilities. The development of Computer-aided design had little effect on CNC initially due to
the different capabilities and file formats used by drawing and machining programs, but as Cad applications
such as SolidWorks and AutoCad incorporate Cam intelligence, and as Cam applications such as MasterCam
adopt sophisticated Cad tools both designers and manufacturers are now enjoying an increasing variety of
capable Cad/Cam software. Most CAD/CAM software was developed for product development and the design
and manufacturing of components and molds, but they are being used by architects with greater frequency.
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CAD/CAM software utilizes Cad drawing tools designed ultimately to describe geometries in such a manner
that they can be extracted by the Cam portion of the program to define a toolpath that will direct the motion of
a machine tool to machine the same shape that was drawn.

Today, over three-quarters of new machine tools incorporate CNC technologies. These tools are used in every
conceivable manufacturing sector, including many affecting building technologies. CNC technology is related to
Computer-Integrated Manufacturing (CIM), Computer-Aided Process Planning (CAPP) and other technologies
such as Group Technology (GT) and Cellular Manufacturing. Finally, Flexible Manufacturing Systems (FMS) and
Just-In-Time Production (JIT) are important concepts made possible by Numerically-Controlled Machines,
affecting the integration of manufacturing cells, productivity and quality in a wide variety of strategic industries.

 

9.2 Drawing Entities

Description

Drawing objects are all the objects that are seen on a drawing, like lines, circles etc.

Each one of them are specified by their geometry.

Remarks

These objects can be :
Line

Circle

Polyline

Arc

Dimension

Image

Polyface

PolyHatch

Rectangle

Ellipse

Text

Insert  of block

3DFace

 

 

9.2.1 Line

Description

A single line segment.

Lines can be one segment or a series of connected segments, but each segment is a separate line object.
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Use the line object if you want to edit individual segments.

Remarks

Line is specified by two points, the Start point and the End point.
When the line has thickness then the extrusion vector of the line defines the direction of the thickness.

 

9.2.2 Circle

Description

A full circle is defined by its CenterPoint and its Radius.

Circle is drawn in the plane that is defined by CenterPoint and ExtrusionVector.

Remarks

Ways to design a circle:

 

Center,Radius

With this method user sets the
center point and the radius of the
circle

2 Points
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With this method user sets two
opposite points of the circle.
Basically the two points define the
diameter of the circle(position and
size).

3 Points

With this method user sets three
points that belong to the circle.

 

9.2.3 Polyline

Description

This object is a 2D/3D line composed of line and arc (bulges) segments. Polyline is specified by an array of
Vertexes (points). When the Polyline has thickness then the extrusion vector of the polyline defines the
direction of the thickness.

Polyline can be Open or Closed, can be SPLine and be filled with a color or a hatch.

Remarks

Bulge Geometry :
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9.2.4 Arc

Description

A circular arc is defined by the center point, the radius, the start angle and the end angle.

 

An arc is always drawn anti-clockwise from the StartAngle to the EndAngle.

The StartPoint and EndPoint properties of an arc are calculated through the StartAngle, EndAngle and Radius
properties.

The ExtrusionVector is always vertical to the arc. Arc is drawn in the plane that is defined by CenterPoint and
ExtrusionVector

Remarks

Ways to design an arc:

 

Center Point,Radius,Start Angle,End Angle

With this method user has to set
Center Point,Radius,Start angle
and End angle of the arc

With this method user has to
set 3 points of the arc

9.2.5 Dimension

Description

Dimensioning is the process of adding measurement annotation to a drawing. User has many ways to
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dimension objects and many ways to format dimensions. You can create dimensions for a wide variety of
object shapes in many different orientations. You can create dimension styles to format dimensions quickly and
ensure that dimensions in your drawing conform to industry or project standards.

Dimensions show the measurements of objects, the distances or angles between objects, or the distance of a
feature from an origin you specify. User has three basic types of dimensioning: linear, radial, and angular.
Dimensions can be horizontal, vertical, aligned, rotated,angular. A linear dimension measuring the distance
between two points which is displayed parallel to the points  being measured. In aligned dimensions, the
dimension  line is parallel to the extension line origins. The extension  line origins are specified using the
DefPoint1 and DefPoint2 properties.

Angular dimensions measure the angle between two lines or three points.

9.2.6 Image

Description

It is a basic object for inserting images in the drawing.
Inserted Images can be BMP, GIF, JPG, PNG and TIFF

When the inserted image is an 1-bit Image (B&W) then the background color of the image (usually the white)
is shown transparent and the other color is shown black or white, depending on the background color. This is
useful for drawings to be scanned and then inserted as images in other drawings.

Image has a Scale property that is used to resize keeping the aspect ratio of the image.

The image is defined by InsertionPoint, Rotation, Width and Height.
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9.2.7 Polyface

Description

User defines a PolyFace by specifying each vertex and then associating those vertices with faces in the mesh. 

In essence , polyface is a number of 3dfaces combined to an object.
User can explode the polyface into 3dfaces.

User can create complex 3D objects.

9.2.8 PolyHatch

Description

Polyhatch is a collection which contain PolyLine Objects.

Every PolyLine represents one Hatch which can be excluded from the whole collection or be included to the
collection. You can control this using CombineList property. If the CombineList index = 16 then it is excluded
else it is included.

Remarks

You can Use Item, Count methods and for each to access the PolyLine Objects of Polyhatch object.
When your drawings have Polyhatch objects and are saved in third party formats then Polyhatches are
converted to Hatches and vice versa.

Polyhatch objects do not have thickness.
Polyhatch objects in 3D are displayed as solids filled with the FillColor.

 

9.2.9 Ellipse

Description

An ellipse is defined when we know:

a) length of axis 1 and the end point of axis 2

b) center point and the end points of the two axis. 
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9.2.10 Text

Description

If you want to add a text in the drawing you can use the text command.

You have to set the start point where the text will begin. Then you have to set the rotation angle of the text.
After that you can specify the text. Notice that the text will be drawn with the current Text Style of the
document.
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9.2.11 Insert

Description

Places a drawing or a named block into the current drawing.

When you insert a block, you determine its location (or its name if it exists in the drawing), scale factor, and
rotation angle.Inserting a block creates an object called a block reference because it references a block
definition stored in your current drawing. Notice that in order to insert a block , this must be an existing block
that previously has been created or that it will exist as an independent drawing.

 

Remarks

The insert object can be exploded to the objects that consist of.

 

9.2.12 3DFace

Description

3dface creates a three or four sided surface anywhere in 3D space. You can specify different Z coordinate
values for each corner point of a 3D face.

Remarks
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Is an object which have a vertexlist with 4 items as Point(x,y,z) in World CS.

The fourth point can be the same as first (to make a triangle).

 

9.3 Collections

Description

The Collections are very important. The drawing objects (lines, text, dimensions etc) take their properties,
when they are created, from these collections. The collections are:

Layers

Layouts

TextStyles

DimStyles

Blocks

Lights

Selections

Section Clips

Linetypes

Lineweights

9.3.1 Layers

Description

Layer is the equivalent of the overlay used in paper-based drafting. It is the primary organizational tool in the
WireCAD CAD space, and you can use it to group information by function and to enforce linetype, color, and
other standards.
Organizing Layers and the objects on Layers make it easier to manage the information in your Drawings.

When you put one layer over another then the result is the complete drawing.

                                                                      

Having kindred objects on the same layer it is very helpfull in order to organise the drawing.

Properties:
layer name

color of the entities

line type of the entities

line weight of the entities

if it is participate or not in the drawing(thawed or frozen)
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locked or not

Remarks

When you begin a new drawing, WireCAD creates a special layer named 0. By default, layer 0 is assigned
color number 7 (white or black depending upon your background color), the CONTINUOUS linetype and a
lineweight of Default (the default setting is .01 inch or .25 mm). Layer 0 cannot be deleted or renamed.

All new objects are added to the active layer if no layer is specified.

Using the Layers editor you can Freeze (Hide), Thaw (Show) and Lock layers.

By controlling whether a Layer's state is Thaw or Frozen you can change the appearance of your drawing to
display only the information on the Layers that are visible. Freezing unused Layers will help the performance of
WireCAD.

In the drawing below (Picture 1) there are 3 types of items : walls (the lines and Polylines with red color),
doors&windows (Blue color) and furniture (Magenta).
These objects are teamed and drawn in different layers. Walls placed on layer "WALLS", Doors&windows are
placed on layer "WIN_DOORS" and furniture are placed on layer "FURNITURE".

Picture 1

All layers are Thawed. All
information is shown.

In big drawings this might
confuse the user.

Picture 2

Layer "FURNITURE" is
Freezed. The furniture is not

shown.
A civil engineer would like to
view the drawing this way.
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Picture 3

All layers except the
"WALLS" are freezed.

This is the basic information.

 

***

9.3.2 Layouts

Description

Layout is used to compose or lay out your model drawing for printing. A layout may consist of a title block, one
or more viewports, and annotations. As you create a layout, you can design floating Viewport configurations to
visualize different details in your drawing.

A layout is a paper space environment that simulates a sheet of paper. In a layout, you can create and
position viewport objects, and you can add a title block or other geometry. You can create multiple layouts in a
drawing to display various views. Each layout displays the drawing as it will be printed on the sheet of paper.

Typically, when you begin designing a layout environment, you step through the following process:
   Create a model drawing.
   Activate or create a layout.
   Insert a title block.
   Create floating viewports and position them in the layout.
   Set the view scale of the floating viewports.
   Print your layout.

Remarks

Sample of a Layout (Paper Space) :

mailto:helpsdk@vdraw.com?subject=Documentation Feedback: Layers [6/23/2004]
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***

9.3.3 TextStyles

Description

TextStyle is a named, saved collection of settings that determines the appearance of text strings.

You can create your own text styles which can have specific fonts and text height. You can also specify if the 
text  will be underlined,bold etc.

There is no limit to the number of text styles you can create in your drawing. 

Remarks

The active text style determines the appearance of new text created in the drawing. StyleName of text object
will get the value of ActiveTextStyle property.

When you enter text, it uses the current text style, which sets the font, size, and other text characteristics. If
you want to create text using a different text style, you can make another text style active.

 

9.3.4 DimStyles

Description

A dimension style is a group of dimension settings that determines the appearance of a dimension  . 

Remarks

The active dimension style determines the appearance of new dimensions created in the drawing.
To change the style of an existing dimension, use the StyleName property found on the dimension.

When you create a dimension, the current dimension style is associated with that dimension. The dimension
retains this dimension style unless you apply a new dimension style to it or set up dimension style overrides.
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The picture below shows where the vdDimstyle's properties apply to vdDimension objects.

 

9.3.5 Blocks

Description

A block is a collection of objects you can associate together to form a single object, or block definition. You can
insert, scale, and rotate a block in a drawing. You can explode a block into its component objects, modify
them, and redefine the block definition.

Remarks

Blocks streamline the drawing process. For example, you can use blocks to
Build a standard library of frequently used symbols, components, or standard parts.
You can insert  the same block numerous times instead of re-creating the drawing elements each
time.

Revise drawings efficiently by inserting, relocating, and copying blocks as components rather than
individual geometric objects.

Save disk space by storing all references to the same block as one block definition in the drawing
database.

When you insert  a block in your drawing, you are creating a block instance. Each time you insert a block
instance, you assign a scale factor and rotation angle to the inserted block. You can also scale a block instance
using different values in any coordinate (X, Y, Z) direction. Blocks make it possible for you to organize your
drawing tasks in a systematic way, so that you can set up, redesign, and sort the objects in your drawings and
the information associated with them.
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9.3.6 Lights

Description

It is the collection of the Lights objects.

Adding lights to your drawing is the simplest way to improve the appearance of your models. You can use
lights to illuminate a whole model or to highlight selected objects and parts of objects in your drawing.

Remarks

You can add as many lights you want but you can only enable 8 including the Default Light.

This is an example of a sphere with two lights.

9.3.7 Selections

Description

One or more selected objects that specify a selection for processing as a single unit. 

For example instead of copying objects to another location one at a time, you can select all objects and copy
the selection once.

Remarks

There is no limit to the number of selection sets you can create in your drawing.
However, there can be only one instance of the SelectionSets Collection. 
The SelectionSets Collection object is predefined for each drawing.

 

9.3.8 Section Clips

Description

WireCAD uses section clipping planes to hide an area of the drawing. This SectionClip defines the side of the
drawing that will be visible. The rest will be hidden.

Remarks

The visible plane is defined in the vdSectionClip object by defining the OriginPoint and the Direction vector. The
direction of that vector defines the visible area. The area in the opposite direction will be hidden.
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Direction with the OriginPoint define the plane that will do the section clipping. Their values are always in World
Coordinating System.

Multiple vdSectionClip objects will show the common viewable area of all. This allows an unobstructed interior
view of a 3D drawing by hiding the defined area from view.

9.3.9 Linetypes

Description

With linetype you can select a specific type for a line  which all the new lines will be.

Any future object in the drawing will be added with the new selected line type.

TIPS:Instead of changing line type any time you want a different line type, you can create different layers
with the desirable line type.

Remarks

130

139
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WireCAD uses penstyle property to define the linetype.

Default value is VdPenByLayer (PenStyle by Layer). When object is a Layer then the default value is
VdPenSolid.

Penstyle is scaleable.The scale is set from the ActiveDocument.LineTypeScale property.

If the entity is part of a block and it's layer name is "0" and pen style is VdPenByLayer (by Layer) then, when
the block is inserted, entity takes the pen style value of the inserted object. This can be done the same if you
use for Penstyle the value VdPenByBlock (by block).

These are some examples of linetypes:

 

9.3.10 Lineweights

Description

With lineweight you can select a specific width for a line which all the new lines will be.

Using lineweights, you can create heavy and thin lines to show cuts in sections, depth in elevations, dimension
lines and tick marks, and varying object thicknesses in details.

Remarks

TIPS:Instead of changing lineweight any time you want a different lineweight, you can create different layers
 with the desirable lineweight.

Any future object in the drawing will be added with the new selected lineweight.

In model space, lineweights are displayed in pixels and do not change when zoomed in or out. Thus, you
should not use lineweights to represent the exact width of an object in model space. For example, if you want
to draw an object with a real-world width of 0.5 inches, do not use a lineweight, instead, use a polyline with
penwidth equal to 0.5 inches to represent the object.

 

9.4 Commands

Description

In order to edit designed objects you have to run the specific command and then select the object(or objects)
you want to edit. The same procedure must be done when you want to create new objects from one or more
drawing objects.

Alternative, you can choose firstly the objects and then run the command. However not every command
accepts preselected objects.Also not every command accepts multiple selected objects.

Remarks

The commands are used to edit the drawing objects, like splitting a line to two smaller lines, delete a circle etc.
The commands are the following:

Select
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Erase

Undo

Redo

Copy

Offset

Fillet

Move

Trim

Extend

Mirror

Array

Break

Scale

Rotate

Explode

Purge

Zoom

Pan

View3D

 

9.4.1 Select

Description

When you run an edit command (which allows multiple object selection) you have to select the objects(or
object) that you want to edit.

There are many ways to select objects:
You can click one by one the objects you want to select.

Crossing method. With this method you have to set a rectangle by setting the two opposite corners
(first set one of the two right corners) of the rectangle. Then all the objects that are included entirely
in the rectangle or have an intersectection point with the rectangle , will be selected.

Window method. It is similar with the crossing method , but only the objects that are included
entirely in the rectangle will be selected(Also you have to set one of the left corners of the window).

Select All. With this method you can select all the objects of the drawing

Select Last. With this method you can select the last drawn object.

Select Previous. With this method you can select the objects that was selected before the completion
of the last edit command(Notice that previous command does not take effect when the previous
command was erase or undo.

 

Remarks

9.4.2 Erase

Description

With the erase command you can delete one or more objects of the drawing.

If you want to erase multiple objects you have to execute the select  method.
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After the erase command, the objects no more "exist" in the document and in the collection they belonged to,
however the objects still exist as "deleted" objects in memory. So with undo command you can get them back
to the drawing.

Remarks

 

9.4.3 Undo

Description

Many times you want to cancel one or more commands that took place.This can be done with the undo
command.

You can also undo a group of commands that took place. The group undo takes place by the opposite order.If
for example 100 commands were executed, undo command cancels first the 100th command , then the 99th
etc.

Remarks

 

9.4.4 Copy

Description

With copy command you can copy one or more objects of the drawing.

When copy command starts, user has to select  objects. Then the user is prompted to select two points.
These two points define the "copy vector" and  can either belong to the selected objects or not.The first point
specifies the begining of the "copy vector" and the second point the end of it.

Remarks

 

9.4.5 Offset

Description

With Offset command you can create a new object , in parallel direction and in specified distance from the
original object which is used as pattern for the new object.

When you execute offset command , you are promt to select  an object. Then you have to specify the offset
distance which is the distance that the new object will be draw from the original object. Then you have to set
the side that the object will be draw because there are two sides.
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Remarks

 

 

9.4.6 Fillet

Description

With the fillet command you can connect two lines , two arcs, or one arc with a line(these two objects must
have at least one common point either visible, or in their extension) , with an arc with a specific radius. The
value of the radius has some restrictions depending the position of the objects. If radius=0 then simply the
objects are either extended until they intersect each other in one point(if there was not an intersection point)
either trimmed(if an intersection point is visible).

 

                                                

You can also insert fillet arcs at vertex of specified index of a polyline where two line segments meet if the
specified radius is enough small to fit into lines.

If the radius is bigger then it is ignored for the specific vertex.

 

 

                                                   

Remarks
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9.4.7 Move

Description

With move command you can move one or more drawing objects.

In order to take place the move command you have(after selecting  the objects or object)  to define two
points that define the distance and the direction of the movement.

The firts point defines the beginning of the "movement vector" and the second the end of the vector.

Remarks

 

9.4.8 Trim

Description

With trim command you can trim objects at a cutting edge defined by other objects.

First select  the objects that define the cutting edges at which you want to trim an object and then the
object.
Objects that can be trimmed include arcs, circles, elliptical arcs, lines.

Notice that the trim command do not function if the objects do not intersect.

At the example below there are some lines that were trimmed.

 

 

                                            

Remarks

9.4.9 Extend

Description

With extend command you can extend lines,arcs,polylines until they intersect with some other object which is
used as limit of the extension.

Firstly you have to select  the objects that consist the limits of the extension. Then you have to choose a
point at an object that you want to extend. If the object you want to extend does not intersect with above
objects then nothing will happen.
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Remarks

 

9.4.10 Mirror

Description

With mirror command you can create the symmetrical of one or more objects reflected by an axis defined by
the user.

 First you have to select  the objects you want to mirror. Then you have to set the axis , by setting the first
point of mirror line and then the second. At this point you have to choose if the source ojects will be deleted or
not.

 

                                                    

Remarks

 

9.4.11 Array

Description

Creates multiple copies of objects in a pattern. 

There are the Rectangular Array and the Polar Array.

With the rectangular array you can create an array defined by a number of rows and columns of copies of the
selected object.
First you have to select  the objects.Then you have to define number of rows and number of columns of the
rectangle, the distance between rows and the distance between columns.
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With the Polar Array you can create an array by copying the selected objects around a center point.
First you have to select the objects.Then you have to set the center point and next you have to define the
numbers of the copy objects that will be created and the fill angle(if you put for example 360 then the object
will be created like in the below example). At the end you are prompt to choose if the object will be rotated or
not.

 

 

                                        

 

Remarks

9.4.12 Break

Description

With break command you can divide one object into two objects, or you can remove one part of it(this part will
be defined by two points that you have to pick).

First you have to select  the object.Then you have to define the first break point and the second break point.
When you pick this points , the part which is defined by the two points will be deleted from the object.

 

Remarks

The two points can be the same point. In this case you only explode the object into two other objects(for
example you can cut a line into two lines).

If break command runs over a circle , you have to set two different points in order to see a result because a
circle cannot break in one point. After break command the circle becomes arcs.

 

9.4.13 Scale

Description

With scale command you can increase or decrease the size of one or more objects.

First you have to select  one or more objects.Then you have to pick one point ,which is going to be the base
point. Next step is to specify the scale factor .

Remarks
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9.4.14 Explode

Description

With explode command you can break compound objects , like inserts  ,dimensions  ,polylines  etc into
their sub entities.

Remarks

Here are some objects that can be exploded:
vd3DFace explode to one vdPolyline

vdDimension explode to vdLines, vdText(s), and vdInserts (the arrows)

vdInsert explode to the entities that is consist of. (If there are Inserts inside Blocks then you may
need to apply more than 1 explode to get the simplies entities)

vdPolyface explode to vd3DFace(s)

vdPolyHatch explode to vdPolyline(s)

vdPolyline explode to vdLine(s) and/or vdArc(s)

vdRect explode to vdPolyline

vdText explode to vdPolylines(only texts with fontfile SHX).TTF(true type font) texts are not exploded

 

9.4.15 Purge

Description

With purge command you can reject some tables of the drawing like layers ,textstyles ,linetypes  etc
that you do not use in the drawing and you do not want anymore.

In purge command you have to specify what objects you want to delete(PurgeFlag). You can also see with
purge command which tables are not currently used in the drawing.

Remarks

PurgeFlag can be one of the following:
  ALL         Removes all unused named objects layers, textstyles, dimstyles, blocks and images.
  LAYERS      Removes all unused named layers
  TEXTSTYLES  Removes all unused named textstyles
  DIMSTYLES   Removes all unused named dimstyles
  BLOCKS      Removes all unused named blocks
  IMAGES      Removes all unused image information. 
  GETLAYERS        fills the return value with the array of all unused named layers (the objects still exist)
  GETTEXTSTYLES  fills the return value with the array of all unused named textstyles (the objects still exist)
  GETDIMSTYLES   fills the return value with the array of all unused named dimstyles (the objects still exist)
  GETBLOCKS      fills the return value with the array of all unused named blocks (the objects still exist)

 

9.4.16 Zoom

Description

Zoom command allows the user to increase or decrease the apparent size of objects , so the user can control
the part of the drawing that is included in the screen.

Zoom command is a transparent command.
Transparent commands are commands that can be invoked when another command is active.

Remarks

There are several ways to execute the zoom command:
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"E"(Extends) Zooms to display the drawing extents

"P"(Previous) Zooms to display the previous view

"W"(Window) Zooms to display an area specified by two opposite corners of a rectangular window. User must
specify these two corners.

"A"(All) zooms to the drawing limits or current extents, whichever is greater.

"S"(Scale) Zooms the display at a specified scale factor. For example, entering 2 doubles the apparent display
size of any objects from what it would be if you were zoomed to the limits of the drawing. Entering 0.5
causes each object to be displayed at half its current size on the screen.

 

9.4.17 Pan

Description

You can shift the location of your view by using

 pan or by using the window scroll bars. Like panning with a camera, pan does not change the location or
magnification of objects on your drawing; it changes only the view.

Pan command is a transparent command.
Transparent commands are commands that can be invoked when another command is active.

Remarks

 

9.4.18 View3D

Description

With View3D command you can change the current view of the drawing.

Remarks

The View3D function when is called it also changes the Current Coordinate System (CCS) to World Coordinate
System (WCS).

 

Arguments

Description Parameter

Sets the view point to top VTOP

Sets the view point to bottom VBOTTOM

Sets the view point to left VLEFT

Sets the view point to right VRIGHT

Sets the view point to front VFRONT

Sets the view point to back VBACK

Sets the view point to southwest isometric VISW

Sets the view point to southeast isometric VISE

Sets the view point to northeast isometric VINE

Sets the view point to northwest isometric VINW

Shades the objects between the polygon faces and displays materials if there are
attached on object colors else the result is the same like SHADE

RENDER

You can start a continuous motion with it , by rotating the coordinate system around X
(vertical motion dy) and/or around Y Axis (Horizontal motion dx)

VROT
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Shades the objects between the polygon faces and does not displays materials.
Coloring the objects surfaces with it's colors.

SHADE

Combines the SHADE and WIRE options SHADEON

Displays the objects using 3D wire frame representation and hides lines representing
back faces.

HIDE

Displays the objects using lines and curves to represent the boundaries. WIRE

Sets the view point to World system. VWORLD

Sets the view point to any angle. VPOINTANGLE

 

9.5 Limits

Description

While designing in paper user has a specific space to make the drawing , with CAD user can have unlimited
space to design the drawing.

The drawing limits are two-dimensional points in the world coordinate system that represent the lower-left and
upper-right boundaries. You cannot impose limits on the Z direction.

Remarks

When limits checking is turned on , the drawing limits restrict the coordinates  you can enter to within the
rectangular area. Drawing limits also determine the area of the drawing that can display grid dots, the area
displayed by one of the scale options of

 zoom, and the minimum area displayed by zoom all.

 

9.6 Coordinates

Description

Coordinates are being expressed in drawing units.Drawing units are not expressing particular units(meters,
inches etc).

In this part user have to make some assumptions in order to define that the coordinates of the drawing mean
particular units(meters,inches etc).

For example:

For a mechanichal drawing we can make the assumption for example:  where one drawing unit defines one
millimeter(1 D.U=1mm)

For a architectural/technical drawing we can make the assumption for example: where one drawing unit
defines one meter(1 D.U=1m)

This can be very helpfull in designing,dimensioning,retrieving informations from the drawing(distances,area
calculations)

 

Remarks
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9.7 Viewport

Description

Viewports are areas that display different views of your model. As you work, you can split the drawing area
into one or more adjacent rectangular views known as model viewports. In large or complex drawings,
displaying different views reduces the time needed to zoom or pan in a single view. Also, errors you might
miss in one view may be apparent into others.

ViewPorts are treated as rectangle drawing objects which display views and can be moved or resized.

They can be created only in entity list collection of a layout and not in Model.

With WireCAD 6.1 you can now attach viewports to closed polygons (polylines, circles, ellipses, rectangles). 

                            

Remarks

Those rectangles filled with the image of the model space objects in different scales depend from the ViewSize
and the ViewCenter property. This way in one paper you can print out diffent views (with differnt scales) of the
same drawing (Model Space) or parts of this drawing.

In viewports commands like Pan, Zoom and View3D of vdCommandAction objects can be applied, only when
Viewport is Active (See ActiveViewport property of Layout object) and SpaceMode property of vdLayout has
the value SPACEMODE_MODEL.
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9.8 Model Space Boundaries

It's a big model space in there. We can, if we are not careful, create a drawing that is so big that it can't be
effectively printed or plotted. In order to have some Idea of where the fences are WireCAD can place boundaries
in the model space. The boundary is created from the viewport. We use the text height as the terms for our
equation. We do this because a drawing is considered readable if we can read the text. If we can't read the text
the drawing becomes useless.

In the following example we have created a viewport in our ANSI_A layout that is attached to a closed polyline.
The polyline traces the page border that encroaches on the display space. We then create a boundary with our
parameters. The results look like this:

Layout with page border, and polygon viewport

The Boundary dialog
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The boundary is created and positioned against the viewport from which it is created at the scale defined by our
parameters

9.9 Grid

Description

The grid is a rectangular pattern of dots that extends over the area you specify as the drawing limits. Using the
grid is similar to placing a sheet of grid paper under a drawing. The grid helps you align objects and visualize
the distances between them.

The grid is not printed. If you zoom in or out of your drawing, you may need to adjust grid spacing to be more
appropriate for the new magnification.

Remarks

User can modify the x,y grid spacing(distance between the dots horizontally or vertically).\
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9.10 Snap

Description

Snap mode restricts the movement of the crosshairs to intervals that you define. When Snap mode is on, the
cursor seems to adhere, or "snap," to an invisible rectangular grid. Snap is useful for specifying precise points
with the arrow keys or the pointing device.

Remarks

User can modify the x,y snap spacing.

You can also set the base point of the snap.This point defines the bottom left point of the snap.

If you need to draw along a specific alignment or angle, you can change the snap angle. This rotation realigns
the crosshairs on the screen to match the new angle.

 

9.11 Ortho

Description

A setting that limits pointing device input to horizontal or vertical (relative to the current snap angle and the
user coordinate  system).

That means that if ortho mode is on and you want to draw for example one line , this line will be parallel to x
or y axis.

Remarks

 

9.12 Osnap

Description

An object snap(Osnap) mode specifies a snap point at an exact location on an object. osnap specifies running
object snap modes, which remain active until you turn them off.

Remarks

The snap point on an object can be:
Endpoint

Midpoint

Center

Insertion

Perpendicular

Nearest

Apparent Intersection 

Node (point)

Quadrant

Tangent

 Intersection (one point)
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9.13 Units

Description

You can specify the type of the current unit of measurement and the precision for the current units as also the
current angle format and the precision for the current angle display.

Remarks

Type of measurement can be:

    Scientific           1.6449E+001
    Decimal             16.4492
    Engineering        1' - 4.4492"
    Architectural      1' - 4  7/16"
    Fractional          16 7/16
    Windows desktop (It takes the settings of the regional settings)

Angle format can be:

    Decimal degrees
    Degrees/minutes/seconds
    Gradians
    Radians

 

9.14 Print

Description

By pressing the print preview button you can see the default Print Preview dialog of WireCAD.
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At the top right window you can set the margins either in millimeters or in inches.

Orientation can be change to landscape or portrait.

With Scale you can set the scale of the drawing in the print page. For example 1mm of the page will represent
0.35747 drawing units.

You can also turn B&W to on in order to print in black and white mode.

In print area you can either set extends to include the whole drawing or you can choose a window.

9.15 PDF Export

Description

By pressing the PDF Export button you can see the Print Preview dialog in PDF Export mode. Note the Print
button has been replaced by a Save button.
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9.16 Extrusion Vector

Description

The extrusion vector defines the plane that the object will be drawn and is always vertical in that plane.

                                        

Remarks

If the entity has thickness then the thickness follows extrusion vector direction.
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For example the default value of extrusion vector is (0,0,1) (the Z axis direction) if the object is drawn in the
XY plane.
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10 Customizing WireCAD (SDK)

WireCAD XLT and PRO provide access to the WireCAD Software Development Kit (SDK). With the WireCAD SDK
you can write code to customize WireCAD to fit your needs. A complete discussion of the WireCAD SDK is beyond
the scope of this manual. What follows is a brief outline of how easy it is to write WireCAD Plugins. The assumption
is that you have a basic understanding of  C# programming syntax and structure (the examples are in C# but you
may use and .NET programming language that you are comfortable with). If you do not understand it don't let that
deter you. It is really very easy to understand. Microsoft has tons of examples. Just get on the web. 

STUDY THE EXAMPLES in the \WireCAD shared\WireCAD SDK\Examples folder

If you have WireCAD SDK specific questions post them on the forum along with as must code as you can and an
explanation of what you are
trying to do. We will try to help. If you need more help or if you are developing a commercial plugin for WireCAD
you may want to consider
purchasing SDK assurance. Please call the office for more information. Please note that we cannot take phone
support calls for SDK issues unless you are an SDK assurance member. 

The first place to go with any programming effort is the ubiquitous "Hello World" example in the Basic folder.

NOTE: there are two types of WireCAD plugin. 
1. The automatically discovered (AD) plugin that loads silently 

and may or may not interact with the user.
2. Plugins that require a WireCAD .wpi manifest file that describes

where the plugin can be found, how to call it, what icon to display and on
which toolbar or menu, etc. Both plugins implement the WireCAD.IPlugin interface.

AD plugins are named YourPluginName.Plugin.Dll and are placed in the ..\WireCADx\bin folder. Standard WireCAD
plugins have no naming requirements but must be accompanied by a .wpi file in the ..\WireCADx\bin\plugins
folder.

To create a wpi file you can use the utility in Plugins>Plugin Manager [New PI Info]  

Take some time to read through the code. The interface is very simple, yet you can access most of the WireCAD
object model including drawing, data access, grids, GUI, reports, etc.

You can also create your own forms and functions to interact with the WireCAD objects.

//////////////////////////////////////////////////////////////////////////////
THIRD PARTY LIBRARIES
//////////////////////////////////////////////////////////////////////////////
WIRECAD USES THIRD PARTY LIBRARIES THAT MAY REQUIRE YOU TO PURCHASE DEVELOPER COPIES. PLEASE
DO NOT IGNORE THIS STATEMENT. THESE ARE GREAT LIBRARIES AND IF YOU ARE PLANNING TO DEVELOP A
COMMERCIAL PLUGIN FOR WIRECAD YOU WILL WANT TO HAVE THEM. If you are developing a small project or
line of business function for your own use you may not need to purchase licenses. Here is an example: If you want
your plugin to have the same look and feel, or create a custom form with the same gridview or treeview as
WireCAD you will need to purchase the Developer Express library. If you are developing a custom form that needs
to show its own drawing engine you will need to purchase the VectorDraw developer framework. If, on the other
hand, you are able to use the WireCAD baseforms object, are happy with the WinForms controls and can develop
using the WireCAD drawing engine then you can get started without spending a dime.  
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10.1 Hello World

Every programming effort starts with the ubiquitous "Hello World" example. This example is meant to provide just
enough information to show the framework and produce an output.

Please note that in C# comments are preceded by //.

//////////////////////////////////////////////////////////////////////

//WireCAD Plugin

//Contents:

// Basic WireCAD Plugin Framework

//

//Instructions:

// 1.This project assumes that you installed WireCAD in the default

// location. If you did not, you will need to change the reference

// path and the build path to that of your install path 

// ..\WireCADx\bin folder. You can do that byclicking:

// Project>Project Options [Reference Paths]  Reference path

// Project>Project Options [Compiling Tab] Output Path

// 3.Add your code and build

// 4.Create a wpi file (from within WireCAD click Plugins>Plugin Manager [New]) that points to your assembly and method and

// place it in the ..WireCADx\bin\plugins folder

//

//////////////////////////////////////////////////////////////////////

//Explanation:

//This heloworld example demonstrates a number of different WireCAD SDK

//concepts. This is WireCAD Automatically Discovered (AD) plugin and

//therefore does not require a .wpi file in the /plugins folder. As such,

//it will load silently and can only be executed from the commandline since

//it does not add any other GUI elements.

//

//TESTING:

//First familiarize yourself with the code below and try to understand

//what will happen before testing.

//1. Build the project and ensure that the helloworld.plugin.dll is located

// in the ..WireCADx\bin folder.

//2. if WireCAD is running click Plugins>Plugin Manager[Rescan and Load Plugins]

//3. Type hw into the WireCAD commandline.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows.Forms;

using VectorDraw.Professional.vdFigures;

using VectorDraw.Professional.vdObjects;

using WireCAD;

using WireCAD.Interfaces;

using WireCAD.Translation;

namespace hello_world

{

    public class MyPlugin: IPluginCore

    {

        #region Fields

//Place your field level variables here

       CommandInfo ci = null;

        #endregion
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#region Properties

//Place your Properties Here

       

        #endregion

        #region IPluginCore Members

        /// <summary>

        /// Called before plugin is loaded to make sure that this plugin

        /// has permission to run at this application mode level and

        /// for this person(Identity)

        /// </summary>

        /// <param name="ws">The Singleton Workspace object</param>

        /// <param name="id">Current user identity</param>

        /// <returns>should return true if the plug can load</returns>

        public bool HasPermissionToRun(IWorkspace ws, Identity id)

        {

            return true;

        }

        /// <summary>

        /// This is called when the plugin is loaded at application start

        /// </summary>

        /// <param name="ws">Singleton WireCAD Workspace object</param>

        public void Load(IWorkspace ws)

        {

        //We pass an IWorkspace object exposing most if the WireCAD

        //object model

        

        

            //on load we will register a commandInfo object with our

            //commands so that our static method can be invoked from 

            //the command line in WireCAD

            ci = new CommandInfo();

            //The name of our dll

            ci.Assembly = "helloworld.plugin.dll";

            //The NameSpace and Class of our function

            ci.NameSpaceAndClass = "hello_world.MyPlugin";

            //Our function's name

            ci.MethodName = "HelloWorld";

            //The long descriptive name of our function

            ci.CommandLongName = "Hello World Demo";

            //An alternative name for our function. You can type this text into the WireCAD command line

            //to call the function

            ci.CommandAlt = "hello";

 //The shortcut 

            ci.ShortCut = "hw";

            //this registers the command so that the commandline knows how to parse the information

            //and call our function

            ws.Commands.RegisterCommand(ci);

        }

        /// <summary>

        /// Unload code for your plugin

        /// </summary>

        /// <param name="ws"></param>

        public void Unload(IWorkspace ws)

        {

            //here we place any code to unload our plugin.
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            //Unregistering the commandInfo prohibits the command from

            //being persisted. This is more a development function.

            //once you are ready to distribute your plugin you will

            //probably want your user to be able to save his own shortcuts

            //and therefore not unregister the command.

            ws.Commands.UnRegisterCommand(ci);

        }

        #endregion

#region Static Methods

        /// <summary>

        /// Static method that can be called from the WireCAD command line

/// It's a good idea to rename this to something meaningful

        /// </summary>

        /// <param name="ws">WireCAD is expecting to find this parameter</param>

        public static void HelloWorld(Workspace ws)

        {

           //This hello world function demostrates a number of different 

           //areas of the WireCAD SDK

           

           //this is a winForms messagebox

           MessageBox.Show("Hello World");

           

           //now we'll show an instance of form1(defined elsewhere in this project);

           Form1 f = new Form1();

           f.ShowDialog();

           

           //now let's send a message to the Command Line History

           ws.MainForm.CommandLine.AppendHistory("Hello World");

           

           //let's check to make sure that we have an open drawing

           if(!Commands.IsActiveDrawing(ws,true))

           {

           //no active drawing so return

           return;

           }

           

           //Get some user input on the next step

           if(DialogResult.No == MessageBox.Show(

           "Would you like us to add some text to the active drawing?",

           "WireCAD SDK",MessageBoxButtons.YesNo)) return;

           

           //First we create a vdText object

           vdText text = new vdText();

           //register it with the active document

           text.SetUnRegisterDocument(ws.ActiveDrawing);

           //give it the document defaults

           text.setDocumentDefaults();

           //Set the string

           text.TextString = "hello world";

           //locate it in the coordinate space

           text.InsertionPoint = new VectorDraw.Geometry.gPoint(0,0,0);

           //Set the textHeight

           text.Height = .25;

           //Set the color

           vdColor colorRed = new vdColor();

           colorRed.SetUnRegisterDocument(ws.ActiveDrawing);

           colorRed.Palette = ws.ActiveDrawing.Palette;

           colorRed.FromRGB(255,0,0);

           

           text.PenColor = colorRed;



WireCAD v7 User Manual169

© 2013 Holbrook Enterprises, Inc. dba WireCAD

           

           //alternately you could do this

           //text.PenColor.ColorIndex = 1;

           

           

           //our text will be added to the drawing on the ActiveLayer and with 

           //the ActiveTextStyle if you want to change those you can by setting

           //those properties on the text object

           

           ws.ActiveDrawing.ActiveLayOut.Entities.AddItem(text);

           

           //now refresh the drawing

           ws.ActiveDrawing.Redraw(true);

     //alternately you can just invalidate the text object(less expensive)

     //like this:

     //text.Invalidate();

        }

#endregion

    }

}

10.2 Getting Started

Menu: Plugins>Plugin Manager[Edit Plugin Code]

Default command line shortcut: none

To get started writing plugins for WireCAD launch the #Develop (pronounced
sharp develop) development environment.

Applies To:
XLT PRO
Related Settings:
None

Click 
File>New>Solution
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Select WireCAD Plugin
and enter a Name and
solution path

Click [Create] and a new solution will be created for you with all the necessary references and interface files.
Now start coding!

To test your plugin make sure that is copied to the WireCAD\bin folder and that your .wpi  manifest file is in
the WireCAD\Bin\Plugins folder. 
Relaunch WireCAD or click [Rescan and Reload] from the WireCAD Plugin Manager to make WireCAD load
your plugin

171
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Debugging Your Code

To debug you will attach the #Develop debugger to the main WireCAD process by clicking Debug>Attach to
Process and select WireCAD from the list of running processes. You can place breakpoints by clicking on the left
edge of the edit space. 

When code is executing with the debugger attached and the breakpoint is hit code will stop executing and allow
you to examine variables. To continue execution use the Continue, or Step functions.

Happy coding!

10.3 Registering Your Plugin

Menu: Plugins>Plugin Manager[Add/Edit PI Info]

Default command line shortcut: none

Assuming your plugin requires user input to launch it, ie it does not respond
to an event. You will want to register your command with the application.

Applies To:
XLT PRO
Related Settings:
None

WireCAD uses an information file (wpi - WireCAD Plugin Info) to describe a command and to tell the application
how to execute the command. WireCAD looks for these files in the c:\program files\WireCAD\bin\plugins folder. 

Commands can be executed directly from the commandline or from a button on a menu bar. In order to register
your command you must, at minimum, set up the commandline arguments. Toolbar buttons are optional. To edit a
wpi file use the editor.

WPI File Editor
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Name

Self explanatory
Description
Author
Website
Copyright

Button Info

Tool Tip Tool tip text
Caption The button caption
Button Site What is the base location of the button
Button Path Button path is the path in the menu tree of the button. Start with Main Menu and work your way

down. If the menu tree does not exist it will be created. Use the & key to create accelerators. If
you are using an existing path be sure to include accelerators or you will end up creating a new
menu item.

Button Bitmap 16x16 bitmap

Command Line and Assembly Info

Long Name The display name of your command

Short Name The shortcut
Alt Shorter less descriptive
Assembly
Name

The name and path of your dll. If no path we will search the WireCAD\bin directory

Namespace
Dot Class

SomeNameSpace.MyClass where your function is located

Static Method
Name

The static void method name of your function. This must have the proper signature as follows:

public static void YourFunctionName(WorkSpace ws)

{

.....

}

Using the above example the Static Method Name would be: YourFunctionName

NOTE: if you use the WireCAD Plugin template  a static method with the proper signature will
be created for you.

170
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11 Using Your CAD Drawings With WireCAD

With WireCAD v7 you can now WireCADify your existing CAD blocks to include WireCAD intelligence; thus making
them work with WireCAD. Pretty cool huh?

The process requires at least two steps:
1. WireCADify the block.
2. Add ports to the block.
3. WireCADify any cables.

11.1 Customiztion Your CAD Blocks to Work with WireCAD

Menu: Advanced Tools>WireCADify>WireCADify Block

Default command line shortcut: wc

Requires an active drawing with a CAD block.

Adds the base WireCAD attribute set to the selected block, mapping your
attribute data into our attributes if you choose.

Applies To:
PRO, ENT
Related Settings:
None

How To

Step Explanation

1. Click Advanced
Tools>WireCADify>
WireCADify Block

You will be prompted to select a CAD block.

Here we have a CAD block with the displayed attributes (Yours).
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2. Select your CAD
block

It must be a block and not raw entities.

3. Map your attribute
to our attributes
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4. Select the
[Descriptor
Locations] button

Drag the elements to reposition
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5. Click [Ok] to do it.

Preview after repositioning

11.2 Adding a Port to an Existing CAD Block

Menu: Advanced Tools>WireCADify>Add Connection Point

Default command line shortcut: none

Requires an active drawing with a WireCAD block.

Adds the connection point to the selected block.

Applies To:
PRO, ENT
Related Settings:
None

How To

Step Explanation
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1. Click Advanced
Tools>WireCADify>
Add Connection
Point

You will be prompted to select a WireCAD block.

Here we have a WireCADified block
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2. You will be
prompted for the
point at which to add
the Connection Point

Here will will choose the arc quandrant
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3. Enter your port info
the in the dialog that
is presented

Here will will say that the port is an input called IN 10.
We will show the labels and include a small circle to snap to.

4. Click [OK] to
finish.
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The following index is generated from the online text and as
such the page numbers may represent a sub chapter
heading instead of the actual page.

The key word you are searching for will be in the sub
chapter.

A Note About the Index
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DimStyles     142
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Drawing Cables     29
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Explode     153
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Hello World     166
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How To: Create a new drawing using the wizard     28

How To: Create a New Project     27

How To: Create Your Own Custom Titleblocks     95
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Image     135

Include hashes     49

Inputs     47

Insert     138

Insertion Point     49, 53

Integrator     124

Introduction     120
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IsSequential     125

- L -
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Layers     139

Layouts     141

Length     124

License Agreement     14

Licensing FAQ     16

Lights     144

Limits     155

Line     130
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Linetypes     145

Lineweights     146

Location     125

location change     49

Location Filter     53

- M -
Manual Draw Cables     33

Manufacturer     125

Many-to-Many Cable     41

Many-to-One Cable     39

Maximum Column Count     53

minimum WireCAD build version     120

Mirror     151

Mirroring     122

More about Regular Expressions     89, 92

Move     150

Multicore     46, 124

- N -
NamedPath     124

New +     46

New Drawing     28

New Drawing Wizard     63

New Equipment     24

New Plugin Template     170

New Project     27

New Report with Wizard     76

- O -
Offset     148
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One-to-One Cable     29, 31
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Osnap     159

Outputs     47
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- P -
Pan     154

parameters     73
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Pinouts     107

Place Text If Item Cannot Be Created     49

Polyface     136
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Port Polling Status Bar     64

Preview     73, 122

Print     160

Print All     122
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Print This     122

Printer Options     122

PRO     10

Project Cables database     120

Project Settings Panel     67

Project Systems database     120
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ProjectRevision     124

P-touch     120

Purge     153

- R -
Rack Builder Controls     51

Rack Builder tool     49

RatsNest     52

Record Selectors     122

ReplacedBY     124

Report filtering     74

Reports     73

- S -
Scale     152

Section Clips     144

Select     147

Selected Format     87

Selections     144

SHEET     124

Show Cable Numbers     54

ShowDWGInPath     49

Signal Types to Display     53

SignalType     46, 124

Slot Count     49

Slot Delimiter     49

Snap     159

Software Activation     10

Software Key     12
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