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2 Introduction

= @

Welcome to WireCAD. WireCAD tools aim to decrease the
rustration  associated with  creating accurate, detailed
documentation. WireCAD produces DWG compatible drawings...
Welcome to WireCAD. WireCAD tools aim to decrease the frustration associated with creating
accurate, detailed documentation. WireCAD produces DWG compatible drawings accompanied by
either VISTADB or SQL Server databases containing all pertinent project data. WireCAD is a cable
management and facility design tool that allows you to easily create AutoCAD drawings. WireCAD
maintains a database of equipment, from which you can create equipment blocks for your drawings.
Equipment blocks are created dynamically from information stored in the equipment database.
Rather than maintaining a large library of equipment blocks or symbols, WireCAD stores this
information in a database and then creates blocks from the equipment definitions contained therein.
Equipment definitions are easily added to the database. In addition to equipment databases,
WireCAD also provides drawing tools to rapidly create documentation, and database management
tools to track:
eProjects
eDrawings
eRevisions
eCable Types
eSignal Types
eConnectors

Things really start to fly when it is time to assign System Names (unique IDs) and Cable Numbers
to the equipment in your drawing with our automated tools.
Extensive reporting is available for the project databases including:
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eCable run sheets

eCable labels

eProject drawings

eEquipment lists

oBill of Materials

ePower consumption and heat load

In addition, a powerful report designer is included with WireCAD for creating your own reports and
labels, or modifying existing report definition files.

2.1 New in Version 10

WireCAD v10.1 Changes

WireCAD v10.1 implements a number of security changes; most notably the change from VISTA
DB v3 to v6 databases. We did this to remain FIPS compliant. The switch from vdb3 to vdb6 files
is seamless with the only drawback being that you cannot use a WireCAD v10.1 project in any
earlier vesion of WireCAD.

We have added the teams.wirecad.com Teams portal with its accompanying Publish Project to
Portal tool. All current Assurance members have access to the portal where you can publish
projects and invite users to view/redline in any modern browser.Added the Publish Project to
Portal tool. You can find it at Projects>Publish Project to Portal. This tool prepares and
uploads the project to the new WireCAD Team Portal at:_https://teams.wirecad.com. Create your
account with your WireCAD v10 key with active Assurance. From the WireCAD Team Portal you
can share you project, its data and drawings with your team. Redline drawings, research and
visualize your project data.

WireCAD v10.1 adds project specific global databases. You can, if you choose, relate a global
database to a project. This is useful for those that are continually switching global databases to
satisfy customer requirements.

o Modified the Attribute Editor to allow modification of additional properties.

o Modified the SysName Assignment dialog to allow selecting of existing SysNames where the
make/model match or don't.

o Modified the Inputs/Outputs page of the Equipment Library to support forcing the selection to
the top or bottom.

o Added Advanced Tools>Equipment Functions>Next No edit to the drawing Ul to allow users to
quickly update the next number without having to open the Next Numbers grid.

o Added Advanced Tools>Cable Functions>Next No edit to the drawing Ul to allow users to
quickly update the next number without having to open the Next Numbers grid.

o Added Advanced Tools>Cable Functions>Show Port Info to allow users to interrogate port
information but clicking on the port.

o Modified the Rack Builder dialog to allow exclusion of Systems Involved by adding a checkbox
list.

o Modified messaging when a project folder structure is wrong.

o Improved messaging when pointer linking fails.
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o Modified the Total Edit Time display on the Start Page and the Project Info page to show the
Days, Hours, Minutes, Seconds, Total Hours, Total Minutes.

o Added Table of Contents generator. This can be found on the File menu of any active drawing.
This function generates a Table of Contents from the project Drawings table. This is a BETA
release of this plugin. This is available in PRO and up.

o Refactored the SysName Format dialog for better stability and usability.

o Refactored the Cable No Format dialog for better stability and usability.

o Added Signalize Group Markers property to the Equipment Library. This property sets whether
the Group Markers inherit the color of the pins or the pin names.

o Modified the My Manufacturers list to persist changes to the column structure.

o Reworked the Autoblock tool to align to the the block creation modes.

o Modified the Autoblock tool to use the new Appearance settings.

o Improvements in the Packup and Go function.

o Improvements in the Unpack function.

o Improvements in the Check In function.

o Added Default Single Line of Text Height property to the Drawing Settings. This reduces the
number of steps required to enter text in the drawing.

o Added Default MText Height property to the Drawing Settings. This reduces the number of
steps required to enter text in the drawing.

o Added the ability to better edit Plan View cables. Add, edit delete and update.

o Removed the Strict naming policy from the Edit Plan View Cables dialog.

o Added a link to the Show Me context menu in drawings that links to the Global Equipment
Library for that device.

o Modified the Dimension text height to honor the dwg file format Text Style text height. Removed
the Text Height property from the property grid as it is confusing.

o Migrated from VistaDB3 to VistaDB6 databases for speed and FIPS compliance. Please note
that the conversion process is automatic. Once you open a project or global database in
WireCAD 10.1 you will not be able to revert to WireCAD 10.

o Updated Ul components that work better with large displays.

o New drawing engine that opens large drawings.

o Added the ability to set the key on the Serial Keys page of the website to NEVERLOCK. In this
mode the key cannot be locked to a machine. Note: in this mode WireCAD requires an internet
connection to run.

o Added the ability for a key token to be assigned to a key for better user management. If
someone leaves the organization you just change and redistribute a new token.

o Added the ability to disable a Locked license. Note that this only works in WireCAD 10.1 and
forward.

o Faster paste operations.

o Implemented post clipboard paste operation to check for an relink pointer that are pasted from
another drawing. Works for both On sheet and Off sheet pointers, as well as Copy and Cut
operations.

o Added the ability to search grid columns from the Column Chooser.

o Modified the New Project Wizard project Description field to track the project Name field by
default.

o Modified the Equipment Library Appearance Settings to allow for custom settings to be saved
at the user and project levels. There are no more limits on the numbers of appearance settings
you can save. This modification removes existing appearance settings. You will need to remake
yours.

o Modified the ColorPicker in the property grid for the drawings and library to match elsewhere.

o Modified the Viewport Frozen Layers select dialog to hide frozen layers from the available
layers to select upon initial show of the dialog.
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o Modified the Drawing Properties grid to only show selections of 500 objects or less to optimize
speed. When a selection set of more than 500 objects is sent to the property grid a message is
displayed indicating that the selection set is too large.

o Modified to better support the 3DConnexion SuperMouse button events.

o Updated the New Report Wizard.

o Added filters to the Terminal placement tool panels.

o Added new location based cable run sheet report.

o Added new location based cable pull sheet with cable types and counts.

o Added Find field to Project Explorer.

o Added the ability to control from the Settings dialog whether the Folder Sync mechanism is
enabled for SQL projects.

o Added the ability to drag/drop move folders in the Project Explorer

SDK Changes

o Added new event to the Workspace - BeforeUpdateCableText which fires just before the cable
number text entities are to be updated handing off the Cables, Polyline, and DrawCablelnfo
objects for you to set the source and destination texts for the CableNo and the AuxText.

o You will need to recompile any custom plugins.

o Modified the constructors for GridFormBase and GridFormBaseEXxEXx to require that you pass
the Workspace to them. This is a breaking change for any of your code that calls these base
forms.

o Added a new Select Checked List dialog (frmSelectCheckedList) to the SDK.

o Added a new event: QuerySettingsPanels that is fired upon open of the Settings dialog to load
your setting panels that implement the 1SettingsPanel interface.

o Modified the EntitySpaces.VistadbProvider dll to support VistaDB 6. Removed the
AllowMediumTrust attribute. The assembly will now only allow FullTrust access.

WireCAD v10 Changes
Major Function Changes

eCompletely reworked the Equipment Library and the Library SDK.

sModified the Assign SysName dialog to clarify the different modes of operation.
eModified the Assign Cables dialog to clarify the different modes of operation.

eAdded support for ACAD 2018 drawings.

eAdded PDF Import to drawing function.

eDramatically decreased project load time.

eDramatically decreased drawing open/save time.

eDramatically improved full ripple times.

sFaster project switching.

eAdded swap Project Location Delimiter function. Allows you to change the LocationDelimiter
and ElevationSlotDelimiter variables mid project.

sModified the Equipment Library to provide port markers. We have provided 38 marker
variants and an SDK event to register your own through code.
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eModified the Equipment Library to include Bidirectional ports. If a port is marked as
Bidirectional it appears on both the Inputs and Outputs list but can be selected for inclusion in
the block from only one side or the other.

eAdded AutoWidth property to the display prefs of the Equipment Library.

eAdded support for grouped ports

eImplemented round-trip export-import on the project grids.

eImplemented round-trip export-import on the global grids.

eAdded Title Block Manager.

Minor Function Changes

sAdded Swap Pointer Function. Allows universal change of pointer style.

eAdded Swap Terminal Function. Allows universal change of terminal style.

eAdded setting to disable progress bar. This helps larger drawings load faster.

eAdded Arc Text tool.

eRemoved drawing rulers. This was done to stabilize some WIN10 installations that were not
displaying the ruler correctly and were throwing exceptions.

eAdded project drawing file system watchers for renaming and creating drawings in the active
project folder.

eAdded splitter bar to Project Systems Grid for better resizing.

eAdded the ability to create multiple new drawings from the New Drawing Wizard.

sModified the Crosshair setting to allow larger sized crosshairs.

¢The ModifiedByUser field is now honored in the Equipment Library.

eThe ModifiedBy field is now deprecated.

eRemoved support for Tags in user defined shapes.

eMoved the tool panel tabs to the left side and added a user setting to allow return to the
bottom position.

eModified the response to missing SysName to better guide the user.

eAdded Image field to global Connectors table.

So, let's get started!

Speed

As we mentioned, speed was the watchword for this effort. We have been working much closer to
the hardware to take full advantage of multi-core processors and parallel programming techniques
to increase the speed of many of the mundane and long playing operations. We now use all
processor cores as well as parallel programming techniques to increase program speed.
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Below are some of our benchmarks:

Operation v9 Execution Time v10 Execution Time
Demo Edit Suite Project Open |30 seconds 2.15 seconds
Edit_1_VID.DWG open 10+ seconds 3.8 seconds

Project Signal Types full ripple |3+ minutes 1.3 seconds

There are similar numbers on all of the ripple operations as well as the drawing save and application
close functions.

Equipment Library

We have completely redone the Equipment Library. Completely!

We have made the library faster to load and preview. All of the pertinent information is on the main
page. Select a Manufacturer and all of its equipment is shown along with the detail data for the
selected device.

We have increased access speed to the Community Library.
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Shapes

The Library now supports many more stock shapes and the ability to code your own in the SDK.
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Pin Types

The Library now supports many more pin types and the ability to code your own in the SDK.
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Port Markers

The Library now supports port markers and the ability to code your own in the SDK.
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Bidirectional Signal Types
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The Library now supports bidirectional signal types. A bidirectional signal type is one that might be
displayed on either side of a block depending on document flow.

The new bidirectional port flag is used to ensure that a port so flagged can only be selected once. If
it is selected on the input side it cannot be selected on the output side and vice versa.
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Port Grouping

The Library now supports port grouping. The groups have several properties that control their
appearance:

eInput/Output Enable Grouping

oInput/Output Group Spacing - the vertical distance between groups

o|nput/Output Group Port Name Concatenation Mode - controls the way the group name is
combined with the port name field to represent the combined information in the cables
database.

o|nput/Output Group Format String - if the Group Port Name Concatenation Mode =
UseFormatString then the format string will control the port name.

e|nput/Output Group Marker
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Port Adder Dialog

We have reworked the Port Adder dialog to support:
eBidirectional signal types
¢Grouping
eInput Pin Type selection
+Output Pin Type selection
eInput Port Marker Selection
oOQutput Port Marker Selection
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Tips

For feed-through connections of buldhead pansls st the input and output Name the s

Conscler naming patchbay ports A-# and B-# for the top and bottom rows

It doesn't matter whach sde you place & port on. You can always move it laber.

When sslecting the connector gender shways consider that WireCAD nesds the CABLE BND of the conmection, nat the dhassis sde,

Sacirecional signals will be added o both Inputs and Cutputs ksts with teh Bidrectional ag set ko True. This wil exdude acodental selection of mone that one port of the saeme nams,

Add to Which List: Port Name: ¥ | — Add Multiples:
Group: Bl Mol tple Ports

&) Irputs (Left Sade) Connecter (Cable End): W 4

Outputs (Right Sade) Signal Type: W4

Bath Inguit Ports

BrecioRs Input Pin Style: - R v

Erput Port Marker . Mone) e
Output Ports
E Finally Append Characters
Add Ports and Close Clase Apply

SysName Assignment Dialog

The new SysName Assignment Dialog clarifies the dialog mode via the use of a radio button
selection to determine user intent.

&1 Mew Sysname for 360 SYSTEMS-Image Server 2K » IEl

Select Existing

Alas SRR
Lacabon Leaton W |+ Bevaton Elevaton b
LUserl Uiser2
Liserd Liper4
1P Ackiress Subnet Mask
Poresr CorsumpBon S0 Porever Corsumpion Uit | Watks
WWeight £ &9 WWieight Linit Founds

endor 1 a v | Vendor 2 - v
Flags + BT -
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Cable Number Assignment Dialog

The new Cable Number Assignment Dialog clarifies the dialog mode via the use of a radio button
selection to determine user intent.

&l Edit Cable Data  IER
EDMON-02 10XL-01
B B
VID.1-LOOP V.l
EDMON-02 V-1012- QC SWR
ROOM 118337 ROOM 118,235
Action
v Mext Number
» Edit existing ru.rnbcr_' V-1012-

Salect Exxsting Avalable Add Multi-core Cables
CablaTypeMany w  CablaType W |
SignalType i w
HamedPath v Length 0w
Integrator
Usar ] Usarl
User3 Userd
Sheet MACHINE_ROOM.dwg
Vendor 1 v | Vendor 2 W
Cale tme= 00:00:00.0033597 Show Me Update Camosl

Round Trip Export/import

We have added the ability to export any grid to Excel then modify it in Excel and import the changes
back into WireCAD.

In order for this to work you must make sure to export the table's primary key field - usually
xoxGUID where xxxx is the name of the collection that is being exported.

Failing to export the primary key will disable round trip importation and the imported data will be
appended to the table.
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Pointers On Multi-relational Cables

Pointers can now be added to multi-relational cables. The following functions have been enabled:
sLink/Traverse. Double-click to link. [Ctr]Double-click to traverse. Just like a normal pointer.
sLink Selected Pointers. Link a group of pointers on/off sheet.
eAssign Cable Number. Just like any other cable, double-click the cable to assign.

The following functions have not yet been enabled:
eReverse linking to a flipped pointer.
eUsing a Many-to-One cable to a pointer then pointer to a One-to-Many will not
collapse/expand that number of records in the database automatically.

]
d

RN

i

Swap Pointers Function
We have added a long requested feature to allow you to change all pointers of a selected type to
that of another.

If you get into the project and decide that something about a pointer does not please your eye you
can now change it easily.

Simply select the pointer on the source side of the cable and launch the function. Then select the
replacement values. All pointers on and off sheet will be replaced and updated.
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This function will replace pointer sets in this and other drawings.

Select the _S and _D ponter to replace with.

This function works on-sheet and off-shest.

IF the other pointer s on another sheet, that dravang vl be cpened and the
pointer replaced

Don't forget to save all drawings when this is finished.

THIS CAN TAEE A WHILE. Be pabent.

Outgoing Ponter D WC3_Pointer D
Incceming Pointer _D b
Incoming Pointer S W

O Cancel

Swap Terminals Function

We have added a long requested feature to allow you to change all terminals of a selected type to
that of another.

If you get into the project and decide that something about a terminal does not please your eye you
can now change it easily.

Simply select the terminal and launch the function. Then select the replacement value. All terminal
on that sheet will be replaced and updated.

This funcion will replace TERMINALS - JACKS, JBOXES, ROUTERS.

It requires two varniables:

Select the cutgoing terminal. The suffix must match in order to be swapped.
Don't forget to save al drawings when this is finished.

THIS CAM TAXE A WHILE. Be patient.

Ouwbgoing Terminal | w3 _su_bn_d
Incoming Terminal w

Title Block Manager
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We have added a long requested feature to manage your title blocks throughout the project.

The information is common to all the drawings in the project. You can choose to have the title block
data updated manually or on drawing open.

Adding a title block to the tool enumerates the block's attributes, whereupon you assign project
variables to the attribute and set the update mode.

There are many project variables that you can assign to the attributes as well as a string constant
value.

In the example below we have assigned the some string constants to the Title1-3 attributes and
then assigned project variables to others.

i | Froject Title Mock Mansger - 0 X
Tisetdosck Manager
OO0 M = § & Hl
Addd Aerare Ecit Compuaryy  Bolit Ol Al Marusl Al Or Lidane AL brve
[reks [ [ ] D ey b
Page Borders Datn oy pdate
Page Borders Attributes
[weit7 ] Tag String atirbute Ve Siring Constant Lipcate Mode
¥ | Tite I Hone Manual
Tite 2 hone Manual
Titke 3 st Flarsl
Tithe o -] Parual
ione Parnal
Crawirgg & Mo Marual
Sheet Hone Planuasl
Chrageen 15 Hone PManual
Ohesckesd B Hene Manual
=i Manus
ISSLED | - Paral
DATE Mo Plarual
Hone PMarnal
155N 2 Hane il
DATE Hone Manusl
3 Hone: Manual
ISEUED 3 Hone Manual
DATE 3 o Plarual
4 e Parnsal
YL 4 thore Marual
4 Hone Manual
] Hone PManual
SELET Hone Manual
OATE 5 Hone Manual
Soale hong Panual

New Drawing Wizard
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We have added a long requested feature to allow multiple new drawings to be created from the New
Drawing Wizard.

& New Drawing * IEN
@ Mew Drawingls)
Mame the Drawing(s

Mames *| Draveing |
Draveing 2

Craving 3

Fobder™ | C:\Users \Publc \Doouments TWineCAD WireCAD 10/Demo Projects \Edit Suite Dems Praject Dravings ﬁ

et > Camced

2.2 Software Activation

Navigation: Introduction! ) >

WireCAD v10.1 offers 3 program levels with two licensing models:

XLT Perpetual License. This entry level license has several limitations but is a great place to start.
PRO Perpetual License.

PRO Subscription License. This license has a one year term with an expiration date.

CMS Perpetual License. CMS fiber management tools only support the perpetual license model.

WireCAD v10.1 includes server side license management tools that allow you to deactivate a key

from www.wirecad.com/serial _keys

From there you can:

e Deactivate a key.

o Set a flag that determines whether a key can lock to a machine or must float.

¢ Set a token on the key. Consider tokens to be like passwords only they are not encrypted or
restricted from view in the interface. These can be use to control who in your organization can
use a key. In other words, not only does the user need a key, they need the token as well in
order to activate. If someone leaves your organization with the key and you want to restrict their
usage, simply add/change the token and distribute the token to everyone else.

An activation key is all that is required to change program levels. If you have questions about the
licensing scheme click here! .

Floating Licenses| s1

Floating License Leases| s1
How Tol s
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Troubleshooting Activation[ s7

Activation

Integral to WireCAD is the ability to have a single authorization key activate multiple concurrent
machines if your organization has paid for more than one seat. By default, when you purchase a
seat of WireCAD your license count for your key will be set to 1 (one). Operational.

3?‘[ Zuul 2

Register | Advanced

Serial Key

Subscription Duration Licence Usage:

552 C Active on this machine until WireCAD is shut down. Requires internet
connection at startup and shutdown.

Subscription Expires On

remove any files it just let's the license server know that the key can be used

77?7 Active on this machine until you deactivate this copy. Deactivating does not
et elsewhere.

Activation Required

Status

Your trial expires: 2023-12-23

Continue ->

Software Activation control dialog

This will allow 1 (one) machine to be active at a time.
You may install WireCAD on any number of machines throughout your organization; However, only
one (or your license count) machine will be active at any given time.

Floating License Lease
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The mechanism by which we float licenses is the license lease. Leases can float or lock to a
machine.

In order to change the License Usage you must first Deactivate in order to make the switch
between Lock and Float.

NOTE: The point of contact on the account can determine whether the key is allowed to lock to a
machine from the www.wirecad.com/serial keys page.

H 7

Regster | Configure Prowy | Server Time Check

Serial ey

Adguraret Duraton Loere Usage:

YEARLY o

Actrop on thix machirg untl WireCAD & ghot down,

Faguines intemet connecton ot startup and shudgen
Expirea On T o0

Actve on s maching il you desctvate Sis copy.

SIBIEGED Deascireping doss not remgve any fles it st efs e

eree server imde T the key Oon be wge] detwhsre.

Regster by Web

% Aster Koy @ Limr Db phene “ 2y amer o creded

Tevers Mg

You have successfully deactivated this copy of WireCAD10. No files were
harmeed and WireCADAO is still installed on this machine. Hovever, you must
reacthvate It in order to run again.

Repater by Frane

Aobwate Dereite Esit WirelAD

Once activated the application operates until it is shut down whereupon it released the license(if
web connected); thus making the license available to another machine. Upon application startup the
license is validated and a lease is acquired automatically if web connected. If you cannot connect to
the web you will need to phone WireCAD support at:

1 661.253.4370 international.

1 866.273.5298 US and Canada toll free.

NOTE: Subscription keys must be activated via the web at least once per subscription
period and cannot be activated by phone.

1.Enter your authorization key (it's the really long one that ends in 10. If you fail to enter the key
correctly you will not be able to proceed.
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Submcriphion

Regster  Configure Prossy | Sarver Tirms (heck
Sarisl Ky

1234-1234-1234-1234-1234-1234-1234 L]

2.If you have successfully entered a valid key and you are web connected you will be able to
activate by web.

3.Select the Float/Lock mode and click [Activate/Deactivate]. If you are successful your screen
will look like this:

i T
Regmter Configure Proxy | Server Time Ched
Serial ey
Agsurares Duraten Literan Liaga:
YEARL“’ At o B machine Ll WireCAD i ghut dowr.
Riequines imfermet connection at startug snd shutdown
Expires On s
Actrve on this machine untl you deactvabe Tis oopy.
5;‘3}[‘2020 D Swintreg dors Fet Femgren oy Sk 1 et let's the
boenge server inow hat the key on be used deevwhere,
Regster by Vel
@ Adke Ky w At Cobadrgiben @ AoBeamah Contbded
Layront Mesgmaed

WireCAD10 is activated on this machine,

Regster by Prone

st aite De s mvate Cortrue

If you are not web connected you will need to call us at:

1 661.253.4370 international.

1 866.273.5298 US and Canada toll free.

If no connection is available you will see the dialog configured like this:
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& subscription z

Regster | ConfigureProay | Server Time Chede

Sl Wy

o v e - -
5/8/2019

Ringieter bry Phore
W cannot conndct 10 the hoense sena, please call | [(856) 273-5286 or 1 (561) 2534370
[rthinaticngd) of @mal fupsortBwingcad. i with poer Ky ad Unigue Maching 10, We will dend
vou and Actsvation Code. Enber the value in the box bedow and dick Contine.

Ths Machine's Ursaue 1D (pravie i 18 us) Aermrvaben Cinde B enided by us)

0120-7133

(==

Call the number above. We will need the Machine ID and will read you back an activation code that

you will enter in the box.
Then click the [Continue] button.

You will receive a message box indicating the success of the activation.

The following are a few reasons your activation by web will fail:

1.Not connected

2.Lease already in use by another machine

3.Authorization key abuse

4. Authorization key not found in the database

5.Your machine Date/Time is more than twenty four hours out of sync with our web server (UTC).
6.License count exceeded.

7.Subscription expired (Applies only to subscription keys).

8.Incorrect Token (if set by POC on the key in the web interface).

The following are a few reasons your activation by phone will fail:
1.You have provided an incorrect Machine ID.

2.The WireCAD technician has entered an incorrect value.

3.You have entered an incorrect value in the activation field.
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2.3 License Agreement

Navigation: Introduction| 1>

License Agreement

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE
OPENING

THIS PACKAGE AND/OR BY USING THE SOFTWARE. OPENING THIS PACKAGE OR USING
THE

SOFTWARE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU
DO

NOT AGREE WITH THEM, YOU SHOULD PROMPTLY RETURN THE PACKAGE TO THE
LOCATION

WHERE YOU PURCHASED THE SOFTWARE, UNOPENED WITH PROOF OF PURCHASE,

AND YOUR MONEY WILL BE REFUNDED.

Holbrook Enterprises, Inc. provides this program and licenses its use.
Holbrook Enterprises, Inc. retains the ownership of this product.

LICENSE

Permitted Uses/You May:

* Use the software on any computer provided the software is used on only one
computer and by one user at a time.

* Copy the program into any machine readable or printed form for backup or
modification purposes in support of your use of the program on a single
machine.

Prohibited Uses/You May not:

* Make copies of the documentation or software, except as noted above.
* Distribute, rent, sub-license, transfer, or lease the software or
documentation.

* Alter, modify or adapt the software or documentation, including, but not
limited to, translating, decompiling, disassembling, or creating derivative
works.

This license and your right to use the software automatically terminate if
you fail to comply with the provisions of this License Agreement.

TERM

The license is effective until terminated. You may terminate it at any other
time by destroying the program together with all copies, modifications and
merged portions in any form. It will also terminate upon conditions set

forth elsewhere in this Agreement or if you fail to comply with any term or
condition of this Agreement. You agree upon such termination to destroy the
program together with all copies, modifications and merged portions in any
form.

IF YOU TRANSFER POSSESSION OF ANY COPY, MODIFICATION OR MERGED PORTION OF
THE PROGRAM TO ANOTHER PARTY, YOUR LICENSE IS AUTOMATICALLY TERMINATED.

TRADE SECRET

You acknowledge that the software constitutes valuable trade secret
information that is the exclusive property of Holbrook Enterprises, Inc..
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Automatic Updates
Holbrook Enterprises, Inc. may periodically check the web for updates.
No personal information will be transferred.

LIMITED WARRANTY

Holbrook Enterprises, Inc. warrants for a period of 30 days from the date of
original delivery to you that the program will substantially conform to the
published specifications and to the documentation, provided that it is used
on the computer hardware and with the operating system for which it was
designed. Holbrook Enterprises, Inc. warrants the diskette(s) on which the
program is furnished, to be free from defects in materials and workmanship
under normal use for a period of ninety (90) days from the date of delivery
to you as evidenced by a copy of your receipt. This warranty gives you
specific legal rights. You may have other rights that vary from state to state.

DURING THE WARRANTY PERIOD, IF THE SOFTWARE DOES NOT PERFORM AS
WARRANTED,

YOUR EXCLUSIVE REMEDY SHALL BE TO SEND THE SOFTWARE TO HOLBROOK
ENTERPRISES, INC.

WHICH SHALL, AT ITS OPTION, EITHER REFUND TO YOU THE PRICE PAID OR REPAIR OR
REPLACE THE SOFTWARE.

To the extent permitted by applicable law, Holbrook Enterprises, Inc.
disclaims all other warranties, either or implied, including, buy not
limited to, warranties of merchant ability and fitness for a particular
purpose. Holbrook Enterprises, Inc. makes no warranty as to title.
No Holbrook Enterprises, Inc. dealer, distributor, agent, or employee
is authorized to make any modification or addition to this warranty.

LIMITATION OF LIABILITY

Because programs are inherently complex and may not be completely free of

errors, you are advised to validate your work. TO THE EXTENT PERMITTED BY

APPLICABLE LAW, IN NO EVENT WILL HOLBROOK ENTERPRISES, INC. OR ANY OF ITS
PRINCIPALS OR AGENTS BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES WHATSOEVER ARISING OUT OF THE USE OF OR INABILITY TO
USE THE PROGRAM OR DOCUMENTATION, even if advised of the possibility of such

damages. Specifically, Holbrook Enterprises, Inc. is not responsible for any

costs or damages including, but not limited to, those incurred as a result of

lost profits or revenue, loss of use of the computer program, loss of data,

the costs of recovering such programs or data, the cost of any substitute program,

claims by third parties, or for other similar costs. IN NO CASE WHATSOEVER SHALL

HOLBROOK ENTERPRISES, INC.'S LIABILITY EXCEED THE PRICE PAID FOR THE LICENSE
TO

USE THE SOFTWARE.

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY
FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION OR
EXCLUSION MAY NOT APPLY TO YOU.

Should you have any questions concerning this Agreement, you may contact
Holbrook Enterprises, Inc. by writing to:

Holbrook Enterprises, Inc.

1112 6th Street South
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Nampa, ID 83651

(866) 273-5298 U.S. and Canada

(661) 253-4370 International

support@wirecad.com

You acknowledge that you have read this agreement, understand it and agree to be
bound by its terms and conditions. You further agree that it is the complete and
exclusive statement of the agreement between us which supersedes any proposal or
prior agreement, oral or written, and any other communications between us relating
to the subject matter of this agreement.

2.4 Licensing FAQ

Navigation: Introduction| 1>

The following are some frequently asked questions about the WireCAD licensing scheme.

Q: Does WireCAD support floating licenses?
A: Yes, if you choose to use the function it is
built in to both PRO and CMS and for
subscription keys. You may disable this
feature by selecting the Lock option on the
License Usage section at activation time.
Choosing to do so limits that Authorization
Key to that machine only.

Q: How many machines can | install WireCAD on?

A: You may install WireCAD on any number of
machines. You will only be able to launch
WireCAD on as many machines as your license
count supports. The default license count is 1.
If you wish to purchase additional licenses
you may want to consult with your WireCAD
sales professional who will help you decide
the best course of action.

Q: | have a laptop and a desktop WireCAD used to let me install on both. How come | have to
choose?

A: You don't. WireCAD will still install on both.

It will only run on one at a time.

Q: What happens if my machine dies?
A: If your machine dies and you are using the
floating license scheme, one of two things will
happen:

1. Install WireCAD on the new machine an
wait for your lease to expire in what ever
lease expiration period you selected (not
optimum, but serviceable).

2. Log in to www.wirecad.com/serial keys
and deactivate the lease for the machine that
is dead.
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Q: | am not connected to the internet very often, can | still use the floating license scheme?
A: We recommend that you use the floating
license scheme only if you are regularly
connected to the web.

Q: | am going on-site. How do | ensure that my copy of WireCAD will stay active while | am
disconnected from the web?

A:If you have already activated WireCAD in

Float mode the click the

[Activate/Deactivate] button and proceed to

deactivate. Then set the License Usage to

Lock and Activate.

Q: What are the benefits of the Assurance Subscription?
A: A current Assurance subscription gives you
the following premium benefits:

Free major and minor version upgrades and
hot-fixes.

ePriority technical support.

eNew samples, tips and how-to topics from
time-to-time.

eDiscounts on training.
eAccess to beta products.

eAssurance Price Lock guarantees that your
annual Assurance rate will not increase year-
to-year as long as you remain current.

Q: Does the license expire if the Assurance Subscription expires?
A: Depends. If you have been issued a
perpetual key, your license does not expire
even if your Assurance expires. You can use
the products indefinitely even after the
Assurance subscription expires.

Q: How long does my Assurance Subscription remain valid?
A:Your subscription duration is for 1 year from date of purchase or renewal.

Q: My Assurance Subscription is about to expire. What should | do?

A:You must renew your subscription to continue to receive the latest versions for free
along with all the other benefits of the subscription. To renew your Assurance, contact
sales@wirecad.com.

Note that you may or may not receive notifications from Holbrook Enterprises, Inc. dba WireCAD
about the pending expiration of your subscription. It is your responsibility to renew your subscription
when it is about to expire. You can renew your subscription as early as you want or opt for a
monthly credit card payment.
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2.5

2.5.1

Q: When can | renew my subscription?

A:You must renew your subscription before the expiration of your current subscription
You can renew your subscription anytime before your current subscription has expired;
you will not lose any days as the new subscription will come into effect on the day your
current subscription ends. In effect, your current subscription will be extended by 1
year.

If you do not renew your subscription before
the expiry of your current subscription, your
subscription is considered as lapsed and you
will not be eligible for free upgrades and
other benefits anymore.

Q: My Assurance subscription has lapsed. How can | get the latest version?
A:Maintaining your Assurance subscription and renewing your subscription
each year to keep it current is the best and the most cost-effective way to
receive all new major and minor versions as they are released. In case
your subscription has lapsed and you want to upgrade to the latest version
you may simply renew your Assurance subscription at the current rates.

Q: Do you offer academic discounts?

A: We do have academic discounts if WireCAD will be used for education/research
purposes. Please contact sales@wirecad.com for more information.

Context Sensitive Help

Navigation: [ntroduction| 1>

WireCAD v10 is tightly coupled to the help file.

When you first start WireCAD we enable Beginner Mode. In this mode your moves are reflected
in the help system. As you launch functions the help system will display context sensitive

help for forms and dialogs.

You can enable/disable Beginner Mode from:

Application Menu>Settings... [User][Expert Mode]

You can get context sensitive help in the following ways from within the application:

Dialog Based Help

Navigation: Introduction[ &> Context Sensitive Help[ «3 >

Each dialog in WireCAD v10 has a ? in the upper right-hand corner.
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2.5.2 Form Based Help

Navigation: Introduction[ &> Context Sensitive Help[ + >

To display context help for the active form click F1 or the Help menu item
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2.5.3  Tool Panel Based Help

Navigation: Introduction[ &> Context Sensitive Help| +1 >

The same follows for tool panels. Click the ? icon to show a help topic specific to that tool panel.
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2.5.4  Settings Panel Based Help

Navigation: Introduction[ &> Context Sensitive Help| +1 >

When the Settings dialog is shown you can get help for each panel by clicking the [Help] button.
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Clicking the help button will show context specific help for the current settings panel.

In the case below we see the help for the [User][Basic] panel.
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These are settings for your user profile on this machine.

Basic Panel Options

+ Open New Drawing Upon Application Startup - Opens a blank new drawing when
WireCAD starts.

+ Use the New Drawing Wizard - Shows the New Drawing Wizard when you click File
= New. Allows the use of template drawings. If set to false, just creates a new drawing
without a template.

» Open My Last Project When | Start WireCAD - Behaves like earlier versions of
WireCAD that opened the last project automatically on startup.

+ Show Library Tips - This shows the Tips and Tricks form in frant of the Equipment
Library.

+ Show the WireCAD Startup Page

+ Warn of Signal Type Mismatch - When you finish drawing a cable WireCAD will check
the source and destination port signal types and let you know if they don't match. You can
use the new status panel to know the port type if you are confused.
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3 WireCAD PRO Manual

3.1 Getting Started
Navigation: WireCAD PRO Manual[ ) >
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3.1.1 Grid Basics

Navigation: WireCAD PRO Manuall 8 > Getting Started| +1>
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Menu: various
Default command line shortcut: various

WireCAD displays data from the various databases in grid form. WireCAD grids support the
following:

eSearching

eSorting

eColumn re-ordering

eColumn hiding/showing

eColumn grouping

eColumn resizing

eColumn filtering

oCopy Selection Down

eIncrement Selection Down

eHierarchical display

eExport to PDF, EXCEL, TXT, HTML, XML and more In addition, several grids support WireCAD
Visualization Tools.

eExpression Execution.
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ordered)

Record
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Grid Parts

3.1.1.1 How To: Grid Functions
Navigation: WireCAD PRO Manuall +$) > Getting Started| «51 > Grid Basics| 41>

oGrid Searching - Enter your search text in the Search box and click [Search]. WireCAD will
search all fields in the table for the search term. The % character is the wild card.
eSort - Clicking on a column header will cause a sort. Clicking it again will reverse the sort order.
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eColumn re-ordering/resizing - Drag a column from its center to initiate a move. Drop it where
you want it to display. To resize a column, drag its edge left or right.

eColumn hiding/showing - To hide a column: right-click the column header and choose [Remove
this Column] from the context menu.

To show a column:

1.Right-click any column header

2.Click the [Column Chooser] context menu item

Ag *
AppID

CreatedOn

DateAdded

DateModified

DBRef

Entity Type =

The Customization form displays hidden column headers
3.Drag the column header you wish to display and drop it on the header bar with the other column
headers.
eColumn grouping - If the grid supports grouping the grid will display a GroupBy panel at the top
indicating that column headers may be dropped there to group.

Search:
Manufacturer &
— Eguipmenthame a
Sysname 4 Available Location Elevation Alias Flags
7 (=]
¥ Manufacturer: 360 SYSTEMS
] ¥ Equipmentlame: Image Server 2K
@ SRVR-001 O Location Elevation SRVR-001
@B SRVR-002 O RE-003 10 SRVR-002

» Manufacturer: ACCOM
F Manufacturer: ADC

Grid grouped by Manufacturer and EquipmentName fields
To un-group simply drag the column header back to the header bar.

eColumn filtering - Columns may be filtered in one of three ways:

1.Click the column header filter icon on the column header. You will be presented with a list of
unique values found in that column.
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2.Click the (Custom) menu item presented in the column filter list.

GEMERIC EQUIPMENT
GRASS VALLEY
WManufacturerflams
PESA

SIOMY

WORLER

r

PR RS TN

Shew rows where:
Manufacturer

Equals
®and Oox

Cancel

3.1f the grid supports it, a filter pane will appear as the top row of the grid. Entering filter criteria in

the desired column will cause filtering.

oClearing Filter Criteria - If a filter has been applied to a grid, a filter panel will display on the grid
in the lower left hand corner.
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You may clear the filter by closing [X] the filter panel.

X ¥ Manufacturer] =350 SYSTEMS' +

«Copy Selection Down - If the grid supports it you will be able to copy the top item in a selection
down into all of the selected cells below it. Follow these steps:

1.Create your selection

2.Click Edit>Copy Selection Down or press [CtriI]+[D] on your keyboard.

3.Be sure to click File>Save to commit your changes to the database.

eIncrement Selection Down - If the grid supports it you will be able to increment the top item in a
selection down into all of the selected cells below it. Follow these steps:

1.Create your selection

2.Click Edit>Increment Selection Down or press [CtrI]+[I] on your keyboard.

3.Be sure to click File>Save to commit your changes to the database.

eDeleting Cell Data - To delete the contents of the selected cells simply click the [Del] key on your
keyboard.

eDeleting Selected Rows - To remove the rows from the grid:

1.Select the rows to delete by clicking on the Record Selector (left-most column without data).
2.Click Edit>Delete Selected Rows or click [Ctri]+[Del] on your keyboard.

3.Be sure to click File>Save to commit your changes to the database.

eDisplay Hierarchical Detail Data - If the grid supports it and there is detail data to display you
can click the [+] button in the left-most row.
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esExport - Click File>Export>[File Type]. WireCAD will then export the data with your current
grouping, sorting, and filtering applied to the selected format.

eExecute Expression - Manipulate data using the expression engine:
1.0Open the grid on which you want to manipulate or transform data.
2.Click [Function] button to show the Expression Builder.

® + .
Esgresson | Te Steedn

Fraiotype -
[ agreamon
(1=1) then set propertylame = value else propertyllame = otherValue

Aoy i Test Diect

3.Enter an expression to evaluate. You can test it against a prototype Test Object on which you can
set the data before testing.
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4.0Once happy with the expression click [OK] to execute the expression against the grid data.

3.1.1.2 How To: Round Trip Export/Imprt on all Grids
Navigation: WireCAD PRO Manuall «\ > Getting Started| «1 > Grid Basics| +1 >

All project and global database grids support the concept that they can be exported to Excel and re-
imported into WireCAD.

Users can do a blind import of data ignoring the data that is already in place, or you can do a round
trip export/import process.

If the user is using the round trip process the user MUST export the table's GUID (Global Unique
Identifier) so that there is a database reference.

After making changes to the project data, the user can ripple the changes across the project.

Here is the model that you should follow when using the Round Trip Export/Import function:

Show
the GUID
column

Import Modify
back to datain
WireCAD Excel

To perform the round trip export/import:

1. Open the grid that you would like to export.
2. In the File menu, Click the [Export] drop-down, and select [To XLS]
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3. Open your Excel file and make a change. Here, we will make a change in the Building field. Save
your changes.
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5. Once done, you'll get a notification regarding things that may or may not have gone wrong.
6. Ripple your changes across the project.

3.1.2  Setting Up Your Global Data
Navigation: WireCAD PRO Manuall «6) > Getting Started|[ «1>

Menu: Several
Default command line shortcut: le

WireCAD maintains a global database with tables representing Manufacturers, Equipment, Signal
Types, Connectors, Etc.

Getting started with WireCAD entails setting up the global databases to fit your needs. While the
database is populated with data you may find that it suits your needs to purge the data and start
fresh. If this is the case we can provide empty databases. At the very least you will want to set up
the Signal Types grid with your defaults.

Next you will customize the Equipment Library with the products and IO that you use. In order to do
this,%%u may either download existing products from the WireCAD Community Server or enter your
own| es,

Structure:

oManufacturers - The topmost table in the hierarchy
oEquipment - The Equipment description

olnputs - inputs of a device

oOutputs - outputs of a device

oSignal Types - signal types and a bunch of defaults.
oConnectors - connector types.

oPinouts - pin out definitions (data).

oColor Codes - color code look-up. Used by Cable Types.
oCable Types - cable type information.

oCable Cores - cores or conductor data for a cable type.
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Global Equipment Library Schema (abrv)
3.1.2.1 Signal Types

Navigation: WireCAD PRO Manuall «) > Getting Started|[ «1> Setting Up Your Global Datal ss1 >

Menu: Database > Default Signal Types
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Menu: Database > Project Signal Types

Default command line shortcut: st

Default command line shortcut: ShowProjectSignalTypesGrid
Related Settings:

None

The Signal Types grids contain many defaults:
ePen Color

elLine Type

eLayer mapping

eCable Type Manufacturer

eCable Type

eCable Number Prefix

We cannot stress the importance of this data collection. You should probably start here and define
your defaults.

There are two Signal Types collections:
1.Default Signal Types is contained in the Global Database.
2.The Project Signal Types grid is generated dynamically as you go.

WireCAD first looks to the Project Signal Types collection for information. If not found the Default
Signal Types collection is queried. If found the Project Signal Types collection is updated with the
defaults and the Project Signal Types collection is returned to the requesting function.

3.1.2.2 Cable Types
Navigation: WireCAD PRO Manuall +8 > Getting Started[ +81 > Setting Up Your Global Datal s >

Menu: Database > Cable Types.

Default command line shortcut: ShowCableTypesGrid
Related Settings:

None

This look-up grid contains the global list of Cable Types.
The list is hierarchical and shows the relation of a Cable Type to its Conductors Collection.
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3.1.2.2.1 How To: Create a New Cable Type

Cable Types| 601>

Navigation: WireCAD PRO Manuall «) > Getting Started| «81 > Setting Up Your Global Datal s >

1.Click Database > Cable Types.

2.Click File > New.
Himpa Cabie Type

File

<48 -

Mamfactuer 1D

CumcTIpROn

Cable Chawr 7

Cable Sasage

bl Vgt

i cla: Dodtiguriion

Treriding

= [y Bl Core

Coler Ciade Apel Tex

Canductors

Ielessiticr

= Cabs Tyt ar P8

(= s
Cabhe Fabing

= Fancderdiangth

Conductor Caunt Encluding sl
Dfmadt Core b Mock:

3.Fill in all information about this cable including Manufacturer, Cable Type or P/N & Description. If
you are working in the CMS tools you will need to define multi-core core configuration.
My b Type

File

<@ -

Marutucmaer 0 WIST P
emcripfon Tesd
by Thawr 3
Cabie Sasage
Cable Wit

e fondector Costiguriton

Freriing = buBu Cone

Coles Code Apphin Tec

Canducton

Infe=saten

= Otk Typeeor P Tt

g O

(Catie Rating

o Sesraierd Langih

Corshictor Count Incisiing Shslei(s]

Deefpuit Core Fiber Mo

x

4. If this cable is a multi core cable, you will need to check the Is Multi Core checkbox and set how
many cores are in this cable.
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5.Select the Default Core\Fiber Mode. To label specific cores as SM or MM, see step 8.
6.Click File > Save.
3.1.2.3 How To: Open the Equipment Library

Navigation: WireCAD PRO Manuall 1 > Getting Started| «1 > Setting Up Your Global Datal =51 >

The Project Explorer

The Project Explorer allows access to some of the global data grids.
You can also access all of the these grids from the Database menu.

Project Explor

o %
= (5 'E".ui iE
ftem ' .

ﬁ Equipment Library. ..

=7 Cable Types
1T Connectors
7 Permissions
LT Color Codes
¥+ | Projects

r My First Froject In House Tiraini

|, Project Databases

-I7 Equipment List (Sysham
s & Syshame Format
—I7 Cables

.-
Project Explorer Showing Equipment Library Access

Menu Commands to Access The Equipment Library
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eDatabase>Equipment Library
e\With an active drawing the Equipment Library can also be opened from: Advanced Tools>Equipment Library
eCommandline shortcut: e

3.1.3  Equipment Library
Navigation: WireCAD PRO Manuall « > Getting Started| «1>

Menu: Database>Equipment Library
Menu: Advanced Tools>Equipment Library
Default command line shortcut: LE

The WireCAD Equipment Library is where you will spend a fair amount of time as you get define
equipment that you will use in your designs. This is also where we come to create CAD blocks in
our drawings. There are many settings here that let you customize appearance. This chapter is the
basics.

Main Library Dialogue

This is where you can find all of the information about a selected device with the exception of input
and output information.

Find equipment definitions in the global database or the Community Server. To use a piece of
equipment from the Community Library, download it to your local database. Map your signal types
from the ones the device creator used.

Preview the block before adding[ ) to drawing.

ror Han e

-,

St L

—

o L o -
= = d -
P T
# 2 e
i =3
H
Bty b
[T o o
-

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

3.1.3.1 1/0Tab
Navigation: WireCAD PRO Manuall +$\ > Getting Started| «51 > Equipment Library| «5 >

The Inputs/Outputs tab allows for:

eThe ability to change pin type

eUsers to group ports

eUsers to mark ports to allow you to better present or clarify a design

eUsers to create bidirectional signal types. If you are not sure which ide to place a prot, you can
add a bidirectional port and it will display on inputs and outputs, but you can only use it as one or
the other.
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Related Topics:
How To: Add Some Inputs and Outputs| s

3.1.4 Display Preferences Tab
Navigation: WireCAD PRO Manuall «) > Getting Started| «1>

Controls the appearance of the created block.

You can indicate whether or not your port groups are displayed and how the group and port names
are concatenated together.

The Display Preferences tab allow you to control the display or groups.

The Equipment Library holds a variety of block shapes to choose from. The width of your block is
based on the text size.

Users are able to use the Appearance Settings ribbon menu to customize the appearance of
projects, use the default settings, or use settings previously saved in WireCAD.
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Related Topics:
How To: Add Equipment to Drawings| 31

3.1.5 Creating a New Equipment Definition

Navigation: WireCAD PRO Manuall «6) > Getting Started|[ «1>

Menu: Database>Equipment Library[Add Equipment to Library]
Default command line shortcut: le

Equipment definitions are at the heart of WireCAD. They describe equipment down to the 1/0.
Create a new equipment definition from which to create functional blocks, rack panels, etc.

3.1.5.1 How To: Add Equipment to the Library

Navigation: WireCAD PRO Manuall +) > Getting Started[ «1 > Creating a New Equipment
Definition| ss1>

1.Click Database>Equipment Library
2.Click [Add Equipment to Library]
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3.Select or add a Manufacturer.

Mew Equipment

Who Makes It and What's it Called

Manufacturer™
EquipmentiMameModel Part Mumber*
Description™

SysMame Prefix™

* = Required

4.Enter model/pn/name, description, etc.
5.Click [Next >]
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There is always some confusion about the SysName Prefix (Equipment
Type) field. Consider the following:

We have two types of video server -model A and model B - that use
similar wiring. We may consider using the SysName Prefix - SRVR.
Anytime we create an instance of one of these we they will be SRVR-
01, SRVR-02, and SRVR-On. Now consider that model A is not
available to use and that we have to install model b instead. No
problem. Because they "harness" is named SRVR-n we can
interchange Make and Model as needed.

6.This page is optional, but we recommend filling in the Front Panel File field.
7.

%1 New Equipment 2 IEH

© Mew Equipment

Completing the wizard

Front Panel File

Flan View File

Image Mo image data
Categories

Synonyms

Abbreviation Accessory Of

Cancel
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id
g '_,

=== Filling in the Front Panel File field will make the Rack Builder tool
work. Leave it empty and you may be frustrated later.

-
‘

W N

8.Click [Next >] to add the new definition.
The wizard completes and you are taken to the Equipment Library to edit the newly added
equipment definition.

3.1.5.2 How To: Add Some Inputs and Outputs

Navigation: WireCAD PRO Manuall +) > Getting Started[ 1 > Creating a New Equipment
Definition| es1 >

1.0pen the Equipment Library.

2.Find an equipment definition to which we will add ports.

3.Select the 1/0 tab.

4.Click [Add Ports] button.

5.Enter a port name, connector, signal type.

6.Select Inputs, Outputs table or Both.

7.Click [Add Ports and Close] or [Apply] (if you want to leave the form open).
Your port(s) will be added to the selected list(s):
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8.Add a single port to the Inputs and Outputs list at the same time.
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9.Add 10 ports to each grid appending a port number to each record.

- z
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10.Now let's create the 8 left line inputs of a stereo mixer. We will use the Finally Append
Characters field to append the characters -verr after the number is created and appended to the

Port Name.

5 Add Ports : IEE

Tgn
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Try adding multiple ports. Enter "PORT-" (leave off the quotes).
Select any Connector and Signal Type. Select the BOTH radio
button to add to both lists. Now Check the Add Multiple Ports box
and enter a Count of 8. Click [Add Ports and Close]. See below.

3.1.6  Creating a New Project
Navigation: WireCAD PRO Manuall «) > Getting Started| «1>

Menu: Application Menu > New Project
Default command line shortcut: np

Create a new WireCAD Project structure. This involves folder structures on your operating system
as well as databases and support files.

WireCAD can create projects with a number of different database formats.

You may choose to create a new project using file based databases for their zero admin
capabilities, or SQL Server for an enterprise installation.

3.1.6.1 How To: Create a New Project
Navigation: WireCAD PRO Manuall 8 > Getting Started[ «51 > Creating a New Project[ 31 >

1.Click [Application Menu] > [New Project]
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Mew Project
Welcome to the New Project wizard

Project Folder

= wcBplf

B

— r‘f't
Drawings r‘ '

‘ — and Gther Files ﬂ
Lo

Databases
Remote or Local’

Cancel

2.Click [Next >]
3.Select the type of database you wish to use and Click [Next >]

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

%1 New Project

@ Mew Project

Choose Your Database

®) Uze File Based Local or Metwork Share Database (VistaDB)

|Use Database Server (SQL Server)

Use SQL Azure (doud storage)

When using a database file you will need permission to the folder where
you want to store the database and project information. If you want
multiple users to access the database you will need to make sure that
all users have readfwrite access to the location.

Cancel

4.Enter the Name for the new project. This must follow file naming conventions because we are
going to make a folder out of the name and in the Project Path that you choose.

NOTE: We recommend NOT using the possessive ' i.e "Bob's
Project." The ' character is the SQL escape character and though
we rarely use it in WireCAD it can cause some queries to fail.

5.Enter a Description.
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%1 New Project

@ Mew Project

Project Name and Location
Marme: |
Description:

Project Files Path: Cidsers‘Public\Documents

Project Lead Person:

Project Path:

6.Click [Next >]
7.1f using SQL databases enter the host information. Click [Next >]
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%1 New Project

@ Mew Project

Database Server Information

Database Host: | \sglexpress|
Databasze Mame: alfjalsdfjsdfj=difj
v Use Windows User Validation

Test Connection

8.Define some of your project preferences. Here you set your base Starting Cable Number for all
sequences.
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%1 New Project

@ Mew Project

Project Settings (also available under Project> Settings)

Project Settings

Set up defaults for the current project. Each project has its own settings.

Starting Cable Mumber 1,001, | &

Integer used in conjunction with the Cable Mumber Format tool as a starting

Leading Zero Count 3 : Ignore Cable# Text Color

1 Build My Racks From the Top Down Default Radk Height in Rack Units 458

Default Cable Type Manufacturer and Cable Type To Use When Assigning Cable Mumbers

Default Cable Manufacturer BELDEM % | Default Cable Type | 15054 W

Used when no cable type is assodated with a Signal Type for the cable number being assigned

Default Plan Yiew Block File: %ELOCKS %2 \Plan View'eguipment12x12.dwg
w| Users (mere mortals) Can Modify These Project Settings
Add Pinout Data to Each Cable, Pinout Data is Defined in the Database =Pinouts Tool
| Use the device display settings. Mot the Project Settings.
w*| Show duplicate numbers from related projects

Cancel

9.Click [Next >]

10.By default the Next Numbers table will suggest and test the next number. If that number is in
use, the Next Numbers table is incremented and tested until an available number is found. This
behavior can be overridden to force the usage of the number in the Next Numbers table without
testing for existence. To do this Check the Disable Find Next Available ......
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X1

@ Mew Project

Project Settings (also available under Project> Settings)

NHumber Generation
Disable Find Mext Available Syshame (Use Mext Mumber W0 Checking)

Disable Find Mext Available Cable Mumber {(Use Mext Mumber W /O Checking)

The default behaviour is for WireCAD to lookup the next number from the Mext Mumbers table, then check
to see if that number is in use - if so keep incrementing until an available number is found. Disabling this
functionality will use the number in the Mext Numbers table without checking its availability.

| Automatically Consume Cables that are marked as Prewired.
This will use those numbers applied to the PreWire Cable instead of producing a new number.

w*| Strict Multicore Location Assignment. Ensures that all assigned cores go to the same locations.
IF Mask Mode v | Default Subnet Mask | 255.255,255.0

Relational Data

By default WireCaD attempts to maintain a series of tables that relate the main tables to each other. This
allows you to see, for example, which drawings a SysMame can be found in etc. The relational data can
get out of sync or otherwise corrupt. You may elect here to not maintain it in the project and your project
will speed up. Your main Equipment List, Cables, Drawings, and Circuits tables WILL MOT BE EFFECTED.

w| Maintain Relational Data
Disable Cable Mumber Edit Dialog Mask
Disable SysMame Edit Dialog Mask

11.Click [Next >]
12.Enabling Locations Look-up causes a subtle change in the SysName Assignment process. You

will no longer be able to just type a location but rather will select your predefined locations from a
drop-down list. If you wish to work as you have in previous versions of WireCAD disable Locations

Look-up.

© 2025 Holbrook Enterprises, Inc. - WireCAD
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%I New Project
@ Mew Project
Project Settings (also available under Project> Settings)
s
Location Settings
Location / Elevation String Parsing
Location Delimeter . Elevation - Slot Delimeter |-
Location delimeter is used to separate the various elements of the location field. Example: you might
use the dot".' to separate the location field into its constituent part like:
Campus.Building. Floor . Room.Rack. Elevation. The delimeter must be consistent across the project.
Default Location Location v | Default Elevation Elevation
Fnable Locations Lookup Tablei
This allows you to predefine your locations and enforces use of only those predefined locations.
'
W
'
'
'
'
W

13.Click [Next >]

14. Review and click [Finish]

WireCAD will then create files and folders on the OS and create a new database on the SQL server
if you have elected to use SQL server databases. Otherwise the blank project database will be
copied to your project databases folder.

3.1.7  Creating a New Drawing

Navigation: WireCAD PRO Manuall «9 > Getting Started| «1>

Menu: File>New Drawing, Project Explorer\Current Project\New Drawing
Default command line shortcut: nd

Related Settings:

Show New Drawing Wizard = true

Create a new drawing based on a drawing template, with or without model space boundaries.
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3.1.7.1 How To: Create a New Drawing

Navigation: WireCAD PRO Manuall «81 > Getting Started|[ +1 > Creating a New Drawing| 71>

1.Click Project>New Drawing

x * IEE

Hiws Diarminigg

Select a Ternplate Drawing

(rane)
ST AL dwg
ANS]_A Landscape DG

1A L.DWG
BES]_BLCRNG

Lo e )

L ]
tehl_ELG
BLANCIWG

150_A]1 Landicans. deg
150_A1 Porraitdeg
150 _AT Landhcags. deg
1501_AZ Por it g
1501_AS Lanchenge. deeg
150 _AZ Parirait g
190_Ad Landioans. deg

higxt > Cargel

2.Select a template drawing from which to start.

Template drawings are drawings that have been saved in the template drawings folder and
already have entities such as page borders, layouts and viewports added to them.
3.Click [Next >]
4.Name your drawing(s). We have added feature allowing you to create more than one drawing
at a given time. Simply type the name of your drawing into the text box minus the file extension.
If you are creating multiple drawings, enter one name per line. Click [Next>]

1Bl riew Dvaming + IER

@ e

Fokder™ | C-Liners Puble Dot JineCAD fineC A0 10 Deme Project [ Surte Demo Progect Crasings i

5.Select boundary settings. Create Model Space Boundaries. The Model Space Boundaries
function takes two arguments, the Model Space Text Height and the desired Printed Output Text
Height. Using these two variables in conjunction with the size of the Viewports in each Layout to
create boundary rectangles in the Model space. Each boundary is accompanied by a text

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

description that describes the Viewport and to which the boundary applies as well as the text
heights and scale factor.

Note: You can add Model Space Boundaries later using the Drawing>Format>Model Space
Boundaries ... function

&1 New Drawing T HIEN
@ Hew Drzaing
Use Model Space Boundaries
[ e el Spasce Boumcdanies
_________________ i
| 5
i |
i : :
H |
I— —————————— Nghes
i [ ! BF wou da ot create boundlanies here you
1 v | i use the Format +Model Space
| | | Bewnclaries contral
1 I
| | :
i [ :
| pppp———
Hext Carced

6.Click [Next >] to finish and name your drawing.

WireCAD creates the drawing in the project drawings folder tree.

3.1.8  Adding Equipment to Drawings
Navigation: WireCAD PRO Manuall 8\ > Getting Started| «8 >

Menu: Database>Equipment Library [Add to Drawing]
Default command line shortcut: le

Create a new equipment block from the library and add it to the current drawing.
You can create equipment in one of these modes:

eFunctional I/O

e

b
iy

&

i

-
HEE

eConceptual 1/0O (low detail) - Collapses to the I/0O type
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=
e Larea

Gpenamy

s AES12 PES

> ALS A r

ALD

. e -

LesCalsn

eConceptual I/O (high detail)

380 SYSTEL!
WrgR e

Sysnamy
w AES12 AETIA o

ALS ) Ars ARS

AL AT
i Alian L
Lol

eFront Panel (File Merge)

eFront Panel (From Dims)

«Plan View (File Merge)

ePlan View (From Dims) - Not Yet Implemented

3.1.8.1 How To: Add Equipment to Drawings

Navigation: WireCAD PRO Manuall «51 > Getting Started| «1 > Adding Equipment to Drawings| 751
>

1.Create and open a drawing.
2.Find and select the equipment definition from the Equipment Library.
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Q2 e 0o vl X | --|?:& L e e LR

3.Select the 10 you want to display in the drawing

e A x
= e —— o
L2 0 0 08§ A St SR R

4.Select the Display mode

Dxsplay As:

(@) Functional Block
Ol:wen:ﬂhdc

{:.'I' Signal Types Onily Block

() Mappable Terminal From File
(O user Defined Shape from Fie
(O Front Pansl from Fie
OFrun'-Pa'-d from Dims

() Plan View from Fie

5.Select the Display Preferences. Everything is parametric. There are settings for Body Width,
Pin Spacing, Color, etc.

® 08 &

i e T et Fry ey

6.1f the Auto Preview function is not set, you may wish to click the Refresh button (in the preview
window).
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Preview

® e & | E

7.Click [Add to Drawing] (requires an active drawing).

8.Place the newly created block in the drawing. You will be able to place any number of copies.
Just keep left-clicking to place. When you are done right-click and click done or click the [Enter]
key.

3.1.9 Drawing Cables
Navigation: WireCAD PRO Manuall «6) > Getting Started|[ «1>

WireCAD provides a series of tools to draw cables.

Normally we draw from one WireCAD device to another.

If you need to draw spare cables, see the Spare Cables|+: tool.

WireCAD provides a cable auto-routing tool that automatically routes the cable around other
devices and, if selected, avoids other cables. The auto-router will always find a path for the cable,
even if it means that the cable is drawn through another device or must overlay another cable.

If you do not like the way a cable is routed, you have two choices:

1.Manually draw the cable by selecting Manual Draw and place every point from source to
destination.

2.Select the cable as drawn and grab a grip on the cable and move it around. You can use
Ctrl+Shft+Click to add vertexes and Ctrl+Click to remove vertexes.

If you manually draw cables or otherwise put them where you want them and then
move a device, the auto-router will be invoked and re-route all your changes.

WireCAD Cable Terminology

Devices have inputs and outputs, Cables have sources and destinations.
For purposes of this manual we will refer to Jacks, Junction Boxes, Router Crosspoints, Bulkhead
connectors, and On-Sheet/Off-Sheet Pointers, Adapters and Splice Points collectively as terminals.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

i
I
L]
P Ml e R g s
= : = T~ oL 1
~~  Gysiama i .
_{ i Sy _\“\_ .;;:c" "Byshlame _:} 4
. e L — F
> Sytiame Hans — ;—,
T ik
_.--":' :‘.fi.r_'{- - & & ;
‘\_'.«.r_ o ‘} = e n
pr— L — L
o = P i | i

Terminals

Point to
Terminal

Terminal
to Paoint

WYy
Avoid :
Other Tidy
Cables

Cables

Common Controls

These controls effect the behavior of all of the available options.

e Start Cable button - Starts the cable drawing function based on the current setting (one-to-one, one-
to-many, etc.). The Start Cable function is disabled when you are drawing Source to Terminal or
Terminal as Source.

eAvoid Other Cables - Determines whether cables will avoid other cables. Toggling this button will
not affect any existing cable but will from that point forward determine the behavior of cable drawing
and device moving.
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True
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False

o Tidy Cables - After moving a grip on a cable the cable is forced ortho.

1
7

Before Tidy
ol I 4
) -
,_d_:p-"“_.rf_r.r”_. ,’___J__u_;
i .
After Tidy

eRepeat - Repeat drawing cables until Esc is pressed.
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3.1.9.1 One to One Cables
Navigation: WireCAD PRO Manuall +) > Getting Started| «51 > Drawing Cables| &1 >
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L

Start Cable
Point to Point Cable

Cable Text Height (1,100 DLI) 25

4 ¥k

Replace Cable with Pointers

Paointer: VBH_Pointer D.DWG -

Split Cable

D Manually Draw Cable
Cable Text Draw Mode

Mode Default -
1/100 DL
Aux Text
Enable

Apply Aux Text to Existing Cable
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YAMAHA
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DR-01 Q2ZR-M
AESDT Y B DA-1005- DA-1005- XY AES1Z

eCable Text Height -The Cable# text entity height in 100/DU.
eReplace Cable with Pointers checkbox- When checked this function will place linked pointers
between the source and destination ports based on the Default Pointer selection.
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[Split Cable] - Splits a cable that is drawn between two ports into a cable with pointers on either
side of the ports. This is useful if you need to break up a drawing and copy/paste part of the
drawing to another. For more information see How to: Split Cables. [+

eManual Draw checkbox - Draw every point in the cable.

Cable Text Draw Mode

o Default - Draw two Cable# text entities, one at each end of the cable.
o Left - Draw only the left side Cable# text entity.

¢ Right - Draw only the right side Cable# text entity.

[ ]

LeftAlwaysRightlf - Draws the left side always and the right side if the cable polyline is longer than the
entered value in 1/100DU.

¢ RightAlwaysLeftlf - Draws the right side always and the left side if the cable polyline is longer than the
entered value in 1/100DU.

e Aux Text Enable - Enable the placement of Aux Text.
[Apply Aux Text to Existing Cable] - Updates an existing cable to show the Aux Text if not shown.
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Aux Text

.| FXLR Cables f

| FXLR

T ,,-1,_/

Aux Text Shown
e Aux Text Height - The height in 100/DU of the Aux Text.
e[ ocation - The position of the Aux Text relative to the cable polyline.
Over - positioned over the cable polyline.
Under - positioned under the cable polyline.
Bubble - Not yet supported.

eVariable - You may choose to populate the Aux Text with the following variables:
CircuitNumber - The Circuit Number as entered in the Cable Edit Dialog.
IPAddreess - Not yet implemented.

Length - The Length field as entered in the Cable Edit Dialog.

User1 - The User1 as entered in the Cable Edit Dialog.

User2 - The User2 as entered in the Cable Edit Dialog.

User3 - The User3 as entered in the Cable Edit Dialog.

Userd - The User4 as entered in the Cable Edit Dialog.

eFormat - Used to apply string formatting to the Variable selected. {0} represents the data from the
selected variable.

Example: the incoming data from the selected variable is 300 and you want to format it to
represent meters to the reader. Your format field would be {0}m. The output would be formatted as
300m.

e X Offset - Horizontal auto-router offset. When drawing cables, WireCAD uses an auto-routing
algorithm. The X Offset determines how far away horizontally from other equipment and cables a
new cable will rout.

[

Ty

Fl amr %
¥ | .
Rea | L i RCA j
Rea | R ! Rea | 4
Juble & B Video f | Cable = B i
N | J
2000

=L
I e f"“"/ L5 - ,-_/

oY Offset - Vertical auto-router offset. When drawing cables, WireCAD uses an auto-routing algorithm. The Y
Offset determines how far away Vertically from other equipment and cables a new cable will route.
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eDefault Pointer - Select the pointer to use when replacing cable with pointers.

3.1.9.2 One to Many Cables
Navigation: WireCAD PRO Manual[ +8) > Getting Started| +) > Drawing Cables/ ¢31 >
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one-to-many cable

Use this set of controls to place a cable from one output to many inputs.
eFeeder selection - Determines the display of the Y point(s).
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eOne Cable Database Entry - Adds a single entry in the cables database and one Cable# text entity at the Y

point.
eMany Cable Database Entries - Adds a many entries in the cables database and many Cable# text entity at
the connection points.

Note: One-to-Many and Many-to-One cables set to Many Cable Database Entries will assign the
connection point closest to the cursor when the cable is double-clicked. The first assignment on the
cable will enter the database as expected, subsequent assignments will display the Existing Ports
dialog prompting you to decide how to number the cables.
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3.1.9.3 Many to One Cables
Navigation: WireCAD PRO Manuall +8) > Getting Started[ +1 > Drawing Cables| =) >

Many-to-One Cable

Use this set of controls to place a cable from many outputs to one input.
e Count - Source count.

s e T P ¢ 1

&
4
loe {

count=3
The remainder of the controls have been explained above.
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3.1.9.4 Many to Many Cables
Navigation: WireCAD PRO Manuall +) > Getting Started| «51 > Drawing Cables| &1 >
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Many-to-Many Cable

Many-to-Many cables behave like a buss. They are a collection of one-to-one cables drawn as a
single polyline. When assigning cable numbers the connection point closest to the cursor is used.
See the above descriptions for more information about settings.

Related User Settings - When | double-click a Many-to-Many Cable Assign them All. This
setting overrides the default "point-nearest" behavior.

eCount - Source and destination count.
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The remainder of the controls have been explained above.
3.1.9.5 Terminal as Source

Navigation: WireCAD PRO Manual[ +) > Getting Started| +) > Drawing Cables/ ¢31 >

B

DV-1023- B SD

DV-1024- B SD

Displays the available Terminals sorted by Terminal style (Jack,Terminal, Pointer).

Note: Terminal file suffixes determine whether the file will be displayed in this window. Files stored
in the %BLOCKS%\WireCAD Terminals support path having a _SD.DWG, or _S.DWG suffix will
appear in this view.

eTerminal, Pointer, Jack, Splice, Adapter Gallery - Displays a gallery of items to click and place

in the active drawing.
eRefresh Button - Reloads the galleries.
eWire Length in 1/100 Drawing Unit(DU). - The length of the attaching cable or the terminal offset

from the attachedrport.
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3.1.9.6 How To: Place a Terminal as a Source
Navigation: WireCAD PRO Manuall +) > Getting Started| «51 > Drawing Cables| ¢2) >

1.Create and open a drawing.

2.Place a standard block with ports in the drawing.

3.Click the Terminal as Source Window icon.

4.Click the item in the gallery that you wish to place. This will add it to the drawing for placement
including the attaching cable.
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N~ 1] JEEEEE S j
s - = T
£ Il e e E +*
o R S -
b gl el et il gyl I e i b p f

3.1.9.7 Terminal as a Destination
Navigation: WireCAD PRO Manuall «81 > Getting Started|[ «51> Drawing Cables/ s31>

o7 B Dv-1 A-1007- s VPBE-01

B8-07

8 |B DV-10 VPB-01

~_ A0

09 B DY-1009- DV-1009- __— VPE-M

e-0%

Terminal as Destination Window

Displays the available Terminals sorted by Terminal style (Jack,Terminal, Pointer).

Note: Terminal file suffixes determine whether the file will be displayed in this window. Files stored
in the %BLOCKS%\WireCAD Terminals support path a _SD.DWG, or _D.DWG suffix will appear in
this view.

-----
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3.1.9.8 Splice Points
Navigation: WireCAD PRO Manuall +) > Getting Started| «51 > Drawing Cables| &1 >

WireCAD supports splice points. If you need a junction in the cable/wire/fiber then use a Splice
Point. Splice Points can be found in the Terminals tool panels and are placed like any other

Terminal.
To Assign a Splice Point you just double-click it and fill in the data.
A | g T W

SPLICE

- le# | ' Cable#
-
pl iIceg. wCable#
- Kitchen Syﬁ Name
olnts Ie#:ﬁ.' | | ouTPuTL-2
Location Sys Name

NOTE: if the SysName contains the text SPLICE then the duplicate checks and other validations
against the Cables and Equipment Lists are ignored. This allows you to have any number of Splice
Points all with the same name

3.1.9.9 Adapters
Navigation: WireCAD PRO Manuall +) > Getting Started|[ +81 > Drawing Cables| =) >

WireCAD supports the use of Adapters. Adapters are typically used to convert from one connector
to another and may also involve the conversion of signal type. Adapters are found in the Terminals
tool panels and are placed similar to other terminals. The difference is that instead of a wire being
placed between the port and the terminal the Adapter is placed directly on the port. Once placed,
the adapter reads the block to which it is being attached and gets the SysName and Port
information. It then asks you for the new connector type. Finally it populates the Adapter with the
extracted information

H.l:l:
ANBWP TAULTROLINE AHITE )

WILE-001
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NOTE: if the functional block to which you are attaching the adapter is not yet assigned a
SysName you will be prompted that the operation cannot complete until you have assigned a
SysName to the device. You will then need to double-click each attached adapter to get the
information into the adapter.

3.1.9.10 Working with Pointers (on-sheet/off-sheet reference)
Navigation: WireCAD PRO Manual[ 41 > Getting Started| +1 > Drawing Cables/ 31 >

Pointers in WireCAD are a class of Terminal that allows linking two pointers on the same sheet or
across sheets.

Unlike other terminals in WireCAD, pointers must be used in pairs.

The process of relating one pointer to another is referred to as linking.

There are two pointer families:

1.Pointer_S.dwg and Pointer_D.dwg are the old style pointers. They are still supported but not
editable.

2.WC3_<SOMENAME>_S.DWG and WC3_<SOMENAME>_D.dwg are the WC3 family. These are
editable. You can change, rename, edit the geometry, etc.

Usage

Pointer pairs that reside on the same sheet can be created and linked automatically by invoking the
[Start Cable] function while the Replace Cable with Pointers checkbox checked.
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Automatically draw Pointers instead of cables.
In this case the pointer pairs are placed and linked.
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Pointer pairs that must be linked across sheets must follow this process:

1.Place the pointer on the source sheet.

2.Place the pointer on the destination sheet.

3.Double-click the pointer on the source sheet. You must start on the source side.

4.You will be presented with a list of project drawings. Select the one where the destination pointer
resides

5.You will be switched to the other drawing. If it is not open it will be first.

6.Find the destination pointer and click it.

7.The pointers will be updated with the complimentary end data.

Flipped Pointers

S -002 P BC | SDi-004
SOI-D03 BHC IMPUT < .l'f = Callen BHC | \MIDEO
=" = Al
SOI004 | BNC
ViGA, 150 HD

WIDEC | BNC L

VIDED.02 BHC

VIEED.03 BHC

Occasionally you may find the need to point out of an Input or into an Output.

In order to do this, WireCAD provides a set of pointers that have a reversed geometry.

The naming convention used is <SomePointerName>_FLIPPED_S.DWG or
<SomePointerName>_FLIPPED_D.DWG.

The same process applies as a normal pointer set. Start with the pointer that represents the source
side

of the cable and double-click that. Then move to the other side as usual.

3.1.9.10.1 How To: Link Many Pointers at Once

Navigation: WireCAD PRO Manuall «81 > Getting Started| +1 > Drawing Cables| s > Working with
Pointers (on-sheet/off-sheet reference)[ s41>

Explanation

This process links multiple pointers across sheets or on the same sheet at once.

1.Place the pointers on the source sheet.

2.Place the pointers on the destination sheet.

3.Select the pointers on the source sheet. You must start on the source side.

4.You will presented with a list of project drawings. Select the one where the destination pointer
resides.

5.You will be switched to the other drawing. If it is not open it will be first.

6.Select the same amount of pointers on the destination sheet.
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7.The pointers will be updated with the complimentary end data.

The process will fail if:

eThe counts do not match.

eThe pointer families are found to be different.
eThe process is not started on the source side.

3.1.9.10.2 How To: Swap Pointers

Navigation: WireCAD PRO Manuall «51> Getting Started[ 1 > Drawing Cables| s21 > Working with
Pointers (on-sheet/off-sheet reference)| es1>

This feature allows you to change all pointers of a selected type to that of another.

If you get into the project and decide that something about a pointer does not please your eye you
can change it easily by following these steps:

1. Select the Pointer you wish to swap.

2. [Advanced Tools], [Swap], [Swap All Pointers]

ﬁalﬂﬁpkbﬁ.ﬂ.q shape
n D awing CAD Tools Advanced Tooks Wit D tahase Plugang R

21 . .@ {EF‘ ) 5 I_‘: | Vesbose Syshlame Assigrment
ap i

e Insert with Database

Ecpapereni Ressch: Buslches A Poiriler G =
Lirary Syshame r.hH: ~  Operations - . Shap Syshlames

Exquipm Rack Tooks Equipment Functions

3. The swap pointers dialogue will open and you can now select the pointer that satisfies your
drawing.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

This function will replace pointer sets in thes and other drawings.

Select the _S and _D pointer to replace with.

This function works on-sheet and off-shest.

If the other pointer is on another sheet, that drawing will be opened and the
pointer replaced.

Don't forget to save all drawings when this is finished.

THIS CAM TAKE A WHILE. Be patient,

Outgoing Pointer D WC3_Pointer D

Incoming Pointer _D W
Incoming Pointer _S w
oK Cancel
4. Click [OK]

3.1.10 Defining Locations
Navigation: WireCAD PRO Manuall «$) > Getting Started| 51 >

Menu: Project Explorer>Project Databases>Locations
Default command line shortcut: none

Related Settings:

Enable Locations Look-up Table = true

You can enable the Locations Look-up table. Here you can predefine your locations; thus
maintaining referential integrity across all of your locations. In order to use this function you must
set Application Menu > Settings > Project [Locations] Enable Locations Look-up = true. If
this setting is false, WireCAD behaves as it did in previous versions allowing you to type any value
in the Location field of the SysName Assignment dialog.

When using the Locations Look-up setting you will need to add locations before you can make
use of them in the SysName Assignment dialog.

There is one other ramification of using the Locations Look-up: in the Cables table are two new
fields SRCEL and DESTEL (Source Elevation, Destination Elevation). These are now populated as
you assign cables. This provides an additional level of control as you create reports.

3.1.10.1 How To: Add a New Location
Navigation: WireCAD PRO Manuall +8) > Getting Started| +1 > Defining Locations [+ >

1.Click Project Explorer>Project Databases>Locations. This opens the Locations table.
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2.Click File>New.

5 Add Location(s) * IEN
taps || v | Count

Buiding v | Coant

Pl v Coant

Baom ¥ Count

Fladk Count

Descripion

(ralilied Location
Gl Locabon ned Cancel

3.Enter your data and click [Add]. This will add a single location to the Locations table.
3.1.10.2 How To: Add Multiple Locations

Navigation: WireCAD PRO Manual[ +81 > Getting Started| «1 > Defining Locations|[ %1 >

1.Click Project Explorer>Project Databases>Locations. This opens the Locations table.
2.Click File>New.

& Add Location(s) * IER
tarpa || o | ot =
Tisickre] ~ | Count
Fier W | Lot
o ~ | Count
Bk T
Desrphon
Crualiied Lecation
Cpaabdend Lmca b L= Cancel

3.Increment the Count field for the location that you want to add multiple of.
For example, let's say we have 10 racks in the location: LA.THE FACTORY.FL-01.RM-101
4. Enter LA in the Campus field.
5.Enter THE FACTORY in the Building field.
6.Enter FL-01 in the Floor field.
7.Enter RM-101 in the Room field.
8.Enter RK- in the Rack field
9.Enter 10 in the Rack Count field.
10.Click [Add]. This will add 10 locations to the Locations table:
LA.THE FACTORY.FL-01.RM-101.RK-01
LA.THE FACTORY.FL-01.RM-101.RK-02

LA.THE FACTORY.FL-01.RM-101.RK-10
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3.1.11 Assigning Unique IDs (SysNames)
Navigation: WireCAD PRO Manual[ +) > Getting Started| 1 >

Menu: Advanced Tools>Equipment Functions>Assign SysName
Default command line shortcut: as

Alternately: double-click the equipment block in the drawing.

Related Project Settings:

SysName Format /25

Leading Zeros

Next Numbers Database

WireCAD allows you to provide unique names for each piece of equipment in the project. We refer
to this name as a SysName. SysNames must be unique by location. WireCAD can enforce a
SysName format or allow free form input.

Edit SysNames Dialog Controls

Bl Ecdting Syibiame For CLISTOM BANEL-B52 T R

B ton
Fire Farnl Fimbe
& P Bxmiting Sydfiame 501

St Exintirg

L] E i w o+ Bl

F dadies Sadee] Mash

Prirmaty i Prgrmaty it Lt
e i

el | w e

Flari w BT

eAction - Clarifies the dialog mode via the use of a radio button selection to determine user intent.
eManufacturer - The manufacturer of the device. This field is usually disabled as the dialog has
received the Manufacturer information from an upstream process.

eEquipment Name - The model/pn/item number of the device being assigned. This field is usually
disabled as the dialog has received the EquipmentName information from an upstream process.
eSysName - This is our unique-by-location id. If you manually enter a SysName it must follow the
format defined in the SysName Format tool. The SysName textbox will be masked to help you follow
the format.

eAlias - A functional name for the device. Think of it like the friendly name. The SysName is the
unique ID the Alias can be duplicated if desired

eLocation / Elevation - We recommend that you enter a Location and Elevation. Take your best
guess. The Rack Builder tool will use your guesses to create a preliminary rack layout that can
easily be modified to suit your final design.

eUser 1-4 - For you. You can change these captions from the Plugins>Translation Manager.
Search for the key SysNameUser1 - SysNameUser4 and modify the translated field to be what
you want.

o|P Address / Subnet Mask - For the IP information if any.
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ePower Consumption / Weight - Pre-populated from the Global Equipment database if exists.
eFlags - Various flags to help you sort the equipment in your Systems table.

3.1.11.1 How To: Assign a SysName

Navigation:  WireCAD PRO Manual[+) > Getting Started|+ > Assigning Unique IDs
(SysNames)| 1031 >

This function performs the following steps:

1.Gets the next number in the sequence (based on the SysName Format[+%) from the Next
Numbers table.

2.Prompts the user for input.

3.Updates the drawing

4.Updates the project systems database.

Note: if the project contains related projects, you will be notified of duplicate SysNames in related
projects

1.Create and open a project.

2.Create and open a drawing.

3.Add equipment to the drawing.

4.Set the Verbose SysName Assignment checkbox = true. Advanced Tools>Equipment
Functions.

5.Double-click the equipment in the drawing.

6.The SysName and Alias field will be populated with the next SysName in the sequence based in
the Number Format and the Next Numbers table.

7.Enter any additional data and take your best guess at Location and Elevation.

8.Click [OK].

The drawing will be updated and a new record will be added to the Project Equipment List.

3.1.11.2 How To: Assign Multiple SysNames

Navigation: WireCAD PRO Manual[+«) > Getting Started[+«1 > Assigning Unique IDs
(SysNames)| 1031 >

1.Create and open a project.

2.Create and open a drawing.

3.Add equipment to the drawing.

4.Set the Verbose SysName Assignment checkbox = false. Advanced Tools>Equipment
Functions.

5.Set the Default Project Location and Elevation in the Application Menu > Settings [Project]
[Locations].

6.Create a selection set of devices to assign.

7.Click Advanced Tools > Equipment Functions > Assign SysName.

8.The SysName and Alias field will be populated with the next SysName in the sequence based in
the Number Format and the Next Numbers table.

9.The Location and Elevation fields will be populated with the defaults in the Project Settings.

The drawing will be updated and new record(s) will be added to the Project Equipment List.
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3.1.12 Assigning Terminals
Navigation: WireCAD PRO Manuall «9 > Getting Started| «1>

Menu: Advanced Tools>Equipment Functions>Assign Terminals
Default command line shortcut: ats
Alternately: Double-click the terminal in the drawing.
Assumptions:

At least one SysName/[ % has been assigned.

Terminals are one or two port devices. The dwg file defines the geometry.
WireCAD treats terminal assignment slightly differently from a normal SysName assignment.
During a Terminal Assignment we map the existing SysName ID AND /O port info onto the selected

terminal.

&
Cables Cablam. ~ nilame. ?_?G j
Cable# Ca'blem: N-" ‘_l"‘* “‘D -‘
Cables Cabl&&D " Snablams :‘D l
Cable# Ca'nle,iﬁ;"' Spstiama ":“D f
Cable# Gam%*’ TSritiamg ‘“-G
Cable# Cameﬁﬁ” “Spibiame "‘“D "-,'
Cable# -::ameﬁ.c}" s_r_-:?‘*-

t::r’ "o

—

Assign Terminal(s) Dialog
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eSysName - Select the SysName or press the [+] button to add a new SysName

el am Just Changing a SysName - Leaves all port data as currently displayed on a terminal, just changes the
SysName. This is useful for modifying existing terminal assignments.

eRemember this equipment - Remembers the selected SysName and returns to it on the next terminal
assignment.

eOutputs track inputs - When you select an input that has a corresponding output of the exact same name,
that output will also be selected.

eInputs grid - Active only if the selected terminal(s) have input connection points.
eOutputs grid - Active only if the selected terminal(s) have output connection points.

3.1.12.1 How To: Assign Terminals
Navigation: WireCAD PRO Manuall +$) > Getting Started| «51 > Assigning Terminals [ >

This function performs the following steps:

1.0pens a port selection dialog based on SysName.

2.Prompts the user to select the SysName and the port or ports to display(or range of ports of
multiple terminals are selected).

3.Updates the terminal(s) in the drawing.

1.Create and open a project.

2.Create and open a drawing.

3.Add a terminal to the drawing.

4.Double-click the terminal.

5.Select the SysName from the SysNames dropdown.
6.Select the Input port to apply to the terminal input.
7.Select the Output port to apply to the terminal output.
8.Click [OK].

3.1.12.2 How To: Assign Multiple Terminals
Navigation: WireCAD PRO Manuall +) > Getting Started| «81 > Assigning Terminals [ >

This function performs the following steps:
1.0pens a port selection dialog based on SysName.
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2.Prompts the user to select the SysName and the port or ports to display(or range of ports of
multiple terminals are selected). The order the terminals are added to the selection set is the order
that they will be assigned numbers.

3.Updates the terminal(s) in the drawing.

1.Create and open a project.

2.Create and open a drawing.

3.Add terminals to the drawing.

4.Select the terminals to assign.

5.Click Advanced Tools > Equipment Functions > Assign Terminal(s) or enter ats in the
Commandline and click [Enter].

6.Select the SysName from the SysNames dropdown.

7.Select the top Input port to apply to the terminal input.

8.Select the top Output port to apply to the terminal output.

9.Click [OK].

WireCAD will assign the terminals from top to bottom in the grid and based on the selection set
order.

3.1.12.3 How To: Swap Terminals
Navigation: WireCAD PRO Manuall «51 > Getting Started| «1> Assigning Terminals [ 5 >

The Swap Terminals feature allows you to change all terminals of a selected type to that of another.

If you get into the project and decide that something about a terminal does not please your eye you
can now change it easily.

1. Select the Terminal you wish to swap.

2. [Advanced Tools], [Swap], [Swap All Terminals]
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3. The swap terminals dialogue will open and you can now select the terminal that satisfies your
drawing.
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4. [OK]
3.1.13 Assigning Cable Numbers

Navigation: WireCAD PRO Manuall +$) > Getting Started |« >

Menu: Advanced Tools>Cable Functions>Assign Cable Number
Default command line shortcut: ac

Alternately: Double-click the cable in the drawing.

Related Settings:

Cable Number Format][ 5

Project Settings|seh

Provides a number for a cable in the drawing and Cables table of the project database.

Assumes that the devices on both sides of the cable have first been assigned SysNames.

To assign multiple cables at once, create a selection of cables.

The order the cables are added to the select set is the order that they will be assigned numbers.
Once you have created a selection of cables, click: Advanced Tools>Cable Functions>Assign
Cable Number, or type ac into the command line followed by the [Enter] key.

The Assign Cables function performs the following steps:

1.Gets the next number in the sequence (based on the Cable Number Format [+2).
2.Prompts the user for input.

3.Updates the drawing.

4.Updates the project systems database.

Edit Cable Numbers Dialog Controls
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ePreview - This area displays the connection info as found in the drawing.

WPB-01 RTR-01
B B
B-01 =001
VPE-01 DV-1001- MAIN ROUTER
ROOM 110.4.30 ROOM 110.5.16

eCableNo - CableNo is a direct entry field as well as a drop down that displays all available cables. When
double-clicking an assigned cable, the form will be shown in edit mode. The [New +] button will allow the cable
number to be fully edited. This field is auto populated with the next number based on the Cable Number

Format and the Next Numbers table.

®) Edit existing number; DV-1001-
eAction - clarifies the dialog mode via the use of a radio button selection to determine user intent.

eCableTypeManu, CableType - Select the Cable Type Manufacturer and Cable Type. These are populated by
the SignalType if found. If not, then the project default Cable Manufacturer and Cable Type.

CablsTypeMaru | BELDEM v |CableType 15054 w4
oSignal Type - The incoming signal type. Changing this value may cause a recalculation of the
CableNo base on the Cable Number Format.

eIntegrator - A user field for assigning the responsibility of the cable.

eUsers1-4 - For you.
eSheet - The drawing file name where the assignment is being made from.
ePinout - If Pinouts are used select the Pinout that matches the two connector types.

3.1.13.1 How To: Assign a Cable Number
Navigation: WireCAD PRO Manuall +) > Getting Started| «51 > Assigning Cable Numbers |18 >

1.Create and open a project.
2.Create and open a drawing.
3.Add equipment to the drawing.
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4.Add cables to the drawing.

5.Assign SysNames to the equipment in the drawing.

6.Set the Verbose Cable Assignment checkbox = true. Advanced Tools>Cable Functions. This
will display the edit dialog.

7.Double-click a cable.

8.The dialog above will appear with a preformatted cable number in the CableNo field.

9.Add any additional data.

10.Click [OK].

The drawing will be updated and a new record will be added to the Project Cables table.

Prerequisites
Two SysNamed devices and one cable.

Related Topics:
Cable Connection Exists [+

3.1.13.2 How To: Assign Multiple Cable Numbers
Navigation: WireCAD PRO Manual[ +81 > Getting Started| +1 > Assigning Cable Numbers |1 >

1.Create and open a project.

2.Create and open a drawing.

3.Add equipment to the drawing.

4.Add cables to the drawing.

5.Assign SysNames to the equipment in the drawing.

6.Set the Verbose Cable Assignment checkbox = false. Advanced Tools>Cable Functions. This
will not display the edit dialog.

7.Create a selection set of cables.

8.Click Advanced Tools > Cable Functions > Assign Cable Number.

The drawing will be updated and new record(s) will be added to the Project Cables table.

Prerequisites
All selected cables must be attached to devices with SysNames.

Related Topics:
Cable Connection Exists [+8)

3.1.14 Rack Builder Tool
Navigation: WireCAD PRO Manuall «) > Getting Started| 1 >

Menu: Advanced Tools>Rack Functions>Rack Builder
Default command line shortcut: rb

Related Settings:

Default Rack Height|[ s

Top Down Racks|h

The Rack Builder tool utilizes information in the Project Systems table and the global equipment
library to place and populate rack elevation views. This process may be run repeatedly as the
project progresses.
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o¢The [Basic] tab allows you to select the locations to include in the Rack Building function. As
you select each location, the Systems Involved list will populate.

e Systems Involved - Displays a list of all the systems that will be placed in the created drawing.
eChassis Width - Sets the width of the chassis in DU.

eHeight in RU - Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm).
eSlot Count - Sets the number of slots per locator grid. This is used to position items that may
not be located at the insertion point of the rack unit.
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oSlot Delimiter - WireCAD searches the Elevation field for numeric values first then for the slot
delimiter if found it parses the data into two values the elevation and the slot, or in other words
how far up in the rack and how far over.

einsertion Point - Where to start the whole process.

s Attribute Height - If view rule is not Front Panel (file merge), sets the attribute height of the
displayed text.

oCreate As -
Front Panel (file merge) = use the dwg file found in the equipment definition BlockRef (Front Panel
File).
Front Panel (from dims) = use the dimension data from the equipment definition to create a 3D
rack block.

From Dims if file not found = Use dimension data if the BlockRef is not found.
ePlace Text If Item Cannot Be Created - If the item cannot be created due to lacking data, place
a text marker in the drawing at the location.
eInclude Grid Hash Marks - This will normally be checked unless you are rebuilding a drawing that
already has the locator grids.
eSpacing DU - Sets the location grid spacing in Drawing Units. Measures from left edge to left
edge.

3.1.14.1 How It Works
Navigation: WireCAD PRO Manuall +) > Getting Started| «81 > Rack Builder Tool[+) >

The Rack Builder tool relies on three key pieces of information. First we need the SysName of the
device to add to the rack. From the SysName we retrieve the equipment manufacturer and model.
Second, using the equipment manufacturer and model, we get the global equipment definition from
the global equipment database. If the global equipment definition is complete it will contain either a
reference to a front panel dwg file (BlockRef) or dimensional data. If either of these are missing the
Rack Builder tool will flag that equipment definition as requiring more information. The Rack Builder

WTR-01

e R A P

Assuming all of the data fiddly-bits are in the right place, the Rack Builder tool will populate the
drawing with one locator grid per location selected. A locator grid is an array of point entities that
are spaced horizontally and vertically based upon your selection in the preferences.
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Next the Rack Builder tool, based on the Mechanical View Rule, will place either the front panel file
or a block created from the dimensional data at the location point defined in the Project System
entry.

The locator grids facilitate location aware movement of the devices placed on the grid.

You may manually place devices created from the equipment library in Front Panel mode on the
locator grids.

To move a device within the rack elevations, select the device, grab it by its grip and move it to the
desired Iocation
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Note: It is desirable to turn on End Point snap and possibly Node Snap while moving devices

WireCAD will notify you of the location change and update the databases immediately to reflect the
change.
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Location Change Detected
VPB-01 has maoved to;
Location: ROOM 110, 4 Elevation: 28

It will not update the remainder of the drawing set until you click File > Save. You will then be given
the opportunity to Ripple your changes. Though you are offered the choice you should ALWAYS
select [Yes] when working in the Rack Builder drawings.
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Once changes are made across the drawing set you will be notified of the changed drawings.
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3.1.15 Next Numbers Grid
Navigation: WireCAD PRO Manuall +) > Getting Started| 1 >

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None

Product Level: ALL
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The Next Numbers Grid will show you the next available Cable number based on your Cable
Number Format/[ 5. To access the Next Numbers Tool, type ux in the command line prompt.

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As
you progress through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number

box and fill in the desired number. Be sure that you are not entering a number that is already in use.

“.. | — . Ti_;:
L= = 1 WircCAD

CERIF TR TR TR SR

Note: Yours will look different as the Next Numbers grid will automatically create entries for each
new sequence used by the application.

3.2 Advanced Topics
Navigation: WireCAD PRO Manuall «) >

The following sections cover more advanced topics in WireCAD.
3.2.1 Equipment List Visualizer
Navigation: WireCAD PRO Manual[ +1 > Advanced Topics[% >

Menu: Database>Project Systems>Equipment List (SysNames)
Default command line shortcut: sys

Related Settings:

See the Settings Tab

The Equipment List Visualization tool utilizes information in the Project Systems table and the
Global Equipment Library and the Project Cables database to create a view of all cables attached
to the selected item.

These details are useful for error checking and in the field as an installation aid.
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3.2.1.1

System Snapshot of all ports and connections

Controls

- e S
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eSettings Tab - Control the output of the Visualizer.

eUse Last Display Order if Set - Sorts the ports of the block based on the saved display order if any.
eTerminal - The terminal to display.

eUse Last Saved Appearance - If there are device level settings saved, use them.

eBody Width and Pin Spacing - Appearance settings in 100/DU.

ePort Data Source -
Pull the port data from the Equipment Library. This will show ALL ports associated with this device definition.

Pull the port data from the Cables table. This will show only those ports to which cables have been
attached and assigned.

e Title Block - Describes the visualization. Salt to taste.

eVisualization tab - Does it.

How To: Use the Equipment Visualizer
Navigation: WireCAD PRO Manuall +8) > Advanced Topics! ) > Equipment List Visualizer|[+% >

1.Create a project.

2.Add equipment.
3.Assign SysNames.
4.Draw cables.

5.Assign Cable Numbers.
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6.0pen the project Equipment List.

7.Select the SysName record to visualize.

8.Click the Settings tab.

9.Set the Terminal. This is the item that will be displayed as the source and destination of each
cable.

10.Click the Visualize tab.

3.2.2  Cables Visualizer
Navigation: WireCAD PRO Manual[ +1 > Advanced Topics[% >

Menu: Database>Project Cables>Project Cables Grid
Default command line shortcut: cg

Related Settings:

See the Settings tab

The Cables Visualization tool creates a layered diagraph (ladder diagram) showing the
Locations (vertically) and the cables between them (horizontally).

Use this output for:

ePre-wires.

eSpare inventory.

eGeneral overview.

eEnlighten and amaze your friends.

Honzontal
Lines

Represent the
Cable Between
Locations

Vertical Lines
Represent the
Location
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3.2.2.1 How To: Use the Cables Visualizer
Navigation: WireCAD PRO Manuall «81 > Advanced Topics[+5 > Cables Visualizer[ >

1.Create a project.

2.Add equipment.

3.Assign SysNames.

4.Draw cables.

5.Assign Cable Numbers.

6.0pen the project Cables grid.
7.Select a group of records to visualize.
8.Click the Settings tab.

9.Adjust settings to suit.

10.Click the Visualize tab.

3.2.3  AutoScheme Tools
Navigation: WireCAD PRO Manual[ 491 > Advanced Topics[% >

The AutoScheme tools create functional drawings or parts thereof from the data in the project
systems and cables databases. This is useful to create detail or overall views.

The AutoScheme tools consist of two utilities. The Auto Block tool automatically places blocks in
the drawing on a grid. The Ratsnest tool checks the project cables database against the
drawing. If connections defined in the cables database can be reproduced in the drawing
because the SysNames and Ports exist, a cable is placed.

Prerequisites
SysNames and Cable Numbers in the project database.

Auto Blocked drawing. Blocks have been created and placed.
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4
0 g 0 U &2 & &2 & =
;H[__eeei}[l‘]il‘} ¥
¥ N i W

-
After running the Ratsnest tool. This supplies the drawing with cable data and provides a
positional reference to help you decide where to move block to better display the drawing.
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After running the Cleanup tool from the Ratsnest utility.
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3.2.3.1 Auto Block
Navigation: WireCAD PRO Manual[ +81 > Advanced Topics[+5 > AutoScheme Tools[5 >

Menu: Advanced Tools>AutoScheme Tools>Auto Block
Default command line shortcut: ab

Related Settings:

None

The Auto Block tool automatically places functional blocks in the drawing. This tool requires that the
Project Systems table be populated.

Controls
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eThe [Basic] tab allows you to determine which systems to add to the drawing.
oFilter - Filters the list by your criteria.
eThe [Advanced] tab allows you to refine the behavior of the utility.
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elnsertion Point - The point we start from.

eHorizontal Spacing DU - How far apart horizontally. The vertical spacing is defined by the height of the
highest block in the row.

eMaximum Column Count - How many columns horizontally.

eGet Port Data From Cables Database - Select this option to search the cables database for port info instead
of the global equipment database. This will effectively show only those ports to which we have attached cables.

eDisplay As - How to display the blocks.
eDisplay Preferences - If Functional Block or Concept block is selected then set basic display parameters.
eSignal Types to Display - Filter ports by the selected signal types.
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3.2.3.2 RatsNest
Navigation: WireCAD PRO Manuall +1 > Advanced Topics !+ > AutoScheme Tools [+ >

Menu: Advanced Tools>AutoScheme Tools>RatsNest
Default command line shortcut: rn

Related Settings:

None

The RatsNest tool checks the project cables database against the drawing. If connections defined
in the cables database can be reproduced in the drawing because the SysNames and Ports exist, a
cable is placed.

This tool requires that the Project Cables table be populated.

Controls

Bl matsnest * IEEN

This function pulls cable data from the Cables table and looks into the active drawing to
sen il the source and destination ports exist in the drawing; if found a cable is placed
bebween the ports. The result looks ke a giant ratsnest, Looking at the ratsnest you
can tell which devices need to be repositioned to better display the data. You can move
the blocks and in so doing the cables will be rerouted and deaned up. Alternately you
can use the [Cleanup] button to reroute all cables, Fillet apples a fillet to each cormer of
every cable in drawing.

Rats Nest Chrareg Calies Fillet Al Cables
Ratsnest | Clearup Filet
| Show Cable Mumbers Avokd Crther Cables Radus 0.35(5
Clear Al Cables

oThis tool has three sections. The RatsNest section does the work of placing the cables in the
drawing as defined in the Cables database.

o[Ratsnest] - Run the utility to place the cables.

eShow Cable Numbers - With or without cable numbers.

o[Clear All Cables] - Removes ALL cables from the drawing. Not just ratsnested cables. This will
remove ALL.

e[Cleanup] - Applies the auto-router to all cables in the drawing.

eAvoid Other Cables - Auto-router avoids other cables on cleanup.

o[Fillet] - Applies fillets to ALL cables in the drawing.

eDistance - Fillet distance in 100/DU.
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3.2.4  SysName Formatting
Navigation: WireCAD PRO Manual[ «9 > Advanced Topics[% >

Menu: Project Explorer>Project Databases>Project SysName Format
Default command line shortcut: fsys

Related Settings:

None

Allows control of the SysName numbering scheme. Using the SysName Format dialog you can
select any field that is associated with the SysName and concatenate it into your own numbering
scheme. Each of the fields selected can be formatted and the numbers can be set to sequence off
of another field.

How it Works
The SysName Format Tool is used to generate regular expressions that are then used to parse
SysName info as well as provide formatting information to masked text boxes.

A note on regular expressions: WireCAD makes extensive use of regular expressions (Regex).
Regular expressions are well documented string parsing tools. Much has been written on them. It
is not within the scope of this quick start guide to fully explain regular expressions; however, a
Google search will tell you more than you ever wanted to know.

Two forms of regular expression are generated: a simplified form that is used as a mask in both the
Systems database and in textboxes, and a complex form that aids in the generation of queries to
determine the next number in a sequence. The following are both the simplified and complex Regex
for the default format:

\w{l,6}-\d{1,5}
(?<EQUIPMENTTYPE>\w{1, 6}) - (?<NUMERICSEQUENCE>\d{1,5})

Controls
eSelected Format - Selects the current SysName format. Allows addition and deletion of formats as well.

X Sysiame Formal Detals + IEl

Fle Toch  ‘Wiew

Fﬂx:r:far-a: Dl w = ]

ot Shng  Exgu Type-000000

Loy, Lk Exug: 0000
e Bebvarced Frgular Exprrmsicn 1o [k Shatf)

o Eigen Dampie.

Ficld Seg O Format Order
¥ | EQUEPSENTTYTE [ cA-20-8 1L L)
BRI LT ECLEPMENTTYSE BiLy
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eVariable List - Displays the sequence of variables in grid view that will be concatenated into the final
SysName.

[ Sysiame Forsmat Detak +
Fe 32 Took Wew

fowined bpmgr. DAL w4
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B | DR Fonk-304 L VIE L 8
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«SeqOn - This variable should sequence on another variable's value.
oOrder - The order in the list of the variable.
eAvailable Variables -

Variable Description Can Sequence On Default Format
(Regex)
MANUFACTURER Manufacturer Name X \w{l,6}

EQUIPMENTNAME Equipment X \wi{l,6}
Name/PN/Model
Number
DESCRIPTION The device X \w{l,6}
description as
contained in the
global equipment
library
EQUIPMENTTYPE The Equipment Type X \w{l,6}
as contained in the
global equipment
library

LOCATION The location typed in| X \w{l,6}
the SysName edit
dialog

ELEVATION The location typed in| X \wi{l,6}
the SysName edit
dialog

STRING any string (usually -
used for delimiters
like dashes (-))

NUMERICSEQUENCE a numeric sequencel \d{1,5}
that starts with the
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project starting
number
ALPHASEQUENCE an alpha sequence \w{4}
that starts at the
letter 'a’
USER1 the global equipment \wi{l,6}
library device
definition user1 field
USER2 " \w{l, 6}
USER3 " \w{l,6}
USER4 " \w{l, 6}

More About Regex

The Format field uses regular expressions. The following are some simple examples:

\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters

\d{1,5} Digits 1 to 5 digits in length

\d* Digits any length

\\ a slash "\". The \ is the escape character so you need two

- a dash except when in [] or {} then a range.
[a-zA-Z0-9 \-\]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.

3.2.5 Cable Number Formatting
Navigation: WireCAD PRO Manuall +$\ > Advanced Topics |+ >

Menu: Project Explorer>Project Databases>Project Cable Number Format
Default command line shortcut: fcab

Related Settings:

None

Allows control of the Cable numbering scheme. Using the Cable Number Format dialog you can
select any field that is associated with the Cable Number and concatenate it into your own
numbering scheme. Each of the fields selected can be formatted and the numbers can be set to
sequence off of another field.

How it Works

The Cable Number format tool is used to generate regular expressions that are then used to parse
Cable Number info as well as provide formatting information to masked text boxes.
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A note on regular expressions: WireCAD makes extensive use of regular expressions (Regex).
Regular expressions are well documented string parsing tools. Much has been written on them. It is
not within the scope of this quick start guide to fully explain regular expressions; however, a Google
search will tell you more than you ever wanted to know.

Two forms of regular expression are generated: a simplified form that is used as a mask in both
the Cables database and in text boxes, and a complex form that aids in the generation of queries
to determine the next number in a sequence. The following are both the simplified and complex
Regex for the default cable number format:

\w{l,6}-\d{1,5}-\w*

(?<SIGNALTYPEPREFIX>\w{l,6})- (?<NUMERICSEQUENCE>\d{1l,5}) - (?<MULTICOREDATA>\w*)

Controls

eSelected Format - Selects the current Cable Number format. Allows addition and deletion of formats as well.

& Cable Wumber Format Detals + IEER
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eVariable List - Displays the sequence of variables in grid view that will be concatenated into the final Cable
Number.
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¢SeqOn - This variable should sequence on another variable's value.
eOrder - The order in the list of the variable.
eTest Syntax - Performs a basic syntax test on the regular expressions.

eAvailable Variables -

Variable Description Can Sequence On Default Format
(Regex)
SIGNALTYPE The signal type X \w{l,4}
associated with the
cable
SIGNALTYPEPREFIX the signal type prefix X \w{l,4}
associated with the
signal type of the
cable
SOURCESYSTEM The source X \w{l,6}
SysName
SOURCEPIN The source port or X \w{l, 6}
pin name
SOURCEALIAS The source Alias X \w{l,6}
SOURCELOCATION The source location X \w{l,6}
DESTSYSTEM The destination \w{l, 6}
SysName
DESTPIN The destination port \w{l,6}
or pin name
DESTALIAS The destination alias \w{l, 6}
DESTLOCATION The destination alias \w{l,6}
SOURCE_OR DEST PIN| Not Yet \w{l,6}
~_IF JACKFIELD Implemented
MULTICOREDATA Core data as \w*
defined in the
associated cable
type if any
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STRING any string (usually -
used for delimiters
like dashes (-))

NUMERICSEQUENCE a numeric sequence \d{1,5}
that starts with the
project starting
number
ALPHASEQUENCE an alpha sequence \w{4}
that starts at the
letter 'a’
USER1 the global equipment \w{l, 6}
library device
definition user1 field
USER2 " \w{l,6}
USER3 " \w{l, 6}
USER4 " \w{l,6}
More About Regex

The Format field uses regular expressions. The following are some simple examples:

\w{1,6} Any non number, non punctuation string from 1 to 6 characters
\w* Any non number, non punctuation string any length
[a-zA-Z0-9]{5} Lower / Upper case and 0 thru 9 exactly 5 characters

\d{1,5} Digits 1 to 5 digits in length

\d* Digits any length

\\ a slash "\". The \ is the escape character so you need two

- a dash except when in [] or {} then a range.
[a-zA-Z0-9 \-\,]{1,4} Lower / Upper case, 0-9, underscore, dash, and comma.

3.2.6  Using Your CAD Drawings With WireCAD
Navigation: WireCAD PRO Manual[ +81 > Advanced Topics|[5 >

With WireCAD you can "WireCADify" your existing non-WireCAD CAD blocks to include WireCAD
intelligence; thus making them work with WireCAD. Pretty cool huh?

The process requires at least two steps:
1. WireCADify the block.
2. Add ports to the block.

3.2.6.1 How To: Customize Your CAD Blocks to Work with WireCAD

Navigation: WireCAD PRO Manuall «81 > Advanced Topics[+5 > Using Your CAD Drawings With
WireCAD | 128 >

Menu: Advanced Tools>WireCADify>WireCADify Block
Default command line shortcut: wc
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Requires an active drawing with a CAD block.

Adds the base WireCAD attribute set to the selected block, mapping your attribute data into our
attributes if you choose.

1.0pen a drawing with a non-WireCAD CAD block that you want to make work with WireCAD.
2.Click Advanced Tools>WireCADify>WireCADify Block.

3.You will be prompted to select a CAD block.

s ™
Edit Attribates -
Bock Mo o7
Tag ‘Wi
mn o
mcuted Eam—.
(23 Les
" 9 355 398 355 4 ) Ei )
PR— + N J.'L. &
it o s wa o
. 4

Here we have a CAD block with the displayed attributes (Yours).
4.Select your CAD block. It must be a block and not raw entities.
X | |Executing Command: WireCaDifyBlock, , we
Select an Insert to which we will add the WireCAD base attribute set.

5.Map your attribute to our attributes.

1 Mg Enting Attribates 16 WieeCAD Altribntes * [l

Fins ATNCata T o T VLS Y

et b T = [
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6.Select the [Descriptor Locations] button.

Drag to reposition
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7.Click [OK] to finish.
3.2.6.2 How To: Add a Port to an Existing CAD Block

Navigation: WireCAD PRO Manuall+1 > Advanced Topics/++# > Using Your CAD Drawings With
WireCAD | 1251 >

Menu: Advanced Tools>WireCADify>Add Connection Point
Default command line shortcut: none

Related Settings:

None

Adds a connection point to the selected block.
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1.0pen a drawing with a WireCAD block.
2.Click Advanced Tools>WireCADify>Add Connection Point
3.You will be prompted to select a WireCAD block.
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Here we have a WireCADified block
4.You will be prompted for the point at which to add the Connection Point.
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Here will will choose the arc quandrant
5.Enter your port info into the dialog that is presented.

&1 Add Connection Point to Existing Block (Insart) 7 EEN
Peet Mame
Synal Type Liie] w
Connector {(Cabls End]) BC W
w'| Port 5 Input Labed Text Height {17100 0U) 1] :
Show Labels
| Podt hiarne o TRl

| Indude Geometry

® Cirde Square Triangie X
Geometry Size X (1100 DU) 10| 5 | Geometry Siee ¥ {1/ 200 DU ]
Line Width 1|8

o Carsel

Here we will say that the port is an input
called IN10.
We will show the labels and include a small
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circle to snap to.

6.Click [OK] to finish.
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3.2.7 Understanding Indexes
Navigation: WireCAD PRO Manual[ « > Advanced Topics[% >

'\
(Cabln. _}E{ cables_drawings_cables F*(CE Drawings e
= a % DvawingGll.. =
| ProjectiD T I
i DrawingMa...
| sysnames_cables_sysnames DrawingSh... i E
8 DrawingLe...
4 CurrentRey... Ei—
( } ] DrawingMu...
I Systems E‘{ sysnames_drawings_sysnames T‘Eﬁ Eoria b
J

C___ =Primary Data

Related Topics:
Unassigned Cables|s
Unassigned SysNames s
Cables by Drawingls$
SysNames by Drawing[s#
Cables by SysName/ss
Orphaned Cables|s#
Orphaned SysNames [s:5

WireCAD keeps track of two classes of data.

1. Primary - examples of primary data include: SysNames, Cable Numbers, Locations, and
Drawings. This data is of cardinal importance. We always want this data to accurately portray what
goes on in the drawing/database.

Unassigr
Unassigr
Orphane

Orphane
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2. Secondary - Indexes are secondary or transient data.
The indexes are link data relating the primary data bits to each other.

Index data is transient in nature.

WireCAD consists of a drawing interface with undo/redo and a database which does not. With that
as our framework let's discuss a scenario which will put the indexes out of sync quickly.

1.You add a cable to a drawing. A record is added to the Unassigned Cables index.

2.You undo. The cable is removed from the drawing but the database does not have an undo
function (nor should it but that's a discussion for another day).

3.We now have a record in the Unassigned Cables index that is in error. It only took two steps to
create an inconsistency in the index table.

So rather than trying unsuccessfully to keep every move in sync, we routinely scan the drawing and
rebuild the index tables as a background process.

The indexes can be destroyed, rebuilt, and at any given time - out of sync. Deleting all indexes has
no effect on primary data.

To insure the most current indexes, run the Rebuild Indexes command.

You can view the indexed data in the primary data grids as sub grids with the [+] button.
You can also view the indexed data in individual grids.

There are seven indexes:

1. Unassigned Cables by Drawing. We search the drawing and add any cable that does not yet
have a number to this index.

2. Unassigned SysNames (equipment) by drawing. We search the drawing for any equipment that
does not yet have a SysName and add it to this index.

3. Equipment by Drawing. Any equipment that has a SysName and corresponding entry in the
Equipment List is added to this index by drawing.

4. Cables by Drawing. Any cable that has a number and corresponding entry in the Cables
database is added to this index by drawing.

5. Cables by Equipment. Any cable that has a number and corresponding entry in the cables
database and where both ends of the cable have valid entries in the Equipment list will be added to
this index.

6. Orphaned Cables. Any cable with a number but no corresponding entry in the Cables database
will be added to this index by drawing.

7. Orphaned SysNames. Any equipment with a SysName but no corresponding entry in the
Equipment list will be added to this index by drawing.

Settings that affect Indexing

The Auto Index setting will scan the project in the background upon project open and any drawing
save.

The Show Index Progress setting turns on the main progress bar in the status bar to indicate
progress.
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3.2.8  Sync Equipment with Database
Navigation: WireCAD PRO Manual[ +) > Advanced Topics/1>

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Sync
Equipment with Database
Default command line shortcut: SyncinsertWithDatabase

Occasionally you will make a decision that puts the data on an insert out of sync with the
corresponding record in the Equipment List.

This will be manifest by an Orphaned SysName record. To remedy the error use the following
steps:

1.Select the insert in the drawing that is orphaned. If you are unsure you can always start this
function and if the insert matches the database you will be informed as such.

2.Right-click to show the context menu.

3.Click Equipment>Sync Insert with Database.

These are the possible outcomes:

1.The insert matches the database. At which point you will be informed as such.

2.The insert partially matches the database. The SysName and Location match but other fields do
not. You will be given a choice as to which record to use as the update source.

3.The insert cannot be matched with a record in the database. This results in two other options:

a. You will be given the choice to add a new record, or:

b. The database is queried for like Manufacturer and EquipmentName records from which you
can select to apply to the insert. Note: only SysNames of the same Manufacturer and
EquipmentName will be shown for selection.

Depending on your selection the following will happen:

Outcome Update Insert Update Update Cable Add New Update
in Drawing Database Data Data Record Attached
Pointers

Item Matches
Database

Item Matches

SysName and

Location X
Choice to use

Insert Data

Item Matches
SysName and
Location X X X
Choice to use
Database Data

Item not
found in
Database
Choice is Add
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Item not

found in

data_base _ X X X
choice is

select other

existing

3.2.9 Swap Equipment
Navigation: WireCAD PRO Manuall 8 > Advanced Topics /i >

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Swap
Equipment
Default command line shortcut: none

The Swap Equipment function allows you to swap Manufacturer, Model, and port data on an
existing functional block or concept block.

Applies To:
Functional Blocks
Concept (High Detail) Blocks.

Used For:
Switching from one make/model to another.

Controls
® Eqpupment Swicher + IEl
Stk Frodro WTR-02 8 RosDbg 100E 14-[ D080 ASGE]
N = Bt Hamw | 7008 -

Brevemsg bpus Drigoirg Irputy Dastgrang Cuipuis Inczming Cuiputy
" o | 50O - - 30

ACLY <L - AUD AES 1LT-WRA < DGA

eManufacturer - Select the Manufacturer to replace the outgoing device with.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

eEquipment Name - Select the Equipment Name / Model / PN to replace the outgoing device
with.

eInputs grid, Outputs grid - Select the ports to replace.

oFind Matches - Matches incoming ports to outgoing ports.

¢OK - Do it!

3.2.9.1 How To: Swap Equipment
Navigation: WireCAD PRO Manual[ + > Advanced Topics[+% > Swap Equipment /s >

1.0pen a drawing.

2.Select one of the block types in the Applies To section.
3.Right-click to show the context menu.

4.Click Equipment Functions > Swap Equipment.
5.Fill in the Equipment Switcher form data.

6.Click OK.

3.2.10 Edit Block in Place
Navigation: WireCAD PRO Manuall +$\ > Advanced Topics |+ >

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Edit Block in
Place

Menu: Context Menu with Equipment Insert Selected>Equipment Functions>Edit Block in
Place Ignore Attached Cables

Default command line shortcut: ebip, EditBlockinPlacelgnoreAttachedCables

Related Settings:

None

Edit Block in Place allows you to modify an existing insert that was created from the Equipment
Library. There are two variants of the function. One that attempts to keep all cables attached to the
ports from which they started. The other does not.

Because blocks in the CAD file are immutable the function actually creates a replacement block
and inserts it into the drawing in place of the other.

Prerequisites
A WireCAD created functional block

Overview

1.The port information is read from the block.

2.The display information is read from the block.

3.Cable information is read from the block.

4. The Equipment Library is queried for the incoming device and the Library is placed in Edit
Mode.

5.The drawing information is used to create a matching block in the Equipment Library.

6.Edit to suit.

7.Update the insert in the drawing.
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8.Re-route all cables to find their starting ports or not depending on the variant.
9.Cables that cannot find their starting ports are modified to show a dashed LineType.
10.Show a dialog indicating cables that cannot find home.

NOTE: While the port information is being read into the Equipment Library if a port exists on the
drawing that does not exist in the Equipment Library it will be added.

3.2.10.1 How To: Edit a Block In Place
Navigation: WireCAD PRO Manual[ «9 > Advanced Topics[+% > Edit Block in Place[h >

1.0pen a drawing with a WireCAD created functional block.
2.Select the block. It must be the only thing in the selection.
3.Right-click and select Equipment>Edit Block in Place.

.......

!
. 00008 1l
i
i

A Com
B | s
[=

4.The block is loaded into the Equipment Library for edit.

Jpmsl | L
= | = = - > - = =y
L} T .

Edit Initiated

5.Make changes. Here will move the top SDI port to the bottom.
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List Reordered

6.Click [Update Insert in Drawing].

360 SYSTEMS
Image Server 2K

Sysname
BNC 01 SDI. BNC
BNC S0D1-001 SD01.03 BNC
BHC SDI-002 SDI-001 BNC
BNC SO1-003 S0I-02 BNC
BHC S01-004 S01-003 BNC
BNC VIDED SDI-004 BNC
i GEMLOCK s BNC Cabded
Alias
Locaton

Port moved and cable reattached
7.Done.

3.2.11 Rereference Pointers

Navigation: WireCAD PRO Manual[ «9 > Advanced Topics[% >

Explanation
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Occasionally you will save pointers to another sheet. This can be because you have done a SaveAs
or Copy/Paste.

At that point you will want to change the sheet reference on the pointers. Those pointers that point
to the new sheet from other drawings as well as the pointers on this sheet that point to the old
drawing will need to be renamed to the new sheet.

Usage

1.Click Advanced Tools > Rereference Drawing Pointers (Change SheetRef Names).
2.Fill in the dialog - Set the rename From/To names and where you want to search.

3.2.12 Save and Ripple
Navigation: WireCAD PRO Manual[ +81 > Advanced Topics|[ 5 >

Occasionally throughout normal program execution you will be presented with the Ripple Choice [+
dialog.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

’fl Ripple Type 7 x

You have made changes that likely impact other drawings and databases. WireCAD can now ripple the changes
across the drawing set and affected databases.

o Full Ripple. Searches all drawings. This is the safest but takes more time.

Quick Ripple is not an option if any of the items to ripple are missing drawing indexes. To be sure that the indexes are up to date you can use the
Re-index function on the Equipment and Cables grids.

@ ‘Quick Ripple. Searches only the indexed drawings for each item. !

‘You can tell if an item has indexes by looking at its row in the grid if the [+] is enabled there is an index.

Yes Ma Cancel

Something has changed that potentially effects data in other drawings and databases. This is your
chance to update those other entities in other places throughout the project.

Options

Full Ripple - This is the safest of all ripples and is essentially a find a replace function that
searches all drawings. In order for a match to be found the OldSysName and OldLocation fields
from the database must match the Sysname and Location field on the block. Then an update to the
new information will be made.

Exclusive Full Ripple - Expert Mode s only. Don't use this if you don't know exactly what you are
doing and why. This option allows you to pick the drawings that you want to do a Full Ripple on.
Quick Ripple - This ripple uses stored index data to update the block by drawing handle. In this
ripple we get the index which is a pointer to a block in a drawing and we go get that block and
update it.

Applies To:
Equipment List /s
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Cables|s:h database
Locations[ssh database
Rack Builder/ ) drawings
Experience Levellst)

Related Topics:
Understanding Indexes |35

3.2.13 Spare Cables
Navigation: WireCAD PRO Manual[ +$1 > Advanced Topics|[5 >

Menu: Advanced Tools > Add Spare Cable(s)
Default command line shortcut: AddSpareCables
Related Settings:

None

Place geometry in the drawing and cable(s) in the Cables database that represent spare cables.

CONF RM DV-1014- / DV-1018- LIVEU RK

BMC 1189A BMC

The following images represent the above settings in both drawing and the Cables database.

This function adds Count number of cable records to the Cables database. The number is
automatically formatted in accordance with the Cable Number Format/ 2} tool and the
Next Numbers [+ table.

Used For:
Adding geometry and cable entries in the project Cables database.

Controls
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¥l Add spare(s) » I
Cable Type: |EELDEN: 11658 v | | Sigral Type: | 13540 [
Lef Sade Righn Sk
Lecatern | 1041 Ld b Lecation: | 10%.1 w o
Corrector: | 14" w4 Connecior: | 140 W
Caumnls 4
Gepmetry
| S Liocation v Show Connector
| Shiye Cable Type | Shase Cable Mummber(z)
w"| Ciofior by Sagnasl Type:
D Pyl Cancel

eCable Type - Select the CableType.

eLeft Side, Right Side - set the location and the connector.
«Count - how many cable records to enter.

eGeometry - What to include in the drawing.

3.2.13.1 How To: Add a Spare Cable
Navigation: WireCAD PRO Manuall +8) > Advanced Topics!+# > Spare Cables |5 >

1.0pen a project.

2.0pen a drawing.

3.Click Advanced Tools > Add Spare Cable(s).
4.Fill in the dialog.

¥ Add Spare(s) * N

Cable Types  BELDEN-1 35534 ¥ 4| Sgnal Type: | 13540 w |+

Lef Sue Rught S

LEam™ {14 bt Laar L8] ol b

Conmector: | L | Conmector: | L W
Cioarit

Getee s

w| S Loeasio o e Crvranii

| Shives Cable Type w Shioe Cable Humbers)

| Calor by Sgnal Type

Do Folyieres Carsod

5.Click [Draw Polyline].

6.The dialog will be dismissed. You are prompted to draw a polyline.
7.Click the points to enter in the polyline.

8.Right-click to finish.
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3.2.14 Split Cables
Navigation: WireCAD PRO Manual[ «9 > Advanced Topics[% >

The Split Cables function allows you to replace existing cables, whether assigned or not, with linked
pointer sets.

3.2.14.1 How To: Split Cables
Navigation: WireCAD PRO Manuall «1> Advanced Topics!++1 > Split Cables [+« >

1. Select the cable or group of cables in your drawing that you would like to split.

2. Select the Default Pointer that you would like to use. If you select a pointer set that has a full
complement of pointers, ' S', ' D' and the flipped '_S' and '_D' versions of your Default Pointer, you
will get optimum results out of this function.
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4 e
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= || orew Tont et -

A Bt o S &

() e By Bon Tl b Wi Lol - ) 7
- el
i .
i
] # Setirge

Ry T Ofet) (L0018
;_| R T Ot (1SS0 00 Tl i | "
[ NP ] e [+
o z q
] el ——

Se1oae. | Doboi  ue | -
._' Mockdl | Livietd | mAMgRaRasE | maEa | aoap i ¥
T o~ g
g a
e Comemarct ] w

3. Select [Split Cable]

I

. Your end result will look like this:
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Hint: Move blocks apart from each other so that you have room for the newly minted pointer. See
above example for how not to do it.

3.2.15 Aux Text
Navigation: WireCAD PRO Manual[ +81 > Advanced Topics|[5 >

The Aux Text Fuction is for those users that use Aux Text, but forgot to check the box. This function
allows you to add the Auxiliary Text without having to redraw a cable.

3.2.15.1 How To: Apply Aux Text to an Existing Cable
Navigation: WireCAD PRO Manuall 81 > Advanced Topics !+ > Aux Text[+ >

1. Select the Cables that you would like to Apply Aux Text to.

2. Select [Apply Aux Text to Existing Cable] in the Draw Cables menu.
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3.2.16 Title Block Manager
Navigation: WireCAD PRO Manual[ «9 > Advanced Topics[% >

Menu: [Project] > [Title Block Manager]
Default command line shortcut: tbm

Tag Srrg A sk String Coratant Lipsiatn Moxde

e e

The Title Block Manager allows you to edit Attributes in your drawings to reflect across your project.

3.2.16.1 How To: Adjust Attributes in the Title Block Manager
Navigation: WireCAD PRO Manuall +) > Advanced Topics+# > Title Block Manager! ) >

The Title Block Manager will allow you to add a Title Block by adding variables to your available
attributes.

1. Open the Title Block Manager. [Project] > [Title Block Manager]
If you have not already selected the attributes that you would like to show, simply select [Add]
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WireCAD will prompt you that it is going to hide the Title Block Manager Dialogue so that you can
select a page border insert to work with. Click [OK]
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2. Select the Title Block that you would like to manage. The Title Block Manager will re-appear and
you will now be able to edit your Attribute Values.

3. Edit your Attribute Values to fit your project needs.

4. Once you have edited your Attribute Values, you can can save your changes in one of two ways.
The first way you can save your changes is by selecting [Update Active Drawing Now].
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You can also set the update settings for each attribute.
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5. You are finished.

3.2.17 Understanding Terminals
Navigation: WireCAD PRO Manual[ «1> Advanced Topics|[5 >

Terminals in WireCAD represent a one or two port device and are used to draw compact inline
signal flows.

The terminal is a standard CAD block with specific WireCAD attributes. The geometry of the
terminal

is defined in the CAD drawing file.

In order to be a WireCAD Terminal the following criteria must be met:
oWireCAD Attribute set which includes:
SysName

EquipmentName
ManufacturerName

Location

Alias

SheetRef

Created With:

EquipmentID

WC_TYPE

EquipmentDescription

In addition a Terminal must have at least one invisible Connection Point attribute with the Tag:
CP_IN or CP_OUT.
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The CP_IN should be placed on geometry that represents the input connection point. Or the point
to which we will connect our cable destination.

The CP_OUT should be placed on geometry that represents the output connection point. Or the
point to which we will connect our cable source.

If a CP_IN is defined, the following display attributes may also be used:
INPUT_CONN - optional input connector display name.
INPUT_NAME - optional input display name.

INPUT_TYPE - optional input signal type display name.

If a CP_OUT is defined. The follow display attributes may also be used:
OUTPUT_CONN - optional output connector display name.
OUTPUT_NAME - optional output display name.

OUTPUT_TYPE - optional output signal type display name.

3.2.17.1 How To: Customize a Terminal

Navigation: WireCAD PRO Manuall 81 > Advanced Topics !+ > Understanding Terminals | >

1.0pen the base CAD file. The terminals are in the %BLOCKS%\WireCAD Terminals path.
2.Modify the geometry and or attributes to suit.

3.Click File > Save As. Remember to keep the _S.DWG and the _D.DWG naming convention
intact.

4.0Open a drawing that you want to use your shiny new terminal in.

5.Refresh the Terminals tool panel. This will display your new terminal in the place terminals

galleries.
Poinit,[in drawing] to Terminal

& Length 400
et

L

4

#All groups

it T R TN R T WAt [

i

WC3_FN_JACK_SD
FULL NORMAL JACK 50

6.Click to use as any other terminal.

If the terminal needs changes you will have to do the following:
1.Delete all instances of the offending terminal insert from the drawing.
2.Click File > Purge.

3.Verify that your file name is in the purge blocks list.

4.Purge the drawing of unused entities.

5.0pen the base CAD file again and edit and save.

6.Repeat steps 4 - 6 above.

3.3 Plan View and Layout Tools Dialogs
Navigation: WireCAD PRO Manual| 41>

The following set of tools is targeted at the plan view space.
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3.3.1 Take Offs
Navigation: WireCAD PRO Manuall 8 > Plan View and Layout Tools Dialogs b >

Menu: Drawing > Plan View and Layout Tools > Take Offs
Default Commandline shortcut: showtakeoffs

Related Settings:

None

Often we need to count items in the plan view space for quoting or other purposes. The Take Offs
tool facilitates this process by filtering the drawing for specific entity types on specific layers then
counting those instances.

Possible Uses

e¢Quote preparation.
eTrouble-shooting.

Dialog Options
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Informaton:

oPrint - Print the grid.

esExport - Export the grid.

eLayer - What layer are we searching for the selected entity type(s).

oEntity Types - What entity type(s) are we searching for.

eGenerate - Do It! The results will be displayed in the grid.

eCount - Count the items in the list. The results will be displayed in the right-hand list.
*Grid Columns

ItemHandle ShowMe - Zooms to show the item in the drawing.

Block Name or Entity Type - obvious.

IgnorelnCount - Ignore me when counting.

3.3.1.1 How To: Pull a Take-Off from a Drawing
Navigation: WireCAD PRO Manuall « > Plan View and Layout Tools Dialogs| b > Take Offs[+sh >

1.0pen a plan view drawing.

2.Click Plan View Tools > Take-Offs.

3.Select the Insert check-button.

4.Then click [Generate]. This generates a list of all Inserts in the drawing.

5.Click [Count]. This counts the different inserts in the drawing. The results appear in the list on the
right.
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Infrmabon:

Now let's say we want to count all circles on the CEIL_SPKR layer.

1.0pen a plan view drawing.
2.Click Plan View Tools > Take-Offs.
3.Select the Circles check-button, and select the Layer on which to search.

L - o s

v Baoaed DafD 0 W o

Informaton:

4.Click [Generate]. This produces a list of all the circle entities found on the selected layer.
5.Click [Count]. This counts them and outputs the result in the right-hand list.
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3.3.2 Location Boundary
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As you can see we have 20 circles that appear on the CEIL_SPKR layer.

Navigation: WireCAD PRO Manual[ + > Plan View and Layout Tools Dialogs [ 15 >

Menu: Plan View and Layout Tools > Add Boundaries from Text
Default Commandline shortcut: DrawLocationBoundaryRectangle

Related Settings:

None

Used to define geometric boundaries for locations important to the design. For example we would
want to know where on the drawing the Machine Room is but not necessarily the kitchen (unless
part of our cable ends up in the kitchen).

Boundaries can be nested in other boundaries. It is common practice to create the Campus
boundary and then nest the Building boundary then the Floor boundary then the Room and Racks

boundaries.
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Location Boundary for the room ISO 111

Prerequisites
A plan view drawing.

Dialog Options
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eName - The location name.

eLocation Kind - You will need to tell us the kind.

eAutomatically Nest Locations - Default is true.

eBoundary Entity - Rectangle, Closed Polyline, Circle.

eShow Name in LineType - Renders the entity with the location name as the linetype.
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3.3.2.1 How To: Place a Location Boundary

Navigation: WireCAD PRO Manuall«) > Plan View and Layout Tools Dialogs[b > Location
Boundary| 154 >

Method 1
Use the selected text entity to populate the dialog.

1.0pen a plan view drawing.

2.Select a text entity that represents the location name of the location for which we will create the
boundary. This text will populate the dialog Name field.

3.Click Plan View and Layout Tools > Location Boundaries from Text.

4.Set the Location Kind.

5.Set the Boundary Entity.

6.Click [OK]. The dialog is dismissed and you are prompted to draw the boundary entity.

7.Draw the boundary.

Method 2

Manually populate the Name field.

1.0pen a plan view drawing.

2.Click Plan View and Layout Tools > Location Boundaries from Text.

3.Enter the Name.

4.Set the Location Kind.

5.Set the Boundary Entity.

6.Click [OK]. The dialog is dismissed and you are prompted to draw the boundary entity.
7.Draw the boundary.

3.3.3 Draw Cable
Navigation: WireCAD PRO Manual[ +$1> Plan View and Layout Tools Dialogs[1s5 >

Menu: Drawing > PlanView and Layout Tools > Draw Cable
Default Commandline shortcut: pwdc

Related Settings:

None

Product Level: ALL

This tool allows you to draw a cable in Plan View space that is assigned to the Cables table.

Related Topics:
Draw Cables| s31

Dialog Options
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Integrator Sheet

Signal Type » | Length

Uper 1 Liser2
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Cable No

[+ 4 Cancel

eCable Type - Select the Cable Type.

eSource Information - The source SysName is pulled from the drawing. You will need to select
the Src Pin and such.

eDestination Information - The destination SysName is pulled from the drawing. You will need to
select the Dest Pin and such.

o¢Other Stuff - Enter user information.

eCable No - Click the [...] button to generate a cable number.

3.3.3.1 How To: Draw a Cable in Planview

Navigation: WireCAD PRO Manuall «) > Plan View and Layout Tools Dialogs[ > Draw Cable /s
>

This tool allows you to draw geometry in the Plan View space that represents the path of the cable.
Prerequisites

1.SysNamed source and destination equipment placed in the Plan View space or:

2.Source and destination Location Boundaries placed in the Plan View space.

1.0pen a plan view drawing.

2.Click Plan View and Layout Tools>Draw Cable
3.Select the source SysNamed equipment.

4.Select the destination SysNamed equipment.

5.Place the points in the polyline to finalize the appearance.

3.3.4 Populate Cables
Navigation: WireCAD PRO Manuall «1> Plan View and Layout Tools Dialogs[1s51 >

Menu: Drawing > PlanView and Layout Tools > Populate Cables
Default Commandline shortcut: popc

Related Settings:

None

Product Level: ALL
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This tool pulls the cables from the Cables table into the drawing. The assumption with this tool is
that you will use it after you have done your functional drawings and assigned Cable Numbers and
SysNames.

Related Topics:
Draw Cables/ s

Dialog Options

@ : N

»" Group cables fromio same location into & sngle lne
Must connect o exdsling equipment: in the drawing

»" [gnore cables that come and go o the same location

»" Flag if ather end is not found

Py Bulge Factor 0.2

-

eGroup Cables - Place a single polyline with hash marks to indicate count. All cables that come
and go from a single Location or SysName will be grouped. Otherwise a single polyline for each
cable will be added.

Grouped Cable
eMust connect to equipment in the drawing - The population will fail if the connected equipment
SysName is not found. Otherwise the cable will be populated to the drawing based on Location
Boundary.
elgnore cables that come and go to the same location - Keeps the drawing cleaner.
oFlag if other is not found - If both Locations or SysNames are not found in the drawing a flag
will be placed pointing to the other end.
ePolyline Bulge Factor - The bulge factor to create an arc instead of a straight line.
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3.3.4.1 How To: Populate Cables in Planveiw

Navigation: WireCAD PRO Manuall«) > Plan View and Layout Tools Dialogs/+sb > Populate
Cables| 1>

Prerequisites

1.SysNamed source and destination equipment placed in the Plan View space or:
2.Source and destination Location Boundaries placed in the Plan View space.
3.Cable data in the Cables table that matches the placed equipment or locations.

Operation

1.0pen a plan view drawing.

2.Place Location Boundaries.

3.Place plan view equipment and SysName - Optional.
4.Click Plan View and Layout Tools > Populate Cables.
5.Click [OK].

i
E}a ° NG
- A1
|:1 Q
x 4
/ = -r:.
/T N
.......... 0 ] ‘ i
) o % ”;f o
: N
> X0 J Q\ J
E G; o 5 o ‘

h | i F
Planview Populate Cables

3.3.5 Draw Prewire

Navigation: WireCAD PRO Manuall «1> Plan View and Layout Tools Dialogs[1s51 >
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Menu: PlanView and Layout Tools > Draw Prewire Cable
Default Commandline shortcut: pw

Related Project Settings:

Automatically Consume Prewire Cables

Product Level: ALL

This tool allows you to draw geometry in the drawing that represents cables that have not yet had
their functions assigned. The only thing we know about these cables is the locations from which
they start and end and the Cable Type. A record will be added to the Cables table based on the
count defined. The record is marked Available and PreWIRE. Prewire cables can be automatically
consumed later if the Automatically Consume Prewire [se5) setting is checked.

Prerequisites
1.Source and destination Location Boundaries placed in the Plan View space.

Related Topics:
Draw Cables| 31

Dialog Options

Prewire Infa ®
Frewire cables works only if  Cabls Type: -
vou have added location yoe
Eeurdarieg b0 your plan view Signal Type: -

drawing. If you have added
Syshiames you can use tham  How Many?
a5 vl bt the localons are

ot optional. Count: =
2
Length Devsor; i? =
A Path o Mamed Patha Table
Makes Hamed Path
o Canced

eCable Type, Signal Type

eHow Many - How many wires of this type take this path. A record will be created for each.
eLength Divisor - We will divide the length of the polyline by this value and place that info in the
Length field of the record. For example, say your Drawing Unit = 1 inch and you want the length in
the Length field to be displayed in feet. Your Length Divisor would be 12.

oCreate Named Path - Create an entry in the Named Paths table with the name provided and
length of the polyline.

3.3.5.1 How To: Draw a Prewire Cable in Planview

Navigation: WireCAD PRO Manuall + > Plan View and Layout Tools Dialogs/ > Draw
Prewire | 159 >
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Operation

1.0pen a plan view drawing.
2.Click PlanView and Layout Tools > Draw Prewire Cable.

Prewire Info X

Prewire cables works only i Cable Type: -
vou have added location Yee:
Emradlaried b your plan vew Signal Type: -
drawing. If you have added
Syshiames you can use tham  How Many?
a5 wel but e loatons ane
rict opbonal. Count: 15
7
Length Divisor: i2 =
Add Path to Hamed Paths Table

Maie hamed Path

3.Fill in the form.

4.Click [OK]. This will dismiss the dialog and prompt you to draw a polyline.

5.Draw the cable path.

6.n Cables will be added to the project Cables table with a formatted number based on the project
Cable Number Format and the Next Numbers table.

7.The polyline length will be divided by the Length Divisor field and added to the cable record
Length field.

3.3.6  Populate Equipment
Navigation: WireCAD PRO Manuall 8 > Plan View and Layout Tools Dialogs b >

Menu: PlanView and Layout Tools > Populate Equipment
Default Commandline shortcut: pope

Related Project Settings:

None

Product Level: ALL

There is no Ul for this tool.

This tool pulls the Plan View version of the equipment from the Equipment List.

The assumption with this tool is that you will use it after you have done your functional drawings
and assigned cable numbers and SysNames.

This tool relies on the Plan View File in the device definition to know what to place.
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If the Plan View File is blank the Project Default Plan View File will be placed if the Location
Boundary is found:
Application Menu > Settings [Project][Basic][Default Plan View Block File]

Default Plan View Bock Fie: HRELOCKS YelPlan View \equipment 12x 12.dwg

3.3.6.1 How To: Populate Equipment in Planview

Navigation: WireCAD PRO Manuall +) > Plan View and Layout Tools Dialogs/+h > Populate
Equipment|+s1) >

Prerequisites

1.SysNamed equipment preferably with an associated Plan View File in the global Equipment
Library.

2.Location Boundaries placed in the drawing.

Operation

1.0pen a plan view drawing.

2.Place Location Boundaries.

3.Click PlanView and Layout Tools > Populate Equipment.

4.A message box will explain the operation of the function. Click [OK]. The tool will run.
5.At completion the tool will report the number of placed items.
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3.4 Reporting
Navigation: WireCAD PRO Manuall s81>

Menu: double-click the report in the Project Explorer or Click the report in the Reports > Reports
gallery
Default command line shortcut: none
Related User Settings:
Report Show Mode - Determines where the reports will be shown:
Project Explorer
Ribbon Menu Gallery
Both

Opens a report for preview, printing or export. Reports are designed to connect to the WireCAD
DataAccess object that provides access to the entire data model both Global and Project data.
There are four tabs presented when a report is loaded:

1.Preview - Shows the print preview that will be output to the selected system printer.

2.HTML - Shows the report rendered to HTML for use in web pages.

3.Design - Shows the report designer.

4.Cable Data Selector - Shows a selector grid for use with the ProjectCables collection. This grid
is not implemented for any other data collection.

Print Preview HTML Wiew Report Designer Cable Data Selector
~ 1 - -] — i | -

3.4.1 How To: Print Reports
Navigation: WireCAD PRO Manuall +$) > Reporting 1% >

1.Double-click the report in the Project Explorer or Click the report in the Reports > Reports
gallery.
2.The report will load in Preview Mode.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD PRO Manual

Run Sheet 11x17.repx - WireCADID -PRO - tSuite Demo Project] @ - x

HTMLView  ReportDesigner _ Cable Data Selector 263 L i

X
o -
o}

2 e @ KO 0D « PP aqa a B8 WireCAD
Save Print %:\:r Scale  Margins Orientaton  Size Find. g;gxe\ ::;«E Q ManyPages ZoomOut Zoom Zoomln | Page Color Watermark E;:c_wl EA:A?H 1re
Docum. Print Page Setup i Navigation Zoom Page Background Export. Close. »

MAGHINE_ROOM.dwg*™ # x | RunSheet 1ixi7repx # X
Project Explorer Q1 x ERETO 2

& 0 o8
e
Cable Run Sheet
Souree Destnation
Number | Souree s Comn Locaton Desination S Com Locaton Length Sheet SgTye CableType
AL00L VIROISMONL  VIRO! x roon 1102 LoxL o111 cswe s> rooiiod 0 MACHINEROOM AUD BELDEVAS01A
A-1002-  VTRO01>MONR VTRO01 X ROOM 1102 10XL-01>R1 QCSWR 37D ROOM 1102 0 MACHINE_ROOM  AUD BELDEN-1801A
ave
A003. VIRGSMONL  VIRO x RooM 1102 LoxLo1L2 s s> rooMiid 0 MACHINEROOM AUD BELDENAS01A
A1004 VIR0Z>MONR  VIRO2 x ROOM 1102 10XL015R2 QCSWR 37D ROOM 1102 0 MACHINE_ROOM AUD BELDEN-18014
A005. VIRGSMONL  VIROS x RoOM 1103 LoxL o113 cswr  sp Rooinod 0 MACHINERGOM AUD BELDEN-A501
ae

A006 | VIROS>MONR  VIRO3 x RooM 1103 LoXLo1RS swr 3D rooin: 0 MaCHINEROOM AUD BELDENASO1A
AL007.  VIROSSMONL  VIRO: x RooM 1103 LoxL o114 s s> rooiid 0 MACHINEROOM AUD BELDEVAS01A
A1008. VIRO4>MONR  VIRO4 x ROOM 1103 10XLO15RA QCSWR 37D ROOM 1102 0 MACHINE_ROOM AUD BELDEN-1801A
41009, |OROISCRL  OROL s 19 PAODL Past x 1001 0 EDITiAUDasg AUD BELDENAS01A
ALl ORNSRR  Omol 1 100 PacLR Paot x 1001 o EDIT1 AUDawE AUD BELDEN.1801A
AL01L PAOISR Paot X 1001 - ko2 B 10 0 EDITiAUDwg BN BELDENAS01A
Al PAMSL Paot x 1001 sPRaLI secor B 9 0 EDIT1 AUDawE BA BELDEN.1801A
A-1013-  O2R02>CRL O2R-02 14 110 PA02L PA02 X 1121 0 EDIT_2_AUDdwg AUD BELDEN-1801A

s Readony) |
Y X[ No AutoSave : MAGHINE_ROOM,
No AutoSave : MACHINE_ROOM dwg™ - Open Jo

e | ro. | wo. | QA | @6 || comand: (caaator: [< v

< >

3.Click File > Print and select a printer.

3.4.2 How To: Print Reports with Parameters

Navigation: WireCAD PRO Manuall «$) > Reporting[ 15 >

Parameters allow the report designer a way to collect input from the user before the report is
rendered.

Parameters may be used in the report for several purposes:

eReplace title and descriptive text.

eProvide data to filters.

eProvide data to scripts.

The report designer may force the user to submit parameter data or allow the report to render with
default data.
If the report has no parameters defined the Parameters menu item will be disabled.

1.0pen a report - Double-click the report in the Project Explorer or Click the report in the Reports
> Reports gallery.

2.The report will load in Preview Mode.

3.If the report has parameters the Parameters menu item will be enabled. If the report designer
determined the report must gather parameters first, the report will not render until you click the
[Submit] button on the Parameters tool panel.
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4.Enter parameter data.
5.Click [Submit]. The report will render with the submitted data.
6.Click File > Print and select a printer.

3.4.3 How To: Filter Reports
Navigation: WireCAD PRO Manuall «) > Reporting| 1% >

By default a report will query the database for all records in the selected collection. For example if
the report displays the project CablesCollection, all records will be displayed. This may or may not
be desirable. If you wish to filter the record set to show a specific set of records you have two
choices:

1.If the collection being displayed is the CablesCollection you may use the Cable Data Selector
tab and make a manual selection there.

2.0Otherwise you must create a filter.

1.0pen a report.
2.Switch to the Report Designer tab.
3.Locate the Property window. Make sure that the Property window is displayed. If not click: Report
Designer>Windows>Property Grid
4.From the Property grid object selector, select XRReport1

xtraReport1l Report W

5.From the Property grid select the data tab and then the Filter String [...] ellipsis button.
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Property Grid X

sirafepedt] Report W

-'-#I:I*.t

Cafodyted Felde | (Todkecnon]

Data Adapter o | i
Dusta Bhembes (e e w
Data Source brdrgiourae ] v B
I Fieer S | 1
Pargmaetens -:.'-F{f\-r'.fn. |
Teg
WML Dt Path
Filter Shring

Soecfies the riteria weed o f5er dats in 8 reoort,
1 Bepert Exgilrer -"l’ha-.—'.-a-c

6.This opens the filter dialog from which you may select a number of different filters.

FilterString Editor

And 3
[Available] | = Equals v P = ]
= Eguals
# Does not equal
> Is greater than
2 Iz greater than or equal to
< Iz less than
€ Isless than or equal to
£ Is between
4+ Is not between
1 Is Mull
- & Is Mot Mull
[Available]| gy 15 any of
&% Is none of
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7.Select a field to filter on.

Filtersbrmg I datar

Wmal | et
& mdali = | Equal
v slabie
Avadable Cornen
ot ekl b ool By e 1
Cable U
T 1
Cabie Mazh
Cabis Floy
Cable Mo Brols
Tl Pl b
Calle T Cancel
Table Tyoe Many

8.Select a filter operator.

Filteribrimg ['dibar

9.Enter a value.

Filterikrimg ['dibar

(2 4 Cancel

with V-,
11.Select the Print Preview tab to render the report with the filter.
How To: Filter a Report Using Parameters

10.Click [OK] to commit the filter. This filter with show only cables where the CableNo field begins

3.4.4

Navigation: WireCAD PRO Manuall 8 > Reporting| 1% >

Filters may also contain parameters that the user must enter before the report is generated. In
order to make use of this function you must follow these steps:

1.Add a parameter to the report while in Design view. Click the Parameters (...) ellipsis button
to view the Parameters collection.
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2.Click the [Add] button to add a parameter to the collection.

Parameter Colection Editor
P e e 1 :,:‘__ &l
Brhaviar -
el es
Dhata -
Al Mull NG
Description
Leok-Up Settings ha Lok -Uip
Multi-¥aie ho
Tag
Type Siring
‘W
Design -
Ehdame] paramseterl
Add e + +
[+ 3 Cancel

3.Enter description and default value information.
4.0Open the filter editor (see above)
5.Add a Field and Operator, then click on the icon to the right of the field to select parameters.
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FitérString Editor
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=3 Cancel

6.Select your parameter from the parameters list. Above we are selecting parameter1.

7.Click [OK] to submit the filter.

8.Now let's make sure that the parameters are submitted before the report renders. Set the
Request Parameters property = Yes.

Froperly L= & o8 =
wtralopoaitl Keport -
<1

Frapee il Samwdard LixiT

Pringes Pl
T Rl Paper -]
¥ Lnirg Setings ¢ (Lang Prmder Sot

P L
5 P
|(_- R P T -
=
* Buport Pring Op (Raport Prind Cpés
Faght b Laft Pl
e b L Ly P

Shems Print Mary Vi

Sl TS S5 T
Sraee
Barch [Collecticn]
Rttt Py amties
Spaes whe S B neport decument

reaton ki st e o B nepont
paramters are sbmtted

[ Romport Espiorer = paroaary Gl

9.Click the [Print Preview] tab to preview the report. You will see a Parameters pane on the
left hand side with a submit button.

10.Enter a value and click [Submit].

11.Select the print preview tab to render the report with the filter.
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12.Your report will be rendered with parameter1 applied to the filter.

3.4.5 Report Design
Navigation: WireCAD PRO Manuall «1 > Reporting| 1% >

Menu: Report>New Report with Wizard

Default command line shortcut: rw

Related User Settings:

Report Show Mode - Determines where the reports will be shown:
Project Explorer
Ribbon Menu Gallery
Both

3.4.5.1 How To: Create a Standard Report
Navigation: WireCAD PRO Manuall «1 > Reporting | > Report Design [+ >

1.Click Reports>New Report with Wizard.

2.Select the Standard Report option.
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Welcome to the Reports Wizard

- T meitiared will erbates & fatw HESot with data-Bourd controh
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& Sowwistd Report
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Caraed Bt >

3.Click [Next >].

4.Select a data collection. Data collections access both the global and project databases. For
example: say you wanted to show a list of all manufacturers. You would select the

GlobalManufacturersCollection.

Repot Wizard
Salect Data Collectson For Report _—

VereCAD erganies dats rho evther globsl or project data collections, Colectons (R
are Pesrarchicl. If you sre Teaing & cable label use e Cables oolecton e, (N

A

D

Cr v vimornlolector

D yweingnC ol fon

(i e T et e T

Gl oy C bl ool b *
. S

P S— -

Card o« Badi Fagait = Frugh

Note: collections are hierarchical to aid in the creation of sub-reports. All collections are populated
with data when the report is previewed.

5.Select the fields (columns) you wish to display in the report.
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6.Apply any grouping. Each set of records with the same value will become a "group" with its own
header.
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7.Select a Layout and Orientation for your report. The Adjust field width to fit function will force all
selected fields on to a single page possibly rendering some of the data unreadable. If you have
lots of fields to display, consider using a Justified report.
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8.Select a Report Style. There are several predefine report styles. You can always modify the
look and feel later.

Repot Wizard

What siyle would you o ?
The repar T it Seahe the appea ancs oF your ngort.

——
Camus

LT TR T T Compact
[ H Comorate

o Forma
1| Title

Caplion
(R ENTY
Carael < B et >

" e

9.Title your report.

Repot \Wizard

report?

MankReport

B report,

Cancel < Back

What title do you want for your

That's all % information Sw wizard reeds 1 Ceate your

10.Click [Finish] to create your shiny new report

b o W Rl ® X

BlankReport

Eivplay in Catda Typen Syl ik wbie Trprd

Manader toparambar M, (H10
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11.Click File>Save and save your work to your reports support path. It can be saved anywhere
in the %REPORTS% support path folder tree.

3.4.5.2 How To: Create a Label Report
Navigation: WireCAD PRO Manuall «) > Reporting[ ¢ > Report Design /[ >

1.Click Reports>New Report with Wizard.

2.Select the Label Report option.

Welcome to the Reports Wizard

Thin mcard wil creade & new repor £ welh Sabsbound confols
| o dackiy Aformaton fom the daleset you speafy
=

= Ok Mewt 0 confirue.

Bemart Troe
Snariard Report

# Labwl Raport

Laroe Pl =

3.Click [Next >].

4.Select a data collection. Data collections access both the global and project databases. Note:
In the case of labels we probably want to use the CablesCollection.

Repoet Wizard
Select Dty Collection For Plepart —
WrECAD prpaniZes dats P ey ghobal or project dets peleriors, Colectons T
e herarchical. I v ae crestng & cabie label use T Cobles cobecion et (I

AocourSnioColecion -
Boemie fasiCode 00N

Cancel « Back Maxt > Fruh

5.Select a label format. WireCAD comes stock with over 1000 label formats from 15
manufacturers including Panduit, Hellerman Tyton and Brady.
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6.Modify height and width of each label and its printable area and margins.
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8.Select the Field List and drag any fields that you wish to display on to the report design

surface. Avoid placing field on the light and dark gray areas. The light gray area will not print and
the dark gray is indicative of the clear laminating portion of a cable label.
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9.Here we have three fields that we have dragged and positioned on the design surface.

[Dhdczepamey Rl

[ akleCondunid
[De faunThapin

10.Final output looks like this:

11.Click File>Save and save your work to your reports support path. It can be saved anywhere
in the %REPORTS% support path folder tree.

3.4.5.3 Report Design Basics
Navigation: WireCAD PRO Manuall 8 > Reporting[ ¢ > Report Design |75 >

The following topic assumes that you have either opened a new blank report or that you have run
the New Report Wizard.
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If you open a new report without running the wizard you will need to set the report Data Member
variable.

Click in the dark gray area to load the general properties. Select the Data Member from the drop
down.
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< >

You can drag fields from the Field List directly to the report designer.

If you want to concatenate multiple fields in a single label you can drag multiple fields onto the
same label or edit it directly.
To edit a label double-click it to enter edit mode.

. - &,
ghl[SRCSys] =

Type directly into the label. Field names must be enclosed in [] brackets.
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3.5 Frequently Asked Questions
Navigation: WireCAD PRO Manuall s81>

3.5.1 How To: Place Custom Titleblocks (Page Borders)
Navigation: WireCAD PRO Manuall 9 > Frequently Asked Questions /751>

Menu: Basic CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: insert

Related Settings:

None

This tutorials assumes you have a custom titleblock in dwg format and that it occupies the Model
Space of the dwg file. Further that you know the path to the file containing the titleblock file.

1.0pen the drawing where you want to place a custom titleblock.
2.Switch to the Layout in which you intend to place your custom page border.

Model Layout2 PAFER SPACE ANEL & 117

3.Click CAD Tools>Blocks and Inserts>Insert Block into Drawing.

] Insert Biock * IEEN
EE 0 5T e e 1]
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=
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o Spally Lister Spoaily Later Spcaily Later

Imppr It Carcal

4 Select [Browse].

5.Browse to the dwg that contains your custom title block in the Model Space.

6.Check Insertion Point - Specify Later. This will let us manually place the inserted block
in the layout space.

7.Uncheck Scale - Specify Later and set the X,Y,Z scale to 1.

8.Uncheck Rotation - Specify Later and set the Angle to 0.

9.Click [Insert It].
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10.The dialog will be dismissed so you can drop the insert in the drawing space.

11.Now you will need to place a Viewport so you can see the model space.

12.Click View>New Viewport and select the logical boundaries of the viewport within the
titleblock you placed earlier.

it o =
- L P

-

13.Double-click the viewport to activate it for zooming and panning and use the mouse wheel or
zoom commands to position the viewport over the model space.

3.5.2 How To: Create Custom Titleblocks
Navigation: WireCAD PRO Manuall «) > Frequently Asked Questions 751>

Menu: CAD Tools>Blocks>Insert Block Into Drawing
Default command line shortcut: insert

Related Settings:

None

1.Create a new drawing with no template.
2.Draw your titleblock in Model space scaling it 1:1 with your printed page size, ie an 11x17
page border would be 11x17 minus your margins.
3.Place any images and attribute definitions.
4.Save the drawing.
5.Follow the steps here[+7 for placing your title block drawing in any other drawing.
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3.5.3  Moving Projects (Pack Up/Check-Out)
Navigation: WireCAD PRO Manuall + > Frequently Asked Questions [+ >

Menu: Application Menu > Project Utilities>Packup / Check-out
Menu: Application Menu > Project Utilities>Unpack

Menu: Application Menu > Project Utilities>Check In

Default command line shortcut: packup

Default command line shortcut: checkinproject

When moving projects from machine to machine there are external items upon which the project
depends. These are referred to as project and drawing dependencies. The main project
dependency is the global equipment database. Drawings may have image, Xref, and font
dependencies. When we Pack Up a project we are grabbing all of those dependencies (fonts are
and exception and are not included) and placing them in the Project folder. We may choose to
Check Out the project at the same time. This flags the project as read only until such time as the
project is Checked In.

Once Packed Up and/or zipped up you are ready to move the project to another machine. Simply
copy the Project folder or the zipped file and move it to the new machine. Then use the Unpack
function.
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To Unpack or Check In - That is the Question

The two functions are practically identical with the exception that the Check In function won't
launch without an active project and once unpacked will mark the active project as Checked In.
Whether you Unpack or Check In a project depends on whether you are moving a project to a
machine on which that project already resides and whether you have Checked Out the Project.

If you have not Checked Out the project then there is no need to Check In the project.
If you are moving a project to another machine, use the Unpack function.
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3.5.3.1 How To: Packup/Check-out

Navigation: WireCAD PRO Manuall +$1 > Frequently Asked Questions [+751> Moving Projects (Pack
Up/Check-Out)| 111 >

Decide whether you are going to Check Out the project before starting.

1.0pen the project to Pack Up/Check Out.

2.Click Application Menu > Check In/Out > Pack Up/Check Out.

3.Click [Next] after reading the explanatory text.

4.If you opt to Check Out the project you will be prompted to enter an Expected Return Date. This
will let anyone opening the project subsequent to its Check Out who checked it out and
approximately when it will be back. In the mean time it will be opened READ ONLY.

5.1f you opt to Compress Output the final operation will be to create a zipped file of the project
folder and place it in the FileName and Path location.

6.Click [Next]. You will be presented with the progress page.

7.Click [Finish].

3.5.3.2 How To: Check In a Project

Navigation: WireCAD PRO Manuall «$) > Frequently Asked Questions -5 > Moving Projects (Pack
Up/Check-Out)| 1811 >

To Check In a project you must first have the project that we are checking into open.
The incoming project should be in a file location that is not the current project path.

1.0pen the project into which we will check in the incoming project.

2.Click Application Menu > Check In/Out > Check In Project.

3.Click [Next] after reading the explanatory text.

4.Browse to the incoming project's .wpi file by clicking the [...] ellipsis button.
5.Click [Next]. This presents the progress page.

6.Click [Finish]. Wait for the process to finish.

3.5.3.3 How To: Unpack a Project

Navigation: WireCAD PRO Manuall «) > Frequently Asked Questions 51> Moving Projects (Pack
Up/Check-Out)| 1 >

To Unpack a project you must not have an open project.
The incoming project should be in a file location WILL BECOME the current project path.

1.Close the current project if any.

2.Click Application Menu > Check In/Out > Unpack Project ...

3.Click [Next] after reading the explanatory text.

4.Browse to the incoming project's .wpi file by clicking the [...] ellipsis button.
5.Click [Next]. This presents the progress page.

6.Click [Finish]. Wait for the process to finish.

3.5.4  Synchronizing with Another Equipment Database
Navigation: WireCAD PRO Manuall +) > Frequently Asked Questions [+ >

Menu: Database>Synchronize Global Database ...
Default command line shortcut: sync
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Related Settings:
None

Occasionally you may experience the need to sync with another user's global database. This will
copy all of their equipment to your Global Equipment Database. The sync includes manufacturers,
equipment, inputs, outputs, signal types, connectors, cable types, cable core data, relational tables,
etc.

You may choose within the tool to perform an import, export or bidirectional sync.

Demystifying Synchronization

Synchronizing data in two tables of the same structure is really very simple. In its most basic form,
records that do not exist in one table are added. Records that exist in both tables receive the most
current data based on a time stamp. In order that records deleted from one table do not get added
back in, a special table is employed to track deleted keys. If the delete is the most current action
then the record will likewise be deleted from the other table. In the unlikely event that the records
have the exact same time stamp, yet the data is different, those records are flagged as conflict
records from which you must pick the most correct.
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Advanced tab
eDatabase Location - Select either a VistaDB file based database or a SQL Server host. If server
based you will need to provide host and credentials. If you do not know them contact your SQL
Server database administrator.
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eImport, Export, Bidirectional - Sync direction. Our current global database is the reference. An
Import will import records into our current global database.

eRemember Settings - Remember database location information.

eSync - Initiates the synchronization with the top progress bar showing the overall progress and the
bottom showing detail progress.

eStatus Bar - Displays status of the sync.

eAdvanced Tab - Select the collections to be synchronized.

3.5.4.1 How To: Sync Equipment Databases

Navigation: WireCAD PRO Manuall +) > Frequently Asked Questions[+8 > Synchronizing with
Another Equipment Database| 5 >

Remember that the Sync Direction is with respect to the current Global Database.

1.Click Database > Synchronize Global Database ...

2.Browse to the remote WireCADGlobalEquipment.vdb3 file or enter the SQL host and login for the
other SQL server.

3.Set the Sync Direction.

4.Click [Sync].

5.Wait for the process to finish.

6.When done you will be presented with a status report. Examine it to make sure that all collections
synchronized properly.
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3.5.5 Setting Up On a Network
Navigation: WireCAD PRO Manuall +) > Frequently Asked Questions [+ >

What follows is a discussion of several different network topologies and work flows that WireCAD
can employ. Regardless of topology or work flow, the following steps should be taken for each
WireCAD machine. For purposes of this discussion, we will distinguish between a Windows user
(operating under group policy or not) and the WireCAD user. The Windows users will be referred to
as OS users. WireCAD users will be referred to as WC users.

1.Install WireCAD

2.Create a network share that is visible to all WireCAD users. Group policy for the OS user of
WireCAD should allow the user to read and write the registry (restriction of the registry editor is
acceptable), as well as, read and write files on the selected shares, the WireCAD9 folder on the
client machine, the OS user's temp directory, the OS user's All Users documents and settings folder

trees.
3.Pick one WireCAD client machine from which to copy the global databases and copy from ...
\WireCAD9\WireCADGlobalEquipment.vdb3 to \

\YourNetworkShare\FolderForWireCADGlobalDatabases\WireCADGlobalEquipment.vdb3
4.Launch WireCAD on the client machine.
5.Click Application Menu > Settings{Support Paths}
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6.Modify the support paths for the Global Equipment database, and any blocks or reports that you
wish to share among all users.

7.Click [Done] and relaunch WireCAD.

8. Click Application Menu > Security>View Permissions. If you are an administrator or rather if
your WireCAD identity is that of an Administrator, you will have edit abilities on this grid.

9. WireCAD uses your Windows groups. You assign permissions to the group. The current user
Identity is set to the group thus determining their access level.

3.5.6  Upgrading from V9
Navigation: WireCAD PRO Manuall « > Frequently Asked Questions 751>

If you are upgrading from v9 you will need to take the following steps:

1.Install WireCAD v10

2.Setup your global databases (file based or SQL Server)

3.Click Database > Sync Equipment Libraries

4 .Click the ellipsis (...) and enter the path to the v10 WireCADGlobalEquipment.vdb3 file or set the
SQL Server Host info.

5.Click the Import radio button.

6.Click [Sync] to sync the two databases.

7.Next convert any projects that you want to work with in v10

8.Click  Application Menu >  Open Project and browse to your v10
<YOURPROJECTNAME>.wc6plf file. WireCAD will open and convert the project. When WireCAD
converts projects no drawings are touched. The database schema is modified.

Note: this may take some time

WireCAD can no longer upgrade a v5 or earlier project. Key data access
components needed to open and import data from the Microsoft Access
databases are no longer available for modern 64bit operating systems.

If you need to bring a v5 or earlier project forward we recommend using a 32bit XP
virtual machine with WireCAD V6 installed. Convert the project to v6. Then open it
in v10 once converted.

We offer this service if you get in trouble. Call us.

3.6 Choosing a Database Format
Navigation: WireCAD PRO Manual| 51>

WireCAD v10 PRO and CMS allows the use of file based and server based databases for the
project and global databases. The choice of which to use requires some forethought. Listed here
are some basic considerations:

SQL Azure SQL Server VistaDB (File Based)
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Zero Administration X

Portable X

ACID Compliant X X X
(atomicity,

consistency, isolation,

durability)

Database Size 2 Gig Theoretically unlimited || Theoretical limit is 16

Exabytes (uint64).
Practical limit is based
upon machine
resources. Files are
not limited by the
database engine, but
loading very large
databases will require
large system
resources.

In Process Processing X
Cloud Based X

At first glance that the table above it would seem that the proper choice would be the file based
solution. However, take note of the item - In Process Processing means that the WireCAD
processes must read and write all data to and from the file based database. Using SQL Server
allows us to hand those processes off to the database server creating, in many instances, a
significant (read 10X) increase in speed.

Before selecting a database format consider the following questions:

sWill | be moving the project from machine to machine? If yes, consider staying file based on the
project.

eDo | have the chops to manage a SQL Server? If no, stay file based. SQL Server requires care
and feeding.

eAm | away from my network when | work on WireCAD projects? If you lose connection,
WireCAD will become hampered.

eDo | really need the speed enhancements? If you are working on projects with hundreds of
thousands of cables, SQL Server is a must.

When you move a project using the Application Menu > Utilities>Pack Up/Check Out
function and you are using SQL Server databases, the database is converted to a file based
version and will remain file based from that point forward.

To set up SQL Server see herelsh

Need help with SQL Azure? Contact us we can help.
3.6.1 How To: Setup a SQL Server

Navigation: WireCAD PRO Manuall «1 > Choosing a Database Format/1eh >

It is not within the scope of this manual to provide an in depth discussion of SQL Server. We will
touch on the basics required for use with WireCAD.
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The WireCAD distribution includes SQL Server database files for the Global Equipment database.
You will need to attach these to the running server. You will then configure WireCAD to look at the
SQL Server for the Global Equipment database. WireCAD projects will create a new database
(catalog) for every new project.

You will need to set up permissions for each user to allow them dbcreator privileges. This is
the default for localhosts but not remote servers.

SQL Server can be set up on a server or on a local machine. WireCAD requires the 2005 version or
newer and can use the Express versions.

SQL Server does not provide a graphical user interface so you will want to download the SQL
Server Management Studio Express as well. Both are free.

The following assumes that you are installing WireCAD on a local machine. If you are installing on a
server you will want to copy the global database files in Step 6 below to the server before you
attach them to the server.

1.Install SQL Server. You can download from the following links:
https://www.microsoft.com/en-us/download/details.aspx?id=21844

Be sure to download SQL Server Management Studio Express as well. Both are free.
http://www.microsoft.com/downloads/details.aspx?FamilylD=c243a5ae-4bd1-4e3d-94b8-
5a0f62bf7796&DisplayLang=en

2.You will be prompted for an instance name. Instance names allow you to have multiple SQL
Servers running on the same machine. In addition you will be prompted for a security mode
(Windows or SQL), Windows uses your Windows users and groups, SQL ignores these and allows
you to manage different users and groups from within SQL Server.

3.Install SQL Server Management Studio(SQLSMS).

4.Launch SQLSMS and log in to the server. If the server is on your local machine you can use the
shorthand [\INSTANCENAME] (eliminate the square braces) for the Localhost.

5.Setup a proper login for WireCAD. You may elect to use Windows logins or not. It is beyond the
scope of this manual to describe the pros and cons of each authentication method.

6.Attach the WireCADGIlobalDatabase.mdf file to the server.

7.You will now need to configure each WireCAD client to look at the SQL Server

8.Launch WireCAD.

9.Click Application Menu > Application Setup and follow the steps for SQL Server.

See Also

www.wirecad.com/wiki search SQL Server

msdn.microsoft.com search SQL Server

3.7 Included Plugins
Navigation: WireCAD PRO Manuall 451>
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WireCAD includes a number of Plugins that provide additional functionality.

Each plugin will load and register its own command line commands if the plugin provides command
functionality.

For information on customizing WireCAD with your own Plugins see the SDK /s documentation and
the SDK samples.

3.7.1 Pinouts
Navigation: WireCAD PRO Manuall <) > Included Plugins| st >

Menu: Database>Pinouts
Default command line shortcut: po
Related Settings:

None

The Pinout utility serves two functions. The first is to generate pinout detail drawings.

[¥]) T [X] - BELDEN - Test Phase REvarsal

The second is to generate data that can be used in the conductors table under any cable that we
wish to attach the data to.
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3.7.2  Find and Replace
Navigation: WireCAD PRO Manuall «8 > Included Plugins|sh >

Menu: View>Tool Panels - Find
Default command line shortcut: none
Related Settings:

None

The Find and Replace tool window allows you to search all of the data collections and drawing. You
may then replace found text with that of your choosing.

The Find and Replace tool shows you the context in which the text was found. You can select from
the results list which items to replace.

S Ol Il S L+ TR
Fumt o Lol cd

i Fed

oFind - The text to search for.

¢[X] - Clear the Find text.

eSearch Active Drawing - Only look in the active drawing.

eSearch All Project Drawings - Search every project drawing.

eShow File - Show file name if any of the context in which the item is found.
eShow Item Type - Is it a text entity in a drawing or a field in a database.
o[Select All] - Selects all items in the results window.

o[Clear Selection] - De-selects all items in the results window.
eReplace With - The text to replace the found text with.

o[Replace Selected] - Initiate the replacement.

e[Cancel] - Cancels the current search.

o[Find] - Initiate the search.

3.7.2.1 How To: Find and Replace a Port Name
Navigation: WireCAD PRO Manuall 1> Included Plugins[h > Find and Replace|sh >

In this section we will discuss the finer points of finding and replacing text in WireCAD blocks.

Before You Start
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When you see a WireCAD block in a drawing it is referred to as an Insert. WireCAD blocks employ
Attributes to display the text values you see. These Attributes are editable. For every port you see
in a WireCAD block there is at least one invisible attribute at the connection point. This attribute
contains a pipe | delimited string formatted as:

PORTNAME|SIGNALTYPE|CONNECTOR

In addition to the connection point attribute there may be a Port Name display attribute.

If you change the display attribute WITHOUT changing the connection point
attribute you WILL have grief later. So ALWAYS changed both the display attribute
and the connection point attribute concurrently.

1.Let's say we want to replace spr 1n on our device with spr v a. Further that we have assigned
cable numbers to the port in question. We will only look in the active drawing so click the
appropriate radio button.

2.Enter sp1r 1n in the Find field and click [Find]. Wait for it....
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3.Notice that we have two attributes and a cable all associated with the port SDI IN. If we don't
change all of these we will have data integrity issues later.
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4.Click [Replace Selected].
5.Done.

3.7.3  Translation Manager

Navigation: WireCAD PRO Manuall 81 > Included Plugins| b >

Menu: Plugins>Translation Manager
Default command line shortcut:
Related Settings:

None

All strings in the application are stored in a dictionary with a key and current culture translation.
The translation utility provides a means by which all strings, captions, and messages may be
translated to a different language.

You can right-click a column header and select the KeyString column to see the base English string
that the program searches from.

Controls
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WireCAD.ucDranCables. simpleButton5. Text
WireCAD.ucDranCables. gePrefs. Text
WireCAD.ucDranCables layoutControlGroup 17.Text
WireCAD.ucDranCables.raManyToManyDb, Text
WireCAD.ucDranCables layoutControl3. Text
WireCAD,.ucDrawCables. layoutControlltem31. Text
WireCAD.ucDranCables layoutControlltem22 Text
WireCAD.ucDranCables layoutControlltem24, Text
WireCAD.ucDranCables.geSrc. Text v

Here we see the Translation Manager with
the English version on the left and the French version
on the right. The pane on the right-hand
side shows statistics.

eCurrent Culture is: - The culture of your machine. If no translation exists, WireCAD defaults to
the en (English) language.

eSelect Language To Translate - Selects the language to edit in the right-hand column.

eShow Context - Select to display a column showing the primary context in which the string or
message appears.

3.7.3.1 How To: Translate a Form Caption

Navigation: WireCAD PRO Manual[ +1 > Included Plugins[+sh > Translation Manager|+sh >

Here we will use the Translation Manager to change the User1 field on the SysName Assignment
dialog to display Serial Number.
We are starting with:
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1.Click Plugins > Translation Manager.
2.Enter sysnaneuser1 in the KeyString filter field.

WireCAD v10.1 User Manual

© 2025 Holbrook Enterprises, Inc. - WireCAD




WireCAD PRO Manual

Start Page x: EDIT_1_VID.dwg X | Translation Utlity = X

Current Culture 2 en - Englsh {Urited States) Sedart Languags to Tra
= ek '
Keysiring
% | sysnameuser 1 |
o CyslamelGer T User1
Syshamellser 10 Syshamellser 10
Syshamelzerll Syshamellzerll
SysMamellser 12 SysMamellser 12
3.Change user1 t0 serial number in the en field.
St mge W | O vELeg N Trsion SRy B OE
T Ta—— By g Eraalons [0 -l i =

T 1 B T A

4.Click File > Save.

5.Now let's check the result by showing the form.
6.0Open a drawing with a functional block.
7.Double-click a block.
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3.7.4  Block Extractor
Navigation: WireCAD PRO Manuall +8) > Included Plugins| b >

Menu: Plugins>Extract All Blocks
Default command line shortcut: exall
Related Settings:

None

Requires an active drawing.
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eExtracts all blocks in the current drawing to the folder of your choosing.

Browse For Folder 4

v | CMS MCC Project Files |
M5 IMCC
CMS Mashyille Praject
CMS PDFS
ForWireCAD
Global Database
GLOBAL DB 3¥NC
hide

wscrenrote | [ o ][ e

eFiles are written out of the drawing as individual dwg files with the name of the block.
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eThe basepoint of the drawing (origin) is the insertion point of the block.
3.7.5 Bulk Block Fixer

Navigation: WireCAD PRO Manuall «$) > Included Plugins| s >

Menu: Plugins>Bulk Block Fixer
Default command line shortcut: blkf

The Bulk Block Fixer utility provides a means by which dwg files may be easily converted for use
with WireCAD. The fixer will convert a single drawing or all drawings in a folder.

Bulk Block Fixer Dialog

&1 Buk Biock Focer Converter T HIEN

Hodifies block files 5o that they have the comrect ongin point for working with the Rack Builder tool and the Equipmeent Library, Use this tool
en manulsciurers fromt panel dwy e and cn costom shape files for the bbrary.

+ Buil Carnoart All Fled in Folder
Buil Cormeert Pty

Baenenaanit PosSon

Sy
» Dewt Mg 0 D't Seuie Sl i o on
Movve Al Enfities bo Lower Left Basepoint (For Rack Front Panels) Seake Inches by mm Scake mem b Inches
Move M Enfibes to Cervier Basepont (For Shape Pies) Scale Inches bo am Scale om bo Inches

Ireneleerd e [ Afes anoe
A WreCAD Attribestes (makes block double -chokabie]) Don't Do Thes Por Shape Files Oniy Rack Panels
Create Boursling oo (geod for shape fes) (=]
Ciopry Feoed ok o WireCAD Drectones
& Dont Copry
Copy o D _Bevabons Folder in the WBLOO0S% Support Fath
Copry it Shapss Fles folder in the “BLOOSY, Suppart Palh

[+ 4 Carmoel

eBulk Convert All Files In Folder - Checked performs selected options on all files in selected
folder.

eBasepoint Position -
Don't Move - Do nothing.
Move All Entities To Lower Left Basepoint.

Before
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After
Move All Entities To Center Basepoint

0
.-'. —

o Before
-‘f.
!I. o

o After

eScaling - Scales all drawing objects based on the selection.
eIntelligence/Appearance
Add WireCAD Attributes. - Use this function to add the standard WireCAD attribute set to the
dwg file. This makes inserted items double-click-able. This is not required, and should not be used,
if you are using the dwg file as a DWGIcon or Custom Shape file.
Create Bounding Box - Creates a rectangle around the entities in the dwg file of the color
selected. This is useful for DW Glcons or Custom Shape files

«Copy - Copies fixed block files to the selected directories. \Subfolder and Prepend allow you to
modify the location and filename upon copy.

3.7.5.1 How To: Use a Manufacturer Front Panel

Navigation: WireCAD PRO Manuall +8) > Included Plugins|[ b > Bulk Block Fixer/[ 15 >

1.0Obtain the manufacturer's front panel dwg file.

2.0pen the file in WireCAD and delete anything that is not related to the front panel view.
3.Close the drawing.

4.Click Plugins > Bulk Block Fixer ...

5.Uncheck Bulk Convert All Files in Folder.

6.Click the Single File Path [...] and browse to the manufacturer's front panel file.
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7.Select Move All Entities to Lower Left Basepoint.
8.Select Add WireCAD Attributes.

9.Click [OK].

10.0Open the Equipment Library.

Soabe mm o om
Scale mm i Irches
Ceale o o bnches

Prpend iz flerame

11.Find the equipment that we want to use our shiny new front panel

12.Set the Front Panel File to point to our file.
13.Click File > Save.
14.Now you can use it.

3.7.6 Batch Plot

Navigation: WireCAD PRO Manuall «1 > Included Plugins| b >

Menu: Plugins>Batch Plotter
Default command line shortcut: bp
Related Settings:

None

The Batch Plot plugin allows you to select any number of layouts to print from project drawings.
The first step is to click the [Rescan] button. This populates the list with all drawings and layouts.
The Plot This checkbox determines which layouts to send to the printer.

The [Plot/Print] button is the same as the File>Plot/Print menu command and sends all selected

layouts to their respective printers.

The [UP] and [Down] buttons move the selected layout up or down in the list thereby reordering

their output order.

If you want to delete a layout. Select the layout in the list and click the minus [-] button in the

navigation window in the lower left hand corner of the grid

Clicking the [Preview] button will preview the selected layout in the Preview Pane regardless of

whether it is selected to in the Plot This column
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What it Does

eBatch Plot lets you select the drawings and layouts that you want to send to the printer and print
them as a batch.

eYou may print any layout in any drawing in the current WireCAD project.

eYou may also specify how many copies and in what order to print.

eBatch Plot allows you to save Batch Plot files for reuse at a future time.
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What it Doesn't Do

eBatch Plot does not print project reports.
eBatch Plot does not collate layouts with multiple copies set.

Controls

eFull Preview - Render actual output. Otherwise show margin box.

ePreview On Plot - Render the full preview (full or not) on output to the printer/plotter.

eUse Layout Settings - Ignore the Batch Plotter settings and use those stored with the drawing
layout. Selecting this disables printer, paper, and margin settings in favor of those in the layout.
ePaper - Printer paper size. If this dropdown is empty, select a printer first.
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eMargins - Set your margin unit of measure first, then the left, right, top and bottom.

eBlack and White - Output in black and white.

eScale to Fit - Force all entities in the selected layout onto the page.

eExtents - Print the extents of the layout.

eLandscape - Landscape output.

eSelect Printer - Choose the printer that all selected layouts will be sent to.

eNew Batch Plot File - Creates a new file scanning the project drawing set and adding all drawing
and all layouts.

*Open Batch Plot File - Opens a saved Batch Plot file.

eSave - Saves your settings to a Batch Plot File. This is helpful if you change the default order of
the list or the number of copies, etc.

eSave As - Save your setting as a new file name.

*Print/Plot Selected - Prints the selected (Plot This) layouts to the printer settings determined in
the layout. So be sure to Print Preview (from the drawing layout) your layouts first and set up all of
your output settings.

eExport Multipage PDF - Output the selected (Plot This) layouts with the selected printer settings
to a multipage PDF document.

eCancel Queue - Stops the function. Does not purge any print jobs already in the windows print
queue.

oExit - Done.

eRescan - Clears the list and re-scans the project drawings for all layouts. This function is like the
File>New function but differs in that it does not create a new file name.

eAdd Drawing - It may be desirable to keep all of your settings and add an additional drawing to
the list.

eRemove Layout - Removes the selected layout.

3.7.7  Archive Project
Navigation: WireCAD PRO Manuall <) > Included Plugins| s>

Archiver %

This function copies the project to a folder Named:

C:\Users\chris\Dropbox\My PC (DESKTOP-CMEH4KP)\Desktop\News Production Control Demo\Hews Production Control Room Demo\Archived Projects
50L databases are converted to VistaDB databases.

50L Projects are archived as VistaDB projects.

Both your project and global databases are archived.

Archived projects are a complete Packed-Up WireCAD filebased project.

Archived Projects can be restored using the Application Menu>Check In/Out>Unpack or Check In.

The drawings in the Project\Archive\ folder are ignored.

You will have the opportunity to modify the CurrentProjectRevision.
Canceling the New Project Revision dialog continues the archive without medifying the CurrentProjectRevision,

‘ou will NOT be prompted to enter the name for the new archive

The settings that contral the behaviour are in your Settings dialog under [Project][ Archive Settings]

Continue?

Menu: Project>Archive Project
Default command line shortcut: ap
Related Settings:

None
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The Archive tool copies all of the project data except the drawings in the Project\Archive folder to a
new folder. The tool can also create a new CurrentProjectRevision at the same time.

The archived version of the project:

+Copies the drawings and databases.

¢SQL databases are archived as VISTADB databases.

oGlobal and Project databases are included.

eThe Project\Archive\ drawings folder is ignored.

«Gives you the choice to increment the CurrentProjectRevision [s:h.

The associated settings panel controls:
eThe Archive path.

eThe Archive name.

eAutomatic naming or user involvement.
eCurrentProjectRevision inclusion.

The output of the archive tool creates a Packed-Up Project that can be unpacked or checked-in.
Restoring an archived project can be done using the UnPack function or the Check-In function.

Related Topics:
Project Archive Tool Settings/s%

Unpack Project/s3b)
Check-In Project 335

3.8 Project Rules
Navigation: WireCAD PRO Manual| +s1>

WireCAD 10 allows you to define project specific rules.

There are four contexts in which rules will be evaluated. Rules are contained in the Project Rules
grid.

Rules can be enabled/disabled by use of the Project>Settings[Project Rules] Enable Project
Rules setting.

A Rule consists of:

1.The Expression to evaluate.

2.The Context in which to evaluate the expression.

3.The ExecutionOrder. If multiple rules are defined to evaluate within the same Context they will
be evaluated in the ExecutionOrder order.

4.A Description of the rule.

Rule Contexts:

1.AssignCableNoAssignBeforeEdit - executed during a new Cable Number Assignment or
existing Cable Number Edit before the dialog is shown.
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2.AssignCableNoAssignAfterEdit - as above but after the user has clicked Save on the dialog or
if Verbose Cable No Assignment = false then during the Cable save process.
3.AssignSysNameAssignBeforeEdit - executed during a new SysName Assignment or existing
SysName Edit before the dialog is shown.

4.AssignSysNameAssidnAfterEdit - as above but after the user has clicked Save on the dialog or
if Verbose SysName Assignment = false then during the SysName save process.

Example

Let's assume that you have the following requirements:

1.SDI SignalType where the Length > 100 should use a different CableType than the default defined
in the Project Signal Types Default Cable Type grid.

2.We want to modify the connector type from BNC to KINGS 2065-10-9 if the CableType is 1694

For requirement number 1 we will create a new rule as follows:

eContext - AssignCableNoAssignAfterEdit. We use this so that we can get the Length from the
user.

oExpression - (SignalType 'SDI' && Length >=100) then set CableType = '1694'

eDescription - My First Rule. Change cable type for SDI if over 100. This is descriptive text for you
and your team. It can be whatever.

eExecutionOrder - 0. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0
will not execute.

For requirement number 2 we will create two rules as follows:

eContext - AssignCableNoAssignBeforeEdit. We use this so we can see our changes in the edit
dialog.

eExpression - (srcconn = 'BNC' s& CableType = '1694') then set SRCConn = 'KINGS 2065-10-9:
eDescription - BNC to Kings

eExecutionOrder - 0. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0
will not execute.

oContext - AssignCableNoAssignBeforeEdit. We use this so we can see our changes in the edit
dialog.

oExpression - (DestConn = 'BNC' && CableType = '1694') then set DestConn = 'KINGS 2065-10-
9'

eDescription - BNC to Kings

eExecutionOrder - 1. Rules execute in the order specified. Any Rule with the ExecutionOrder < 0
will not execute.

3.8.1  Expression Syntax
Navigation: WireCAD PRO Manuall +8 > Project Rules [20% >

(true part [ boolean other true part ]) then set SomeProperty = 'SomeStringValue' [else set

SomeProperty = 'SomeOtherStringValue']

syntax in [] is optional

Description Syntax Example

Single part, (1=1) thenAgsume the property we want to test is the SignalType field and if
set

boolean that sets| v, e rtyna | true then change the CableType to equal 1505
me = (SignalType = 'SDI') then set CableType = '1505'
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i 'strin

a property if true vzlue,g
Multipart boolean 2(:} i}&len Assume the property we want to test is the SignalType field AND the
AND that sets a s+ Length field and if true then change the CableType to equal 1505
propeﬂy if true PropertyNa | (SignalType = 'SDI' && Length > 100) then set CableType =

me = '1505A"

'strin

vzlue'g
Strings 'some

string
Numbers 1001
Boolean AND && this and that then (1=1 ss 2=2) then ...
Boolean OR I this or that then (1=1 || 2=2) then ...
Equality =
Test Null is null (SomeProperty is null) then ...
Set a Property set (1=1) then set NumericPropertyName = 1000 O (1=1) then set
(Assignment) rE[’éoEertyNa StringPropertyName = 'string value'
Wildcard  (any|® Used in conjunction with the 11k operator (cableType LIKE '1505%")
from here) then ... Will evaluate to true for any value that starts with 1505
Wildcard  (any|? Used in conjunction with the 11xe operator (cableType LIKE '15052')
one) then ... Will evaluate to true for any value that starts with 1505 and

has one and only one additional character.

Limitations

This syntax has no block structure. If you need to execute multiple set property operations you will
need to create multiple rules.

[llustration

The following is NOT supported:

(true) then

something;

something else;

some other thing;

else

another thing
or another thing

Consider creating a plugin in the SDK if you need to create very complex rules. There is a Project
Rules Events project template to use as a prototype to get you started.
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4 WireCAD CMS Tools Manual

The WireCAD CMS tools are built upon and extend the WireCAD
PRO tool set for the documentation of large scale management of
the fiber systems.

This section pertains to the CMS product level.

4.1 CMS Tools Concept
Navigation: WireCAD CMS Tools Manual|208) >

WireCAD v10 with CMS tools has introduced the ability to work in a different manner from previous
versions of WireCAD.

The standard work flow for WireCAD users has been to create your Functional Block Diagrams
first, then assign SysNames and Cable Numbers and lastly, generate reports based on this
information.

WireCAD v10 CMS allows you to start by entering your SysNames and Cable Numbers into the
Database first, create Backbones and Circuits and then generate a Functional Block Diagram
based on the information set in the Database.

The CMS tools work on a declare then visualize approach. You tell the database that the thing
exists and WireCAD provides different ways to visualize the data in the database.
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If the database item of interest is a fiber patch panel you can visualize all connections to and from
that panel.

If the database item of interest is a fiber backbone you can visualize as one of the following:
eRiser Diagram

el adder Diagram

eMap

¢GPS Calibrated (Geo-Referenced) DWG drawing

If the database item of interest is a circuit you can visualize as:
«Circuit Functional Block Diagram
eMap

WireCAD CMS also provides the capability to view your fiber infrastructure in Map view. Using GPS
coordinates you can view your plant fiber layout, where fiber patches and panels reside as well as
path data for run way-points such as manholes and pull-boxes. You can use the built in Map tool or
use your dwg plant drawings (you must calibrate[2% the drawing to the GPS coordinate system
first).

You can use WireCAD CMS to manage your fiber and copper infrastructures. WireCAD tracks
every strand of fiber and every CATx cable and jumper/cross-connect.
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4.2 CMS Basics
Navigation: WireCAD CMS Tools Manual[z0b >

The following is a list of How To's for multiple functions in WireCAD v10 including creating Cable
Types [525, New Equipment Definitions, Creating Projects and more.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

Creating a New Project[ -0

Creating a New Cable Typel eh

How To Create a Backbones/ 2

Using The New Circuit Tool!2sh

How to Output a Circuit to CAD[ 235

How to Output Many Circuits to CAD[2s5
Using The Backbone Grid|2h

The following subjects assume that you understand basic WireCAD procedures:
eAdding Equipment to the Equipment Library

eAdding Signal Types.

eAdding Cable Types.

eAssigning SysNames.

eAdding Locations.

4.2.1 Backbones
Navigation: WireCAD CMS Tools Manual[2051 > CMS Basics [205 >

This is a step by step guide on how to create Backbones. Backbones are represented in the cables
database by a collection of cables.

Each cable in the backbone has the same Cable Number Prefix. When you create a new Backbone
you are creating a collection of cables based on the selected Cable Type. If you are documenting
fibers think one fiber equals one core/conductor/cable. backbone cables are flagged with the
boolean value isBackbone = true. Doing so distinguishes a cable as being part of a backbone
structure.

Open the Backbones grid by double-clicking the icon in the Project Explorer [Project Databases]
[Backbones]
Command Line Shortcut: bbg

Before You Start

Prerequisites

1.SysNames assigned to the panels/equipment to which you will attach the ends of the Backbone.
2.Multi-core Cable Type representative of the Backbone.

3. Before creating a Backbone, you will need to make sure you have created your Equipment and
Cable Types associated with this projec
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Operation

This tool allows you to draw geometry in the Plan View space that represents the path of the
Backbone. The process requires the following steps:

3.Draw the polyline that represents the backbone.

4.If locations boundaries are found in the drawing the source and destination locations will be used.
Otherwise you will be prompted to define a location for each end.

5.Next you will be presented with the New Backbone tool where you will select the source and
destination panels/ports and the cable type.

6.Clicking [OK] will build a record in the Cables table for each core in the multi-core cable type.
7.The polyline length populate the cable record Length field.

Dialog Options

eNew Backbone - Select whether we are creating a new number or assigning an existing, unused
core.

eBackbone ID - The number.

eUse Existing Available - Select an already assigned Backbone with available strands to
populate the remaining available strands of fiber.

eLocation Filter - Filter the list by location.

eFrom Panel Info - Select the panel. The ports will be shown in the list.

o¢To Panel Info - Select the panel. The ports will be shown in the list.

eCable Type - Select the Cable Type.

4.2.1.1 The Backbone Grid
Navigation: WireCAD CMS Tools Manual[z% > CMS Basics 205 > Backbones [2i6) >

Menu: Database > Backbones
Default command line shortcut: bbg
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Related Project Settings:
Backbone Status Items
Product Level: CMS

The Backbone Grid will show you a list of all the backbone segments in your project and allow you
to modify their status or delete the entire backbone cable group at once. The status will refer to
whether the backbone is in use, proposed, dead ETC. New backbone status can be created in the
project settings menu. There are 3 default status available; in use, proposed & dead.

The Backbone Grid is easier to use than the Cables Database if you are looking for basic
information about a backbone such as number or origin and destination information or if you are
simply wanting to change the status of the backbone.

To access The Backbone Grid, type BBG in the command line.

With The Backbones Grid open, a list of all created backbones and cores will show along numerous
columns of information about each backbone core.
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Controls

eCopy Selection Down - Create a selection vertically in the grid and click Edit>Copy Selection
Down or Ctrl+D and the topmost cell's data will be copied to all selected cells below.

eDelete Selected Backbone - This function will delete ALL cables associated with the selected
Backbone. If you are just trying to delete a single cable you should do that from the Cables
databases.

eRefresh - Query the database and reload the data into the grid.

eAttach Document - Useful for storing field survey reports and other documents associated with
this backbone. You can attach as many documents as you need. The documents are stored in the
database. You can click on the link provided in the grid to launch the document into the system
document reader for that file extension (MIME Type).

eRename Source Connector(s) - Renames the Source Connector (SrcConn) field and any
jumpers or horizontal cables attached to this backbone.
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eRename Destination Connector(s) - Renames the Destination Connector (DestConn) field and
any jumpers or horizontal cables attached to this backbone.

eRename FiberMode - Renames the Fiber Mode (FiberMode) field and any jumpers or horizontal
cables attached to this backbone.

While a number of fields are shown in The Backbone grid, only the Statusfield & Owner field are
modifiable. All other fields are simply shown for reference.

Note: When marking a backbone as a status that is blocking you must make sure that this cable is
no longer used in an active circuit. If WireCAD detects that this backbone is still in use, you will be
presented with a warning message stating "Cannot mark a cable as <Blocking Status Name> that is
part of an existing Circuit. Please remove the Cable from the Circuit, then change its status. "

% b4
Cannot mark a cable as DEAD that is part of an existing Circuit,
Please remove the cable from the Circuit then change its status.

Note: You will also receive a warning message if you try to delete a cable that is part of an existing
circuit. You must remove the cable/backbone from the circuit before deleting. If you wish to delete
individual cores, you can do so from inside the cables database however this information will not
persist back into the CAD drawings.

% x
You cannot delete a Badkbone that is assocated to any Circuit,
Flease delete any drouits that use the Backbone before attempting to delete the Backbone.

Note: When deleting a backbone in The Backbone Grid, the entire group of cables will be deleted
even if you have only selected a single core. Make sure that you want to delete the entire backbone
segment before selecting delete.

Note: Deleting backbones in The Backbone grid, does not adjust number sequence. If you wish to
reuse deleted backbone numbers, you will need to manually access the Next Numbers Grid and
change the next available number to the one you would like to use. Example, you have created
backbones 1001,1002,1003 & 1004. The next number in the sequence would be 1005. If you then
delete 1002,1003 &1004, the Add Backbone Segment Tool will label the next backbone as 1005. To
reuse 1002, 1003 & 1004, you need to manually select these as next in the sequence by doing so
in the Next Numbers [24) Grid.
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4.2.1.1.1 How To: Draw a Backbone

Navigation: WireCAD CMS Tools Manuallz51 > CMS Basics 208 > Backbones|[2®% > The Backbone
Grid| 2111 >

1.0pen a plan view drawing where you want to draw a plan view polyline.

2.Place source and destination Plan View Equipment or source and destination Plan View Location
Boundaries.

3.Click Plan View and Layout Tools > Draw Backbone.

4.As prompted select the source equipment or location boundary.

5.Draw the points in the polyline.

6.The New Backbone tool is shown.
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7.Select the source, destination, cable type and ports.
8.Click [OK] to finish.

4.2.1.2 How To: Create a New Backbone
Navigation: WireCAD CMS Tools Manual[zb > CMS Basics 205 > Backbones [216) >

The following procedure details the creation of backbones in the CMS module. Backbones are
multi-core cables in the cables database that interconnect two (or more) patch panels.
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Note: While this tool is open in your window other WireCAD users will be locked out of the Cables
table of the Project database.

1.Make sure you have used the steps above to create your Equipment, Customize your 1/O and
create your Cable Types.

2.0pen the Equipment Library/[«5.

3.Find the equipment you would like to use.

4.Click [Add to Project Database Only]. You can add as many pieces of equipment you as you
would like at this time however you will need to have at least the 2 definitions that the Backbone
are linked to.

5.1f there are multiple pieces of the same equipment in this location, you can select the [Add Many]
to create multiple pieces of equipment at the same time. Note: WireCAD will automatically
SysName each piece of equipment using the next available number in the sequence.

6.Enter in your location for this equipment.

7.Click [Add] or [Add Many].

8.0nce you have added your equipment into the Project Database, close your Equipment
Library [«8

9.Enter ABS into the command line and press enter or click on the [Add Backbone] button on the
homepage.

10.The Add Backbone Segment window should now be open.
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11.First select if you would like to create a New Backbone or Use Existing Available.

(®) MNew Efagcbnne O Usg.Existing Bwailable

12. On the From side, select your equipment from the Patch Panel ID field.
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13.0n the To side, select your equipment from the Patch Panel ID field. Again, you can filter your
results using the Location Filter Field.
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14.0n both sides, ports that are available will be shown in white while ports that are currently being
used will show as pink.
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]
‘]

st

iiifAdAAa AR

15.From the Cable Type field, select the Cable Type you would like to use as your backbone. If
you have not already created a Cable Type for your backbone, you can do so by clicking the [+]
sign and following the instructions herel M.
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16.Select the ports you would like to use on the From side, then select a starting port on the To
side. You will see that WireCAD will automatically draw a backbone based on your port selection
and Cable Strand count. NOTE: See * Below!
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17.Click [Apply]. WireCAD will create this backbone and then revert to an empty page ready for
another backbone assignment.

*Note: Always make sure that you are not overlaying on used ports and that the ports coming in are
not the same as the ports going out. Example: If you have a Patch Panel with 24 Ports in and 24
Ports out, you could use ports 1-12 as your incoming ports and 13-24 as your output ports. This
allows the other 12 ports on each side to be used for jumpers to other equipment while maintaining
a backbone infrastructure.

4.2.1.3 Backbone Visualization Settings
Navigation: WireCAD CMS Tools Manual[z081 > CMS Basics [205) > Backbones [2:5) >

These settings are available on the Backbones Grid [Visualization Settings] tab.
In order to preview Backbones you will first need to Add Backbones |14

These settings determine the display of the Backbones Visualize tool.

There are three variants:

1.Layered Digraph (ladder diagram).
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Map Tool - within the Backbones Visualizer
This mode is only viable if you have associated GPS coordinate data in your Locations table. For
more information see this topic[zb. In Map view the backbones returned by the Filter Settings are

shown on the Map tool. The backbones honor the Backbones Color, and Line Width settings/[7b.
The Map may be printed or exported through the print preview dialog.

Layered Digraph Mode Data Source

eShow All - Shows all backbones in the database in the Visualize tool.
oCurrent Record - Allows selection of only those backbones that touch the selected record.
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eSearch Depth - How many branches deep are we going to search.
eSearch Width - How many backbones per branch.

Appearance

eLocation Marker Spacing, Location Marker Text Height, Location Marker Color, Junction
Dot Radius, Vertical Backbone Spacing(DU).

[ Ay
.}. - Livcobry hibauo - '
= Spacing -
- + -
Ve Backboes T2
Spacng e
F-
- T

eCenter Label Format - String used to create the center label. Can make use of the following
variables:

{0} = Backbone Number

{1} = Total Count

{2} = Total Available Count

{3} = Total Dead Count

{4} = Single Mode Fiber Count

{5} = Available Single Mode Fiber Count
{6} = Dead Single Mode Fiber Count
{7} = Multimode Fiber Count

{8} = Available Multimode Fiber Count
{9} = Dead Multimode Fiber Count

Example:
Assume that our backbone number is 1001 with 12 single mode fibers of which 1 is dead and four
are in use.

String:
B{0}-SM COUNT:{4} Avail:{5} Dead:{6}

Output:
B1001-SM COUNT:12 Avail:8 Dead:1

String:
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B{0}

Output:

B1001

eCenter Label Offset - Offset from center in DU.

eShow SysNames - Shows the SysName labels.

elgnore Same Locations - Hides backbones that originate and terminate in the same location.
eSysName Rotation Angle - Sets the rotation angle of the SysName label if shown.
eSysName Text Height (100th DU) - Sets the height of the SysName text if shown.
eSysName Text Offset - Offset from the endpoint of the backbone.

Riser Diagram Mode

eCampus and Building - The Campus and Building for which to build the riser diagram.
eLayout Max Columns, Column Spacing,Minimum Row Height - Determine the layout of the
panels in the diagram.

B5th Moo

dth fiotr

3rd fioor

eBody Color, Body Width, Descriptor Locations - Determines the appearance of the body of the
panels in the diagram.

eShow Terminals if Backbone Leaves the Building, Terminal Offset - If the other end of the
Backbone is not in the selected building a terminal will be placed and a backbone drawn to it. The
terminal's position from the port on the panel is determined by the Terminal Offset property.

Place Termiral if Backbors Liawes thi

Building

01012 _S0A BONISE Mk EDOTSE M T

| PUNNNNN. 1 | I

Offsat

| : —Tarminal _‘
.'HFSE-E-EH}LL
eApply Jumps -

eAvoid Other Cables - Instructs the cable autorouter to attempt to avoid other cables.
eShow Unresolved Backbones - If the Backbone cannot be placed in the drawing a list is
generated. Enabling this setting shows the list as the function completes.
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Map Mode

eLocation Filter - Filter the displayed backbones by location.

ePanels Filter - This filter relies on the Locations Filter and provides further filtering by SysName.
eBackbones Filter - This filter relies on the Locations Filter and the Panels Filter and provides
further filtering by Backbone number.

The map relies on the Locations table GPS fields. If you have not assigned GPS Lat and Lon to the

Location the backbones map will not display any data.
To Assign GPS Lat and Lon you can use the Map tool or your GPS calibrated drawing.

Title and Comment Block

eShow Title - Sets the visibility of the title/comment block.

okl Bpchlory

Lagera
Backing = | Sarendl Gonend | Avpiacis Tuenas | Deed Brenes)
D Drencs. fnges i Avplacde Sirend Conns

Tewaaay. May OT. J5)

d
MISC.
eBackbone Color by Signal Type - Pulls the backbone color from the global Signal Types
database.

eShow Directional Coloring - Shows green dots for the source end of the backbone and red dots
for the destination end if shown.

eBackbone Color - Sets all backbones to the color defined.

¢[Reset Default] - Button to reset the settings to the defaults.

4.2.1.4 Backbone Preview Export
Navigation: WireCAD CMS Tools Manualle81 > CMS Basics [2051 > Backbones [2:5) >

Exporting the CAD preview of the Backbones Visualization tool is as easy as clicking the [Export]
button.

The current preview will be exported based on the Export Settings found in the Application Menu >
Settings [Project][Export Settings][ s tool.

4.2.1.5 Import Backbone Data
Navigation: WireCAD CMS Tools Manual[z:51 > CMS Basics|[2081 > Backbones 211 >

Menu: Database > Backbones
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Default command line shortcut: bbg
Related Project Settings:
Backbone Status Items

We have provided an import template that can be found at:
c:\users\public\documents\WireCAD\WireCAD9\Import Templates\import_backbone_template.xIsx.

Command:
Open the Backbones Grid. Then click File>Import Backbones.

Prerequisites
You should have a Backbones import template excel file filled in with your backbone data.

Related Topics:

Import Circuits [2:3)
Backbones Grid /=M

This document, when properly filled out will not only import a single line of data that expands to
many cables database entries as a backbone but will do the following as well:

oCreate global Cable Type and Manufacturer.

oCreate global panel data and Manufacturer.

oCreate Project SysName data.

oCreate Project Location data.

The import tool will perform several checks on the incoming data to ensure that it does not conflict
with existing data. Some of these checks include:

eBasic template data check to make sure all required fields are filled in.

oPreflight queries to check against the existing project data. At this point in the import no data has
actually been imported. If any errors are found the template row number is returned with error text
describing the problem and the import is stopped.

oPost-flight queries to ensure no duplicates were created during the import. If found the error is
reported with the opportunity to roll back the import.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

WireCAD CMS BACKBONE and CIRCUIT IMPORT
PROCESS

OPEN BACKBONE
IMPORT CREATE CIRCUIT

TEMPLATE IN IMPORT
MSEXCEL TEMPLATE

PREPARE PREPARE

BACKBONE CIRCUIT IMPORT

IMPORT
TEMPLATE U2 _FLiils

IMPORT IMPORT CIRCUIT
BACKBONE DATA
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4.2.2  Blind Patch Tool
Navigation: WireCAD CMS Tools Manual[205 > CMS Basics [205 >

Menu: Project Explorer > Project Databases > Blind Patches
Default command line shortcut: ShowBlindPatchTool

Related Project Settings:

Status Behavior CMS |5

Explanation

Unlike the normal WireCAD New Circuit[2s8 tool which requires that you know the complete circuit
end-to-end, the Blind Patch Tool allows you to document your existing patches and then discover
circuits from those patches.

You will use the Blind Patch Tool to document patches between panels. It is not necessary that
you know the whole circuit. Simply create patches from panel to panel as you go. You can use the
[Discover] tool to find circuits from the blind patches. Once the Blind Patch Circuits are
discovered you can use the [Make Circuit] function to create real Circuits.

As you add Blind Patches the Status of the connected Backbone(s) will be mark

BLIND_PATCH. This status item is a blocking status item. Meaning that other operations will not
be able to use or delete this segment of the Patch Panel or Backbone.

Unknown Circuit
B e—-—EE] e —E]

P P FR100 FP.10L

Discovered Circuit

Prerequisites:
Backbones |2

Related Topics:
Blind Patch Tool[s21 form.
New Blind Patch s dialog.
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4.2.2.1 How To: Create a Blind Patch
Navigation: WireCAD CMS Tools Manuallz051 > CMS Basics|z051 > Blind Patch Tool 2281 >

The follow procedure describes creating a Blind Patch. Blind Patches are connections between two
panels. We only know the two ends of the patch. We will discover circuits after adding more Blind
Patches.

Prerequisites:
At least two backbones.

Procedure:

1.0pen the Blind Patches tool: Click Project Explorer>Project Databases>Blind Patches.
2.Select the Patch Panel (SysName) from the drop-down. This will populate the ToSys in the grid.
3.Select the row in the grid representing the port that you want to patch to on the ToSys.

4.Select either Simplex or Duplex Jumper. Duplex will require two rows and that the row below
the selected row be empty to receive data as well.

5.Click Blind Patch>New.

L » IEN

* Mamed Equipment (Syshame) .

Customer Furrished Equipment (CFE)

0K Canoe

6.Select either Named Equipment (SysName) or new CFE. Click OK.

7.The new Blind Patch is added. Backbones that touch the Blind Patch will have their Status
field set to Blind_Patch.

8.Done.

4.2.2.2 How To: Discover Circuits From Blind Patches
Navigation: WireCAD CMS Tools Manual[z51> CMS Basics 2051 > Blind Patch Tool 2251 >

The following procedure describes discovering circuits from Blind Patches.

Prerequisites:
More than one Blind Patch.

Procedure:

1.0pen the Blind Patches tool: Click Project Explorer>Project Databases>Blind Patches.
2.Switch to the Discover Circuits from Blind Patches tab.

3.Click [Discover Circuits].

4.The grid will be populated.

5.Select a row and the found circuit will be presented in the Preview pane (if the [Preview
Selected] check item is checked).

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

Ol Dt 01 D e b s Coued * e Eaults e, Mah i1 54 L MR L LT

Stats: Bhnd Patch Counk & oty Foundd From Blnd Patches = 3

4.2.2.3 How To: Make a Real Circuit From Blind Patches

4.2.3

Navigation: WireCAD CMS Tools Manual[z05) > CMS Basics|[28 > Blind Patch Tool 225 >

The following procedure describes making real circuits from discovered circuits.

Prerequisites:
Blind Patches

Procedure:

1.Follow the steps above to Discover Circuits.

2.Select the circuit in the grid that you wish to make real.

3.Edit the CktNo and CktDescription fields.

4.Click [Make Circuit].

5.The circuit will be added to the Circuits table and removed from the Blind Patches list.
6.Done.

Circuits
Navigation: WireCAD CMS Tools Manual[z > CMS Basics 2081 >

A circuit in WireCAD is defined as a collection of cables. Each circuit may have a Name,
Description, and other meta data. A circuit also has a strand count to indicate the number of
connections made from the originating device on through to the terminating device. Circuits have a
one-to-many relationship with the cables in the Cables database. Each circuit may have many
cables but a cable can belong to only one circuit.
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| Circuits Ii
| Cables I

I isBackbone I

isJumper I
isHorizontalCable I

4.2.3.1 Circuits Grid
Navigation: WireCAD CMS Tools Manuallz0¥ > CMS Basics 208 > Circuits 225 >

Menu: Database > Circuits

Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items

Product Level: CMS

The Circuits Grid presents the overall circuit data in list form with the child cable data attached for
view.

Cirnaudts ‘WitLaliration Settings Wity salire

Drag & column header here Bo group by that cobumn

kit CktGre CkeDst IT System CkiStrandCount PAddress

¥

_; 0oa1 _TB-}.
Cables By Crost
o CobleTy.. CableType SRE Lo E
] GEME... = GENERIC jB... T
GEMERIC 72 STRAND... Bua T
GENERIC GENERIC 00010002 TE-43 025 . T
GEMERIC 72 STRAND... 195,21 TH-43 021 SCA Pua T
TB-47 021 SCa WFPua T
To-45 093 SCA Poa T
TH-45 03 SCA - ]
& 0002 TB-2 [CFE~IT EQUIPM... A 0C... |1
0003 TB-2 [CFE~IT EQUERM... ] RELOC... |1

eAttach Document - Useful for storing field survey reports and other documents associated with
this circuit. You can attach as many documents as you need. The documents are stored in the
database. You can click on the link provided in the grid to launch the document into the system
document reader for that file extension (MIME Type).

eRename Circuit - Renames a circuit and all of its cables.

eCombine Circuit - See the topic Combining Circuits|2:.
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Strand Count and Ordinal Explanation
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NOTE: Backbones are never

renumbered and will not show

strand or ordinal

WireCAD uses the strand and ordinal to know the exact position of a cable in a circuit. Strand 0 will
always be the topmost cable in the circuit with Strand n being the bottommost cable in a circuit.
Ordinal 0 will be the leftmost set of cables in the circuit with Ordinal n being the rightmost set of

cables in the circuit.

4.2.3.2 Circuits Preview Settings

Navigation: WireCAD CMS Tools Manual[z081 > CMS Basics|[2081 > Circuits 226 >

These settings are available on the Circuits Grid [Visualization Settings] tab.
In order to preview Circuits you will first need to Add Circuits [2s7
These settings determine the display of the Circuits Visualization tool.

There are two variants:
1.Functional Block Diagram.
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Displays a CAD representation of the circuit as a functional block diagram. The master source and
destination are show with a series of equipment panels, jumpers, and backbones.
2.Map View.

Map Tool - within the Circuit Visualizer
This mode is only viable if you have associated GPS coordinate data in your Locations table. For

more information see this topic[zs. In Map view the backbones of the selected circuit(s) are shown
on the Map tool. The backbones honor the Backbones Color, and Line Width settings[s:6). The Map

may be printed or exported through the print preview dialog.

5w

Appearance

eSource, Middle and Destination Shape - Choose one of the 16 stock shapes.

eSource, Middle and Destination shape Width in (100th DU) - How wide is it.

eSource, Middle and Destination shape Color - Set the color of the shape.

eSource, Middle and Destination shape Descriptor Locations - Drag the descriptor to the
location map or to the Hidden Items list to hide.

eBackbone Color - Sets the color.
eJumper Color - Sets the color.
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eHorizontal Cable Color - Sets the color.
eMerge and Center Text in Body

TE-4T
SCA 083 | BCA SCA

= i,
R '
. #d Mormal | Merged

eText Height - Sets the height of all text in the visualization.

S0

Layout

eMax Columns - The maximum number of blocks placed before a new row is started below.
eColumn Spacing - The distance between blocks.
*Row Spacing - The Distance between rows.

Title and Comment Block

eShow Title - Sets the visibility of the title/comment block.

oTitle - You can type whatever you want in this field. In addition the following variables are
available:

{0} = Circuit Number

{1} = It System

Y

I~ P[;;;]n+__é;y[:::l

(L] CAMERA BYETEM CUTOVER FIBER DESIGHN
Tusscary, May 07, 2013

MISC.

eShow Attenuation Labels, Show Jumper Length Labels, Show Backbone Length Labels

=

CINMETCA SraTEM CUTGVER FIER CEGH

™
Teeacay, ay 07, 2013

eShow Jumper Numbers, Show Backbone Numbers, Show Length
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4.2.3.3 Outputting Circuits to CAD
Navigation: WireCAD CMS Tools Manuallz08 > CMS Basics 208 > Circuits 225 >

Once a circuit has been defined you can create CAD views of single and multiple circuits. The tools
to do this are contained in the Circuits Grid which you can access from the command line shortcut
CMSCG or by selecting the [CAD Preview/Circuits Grid] on the home page.

Before accessing the Circuits Grid, please make sure to setup your export preferences in the
settings menu.
Please refer here[- for more information on the settings menu.

You can also batch output the selected records by clicking Tools>Output Selected.
All export is governed by settings in the Application Menu > Settings[Project][Export Settings]
tool.

- e |

o[Export] - Output to file based on the Export Settings found in Application Menu > Settings
[Project][Export Settings]

¢[Copy to Clipboard] - Copies the preview to the clipboard so it can be pasted into another
drawing.

4.2.3.4 How To: Output a Circuit to CAD
Navigation: WireCAD CMS Tools Manuallz051 > CMS Basics /2081 > Circuits 2251 >

This step by step will guide you on exporting a circuit.

1.Enter ShowCircuitsGridCMS in the command line prompt. The Circuit Grid Window will open.
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Command: Calaator: |«

2.Select the Circuit Number you would like to Export.

3.Select the [Visualize] Tab.
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4 Verify the circuit is the one you would like to use and click [Export]. A Windows explorer window
will come up. Enter the path to export to, what you would like this file to be called and what file type
you would like to export as. Note: All of these settings can be automated in the Settings Menu.
5.Click [Save]. Your exported file will now be created and placed in the location you have specified
of the file type you specified in the Save As Dialog filter.
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4.2.3.5 How To: Output Many Circuits to CAD
Navigation: WireCAD CMS Tools Manual[z051 > CMS Basics|[2081 > Circuits 228 >

This Step by step will guide you on exporting multiple circuits.

Note: this is different from the command Tools>Output All Selected Circuits

1.Enter ShowCircuitsGridCMS in the command line prompt. The Circuit Grid Window will open.
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2.elect the Circuit Numbers you would like to Export. You can select multiple circuits by draggm
down with your mouse clicked, by holding [Shift] and selecting a set or by holding down [CTRL]
and selecting multiple records individually.
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3.Select the [Visualize] Tab.
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4 Verify the circuits shown are the ones you would like to use and click [Export]. A Windows
explorer window will come up. Enter the path to export to, what you would like this file to be called
and what file type you would like to export as. Note: All of these settings can be automated in the
Settings Menu.

5.Click [Save]. Your exported file will now be created and placed in the location you have specified
of the file type you specified in the Save As Dialog filter.

4.2.3.6 New Circuit Tool
Navigation: WireCAD CMS Tools Manuall2081 > CMS Basics [2081 > Circuits -8 >

The New Circuit tool is used to connect Field End & Head End Equipment together by adding
jumpers between existing Backbones. Each circuit is comprised of descriptive data, such as Name,
Customer, IT System or Description, source and destination equipment (SysNames); as well as a
collection of cables in the Cable database. You simply select the ports that you wish to jumper
from/to and add the jumpers/back bone segments to the Proposed Cables list. A Path Finder tool
helps you search out possible routes. A [Preview] window presents the functional block view of the
Proposed Cables. Once you are happy with the circuit, simply click [Build] and all Proposed cables
will be added and associated to the named circuit.

To open the New Circuit tool open the Circuits grid and click File>New
Command line shortcut: nc
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Note: While this tool is open in your window other WireCAD users will be locked out of the Cables
table of the Project database.

4.2.3.6.1 How To: Create a New Circuit

Navigation: WireCAD CMS Tools Manuallzeb > CMS Basics[25 > Circuits 2281 > New Circuit
Tool| 281 >

Menu: Database > Circuits

Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items

Product Level: CMS

Click File > New.

Before you Start

The use of this tool assumes the following:

eThat you have added Backbones to the project.

eThat you have added the necessary Cable Types to the global Cable Types [s3.

eThat you have an idea of what you want to connect together and that you know the first bit of
infrastructure to which you will attach.

eThat you have created your Customer Furnished Equipment(CFE) in the Equipment Library [ for
the originating and final destination equipment devices and/or that SysNames have been created for
each individual piece of equipment to which you will attach.

1.Verify that you have created all your Equipment and Cable Types needed for this circuit.
2.From the Circuits Grid click [File>New] to launch the New Circuit tool.
3.Verify that your Circuit Number/Name is correct and that it is not duplicating an existing entry.
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4.Enter your IT System and Customer info. IT System is a descriptive name.
5.Select your Origin(named equipment) from the drop down menu on the left. Alternately, select the
Origin CFE (Customer Furnished Equipment) and fill in the detail data in the dropdown.
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6.Select your Final Destination System (named equipment) from the drop down menu on the right.
Alternately, select the Final Destination CFE(Customer Furnished Equipment) and fill in the detail
data in the dropdown.
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7.Select your Jumper To Equipment. This will be the first Patch Panel to which your Origin system
will connect.

8.Select the ports from your Origin equipment and the Ports on your Jumper To equipment. You will
see that WireCAD creates a preview jumper between the 2 for you to verify correct connections.
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9.Click [Add Jumper]. Note: If you have connector types that WireCAD believes do not match, you
will be presented with a window stating "Connector String Mismatch". If you want to turn this

message off, you can do so in the Application Menu > Settings>UserCMS.
Connector String Hismatcﬁ.

Ome or more of the connector types are mismatched.
Do you want to continue?

Yfou can turn this warming off from Project >Settings User [CM5]
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10. Click the [Next>] button. Note: WireCAD will automatically populate an available route between
Patch Panels using existing Backbone structures.

WireCAD v10.1 User Manual

© 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

- B o
- . — ] =%
T
o e e e e L T et
@ rg™ OFE RN = BT AL 8 WL JERERC & FORT B v Pl Do P R 1T IR L | e s R L WK
Bl Crcu B
A From gt AT 1L o ASLLARREEN L BT P DOR: BB 12 RN b FRIT RAMEL
T Pab Bl Al St kbl
Gy Frsm o i s Laren g T
= Cegraie Py e =t
rgrasey b ey Bl i i L o
EH s i Bt Eut (T
= s
[ [ tegibmi b o Pt L [ WCar ] Wi wobambe Drsoraeal [ T
B EMERIE AP 1 L 2 L ALY L. 3R A
LA (20 R EEHIY =3 [Ty AL L. BN B [ L) Q
TEE I EE N
St S N Bkl [
Smitae K| Orof = ewCeads
T
o ard i ol Dol i e,
& Orget OV R < T AL 8 AL a0 BRI 4 PORT B v 0 sl Doy [P R - 1T PSR AL | e s R L BT
Bl Crcu B
R From gt T 1| ) RSN L. e L i BT RAEL
- &l St Pk
- s s e Fe—
B .
} {
B 2 4
EE s - L
e R tegibmi vl o Pt L [ mCar ] W wobmbe Drsiraeal [
AP Ot WL oz Lot ALEMEL L. A e L] L] L]
(20 SR EEHLY =3 [Ty ALY 1. BN B [ L] Q
Lol L1 L=t ) " AR L. AMMBDG 1N S0A A L] a4
Ll at Lo ] . ALLMEY 1. AMURDD 113 e A i a
- - s + = m
St S N Bkl [

12.Verify the correct cables have been added to the Proposed Cables In Circuit list.

13.Then click [Next].

14.Select the Jumper To Equipment to populate the To Ports list. Alternately you can click the
[Last] button to populate the To Ports list with the ports of the Final Destination Equipment.
That's what we will do here.

15.Click [Last].

16.Select the top two records.
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17.Click [Add Jumper]. This places the final jumper in the list.
18.Click [Preview].
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19.1f everything looks correct, Click Build Circuit tab.
20.Click [Build Circuit].
21.Done.

4.2.3.6.2 Path Finder Tab

Navigation: WireCAD CMS Tools Manuallz08) > CMS Basics/2% > Circuits 225 > New Circuit
Tool| 236 >

Explanation:

The Path Finder tool can be used to find available ports and backbone segments from a source to
a destination. The Path Finder tool will search the backbone structure for backbones that can be
used to get from the source panel to the destination panel, then once a route is established the
route candidate is checked for available port count. If all criteria are met the route is returned. If no
routes can be established you will be notified.
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2 possible routes returned each with 6 segments. We will use Route 0.
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After adding Route 0
Controls

eFrom - Prepopulated by your selection with the last jumper added in the Build tab.

eLast Existing - Select the last existing piece of infrastructure that we will search for.

¢[Find] - Start the search.

e[Cancel] - Cancel the search.

eUse Route Number - Once routes are returned for selection this dropdown will be populated with
the available routes.

o[Add Selected Route to Circuit] - Once you have selected a route this button will enable for you
to add the route to the Proposed Cables to Add to Circuit list on the[Build] tab.

eSearch Depth - How deep to search more will take longer but find more routes.

eSearch Width - Maximum candidate routes to search.

eShow All - Show all routes found and populated with jumpers.

eShow Backbones Only (for research) - Show only the backbones without jumpers. Useful for
research.
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eShow Only First Path Found - Stop searching when the first route is resolved.

eShow Only Least Link Path - Search all then prune the list to the route with the shortest number
of segments.

eCable No Prefix, Cable No, SRC Sys, Dest Sys, Src Pin, Dest Pin, Src Loc, Dest Loc - Fields pulled from

the Cables database or populated by jumpers that would need to be created to complete this circuit along this
route.

«Ckt Strand Number - For more information about circuit strand and ordinal see here|z?.

«Ckt Ordinal - For more information about circuit strand and ordinal see here[2z5).

eRoute Number - The router may find multiple paths or none. If paths are found they will be
returned with a route number. You may then select the which, if any, route to add to the circuit.
eMade It - Indicates that the route made it to the destination. All routes shown will show Made It on
the last segment.

4.2.3.7 Combining Circuits
Navigation: WireCAD CMS Tools Manuallz081 > CMS Basics [2081 > Circuits 228 >

Menu: Database > Circuits

Default command line shortcut: showcircuitsgridcms
Related Project Settings:

Circuit Status Items

Product Level: CMS

Click Tools > Combine Circuits.

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have
the same Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted
will be discarded.

n "

Labeinenphed s ] gt

Fhia Circust 00 10 -

Csiae: i 03 Strarel Coerit: 4 « FIBER CIRCLET

® Anpeais W 0L w
ACEnus: DO SRS Cownt 4 - FIBER CIROUT

Enls

oeThis Circuit - The Circuit Name/Number of the circuit that will be appended or inserted into
another circuit. This circuit Name/Number will be discarded if successfully appended or inserted.
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eAppends To - The Circuit Name/Number of the circuit that will be appended to.

eInserts Into - The Circuit Name/Number of the circuit that will be inserted into.

eBefore - Before this SysName.

eAfter - After this SysName.

einsert Jumpers if Necessary - It is possible to create collections of cables in a circuit that do not
interconnect. If you do not select this option you will create collection of cables that do not

interconnect.
ePreview
&l combine Croults : EEE
Labelserpiel sheliem |
Thas Circat oo w
Ciroai 10 Strand Count 4 - FIBER CIROUIT
® Aopends o DLl w

Cirousty 0013 Sirand Counit: 4 - FIBER CIROUIT

info

e

o Camcal

e[Commit] - Do it.

4.2.3.8 How To: UnMake a Real Circuit Into Blind Patches
Navigation: WireCAD CMS Tools Manuallze81 > CMS Basics [2081 > Circuits -8 >

The follow procedure describes the process to turn a real circuit into a collection of Blind Patches.

Prerequisites:
At least one Circuit.

Procedure:

1.0pen the Circuits grid.
2.Select the Circuit to remove.
3.Click Tools>UnMake Circuit.

The jumpers associated with the circuit will be marked as IsBlindPatch = true.
The backbones associated with the circuit will have their Status field = Blind_Patch.
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4.2.3.9 Import Circuit Data
Navigation: WireCAD CMS Tools Manuallz051 > CMS Basics|[2081 > Circuits [ 228 >

Menu: Database > Circuits

Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items

Product Level: ENT

Click Tools > Import Circuits.

palpinlninlaimlyialninln " " E S

LR RS

Command:
Open the Circuits Grid. Then click: File>Create Import Template.
Open the Circuits Grid. Then click: File>Import Circuits.

Limitations

Simplex, duplex or n-strand/core count can be imported. You are limited to 82 rows of circuit data. If
you are importing more than 82 rows start another file.

The import template will only accommodate circuits with a maximum of 6 backbones/risers, or in
other words a simplex/duplex/n-plex circuit with a maximum of 8 jumpers.

AN

SJUNFERS

Prerequisites
You must have created backbone data in order to establish circuits.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

Related Topics:
Import Backbones [ 225
Circuits Grid| 225

Prerequisites

You will need to have entered or imported backbone data in order to create circuits.

This is a multi-step process.
Step 1:

Create the import template:

Open the Circuits Grid. Then click: File>Create Import Template.

This will export the data from your project to the import template. This makes the use of drop downs
with project-specific data possible. Without this you will likely get errors if you were to just type the
data manually into the import template.

c:\users\public\documents\WireCAD\WireCAD9\Import
Templates\SomelmportTemplateNameWithADateCode.xIsx

NOTE: Be sure to use the most current import template.

Step 2:

Open the import template in MSExcel and enter your data into the Circuit Import Template created
in Step 1 above.
Be sure to fill in all fields.

NOTE: If you leave the Circuit Number field blank one will be assigned on import.

A circuit in its simplest form will consist of source and destination equipment with at least one
backbone and two jumpers:
The following is a n-plex simple circuit:

This import would require 4 rows in the import template. One row for each horizontal strand/core.
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When completing the import template you will need to type the source and destination equipment
manufacturers/name and port info.

You will then need to select the first jumper action. The jumper will either jumper to the next
backbone or to the final destination.

You will then select the first panel into which we will apply a jumper and the port we will use.

NOTE: The ports displayed in the drop downs are available ports. If you are trying to use a port that
is not listed check to see why that port is not listed.

Port and System ID fields are strictly validated. You cannot enter field data in the generated
template that is not allowed.

Once you have the first row of the circuit defined you will need to select the Final Action in Column
BN. Your choices are:

¢CKT CONTINUES ON NEXT LINE

¢CKT COMPLETE. NEW CKT NEXT LINE

¢CKT COMPLETE. END OF FILE

There can only be one and only one CKT COMPLETE. END OF FILE row in the template.

Once you have entered all of your data. Save the file and proceed to the next step.

Step 3:

Import your data using the Import Circuits tool.

The Import Circuits tool performs several data integrity checks before the data is actually imported:
o|s the import template the proper format.
o|s all of the necessary data in place.

Then the data is validated against existing data in a preflight check.
eDo the backbones exist.

eAre the ports already assigned to another circuit.

e|s the circuit number available.
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WireCAD CMS BACKBONE and CIRCUIT IMPORT
PROCESS

OPEN BACKBONE
IMPORT CREATE CIRCUIT

TEMPLATE IN IMPORT
MSEXCEL TEMPLATE

PREPARE PREPARE

BACKBONE CIRCUIT IMPORT

IMPORT
TEMPLATE U2 _FLiils

IMPORT IMPORT CIRCUIT
BACKBONE DATA
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4.2.3.10 Exporting Circuit Data to Excel
Navigation: WireCAD CMS Tools Manual[z051 > CMS Basics|[2081 > Circuits 228 >

Menu: Database > Circuits

Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items

Product Level: CMS

Click Tools > Export Circuit to Excel

This function exports the selected circuit(s) to excel. In addition this function also creates a full
circuit import template in the same file.

Limitations:
This function will fill up to line 100 in the excel file starting at row 18. If you have selected circuits
that expand to more than 82 rows the function will fail.

4.2.4  Next Numbers Grid
Navigation: WireCAD CMS Tools Manual[z051> CMS Basics [205 >

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None

Product Level: ALL

The Next Numbers Grid will show you the next available Cable number based on your Cable
Number Format/ . To access the Next Numbers Tool, type nn in the command line prompt.

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As
you progress through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number
box and fill in the desired number. Be sure that you are not entering a number that is already in use.
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Note: Yours will look different as the Next Numbers grid will automatically create entries for each
new sequence used by the application.

4.2.5 GPS Mapping Tools
Navigation: WireCAD CMS Tools Manual[z08) > CMS Basics 2081 >

WireCAD v10 CMS provides several ways for you to visualize your locations, panels, backbones
and circuits with relation to their GPS coordinates:

1.GPS calibrate (georeference) your dwg drawing and use the tools to pick GPS coordinates from
the drawing and display graphical representations of your Locations, Panels and Backbones.

2.You can also set up isometric drawings to show your riser interconnect.
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Isometric View Showing Backbone Interconnect
3.Use the Project Map. The functions are the same but the map detail will be less than that of a
specific drawing. For example the map may show your building(s) but your CAD drawings will show
the detail inside the buildings.

Map Tool - showing Location, Panels and Backbones
4.The Map Tool is available as a visualization[>%) in the Backbones grid to show you your
Backbones in map view.
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Map Tool - within the Backbones Visualizer
5.The Map Tool is available as a visualization[:b in the Circuits grid to show you the GPS path of a
selected circuit.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

Map Tool - within the Circuit Visualizer

The WireCAD Locations table within the project database contains fields for named locations within
your plant. In addition, those named locations can be associated with GPS coordinates.

Room Rade Qualified Locaton (What She pr... = GPRLocaton GPELat SPELon GPSOevaton  Desoipbon Locationbs. |

1o} AMLILANMEN 1. EST ALOOR. 101 36. 1505, 55 TITIT6L 36 15Te0BR03433E  BE. TTTITHEI05... QUD0D0D00. .,

Once the project Locations table has associated GPS coordinates you can visualize your data:
1.From your GPS calibrated dwg drawing.

2.From the Project Map tool.

3.From the Backbones grid Visualizer.

4.From the Circuits grid Visualizer.

Related Topics:
GPS Mapping Tools For Drawings/s®
GPS Mapping Tools for Map Tool |25

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

Accuracy and Precision

There are several factors that effect the accuracy of the GPS coordinate system alignment:
e¢The accuracy of the drawing.

eThe accuracy of the control points.

eThe accuracy of the GPS coordinate provided.

From the wikipedia page on decimal precision:

The radius of the semi-major axis of the Earth at the equator is 6,378,137.0 meters resulting

in a circumference of 40,075,161.2 meters. The equator is divided into 360 degrees of

longitude, so each degree at the equator represents 111,319.9 meters or approximately

111.32 km. As one moves away from the equator towards a pole, however, one degree of

longitude is multiplied by the cosine of the latitude, decreasing the distance, approaching zero

at the pole. The number of decimal places required for a particular precision at the equator is:
Degree precision versus length
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qualitativ
. . e scale N/S or
decimal | decimal DMS that can E/W E/W at
places | degrees 23N/S
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0° 00' street,
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0° 00' individual
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0° 00' individual [111.32 102.47
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practical
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0° 00' . 111.132 10.247
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surveying
specialize
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g 0.00000000° 00' (S:“’ey'”g 11132 |1.0247
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78.71 km

7.871 km
787.1m

78.71m

7.871m

787.1 mm

78.71 mm

7.871 mm

787.1 um
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67N/S

43.496 km

4.3496 km
434.96 m

43.496 m

4.3496 m

434.96
mm

43.496
mm

4.3496

434.96 um

A value in decimal degrees to a precision of 4 decimal places is precise to 11.132 meters at
the equator. A value in decimal degrees to 5 decimal places is precise to 1.1132 meter at the
equator. Elevation also introduces a small error. At 6,378 m elevation, the radius and surface
distance is increased by 0.001 or 0.1%. Because the earth is not flat, the precision of the
longitude part of the coordinates increases the further from the equator you get. The precision
of the latitude part does not increase so much, more strictly however, a meridian arc length
per 1 second depends on latitude at point concerned. The discrepancy of 1 second meridian
arc length between equator and pole is about 0.3 metres because the earth is an oblate

spheroid.
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4.2.5.1 Using the Map Tool
Navigation: WireCAD CMS Tools Manual[z081 > CMS Basics 2051 > GPS Mapping Tools [2s5) >

WireCAD CMS provides a world map tool. The Map Tool can be opened with the link on the Project
Explorer s under the Project Database section.

-
kY

e

g - - g e € Dy | iy
Concept

The Map tool within WireCAD can be used to associate your Locations table entries to specific
GPS coordinates.

Once the Locations table entries have been associated with corresponding GPS coordinates we
can automatically place:

eLocation Markers

ePanel Markers

eBackbone Markers

Note that the Map Tool requires an internet connection. We are grateful to the folks at
OpenStreetMaps for providing the map image data. The map images are © OpenStreetMap
contributors.

Pseudo Procedure

The following is a rough procedure for automatically creating a grapic that shows all locations in the
Locations table, all SysNames in the Project Equipment List, and all Backbones in the Backbones
grid.

1.Use the Map>Tools>ID GPS Location Coord tool[s# to specifically associate your named
locations to GPS coordinates.

2.Use the Map>Display>Location Markers tool to display all of the Locations in the Locations|ssh
table that have GPS coordinates.
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3.Use the Map>Display>Panel Markers tool to display all of the SysNames in the Project
Egujgment List[ss that have Locations in the Locations|ssh table that have GPS coordinates.

= : =il
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5 |;;2|

4.Use the Map>DispIay>Backbo'|.'\e' Markers tool to display a polyline representing the
Backbone[21h between location/panels that have Locations in the Locations|ssh table that have
GPS coordinates.

= : =

5 |;;2|

Related Topics:

Map Display 23 tab
GPS Settings [+7% panel

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.1.1 How To: Associate GPS LAT, LON with your Locations

Navigation: WireCAD CMS Tools Manuallz8 > CMS Basics[2081 > GPS Mapping Tools 2561 > Using
the Map Tool| 2541 >

This topic focuses on the procedure to identify GPS Lat, Lon point from the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see here|ze8.
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Explanation
The WireCAD Locations table within the project database contains fields for named locations within
your plant. In addition, those named locations can be associated with GPS coordinates.

FRnom Pk Qualified Location (What the pr... = GSLocation GPSLat GPSLon GPSfevation | Desapton Locationls. |

101 AMLLANMEN 1. EST ALOOR. 101 35. |5 ME0EE, 25 TITIT6L 36 157085034335 B6. TTTITHEI05.,. Q0000000 .,

There are four fields to contain the GPS data:
¢GPSLat - Latitude decimal precision 18 decimals.
¢GPSLon - Longitude decimal precision 18 decimals.
oGPSEI - Elevation decimal precision 18 decimals.
oGPSLocation - text convenience field of the Lat,Lon.

Note: We realize that 18 decimal places is far beyond the capabilities of any non-stationary GPS
receiver. We just want to be thorough.

Related Topics:
ID GPS Locations [s% dialog reference.

The Map Tool does not give us specific detail of the rooms within our building so some guessing is
required if we are going to use this tool to identify Locations within a building. If you have dwg
drawing of your building you may be better served to Calibrate[zs}) those and use the same tool
within the drawing to pick location point|zeb.

WireCAD provides a tool to identify the GPS coordinates from the Map Tool and fill the GPS field
data appropriately.

1.0pen the Map tool.
2.Click Tools > ID GPS Location Coords. This will open a dialog from which to select the
Location of interest.

Lampus Bidng - oo e ach (i Locanan

3.Select the row(s) of interest within the Locations grid. Here we will define the GPS coordinates for
the Location "AMU.COM CTR CORE SWITCH.ROOM 120.5".
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4.Click Pick > . The ID dialog is temporarily dismissed to allow you to pick the coordinate from the
Map Tool.
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LE® & |r|® .
Hew

Lares Laszhbion Marker
Seve  Chede Copy Selection || Pak >
Dicrmem
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5.Pick the coordinate by moving your cursor to the coordinate in the Map Tool and left-click. Here
we will select a location in the corner of the building where we estimate the AMU.COM CTR CORE
SWITCH.ROOM 120.5 to be. If you have selected [Leave Location Marker] as we have here you
will leave behind a location marker at the point you have picked.

6.The ID dialog will be shown with the coordinate data in the selected row(s).

7.Click File > Save.
8.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.
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4.2.5.1.2 How To: Show Location Markers in the Map Tool

Navigation: WireCAD CMS Tools Manual[zt > CMS Basics 208 > GPS Mapping Tools[2:h > Using
the Map Tooll 2521 >

This topic focuses on the procedure to display Locations in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic|ze.

Explanation

The WireCAD_Map Tool[ssh can show your Locations for which you have entered GPS coordinate
data. Only Locations that have GPS data will be considered.

The text displayed in the Location Marker is determined by the Display Format String of the
Location section of the GPS Settings/[+7% panel.

Related Topics:
Display Tab /=4 of the Map Tool interface.
Map Tool Dialogs| s

GPS Settings|s7h

1.0pen the Map Tool. It can be found in the Project Explorer[s under the Project Databases
section.

=]

2.Enter any Filter[2s2 data that you would like to limit the display of Locations by.
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3.Click Display > Locations. This will display all locations for which GPS data has been entered. If
you have an empty filter all Locations will be shown.
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4.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.1.3 How To: Show Panel Markers in the Map Tool

Navigation: WireCAD CMS Tools Manuallz8 > CMS Basics[z0% > GPS Mapping Tools [zt > Using
the Map Tool| 2541 >

This topic focuses on the procedure to display Panels or Equipment in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic| 2.

Explanation

The WireCAD Map Tool[ st can show your Panels (SysNames). The Location of the SysName will
be referenced to the Locations table entry. If the Locations record has GPS data the SysName will
be placed. Only Locations that have GPS data will be considered.

The text displayed in the Panel Marker is determined by the Display Format String of the Panles
section of the GPS Settings [+ panel.

Related Topics:
Display Tab /2% of the Map Tool interface.
Map Tool Dialogs| s

GPS Settings[+h

1.0pen the Map Tool. It can be found in the Project Explorer[s under the Project Databases
section.
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2.Enter any Filter[2s2 data that you would like to limit the display of Panels (SysNames) by.

“ Froject play View Database Plugins Reports
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Lacationz | Panels Backbaonez | & — Zoom Extents | Settings
,a,|| % | ¥ [Baddhones

Reset Locatio... Pan.. Backbon... Fiters View ml Sett. &

3.Click Display > Panels. This will display all Panels (SysName) for which GPS data can be found.
If you have an empty filter all Panels with Locations with GPS data will be shown.
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4.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.1.4 How To: Show Backbone Markers in the Map Tool

Navigation: WireCAD CMS Tools Manuallzt > CMS Basics 208 > GPS Mapping Tools [2sb > Using
the Map Tooll 253 >

This topic focuses on the procedure to display Backbones in the Map tool.
For a similar procedure using your GPS calibrated dwg drawing see this topic| 2.

Explanation

The WireCAD Map Toollss can show your Backbones for which you have entered GPS coordinate
data. Only Backbones with Locations that have GPS data will be considered.
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The Backbone Marker color and Line Width is set in the Backbones section of the GPS
Settings [0 panel.

Related Topics:

Display Tab /2% of the Map Tool interface.
Map Tool Dialogs| s

GPS Settings[+5)

1.0pen the Map Tool. It can be found in the Project Explorer|ssy under the Project Databases
section.

2.Enter any Filter[zs2 data that you would like to limit the display of Backbones by.
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3.Click Display > Backbones. This will display all Backbone for which GPS data can be found. If
you have an empty filter all Backbone with Location data will be shown.
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4.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.
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4.2.5.1.5 Using Filters

Navigation: WireCAD CMS Tools Manual[zt > CMS Basics 208 > GPS Mapping Tools[2sb > Using
the Map Tool| 254 >

n Projsct mplay | Ve Datsbace I Reparts
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) = ]
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Reset Lecatio Pan Eadkbon Fifters View Rl Sett. &

The filter section is cascading. Selecting a Location will cascade to the Panels filter by limiting the
Panels shown to those that appear at the selected Location(s). In the same way, the Panels filter
will cascade to the Backbones filter. You may select as many of the filterable items you wish.

4.2.5.2 Using Your DWG Drawings as Maps
Navigation: WireCAD CMS Tools Manual[z081 > CMS Basics 2051 > GPS Mapping Tools [2s5) >

WireCAD CMS supports the use of DWG maps to display equipment and backbones.

Concept

WireCAD can calibrate or georeference any properly scaled drawing to two known control points.
These control points typically reference survey markers in the drawing with their associated GPS
coordinates. Control points can be any geometry in the drawing for which you know the GPS
latitude and longitude. In other words, the control points can be any two points as long as they have
known coordinates in both systems.

Note WireCAD uses the term Calibrate synonymous with georeference. Calibration or
georeferencing is the process of aligning the WCS (world coordinate system) of the drawing with
the GPS coordinate system.

T S — e
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Coordinate System Alignment Showing Four Control Points for lllustration. WireCAD Requires Only
Two Control Points

n

Once the drawing has been calibrated, the cursor location is displayed in both Drawing and GPS
coordinates.
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Further, WireCAD can then be used to associate your Locations table entries to specific GPS
coordinates.

Once the Locations table entries have been associated with corresponding GPS coordinates we
can use that data to automatically draw:

eLocation Markers. Location markers can be any CAD Block of your choice.

ePanel Markers. Panel markers can be any CAD Block of your choice.

eBackbone Markers. Backbones will be represented using polylines with the vertexes defined by the
GPS coordinates of the end point locations as well as Via locations.

Related Topics:
Display Tab /s of the Drawing Mapping Tools interface.

Pseudo Procedure

The following is a rough procedure for automatically creating a drawing that shows all locations in
the Locations table,all SysNames in the Project Equipment List, and all Backbones in the
Backbones grid.

Prerequisites

You will need a DWG drawing of your plant or campus that is drawn to scale. The scale used does
not matter as long as it is applied consistently. You will need the GPS coordinates of two control
points in the drawing.

1.Calibrate the drawing using Mapping Tools>GPS>Calibrate.

2.Use the Mapping Tools>Tools>ID GPS Location Coord|s# tool to specifically associate your
named locations to GPS coordinates.

3.Use the Mapping Tools>Display>Location Markers tool to display all of the Locations in the
Locations table that have GPS coordinates.

4.Use the Mapping Tools>Display>Panel Markers tool to display all of the SysNames in the Project
Equipment List that have Locations in the Locations table that have GPS coordinates.

5.Use the Mapping Tools>Display>Backbone Markers tool to display a polyline representing the
backbone between location/panels that have Locations in the Locations table that have GPS
coordinates.

4.2.5.2.1 How To: Calibrate (Geo-Reference) Your DWG to the GPS Coordinate System

Navigation: WireCAD CMS Tools Manuall2% > CMS Basics[2081 > GPS Mapping Tools 25 > Using
Your DWG Drawings as Maps| 2s2) >

Prerequisites

This topic assumes that you have a scaled drawing of your plant.

Further that there exists in the drawing two control points. Control points are typically survey
markers for which you have the GPS coordinate data. However, they can be any geometry in your
drawing such as the corners of buildings or manhole covers as long as you have reliable GPS data
for that point.

Procedure

1.0pen your plant or campus drawing. If the your plant drawing is very large you may want to
consider Externally Referencingl+% (XREF) it into a new drawing. This is done to keep the save
operation lightweight. Externally referenced drawings do not get saved, only the base drawing.
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2.Click Mapping Tools > GPS > Calibrate.

a3 a e e Q] FP3.dwg - WireCAD10 - ENTERPRISE - Current Project: [Edit Suite Demo Project] Mapping Tools

Project File Drawing CAD Tools Advanced Tools View Database Plugins Reports Plan View and Layout Tools GPS Tools Display

Calibrate Copy from
Other Drawing

Calibration

3.You will be prompted in the Command Prompt to pick the first point, or lower left point, from the
drawing. Do so.

4 .Enter the GPS point data for the lower left point. The control point does not necessarily have to be
the lower left corner. We just need points opposite.

X | Executing Command: CalibrateDWGtoGPs, |,
Pick the LL point -1140'-3 7/8",-754'-9 13/18°0
Enter the LL Latitude,Longitude in dedmal form here==

Please note that the coordinate is expected in decimal lat,lon form. Do not Crtl+V to paste your
coordinate data as this will initiate the paste function in the drawing not the command line. Use the
Right-Click context menu and select Paste there.

5.Pick the upper right point in the drawing.

6.Enter its GPS coordinate.

When done the drawing will display GPS in the lower right-hand corner to indicate that it is
calibrated.

od
1

You will be able to use the GPS tools to pick location points from the drawing.
The statusbar text will show you the GPS coordinate of the current cursor position.

fnsp | [OSnap || Grid | Ortho | Polar Trading  Extension Traddng | Port Info I&l!?ﬁlﬂ,—&&.”ﬁﬂén Hdﬂjhﬂ,-ﬁdi%ﬂ,ﬂ.m AubcSave In: 07:3%

Once the drawing is calibrated you can use the Mapping Tools > GPS > Show Calibration Marks
tool to place a marker in the drawing at your calibration points.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



WireCAD CMS Tools Manual

K & = 0@ q g FP3.dwg™ - WireCAD10 - ENTERPRISE - Current Project: [Edit Suite Demo Project] Mapping Tools
Project File DrawingeCAD Togls _ Advanced Tools View Databaze Plugins Reports Plan View and Layout Tools GPS Tools Display

Delete Show Calibration
Calibration Marks

Calibration

1

CPS Locaion P18 TA545%) -84 TTR68s

&
L. | — BRS’
Related Topics:

Display Tab /s of the Drawing Mapping Tools interface.

4.2.5.2.2 How To: Copy Calibration Data from another Drawing

Navigation: WireCAD CMS Tools Manuallz6 > CMS Basics[z0% > GPS Mapping Tools [zt > Using
Your DWG Drawings as Maps| 221 >

WireCAD provides a tool to copy calibration or georeference data from another drawing. This
assumes the following:

eThe drawing you are copying from has been Calibrated. You can tell if the drawing has been
calibrated if you open it and it displays the text GPS in the lower right-hand corner.

eThe geometry in the two drawings shares the same WCS origin point. This is crucial. If the
geometry in the two drawings does not share the same origin point the GPS coordinate system will
be off.

Procedure
1.0Open the drawing that you want to copy Calibration data into.

X EH & o= e nQ q § FP3.dwg - WireCAD10 - ENTERPRISE - Current Project: [Edit Suite Demo Project] Mapping Tools
Project File Drawing CAD Tools Advanced Tools View Database Plugins Reports Flan View and Layout Tools GPS Tools Display
Calibrate Copy from
Other Drawing
Calibration

2.Click Mapping Tools > GPS >Copy From Other Drawing. This will open a file browser dialog.
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&l Open *
N <« WireCAD » WireCAD9 » Demo Projects » Edit Suite Demo Project » DRAWINGS v O Search DRAWINGS 2
Organize * MNew folder = O @
~ MName Date modified Type Size
7 Quick access
Floor Plan 4, 93:27PM File folder
I Desktop . . :
Project Base Template Drawing 3 1811:42 AM  File folder
‘_' Downloads Single Lines 7/17/2018 11:04PM  File folder
=] Documents Snap Shots 3/2/2018 11:42 AM File folder
=| Pictures |_'| (Table Of Contents).dwg 3/29/2013 7:01 PM WireCADG Drawing 92 KB
California Media |_'| all systems.dwyg 5 19418 PM WireCADG Drawing 214 KB
Heartland Video [ ] demo today.dwg 8/13/2018 11:56 AM  WireCAD6 Drawing 63 KB
IMT [] EL_OFFICE_116A.dwg 7 23PM  WireCADE Drawing 1,645 KB
] |_'| rack demo.dwg 5/10/2019 1241 PM  WireCAD6 Drawing 87 KB
WireCAD10Ar
¢ OneDrive
[ This PC
¥ Metwork
[ DEMISE-PC
File name: || v| DWG Draings ~

3.Browse to the Calibrated drawing and select it.

4.Click [Open]. This will initiate the process. If the drawing has been calibrated the process will
proceed and the commandline history will indicate that the process has been completed.

5.Click File > Save to save the calibration data with the drawing.

6.You are done.

4.2.5.2.3 How To: Associate GPS LAT, LON with your Locations

Navigation: WireCAD CMS Tools Manuallz8 > CMS Basics[20% > GPS Mapping Tools [zt > Using
Your DWG Drawings as Maps| 2621 >

This topic focuses on the procedure to identify GPS Lat, Lon point from a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic/zs8,

Prerequisites
This topic assumes that you have a GPS Calibrated drawing of your plant.
For more information on calibrating your drawing see this topic (263,

Explanation
The WireCAD Locations table within the project database contains fields for named locations within
your plant. In addition, those named locations can be associated with GPS coordinates.

Room Aade Quaifed Locabon (What She pr... & GPHLocaSon Pt SPELon GPSfeyvation  Desoipbon Locationlbs. |

101 AMLLANREN 1. EST ALOOR. 101 35, 1 5E0SE, 05, TITITHEL 35, 157e080034385 86 T7TITHGI0E.,. QUODD0D0D, .,

There are four fields to contain the GPS data:
eGPSLat - Latitude decimal precision 18 decimals.
¢GPSLon - Longitude decimal precision 18 decimals.
*GPSEI - Elevation decimal precision 18 decimals.
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eGPSLocation - text convenience field of the Lat,Lon.

Note: We realize that 18 decimal places is far beyond the capabilities of any non-stationary GPS
receiver. We just want to be thorough.

Related Topics:
ID GPS Locations |54 dialog reference.

WireCAD provides a tool to identify the GPS coordinates from your GPS calibrated drawing and fill
the field data appropriately.

1.0pen your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand
corner, S|t|0p'

Lyl

2.Click Mapping Tools > Tools > ID GPS Location Coords. This will open a dialog from which to
select the Location of interest.

P — e s e v e e pp—

7 GPS ID Existing Location ? X%

File

LEO & )»

Mew Save  Close Copy Selection Pick =

Leave Location Marker  |v/

Dawr
File 7 Edit IF Tools I Behavior ~
Campus Building w | Floor Room Rack Qualified Location
¥ | adc afc afc afc A A
» LA " THEFACTO... MAIN MR RK-10 LA THE FACTORY.MAIN.MR..RK-10
109 109
109 1 5 507 109.1.5,507
109 1 109.1
4 4 4 Record 1of4 » ke M £ >

Status

3.Select the row(s) of interest within the Locations grid. Here we will define the GPS coordinates for
the Location "AMU.COM CTR CORE SWITCH.ROOM 120.5".
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File

LEOe & )»

Mew Save  Close Copy Selection Pick =
Down

Leave Location Marker v/

File & Edit & Tools |} Behavior ~
Campus Building w | Floor Room Rack Qualified Location GPS Location GPS Lat
= g g g g: g: e —
>I LA THE FACTO... MAIN MR. RK-10 LA. THE FACTORY.MAIN.MR.RK-10 I|
109 109
109 1 5 507 109.1.5.507
109 1

109.1

44 44 4 Record 1of4 b b W €

Status

4 .Click Pick > . The ID dialog is temporarily dismissed to allow you to pick the coordinate from the
drawing.

X - GPS ID Existing Location 7 %

B -
LEQ & |

Mew Save  Close Copy Selection Pick =
Daown

Leave Location Marker v

File IF] Edit IF] Tools IF] Behavior -

5.Pick the coordinate by moving your cursor to the coordinate in the drawing and left-click. If you
have selected [Leave Location Marker] as we have here you will leave behind a location marker at
the point you have picked.

6.The ID dialog will be shown with the coordinate data in the selected row(s).
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2
2
e, 2
% )., %
%, P 4 %
o"‘( e o % )
i3 e ”) 3
) Z
b GPS ID Existing Location 7 X <
File 'y
we % 1
po % o
L & » A
© Leave Location Marker v/ =)
New Save Close | CopySelection | Pick> 2
Down

Fie [ Eit  ® Tods  ® Behavior

leation GPS Location GPSLat GPsLon
o

133.9240860668422,... | 33.9249850... ~117.49888.

5

» ETORY.MAIN. MR.RK-10

7

Quct

144 4 Record 1of4 b # mi €

- mapimages @ OpenStreetMap contributors
! ol A

7.Click File > Save.
8.You are done.

4.2.5.2.4 How To: Show Location Markers in your Drawing

Navigation: WireCAD CMS Tools Manuallz0 > CMS Basics[=081> GPS Mapping Tools st > Using
Your DWG Drawings as Maps| 2621 >

This topic focuses on the procedure to place Location Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic|zs8),

Prerequisites
This topic assumes that you have a GPS calibrated drawing of your plant.
For more information on calibrating your drawing see here|zs5.

Further, this topic assumes that you have identified GPS coordinates for your Locations in your
Locations table. For more information on this topic see here 2.

Explanation

WireCAD has the ability to place a marker for every location in the Locations table for which GPS
coordinate data exists. The markers placed are based on the current filter settings. For more
information on setting filters see herel 2/

The type of marker placed, its scale, and Overlay Mode can be determined in the menu structure.
The marker text, color and Overlay Mode settings can be controlled in the GPS Settings [/ panel.

Related Topics:
GPS Settings /s
Display % Tab

Procedure

1.0pen your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand
corner, stop.
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2.Select the Geometry and Scale. Geometry sets the block to insert as a Location Marker. For
more information on the Geometry see this topic /s

ME &= )2QQQ]

?28mpL i

*T WireCAD

3.Select the Overlay Mode. For more information on the Overlay Mode see this topic /5.
4. Enter any Filter[2s2 data that you would like to limit the display of Locations by. For more
information on the Filters see this topic[z/4,

HMEwoc=2aaag FP3.dng Mapping Tools

263 L i

e S T WireCAD

Here we have selected a block that has the appearance of a Location pin

5.Click Mapping Tools > Display > Locations. This will display all locations for which GPS data
has been entered. If you have an empty filter all Locations will be shown.
= v g WS H - g S B = E

L

6.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.2.5 How To: Show Panel Markers in your Drawing

Navigation: WireCAD CMS Tools Manuall2 > CMS Basics[208 > GPS Mapping Tools[2s81 > Using
Your DWG Drawings as Maps| 2s2) >
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This topic focuses on the procedure to place Panel Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic|zs8).

Prerequisites

This topic assumes that you have a GPS calibrated drawing of your plant.

For more information on calibrating your drawing see here|z5.

Further, this topic assumes that you have identified GPS coordinates for your Locations in your
Locations table. For more information on this topic see here|zsb.

Explanation

WireCAD has the ability to place a marker for every Panel in the Locations table for which GPS
coordinate data exists. The markers placed are based on the current filter settings. For more
information on setting filters see herel 274

The type of marker placed, its scale, and Overlay Mode can be determined in the menu structure.
The marker text, color and Overlay Mode settings can be controlled in the GPS Settings [+ panel.

Related Topics:

GPS Settings[+h
Display % Tab

Procedure
1.0pen your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand
corner, S.t|°p'

1

2.Select the Geometry and Scale. Geometry sets the block to insert as a Panel Marker. For
more information on the Geometry see this topic/s:.

2@, i

*T WireCAD

Here we have selected a block that has the appearance of a simple rectangle with an angled line.

3.Select the Overlay Mode. For more information on the Overlay Mode see this topic /s
4 Enter any Filter[zs? data that you would like to limit the display of Panels by. For more
information on the Filters see this topic[z74,

XNE e
e
E w3
e

?2emL 0

* T WireCAD
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5.Click Mapping Tools > Display > Locations. This will display all locations for which GPS data
has been entered. If you have an empty filter all Panels with found GPS data will be shown.

Here we see the panels displayed with the Radial Overlay mode
6.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.2.6 How To: Show Backbone Markers in your Drawing

Navigation: WireCAD CMS Tools Manuallzt > CMS Basics 2081 > GPS Mapping Tools [z > Using
Your DWG Drawings as Maps| 2621 >

This topic focuses on the procedure to place Panel Markers in a GPS calibrated drawing.
For a similar procedure using the Map tool see this topic/ze\.

Prerequisites

This topic assumes that you have a GPS calibrated drawing of your plant.

For more information on calibrating your drawing see here|zsb.

Further, this topic assumes that you have identified GPS coordinates for your Locations in your
Locations table. For more information on this topic see here 2.

Explanation

WireCAD has the ability to place a polyline for every Backbone in the Backbones/s# table for
which GPS location coordinate data exists. The markers placed are based on the current filter
settings. For more information on setting filters see here[z/4.

The Arc Distance, Self-Connect Arc Distance and the Show Mode can be determined in the
menu. For more information on these settings see this topic/s.

The marker text, color and other settings can be controlled in the GPS Settings% panel.
The tool can [Show Backbone Stats] such as the fiber count, availability, and blocked fiber count.

This data, if generated, is displayed in the tooltip of the Backbone when the mouse hovers over it.
The statistics are presented in the form: Backbone Number FiberMode\Count\Available\Blocked
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1

k. GPS-

You can also see Backbone stats with or without having the [Show Backbone Stats] checkbox
checked by double-clicking a Backbone. Doing so will present a message box with the stats.

k. GPS -

The polyline can be made to show only its end points or if the Show Vias is checked it will jump
from the starting location through every Via location until it reaches the ending location.

B e o e e o . J ﬁfﬁ:i—ql
1 : : "?'-'VII.
e N e - il

£ GPS

Backbone from panel to panel Via Manhole 1 and Manhole 2
The polyline can also be made to show the Backbone number as the polyline LineType

P

k. GPs-

Backbone showing number as Line Type
Related Topics:
GPS Settings [+
Display =% Tab

Procedure
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1.0pen your GPS calibrated drawing. If your drawing does not display GPS in the lower right-hand
corner, stop.
I| P

-
aﬂ "

2.Select the Arc Distance and Self-Connect Arc Dist. Arc Distance sets the polyline bulge
factor. An Arc Distance of 1 creates an arc of 180°. For more information see this topic [a18),

| - 8 %
2@, i

* T WireCAD

3.Select the Overlay Mode. For more information on the Overlay Mode see this topic/s:.
4 Enter any Filter[2sh data that you would like to limit the display of Backbones by. For more
information on the Filters see this topicz/2.

ME &= )2qQqQ] FP3.dwg® - WireCAD 10 - ENTERPRISE - Current Project: [Edit Site Demo Project] m - x
263 L i

e |5 T WireCAD

5.Click Mapping Tools > Display > Backbones. This will display all locations for which GPS data
has been entered. If you have an empty filter all Panels with found GPS data will be shown.

Here we see the Backbones displayed by GPS Location and we are showing Vias
6.You are done.

Note: Although we are showing a real world location in these examples the data is completely
fictitious. Any resemblance to any data living or dead is purely coincidental.

4.2.5.2.7 Using Filters

Navigation: WireCAD CMS Tools Manuallz8 > CMS Basics[z0% > GPS Mapping Tools [zt > Using
Your DWG Drawings as Maps| zs2) >
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ME S =)0 @Qq FP3.dwg® - WireCAD 10 - ENTERPRISE - Current Project: [Edt Suite Demo Project] m - x
2emp i

ol B I WireCAD

The filter section is cascading. Selecting a Location will cascade to the Panels filter by limiting the
Panels shown to those that appear at the selected Location(s). In the same way, the Panels filter
will cascade to the Backbones filter. You may select as many of the filterable items you wish.

4.2.5.2.8 HOW TO: Create a Multistory Isometric Drawing to Display GPS Data

Navigation: WireCAD CMS Tools Manuall=8 > CMS Basics[20% > GPS Mapping Tools 2561 > Using
Your DWG Drawings as Maps| 265 >

Prerequisites
We will need a new drawing. We will also need the floor plans for each floor one per file all aligned
to the same X,Y origin.

Concept
We can use the different floor plans of a structure stacked one on top of another along the Z axis to
display our interconnect in an isometric view.

Isometric View Showing Backbone Interconnect
Here we have created a new drawing called map.dwg and Externally Referenced each floor on the
same X,Y origin but at a different Z axis location.

Pseudo Procedure

1.Create a new drawing.

2.XREF the first floor inserting it at 0,0,0.

3.XREF the next floor inserting it at 0,0,n where n is some value along the Z axis far enough away
from the origin that when we rotate the drawing into isometric view the two floors do not interfere
with each other.

4 .Lather, rinse, repeat for each floor inserting the floor at 0,0,n*f where n is the distance along the
Z axis and f is the floor number.

5.For ease of use we recommend creating a layer for each floor and assigning the floor to the layer
in order to control visibility.

6.Calibrate|2s% the drawing.

Procedure
Before you start. Collect all of your floor plan files into a known location. We recommend in the
same folder as the new drawing you are about to create.
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1.Create a New Drawing[ 7). Name it map.dwg or some-such.

2.Make sure you are in Model space.

3.With the map.dwg drawing as the active form. Click CAD Tools > External Reference Manager
(XREF). This will open the XREF Manager dialog@%w.

X1

> IEN

Externally referenced drawings are those that are displayed in this drawing but maintained separately

Bind Unload

Attach

Reference Mame File Mame

4 .Click the [Attach] button. This will open a file browser dialog.

Exit

v] @ & £* @

afl Open
Look in: | Drawings
l Mame
|:| WireCAD Drawing.dwg

Cuick access

Desktop

|
Libraries

I

This PC

¢

Network

Date modified
472472019 2:33 PM

File name: ||

> |

Type
WireCADE

Files of type: All Drawing Files (" wdml;” wdel;” vdf:" vdi;* vdp; ~

Preview
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5.Browse to your floor plan file and click [OK]. Thls will display the Insert dialog.

Rnaart Pl
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(=3 Carvidd

6.For the first floor use the default settings for all other floor enter a Z axis insertion point. Click
[OK].

You may need to play with this to find a number that works for the structure you are trying to show.
You don't have to reinsert it every time you want to modify the Z axis. Just open the Drawing
Properties s} tool panel and with the XREF selected in the drawing find the Insertion Point property
and modify the Z Axis there.

.i-_ ;.___ _g_—‘——r—— - —-H - \z
:-.-_ . ’ _l'?.l:l m— e nng_

7.This will load the drawing. Note that you may not see the drawing in the current view of Model
space until you dismiss all dialogs and click Zoom Extents.

8.Repeat steps 4-7 until you have added all floors.

9.Calibrate 263 the map.dwg drawing.

10.Click File > Save.

11.You are done.

4.3 CMS Settings and Options
Navigation: WireCAD CMS Tools Manual 205 >

Menu: Application Menu > Settings
Default Commandline Shortcut: set

To access the settings menu, click Application Menu > Settings. Then select one of the three
default sets of settings Application, User or Project by clicking on the down arrow.
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Note: Third party Plugins may register their own settings categories and panels. Shown are the
stock settings.

xt : IEH

Application A Application Settings
Some of the basic settings and behaviors
Basic

WireCAD Security

Global Database Location

o v| Chedk for Program Updates Automatically Upaon Startup
Organization

Show Application Setup Wizard Upon Startup
Enable/Disable Plugins

Community Equipment Library Connection and Contribution

=
&
R
. Support Paths
%
&=
=

Todo List
v Attempt to connect to the community server over port 1433

User A Community Library Auto-Contribution Mode | AutoContributeMyWerk v
Basic Customer Experience Improvement Program

Projects List v| Silent Plugin Loading (hides message if plugin fails to load)

Drawing

-
=
/&
/" Drawing {(advanced)
-
%
&=

Default Project Database Host{SQL only) | \sglexpress
Command Line Shartouts Use SQL Server Project databases by default

| Users {mere mortzals) can select Project Database Mode
Enterprise CMS ( ) J

Expert Mode Disable Form State Tracking - this may be useful if you are having trouble with different screen resolutions

Disable Matural Sort on grids - this may be helpful if your grids are taking a long time to load
Project ~

Save Cloze Restore Defaults Help

4.3.1  User Settings
Navigation: WireCAD CMS Tools Manual[zb > CMS Settings and Options 27" >

Menu: Application Menu > Settings[User][CMS User]

These are the additional user settings that pertain specifically to the CMS module.
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&1 Settings  IEH
Appiication v CMS User Settings
Some settings spedfic to you
User L] v Use Stock WireCAD Startup Page
Default Mew Circuit Strand Count 2|8
& Basic
Warn of Connector String Mismatch W
£k Projects List
/¥ Draning

/" Drawing {advanced)
£ Command Line Shortcuts

¥ Enterprise CMS

&£k Expert Mode

Project ~

Basic

Advanced
Locations
Delete Handling
Project Rules

Cable Text Search Win...

RN

Enterprise CMS

Save Close Restore Defaults Help

eUse Stock WireCAD Startup Page - Not used anymore.

eDefault New Circuit Strand Count - When creating a new circuit, a default strand count for
jumpers is created. This will change that strand count to a different value.

eWarn Of Connector String Mismatch - Having this box checked will allow a warning message to
display anytime WireCAD detects that 2 ports being connected have a different connector type.

4.3.2  Project Settings
Navigation: WireCAD CMS Tools Manual[z081 > CMS Settings and Options|[zr1 >

Menu: Application Menu > Settings[User][CMS User]
These are the additional project settings that pertain specifically to the CMS module.

Note: You will need to have an open project in order to access these settings.

Note: These settings are project specific and will need to be created for each new project.
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-

£F Basic
£ Projects List

Cable Management System Basics
Some basic settings for the CM5 module

Drawi
/" . Manage Status Items
/" Drawing {(advanced)

. Default Mew Backbone Status | PROPOSED ]
£ Command Line Shortcuts
) Default Mew Circuit Status PROPOSED W
&£k Enterprise CM5
£ Expert Mode
Project ~

£ Basic
& Advanced

Backbone Mumber Format B0} Circuit Mumber Format {0}
£ Locations

Jumper Mumber Format Mok {1k {2 Horizontal Cable Mumber Format | H{0}. {1}. {2}
£ Delete Handling

Default Jumper Manufacturer GEMERIC v | Default Jumper PN GEMERIC W
& Project Rules

Default H Cable Manufacturer | GEMERIC v | Default H Cable PN GEMERIC W
£ Cable Text Search Win...
&£k Enterprise CM5
£ Export Settings
£ Status Behaviour
& GPS Settings

Save Close Restore Defaults Help

eDefault New Backbone Status - When creating a backbone, you have the ability to mark a
"status" on that backbone such as "In Use", "Proposed" ETC. Selecting a status will cause that to
become the default for all backbones in this project. Status Items are defined in the Status
Behavior Project Settings panel.

eDefault New Circuit Status - Just like above, when creating a Circuit, you have the ability to mark
a status on that circuit.

eBackbone Number Format - The variable {0} contains the next number in the Next Numbers grid
for Backbones.

oCircuit Number Format - The variable {0} contains the next number in the Next Numbers grid for
Circuits.

eJumper Number Format -

The variable {0} contains the Circuit base number.

The variable {1} contains the Strand Number of the circuit for this jumper

The variable {2} contains the Ordinal Number of the circuit for this jumper.

4.3.3  Output Settings
Navigation: WireCAD CMS Tools Manual[z08) > CMS Settings and Options[2/1 >

Menu: Application Menu > Settings[Project][Export Settings]
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&1 Settings  IEH

% Basic Ouput Settings

£ Projects List Determines the default preview output behavior
/" Drawing

/" Drawing {advanced) Use Template

## Command Line Shortcuts | Always Ask For Filename and Path

&£k Enterprise CM5 Circuit File Mame Format | CKT{0}

£ Expert Mode Backbone File Mame Format |BE-{0}

Project ~

Basic

Advanced
Locations
Delete Handling
Project Rules

Cable Text Search Win...

L - -0 - - -

Enterprise CMS

¥ Export Settings

# Status Behaviour Circuit Post Process Script

ﬁ GPS Settings Backbone Post Process Script

Save Close Restore Defaults Help

eUse Template - Path to a template drawing that the output will be exported into. Your template
drawings can contain any page borders or layouts and settings that you wish.

eAlways Ask for Filename and Path - You are involved in the file name selection and path.
oCircuit File Name Format - Sets the file name format for Circuit output. {0} = Circuit Name.
eBackbone File Name Format - Sets the file name format for Backbone output. {0} = Backbone
Number.

oFile Format - Presets the output format.

ePath - Where do we output.

oCreate Folders for Each IT System - Create a new folder for each IT System and output the
preview to that folder.

eAutomatically Overwrite Files of Same Name - Self-explanatory.

eAppend Date Stamp to File Name - Self-explanatory.

oCircuit Post Process Script - Path to a c# file which will be run post export but pre write-to-disk.
See the Post Process Scripts |23 topic for more information.

eBackbone Post Process Script - Path to a c# file which will be run post export but pre write-to-
disk. See the Post Process Scripts[2s5 topic for more information.

4.3.4  Status Behaviour
Navigation: WireCAD CMS Tools Manual[=081 > CMS Settings and Options|[zr1 >

Menu: Application Menu > Settings[Project][Status Behavior]
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1 : IEl

Appication M Assigned to Circuit Color
User o [ 5eashel v
Project ~ Status Item Behaviour
Context Status Display Name Back Ground Color Is Blocking
£ Basic % | a@c W _ ]
% Advanced b |Backbones_Status | v | Available [ 255, 255, 255
£ Locations Backbones_Status DEAD [ 255, 165, 0 W
£ Delete Handiing Backbones_Status In Use [ 245, 222, 179 v
£+ Project Rules Backbones_Status PROPOSED [ 255, 255, 255
£8 Cable Text Search Win... Backbones_Status Reserved [ 255, 192, 203 v
Backbones_Status Unknown [ 255, 192, 203 W
% Enterprise CMS Circuits_Status INSERVICE [ 255, 255, 255
o BiEs Circuits_Status PROPOSED [ 255, 255, 255
£ Status Behaviour - (- (]
£ GPS Settings

M4 4 Record 1ofd » W M+ — « + X

Save Close Restore Defaults Help

eAssigned to Circuit Color - The color to display in the Backbones grid if the record is assigned
to a circuit. Here we see circuit 0232 using the backbone B0O00003.41.

Cktho CableType... CableType | CableNo Sresys Destsys SRCPin DestPin SRCLoc SRCEl Destioc Destel SRCConn | DestConn  MultiCore  AvalableC..
7 B | -
GENERIC 43 STRAND... BO0003.35  AD-3 CCRS44 036 036 AMUBLDG ... AMU.COM ... FC sca
GENERIC 48 STRAND... BO0003.37  AD-3 cCRS44 037 037 AMULBLDG ... AMU.COM ... FC scA
GENERIC 48 STRAND... BOODD3.38  AD-3 CCRs44 038 038 AMULBLDG ... AMU.COM ... FC sca
GENERIC 43 STRAND... BO0003.38  AD-3 CCRs44 03 039 AMULBLDG ... AMU.COM ... FC sca
‘( 0232 GENERIC 48 STRAND... BOOOD3.41  AD-3 ccRs44 04 041 AMU.BLDG ... AMU.COM ... FC ScA )
= =
GENERIC 43 STRAND... BO0003.43  AD-3 CCRS44 04 043 AMULBLDG ... AMU.COM ... FC sca
GENERIC 43 STRAND... BO0003.44  AD-3 CCRS44 044 044 AMULBLDG ... AMU.COM ... FC sca
0242 GENERIC 48 STRAND... BOO003.45  AD-3 CCRS44 045 045 AMU.BLDG ... AMU.COM ... FC ScA
0243 GENERIC 48 STRAND... BOODD3.45  AD-3 CCR544 0% 046 AMU.BLDG ... AMU.COM ... FC sca
GENERIC 43 STRAND... BO0003.47  AD-3 CCRS44 047 047 AMULBLDG ... AMU.COM ... FC sca
GENERIC 43 STRAND... BO0003.48  AD-3 CCRS44 0% 048 AMULBLDG ... AMU.COM ... FC sca
~ CableNoPrefix: B00004
GENERIC 24 STRAND... BOODD401  AD-4 AD-5 001 001 AMULBLDG ... AMULBLDG ... st st
GENERIC ~ 24STRAND... BO00D4.02  AD-4 AD-S 002 002 AMULBLDG ... AMU.BLDG ... st sT
GENERIC ~ 24STRAND... BO00D4.03  AD-4 AD-S 003 003 AMUBLDG ... AMU.BLDG ... st sT
GENERIC 24 STRAND... BOODD4.04  AD-4 ADS 004 004 AMULBLDG ... AMU.BLDG ... st st ~
WOH 4 Record9of 11540 b W W< .

eContext - Backbones_grid or Circuits_grid.

eDisplay Name - The name of our status.

eBackground Color - Self-explanatory.

els Blocking - A blocking status is one that blocks operations from proceeding. For example: if we
mark a backbone fiber as DEAD we would not want to use that in a Circuit. If the status item is set
as Is Blocking = true then the New Circuit tool will not allow a circuit to involve that strand of fiber.
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4.3.5 Post Process Scripting
Navigation: WireCAD CMS Tools Manual[205 > CMS Settings and Options (277 >

Post Process Scripting of the output of the Visualizers in WireCAD allow you to customize the final
appearance of the created document.

What follows are two example scripts, one for the Circuit output and the other for the Backbone
output. The process is the same for both. Only the method signature is changed.

Circuits Export Script Example

LI 7777770007777 777 77777777700777777777777777777777777777777777777777
using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using System.IO;

using WireCAD;

using WireCAD.Interfaces;

using VectorDraw.Professional.vdObjects;
using VectorDraw.Professional.vdFigures;
using VectorDraw.Professional.vdPrimaries;
using VectorDraw.Professional.vdCollections;
using WireCAD.ProjectFile.DAL;

using VectorDraw.Geometry;

/// <summary>

/// Fill your titleblock with your data

/// </summary>

//Your class name

public class TitleBlockFiller

{

//the method signature is key so this next line must appear as shown
public static void Run (Workspace ws, Circuits ¢, vdDocument doc)

{

string drawingName = Path.GetFileName (doc.FileName) ;

//change this next line to be your titleblock name
string BlockNameToUpdate = "ansi";

//Get the layout by name that we want to update
vdLayout layOut = doc.LayOuts.FindName ("ANSI B");

//loop through the entities in the layout
foreach (vdFigure figure in layOut.Entities)

{

//if we find a viewport let zoom it to the extents of our model
if (figure is vdViewport)
{
vdViewport vp = figure as vdViewport;
vp.ZoomExtents () ;
vp.Update () ;
}

//now look for our titleblock

if (figure is vdInsert)

{
//cast our base figure into an insert object so we can access its properties
vdInsert insert = (vdInsert) figure;
//now we will test to see if the insert name is one that
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//we know to be a titleblock
//Modify this to meet your needs
if (insert.Block.Name.ToLower () .Contains (BlockNameToUpdate))
{
//need to fix it.
//this next bit makes it insert get the latest version from the blocks table
insert.Update () ;
insert.Invalidate () ;

//we got one so let's set the attributes

//we will use the safeSetAttribute function so that if the attribute doesn't
exist it won't

//fail

//Modify this to meet your needs

//Enter your Attribute names and the values you want to fill them with

ws.Utilities.SafeSetAttributeValue (insert, "SHEET", layOut.Name) ;

ws.Utilities.SafeSetAttributeValue (insert, "Drawing Name",
Path.GetFileNameWithoutExtension (drawingName)) ; B

ws.Utilities.SafeSetAttributeValue (insert, "DWG Number", c.CktNO);

ws.Utilities.SafeSetAttributeValue (insert, "COMPANY", "Slate Gravel Co");

ws.Utilities.SafeSetAttributeValue (insert, "ADDRESS", "Number 1 Quary Way");

ws.Utilities.SafeSetAttributeValue (insert, "ADDRESS2", "Bedrock - The
World") ;

ws.Utilities.SafeSetAttributeValue (insert, "DATE",
DateTime.Now.ToShortDateString());

ws.Utilities.SafeSetAttributeValue (insert, "Scale", "NTS");

insert.Update () ;

insert.Invalidate();

doc.Redraw (true) ;

}

//Now create a text item that displays our circuit number in the upper righthand corner
vdText t = new vdText (doc) ;

t.TextString = string.Format ("CKT - {0}\n{l}",c.CktNO, c.CktDescription);

t.HorJustify = VectorDraw.Professional.Constants.VdConstHorJust.VdTextHorRight;

Box bb = layOut.Entities.GetBoundingBox (true, true) ;

t.Height = .25d;

t.InsertionPoint = new gPoint (bb.Right-3,bb.Top-2);

layOut.Entities.AddItem(t) ;

doc.ActivelLayOut = layOut;

Backbones Export Script Example

The only difference in the two examples is the method signature. Use the code above replacing:
public static void Run (Workspace ws, Circuits c, vdDocument doc)

With:

public static void Run (Workspace ws, CMSSettings settings, vdDocument doc)
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4.3.6  GPS Settings
Navigation: WireCAD CMS Tools Manual[205 > CMS Settings and Options (277 >

Menu: Application Menu > Settings[Project][GPS Settings]

See the Reference section regarding the GPS Settings [+/51 panel.
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5 Reference

Here you will find a listing of all menu functions, forms, and dialogs.

5.1 Ribbon Tabs and Dialogs

Navigation: Reference|zss >

This section provides a reference to the individual controls in the dialogs accessed in the Ribbon
Toolbar.

Only dialogs that need explaining are documented

Please note that although this reference is quite complete, only dialogs that really need explaining
are documented. For example, we assume that you can figure out what menu entries like Save and
Save As do for yourself.

This also applies to simple dialogs whose functions are explained elsewhere. Some of these dialogs
are listed, but only with references to the relevant topics in the Procedures sections.

5.1.1 The Workspace

Navigation: Referencel2s% > Ribbon Tabs and Dialogs [2s5 >

The WireCAD workspace has four main components: The Application Menu at the top of the
screen, the Ribbon Toolbar where you access all program functions, the Tool Panels collection for
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navigating and managing your projects and the Main Window where you edit the content of your
projects. The Main Window can display four distinct environments:

1.The Drawing environment

T WireCAD

o= . - e
T WhreCAD

......

3.The Reporting environment
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5. The Application Menu and Quick Access Toolbar

Quick Access
Application
Menu

x B - e @ Q]

The Application Button in the top left corner of the Help & Manual window is one of the most
important controls. It provides access to the functions normally accessed in the File menu in menu-
based programs. This is where you open existing projects, create new projects, save your projects
under other names and so on.

The Quick Access Toolbar next to the Application Button is a place for frequently-used tools.
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6. The Ribbon Toolbar
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The Ribbon Toolbar is the control center where you access virtually all of WireCAD's functions. If
you use Microsoft Office 2007 you will already be familiar with the Ribbon interface. It is context-
sensitive, automatically displaying functions relevant to what you are currently doing.

Tip: The Ribbon can also be operated almost entirely via the keyboard. To display the accelerator
keys just press and release the ALT key once the keys will be displayed in icons superimposed on
the Ribbon.

7. Tool Panels

A8 e & = b & 8qq S
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o

Tool Panels are organizations of controls. There are different Tool Panels depending on the
current environment.
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8. The Project Explorer Tool Panel

""" The Project Explorer is like Windows Explorer for WireCAD projects. When you load or
create a project all its contents are displayed here, including both the Global Equipment tables

and the Project Databases and files.

B Leators
B Daarepances
[ Rstwted Prodects (Rasd Criy)

g ram Qg P B ree..

Note: This tool panel is active at all times.

9. The Draw Cables Tool Panel

=l The Draw Cables Tool Panel contains all the tools for drawing cables. You can draw
cables with different relationships. You can also set the drawing behavior of cables.
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Note: This tool panel is only active when the current environment contains a drawing.

10. The Drawing Properties Tool Panel

1 "The Drawing Properties Tool Panel allows editing of granular drawing settings. If no entity

selection exists in the drawing the Drawing Properties window will display the general
document properties.
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Note: This tool panel is only active when the current environment contains a drawing.

11. The Find and Replace Tool Panel

" The Find and Replace Tool Panel allows you to search the current drawing, all drawings and
the project databases for text and replace that text with your entered values.
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Note: This tool panel is active at all times.

12. The Plan View Tool Panel

&

" The Plan View Tool Panel allows you to place plan view symbols in your drawing.
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Note: This tool panel is only active when the current environment contains a drawing.
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13. The Favorites Tool Panel

]

™% " The Favorites Tool Panel holds blocks that you have saved as favorites (right-click entity

in drawing>Add to Favorites).
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Note: This tool panel is only active when the current environment contains a drawing.

14. The Command Line Interface

The Command Line Interface allows you to see the command history, receive prompts from the
application and execute commands directly. For a full list of command line command you can
view/edit the Application Menu>Settings[User][Commandline Shortcuts] grid.

T e il L LT Tl o e e———
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5.1.2 Ribbon Tabs

Navigation: Reference[2# > Ribbon Tabs and Dialogs [2s5 >

5.1.2.1 Application Menu
Navigation: Reference[2e% > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|2e) >
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The Application Menu contains the following static menu functions:
eNew Project... - Displays the New Project Wizard.[s2h
eOpen Project - Display a file open dialog. Browse to and select a *.wc6plf file to open the
WireCAD Project.
eSave Project As... - Displays the Save Project As[=b dialog. Use this to create a copy of the
current project in a different location.
eClose Project - Closes the current project.
eFrequently Used Folders >
Project Folder - Opens the root folder of the current project in a window explorer window.
Global Data Folder - Opens the global data folder. C:\Users\Public\WireCAD\WireCADXx
User App Data Folder - Opens C:\Users\<YOUR USER
NAME>\AppData\Local\WireCAD\WireCADx
eSecurity Tools >
View Permissions - Shows the permissions grid.
Manage Security... - Shows the Users Groups and Permissions dialog |z
eCheck In/Out >
Pack Up / Check Out - Packup/check/ s out utility. Collects all info for the project and makes is
portable.
Unpack Project ... - Unpack a project. [ss)
Check In Project - Check in a Checked Out project/ssb.
eProject Info - Project specific info[s like the current revision and related projects list.
eAccount Info - Who is the project for/[s:b.
eApplication Setup - Displays the Application Setup Wizard|[=M. This is shown once on startup but
you can review and change settings here.
«Settings - Displays the main Settings s dialog.
oExit - Exits the program.

5.1.2.2 Project

Navigation: Referencelzs > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs81 >

byl = = B o T RN~ B > G = R} (ToC).DW
" Project File Drawing CAD Tools Advanced Tools View Database Flugins Repol
A—
a . W S z =
= & — a @ M° == %

Mew Project  Open Project  Close Recent  Publish Project  Project Batch  Archive TiteBlock ToC
Project  Projects = to Partal Time Sheet  Plot  Project  Manager

The Project Ribbon Tab is a static menu structure. It does not change with environment changes.
The Project Ribbon Tab contains the following menu items:

New Project ... - Display the New Project Wizard|s2b,

Open Project - Display a file open dialog. Browse to and select a *.wc6plf file to open the WireCAD
Project.

Close Project - Close the current project.

Recent Projects - Most recently used projects list. This selection is based on the Project List
setting in the Application Menu>Settings[Project List].
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Batch Plotter - Launch the Batch Plotter! 2o tool.

Archive Project - Launch the Archivessh tool.

Titleblock Manager - Launch the Titleblock Manager /= tool to assign common variables to all of
your title blocks in the project.

ToC - Launch the Table of Contents|ss5 generator that creates a Table of Contents from the data in
the project Drawings table.

Publish Project to Portal - Launch the Publish Project to Portalzsh tool.

Other

While WireCAD does not currently merge any other tools with the Project menu, authors of
WireCAD plugins have the ability to merge their own tools onto this ribbon tab. Consult their
documentation for information.

5.1.2.3 File
Navigation: Referencelz:8 > Ribbon Tabs and Dialogs [2¢5 > Ribbon Tabs|zs1 >

The File Ribbon Tab is a dynamic menu that changes its structure with the current environment.
Drawing Environment
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Again, we will not explain the obvious ones.

eNew Drawing ... - Shows the New Drawing Wizard |ssd.

eSave As Template Drawing - Any drawing may be used as a template from which other drawings
may be created. Simply Save As Template Drawing to make your drawing usable in the New
Drawing Wizard as a starter drawing.

ePrint Preview ... - Display the Print Preview s dialog.

«PDF Export ... - Display the PDF Export /s dialog.

eExport to Visio - Create smart Visio drawings [ss5 where the WireCAD cable becomes live active
Visio connections.

eSettings ... - Display the main Settings [+ dialog. Same as clicking Application Menu>Settings.
ePurge ... - Purge/+b unused entities from the drawing.

eTodo - Create a New Todol+" linked to this drawing.

Data Environment
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For an general discussion on grid basics see this topic/ +\.

eNew - Create a new item on the collection. The dialog presented will differ based on the
collection.

eClear Data [Del] -

eDelete Selected Rows [Ctrl + Del] -

«Copy Down [Ctri]+[D] -

eIncrement Down [Ctri]+[I] -

*Find and Replace -

eFunction - Displays the Expression Builder[s% dialog so you can manipulate data using the
Expression engine.

eTools - See Grid Specific Functions for a listing of the tools available to each data grid.

Other

While WireCAD does not currently merge any other tools with the File menu, authors of WireCAD
Plugins have the ability to merge their own tools onto this ribbon tab. Consult their documentation
for information.

5.1.2.4 Drawing
Navigation: Reference[2# > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|2s) >

Active only when the current environment is a drawing.

ME 5w = 0aQqQq revert test.DWG - WireCAD10 - PRO - Current Project: [News Production Control Demo] =
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Grid Mode - Toggle the visible grid [F7]. Note: the visible grid is rendered only for the Drawing
Limits which can be set in the Drawing Properties Tool Panel.

Snap Mode - Toggle the invisible snap grid [F9]. The invisible snap grid is based on the SnapX and
SnapY settings in the Drawing Properties Tool Panel.

Polar Track Mode - Toggle PT mode. When enabled and in a function requesting a point from the
drawing the selectable polar angle will be restricted to the Polar Track Angle in the Drawing
Properties Tool Panel.

Extension Tracking -

Ortho Mode - Toggle restrict movement to horizontal/vertical only.

Coordinate - Displays the cursor position in current coordinates. Coordinates are expressed in
drawing units (DU).Drawing units do not express particular units(meters,inches etc).

In this part user have to make some assumptions in order to define that the coordinates of the
drawing mean particular units(meters,inches etc).

For example:
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For a mechanical drawing we can make the assumption for example: where one drawing unit
defines one millimeter(1 D.U=1mm).
For a architectural/technical drawing we can make the assumption for example: where one drawing
unit defines one meter(1 D.U=1m) or one foot.
This can be very helpful in designing,dimensioning,retrieving information from the
drawing(distances,area calculations).

GripBlockStandard - Show only one grip per insert.
GripBlockAttributes - Show one grip per attribute in the selected insert. Grips can be used to
reposition the attribute if the Attribute is set to LockPosition = false.

Layers ... - Shows the Layers [ dialog.

Layouts ... - Shows the Layouts [s5) dialog.

Point Styles ... - Shows the Point Styles[= dialog.

Text Styles ... - Shows the Text Styles| s dialog.

Dim Styles ... - Shows the Dimension Styles [ dialog.

Model Space Bounds - Shows the Model Space Boundaries|«b dialog.
Groups ... - Shows the Groups |« dialog.

Images ... - Shows the Images |+« dialog.

UnSelect - Clears the current selection. Same as pressing {esc}.

Select - Start a selection.

Erase - Erase the current selection. If no selection then you will first be prompted to select entities.
Copy - Copy the current selection. This is a base-point or offset copy and is preferred over [Ctrl][C]
then [Ctri][V] if copying in the same drawing as it is lighter weight. If no selection then you will first
be prompted to select entities.

Move - Move the current selection. If no selection then you will first be prompted to select entities.

Scale / Skew - Scale the current selection. If no selection then you will first be prompted to select
entities.

Scale / Skew >Scale (uniform) - Scale the X and the Y directions to the same scale factor.

Scale / Skew >Scale To (uniform) - Scale from the current size to a specific number. Allows you
to scale without doing the math to calculate the scale factor.

Scale / Skew >Scale X - Scale the entities in the selection set in the horizontal direction only.
Scale / Skew >Scale Y - Scale the entities in the selection set in the vertical direction only.

Scale / Skew >Skew X - Skew the entities in the selection set in the horizontal direction.

Scale / Skew >Skew Y - Skew the entities in the selection set in the vertical direction.

Rotate - Rotate the current selection. If no selection then you will first be prompted to select
entities.

Mirror - Mirror the current selection. If no selection then you will first be prompted to select entities.
Stretch - Stretch polylines in the current selection. If no selection then you will first be prompted to
select entities.

Explode - Explode the current selection. This function will reduce complex object to their primitive
constituent parts. For example; exploding an insert unlinks all of the entities back one level.
Exploding a polyline reduces the polyline to a collection of line segments. If no selection then you
will first be prompted to select entities.

Entities that can been exploded:

¢ vdDimension explode to vdLines, vdText(s), and vdinserts (the arrows).

¢ vdinsert explode to the entities that is consist of. (If there are Inserts inside Blocks then you may
need to apply more than 1 explode to get the base entities).
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vdPolyHatch explode to vdPolyline(s).

vdPolyline explode to vdLine(s) and/or vdArc(s).

vdRect explode to vdPolyline.

vdText explode to vdPolylines(only texts with fontfile SHX).TTF(true type font) texts are not
exploded.
Trim - Trim objects at a cutting edge defined by other objects the current selection. First select the
objects that define the cutting edges at which you want to trim an object and then the object.
Objects that can be trimmed include arcs, circles, elliptical arcs, lines. Notice that the trim
command do not function if the objects do not intersect.
Extend - Extend lines,arcs,polylines until they intersect with some other object which is used as
limit of the extension. Firstly you have to select the objects that consist the limits of the extension.
Then you have to choose a point at an object that you want to extend. If the object you want to
extend does not intersect with above objects then nothing will happen.

Fillet - Connect two lines , two arcs, or one arc with a line(these two objects must have at least one
common point either visible, or in their extension) , with an arc with a specific radius. The value of
the radius has some restrictions depending the position of the objects. If radius=0 then simply the
objects are either extended until they intersect each other in one point (if there was not an
intersection point) either trimmed (if an intersection point is visible).

Offset - Create a new object in parallel direction and in a specified distance from the original object
which is used as pattern for the new object. When you execute an offset command, you are
prompted to select an object. Then you have to specify the offset distance which is the distance
that the new object will be drawn from the original object. Then you have to set the side that the
object will be drawn because there are two sides.

Rectangular Array - Creates multiple copies of objects in a rectangular pattern. Shows the
Rectangular Arrayl«f dialog. With the rectangular array you can create an array defined by a
number of rows and columns of copies of the selected object. First you have to select the objects.
Then you have to define number of rows and number of columns of the rectangle, the distance
between rows and the distance between columns. If no selection then you will first be prompted to
select entities.

Polar Array - Same as R Array but copies radially around a center point. Select the objects to
copy. Then set the center point and next define the numbers of the copy objects that will be created
and the fill angle. Lastly choose if the object will be rotated or not. See the Polar Array dialog
Bring to Front - Bring to front. This changes the Z order of the objects in the render engine
bringing the current selection to the front. If no selection then you will first be prompted to select
entities.

Send to Back - Send the current selection to the back of the Z order. If no selection then you will
first be prompted to select entities.

Corner - Causes lines that can intersect to intersect. Start the command then select the first line
then the second line.

Chamfer - Chamfer the polyline, line, distance or angle object at two intersecting points by the
entered distance.

Break - Break a line, polyline, circle, arc, etc. based on the selected distance.

A
lign and Distribute

The align functions require a selection set with at least two entities selected. The first item in the

selection is used as the reference. The others in the selection are then aligned to the reference
point.
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If the two selected entities are WireCAD blocks with cables attached, the cables will be rerouted.

Align and Distribute>Align Lefts - Left edges.

Align and Distribute>Align Rights - Right edges.

Align and Distribute>Align Tops - Top edges.

Align and Distribute>Align Bottoms - Bottom edges.

Align and Distribute>Align Middles - Middles (vertically).
Align and Distribute>Align Centers - Centers (horizontally).

The distribute functions require a selection set with at least three entities. The entities can be
distributed using uniform spacing between entities or center-to-center spacing of the entities. The
eyeball tends to see the space between the entities especially if the entities are not uniform in size.

Align and Distribute>Distribute Y Centers - Distribute the selection vertically based on center-to-
center spacing.

Align and Distribute>Distribute Y Spacing - Distribute the selection vertically based on uniform
space between entities.

Align and Distribute>Distribute H Centers - Distribute the selection horizontally based on
center-to-center spacing.

Align and Distribute>Distribute H Spacing - Distribute the selection horizontally based on
uniform space between entities.

Align and Distribute>Increase Y Spacing - Increase the vertical spacing. You will be prompted
for the spacing distance.
Align and Distribute>Decrease Y Spacing - Decrease the vertical spacing. You will be prompted
for the spacing distance.

Align and Distribute>Increase X Spacing - Increase the horizontal spacing. You will be
prompted for the spacing distance.
Align and Distribute>Decrease X Spacing - Decrease the horizontal spacing. You will be
prompted for the spacing distance.

5.1.2.5 CAD Tools
Navigation: Referencelzs > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs1 >

Active only when the current environment is a drawing.

Ha e

Entities Page Group
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eLine - A single line segment. Lines can be one segment or a series of connected segments, but

each segment is a separate line object.

[ EndPoint]

o

[StartPoint]

ePolyline - 2D/3D line composed of line and arc (bulges) segments. Polyline is specified by an
array of Vertexes (points). When the Polyline has thickness then the extrusion vector of the polyline
defines the direction of the thickness. Polylines can be Open or Closed, can be SPLine and be filled

with a color or a hatch.

\

\

oCircle - A full circle is defined by its CenterPoint and its Radius. Circle is drawn in the plane that is

defined by CenterPoint and ExtrusionVector.

ePoint - An object which occupies a single point in the coordinate system. The display of the point
is inherited from the document Point Style property and can be set by clicking Drawing>Point

=

Styles...
Poell 8yl Fineal
P Frogarsm
-
Crm
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eRectangle - A rectangular object defined by an insertion point, height and width.
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oText >

Single Line of Text - Text inherits its style from the document Text Styles collection which can be
edited by clicking Drawing>Text Styles... Text entities do not have font properties directly but
inherit the font and font properties from the associated Text Style.

«%‘"@
%‘3&@

Multhine Text (MTEXT) - A multiline text entity.
Thisis
a MTEXT,

Alphanumeric Sequence - Create a sequence of text entities. See Alphanumeric Sequence dialog
here. [+2h

FRED-1
FRED-2
FRED-3

FRED-4

Text Increment - Modify an existing selection of text entities with a sequence of numbers. For more
information see Text Increment/ 2% dialog here.

eImage Frame - Used to render images in the document. Images may either be linked or imbedded
in the drawing file. The image frame defines the location and size of the displayed image. To imbed
an image you must edit the document Images collection Drawing>Images.
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eConstruction Ray - A line entity defined by its starting point and an angle.

&

/!

e

S

V

¢2 or 3 Pt Arc - A circular arc defined by the center point, the radius, the start angle and the end
angle. An arc is always drawn anti-clockwise from the StartAngle to the EndAngle. The StartPoint
and EndPoint properties of an arc are calculated through the StartAngle, EndAngle and Radius
properties. The ExtrusionVector is always vertical to the arc. Arc is drawn in the plane that is
defined by CenterPoint and ExtrusionVector.

P —

O

oEllipse - Draw an Ellipse.
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-

i .
[

eCloud - Draw a cloud.

Blocks and Inserts Page Group

eInsert Block Into Drawing - Opens the Inserts|[«b dialog. You can then insert an existing block
into the drawing or browse to another file to insert in the drawing.

esWrite Block to File - Writes the selected insert out to its own file prompting you for the file save
as name and location as well as the new basepoint for the drawing.

oCreate Attribute Definition - A tag/value data pair that can be included in a block to display
editable text. See the Add Attribute Definition[+# dialog.

eMake a Block - Select entities and group them into a unit called a block. The block resides in the
document Blocks table. To display a block we Insert an instance of the block into the drawing at
some point, scale, and rotation.

eExternal Reference Manager - Other drawings may be displayed within the drawing space and
maintained as separate files. These are called Externally Referenced (XREFS) drawings. The
externally referenced drawing cannot be edited in the current drawing, only viewed, positioned,
scaled and rotated. This function opens the External Reference Manager!«¥ dialog.

oEdit Attributes - Allows editing of the attributes of the selected insert of a block. Here you can
adjust the display value, style, color. The dialog also supports updating other instances of the same
insert, or all inserts with matching Tags. See here[+®.

Dimensions Page Group

Dimensioning is the process of adding measurement annotation to a drawing. There are many ways
to dimension objects and many ways to format dimensions. You can create dimensions for a wide
variety of object shapes in many different orientations. You can create dimension styles to format
dimensions quickly and ensure that dimensions in your drawing conform to industry or project
standards. Dimensions show the measurements of objects, the distances or angles between
objects, or the distance of a feature from an origin you specify. There are three basic types of
dimensioning: linear, radial, and angular. Dimensions can be horizontal, vertical, aligned, rotated,
and angular. A linear dimension measures the distance between two points which is displayed
parallel to the points being measured. In aligned dimensions, the dimension line is parallel to the
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extension line origins. The extension line origins are specified using the DefPoint1 and DefPoint2

properties.
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5.1.2.6 Advanced Tools
Navigation: Referencelz: > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|2e5 >

Active only when the current environment is a drawing.

M F@o 0 =) @] AUDIO.DWG - WireCAD10 - PRO - Current Project: Nlews Pry
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- ex ] Draw Cable: ¥, v

Equpment | RackBulder | Assign  Emor Reset
Lbrary Syshame  Check v o

=% Update Assigned Cable(s) | @) AutoBlock | Q@ WireCADify Block.

Showpartino P Rosrest | Add Comectenpont

S NumberingMode[De . ~| ], AddSpare Cable(s)  Slurp Cables:

Equipment Library page group

Equipment Library - Opens the Equipment Library [«8.

Rack Tools page group

Rack Builder - Opens the Rack Builder/+# tool.
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Equipment Functions page group

Assign SysName - Assigns a SysName[4¥ to all selected inserts that are assignable.

Error Check - Shows the Drawing SysName Error Check [« dialog.

Reset>Reset All Systems - Reset will remove the SysName data from the insert and do nothing
with the database. The Reset functions are useful if you need to reuse a drawing and reassign new
numbers.

Reset>Reset Selected Systems - Reset will remove the SysName data from the insert and do
nothing with the database. The Reset functions are useful if you need to reuse a drawing and
reassign new numbers.

Reset>De-Assigh SysName - De-Assign will remove the SysName data from the insert and mark
the record in the database deleted/available. See also: Project Delete Handling [z settings.

Pointer Operations>Link Selected Pointers - Allows you to link a selection of pointers with
another selection of pointers.

Pointer Operations>Rereference Drawing Pointers (change sheet reference name) - Allows
you to change the name of the sheet to which pointer(s) are pointed.

Pointer Operations>Error Check Pointers - Launches the Error Check Pointers dialog[«®. This
tool tests the links between pointers. It does not test the connection to ports, nor does it test the
validity of the connections, only whether the pointer is properly in both direction.

Swap>Swap Equipment - Allows you to change your equipment out for something else. See the
Swap dialog here[«H.

Swap>Swap All Pointers - Allows you to change your pointer type if the current pointer displeases
your eye. See the Swap Pointers dialog herel5.

Swap>Swap All Terminals - Allows you to change your terminal type if the current terminal
displeases your eye. See the Swap Terminals dialog here[4%.

Show Assignment Dialog - When checked displays the SysName Assignment[« dialog.
Otherwise the assignment proceeds with all default information.

Next No - Dropdown to set the next number of the selected sequence.

Location - Dropdown to set the default Location. You can also add a new Location with the [+].
This presets the Location field in the New SysName assignment [« dialog.

Sync Insert with Database - Checks the selected insert to see if the SysName, Alias,
Manufacturer, EquipmentName, Location and User fields match the Equipment List. If they do not
you will be presented with the Sync Equipment Decision |« dialog.

Slurp SysNames - Gets all of the SysName data from the drawing and adds it to the database if
not found in the database.

Assign Terminal(s) - Starts the terminal assignment dialog for the current selection of assignable
terminals.
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Cable Functions page group

Assign Cable Number - Assigns the cable[+% a number based on several factors:

The Project Settings[Starting Number][ss4.

Project Cable Number Format /25 tool.

Next Number!s«) sequence.

Show Cable Assignment Dialog - See below.

The process of assignment will update drawing with the number as well as place an entry in the
project Cables table.

Error Check - Shows the Error Check 4 dialog.

Reset>Reset All

Reset>Reset Selected Cables - Removes the Cable data from the drawing and do nothing to the
database. The Reset functions are useful if you need to reuse a drawing and reassign new
numbers. This function does not work across pointers.

Reset>De-Assign Cable Number - De-Assign will remove the Cable data from the drawing and
mark the record in the database deleted/available. This function works across pointers. In other
words if the cable that is being de-assigned is pointed to another cable/drawing the complementary
pointer is de-assigned as well. See also: Project Delete Handling[=sh settings.

Show Assignment Dialog - When checked displays the Cable Assignment [4sh) dialog. Otherwise
the assignment proceeds with all default information.

Next No - Dropdown to set the next number of the selected sequence.

Numbering Mode - Numbering sequence mode (Default (no skipping), Evens, Odds, Fives,
Tens). Use to skip numbers.

Add Multicore Cable - Displays the Add Multi-core Cable[«b dialog. There you select the cable
type number base, etc. and build an entry in the Cables table for every core in the associated cable
type marking the records available.

Draw Cable - Starts the Draw Cable /s function.

Add Spare Cable(s) - Add spare cable(s) that do not connect to anything yet but can have. See
the Add Spares |« dialog.

Recover Cables - The Recover Cables function does the following:

¢ Gets all cable data from the drawing.

e Compares it to the Cables table of the project.

¢ Updates the Cable Number information in the drawing for matches. A match is found when the
source and destination SysNames, Locations, and Port names match.

Tidy Cable - Forces the selected cable to be orthogonal (horizontal or vertical only).

Slurp Cables - Gets all of the Cable data from the drawing and adds it to the Cables table if not

found in the database.

Update Assigned Cable(s) - Ensure that the database matches the currently attached ports. Can
be used after a cable has been moved to another port.
Show Port Info - Click a port to show all port data Name - Connector - Type.

AutoScheme Tools page group
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Auto Block - Shows the Auto Block [+ dialog. With Auto Block you can place functional blocks in
the drawing on a grid simply by selecting which SysName to place.

Ratsnest - Shows the Ratsnest [« dialog. Used in conjunction with Auto Block to wire the placed
blocks. Pulls cable data from the Cables table, searches the drawings for matches and when found
places a cable.

WireCADify Tool page group

WireCADify Block - Shows the WireCADify Block[«% dialog. Add the WireCAD attribute set to
your CAD blocks. You do not need to use this command on any WireCAD generated block.

Add Connection Point - Shows the Add Connection Point[«% dialog. Add WireCAD Connection
Points to blocks that you have WireCADified. You do not need to use this command on any
WireCAD generated block.

5.1.2.7 View
Navigation: Referencelzs8 > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs |z >

The View tab is dynamic. It merges tools from the current environment.
Static View

b
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eTool Panels >

Project Explorer - Toggle the visibility of the Project Explorer|ss Tool Panel.

Draw Cables - Toggle the visibility of the Draw Cablesssh Tool Panel.

Drawing Properties - Toggle the visibility of the Drawing Properties [ss5 Tool Panel.
Find and Replace - Toggle the visibility of the Find and Replace s Tool Panel.
Plan View Tools - Toggle the visibility of the Plan View Tools [/ Tool Panel.
Favorites - Toggle the visibility of the Favorites Tool[s7% Panel.

Command Line - Toggle the visibility of the Command Line!s/ Tool Panel.

There may be others depending on the plugins that are loaded. These are the default tool panels.
eShow Start Page - Toggle the visibility of the Start Page.

oSkin Gallery - Select the look and feel of the application.

eSwitch Windows - {Current Window Set} - Toggle the active window.

Drawing Environment View
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View page group

ePan - Reposition of the view. This can be better done with the mouse wheel of your mouse.
Depress the mousewheel to click the button underneath it to activate the PAN mode. NOTE: this
relies on your mouse driver middle button set to default.

eZoom Commands - Zoom command allows the user to increase or decrease the apparent size of
objects , so the user can control the part of the drawing that is included in the screen. Zoom
commands are transparent. Transparent commands are commands that can be invoked when
another command is active.

Remarks:

There are several ways to execute the zoom command:

"E"(Extends) Zooms to display the drawing extents

"P"(Previous) Zooms to display the previous view

"W"(Window) Zooms to display an area specified by two opposite corners of a rectangular window.
User must specify these two corners.

"A"(All) zooms to the drawing limits or current extents, whichever is greater.

eZoom Scale - Show the Zoom Scale dialog. Zooms the display at a specified scale factor. For
example, entering 2 doubles the apparent display size of any objects from what it would be if you
were zoomed to the limits of the drawing. Entering 0.5 causes each object to be displayed at half its
current size on the screen.

eRegenerate - Re render the entire drawing.

eNew Viewport commands - Viewports are areas that display different views of your model. As
you work, you can split the drawing area into one or more adjacent rectangular views known as
model viewports. In large or complex drawings, displaying different views reduces the time needed
to zoom or pan in a single view. Also, errors you might miss in one view may be apparent into
others. ViewPorts are treated as rectangle drawing objects which display views and can be moved
or resized. They can be created only in a layout and not in Model space. You can also attach
viewports to closed polygons (polylines, circles, ellipses, rectangles).

Object Snaps page group

Object Snaps - OSnaps provide an easy way to pick geometric points from the drawing.

OSnap Function

End End Point snap

Mid Mid Point snap

Center Center snap

Ins Insertion Point snap

Perp Perpendicular To snap
Near Nearest snap. This one overrides all others.
Inter Intersection snap

Node Point snap

Quad Quadrant snap

Tang Tangential To snap
Appint Apparent Intersection snap
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Disable Toggle currently selected OSnap state
All Enable/Disable all.
Info page group

eMeasure Distance - Measure the distance in Drawing Units(DU) between two points selected from
the drawing.

eArea - Measure the area of a selected object.

¢ID - Get the drawing ID of the selected object.

Other

While WireCAD does not currently merge any other tools with the View menu, authors of WireCAD
plugins have the ability to merge their own tools onto this ribbon tab. Consult their documentation
for information.

5.1.2.8 Database
Navigation: Referencelzs8 > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs >

No environments currently merge with this tab. This is the default view but Plugins may register
additional commands.
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Equipment Library page group

eEquipment Library - Show the global Equipment Library [+,

Global Database Grids page group

eManufacturers - Show the global Manufacturers[s:5 Grid.

eEquipment - Show the global Eguigment% Grid.

eConnectors - Show the global Connectors|s2) Grid.

eCable Types - Show the global Cable Types|s2% Grid.

eDefault Signal Types - Show the Default Signal Types|s:1 Grid. This grid defines many default
behaviors like cable color and default cable type. For more information see this topic on Signal
Types| =8

ePinouts - Show the global Pinouts [=5 tool.
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Project Database Grids page group

eEquipment List - Show the project Equipment List[ss5. This is the collection of all SysNamed
equipment across all drawings in the project.

eBackbones - Show the project Backbones grid. (ENT ONLY). This is the collection of all
Backbones in the project.

oCircuits - Show the project Circuits grid. (ENT ONLY). This is the collection of all Circuits in the
project.

eCables - Show the project Cables s grid. This is the collection of all Cables in the project.
elndex Grids > For more information see_this topic /5. This sub menu will show any or all of the
index grids and allow you to delete and rebuild the indexes.
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«Project Signal Types - Show the Project Signal Types s grid. This grid has priority for Signal Types.
If a signal type is not found in this database it is pulled from the Default Signal Types|s2" grid.
eLocations - Show the project Locations grid. This is the collection of all Locations in the project.
eNamed Paths - Show the project Named Paths grid. This is the collection of all Named Paths in
the project.

eTodo List - Show the project Todo List.

eImport Project Data Wiz - Show the project Import Data Wizard. This tool allows you to import
cable and equipment data from other sources.

eAdd Multicore Cable - Displays the Add Multi-core Cablel+sb) dialog. There you select the cable
type number base, etc. and build an entry in the Cables table for every core in the associated cable
type marking the records available.

Utilities page group

ePack Project Database - This file base database utility will compress and reorganize your project
database.
ePack Global Database - This file base database utility will compress and reorganize your global
database.
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eSynchronize Global Database - Show the global database Synchronizer|+#) tool. This tool allows
you to import/export/merge two global databases of either SQL,VISTA, or SQL Azure.

5.1.2.9 Plugins
Navigation: Referencelzs8 > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs |z >

This tab is dynamic. Depending on product level and installed third party or WireCAD plugins these
menu items are subject to change.
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Plugins page group
ePlugin Manager ... - Shows the Plugin Manager/sk dialog where you can control which plugins
are loaded.

«Script Editor Runner - Shows the Script Editor/Runner/s dialog. This tool allows you to create
custom scripts to perform tasks. You can view/edit existing scripts that show how to do a bunch of
things by browsing to the script folder in c:\users\public\wirecad\wirecadx\scripts. Therein you will
find many example scripts. Scripts are written in C# and the editor provides intellisense hints.
eTranslation Manager - Shows the Translation Manager/[+sh. While not technically a plugin we
have always shown it here so why break with tradition. All text (strings) in WireCAD are held in a
dictionary. The dictionary is editable through the Translation Manager. All strings default to English
if the machines current culture cannot find a translation in the dictionary. You have the ability to
change the displayed messages, column headings, and all other strings.

eBatch Plot - Show the Batch Plot/20b tool. This tool allows you to scan the drawings for layouts
and select the layouts to print/plot in a batch. You can save/load your settings for the next time
around.

eBrother P-Touch! - Show the Brother P-Touch! plugin to print directly to P-Touch! printer with
USB ports that support direct print. (NOTE: not all P-Touch! printers with USB ports support direct
print).

ePatchVerx - If you have installed PatchVerx on your machine this icon will be present so you can
run the worlds best patchbay designation strip tool inside of WireCAD and pull data directly from
your Cables table and place in on your patchbay label.

CAD Tools page group

eExtract All Blocks - Extracts all blocks[ b from the active drawing and writes them out as
individual dwg files to the selected folder.

eBulk Block Fixer - If you want to use someone else's CAD blocks you will need to fix them so
they work with WireCAD. This is the tool.

«DWG Diff - Drawing Differencing tool. Compare two similar drawings and create three views A not
B, B not A, and Common to Both. Compares geometry and drawing collections like layers,
linetypes, etc.
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5.1.2.10 Reports
Navigation: Referencelz: > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs81 >

ltems on this tab are static. Whether or not the gallery displays is based on the Application
Menu>Settings[User][Basic]ReportShowMode.
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Reports page group

eNew with Wizard... - Create a new report using the New Report Wizard. We recommend that you
find a report in the existing Reports Gallery that is close and save that as your new name then edit
your changes there. You will save a bunch of time.

eGenerate Bill of Materials - Shows the BOM generator/ss which counts equipment, cable, and
connectors in the project. NOTE be sure to run this tool before you run any of the BOM reports or
they will be empty.

eScan Project for Discrepancies - Scan for common problems. Shows the Discrepancy
Scanner|seh dialog. When it finishes you can see the results in the Project Discrepancy list from
the Project Explorer.

eReports Gallery - Lists all reports in the %REPORTS% support path and its subdirectories.
Clicking a gallery item will load the report into a report form for preview/design/export.

5.1.2.11 Plan View and Layout Tools

Navigation: Referencelzs8 > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs >

Active only when the current environment is a drawing.
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For more information see the Plan View and Layout Tools|[ s topic.

Estimating page group

eTake Offs - Show the Take Offs[«M tool. This tool assists in counting items in the drawing.

Locations page group
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eAdd Boundaries from Text - Add Location Boundaries[sn using a text entity to derive the
location name. Once you select a text entity the Boundaries form is displayed allowing you to set
the remainder of the properties.

Cabling page group

eDraw Backbone - ENT only. Draw a polyline representing the backbone in the plan view space.
Then assign a number, cable type, source and destination ports and add that to the database.
eDraw Cable - Drawing a polyline representing a cable from a location boundary to another location
boundary or from placed equipment to placed equipment. Cable information is then created in the
Cables table.

ePopulate Cables - Automatically places arched cables from location to location as defined in the
Cables table.

eDraw Prewire Cables - Draw a polyline representing prewire cables and add the data to the
Cables table marking the 10 as PREWIRE. Later, you can assign cables to those PREWIRE
entries.

Equipment page group

ePopulate Equipment - Automatically place SysNamed equipment in the drawing in the Location
Boundaries if found.

ePlace Equipment - Place unnamed plan view equipment in the drawing. Preferably after Location
Boundaries have been defined.

5.1.2.12 Print Preview
Navigation: Referencelzs8 > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs >

Visible only when the active environment is a report.
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Related Topics:
Print Preview Reports Form/[ssh

5.1.2.13 HTML View
Navigation: Reference[2e% > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|2s >

Visible only when the active environment is a report.
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Related Topics:
HTML Preview Reports Form/ssh

5.1.2.14 Report Designer
Navigation: Referencel2s% > Ribbon Tabs and Dialogs [2¢5 > Ribbon Tabs|zsh >

Visible only when the active environment is a report.
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Related Topics:
Report Design Form|ssh
A discussion on report design can be found here[ 7.

5.1.2.15 Toolbox
Navigation: Referencelzs% > Ribbon Tabs and Dialogs [2¢5 > Ribbon Tabs|zsb1 >

Visible only when the Report Designer Tab is active.
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Related Topics:
Report Design Toolbox Form/[ssy

5.1.2.16 Cable Data Selector
Navigation: Referencelzs > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|zs81 >

Visible only when the active environment is a report.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

- | x]_ B L6 ren
oy | WO | Lo ﬂ
ekl | o Solpct il | o e ety R .- iy

Rctorm

Related Topics:
Cable Data Selector Form|ssh

5.1.2.17 GPS Mapping Tools For Drawings

Navigation: Referencelzs5 > Ribbon Tabs and Dialogs [2s51 > Ribbon Tabs|2sh1 >

Active only when the current environment is a drawing.
The GPS Mapping Tools section provides access to the functions necessary to use your DWG
plant drawings with the GPS coordinate system.

5.1.2.17.1 GPS

Navigation: Reference[=s81 > Ribbon Tabs and Dialogs/z5 > Ribbon Tabs/z8 > GPS Mapping
Tools For Drawings|[s® >

Active only when the current environment is a drawing.
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Calibrate: Align the world coordinate system of the drawing to the GPS coordinate system.

Delete Calibration: Removes the calibration data from the drawing. Only available if the drawing
has current GPS calibration data.

Copy from Other Drawing: Allows you to copy calibration data from a drawing that shares the
same coordinate data. The drawing you are copying from must have GPS calibration data or this
function will fail.

Show Calibration Marks: Place location markers at the two calibration points in the drawing.

Related Topics:
How To: Calibrate Your DWG to the GPS Coordinate System|zé%
How To: Copy Calibration Data from another Drawing| 25

5.1.2.17.2 Tools

Navigation: Reference[zs5 > Ribbon Tabs and Dialogs/2s% > Ribbon Tabs/z8 > GPS Mapping
Tools For Drawings| s >
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Active only when the current environment is a drawing.
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Relate Section
ID Location GPS Coord: Associate a Locations table record with a specific GPS coordinate point.

Related Topics:

eHow To: Associate GPS LAT, LON with your Locations|2s5 Map tool version
eHow To: Associate GPS LAT, LON with your Locations| s DWG version.
«ID GPS Locations /s dialog reference.

Tools Section

Get GPS Point to Clipboard: Allows you to select a point in the drawing. Once a point is selected
its GPS lat, lon are copied to the clipboard as text. You can paste this data into any other
application as text.

Show GPS Point in Drawing: Prompts for the GPS Lat,Lon to show. Enter the Lat,Lon in the
command line. A location marker will be placed and zoomed into view.

Draw Section

Panel: Place a new SysNamed Panel or other equipment at a specific location within the drawing
using the GPS Location markers as the location for the equipment. Requires that at least one
Location Marker is displayed. For more information on displaying Location Markers see this

Backbone: Draw a new Backbone between two panels. The panel markers must exist in the
drawing.

Related Topics:
eHow To: Show Panel Markers in your Drawing|27.
eHow To: Draw a Backbone in your Drawing.

5.1.2.17.3 Display

Navigation: Reference[2s% > Ribbon Tabs and Dialogs[2#% > Ribbon Tabs[2% > GPS Mapping
Tools For Drawings|ss >

Active only when the current environment is a drawing.
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Reset Section

Reset All: Removes existing Location, Panel and Backbone markers.

Location Marker Section

Location Marker: Toggle the view of the Location Markers in the GPS calibrated drawing.

Location Markers are inserts that are placed at the GPS coordinates of the drawing. The tooltip of
the marker displays the Location name as defined in the Display Format String of the GPS
Settings [+ tool as well as any equipment found at that location.

Location Markers are placed in the drawing on a layer named "GPS_LOC_PIN_TEMP". We do not
recommend placing any other entities on this layer. When the Location Marker toggle button is set
to unchecked, all layer entities are deleted without prompting.

Double-clicking a Location Marker in the drawing will show its statistics.
Insert Scale: Sets the scale of the block defined in the Geometry setting.

Geometry: Sets the block to insert as a Location Marker. The Geometry dropdown is populated by
dwg files in the %BLOCKS%/:"\GPS\Location Markers directory.

In a stock installation this will be:
C:\users\public\documents\WireCAD\WireCADx\Blocks\GPS\Location Markers.

Overlay Mode: Determines the display behavior of locations that share the same GPS coordinates.
The modes are:

eNone: Do nothing. Overlay marker upon marker. In this mode the tooltip data is aggregated to the
topmost marker.

«Offset: Offset the markers based on the OffsetX and OffsetY of the GPS Settings 7.

eRotate: Rotate the markers around the point.

eRadial: Rotate the markers based on the Radial Angle and Radial Distance of the GPS
Settings [+7h.

Panel Marker Section

Panel: Toggle the view of the Panel Markers in the GPS calibrated drawing.
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Panel Markers are inserts that are placed at the GPS coordinates of the drawing. The tooltip of the
marker displays the Sysname as defined in the Display Format String of the GPS Settings [+ tool
as well as any Backbones found on that SysName.

Panel Markers are placed in the drawing on a layer named "GPS_LOC_PANEL_TEMP". We do not
recommend placing any other entities on this layer. When the Panel toggle button is set to
unchecked, all layer entities are deleted without prompting.

Double-clicking a Panel Marker in the drawing will show its statistics.
Insert Scale: Sets the scale of the block defined in the Geometry setting.

Geometry: Sets the block to insert as a Panel Marker. The Geometry dropdown is populated by
dwg files in the %BLOCKS% :s"\GPS\Panel Markers directory.

In a stock installation this will be:
C:\users\public\documents\WireCAD\WireCADx\Blocks\GPS\Panel Markers.

Overlay Mode: Determines the display behavior of panels that share the same GPS coordinates.
The modes are:

eNone: Do nothing. Overlay marker upon marker. In this mode the tooltip data is aggregated to the
topmost marker.

«Offset: Offset the markers based on the OffsetX and OffsetY of the GPS Settings 7.

eRotate: Rotate the markers around the point.

eRadial: Rotate the markers based on the Radial Angle and Radial Distance of the GPS
Settings [+7h.

Backbones Section

Backbones: Toggle the view of the Backbones Markers in the GPS calibrated drawing.
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Backbone Markers are polylines that are placed at the GPS coordinates of the drawing. The tooltip
of the marker displays the Backbone either the basic data of the first strand of fiber in the Backbone
or the full Backbone statistics if the Show Backbone Stats checkbox is checked.

Backbone Markers are placed in the drawing on a layer named "GPS_LOC_BB_TEMP". We do not
recommend placing any other entities on this layer. When the Backbone toggle button is set to
unchecked, all layer entities are deleted without prompting.

Double-clicking a Backbone Marker in the drawing will show its statistics.

Arc Distance: Sets the polyline bulge factor of the Backbone. A bulge factor of 1 will create an arc
of 180°.

O)
R

A ]

! o

Arc Distance of .1

Self-Connect Arc Distance: Sets the polyline bulge factor of polyline that share the same source
and destination location GPS coordinates.

Show Mode: Determines the display behavior of backbones. The modes are:

*ByGPSLocation: Place the source and destination points of the polyline based on GPS
coordinates.

eBylLocationMarker: Place the source and destination points of the polyline based on the GPS
coordinates of Location Markers found in the drawing. This can be used to limit the display of
Backbones.

eByPanelMarker: Place the source and destination points of the polyline based on the GPS
coordinates of Panel Markers found in the drawing. This can be used to limit the display of
Backbones.
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Show Backbone Stats: Generate the backbone statistics such as total fiber count, available fiber
count and blocked fibers. This data is then displayed in the tooltip when the mouse hovers over the
Backbone polyline.

Show Vias: If the Backbone contains related Via data with Locations (with GPS data) the polyline
traverse from source to destination and every Via point.

Filter Section

The filter section is cascading. Selecting a location will cascade to the Panels filter by limiting the
Panels shown to those that appear at the selected Location(s). In the same way, the Panels filter
will cascade to the Backbones filter.

Locations: Filter by Location.
Panels: Filter by Panels.
Backbones: Filter by Backbones.

Settings Section

Settings: Display the GPS Settings [+75.
5.1.2.18 GPS Mapping Tools for Map Tool

Navigation: Referencel2s% > Ribbon Tabs and Dialogs [2s5 > Ribbon Tabs|[2sb1 >

Active only when the current environment is the Map Tool.
5.1.2.18.1 File

Navigation: Referencelzsh > Ribbon Tabs and Dialogs[zs > Ribbon Tabs[zs5 > GPS Mapping
Tools for Map Tool[s2% >

Active only when the current environment is the Map tool.
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Print Preview: Show the Print Preview dialog. From the Print Preview dialog you can set the paper
size, scale, orientation, and printer. You can also export to several formats from here.

Print Setup: Show the printer setup dialog where you can set the printer and print preferences.

Related Topics:
Print Preview/ s

5.1.2.18.2 Tools

Navigation: Reference[zsh > Ribbon Tabs and Dialogs[zsh > Ribbon Tabs[zs8 > GPS Mapping
Tools for Map Tool| a231 >

Active only when the current environment is the Map tool.

mE ~ WireCAD

ID GPS Location Coord: Show the ID GPS Location Coordinate dialog.

Copy Point to Clipboard: Select a point and the GPS coordinates are copied as text to the
clipboard. The text format is: Lat,Lon in decimal form.

Related Topics:
ID GPS Locations [sh

5.1.2.18.3 Display

Navigation: Reference[=s > Ribbon Tabs and Dialogs|[zs6 > Ribbon Tabs[zs5 > GPS Mapping
Tools for Map Tool| 3231 >

Active only when the current environment is the Map tool.

. *“TWireCAD
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Reset All: Removes all Location, Panel and Backbone Markers from the map.
Locations: Toggle the display of Location Markers in the map.
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Panels: Toggle the display of Pahei Markers in the map. Panel text is determined by the Display
String Format of the GPS Settings [+ panel.
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Backbones: Toggle the display of Backbone Markers in the map. Backbone color and line width
can be controlled from the GPS Settings E%panel
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Filters:

The filter section is cascading. Selecting a location will cascade to the Panels filter by limiting the
Panels shown to those that appear at the selected Location(s). In the same way, the Panels filter
will cascade to the Backbones filter.

Locations: Filter by Location.
Panels: Filter by Panels.
Backbones: Filter by Backbones.

Zoom Extents: Show all entities in the map.
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5.2

5.2.1

5.2.1.1

Settings: Show the Settings dialog with the GPS Settings (76 panel shown.

Related Topics:
GPS Settings[s/5

Dialogs
Navigation: Reference|zs3 >
Dialogs differ from Forms in that they do not occupy the full client docking area of the main window.

Dialogs can be floating or modal. When a dialog is modal no other interaction with elements outside
the modal dialog can take place.

Dialogs will remember their position and size unless you enable the setting s
Application [Basic] Disable Form State Tracking.

Related Topics:
None

Application Menu Dialogs

Navigation: Referencelz: > Dialogss26 >

The following is a set of dialogs associated with Application Menu.
New Project Wizard

Navigation: Referencel2s% > Dialogs|s% > Application Menu Dialogs [28 >

& Hew Project

Hew Progect

Welcome to the Mew Project wizard

B
R

(R T
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Application Menu > New Project...
Commandline: np

Explanation

WireCAD Projects are a loosely coupled collection of files, folders and databases. The New Project
Wizard will guide you through the steps of creating a new Project with several different options for
different database types.

For a more extensive discussion see the How To: Create a New Project/ ¢ topic.

Related Topics:
Create a new Project/ )

Dialog Options

eNavigate Forward, Navigate Backward

B bew Project + EEN

@ Plea Project

Choose Your Database

& s P Baged Locsl or et Shave Database (VistaDE]

e Ciababone Server (501 Server)

Ll S0 Azung [deud siorage)
i g @ databacs S you will reed permien b S fokder whirs
vou want 1o store the: datsbhase and praject nformaton, 1F you wank

reultple users b acoess the database you will foed B make sure that
llumers have reacifnrfie scoess 1o the kecaton,

et Caroel

Explanation

Related Topics:
Choose your Database Type! b
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Choose Database Page Options

eUse File Based Local or Network Share Database (VISTADB) - File based databases.

eUse Database Server (SQL Server) - You will need the host name and log in info to proceed.
eUse SQL Azure (cloud storage) - You will need a Microsoft Azure account for this option. Don't
have one? Contact us. We can help.

Explanation

Name, describe and locate the project.

NOTE: SQL, and SQL Azure do not like project names that start with a number.

Related Topics:
Default Project Location [sh

Name, Description, Location Page Options

eName - 50 Characters max. Must not have any operating system illegal characters. We also
recommend not using the ['] apostrophe.
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eDescription - Required.
eProject Files Path - Pulled from the Settings, you can change it here.
eProject Lead Person - Who is in charge here.

Test Correc i

Explanation

How do we log in to the SQL Server. There is a subtle distinction to be made between SQL And
SQL Azure:

«SQL Server the database name will be the Project Name.

¢SQL Azure the database name will be the name you gave your SQL Azure database. We will
create a schema on that database with the project name as the schema name.

Related Topics:
Choose your Database Type! b

Database Host Page Options

eHost Name - The host name and instance of your SQL Server.
eDatabase Name - The database name. See the explanation above.
eUse Windows Security - Not valid on SQL Azure.

eUser Name and Password

eTest - Can we connect?
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There are several pages of project settings that can also be found in the Application
Menu>Settings[Project] dialog.
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Finalization

Clicking Finish starts the project creation process. Make sure that at the end the log tells you that it
finished. If not the project was not properly created and you may experience errors later.

5.2.1.2 Project Save As

Navigation: Reference[2# > Dialogs!} > Application Menu Dialogs [ >
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°)?I Save Project As ? x

Save the Project sql to azure 1 as:

Save the Current Project as:

/ /

Save this SQL Azure based project in any other database format.
@ Create as File Based (local VISTA DB) Database

O Create as New SQL Server Database (Catalog). To do this you will need db_creator permissions on your database.

O Create as Schema on Existing SQL Azure Cloud Database

Next >

Application Menu > Save Project As ...
Commandline: save project as

Explanation

This tool allows you to save a project as a new name in a new location. The project database can
be changed from any supported format to any other supported format.

For example: if you have a file based database (VISTA DB) and you want to put that data in a SQL
Server, you can use the Application Menu>Save Project As tool to do this.

Dialog Options

eNavigate Forward, Navigate Backward

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD




Reference

¢ Create as File Based (local VISTA DB) Database. This is the easiest and most portable form of
WireCAD project.

o Create a New Server Database (Catalog). To do this you will need db_creator permissions
on the database server. This will create a new database on your database server and copy the
data into it.

¢ Create as Schema on Existing SQL Azure Cloud Database. This will create a new Schema on
and existing database. This is typically done to keep costs contained by using a single database
to house multiple projects.

e Save As: the new project name.

o Save As Project Path: The new project path.

e Host: The database host address. This is typically provided by your system database
administrator. If you are doing this yourself you should know the address or IP address of the
server that is hosting your sql instance.

e Database Name: This is the name of the new database for a standard SQL installation or the
name of the existing database for the Azure host address.

e Schema: This should be empty for standard SQL Server and the project name for SQL Azure.

e Use Windows Security: This determines whether you are submitting your Windows credentials or
the SQL login credentials. When in doubt - ask.

¢ User Name and Password. Used if Windows Authentication is not used.

If you are using either of the SQL options you will be presented with a database server Host and
Login page.
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TI Save Project As ? | X

(€ ) Save the Project sql to azure 1 as:

Database Info

Database Host:

Database Name: | sql to_azure 10

Authentication

|| Use Windows Security

User Name: wc_server_admin

Password: R e

Cancel

Standard SQL Server project with the new database name derived from the project name

The Rules

¢ Project names must follow file naming conventions.
¢ Projects should not be nested in other project.
e SQL Server projects cannot start with a number (digit).

Subtle Differences Between SQL and SQL Azure

When we are creating a new SQL project, we create a new separate database on the database
server.

When we are creating a new SQL Azure project, we are using an existing database that has been
set up for us. This database is capable of distiguishing table data of the same name by separating
them using different "Schema".

Think of database schema as a folder tree, we can have tables named "Cables" in schema1 and
schema2. We access the different "Cables" tables through dotted notation like: schema1.Cables,
schema2.Cables.
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3 az_to_az_checkin_test.Cables

Schema Part Table Part

(Project Name)

Same Database

3 File_to_Azure_Test_5.Cables

nes
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5.2.1.3 Manage Security

Navigation: Referencel2# > Dialogs |2 > Application Menu Dialogs [szh) >

B s Growsps and Perrmssons - (ParmissondyiEes) * IEEH

File v

sy e Cronupm P sgard

P sy Search A0 Rl eI
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G [ Sergan

Lmerhiama [ Ot cuphaTe Crucriphan

Userd b Adewwbators Thee Great ard Powerfud OF

[ ey AT M ) P Mo tals

i RApcord Lof2 & - = & M

Application Menu > Security Tools > Manage Security ...
Commandline: security

Explanation

Administrators can manage users, groups and permissions. If WireCAD Security is enabled (see
related topics). The person that enabled the Security option is the Administrator (the Great and
Powerful Oz). All other users will be added automatically to the Users (mere mortals) group. Oz
may:

eChange the group to which the user belongs.

oCreate new groups.

eModified group permissions.

oCreate other Ozes.

So to be clear. Users belong to Groups. Groups have Permissions.

NOTE: No action is required to add a user. They simply need to open WireCAD. If their user profile
does not yet exist in the WireCAD Security database, it will be added to the Users group.
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NOTE: Oz can proactively add users by searching the Active Directory and adding the user to the
group of his choosing.

Related Topics:
Application Setting - WireCAD Security =
Application Setup Wizard|sh

Users and Groups Tab Options

eNew User - Create a new user and assign to a group.

eNew Group - Create a new Group and associate Permissions set. After creating the new Group,
switch to the Permissions tab and set the permissions on the collections and drawings.

eSearch Active Directory - Using thnestandard AD search box.
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eUser Grid - Assign the User to a Group.

Permissions Tab Options

B Usavs Groups and Parmissions - (Permssionsyvista) i = |
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weand Groaps | Permmsors
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&

1
U A A A A A
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Explanation

Each data collection in WireCAD has Edit, Delete, and Create permissions. This grid enumerates
each collection for each group.
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Related Topics:
Grid Basics| «1

eCollection Name - This is usually the table name in the database.
ePermissions. - Edit, Delete, AddNew.
eGroupName - You may find it handy to filter by group name then set the permissions for the

group.
GroupMarme -7
(Custom)
Administrators
Administrators Users
Administratars A
Administrators
Administrators

AAdmirmictratare

eSelect All and Clear Selection.

il

5.2.1.4 Packup / Checkout

Navigation: Referencelze > Dialogs |2 > Application Menu Dialogs [sz5) >

&l Checkout Project * IER
@ Pacloup TheckTha
Settings
Chaeck Dt Priect

etk Ot Pregect

Firud Chsipust

[=- -4 Q=T T}

Application Menu > Check In/Out > Pack up /Check Out ...
Commandline: packup

Explanation
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A WireCAD project is a loosely coupled group of files, databases and settings. The global database
is maintained separately from the project database, and drawings may have linked images. In order
to move the project to another machine we will need to gather all of the resources used to create
the project into a central location (the project folder).

The Packup / Checkout Tool performs the following functions:

Copy a file based version of the Global Database into the Project\Project Databases folder and
sync it with the SQL Server version if necessary.

*Copy all linked images to the drawings directories.

oIf [Check-out] then flag the project as read only.

oIf [Compress Ouput] then zip all the project folder items into a single zipped file with the name:
[PROJECT_NAME.ZIP]

NOTE: This process can take some time on large projects.

Related Topics:
Moving Projects [sh

Dialog Options

«Check Out Project - Flag the Project Read Only. This is useful if the project is going out into the
field for commissioning. The version that stays in the office should not be edited.

eExpected Return Date - Let the people in the office know when you think you will have the project
checked in.

eCompress Output - Zip it.

5.2.1.5 Unpack Project

Navigation: Referencelze > Dialogs |2 > Application Menu Dialogs [+25) >

T Unpaci; Progect + IEl
(E) vosiirect.i
Pt b P g b Lindgeh ek o

e Frageot Opters

Sty Pt el LnPrach

Application Menu > Check In/Out > Un Pack ...
Commandline: unpack
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Explanation

The complementary function to the Pack Up is the Un Pack. This function performs the following:
eUnzip the compressed file (if necessary).

eSync the local Global Database with the one found in the incoming Project Databases folder.
¢Open the project for use.

NOTE: This process can take some time on large projects.

Prerequisites
A project that has been Packed Up. Using the Pack Up / Check Out tool.
No project can be open or the tool will not run.

Related Topics:
Pack Up / Check Out/ssh
Moving Projects s

Dialog Options

eProject Path - Browse to the zipped file or the .wc6plf file.
«Open project after unpack - Of course.

5.2.1.6 Checkin Project

Navigation: Referencelzs > Dialogs s > Application Menu Dialogs [28) >

B ungack: Project + EX

UnPackiCheck-n

Pt Presed® 12 LFPeck ot i

e Pt O

Cpen project oy UnPack

Application Menu > Check In/OQut > Check In...
Commandline: packup

Explanation
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The complementary function to the Check Out is Check In. This function performs the following:
eUnzip the compressed file (if necessary).

eSync the local Global Database with the one found in the incoming Project Databases folder.
eSyncs the Project Database of the incoming project with the location database.

oOverwrite all drawings with the incoming ones.

eRemove Read Only flag.

NOTE: This process can take some time on large projects.

Prerequisites

A project that has been Checked Out. Using the Pack Up / Check Out tool.

The Checked Out local project must be open before this tool will run.

The project names of the local and incoming projects must match or the tool will fail.

Related Topics:
Pack Up / Check Out/ssh
Moving Projects [+s1

Dialog Options
eProject Path - Browse to the zipped file or the .wc6plf file.

«Open project after unpack - Of course.

5.2.1.7 Account Info

Navigation: Referencel2s > Dialogs|s26 > Application Menu Dialogs [ >

ﬂ w Fdd Aopount Informas bon T x
Ba fan
o
Save Pricit Exit Lirck Eefres
Fie i Edit n L

Arcin T e | Ll e ST

CoritacHhare Cordact iy

Caniactmsd Arnunt e

Arcin e ess

Aocoritiddery

hLooraity Stale AL NFTaAC o0

Arein TR Acvruntinfol er}

AoconriEiedol e 1 Bctoanbinfol berd

Application Menu > Account Info
Commandline: Edit Account Info

Explanation
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This dialog allows you to enter account specific data for use in reports.

5.2.1.8 Application Setup Wizard

Navigation: Referencel2: > Dialogs |2 > Application Menu Dialogs [z >

=1 Appication Setup Wieard T

Application Setup

ekiates B WEE AT LErD S187 by 261053 L The Bkl atan
b= wort I yoLr ernronrment and with wome bane e oo prefer enoen.

To acoept o defpuits simply cholo [Anoept Defaults] . ¥Fou o cove: hadi arvy e and
rrexdfly theie et

Bext = Aconpt D faults

Application Menu > Application Setup Wizard...
Commandline: showappsettings

Explanation

This wizard runs once at the start of WireCAD. You can always run it again to change the settings,
but most of the settings in the wizard are contained in the Settings dialog.

Dialog Options
eNavigate Forward, Navigate Backward

eShow This Again - Show this dialog again.
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B Applcation Setup Wizard

@ Appliatsn Setup

ZFlobal Database Locatson

Thee WireCAD (Fobal Davisbase conbsns nforrabon that me only want o defire once, Things e marufschrers,
Erupmenl, Cable et and oanneCing

Corretey & 0 deareshly b= dhane B rdorna ben wth collegues.

Let's deiermine where your gobal databases are pong o resde.

Sainct [uocal Macking] if you ace morkirg entingly kcal (et singis uier mod)

HOT RECOMMENDED

Sedect [SOL Servier | i v veoukd B B attech iy globul dats on 8 SOL Serveer [manlen Suit-user)

we this sty I you ane cornectng 53 8 S0LASne dafabans or wour own S0L Sereer nifarce.

Lioa ey

& Local Machne
Remobe Hetwork Shang « NOT RECOMMENDED
SO Server

Fagut >

Select [Remcbe Retwork Shane] if yoas wish bn share glotal informadion within & clope retwork (clonped retwork mufs-oser)

Bcept Defmdts

Global Database Location Page Optio

eLocal Machine - The

ns

default location is c:

\users\public\WireCAD\WireCADxX\WireCADGIlobalEquipment.vdb3. You may rename the file in
order to better organize your global data by client. See this topic on the Global Database

Location [ sso.

eRemote Network Storage - This is not recommended but is possible. Why do we do this? Well

we hate to limit you. Here are the ramifications of using
The file is not network fault tolerant like SQL Server.
Data can become locked and in some cases corrupt.

file based storage over a network:

You may find yourself having to Pack (compact and repair) the database if you get locked out of it.
«SQL Server - This is the best option for shared storage, but you lose portability.

1 Applcation Setup Wizand

@ Apphcation Setup

Artach Existing Global Equipment Database

Tty hawve selected] SO0 gerver giobul dababorpes mide
", Before proceeding v vl reed B Fuve acoess to o SR Server

Thes can be Fasied bocally o your machive, on & irbemal netwerk,
o on a hosted S0L Anre platform

¢ Do ous e acoess B your SOL Senver?

Mewt >

* N

Bencepd D fains
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Database Path Page Options

ePath to Shared Global Database - Show if the first selection is Remote Network Storage. Enter
the Path to the WireCADGlobalEquipment.vdb3

&l Appacation Setup Wizard » IEN
@ Application Sebup
Where s Your Database

Enter the datsbads dbrver hadt name and inglands.,

& Create stand-sone datshase e existing database. Creabe global o using schema name
] oot

okl Databacs Mams | WineCADGIchalE ugrmin!

o Lt Wirkkivd Sty

Teat Cormeen

et Acceps Defadis

Show only if the initial selection is SQL Server.

Database Host Info Page Options

oCreate stand-alone database - Use this option if you are installing on an internal network.

eUse existing database. Create global db using schema name. - Use this option if you are
installing on a SQL Azure database. The schema name is used to separate different data structures
on the same database.

eHost - The hostnamelinstance name or IP address\instance name.

*Global Database Name - Either the name of the existing global database or the name of the SQL
Azure database on which we will create our global database schema.

eSchema Name - Name this something like WireCADGIlobalData.

eUse Windows Security - Not available on SQL Azure.

eUser Name, Password -

eTest - See if we can connect.
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[ Appication Setup Wizard + IER
@ Apphcation Setup
Create Tables and Add Data
&) Add defacdt globall data Creabs emply database
| k] rmaruiachrer ok
w| Bk eviperesnit labs
wf| e cable types

| Adld Sornedior Calta

o R sl bmes

This car sk D 15 mins depending on Connecbon speeds. e pasent:.
Create Dababase and Add Dats

Acoept Defaults

Shown only if the SQL Server Option is selected.

Create Tables and Add Data Page Options

eAdd default global data - Create the database on the host and add the selected default data.
eCreate empty database - Create the database on the host with no data.
eCreate Database and Add Data - Do it!

L N

@ Apphoation Setup

WireCAD Community Server Contribution

iould you ke o be a good WireCAD oSzen and conirbute your equipment definitions o the WirelAD Community Server;
thius making thems avalable to all WireCAD wsers. You know you use if, 5o please confribute.

B Vil [ want 1 be 5 gosd WineCAD Smen b coniribute sutsmatoaly 1o the casmunily
Y5, but wait to upload device definiSons untl 1 mark them approved
Mo Eanks

Fgat = Arcept Defadis

WireCAD Community Server Contribution Mode Page Options
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*Yes | want to contribute
oYes but wait until | check the Approved field
eNo Thanks - You can still manually upload from the Equipment Library in this mode.

1 Apphcation Setup Wizard T IEN

@ Application Setup

Use WireCAD Security Settings

Select Use WireCAD Seamty if you want to et socess to the applicaton,
Acdrririatraters sef oo Groups an Permesons, then esign uiers 1 those Groug,

WireCAD can use aither a file based{VISTA) or server based(SOL) permissions set. Choose SOL Server based iff you have
Sk L B SR SIpEnT Server,

WireCAD uses the windowes built-n of Aot DEectony loing S0 Ler Ceaton i sasy.

Use WireCAD Seaurity

Mext > Accept Defaults

|

Explanation

WireCAD Security is used to restrict user access to key application sections and functions. If
enabled, the user launching WireCAD will be subject to the rules of the group to which they belong.
The user that initiates WireCAD security will be the only Administrator and will need to assign all
other user permissions. This is managed through the Manage Security|[: dialog.

Use WireCAD Security Setting Page Options

eUse Security -

eDatabase Type -

VISTADB - while you can use VISTADB as the security database it is only application to this
machine.

SQL - we will create the permissions database on your SQL Server using the SQL host and login
information.

Create SQL Permissions Database - Do It!
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Kl Appication Setup Wizard : IER

@ Applicstion Setup

Synic with WireCAD v5-8 Global Database

Ve see that you have an instance of WireCAD v9 installed on this machine.
To fully upgrade to vid you will need to synchronize your w9 Glabal Equiprment Library
wiith your new w10 Global Equipment Library,

Once you have configured your new Global Database and restarted WireCAD,
Click Database=Syne Equipment Libraries...

Hext > Aorept Defaults

|

Explanation

We found a WireCAD previous version. In order to use the work that you have already done you
will need to synchronize with the previous version Global Database. There are many variables that
can be configured to locate the Global Database elsewhere. When you finish the Application Setup
Wizard restart WireCAD then launch the Database >Sync Global Database tool and set the remote
database to look at your previous instance.

Related Topics:
Synchronizing with Another Global Database| b
Sync Global Database dialog/

5.2.1.9 The Settings Dialog

Navigation: Referencelzs > Dialogs sz > Application Menu Dialogs [ >
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[ ey bn B ] L 1 S i § B papel o o g (T frren e O Marvlar

Application Menu > Settings
Commandline: set

Explanation

The Settings dialog is comprised of the following sections:

eApplication - settings that determine the behavior of WireCAD for this machine. These settings are
stored in the Global Application Data folder as ApplicationSettingsX.xml.

Basic/s4)

WireCAD Security [

Global Database Location [ ssb
Support Paths s

Organization [ssh
Enable/Disable Plugins/|ssh

Todo List[ss8)

eUser - settings specific to your user profile on this machine as UserSettingsX.xml.

Basic/ss0)

Projects List[ss!

Drawing2s5

Drawing (advanced)seb
Command Line Shortcuts|ssh
Enterprise CMS (ENT Only)/seh
Expert Mode |21

eProject - settings specific to the current project. These settings are stored in the project folder as

ProjectSettingsX.xml.
Basic/s5

Advanced 5
Locations |

Delete Handling |5
Enterprise CMS/ssh
Export Settings [se8)

Project Rules 65
Status Behavior [3%)
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NOTE: These are the stock basic settings panels. Third party developers may register their own
settings panels. See their documentation.

Prerequisites
None

Dialog Options

eSave - Commit your changes and issue a SettingsChanged command to the application.
oClose - Do nothing and discard your changes.
eRestore Defaults - Restore the defaults of the current settings panel.

5.2.1.9.1 Application Settings

Navigation: Referencelzs > Dialogs/s% > Application Menu Dialogs[:25 > The Settings Dialog /s«
>

Application settings that determine the behavior of WireCAD for this machine. These settings are
stored in the Global Application Data folder as ApplicationSettingsX.xml.

5.2.1.9.1.1 Application Basic

Navigation: Referencel2s% > Dialogs/=% > Application Menu Dialogs [+ > The Settings Dialog /s
> Application Settings |+ >

] + I
Aok e A Application Seitings
- o P b e v ey
] 0 tsares

Basic Panel Options
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eCheck for Program Updates Automatically on Startup - If updates are available you will see a
banner pop up in the lower right-hand corner of the screen.

eShow Application Setup Wizard on Startup - This is usually unchecked except the first run of
the application. You can always start the Application Setup Wizard by clicking Application Menu
> Application Setup Wizard.

eCommunity Server Contribution - How will you contribute to the WireCAD Community?
eCustomer Experience Improvement Program - You must opt in to the CEIP. We will then
gather usage and error data. The generic data will be uploaded to our servers and aggregated so
we can bring you a better application.

«Silent Plugin Load - Hide all error messages on startup.

eDefault Project Database Host - Applies only to SQL projects. Presets the New Project Wizard.
eUse SQL Server Project Databases by Default - Presets the New Project Wizard.

eUsers (mere mortals) can select Project Database Mode - Some organizations may wish to
limit selection of project database type.

eDisable Form State Tracking - The setting disables the functions that remember form position
and sizing. This can be helpful if you are experiencing trouble with different resolution monitors in a
multi-monitor setup.

5.2.1.9.1.2 WireCAD Security

Navigation: Reference[zsh > Dialogs/+ > Application Menu Dialogs [+ > The Settings Dialog /s
> Application Settings|s4s! >

WireCAD Security
ey e T L ety e b e R ey ey e G
b e e Tty e el e e

TR s s Pl - d L]

g
»
K
&

es I sasovwoe §

WireCAD Security Panel Options

eUse WireCAD Security - Enable Security. When enabled the WireCAD security system uses the
current login to determine program access. If your user is a member of the Administrators group
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you will be able to control the access of other

Manage Security... dialog.

users via the Application Menu > Security >

& users Groups and Permissions - (Permissonsvista)

e

Lty ] G For i

P L Soacch AD. Pt G

sy Feamet: + G Heave

Group [ Cwmrptorn
Lhertame o e

¥ o ¥

» chbh Unrz: ¢ Admrarators
chrin_0EX) Admine b atom

Descriptons
n

The Greas and Powerild OF

Ieloran el o

eDatabase Type - Typically you will only use security in a multi-user environment with a SQL host,
but the capability exists to use file based VistaDB databases.

5.2.1.9.1.3 Global Database Location

Navigation: Referencelz¢h > Dialogs|z > Application Menu Dialogs [k > The Settings Dialog /=

> Application Settings |34 >

¥ scttrgn

Appicaion - Dabtabase Conneclion

B e

B foeetees

B pnmm

& Trabie Eraier S
B Fudsim

[ .

-

g

o g

e —
B ol e Dby
B trimpens el
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B b
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b
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Global Database Location Panel Options
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eDatabase Mode - VISTA/SQL. NOTE: SQL will work for SQL AZURE as well. We will need the
database name and schema name.

oVISTADB Location - Path to the VISTADB file that is your WireCADGlobalEquipment.vdb3 file.
*Global DB File Name - Note that this is the default name given to the global database file but you
may change it.

eHost Name and Instance - This can be a fully qualified path, ip address, or host name.
eDatabase Name - The name of the global database to connect to. This is
WireCADGIobalEquipment by default but you may choose to rename it.

eUse Schema, Schema Name - WireCAD supports multiple schema in the same database file.
This is useful if you are using a cloud based SQL Server service that charges by the database. You
can have a schema for your global database and one for each of your project databases. All
contained within the same database file.

eUse Window Security - Use this if you wish Windows security to manage the login. This will not
work with SQL Azure.

eUser Name, Password

sTest Connection - Test to see if you can connect and have the appropriate privileges.

5.2.1.9.1.4 Support Paths

Navigation: Referencelzst > Dialogs/+ > Application Menu Dialogs[s2% > The Settings Dialog /s«
> Application Settings 3481 >

|
g
|

Application - Support Paths Panel Options

eBlock %BLOCKS% - The path that will replace the %BLOCKS% variable in the equipment
library.

eImages %IMAGES% - The path that will replace the %IMAGES% variable in the equipment library.
eDocuments %DOCUMENTS% - The path that will replace the %DOCUMENTS% variable in the
equipment library.

elcons %ICONS% - The path that will replace the %ICONS% variable in the equipment library.
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eTemplate Drawings - The path to the Template Drawings folder. This is the folder where
Template Drawings are saved when using the File > Save As Template Drawing function is
used and the folder that the New Drawing Wizard searches to fill the Templates list:

® ?

Miws Drawing

Piore]

WRER] B e

BN Lanascane. WG
wel aporwsbowe |
Bl _WE DG

AR B

AR NG

AN CRNG

RSl EDWNG
SLARSLINWG

150_i1 Landscape. dwl
150 A1 Parerait dwg
180_AZ Landscape.dwg
150_AT Portrat. deg
TR0 _AT L ancncape. deg
150_A1 Portrat. deg
150_i4 Landscape. dwg

Pt Canel

eReports - The path to the top reports folder. This is a recursive search and will enumerate all
subfolders and files.

eDefault New Project Location - Presets the New Project Wizard.

&l Hew Project * IEN

@) N Progtat

Progect Pies: Pasic ='W Publc Tocomenits

Progpect L Pes oo
Project Fadh:

5.2.1.9.1.5 Organization

Navigation: Referencelzs > Dialogs/s > Application Menu Dialogs (s > The Settings Dialog /s
> Application Settings|sss) >
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Application - Organization Panel Options
This one's self-explanatory

5.2.1.9.1.6 Enable/Disable Plugins

Navigation: Referencel2s% > Dialogs/ > Application Menu Dialogs[:} > The Settings Dialog /=
> Application Settings |s4s) >

Aople s o Mk Plugrm el you rever e o renane proegr e aLantug ageed

B oo b sisidon. Pluginn (ot loasded on pragraes starhap

ks - s by Cated ~ox

Enable/Disable Plugins Panel Options

Move items to the left-hand list to disable.
Move items to the right-hand list to enable.
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This panel only works with Plugins that support the wpi manifest file. Auto-discovered Plugins
cannot be disabled from here.

5.2.1.9.1.7 Todo List

Navigation: Reference[zsh > Dialogs|sz > Application Menu Dialogs [z} > The Settings Dialog =+
> Application Settings [z« >

Explanation
Sets the drop downs in the Project Todo List

Application - Todo Panel Options

eAssignees - List of people to whom a task may be assigned.
eStatuses - List of Todo item statuses. Modify this to suit your needs.
ePriorities - List of priorities. Again, make it fit your needs.

5.2.1.9.2 User Settings

Navigation: Referencelzs > Dialogs|s > Application Menu Dialogs 2% > The Settings Dialog /s«
>

User settings specific to your user profile on this machine. The path to these settings is usually:
C:\Users\<YOUR_USER_NAME>\AppData\Local\WireCAD\WireCAD9\UserSettings.xml.

Your system administrator has the ability to modify this.
You can use:
Application Menu > Frequently Used Folders > User Application Data Folder

To know the path we are using.
5.2.1.9.2.1 User Basic

Navigation: Referencelzs > Dialogs|s > Application Menu Dialogs|sz%1 > The Settings Dialog /s«
> User Settings|ssa >
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B Settings 7 IEN
User Setlings
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A& Drawirg (advanced)

Commmand | Shortouts.
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ity acles 4o rewdy oeated ports. This petSng presets the A Sort Dusiog
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These are settings for your user profile on this machine.

Basic Panel Options

¢Open New Drawing Upon Application Startup - Opens a blank new drawing when WireCAD
starts.

eUse the New Drawing Wizard - Shows the New Drawing Wizard when you click File > New.
Allows the use of template drawings. If set to false, just creates a new drawing without a template.
«Open My Last Project When | Start WireCAD - Behaves like earlier versions of WireCAD that
opened the last project automatically on startup.

eShow Library Tips - This shows the Tips and Tricks form in front of the Equipment Library.
eShow the WireCAD Startup Page

eWarn of Signal Type Mismatch - When you finish drawing a cable WireCAD will check the
source and destination port signal types and let you know if they don't match. You can use the new
status panel to know the port type if you are confused.
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eWhen | Double-click a Many-to-Many Cable Assign All of Them - Many-to-Many cables that
are set for Multiple Database Entries can either be assigned all at once by a single double-click, or
if this setting is turned off a double-click will find the closest port to the cursor and assign that.
eKeep Equipment Library Open - This is useful if you are using dual monitors and want to have
the Equipment Library stay open on the other monitor.
eWhen | Link Pointers Go Back to the Starting Drawing When Finished - The default Link
Pointer function will leave you on the second sheet. If you set this to true it will jump you back to the
first sheet.
eMy Spacebar is my Enter Key - This is helpful when executing command line commands.
eMouseWheel Double-click Zooms Extents
eLibrary Multiple Port Add Leading Zero Count
ol Will Manually Refresh the Project Explorer - True to disable autorefresh on the Project
Explorer. This may be helpful if your project grows to have hundreds of drawings.
eWhen a Drawing Opens Don't Show the Draw Cables Tool Panel
eLazy Load my drawings in the Project Explorer - True to disable recursive search of all
drawing subfolders. This may be helpful if your project grows to have hundreds of drawings.
eDefault BOM Snapshot Name - Presets the BOM Generator. The {0} represents the current date.
eReport Show Mode - Where are we seeing the reports.

Project Explorer - appends the reports tree after the project.

Reports Gallery - populates the Reports Gallery with thumbnails and descriptions from the
accompanying report manifest xml files (if any).
eAutomatically validate my equipment when | open the Equipment List grid - Default = true
but can be expensive on large projects.
eAutomatically Index Project and Drawings - For more information see the Understanding
Indexes [+s5 topic. True will re-index the project on open and drawings on save.
eShow Index Operation Progress - Displays the progress bar during index operations.

5.2.1.9.2.2 Projects List

Navigation: Referencelzsh > Dialogs|sz > Application Menu Dialogs s} > The Settings Dialog /s«
> User Settings|ss7 >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

Apxicaron «  Mast Becently Used Projects
e e ety s g
Lhe A il s LS g Lt L

Tt tietak [

m B PR T ST sl I e e L ) v
s . [ . =il Y v
i e S gt i L PR el WY SCAC L
Prodrel

L]
o
L]
L]
L]
B Cabie T Lk ke
]
L]
L]
L]

The Most Recently Used (MRU) projects list. The depth of the list is set. As soon as the list count is
exceeded the oldest item is discarded.

Projects List Panel Options

eMost Recently Use Projects List Count - How many items allowed in the list.

eProjects List - displays the name path and whether the project can be reached.

eClear - Reset the list.

eRemove Missing Items - Remove items that cannot be found because the path has changed or
is currently unavailable.

eRemove Item - Remove the selected row.

5.2.1.9.2.3 Drawing

Navigation: Referencelzs% > Dialogs/s > Application Menu Dialogs[:5 > The Settings Dialog /s«
> User Settings /s >
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%1 Settings 2 [ x
frE i ¥ | Drawing Environment Settings
User n Setup the drawing environment to your liking. Other users on this machine will be able to set their own settings.
Auto Save Duration (in minutes) 0 3 D Drawing Background Follows Skin Theme
£ Basic Arrow Move Nudge Distance 0.05 5 Background Color | [ 255, 255, 255 -

## Projects List

Grip Color | MO0, 0, ... ~ o [ }
= = QSnap Color - I —
Drawing = -
~ Grip Size 30 5 *

/" Drawing (advanced) - — l
$ Command Line Shortcuts Cross Hair Size in Pixels = ) Pick Size in Pixels | 10 i
#* Enterprise CMS Show Layout Tabs Mousewheel Zoom Scale | Plus20 -
## Experience Level List Missing Drawing Dependencies D Hover OSnap Toolbar
. [ show the Ucs axis Show Ruler Ruler Width 25+
Froect - Show Paper Space Paper (Draws a "Paper” border indicating the selected printer paper bounds)
Basic D Save Drawing After Every Cable Number Assignment Default File Format | DWG 2010 -
Advanced D Touchscreen Mouse Logic
Locations Clear Selection After Command Executes
Delete Handling D Disable Progress Bar
Project Rules Default Single Line of Text Height (set to 0) to be asked 0.25 :
Cable Text Search Window Default Multiline Text (MText) Height (set to 0) to be asked 0.25 :
Folder Sync Preset OSnaps
Project Specific Global DB F END } iy MID q CEN ‘ QUAD 'h NEAR . NS 1’-—‘ INT 76 APP INT n TANG -$— NODE

Drawing Status Items
Enterprise CMS
Export Settings
Status Behaviour
GPS Settings

Archive Settings

IF Mumbering %\

6 e B % % % o6 % o6 3 o6 3 0 O % B

Project - Nicknamed Pointer ...

Apply Save Close Restore Defaults Help

Common user specific drawing environment settings.

User - Drawing Panel Options

eAuto Save Duration - Sets the Auto Save Duration. Auto Save saves only drawings that are
modified but not currently involved in a function.

eArrow Move Nudge Distance - When nudging a selection how far do we move in the direction.
oGrip Color, Grip Size, Cross Hair Size

eShow UCS Axis - Shows the UCS Axis:
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eShow Paper Space Paper - When a layout is selected, show the current page size as returned
by the selected printer as a white "page."”
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False

eSave Drawing After Every Cable Number Assignment - Setting this to true is not

recommended but will speed the assignment process. You are responsible then for saving the

drawing to ensure drawing/database parity.

eTouchscreen Mouse Logic

oClear Selection After Command Executes - Overrides the default behavior of leaving the

selection set in tact after an operation.

eDrawing Background Follows Skin Theme, Background Color, OSnap Color

ePick Size - Sets the pick size in pixels. The pick determines the search window aperture when

clicking the cursor.

¢ Disable Progress Bar - turn off the main form progress bar during drawing loading.

¢ Default Single Line of Text Height - Sets the TextHeight property of a signle line of text in DU if
non zero.

e Default Multiline Text (MText) Height - Sets the TextHeight property of a MText in DU if non
zero.
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¢ Preset OSnaps - Set the default OSnaps whenever WireCAD turns on the OSnaps it will base
the selection on these presets.

5.2.1.9.2.4 Drawing (advanced)

Navigation: Referencelzsh > Dialogs/+ > Application Menu Dialogs[:25 > The Settings Dialog /s«
> User Settings | 354 >
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These are really granular controls of the render engine. It is beyond the scope of this manual to
explain each we will hit some, but play with them if you are interested and see how they behave.

User - Drawing Advanced Panel Options

eBackupOnSave - Saves the file with the ~.bak extension before overwriting the existing file.
eDisableShowPrinterPaper - Same as Show Paper Space Paper.

eDisableXrefTooltips - Sometimes XREF tool-tips can be annoying.

eEnableTooltips - Show tool-tips or not.

eEnableURLs - URLs of object will be opened.

eMirrorText - Controls how the Mirror command deals with text.

eCurveResolution - How many segments to a circle.

ePickAdd - Sets whether a user selection action replaces the current selection or adds to it.
eSelectActionKey - Set a key value used in combination with mouse-down to add or remove
selected item(s) from a selection.

5.2.1.9.2.5 Command Line Shortcuts

Navigation: Referencelzst > Dialogs/+ > Application Menu Dialogs[:25 > The Settings Dialog /=
> User Settings| s >
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User - Command Line Shortcuts Panel Options

eRegister Your Own Command, Remove Command - Developer function.
eCheck - Checks the shortcuts to see if you have any duplicates.

eCommands List - You may freely edit any of the columns:
CommandName
Alias

ShortCut

Even though the grid allows you to edit the following fields if you are not a developer you should
NOT edit any of the columns:

Assembly
NameSpaceAndClass
MethodName

You will break WireCAD.

5.2.1.9.2.6 CMS

Navigation: Referencelzs% > Dialogs/s > Application Menu Dialogs[s2b > The Settings Dialog /s«
> User Settings| 54 >
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Enterprise CMS Panel Options

eUse Stock WireCAD Startup Page - No longer active. Has no effect.

eDefault New Circuit Strand Count - When creating a new circuit, a default strand count for

jumpers is created. This will change that strand count to a different value.

eWarn of Connector String Mismatch - Having this box checked will allow a warning message to

display anytime WireCAD detects that 2 ports being connected have a different connector type.
5.2.1.9.2.7 Experience Level

Navigation: Referencelzs > Dialogs|s > Application Menu Dialogs[sz%1 > The Settings Dialog /s«
> User Settings|ss41 >
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\ij-l Settings 7 x
—— . | Beginner Mode
Beginner mode causes the help system to track your moves and display help topics related to the current form or dialog.
User =
. Beginner Mode
¥ Basic o
#* Projects List
_ Normal Mode
/“ Drawing

All explanatory messages are displayed
Drawing (adwvanced)

/ © Mormal Mode

## Command Line Shortcuts

#* Enterprise CMS Expert Mode

## Experience Level | . Expert mode disables the explanatory text boxes that introduce function behaviors.
i o Expert Mode

Project =

Basic

Advanced

Locations

Delete Handling

Project Rules

Cable Text Search Window

Folder Sync

RN % 3 % % %

Drrdact Sracific Clahal DR

Apply Save Close Restore Defaults Help

User - Experience Level Panel Options

Explanation

Fine tune WireCAD for you.

eBeginner Mode - tightly couples the help system with your actions in the application. The help
system will display topics based on the current form or dialog.

eNormal Mode - Does not automatically couple to the help system but does show all explanatory
dialogs.

eEnable Expert Mode - Once you learn WireCAD functions, the explanatory dialogs that show
before a function executes can be disabled.

While not a comprehensive list (there are roughly 100 instances in the code that reference the
Expert mode), some of the functions that will execute without explanation are:

e Rack Builder tool.

e De-assign Cable.

De-assign SysName.

Reset All SysNames.

Reset Selected SysNames.

Reset All Cables.
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¢ Reset Selected Cables.

¢ Project switching will not inform you that the current project needs to be closed.

Equipment Library tips will not be shown.

Cables Grid>File>Expert Mode.

Batch Plot.

Copy, move, delete in drawings with selections made outside the visible window will not warn you.
o Pack Project Database.

e Pack Global Database.

5.2.1.9.3 Project Settings

Navigation: Reference[z > Dialogs|s > Application Menu Dialogs s} > The Settings Dialog s+
>

Settings specific to the current project. These settings are stored in the project folder as
ProjectSettings9.xml.

5.2.1.9.3.1 Project Basic

Navigation: Referencel[s > Dialogs|s# > Application Menu Dialogs[s#1 > The Settings Dialog /s«
> Project Settings| s >
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Basic Panel Options

eStarting Cable Number - The default starting number of ALL sequences.
eLeading Zero Count - How many leading zeros in SysNames and Cable Numbers.
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elgnore Cable # Text Color - Does not color the Cable Number text entities.

¢| Build My Racks From the Top Down, Default Rack Height

eDefault Cable Type - This is the default of defaults. The Project Signal Types table can override
this.

eDefault Plan View Block File - If no Plan View File is defined on the Equipment definition then
this will be used by the Populate Equipment function in the Plan View Tools.

eUsers (mere mortals) Can Modify These Project Settings - If you can see and edit this you are
a WireCAD Administrator or have not set up WireCAD Security.

eAdd Pinout Data to Each Cable - Allow pinout data to be attached to a cable as it is being
assigned. The pinout criteria must match in order to be a candidate for inclusion in the list of
available pinouts for a cable.

eUse the device display settings - This setting prioritizes any Equipment Library device settings
saved with the device over the settings saved for the project.

eShow duplicate numbers from related projects - Only if Verbose assignments are being done.

5.2.1.9.3.2 Advanced

Navigation: Reference[zsh > Dialogs|s > Application Menu Dialogs s} > The Settings Dialog /s«
> Project Settings | ssal >
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Project - Advanced Panel Options

eDisable Find Next Available SysName, Disable Find Next Available Cable Number - The
default behavior is for WireCAD to look-up the next number from the Next Numbers table, then
check to see if that number is in use - if so keep incrementing until an available number is found.
Disabling this functionality will use the number in the Next Numbers table without checking its
availability.

eAutomatically Consume Prewire Cables - This will use those numbers applied to the PreWire
Cable instead of producing a new number.

¢Strict Multi-core Assignment - Enforces a policy that all cores in each end of a multi-core cable
must originate from the same location.

o|P Mask
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eMaintain Relational Data - See this discussion on Understanding Indexes. Disabling this will not
disable the indexing function if you call Re-index but will not attempt to initiate the data in real time.
eDisable Cable Number Edit Dialog Mask - If you find the masking of the Edit Cable Data Cable
Number textbox to be cumbersome you can disable it here. This also disables the mask on the
SysName assignment dialog.

5.2.1.9.3.3 Locations

Navigation: Referencels > Dialogs/+ > Application Menu Dialogs[:28 > The Settings Dialog /s«
> Project Settings| 4 >
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Project - Locations Panel Options

eLocation Delimiter - Settable on project creation only this is the delimiter that separates
CAMPUS from BUILDING, BUILDING from FLOOR, etc. The default is a [.]. This will create
Qualified Locations in the form of: Campus.Building.Floor.Room.Rack.

eElevation-Slot Delimiter - The delimiter that separates the elevation numeric from the slot
numeric. For example: a device located in elevation 20 at slot 5 with a delimiter of a dash [-] would
be typed and 20-5.

eEnable Locations Look-up - If disabled the locations field may be typed into directly. This may
lead to confusion or referential issues, ie; user a calls something Rack 1 and user b calls the same
thing RK 01.

eLocations Table Fields - Enable those that you will use and call them what you will.

eStart Numbering at 1 - Only applies if you are auto generating locations.

5.2.1.9.3.4 Delete Handling

Navigation: Referencelzst > Dialogs/s% > Application Menu Dialogs[:25 > The Settings Dialog /=
> Project Settings|zes >
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Delete Handling Panel Options

eHard Delete - Overrides the default behavior which is to mark a deleted cable Available=true and
place the Deleted Text in key fields. Enabled this removes the row from the table upon deletion.
eDeleted Text - If deleted and not Hard Deleting the text to place in fields. Leave empty to leave
existing text in place.

eDeleting Equipment Deletes ALL Connected Cables - Works with functional blocks, concept
blocks, and terminals.

eDeleting a cable on a pointer resets the cable on the other side of the pointer - The other
sheet will be opened and updated. This can take some time.

5.2.1.9.3.5 Enterprise CMS

Navigation: Reference[2s% > Dialogs |+ > Application Menu Dialogs [} > The Settings Dialog /s«
> Project Settings| a1 >
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Enterprise CMS Panel Options

eManage Status Items - When creating a backbone, you have the ability to mark a "status" on that
backbone such as "In Use", "Proposed" ETC. The Status Behavior settings panel defines the
Status Items in the list.

eBackbone Number Format - The variable {0} contains the next number in the Next Numbers grid
for Backbones. Define the string format of the next Backbone number.

eJumper Number Format -

The variable {0} contains the Circuit base number.

The variable {1} contains the Strand Number of the circuit for this jumper

The variable {2} contains the Ordinal Number of the circuit for this jumper.

Define the string format of the next Jumper number.

eDefault Jumper Manufacturer and P/N, Default Horizontal Cable Manufacturer and P/N
oCircuit Number Format - The variable {0} contains the next number in the Next Numbers grid for
Circuits. Define the string format of the next Circuit number.

eHorizontal Cable Number Format - The variable {0} contains the next number in the Next
Numbers grid for Horizontal Cables. Define the string format of the next Horizontal Cable number.

5.2.1.9.3.6 Export Settings CMS

Navigation: Referencelzs > Dialogs/s% > Application Menu Dialogs[:25 > The Settings Dialog /s«
> Project Settings| 4 >
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Project - Export Settings Panel Options

eUse Template - Path to a template drawing that the output will be exported into. Your template
drawings can contain any page borders or layouts and settings that you wish.

esAlways Ask for FileName and Path - You will be involved in the filename selection and path.
oCircuit FileName Format - Sets the file name format for Circuit output. {0} = Circuit Name.
eBackbone FileName Format - Sets the file name format for Backbone output. {0} = Backbone
Number.

oFile Format - Presets the output format.
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ePath - Where do we output.

oCreate Folder for Each IT Systems

eAutomatically Overwrite Files of Same Name

eAppend Date Stamp to FileName

oCircuit Post Process Script, Backbone Post Process Script - Path to a c# file which will be run
post export but pre write-to-disk. See the Post Process Scripts [2s5 topic for more information.

5.2.1.9.3.7 Project Rules

Navigation: Referencelzsh > Dialogs|z > Application Menu Dialogs 5 > The Settings Dialog /=
> Project Settings| a1 >

------

e

Project - Project Rules Panel Options

Explanation

Rules allow you to modify data during the SysName and Cable Number assignment processes.
There are four events or contexts

in which rules may execute:

SysName assignment pre and post dialog show/dismiss.

Cable Number assignment pre and post dialog show/dismiss.

Related Topics:

Project Rules 209
Expression Syntax|2oh

eEnable Rule Execution - Enable/Disable all rule and rule event execution.
5.2.1.9.3.8 Status Behaviour CMS

Navigation: Referencel[2sh > Dialogs|z > Application Menu Dialogs [ > The Settings Dialog /=
> Project Settings| s >
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Project - Status Behavior Panel Options

eAssigned to Circuit Color - The color to display in the Backbones grid if the record is assigned
to a circuit. Here we see circuit 0232 using the backbone B000003.41.
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eContext - Backbones_grid or Circuits_grid.

eDisplay Name - The name of our status.

eBackground Color - Self-explanatory.

els Blocking - A blocking status is one that blocks operations from proceeding. For example: if we
mark a backbone fiber as DEAD we would not want to use that in a Circuit. If the status item is set
as Is Blocking = true then the New Circuit tool will not allow a circuit to involve that strand of fiber.

5.2.1.9.3.9 GPS Settings CMS

Navigation: Referencelzs5 > Dialogs|s% > Application Menu Dialogs |28 > The Settings Dialog /s«
> Project Settings| s >
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Menu: Application Menu > Settings[Project][GPS Settings]
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Location Marker Settings

Offset X, Y: Used by the Location Overlay Mode = Offset.

Layer Color: sets the color the location marker will paint.

Radial Distance: Used in conjunction with the Location Overlay Mode = Radial and the Show
Radial Project Lines to paint a line from the radial arc center to the location marker.

Display String Format: Sets the variable used to display the name of the location on the marker in
the drawing or map.

The following variables can be used:

{0} = Campus.
{1} = Building.
{2} = Floor.
{3} = Room.
{4} = Rack.

{5} = Qualified Location.

Show Radial Project Lines: Used in conjunction with the Location Overlay Mode = Radial. Sets
the display of a projection line from the arc center to the Radial Distance and location marker.
Radial Angle: Used in conjunction with the Location Overlay Mode = Radial. Sets the rotation
angle of the radially displayed location markers.

Panel (Equipment) Marker Settings

Offset X, Y: Used by the Panel Overlay Mode = Offset.

Layer Color: sets the color the panel marker will paint.

Radial Distance: Used in conjunction with the Panel Overlay Mode = Radial and the Show
Radial Project Lines to paint a line from the radial arc center to the panel marker.

Display String Format: Sets the variable used to display the name of the panel on the marker in
the drawing or map.

The following variables can be used:

{0} = All.
{1} = SysName.
{2} = Alias.
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{3} = Location.
{4} = Manufacturer.
{5} = Equipment Name/Model.

Show Radial Project Lines: Used in conjunction with the Panel Overlay Mode = Radial. Sets the
display of a projection line from the arc center to the Radial Distance and panel marker.

Radial Angle: Used in conjunction with the Panel Overlay Mode = Radial. Sets the rotation angle
of the radially displayed panel markers.

Backbone Marker Settings

Offset X, Y: Used by the Backbone Show Mode not = ByGPSLocation to offset the flyoffs.

Text Height and Style: Sets the appearance of flyoff text.

Backbone Color: sets the color the backbone marker will paint.

Backbone Text Color: sets the color the backbone flyoff marker will paint.

Line Width: Sets the pen stroke width of the backbone.

Flyoff Geometry: Sets the block to use when a flyoff is created.

Flyoff Scale: Sets the scale factor of the Flyoff Geometry.

Show Backbone Number as Linetype: Creates a new linetype with the backbone text as part of
the linetype.

General Settings

Remember Filter Settings: Persist the filter data across forms and sessions.
Display Error Messages: Show a list of the problems found when showing Panels and Backbones.

5.2.1.9.3.10 Archive Project

Navigation: Referencel[zsh > Dialogs|sz > Application Menu Dialogs s} > The Settings Dialog /s«
> Project Settings|[ss >
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Project - Archive Project Panel Options

Settings that affect the Archive tool.

eArchive Path - path to the archive root folder. The Archive Name will be used to create a folder
within this root folder. Use {0} for the current project path.

eShow New Project Revision Dialog - Set whether the New Project Revision dialog is shown
and populated during the archive process. If the New Project Revision dialog is canceled the
CurrentProjectRevision will not be incremented.

eAlways Ask for Archive Name - Sets whether you are asked for the archive name or whether the
archive is automatically named using the Archive Name Format String.

eArchive Name Format String - The name of the folder the project is contained within as well as
the archived project name.

{0} = Current Project Name.

{1} = UTC short date string.

{2} = UTC short time string.

Related Topics:
Archive Project /20

5.2.1.9.3.11 Cable Text Search Window

Navigation: Referencelzsh > Dialogs/s > Application Menu Dialogs[:25 > The Settings Dialog /=
> Project Settings /s >
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Project - Cable Text Search Window Options

WireCAD uses standard text entities placed in a specific point near the end of the cable. If you
reduce the Vertical Pin Spacing of your created blocks you may find that WireCAD selects the
wrong text when assigning a cable number. If that is the case reduce the size of the search window.

eSearch Window X - Sets the x offset from the end of the cable that we search for text.
eSearch Window Y - Sets the y offset from the end of the cable that we search for text.

eShow Search Calibration Window - Renders a red rectangle representing the search window.
Be sure to turn this off before doing actual work in the application.

R _Cable#

Search Calibration Window
ePlacement Offset X - Sets the x offset of the Cable Number text placement. This setting interacts
with the Search Window X. If you set the Placement Offset X outside the Search Window X you
will need to modify the Search Window X to accommodate the new placement.
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ePlacement Offset Y - Sets the y offset of the Cable Number text placement. This setting interacts
with the Search Window Y. If you set the Placement Offset Y outside the Search Window Y you
will need to modify the Search Window Y to accommodate the new placement.

5.2.1.9.3.12 Drawing Status Items

] settings L 7 | x

Application v
User N Drawing Status Items
# basi Edit the items that populate the Status dropdown in the Project Explorer.

asic
£ Projects List Mote: Changing a Status Display Name here does not change any existing drawing status.
/“ Drawing
/‘, el ] Status Display Mame Back Ground Colar

¥ | Aflc —=

## Command Line Shortcuts o
B Enterprise VS »  (Complete) [ 192, 255, 192

nterprise

Awaiting Review [ 255, 255, 128
E i Level
## Experience Level In Progress 220, 220, 220
Project N Needs Attention [ 255, 192, 255
* [

£ Basic
## Advanced
£ Locations

## Delete Handling

## Project Rules

## Cable Text Search Window
# Folder Sync

## Project Spedific Global DB

## Drawing Status Items
TEerprise

## Export Settings

## Status Behaviour

## GPS Settings

ﬁ Archive Settings

% JF Numbering

## Project - Nicknamed Pointer ..

M4 44 4 Record 1of4 » W W+ — & ¥ x

Apply Save Close Restore Defaults Help

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD




Reference

Explanation:
List of Drawing Status Items to help organize your drawings.
These Status Items are used by the Project Explorer [Status] field.

Project Explorer - r x

Enter text to search Find

Ttem Preview Status Checked... Checked QutBy De:
+ [ Global Databases -

Equipment Library...
Default Signal Types

Jau0deg yaaloig ¥

puHd o

Cable Types
Connectors

Permissions

Color Codes
Pinouts
+ [ Project
- D Pointer Rename Test
®A, New Drawing...
Open Drawing(s)
~ [ Project Drawings
J ecAVS01EEEEE.DWG Awaiting Review
A ecAvs04fred DWG In Progress
R ecAV508BARNY.DWG MNeeds Attention
F ecAV511.DWG (Complete)
JA ecAV514.DWG (Complete)
= D Project Databases T
= Project Signal Types
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= Equipment List (SysMNames)
& sysMame Format

= Cables

= Backbones %
= Blind Patches

= Circuits

s Map

& Cable Number Format

= Drawings

= Mamed Paths

= Mext Mumbers

= To Do List

= Locations

= Discrepancies

= Rules

[ Related Projects (Read Only)

| (| (O (o (o () (o) () () [ (] () ] (] [ (M| |mO] [mD

Properties
Status Display Name - Set the caption to be displayed in the drop-down.
Background Color - Set the color to pain the row.
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5.2.1.9.3.13 Project Specific Global Database

'ﬂ Settings E x

K ErT Global Database Connection for this Project

le= Create a connection to the global database that is spedific to this project. This way you can hook up to different global databases per proj
) Who's it for:

% Basic This function is for those that have the need for different global databases per project.

# Projects List Maybe you have one dient that hosts their own doud based global database, but you use your own global database for other projects.
1 ‘fou can, on a project-by-project basis, determine which version of the global database is used by the project.

/" Drawing

This can be used by both VistaDB and SQL versions of the Global Database
/" Drawing (adwvanced)

Enable this functi
## Command Line Shortcuts D nabie this function
#* Enterprise CMS

## Experience Level
Project A

Basic

Advanced

Locations %
Delete Handling

Project Rules

Cable Text Search Window

Folder Sync

Project Spedific Global DB

Drawing Status Items
Enterprise CM5
Export Settings
Status Behaviour
GPS Settings

Archive Settings

JF Mumbering

250 [0 % 3 o 3 o oo o6 3 % 3 %

Project - Micknamed Pointer ...

Apply Save Close Restore Defaults Help

Explanation:

Sometimes it is desirable to have a different Global Database (GDB) for a project.

This could be because you have different client requirements for a project from your normal setup.
If this is the case, you can copy the GDB (WireCADGIobalEquipment.vdb6) to another directory
(probably the project folder) and

enable this function. The point to the GDB in the project folder.

Alternately, you can hook up to a SQL Server database host.

All of the flexibility that is provided in the GDB Location|ssb settings panel is replicated here.

WireCAD v10.1 User Manual
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5.2.1.9.3.14 Folder Sync

°x-I Settings
Application v
User =
¥ Basic

#* Projects List

/“ Drawing

/“ Drawing (advanced)
#* Command Line Shortcuts
## Enterprise CM5

## Experience Level
Project =

Basic

Advanced
Locations
Delete Handling
Project Rules

Cable Text Search Window

Folder Sync

Project Specdific Global DB
Drawing Status Items
Enterprise CMS

Export Settings

Status Behaviour

GPS Settings

Archive Settings

JF Mumbering

Project - Nicknamed Pointer 5.

B 00 U % o o o 3 o (o (% 3 o % %

WireCAD v10.1 User Manual

Folder Sync

WireCAD can sync files in the Project\Drawings folder tree across multiple dients. This functionality is only available when using SQL Server as
the database. This iz enabled by default but can be controlled here. You would typically disable Folder Sync if all users share the same project
folder and there are no other instances of the project folder to keep in sync.

Apply Save Close Restore Defaults Help
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Explanation

WireCAD provides a sync mechanism that can sync local project drawing folders across different
locations.

This is similar to Dropbox, OneDrive, Google Drive, Jungle Drive, etc.

This can be used to share the project drawings across the planet.
Typically this function is used with Azure SQL databases in the cloud, where users may be in
different cities.

Folders are synchronized by scanning the Project Drawings folder and comparing the file size, hash
and timestamp with those in the Drawings table of the project database.

If the file timestamp is older than the server, the server version is downloaded to the the local folder.
If the file timestamp is newer than the server, the local version is uploaded to the server.

Limitations

The sync tool only scans the project drawings folder tree.
The sync tool only works with SQL or SQL Azure databases.

5.2.2  Project Dialogs

Contained herein are explanations about the dialogs that appear on the Project Menu.
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5.2.2.1 Publish Project to Portal
il Publish to Portal (BETA) - o | =

Publish Project to Portal

Welcome

Wedome to the Publish to WireCAD Portal wizard.

We will now prepare a copy of the project to publish,

Thisis a multi-step process that:

1. Checks first to make sure there is a Current Project Revision for use by the portal to organize your project versions.
2. Logs in to the portal and checks to see if the Current Project Revision is unigue.,

3. Makes a copy of the project database.

4, Converts the drawings to a format that can be displayed by our web drawing viewer.

5, Compacts the file,

6. Uploads to the portal.

Mote: the default WireCAD public Portal is used. If you have purchased a private portal,
you will need the address of that.

Larger projects make take some time.

‘Your team members will have a better user experience if the project has good index data.
If you want to rebuild the indexes before publishing, exit this and run:

Database >Index Grids=Rebuild Indexes and wait for it to finish, Then come back here and publish,

Next =
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Explanation

WireCAD can publish the project to the WireCAD teams portal at teams.wirecad.com.

This allows you to share the project to anyone that you invite to the team.

Team members can view and redline drawings as well as view data and message team members
from any modern browser.

You must first create an account at: teams.wirecad.com.
You will need your WireCAD key to create an account.

5.2.2.2 Archive Project

Archiver %

This function copies the project to a folder Named:

C:\Users\chris\Dropbox\My PC (DESKTOP-CMEH4KP)\Desktop\News Production Control Demo\News Production Control Room Demo\Archived Projects
50L databases are converted to VistaDB databases.

50L Projects are archived as VistaDB projects.

Both your project and global databases are archived.

Archived projects are a complete Packed-Up WireCAD filebased project.

Archived Projects can be restored using the Application Menu>Check In/Out>Unpack or Check In.

The drawings in the Project\Archive\ folder are ignored.

‘You will have the opportunity to modify the CurrentProjectRevision.
Canceling the New Project Revision dialog continues the archive without modifying the CurrentProjectRevision.

‘ou will NOT be prompted to enter the name for the new archive

The settings that control the behaviour are in your Settings dialog under [Project][ Archive Settings]

Continue?

Mo
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Explanation

The Archive project tool which inherits the settings from the Project Settings[Archive] settings panel.
The archive tool packs up the project and stores it the location determined in the settings.

Related Topics:

Project Archive Tool Settings|s72

Unpack Project/ssh
Check-In Project|ss%

5.2.2.3 Titleblock Manager
X1 Project Title Block Manager
Titleblock Manager
CO0w 11 M = & & [H
Add  Remove Rename SaveBlodkAs | Edit Company EditClient | Al Manual All On Update Active
Blodk Info Info Open Drawing Mow
Page Borders Attributes
iwcD Tag String Attribute Value String Constant
» BIG_TITLE UseStringConstant MNEWS PCR 2022
Scale UseStringConstant NTS
DATE S UseStringConstant
ISSUED 5 UseStringConstant
5 UseStringConstant
% DATE 4 UseStringConstant
ISSUED 4 UseStringConstant
4 UseStringConstant
DATE 3 UseStringConstant
ISSUED 3 UseStringConstant
3 UseStringConstant
DATE 2 UseStringConstant
ISSUED 2 UseStringConstant
2 UseStringConstant
DATE 1 UseStringConstant 03/22
ISSUED 1 UseStringConstant IMIT
1 UseStringConstant 1]
Checked By: UseStringConstant CEH
Drawn By: UseStringConstant BLW
Sheet None SHEET
Drawing # DrawingFileMame
REW LspStrinaConstant n

WireCAD v10.1 User Manual

= - jo| x
Update Mode
OnDrawingCpen =

OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingCpen
OnDrawingCpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingCpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen
OnDrawingCpen
OnDrawingCpen
OnDrawingOpen
OnDrawingOpen
OnDrawingOpen

OnDrawinoCnen
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Explanation
The Titleblock Manager tool associates the attributes of a titleblock with variables or string
constants.

Menu Items

[Add] - Add a titleblock to the list of Page Border blocks.

[Remove] - Remove the selected block from the list of Page Border blocks.

[Rename Block] - Rename the selected block in the list of Page Border blocks.

[Save Block As] - Create a copy of the selected block with a new name in the list of Page Border
blocks.

[Edit Company Info] - Open the Company Infolssh settings panel.

[Edit Client Info] - Open the Account Info[s:b dialog.

[All Manual] - Set the Update Mode for all attributes to Manual mode. In Manual mode the
titleblock is only updated when you open the TitleBlock Manager dialog and click the [Update
Active Drawing Now] button.

[All on Open] - Set the Update Mode for all attributes to OnDrawingOpen mode. In
OnDrawingOpen mode the attributes that are flagged as OnDrawingOpen will be updated when
the drawing is opened.

[Update Active Drawing Now] - Do it!

Variables

Most of these are self explanatory. Those that are not will be defined.

None - Do nothing

ProjectName

ProjectDescription

ProjectLeadPerson

ProjectInfoUserl - Userl field from the Application Menu>Project Info form.
ProjectInfoUser2 - User2 field from the Application Menu>Project Info form.
ProjectInfoUser3 - User3 field from the Application Menu>Project Info form.
ProjectInfoUser4 - User4 field from the Application Menu>Project Info form.
ProjectPath

ProjectCreationDate

ProjectModifiedDate

CurrentProjectRevision

See this fggmﬂih.

DrawingName

DrawingFileName - file name with extension.
DrawingFileNameAndPath

DrawinglLayoutName - the layout where the Page Border lives.
DrawingCreationDate

DrawingModifiedDate

DrawingUserl - Userl from the Drawings table.
DrawingUser2

DrawingUser3

DrawingUser4

DrawingUser5

DrawingUser6

DrawingUser?7

DrawingUsers8

DrawingUser9

e DrawingUserle
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DrawingUseril

DrawingUserl2

DrawingShort - the Short description from the Drawings table.
Drawinglong - the Long description from the Drawings table.
DrawingFSCM

DrawingNumber

Date and Time

DateTimeNow - The current date and time as right now.
DateShort - The short date as of now.
DateLong - The long date as of now.

Environment

UserName - The environment User Name.

Strings

UseStringConstant - Use the data from the String Constant field.

See this settings Qanelﬂg5.

CompanyName - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyAddressl - Addressl from the Application Settings[Application]>Organization
settings panel.

CompanyAddress2 - Address2 from the Application Settings[Application]>Organization
settings panel.

CompanyCity - City from the Application Settings[Application]>Organization settings panel.
CompanyState - State from the Application Settings[Application]>Organization settings
panel.

CompanyPostalCode - Zipcode from the Application Settings[Application]>Organization
settings panel.

CompanyPhone - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyWebsite - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyCountry - Company Name from the Application Settings[Application]>Organization
settings panel.

See this dialoglsb.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD

ClientAccountName - Account Name from the Application Menu>Account Info dialog.
ClientContactName - Contact Name from the Application Menu>Account Info dialog.
ClientAddressl - Addressl from the Application Menu>Account Info dialog.
ClientAddress2 - Address2 from the Application Menu>Account Info dialog.
ClientCity - City from the Application Menu>Account Info dialog.

ClientState - State from the Application Menu>Account Info dialog.
ClientPostalCode - Zipcode from the Application Menu>Account Info dialog.
ClientPhone - Phone from the Application Menu>Account Info dialog.

ClientFax - Fax from the Application Menu>Account Info dialog.

ClientWebsite - Website from the Application Menu>Account Info dialog.
ClientEmail - Email from the Application Menu>Account Info dialog.
ClientInfoUserl - Userl from the Application Menu>Account Info dialog.
ClientInfoUser2 - User2 from the Application Menu>Account Info dialog.
ClientInfoUser3 - User3 from the Application Menu>Account Info dialog.
ClientInfoUserd4 - User4 from the Application Menu>Account Info dialog.




Reference

5.2.2.4 ToC

Table of Contents Generator

'f[ Table of Contents Generator (Beta v1) = /o] x
Main Menu
~ o o Py }
CEmBEX Tt 3 & GO v 9
Scan Open  Save  Clear Move Up Move Down Copy Down  Increment Select  Clear All Preview Do It
hd Down All Selections
File Grid G 2
Table of Contents Settings
Indude This  Name Path Layout Description User 1 User2 User3 User4 User5 Userg User7 Useg
? =] A Adc AQc Ac "le L= L=l L= "le L= L=l -
» @ (Title).dwag Drawings\(Ti MAIN TITLE... MAIN TITLE...
VI (ToC).DWG  \Drawings\(T TABLE OF C... TABLEOFC...
M AUDIO.DWG  \Drawings\aU AUDIO INT... AUDIO INT...
¥ BSP 1.OWG  \Drawings\BS SERVICE PA... SERVICEPA...
¥4 CABLE PULL... \Drawings\CA CABLE PULL... CABLEPULL...
M CAMREM.D... '\Drawings\CA CAMERARE.. CAMERARE..
m CAMS 1.DWG  \Drawings\CA CAMERAS 1. CAMERAS 1...
¥4 CAMS 2.DWG  \Drawings\CA CAMERAS 4... CAMERAS 4...
@ CAMS 3.DWG  \Drawings\CA CAMERAS 8... CAMERASS..
M CONSOLEE... 'Drawings\CO PCR CONS...
¥4 CRD FRMS1... \Drawings\CR CARD FRA...
¥4 CRD FRMS2... \Drawings\CR CARD FRA...
VI FLOOR PLA... \Drawings\FL PCR FLOOR....
m FLOOR PLA... \Drawings\FL STUDIOFL...
¥4 FLOCR PLA... \Drawings\FL TCFLOCR....
¥ GFX.DWG Drawings\GF GRAPHICI...
m TEOM Auwin e zmiinAc\TE TRITED MM -
Record 10f34 4 L4
4
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Explanation:

This tool generates a Table of Contents from the data in the Drawings table.

It is best to start with an empty drawing.

The ToC can have up to 7 display columns. The column caption and display data can be set based
on the Table of Contents Settings [TAB] settings.

To limit the number of columns displayed is based on the ColumnCount property.

Page No

Drawing

PFath

Descripticn

Usar-l

Usaer Bool

TR -l

Layout

DN TG

MAIN TITLE PAGE

MAIN TITLE PAGE

[ T ]

Lot =1

Draaing 8 TSl OWS

TASLE OF CONTENTS

TASLE OF CONTENTS

[ T ]

Y ]

Drmaing 8 ALDID DG

ARIDIO INTEROOMNE 0T

ALIDID INTEROONNEOT

(WY Y

_a — -1

Crmaing S50 1.0WS

e

SRR S NTRE L ONREET

[ T ]

CeELE FULLS

Sl SR P TG

[ T ]

L= N L]

Cvmimg DAY

mm oG | cesie

(WY Y

e Pl = T

Drmwirgu /OAAYS 1 DWVG

MR 15 WTRRCONNECT

ARG 1 WTRERCONRRCT

(WY Y

e Pl = S

DrmwimgE DANE TOWG

CENERLE +-T WTRRSNNEET

SANERE T WTRRSORRRET

[ T ]

P

Drawingn /DAAYS T DUAS

AR D TR ORNEDT

L ]

DOMEOLE ELEVATIONS

(WY Y

=1 = T

[ T ]

= = T

Craralnge! A58 FESARE DA

L ]

FLODR BLaM POM

gt FLODR PLIN BCR DG

(WY Y

LD PLAN STUDD

Crasinga FLOOR PLIN STUDIDNG

ETUDID LoD PLaN

[ T ]

L =T =1 T I

gl PO PLAN NS

To FLOOmM PLAR

[ T ]

Drmaing 8GOV

GRLEED INTRRS LT

(WY Y

Draning = 90-0OM g

NTRRSEN INTRRESS ST

[ T ]

Cranaing 8 EOURLDVEG

UM INTERC-ONNEST

[ T ]

LD A LA R DVWG

NETWORS INTEROSRREET

(WY Y

L e R

Drmvirgn I DG

MLLTVRN RS TR SRS T

[ T ]

Sl L E— T o

Dravimg e S NOUTE dwg

S e o

[ T ]

e e

Crm g E S T DG

SRR INTRRSCAET

(WY Y

- -

D e ing e 0. DVWG

CONTROL WTRRCHET

(WY Y

AL ELEVATIONES

AT I

[ T ]

—— p——

D rme g U g

L ]

sttt

e L T LE=n ]

(WY Y

L TN o )

Dravimge FEUTERLawWE

REUTER INTRRSONEE T

[ T ]

T ST L

CrawingU STR. STALOWS

ROUTER DONTROL

L ]

_ e = -1

Drmwirg ' MOE 1 DG

(WY Y

E i

SR DR S OWG

[ T ]

E i s —T

Crawinge (ERDES DS

L ]

s e ——

Drmaing & EWR DG

ST O TR T

(WY Y

titleblock

|wq=.l=|-|

Crawinge/cabiock!well. dwg

| L ]

\Drawings

| - |

D rmengE I TR e | T T |

| [ T ]

Generated ToC
Dialog Options
Menu Items:
Scan>Scan - Populates the list with all of the drawing in the project.
Scan>Layouts - Populates the list with all of the drawings and their layouts from the project.
Open - Open an existing ToC file.

Save - Save the current settings to the project root folder.
Clear - Clear the list contents.

WireCAD v10.1 User Manual

© 2025 Holbrook Enterprises, Inc. - WireCAD




Reference

Move Up - Move the selected drawing/layout up in the list.
Move Down - Move the selected drawing/layout down in the list.

Copy Down - Copy the selected row down.
Increment Down - Append a number sequentially to the selection from the top to bottom.

Select All - Selects all drawing records [Include This] field to be included in the Table of Contents.
Clear All Selections - Clear all check marks in the [Include This] field.

Preview - Builds the table as an overlay of the current drawing and dismisses the dialog so you can
see it. Click the [Esc] key to return to the ToC Generator.

e

Page No |Drawing | Layout | IP &tk |Description | User-1|User Bool

CTE R ERe— T

o= NI LE PAGE | Uncheckeda

e L o

ToC Preview Mode
Do It - Does it. You will be presented with a Yes/No/Cancel dialog. Choosing [Yes] creates the ToC
and allows you to save a file that you can open in the future.

Choosing [No] just creates the ToC.

Choosing [Cancel] cancels the Do It function and takes you back to the ToC generator dialog.

Drawings List [TAB]
Drawings Grid. This is the data from the project Drawings table.
The grid data can be assigned to columns in the ToC using the Settings tab as explained below.

Grid Columns:

[Include This] - Check to include this record in the ToC.

[Name] - Drawing Name.

[Path] - Relative path to the drawing in the project drawing folder tree.

[Layout] - The layout if the Scan>Scan Layouts option is chosen, otherwise empty.
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[Description] - The DrawingShort field.
[User 1-12] - The User1-12 text string fields.
[UserBool1] - The UserBool1 field Boolean value.

Table of Contents Settings [TAB]

Properties
Column 1-7 Caption - Sets the column header text.
Column 1-7 Variable - Sets the data source for that column.

Position
Insertion Point - Sets the coordinate of the upper left corner of the table. Clicking the [...] button
temporarily dismisses the dialog so you can pick the insertion point from the current drawing space.

Table

Column Count - Sets the total number of columns displayed.

Line Width - Sets the LineWidth property of the lines that comprise the table.

Max Rows - Sets the max number of rows displayed before the table is continued to the the right.
Show Folder Names as Headers - If the drawing is in a folder that is a child of the
Project\Drawings folder. The folder name will be shown as a header. If all drawings are contained in
the root project Drawings folder, this property is ignored.

| E= v I I ADrawlings\SWR.DWS I SWITCHER INTERCCNNE.’::T' I Unochecked

titleblock

I ——— | | .m-m,.mwxwmm| I | [ ——

\Drawings

| w_ = m__ —u I I ADrawings\WTLA .dwg I LTI LT e | I Unocheckedo

Folders As Headers
Table Width - Sets the total width in DU of the table. The columns are all displayed within this
distance.

Text

Empty Cell Text - Sets the text string to display if the data is a null or empty string.

False Value Display Text - Sets the text string to display if a boolean value evaluates to False.
Heading Height - Sets the text height in DU of the Header text.

Heading Style - Sets the TextStyle of the Header text.

Height - Sets the TextHeight property of all text in the ToC in DU that is not part of a header.
Horizontal Padding - Sets the distance from the left and right side of the cell that text cannot be
displayed in.

Style - Sets the TextStyle property of all text in the ToC that is not part of a header.

Subheading Height - Sets the TextHeight property in DU of text that is displayed in sub heading.
Applies only if the [Show Folder Names as Headers] property is set to true.

Subheading Style - Sets the TextStyle property of text that is displayed in a sub heading.

True Value Display Text - Sets the text string to display if a boolean value evaluates to True.
Vertical Padding - Sets the distance from the top and bottom side of the cell that text cannot be
displayed in.
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5.2.3 Drawing Dialogs

Navigation: Referencel2s > Dialogs s8>

The following is a set of dialogs associated with Drawing Form.

5.2.3.1 CAD Dialogs

Navigation: Referencel2s5 > Dialogs /6 > Drawing Dialogs [ss% >

5.2.3.1.1 New Drawing Wizard
Navigation: Referencel2ss > Dialogs s > Drawing Dialogs[ss5 > CAD Dialogs [ss5 >

M ran Crmar) + I

@ e
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Drawing > File > New
Commandline: nd

Explanation

Create a new drawing for the project somewhere in the project\drawings\ folder tree.

eSelect a template drawing. Template drawings are drawings that are placed in the Template
Drawings Support Path[ssh. They typically contain layouts and page borders, but may also be
populated with barebones systems.

oSet whether to display Model Space Boundaries. These are bounding rectangles based on a scale
factor of the Model Space text height used and the desired output text height of the viewport.

Related Topics:
How To: Create a New Drawing! 78
Model Space Boundaries [«b

Dialog Options

eTemplate Drawings List - Drawings placed in the % TEMPLATEDRAWINGS% support path. Any
drawing is a candidate for saving as a template.

eModel Space Boundaries - Your selected template may already have Model Space Boundaries in
which case it is unnecessary to include them.

5.2.3.1.2 Print Preview

Navigation: Referencel2# > Dialogs/+ > Drawing Dialogs|ss% > CAD Dialogs [ >
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Drawing > File > Print Preview
[Cntrl]+[P]
Commandline: print

Dialog Options

eSelected Printer - Make sure that you select a printer first.

®l (Printer Name: HP2729AC (HP PageWide Pro 477dw MFP) )

ePlot Margins - Set the unit of measure and the Top, Bottom, Left and Right margins. NOTE: the
printer driver will return the hard margins of the printer. These are represented by the black dashed
line in the Partial Preview mode. Setting the margins less than the hard margin values will have no
effect.

eCenter - Adjusts the left and top margins to center the entities in the given space.

eUpside Down - Rotate the output to the plotter.

eOrientation - Portrait/Landscape.

ePaper Size

eScale - Numerical scaling of the entities to the paper.

eScale to Fit - Fit the entities to the paper.

¢1:1 - Scale 1:1.

eBlack and White

+Out as Bitmap - Render to a bitmap then output that. Has different effect on quality depending on
printer/plotter.

eCopies

ePen Assignment - Shows the Pen Assignment dialog. You can assign a different line thickness to
each of the 255 indexed colors.

*Print Area - Pick a window or print the extents.

ePreview Mode - Full preview or partial view to show margins.

eUpdate Preview - Refresh the preview.

*Print

eSelect Printer
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eCancel
5.2.3.1.3 PDF Export

Navigation: Referencelzs8 > Dialogs [+ > Drawing Dialogs[% > CAD Dialogs [ >

[ (Printer Name: BAGCRINE_ROCIMZan) *
Fiot Marpnn
@ ) inchen
Tag 15168 Botom: | 10050
Lk Qu00d Rghe: | 00000
Lrite Cireey Certer To Pager
Drierl ki
) Fotrat  &8) Larchcace
Murrbr of Copaert
T g
= =3 A [ | Papor
i 8 | g | ¥
! = 1
; Tt | Bl (3515 2457 mm
; e i | | i
I : ||~ i
: i : SCale
----------- .-IIII-II--II-.III--II umuﬁ L, g
[ Scalatz Fe
Cuapad Opticene:
[T R L —
[ Greyscale I
Prink Ares
) Eeerts ) Windew Sy Pek
P Opliona Savpn o libe -
) Patel @ Fl | g Updae B [FoF | [ESewicls DB

Drawing > File > PDF Export
Commandline: pdf

Dialog Options

eSelected Printer - Make sure that you select a printer first.

%l (Printer Name: HP2729AC (HP PageWide Pro 477dw MFP) )

ePlot Margins - Set the unit of measure and the Top, Bottom, Left and Right margins. NOTE: the
printer driver will return the hard margins of the printer. These are represented by the black dashed
line in the Partial Preview mode. Setting the margins less than the hard margin values will have no
effect.

eCenter - Adjusts the left and top margins to center the entities in the given space.

eUpside Down - Rotate the output to the plotter.

eOrientation - Portrait/Landscape.

ePaper Size

eScale - Numerical scaling of the entities to the paper.

eScale to Fit - Fit the entities to the paper.

eBlack and White
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+Out as Bitmap - Render to a bitmap then output that. Has different effect on quality depending on
printer/plotter.

eCopies

ePen Assignment - Shows the Pen Assignment dialog. You can assign a different line thickness to
each of the 255 indexed colors.

oPrint Area - Pick a window or print the extents.

ePreview Mode - Full preview or partial view to show margins.

eUpdate Preview - Refresh the preview.

eSave to File

eSelect Printer

eCancel

5.2.3.1.4 Export to Visio
Navigation: Referencelzs > Dialogs 2% > Drawing Dialogs[s% > CAD Dialogs [ >

] WirrCAD WG ba Wi Camerater M
Fage e Lener wmdm | = Lanwhicage
Dt il g ! Lot bl Eumor vt it & e 0n el Bt L vad - Cvoreeie Fie i Edits

Loale b B in ey
a1 AT Vel 320 o Bl Ve 1 in e S
gl Spaece Entera 477400, LSS Bbipergt 43 brep WrelAD sooten
Soale Fpmwr X1 L0 LUREE- -]
e
Stepy

PAROES OF e T
Prpoeisne ol e -t ey

Froceasryg caties

Cormt Cro

Drawing > File > Export to Visio
Commandline: visio

Explanation

The WireCAD to Visio converter is an intelligent converter. It creates active working Visio drawings
from you WireCAD drawings. What this means is that it is not just a dumb geometric import but
rather entities are examined and functioning Visio entities are created. Cables in WireCAD become
Visio Connectors allowing movement of blocks while keeping the wires attached.

Dialog Options

ePage Size - Set the Visio page size.
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eOutput File Name

eLandscape

eOverwrite File if Exists

eScale to Fit - Fit the WireCAD dwg entities onto the selected page size.

eScale Factor - Manually scale the WireCAD entities to the Visio page size.

eCable Routing - Here is the magic. You can either let Vision route the cables or you can attempt
to keep the appearance of your WireCAD routes.

eConvert - Do IT!

5.2.3.1.5 Layers
Navigation: Referencel2s5 > Dialogs[26 > Drawing Dialogs[ss5 > CAD Dialogs[ss% >
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Drawing > Drawing > Layers
Commandline: lay

Explanation

The Layers dialog controls the document Layers collection.

A Layer is the equivalent of the overlay used in paper-based drafting. It is the primary organizational
tool in the WireCAD CAD space, and you can use it to group information by function and to enforce
linetype, color, and other standards.

Organizing Layers and the objects on Layers make it easier to manage the information in your
Drawings.

When you put one layer over another the result is the complete drawing.

Having kindred objects on the same layer it is very helpful in order to organize the drawing.

When you begin a new drawing, WireCAD creates a special layer named 0. By default, layer 0 is
assigned color number 7 (white or black depending upon your background color), the
CONTINUOUS linetype and a lineweight of Default (the default setting is .01 inch or .25 mm). Layer
0 cannot be deleted or renamed.

All new objects are added to the active layer if no layer is specified.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

Using the Layers editor you can Freeze (Hide), Thaw (Show) and Lock layers.

By controlling whether a Layer's state is Thaw or Frozen you can change the appearance of your
drawing to display only the information on the Layers that are visible. Freezing unused Layers will
help the performance of WireCAD.

Dialog Options

eDocument Tree - Lists the document's external references. By selecting an item in the document
tree you can control the layers of XREF drawings within the current drawing.

eNew Layer

eDelete Layer - Deletes the selected layer as long as it is not the current layer or layer 0.

oeSet Current - Set's the current layer. All entities added to the drawing are added to the current
layer.

eStatus - The one and only current layer.

eName

*On - Is it visible.

eFrozen - Is it visible. The difference between Thawed/Frozen and On/Off is a very subtle
distinction. Turning a layer off using the ON/OFF setting makes the objects on that layer hidden, but
these objects will still be considered part of the drawing. For example, objects that have been
turned off are still selectable in the drawing. Selecting it directly on screen of course still isnt
possible, as youve nothing to click on. But other ways of selecting objects will still pick it up try a
SELECTALL for example, and your objects that are turned off will be selected. Frozen layers on the
other hand are completely off. They are not considered part of the drawing at all, and are therefore
not selectable.

eLock - Make the layer unselectable.

ePen Color - Set the pen color for the layer. Only entities that have their PenColor property set to
ByLayer will receive this value.

eLine Type - Set the Line Type for the layer. Only entities that have their Line Type property set to
ByLayer will receive this value.

eLine Weight - Set the Line Weight for the layer. Only entities that have their Line Weight property
set to ByLayer will receive this value.

*OK

eCancel

5.2.3.1.6 Layouts

Navigation: Referencelzs8 > Dialogs 26 > Drawing Dialogs[:s5 > CAD Dialogs [z >
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Drawing > Drawing > Layouts
Commandline: layouts

Explanation

A Layout is used to compose or lay out your model drawing for printing. A layout may consist of a
title block, one or more viewports, and annotations. As you create a layout, you can design floating
Viewport configurations to visualize different details in your drawing.

A layout is a paper space environment that simulates a sheet of paper. In a layout, you can create
and position viewport objects, and you can add a title block or other geometry. You can create
multiple layouts in a drawing to display various views. Each layout displays the drawing as it will be
printed on the sheet of paper.

Typically, when you begin designing a layout environment, you step through the following process:
1.Create a model drawing.

2.Activate or create a layout.

3.Insert a title block.

4.Create floating viewports and position them in the layout.

5.Set the view scale of the floating viewports.

6.Print your layout.

Dialog Options

eLayout List

oSet Current - Set the selected item to be the current view.

eNew, Remove, Rename

«Copy - Copy all entities from the selected layout to a new layout with the name of your choosing.
eMove Up/Down - Reorder the list.
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5.2.3.1.7 Point Styles

Navigation: Referencelzs > Dialogs 26 > Drawing Dialogs [s:% > CAD Dialogs [ssh >
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Drawing > Drawing > Point Styles
Commandline: pointstyles

Explanation
All point entities inserted into the drawings space will render based on the settings here.

NOTE: if you are using the Rack Builder tool WireCAD uses point entities to generate the
positioning grids and sets this value programmatically.

5.2.3.1.8 Text Styles

Navigation: Referencelzs8 > Dialogs 26 > Drawing Dialogs[:s5 > CAD Dialogs [z >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

i » N
Basc | Advasnoed
Enyple Plaree:

Sanreland i+

=
o

Sxple Magd ts B Pt

TTF Fank | dns w

Sod Timle Lrsderins Stplut Crotriline

Pree

Hello World!

Hhele Werid

Drawing > Drawing > Text Styles
Commandline: ts

Explanation

TextStyle is a named, saved collection of settings that determines the appearance of text strings.
You can create your own text styles which can have specific fonts and text height. You can also
specify if the text will be underlined,bold etc.

There is no limit to the number of text styles you can create in your drawing.

The active text style determines the appearance of new text created in the drawing. StyleName of
text object will get the value of ActiveTextStyle property.

When you enter text, it uses the current text style, which sets the font, size, and other text
characteristics. If you want to create text using a different text style, you can make another text
style active.

Dialog Options

«Style Name, Add, Rename, Delete

eFont - Set the font family of the Text Style.

oStyle - Style attributes.

ePreview, Preview Text Edit - Preview of Text Style applied to the Preview Text Edit.
eAdvance Settings - The advance tab displays a property grid with all of the basic settings and a
few more.

eCodePage - Sets the character set used to display text.

eDrawOutline -

eFlag - LeftToRight, Backwards, UpsideDown, etc.

¢ObliqueAngle - in degrees.

eWidthFactor - Value used to stretch text by changing its width.
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5.2.3.1.9 Dimension Styles
Navigation: Referencelzs > Dialogs 26 > Drawing Dialogs [s:% > CAD Dialogs [ssh >

& Demension Styles t EEN
Damaran Sevier Frorares
-] e Dt Y Feriaeme | [ Dot
Arrure - A
A B,
A iyl
Ao 25000
Lines -
Cowlire-Coies ByBlok P
ErshieEnt reFinedie  False g "-n
EviLineoky BBk _‘1\____.
Ex® relint ] LS00 / I T
Fx® reliat? AL i f . A Sr’j‘
baf ek ard gt L0000 | -.’\.- -'_'
Eviineviskie Treet \ (s} Ig\rJ}
UreForced Tree i 4 -,
Lrelslrsiie Fake - § r
Hiu N -
Labed
Lreaiiale st LO005
e 15025
SemeFacter Lo00%
WProges S Ly
Tawt - w
o* Canel

Drawing > Drawing > Dimension Styles
Commandline: dimstyles

Explanation

A Dimension Style is a group of dimension settings that determines the appearance of a

dimension .
The active Dimension Style determines the appearance of new dimensions created in the drawing.

To change the style of an existing dimension, use the StyleName property found on the dimension.
When you create a dimension, the current dimension style is associated with that dimension. The
dimension retains this dimension style unless you apply a new dimension style to it.

Dialog Options

oStyle Name, Add, Rename, Delete
ePreview Pane - Displays the results of the current settings.

eSettings -
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5.2.3.1.10 Model Space Boundaries

Navigation: Referencelz: > Dialogs s > Drawing Dialogs [% > CAD Dialogs [ssh >
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(s 3 Cancel

Drawing > Drawing > Model Space Boundaries
Commandline: bo

Explanation

It's a big model space in there. We can, if we are not careful, create a drawing that is so big that it
can't be effectively printed or plotted. In order to have some Idea of where the fences are WireCAD
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can place boundaries in the model space. The boundary is created from the viewport. We use the
text height as the terms for our equation. We do this because a drawing is considered readable if
we can read the text. If we can't read the text the drawing becomes useless.

Each boundary will be placed on its own layer and named bound_layout_name where
layout_name is replaced with the name of the layout.

Dialog Options

eLayout - Select the layout from which we will create the boundary.

eText Height that you used in Model Space - The default is .25 DU or as given in 1/100th of a
Drawing Unit: 25.

eHeight of the text that you want to print - Here we want the printed output height in 1/100th of a
printer unit.

eColor

5.2.3.1.11 Groups
Navigation: Referencelzs% > Dialogs s > Drawing Dialogs % > CAD Dialogs [z >
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Drawing > Drawing > Groups
Commandline: formatgroups

Explanation
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Create groups of entities in order to better organize your drawings. Groups can be named and
described as well as disabled and edited later.
To create a Group select some entities and right-click then click Group

W G

w Addioleeorte

Dialog Options

elgnore Groups - Disable grouping.

eName - The default Group name will be a GUID. You can rename it if you like.

eDescription

eSelectable - Is the group selectable as a group. If selectable = true then when one object in the
group is selected all objects are selected.

eltem Count

oEdit Entities - Add or remove entities to the group.

oApply Properties - Send the value of the Group Properties fields to the group.

eDelete - Deleting the Group does not delete the entities.

eNew - New from the Group Properties.

5.2.3.1.12 Images

Navigation: Referencelzss > Dialogs 2% > Drawing Dialogs[ss5 > CAD Dialogs [ss5 >
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Drawing > Format > Images
Commandline: formatimages

Explanation

Embed images in the drawing as well as to edit the properties of those images. The document now
contains an Images collection from which images may be inherited throughout the drawing.
Using the Images collection you may now either link or embed an image.

Dialog Options

eImages Gallery

eAttach - Browse to an image file to attach to the document.

«Edit Image - Display the Image Editor[o% dialog for the selected image.
eDetach - Remove the selected image if no instances exist in the drawing.
elmage Path - Path to the linked file.

eBind to Document - Check this box to embed the image in the document.
eChoose Transparency Color

ePlace - Place an instance of the image in the drawing space.

5.2.3.1.13 Image Editor

Navigation: Referencelzs > Dialogs[s26 > Drawing Dialogs [ss% > CAD Dialogs [ssh >
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Double-click an Image
Commandline: none

Explanation

Image editor. You are editing the Image Definition of the document images collection not the
instance. All instances will follow the definition.

5.2.3.1.14 Rectangular Array
Navigation: Reference[2# > Dialogs |} > Drawing Dialogs [ > CAD Dialogs [ssh >

Rectangular Array x
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K Cancel

Drawing > Modify > Rectangular Array
Commandline: ar

Explanation
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Creates multiple copies of objects in a pattern.

With the rectangular array you can create an array defined by a number of rows and columns of
copies of the selected object.

First you have to select the objects. Then you have to define number of rows and number of
columns of the rectangle, the distance between rows and the distance between columns.

Dialog Options

eRows - The number of rows in the array including the source elements.

eColumns - The number of columns in the array including the source elements.

*Row Spacing - Row spacing in DU.

eColumn Spacing - Column spacing in DU.

ePick >> - Momentarily dismiss this dialog so you can pick the spacing out of the drawing.

5.2.3.1.15 Polar Array

:ﬂ Polar Array ? | x
Ttem Count A 2 V! rotate Items
Rotation Angle. = 380 - Pick CenterPaint -=

0K Cancel

Drawing > Modify > Polar Array
Commandline: parray

Explanation

Creates multiple copies of objects in a polar pattern based upon a center point.
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Polar Array Without Rotation
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Polar Array With Rotation

Dialog Options
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eltem Count - The number of elements in the array including the source elements.

sRotate Items - Sets whether the items are rotated about the center point.

eRotation Angle - Sets the rotation angle.

ePick Center Point -> - Momentarily dismiss this dialog so you can pick the center point from of
the drawing.

5.2.3.1.16 Purge
Navigation: Referencelzs8 > Dialogs % > Drawing Dialogs[% > CAD Dialogs [ >

Drawing > File > Purge
Commandline: purge

Explanation

Remove unused entities from the drawing. Only unused entities and object appear here. For an
item to be purgable it must not appear in any drawing space or by used by another entity or object.
Dialog Options

eCollection Tree - The document collections.
eCollection to Purge - The collections to purge.

5.2.3.1.17 Inserts Dialog

Navigation: Referencelzs% > Dialogs[s2% > Drawing Dialogs % > CAD Dialogs [z >
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Drawing > CAD Tools > Insert Block into Drawing
Commandline: insert

Explanation

Insert blocks in to the drawing. This is the collection of Blocks in the drawing. You may also browse
to any .dwg file and insert it into the file.
Dialog Options

eBlocks - Select an existing block or browse to a dwg file and add it to the drawing.
ePreview -

The selected block
eInsertion Point, Scale, Rotation - Pick here or on the drawing.

5.2.3.1.18 XREF Manager
Navigation: Referencel2e > Dialogs s > Drawing Dialogs [% > CAD Dialogs [ssh >
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Drawing > CAD Tools > XREF Manager
Commandline: xref

Explanation

Manage externally referenced drawings. These are drawings that are visible in the current Model
space but maintained in separate files. They are linked here read only. This allows base drawings to
be managed separately yet display in the current drawing. Because they are linked they are not
editable.

You can bind a previously Externally Referenced drawing to the current document if you desire that
it be editable in the current view. You can control the visibility of XREF layers from the Layers
dialog.

Related Topics:
Layers Dialog[ssh

Dialog Options

eAttach - Browse to the file. After which you will be presented with the standard Insert dialog to
position the incoming file on the screen.
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eDetach - Remove the XREF.
eReload - Get any changes to the XREF file and display them.

eBind - Make it a Block in this drawing file. It is no longer linked and changes in the source file will
no longer reflect in the current drawing.

eUnload - Get rid of it.
5.2.3.1.19 Swap Equipment

Navigation: Referencelzet > Dialogs |2 > Drawing Dialogs [ > CAD Dialogs [zsh >
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Context Menu with Equipment Insert Selected>Equipment Functions>Swap Equipment
Default command line shortcut: none

The Swap Equipment function allows you to swap Manufacturer, Model, and port data on an
existing functional block or concept block.

Applies To:
Functional Blocks
Concept (High Detail) Blocks.
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Used For:
Switching from one make/model to another.

Dialog Options

eManufacturer - Select the Manufacturer to replace the outgoing device with.

eEquipment Name - Select the Equipment Name / Model / PN to replace the outgoing device
with.

eIlnputs grid, Outputs grid - Select the ports to replace.

Find Matches - Matches incoming ports to outgoing ports.

¢OK - Do it!

5.2.3.1.20 Swap Pointers

Navigation: Referencel2s5 > Dialogs/s8 > Drawing Dialogs[ss5 > CAD Dialogs[ss5 >

This function will replace pointer sets in this and other drawings.

Select the _Sand _D pointer to replace with

This funcion works on-sheet and off-sheet

If the other pointer is on another sheet, that drawing vl be opened and the
Dol replaisd

Don't forget to save al drawings when this i finished,

THIS CAN TAKE A WHILE. Be patient.

Outgoing Pointer D 'WC3_Ponber D
Incoming Pointer D v
Incoming Fonter _5 o

[Advanced Tools] > [Swap] > [Swap All Pointers]
Default Command Line Shortcut: SwapPointers

If a pointer is displeasing to the eye, it can be changed using this tool.

See also: How To: Swap Pointers| 10

5.2.3.1.21 Swap Terminals

Navigation: Referencel2s% > Dialogs 2% > Drawing Dialogs[ss% > CAD Dialogs [zs% >
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This function will replace TERMINALS - JACKS, JBOXES, ROUTERS.

It requires two vanables:

Select the outgoing terminal, The suffix must match in order to be swapped.
Don't forget to save all drawings when thes is finished.

THIS CAN TAKE A WHILE, Be patent.

Outgoing Terminal | we3_eu_hn_d
Incoming Terminal w

OK Cancel

[Advanced Tools] > [Swap] > [Swap All Terminals]
Default Command Line Shortcut: SwapTerminals

If a terminal is displeasing to the eye, it can be changed using this tool.

See also: How To: Swap Terminals| o9
5.2.3.1.22 Edit Attributes

Navigation: Referencelzs% > Dialogs s > Drawing Dialogs[zs% > CAD Dialogs [z >
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Reset (@) Update only this (O Undate all appearance of this block O Update all blocks to match this style ok Cancel

CAD Tools > Edit Attributes
Default command line shortcut: EditAttributes

If an insert has Attributes they can be edited using this tool.

Be careful using this on WireCAD generated blocks as there is usually a tool that will update the
attributes and the database concurrently.

Applies To:
CAD Blocks.
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Used For:
Editing text in a Insert entity.

Dialog Options

Tag - Descriptive text.

Value - The data that renders as text in the insert.

InvisibileMode - Sets whether the attribute is invisible. True = invisible.
Text Style - Sets the TextStyle and therefore font of the attribute.

Bold - Sets the whether the Attribute text is bold.

Height - Sets the Text Height of the Attribute.

Pen Color - Sets the Pen Color of the Attribute.

Hor Justify - Sets the horizontal justification of the Attribute.

Ver Justify - Sets the Vertical justification of the Attribute.

Rotation - Sets the Rotation in degrees of the Attribute.

Locked Position - Sets whether the attribute can be moved when the document is in
Drawing[Status]>GripBlockAttributes mode.

[Reset] - Resets the attributes back to their default values.

[Update Only This] - Updates this block instance only upon clicking [OK].

[Update all appearance of this block] - All inserts that bear the same Block Name in this drawing
will be updated to match this.

[Update all blocks to match this style] - All inserts in the drawing that have matching attributes
will be updated to match this.

5.2.3.1.23 Add Attribute Definition
Navigation: Referencelzs8 > Dialogs [ > Drawing Dialogs[:s5 > CAD Dialogs |35 >
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CAD Tools > Create Attribute Definitions
Default command line shortcut: none

Used to create an Attribute Definition. Attributes exist in two states.
1.Before a block is created an Attribute is referred to as an Attribute Definition or AttribDef.
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2.After a block is created with an AttribDef it becomes an Attribute.
3.AttribDefs are editable and easily modified. Once added to a block they are harder to change.

Blocks do not limit the number of AttribDefs.
Applies To:

Standard CAD Blocks.

Used For:
Creating editable text in a Insert entity.

Dialog Options

eTag - Descriptive text. This is what renders when not included in a block.
oValue - The data that renders as text in the insert.

5.2.3.1.24 X Properties Grid

Navigation: Referencelzs% > Dialogs s > Drawing Dialogs[zs% > CAD Dialogs [z >
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Not directly callable.

Default command line shortcut: none

This dialog allows you to add edit and delete extended properties on an entity. This is generally
done in code.

This dialog can be shown by clicking the [...] button on the XProperties row of the drawing
Properties Tool Panel.
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@ aQ

villrer® YAMAHAD RV ] w

-
i WProper bes 2 1hems :)

Extrugianisgter 00000, 0000040, 100040
resesrtioniPoint 19.282640.4931,000_

We recommend that you not edit any of this data.

Applies To:
All entities.

Dialog Options

oeType - Variable type.
eName - Descriptive text.
oValue - The data.

eAdd, Edit Delete - obvious.

5.2.3.1.25 Edit X Properties

Navigation: Referencelzs8 > Dialogs 26 > Drawing Dialogs (5 > CAD Dialogs [ >

&1 Extended Property (XProperty) + Il
Type: | RN v
Mame: Enhty e

Property vale

Not directly callable.
Default command line shortcut: none

This dialog allows you to edit existing extended properties on an entity. This is generally done in
code.
This dialog can be shown by clicking the [Edit] button on the Extended Properties [+ grid.

We recommend that you not edit any of this data.
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Applies To:
Select Extended Property of the selected item(s).

Dialog Options

oType - Variable type.

eName - Descriptive text.

eValue - The data.

X, Y, Z - If the data one of the point types.

5.2.3.1.26 Singleline Text Editor

Navigation: Referencel2ss > Dialogs s > Drawing Dialogs[ss5 > CAD Dialogs [ss51 >

®| - Bt Text T
B J U g |[E=== f i Ty [ ] & = = =
5| 5 | Text Heght = . T
Boid sk  Underine ShkeThrough 3 v Laver Bl Top  Coder  Bothe Left erier  Right sy
I EyLave b=
Farit Flsgs e Justhoaton A
[ 51 oo
Acoept Canod

Double-click text entity
Default command line shortcut: none

This dialog allows you to edit existing single line text entities.

Applies To:
Selected Single Line Text entity

Related Topics:

Text Styles |
Layers [

Dialog Options

Bold, Italics, Underline, Strikethrough

oText Style - Text entities do not have fonts but rather document based TextStyles. The TextStyle
associates the font.

eText Height - In drawing units.

eLayer - The Layer on which the entity resides.
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eColor - The pencolor of the text entity
eRotation - Angle in degrees.
eJustification - Sets the horizontal and vertical justification.

5.2.3.1.27 Multi-line Text Editor

Navigation: Referencel2ss > Dialogs s > Drawing Dialogs[ss5 > CAD Dialogs [ss51 >

Sardard ¥ Fexl Stvie w Hataton ’ =
(4] : ol - Lo = §
i u Charpcters «  Colorg = W |y Texthesght |0 w Layer - Tap E 3 H
= = sl LefE =
Foregrourd - P Colee o Lne Spacg
e anon b

Double-click MText entity
Default command line shortcut: none

This dialog allows you to edit existing MText multi-line text entities.
MText entities display multiple lines of text with the ability to format selections within the MText
entity.

kT Eritily

This part of the text is 3x bigger than the selected TextHeight
This part changes color mid line More text with a different color
Then a fraction:

Ya

MText Preview

MTEXT Control Codes

\0...\o Turns overline on and off
\L...\1 Turns underline on and off
\\ Inserts a backslash

N{.. 0\ Inserts an opening and closing brace

\Cindex; Changes to the specified color

\Hvalue; Changes to the text height specified in drawing units

\Hvaluex; Changes the text height to a multiple of the current text

height

\Tvalue; Adjusts the space between characters, from .75 to 4 times

\Qangle; Changes obliquing angle

\Wvalue; Changes width factor to produce wide text

\Ffile name; Changes to the specified font file

\A Sets the alignment value; valid values: 0, 1, 2

\P Ends paragraph

\S..."...; Stacks the subsequent text at the \, #, or ”~ symbol
Applies To:

© 2025 Holbrook Enterprises, Inc. - WireCAD
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Selected MText text entity.

Related Topics:

Text Styles [:o
Layers|soh

Dialog Options

eltalics, Underline, Overline

eCharacters - Insert control codes for the selected character.

eColors - Insert control codes for the selected color. We have provided named colors but the
control code \C can be followed by any of the index colors 0-127

oText Style - Text entities do not have fonts but rather document based TextStyles. The TextStyle
associates the font.

eText Height - In drawing units.

eLayer - The Layer on which the entity resides.

eColor - The pencolor of the text entity

eRotation - Angle in degrees.

eJustification - Sets the horizontal and vertical justification.

5.2.3.1.28 Sync Insert Decision

Navigation: Referencelzs > Dialogs |6 > Drawing Dialogs [2% > CAD Dialogs [ssh >

Insert Data
Ty Lot Brvukabie Ea Hrudfxhee  Eoupmed P Ackdrem Subrwt Fak  User ] ner Lard ey
E el Nk .

Database Data
[am— Lo ivalishie Y. iarinciaer [oupeent  Baddem ubretbsk s [T T )
1 0 e A3k A ILH

Use Insert Data Lis Database Data

Right-click a Functional Block then Equipment > Sync with Database
Default command line shortcut: none

If the block information does not match the database information you are presented with this choice.
Yellow background cells represent fields that do not match.
You must choose which data to use.

Applies To:
Selected Functional or Concept Block.

Related Topics:
None
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5.2.3.1.29 Validate Deletion
Navigation: Referencel2: > Dialogs |26 > Drawing Dialogs [ > CAD Dialogs [zsh >

edeting Them That Has a Database Reference
You e S tng & Tyiem £t wisa Mas an ey in S [gugment Lk
e e

RO : S pyuiem Bay AD0ea N mUitphe O e
Da el et ot chalioaniar ooy ol i harvt dcieied ol refereruns

Chckire [Fes) debenes Tt e ot e Tt Sttt reboned 8. el dek chaaiing widi
Chirng [l delebin orily B i ety Inirvireg B clitibass focord in Lack
Diciing Foanon] cancein £ Ciele S,

2o A . - Carudl

Delete or Erase
Default command line shortcut: e

When deleting an entity in the Applies To list you will be presented with this decision.
This indicates that the entity you are deleting has an matching record in one of the databases.
It is your choice as to whether to keep or delete the associated database record.

Example

Assume you have a device called SRVR-01. Further that SRVR-01 has appearances in the video
drawing and the audio drawing.

When you decide to delete the instance that is in the video drawing, you will be shown this dialog
and need to decide whether to delete the database entry as well.

The appropriate response in this case is not to delete the database record since we still have the
instance in the audio drawing.

Applies To:

Blocks with SysNames
Terminals with SysNames
Cables with Cable Numbers.

Related Topics:
Delete Handling Settingse8)

5.2.3.1.30 Zoom Scale

Navigation: Referencel2s# > Dialogs [+ > Drawing Dialogs|ss% > CAD Dialogs [ >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

b > I

Relative to active view or viewport
Scale Factor:

€%

O Cancel

View > Zoom Scale
Default command line shortcut: ZoomScale

This function is used to numerically zoom the currently active viewport to the underlying Model
Space.

Usage

1.0pen a drawing.

2.Switch to a layout with a viewport.

3.Double-click the viewport to activate it. You will see the crosshair is constrained to the viewport.
4.Click View>Zoom Scale ...

5.Enter a scale factor.

6.Click [OK].

Applies To:
A layout with an activated Viewport.
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5.2.3.1.31 Alphanumeric Sequence

:'ﬂ Alphanumeric Sequence
Example:

FROM: FRED-1
TO: FRED-25

Insertion Point: -25.05478752,120.53040306,0

Prefix: FRED-

Count:

Starting At

Spadng:

Text Height (1,100 DL):

Pen Color: [ BylLayer

Ok

WireCAD v10.1 User Manual

Horizontal

|

24

100

A A B[ Ak A AP

Cancel
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CAD Tools > Entities > Text > Alphanumeric Sequence
Default command line shortcut: AlphanumericSequence

This function creates a sequence of text either verticaly or horizontally in the drawing.

Example
FRED-1

FRED-2
FRED-3

FRED-4

Dialog Options

Insertion Point - Sets the insertion point of the first text item. Click the ellipsis button [...] to pick a
point in the drawing.

Prefix - Sets the prefix of the text. The numbers will be appended to the value in the Prefix field.
Horizontal - Sets whether the sequence is created horizontally.

Count - Sets the total count of the sequence.

Starting At - Sets the starting number of sequence.

Spacing - Sets the spacing in Drawing Units (DU) between the text items in the sequence.
Text Height - Sets the Text Height of the text in 1/100ths of a DU.

Pen Color - Sets the Pen Color of the text in the sequence.
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5.2.3.1.32 Text Increment

:'ﬂ Alphanumeric Sequence
Example:

FROM: FRED-1
TO: FRED-25

Insertion Point: -25.05478752,120.53040306,0

Prefix: FRED-

Count:

Starting At

Spadng:

Text Height (1,100 DL):

Pen Color: [ BylLayer

Ok

WireCAD v10.1 User Manual

Horizontal

|

24

100

A A B[ Ak A AP

Cancel
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CAD Tools > Entities > Text > Text Increment
Default command line shortcut: TCount

This function numbers an existing array of text. It should not be used to number cables or
equipment. Those functions have corresponding Assignment functions.

Example
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Dialog Options

Starting Number- Sets the insertion point of the first text item. Click the ellipsis button [...] to pick
a point in the drawing.

Leading Zero Count - Sets the prefix of the text. The numbers will be appended to the value in the
Prefix field.

Increment- Sets whether the sequence is created horizontally.

Sorting - Sets the total count of the sequence.

Placement of Numbers in Text - Sets the starting number of sequence.

Find and Replace - Sets the spacing in Drawing Units (DU) between the text items in the
sequence.

Overwrite - Sets the Text Height of the text in 1/100ths of a DU.

Append - Sets the Pen Color of the text in the sequence.

Prepend - Sets the Number sequence to be added to the text.

5.2.3.2 Advanced Tools Dialogs

Navigation: Referencelz: > Dialogs s > Drawing Dialogs [ >

The following is a set of dialogs that may be presented while using the advance tools in the drawing
environment.

5.2.3.2.1 Equipment Library

Navigation: Referencel[2# > Dialogs s > Drawing Dialogs [ > Advanced Tools Dialogs 4z >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

®E - Wirecs : sbg.vdb6): [1 1 w1 == & ]x
Library | Inputs/Outputs  Display Preferences  Options (-]
o) o) a1 2 q p
©Q © 0 B’ o o * B P s 1T 4 14 € > p
AddEquipment Delete  AddManufacturer Save SaveAs Attach  Refresh || Your Library | Favorites Community - Find Find Al | Upload oad | Firs e o a
tolibrary  Equpment Document Library
»
‘Your Manufacturers Your Equipment Stock Shapes Preview
Inage Approved NE Desaript Type (Syshame Prefix)
— v o
et + Nothing to see here. Right- a o o o0 e Find ato (2 [ X
Manufacturer Name Manufacturer Image » 2 Nothing to see here. Rig 8 1BEYOND AUTOMATE VX CAMERACONTROLLER  CTRL
»  1eEvonD No image data
1Beyond No image data
360 SYSTEMS ﬁw g
‘sRoaBcasY
360SYSTEMS No image data
A0 Rectangle
scomm 7\
3 C OI I I Details - AUTOMATE VX has 12 inputs and 6 outputs. —
ABEKAS No image data
Ful Neme B
ACCOM No image deta o AUTOMATE X u
ACTIVESTORAGE o image data Desaription K CAVERA CONTROLLER =
Type (SysName Prefix) ¢ CTRL
Front Panel File 4BLOCKS%\2D_FLEVATIONS\2U_2D_EL.DWG
Plan View Fie = Dl b
apC
Image Nothing to see here. Right-click to add image. (@ Functional Block
Wieight O concept Block
Weight Unit of Measure
Signal Types Only Block
ADDER No image data Height O signa ypes oniy sl
ADTEC DIGITAL No image data Height Unit of Measure = O Mappabe Terminal From File
width
ARTOOLS airlesls Width Uit o Measure | OimemsmmEs
Depth (O Front Panel from Fle
AIWA /\\“ Depth Unit of Measure
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Image Path -
Create Sysiiame
AlenTel No image data e . L&
Allentel No image data e T No Body
ALTEC T
ALTECH CORP LTE o = Exit

Database > Equipment Library

Drawing > Advanced Tools > Equipment Library
Commandline: le

Several Others

Explanation

The WireCAD Equipment Library is where you will spend a fair amount of time as you define
equipment that you will use in your designs. The Equipment Library is a presentation of the global
Manufacturers table and its hierarchy. The Equipment Library contains no CAD blocks just
equipment definitions. These equipment definitions describe a piece of equipment its make, model,
and IO.

This is also where we come to create CAD blocks in our drawings. There are many settings here
that let you customize appearance.

The interface is tabbed. The [Find] tab sets the current item. The current item will be enumerated in
the [Detail] and [I/0O] tabs. This topic covers the right-hand column of controls that is visible from all
tabs.

Dialog Options

WireCAD v10.1 User Manual
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| auto| | 2 | N

e Auto Preview - Automatically
generate the preview. This can be costly if you have an equipment definition with lots of Inputs
and Outputs.

Preview

fnum#ﬂ

*Big Preview - Toggle between
large preview mode.

Preview

E Auth | o

eRefresh Preview - Call for a
refresh of the preview window. This will rebuild the image based on all of the data and settings.
ePreview - Displays the currently selected equipment definition based on the Display As: setting.
eDisplay As:

Setting Preview
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Front
Panel
(File
Merge)

SIEHRE MFG MODEL

(mm|
L

Front
Panel
(From
Dims)

\/

Plan
View
(File
Merge)

Plan Not yet implemented.
View

(From

Dims)

eAdd Manufacturer - Shows the Add Manufacturer dialog.
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eAdd Equipment - Shows the Add Equipment Wizard.

eDelete Equipment - Deletes the selected record.

eAdd to Drawing - Add the selected item to the drawing based on the current preview.

eAdd to Project Database Only (Assign SysName) - Shows the SysName Assignment dialog.
eAttach Document - Attach any document to the current record. This is useful for storing data
sheets or specification documents with the equipment definition.

5.2.3.2.1.1 Find

Navigation: Reference[># > Dialogs[+# > Drawing Dialogs/s% > Advanced Tools Dialogs [« >
Equipment Library [+ >

fol= | Equipment Lil - Wirec? i [2WCom]-[A20 ] =) = (& ]lx
Lirary | Inputs/Outputs  Display Preferer Option: (2]

© O QHf:E@JO‘m*)\;i\M,‘ QA s 1 4

i Exmo e e |k atachz= v save i it cerh| R = co Find FdAl\ Upload D
Equpment  Docmenl Ty

Database > Equipment Library

Drawing > Advanced Tools > Equipment Library [Find]
Commandline: le

Several Others

Explanation

The [Find] bar allows you to search the local global database as well as the Community Server.
When searching locally all records are returned by default. When searching the Community
Server you will need to enter a search term. The results will be returned in pages based on your
Results Page Size value.

Search Term Hints:

When searching the databases for items, less is more. You want to enter a value that can be found
in a single field.

For example: say we are looking for a Sony DVW A-500. The following is a list of terms and their
results:

Search: sony - Result: All Sony products and any products from other manufacturers that have Sony
in their description fields.

Search: pvw - Result: All products with DVW somewhere in the name or description.

Search: sonvy pvw - Result: None. There are no products with the manufacturer name and the
product name in a single field.

Find Bar Options

Find - Enter the search term here.
Find button - Do the search.
Find All button - Clear and find all records. (Local only).
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Your Library - Display the data from the local global database as defined in the Application
Settings[Global Database Location][sb) settings panel.

Favorites - Show the Manufacturers that you have added to the Favorites list by right-clicking and
clicking Add to Favorites. Conversly you can remove favorites from the list by activating the
Favorites mode and right-click a Manufacturer and select either Remove or Clear. Clear removes
all.

Community Server - Switch to the Community server.

Test Connection button - Test your connection to the Community. If this fails you may need to
open your firewall to community.wirecad.com port: 1433.

Download From Community - Before any edits can be made to the device you will need to
download it to your local database.

Upload to Community - You can upload manually by clicking this button.

Grid - found items.

Results Paging - You can view the page results here:

Community Equipment - Records 1 to 10 of 244
5.2.3.2.1.2 Inputs/Outputs

Navigation: Referencelzh > Dialogs[=% > Drawing Dialogs[=% > Advanced Tools Dialogs|[# >
Equipment Library | s2s >
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Database > Equipment Library [1/0]
Drawing > Advanced Tools > Equipment Library [1/0]
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Commandline: le
Several Others

Explanation

This is the Inputs and Outputs page. It represents the I/O of the currently selected device. Inputs
are displayed in the left-hand grid and outputs are displayed in the right-hand grid. This is by
convention only. You are free to place inputs on the right-hand side and vice-versa. Each port
record consists of a Name, Type, Connector and a Pin Type. Selected records will be included in
the preview of any Function 1/0 and Concept blocks that you create.

If you are using connector genders be sure to enter the cable-end gender not the chassis side.

I/O Tab Options

elnputs Grid, Outputs Grid - NOTE: Be sure to save your changes if you edit these grids
manually by clicking File>Save.

oSelect All, Clear Selection, All Inputs, All Outputs - Manipulate the selection.

eSelect by Signal Type - Ten buttons in this frame will populate with the first ten signal types from
the 1/0 records. Clicking the button will select all records in both grids of that signal type.

eReorder - Move selection up/down.

eCopy - Copy side-to-side.

eAdd Ports - Show the Add Ports dialog[«5.

eDelete Ports - Delete the selected ports. You will be prompted for each grid. No save is
necessary.

eRefresh - Refresh the preview.

eDisplay Order - Set and sort by the Display Order column. This allows you to rearrange the lists
and be able to return later to your work.

5.2.3.2.1.3 Display Preferences

Navigation: Reference[=% > Dialogs[«% > Drawing Dialogs /s > Advanced Tools Dialogs|«b >
Equipment Library | +28 >
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Deplny Properbes Extended Body Propertes Shinth Shapes

DS riglican DeCTiptoa

Database > Equipment Library

Drawing > Advanced Tools > Equipment Library
Commandline: le

Several Others

Explanation

This is where we determine the look of the block we are about to add to the drawing.

There are four tabs in this view that allow you to customize the appearance of the block you are
about to create.

1.Stock Shapes|+h

2.Mappable Terminals| ¥

3.User Defined Shapes 4

4.Mechanical Forms|4H

Stock Shapes | Mappable Terminals | User Defined Shapes

WireCAD v10.1 User Manual
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Understanding the Settings Mechanism

Settings store the appearance and display mode of the Equipment Library. These settings
determine the look of the created block. You can tell which settings were used to create the block
by looking at the Equipment Library status bar:

CDA3S has 1 inputs and 4 outputs. Preview created from Project settings.

WireCAD stores the settings used to create blocks in three different locations:

1.Device settings. If you create a block in a drawing we store the settings used to make the block
with the device definition in the Equipment Library. These settings have priority.

2.Project settings. If you like the display of a block you can click the:

Set Current Display Properties as Project Default Reset Project Default Reset Device Settings

Doing so will set the current display settings as the Project default. All devices that do not currently
have stored settings will then use the Project defaults.
3.Default settings. When no other settings are found we use the defaults.

Several controls are common to all tabs. We will go into those first.

Common Controls Options

eBody Color - Sets the color of Functional I/O and Concept block bodies. Has no effect on User
Defined Shapes or Terminals. The geometry of the file determines the look.

oCreation Mode - Set by the Ul. Leave it alone.

eDescriptor Locations - Shows the Descriptor Locations Map. Applies to Functional, Concept,
and User Defined Shapes.
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Drag to reposition
eImage Display Mode - Applies to Applies to Functional and Concept blocks.
None - no image or cad block is inserted in the created block.
Image - insert the image that is pointed to in the Image File Path of the Details tab for this device.
DWGilcon - insert the DWG Icon in the DWG Icon File Path of the Details tab for this device.
elmage Position, Image Scale Factor

Image inserted and scaled at MiddleCenter
eMerge and Center - Centers identical text in the block. Applies to Functional and Concept

blocks.
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eText Height - The height of all generated text.
eSpacing and other dimensional info:
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eBody Pen Width - The thickness of the line that represents the block body.
eNudge Positions - Use to nudge the various text around.

eTears and Bulge Factors - Tears are visual elements that represent to the reader of the

document that the device does not display all of its available 1/0. Tears use bulges. The greater the
bulge factor the more dramatic the tear.
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Bottom edge torn bulge factor .15 or 15/100

R R UENT

Ersame

Bottom edge torn bulge factor .5 or 50/100
eSet Current Display Properties as Project Default
*eReset Project Default

eReset Device Settings
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Stock Shapes Options

Stock Shapes j Mappable Terminals | User Defined Shapes | Mechanical Forms

Here you choose from 18 stock shapes. We will not enumerate them here. Try clicking on them to
see what they do.

Mappable Terminals Options

Stock ShEDER Mappable Terminals T}r Defined Shapes | Mechanical Forms

Here you can map the selected 1/0 on to terminals. Terminals are one or two port inline devices. If
you select more than one record in the 1/0 tables we will continue to add terminals to accommodate
the selection. If you select a terminal that has only an input port then any selected output records

will be ignored.

Example showing multiple I/O selected and mapped on to a terminal that represents a full normal
jack:
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User Defined Shapes Options

Stock Shapes | Mappable Termina User Defined Shapes " echanical Forms

Any CAD file can be used as a User Defined Shape. It just needs to be placed in the Shape Files

folder:
%BLOCKS%\Shapes Files

The Display Properties will then scale and stretch the object while applying port data.
Example showing User Defined Shape with four ports applied:
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ADC
PP12232RS-MVJ-DVY
Sysname

Alias
Location

Mechanical Forms Options

Stock Shapes | Mappable Terminals | User Defined Shaps

Mechanical Forms are hard-coded objects that get their dimensional data from the device definition
and use it to render objects.

Item Description

Rack Enclosure

Rack Tray

Cube Select a form. Only available when Front Panel (from Dims) is selected.

Half Rack Left
Half Rack Right

5.2.3.2.1.4 Add Ports

Navigation: Reference[zh > Dialogs/+# > Drawing Dialogs/s% > Advanced Tools Dialogs [« >
Equipment Library [« >
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% > I

Tips

For feed-through cornections or bulkhead panels set the input and output Name the same:

Consider naming patchbay porits A-2 and B-2 for the top and bottom rows

It doesn’t matter which side you place a port on. You can Sways move it laber,

‘When selecting the connector gender abways consider that WireCAD newds the CABLE END of the connection, nat the chassis side

Bichrectional signals will be added to both Inputs and Outputs ists with teh Bidirectional flag set to True. This will exdude: acddental selection of mone that one port of the same name.

Akl b Whichy List: Port Mame: o Add Multiples:
Growug: Add Muitple Ports

& Inputs (Left Side) Cornector (Cable End): v |+

Dustpuits (Right Sde) Signal Type: w |

Bath [rput Parts

B tional irput P Shyle: . Pegrmal w

It Port Markes B e v
Output Ports
Fraly Append Characters
Add Ports and Close Cloresa Apply

Database > Equipment Library [1/0] [Add Ports]

Drawing > Advanced Tools > Equipment Library [1/0] [Add Ports]
Commandline: le

Several Others

Related Topics:
How To: Add Some Inputs and Outputs| e
How To: Add Ports

Explanation

This is the Port Adder dialog. With it you add a single record, two records, or multiple records to the
I/O grids. Here are some things to consider when naming your ports:

1.For feed-through connections or bulkhead panels set the input and output Name the same.
2.Consider naming patchbay ports A-# and B-# for the top and bottom rows.

3.1t doesn't matter which side you place a port on. You can always move it later.

4.For bi-directional signals such as Ethernet or RS-422 consider your document flow when
determining the list to which you will add these ports.

5.When selecting the connector gender always consider that WireCAD needs the CABLE END of
the connection, not the chassis side.

Dialog Options
eAdd to Which List
ePort Name - Enter the port name here. This may be a partial name if the Add I/O dialog is set to

append either multiple records or the Finally Append field contains the remainder of the string.
eConnector (Cable End) - From the global Connectors table.
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eSignal Type - From the Project Signal Types table.

eInput Pin Style - Straight pin (Normal) or looped (two connection points).

¢Output Pin Style - Straight pin (Normal) or bridged (two connection points).

eAdd Multiples - If checked a record will be created for each Count. The number will be appended
to the Port Name info and formatted based on the Leading Zeros format.

oFinally Append Characters - Useful if you want to add characters after the multiple count number
has been appended. See the How to Add Ports topic for more info.

5.2.3.2.1.5 Copy Port Data

Navigation: Referencelzs% > Dialogs[=% > Drawing Dialogs/s% > Advanced Tools Dialogsl+f >
Equipment Library/[ «b >

&l Copy Ports From ...  IER

Copy Source: Image Server 2K - Inputs: 17 - Outputs: 18
Copy Targek: Image Server 2K

Select the Source Equipment

Marufacturer EXEEI=00 v | Model Image Server 2 W

Which Ports to Copy

Inputs Outputs ®| Bath

O Cancel

Database > Equipment Library [Edit > Copy Port Data]
Commandline: le
Several Others

Related Topics:
None

Explanation

Allows you to copy port data from another device definition into the currently selected device
definition.

Dialog Options

eSelect Manufacturer and Model - to copy from.
eWhich Ports to Copy - obvious.
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5.2.3.2.1.6 Incoming Signal Types Map

Navigation: Reference[=% > Dialogs[«% > Drawing Dialogs /s > Advanced Tools Dialogs|«5 >
Equipment Library| 8 >

il Changes Incoming Signal Types T X
Rename From This To This
REF REF .
sE UsE
¥YID VD
ALID ALID
i S0l
BES AES
oK Cancel

Database > Equipment Library [ Download From Community]
Commandline: le
Several Others

Related Topics:
None

Explanation

When downloading from the community server you will use this dialog to map from the Signal Types
used in the incoming device definition to your Signal Types.

Dialog Options

eRename From This - Incoming Signal Types.
oTo This - Map to your Signal Types.

5.2.3.2.1.7 Save Equipment As

Navigation: Referencelzss > Dialogs[+% > Drawing Dialogs /% > Advanced Tools Dialogs [« >
Equipment Library| 28 >
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& save Image Server 2K As: * IEN

Manufacturer: 350 SYSTEMS w

Equipment Model, Name,, or Part Numbser | Emage Server 2

Database > Equipment Library [File > Save As]
Commandline: le
Several Others

Related Topics:
None

Explanation

Allows you to copy the current device definition as a new device definition with a new Manufacturer
and Model.

Dialog Options
eManufacturer - Select Manufacturer.

sEquipment Model - The new name.

5.2.3.2.1.8 Descriptor Map

Navigation: Referencel=% > Dialogs[s} > Drawing Dialogs/% > Advanced Tools Dialogsl+5 >
Equipment Library| 428 >
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—
e
—

Hidden ems i

Cesriphion
Liger 1
Usmr 2
Lisar
Ligar
IPaddrass
Subret

Database > Equipment Library [Display Preferences] Descriptor Locations
Commandline: le
Several Others

Related Topics:
How To: Add Equipment to Drawings| s

Explanation

Change the locations and visibility of the various block descriptors:
eSysName

eManufacturer

eEquipmentName

eLocation

eAlias

eDescription

eUser1 -4

o|PAddress

eSubnet Mask

Operation

Drag the named descriptor to the target on the map.
To hide a descriptor drag it to the Hidden Items frame.
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5.2.3.2.2 Rack Builder Tool

Navigation: Referencelzs > Dialogs 26 > Drawing Dialogs [s:% > Advanced Tools Dialogs 44 >

H Rack Builder ? | x

Basic | Advanced
Select Locations For Which to Build Rack Elevations Systems Involved

Add Location cooc, ANCHOR * MNew Location + ‘f. ACO-01 @ TC.RK-101.43-[ROSS VIDEO~ACO-4500] Alias: ACO-01

/| FRED @ TC.RK-101.05-[360 SYSTEMS~Image Server 2K] Alias: Playout Server
‘f FRM-01 @ TC.RK-101,33-[GRASS VALLEY ~Densite] Alias: FRM-01

‘f FRM-02 @ TC.RK-101.34-[GRASS VALLEY ~Densite] Alias: FRM-02

‘f FRM-03 @ TC.RK-101,30-[GRASS VALLEY ~Densite] Alias: FRM-03

‘f FRM-04 @ TC.RK-101,26-[GRASS VALLEY ~Densite] Alias: FRM-04

‘f FRM-05 @ TC.RK-101,22-[GRASS VALLEY ~Densite] Alias: FRM-05

‘f FRM-06 @ TC.RK-101, 18-[GRASS VALLEY ~Densite] Alias: FRM-06

‘f FRM-07 @ TC.RK-101,14-[GRASS VALLEY ~Densite] Alias: FRM-07

‘f FRM-08 @ TC.RK-101, 10-[GRASS VALLEY ~Densite] Alias: FRM-08

‘f RK-101 @ TC.RK-101.01-[MIDDLE ATLANTIC~VRK-44-36HLRD] Alias: RK-101
PCR.PROD-ASST-UPPER. ‘f SPG-01 @ TC.RK-101.44-[ROSS VIDEQ ~SRG-4500] Alias: SPG-01
PCR.PROD-UPPER. ‘f SPG-02 @ TC.RK-101.41-[ROSS VIDEQ ~SRG-4500] Alias: SPG-02
PCRLUTIL-UPPER ] SRVR-01 @ TC.RK-101,6-[360 SYSTEMS~Image Server 2K] Alias: PLAYOUT SERVER

RK-03
sTU
STU.RK RS
STUDIO
TC
W TC.RK-101
TC.RK-102
TC.RK-102R
TC.RK-103
TC.RK-103R
TC.RK-104
TC.RK-104R
TC.RK-105
TC.RK-105R
TRAINING RM

PCR.OD UPPER-02 =
PCR.OD UPPER-03

PCR.OD UPPER-04

PCR.OD UPPER-05

PCR.OD-LOWER-03

PCR.OD-LOWER-04

PCR.OD-UPPER-01

PCR.OD-UPPER-03

PCR.PROD UPPER

PCR.PROD-ASST

o

Chedk All Clear Al Chedk Selected Uncheck Selected Chedk All Clear Al

oK Cancel

Drawing > Advanced Tools > Rack Builder
Commandline: rb

Explanation

For more information see How the Rack Builder Works|[ 3.

Automatically generate rack layout. Technically speaking we are populating rack locator grids. They
may or may not display an actual rack depending on whether you have assigned a SysName to a
rack.

The [Basic] tab allows you to select the locations to include in the Rack Building function. As you
select each location, the Systems Involved list will populate. You can further narrow your equipment
list by changing the selection in the right-hand pane.

Dialog Options

eAdvanced tab - exposes properties that control the behavior of the utility.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD




Reference

eChassis Width - Sets the width of the chassis in DU.

¢ Height in RU - Sets the height of the locator grid in Rack Units (RU = 1.75 inches or 4.445cm).
eSlot Count - Sets the number of slots per locator grid. This is used to position items that may not
be located at the insertion point of the rack unit.

¢ Slot Delimiter - WireCAD searches the Elevation field for numeric values first then for the slot
delimiter if found it parses the data into two values: the elevation and the slot, or in other words how
far up in the rack and how far over.

¢ Insertion Point - Where to start the whole process. Clicking the [...] ellipsis button will
temporarily dismiss the dialog so you can pick a point from the active drawing.

eAttribute Height - If view rule is not Front Panel (file merge), sets the attribute height of the
displayed text.

oCreate As -
Front Panel (file merge) = use the dwg file found in the equipment definition BlockRef (Front Panel
File).
Front Panel (from dims) = use the dimension data from the equipment definition to create a 3D
rack block.

From Dims if file not found = Use dimension data if the BlockRef is not found.
ePlace Text If Item Cannot Be Created - If the item cannot be created due to lacking data, place
a text marker in the drawing at the location.
eInclude Grid Hash Marks - This will normally be checked unless you are rebuilding a drawing that
already has the locator grids.
eSpacing DU - Sets the location grid spacing in Drawing Units. Measures from left edge to left
edge.

5.2.3.2.3 Assign Sysname

Navigation: Referencelzs > Dialogs sz > Drawing Dialogs [s% > Advanced Tools Dialogs 5 >
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......

Drawing > Advanced Tools > Equipment Library [Add to Project Database Only (Assign SysName)]
Double-click WireCAD Block
Commandline: le

Explanation

This dialog is presented when assigning a SysName. The SysName field is automatically
generated based on the project SysName Format and the Next Numbers table.

Prerequisites
This dialog is only shown when Verbose SysName Assignment is checked.

Related Topics:
How To: Assign a SysName/[ %

Dialog Options

eManufacturer and Model - Filled automatically in most cases.

eSysName - This number is automatically generated based on the project SysName Format and
the Next Numbers table. WireCAD will always present the next number though you do not have to
use it. In fact, there are times when you should select the existing SysName from the dropdown
list. For example say you have shown the video ports of VTR-01 in one drawing and the audio ports
of VTR-01 in another drawing. When you assign the first instance you will get VTR-01 as the
suggested SysName. The second instance will suggest VTR-02. You will then click the dropdown
and select VTR-01 thus ensuring that the two representations of the same device have the same
name.

eAlias - Friendly, functional, or descriptive name for the device.

eLocation - of the device. For more information see the Locations Grid[ssh. Clicking the [+] button
shows the New Locations s} dialog.

eElevation - If numeric then WireCAD assumes RU. If not numeric it does not matter. There is one
special circumstance where the data will be non-numeric but WireCAD will understand how to parse
it. That is the situation when we want to locate something in a slot in a frame in a rack. We will
need to use the form [elevation][slot delimiter][slot]. For example let's say that | have a DA that
needs to go in slot 5 of a frame located at elevation 20 and my project slot delimiter/[s8 is a dash [-].
| would type into the Elevation field 20-5.
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eUser Fields - 50 characters max. You can define these captions in the Translation Manager -
Plugins > Translation Manager. Search for SysNameUser in the key field.

oIP Address Subnet Mask - Masked to either IPv4 or IPv6 based on the_Project Settings/a
dialog.

ePower Consumption - Pulled from the global Equipment definition or typed manually here.
eWeight - Pulled from the global Equipment definition or typed manually here.

eVendor 1 / Vendor 2 - Pulled from the global Equipment definition or typed manually here.

eFlags - Sort, query, filter flags. You can define these flags in the Translation Manager - Plugins
> Translation Manager. Search for SysNameFlagltem in the key field.

eBTU - Heat load in British Thermal Units. Pulled from the global Equipment definition or typed
manually here.

5.2.3.2.4 Assign Cable Number

Navigation: Referencel[2:# > Dialogs 2 > Drawing Dialogs [ > Advanced Tools Dialogs 4z >

Bl Et Cabie Data * Il

vty L R w Gl Tt L ¥+

i
i

T _FTaA ey

T g = 000000 D00 34 Show e Lipchaim

Double-click WireCAD Cable
Commandline: ac

Explanation

This dialog is presented when assigning a Cable number if the Verbose Cable Assignment is
checked. The Cable Number field is automatically generated based on the project Cable Number
Format and the Next Numbers table.

Prerequisites
This dialog is show only when the Verbose Cable Assignment option is checked on the

Advanced Tools ribbon tab.
Related Topics:

How to Assign a Cable Number/[+o8
How to Assign Multiple Cable Numbers/[5
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Dialog Options

eCableNo - This number is automatically generated based on the project Cable Number Format
and the Next Numbers table. WireCAD will always present the next number though you do not
have to use it.

eCable Type Manu, Cable Type*, Signal Type*

eNamed Path - List of Named Paths[s#5. See the documentation on the Named Paths table.
Selecting a Named Path will cause the Length field to change.

sLength - Manually enter the cable length or select a Named Path.

eIntegrator - Who is responsible for the installation of this cable.

eUser Fields - You can define these captions in the Translation Manager - Plugins >
Translation Manager. Search for CableUser in the key field.

eSheet - Automatically filled with the current drawing name.

eReplaced By - A housekeeping field that you may choose to use.

ePinout - If the Enable Pinouts setting is checked then select the Pinout to apply to this cable.
eVendor 1/ Vendor 2 - Pulled from the global Cable Type definition or typed manually here.

* changes to these fields may cause the number to recalculate.
5.2.3.2.5 Assign Terminals

Navigation: Referencelz: > Dialogs 26 > Drawing Dialogs [ > Advanced Tools Dialogs 44 >

11 Assign SysMame and Ports to Terminal(s) T IEE

Sokoct & Systame: vPE-OD LAk

1 am just changeng a Systisme (ol excsbing ports sty e same)

Ry his equirment on et assgnment Cutgasts Teack lrpats §f matcdhng)
Input= Dutputs
Plama Type L= ) S ¥ P Type (=] Cesiraon
e AGL W B ovag L Wi B o038
Aa2 WD B D=1 B-02 L) B LA 103
&403 L B CH-10 B3 VID B
Laral I n -0 B4 VI (]
AL5 Wi B (/BT B0 Vil B
A WD B CAf =11 B0 i B
&a7 L B CH-1 B 1 B
A8 Wi [ B (] [
A WD B DA 1 B B
L] WD B CAf-4i B-10 I B
Lt Wi B L1 B-u B

Double-click Terminal or Select Terminal and Click Advanced Tools > Assign Terminal(s)
Commandline: ats

Explanation
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This dialog is presented when assigning a terminal or a selection of terminals. The process is to first
select the SysName to use, then select the Inputs and Outputs port.

Note that the Inputs or Outputs grid may be disabled if the terminal to which we are assigning this
information does not have a CP_IN or CP_OUT to receive the data.

Record Highlighting

Red - Port assigned to a cable. The Source Info and Destination Info contains the CableNo :
SysName>Port info.

Yellow - A cable has been attached to this port somewhere in the project. The Source Info and
Destination Info contains the SysName>Port info.

Prerequisites
In order to assign a terminal you must first assign a SysName from which you will select ports.

Related Topics:
Understanding Terminals|

Dialog Options

eSelect a SysName - The SysName from which we will select ports.

el am just changing a SysName (all existing ports stay the same) - Use this if you have
already assigned a SysName to a terminal but you want to switch with another SysName.
eRemember this equipment on next assignment - Persist the selected SysName on next
Terminal Assignment.

«Outputs Track Inputs (if matching) - Select a matching record from the Outputs list if the string
matches the record in the Inputs Name field. The Names must match exactly.

5.2.3.2.6 Assign Terminal No Database Reference

Navigation: Referencelzs > Dialogss26 > Drawing Dialogs [% > Advanced Tools Dialogs |5 >
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X Ede Termiral AsrEsses + IEE

Uee P tool ta mamually el B atirbunes of & WineCAD Termnal This & sl o pon) st i3 donumesnt oorveTion 13 a0
el s Wbl el i el i e e Syt detabaet. rment uie T rreal Termral dasgrme] s
ey Bt hohag 1 el o L Bon oy o oy arerd oo SEguigree! P fors s A Tormwan

WOT ALL FREDS ART DESPLAYID I ASE TTRMINALS

Leperses

sl o Madachaer |

e Mol PHyame | PTILITE

A i Kol T

St Sree et

Eagat ]

e b Hame

e L B Pas ol w
gl Tt ol gl T e s

[Ctrl] + Double-click Terminal
Commandline: none

Explanation

Occasionally you will need to land a cable on a device that is not your responsibility. The cable is
yours but the equipment is not.

You can use a Terminal to do this.

Using this method the data in the Terminal will not have a matching entry in the Equipment List.

Note that the Inputs or Outputs section may be disabled if the terminal to which we are assigning
this information does not have a CP_IN or CP_OUT to receive the data.
Prerequisites

None.

Related Topics:
Understanding Terminals|+:5

5.2.3.2.7 Assign Splice

Navigation: Referencelzs8 > Dialogs 26 > Drawing Dialogs[:s5 > Advanced Tools Dialogs [« >
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B Spice/Adapter Info N x |

Sphoe Points in WireCAD allow you to create a junction

in the wire icable and track the location of that junction.

Splce points are not raded in the project Equipment List.

Applying a Splice Point terminates a cable run. The other side will start a
new Cable and have a separate record and number in the Cables table,

Hirik: Uisang the texct ™Sphee™ in Syshame feld with hide this
object from duplcate ermor checks. Thus allowing you to have
mitiple sphce points all named “Splhce™ without causing

SysMame | SPLICE|

Left Right

Hame Hame Hame Hame

Comnector | Conn W Connector  Conn W
Signnal Type Type W
Location Location w4 | Bevation Blevation

K Cancel

Double-click Splice Point Terminal
Commandline: none

Explanation

Occasionally you will need to splice a cable through a connection point of some sort such as:
eTerminal blocks.

ePunch downs.

eButt splices.

You can use a Splice to do this.
Using this method the data in the Splice will not have a matching entry in the Equipment List.

Note that the Inputs or Outputs section may be disabled if the terminal to which we are assigning
this information does not have a CP_IN or CP_OUT to receive the data.

Using the string "SPLICE" in the SysName will cause the cable assignment function to ignore
duplicate port checks.
Prerequisites

None.

Related Topics:
Understanding Terminals|+5
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5.2.3.2.8 SysName Error Check

Navigation: Referencelzs > Dialogs 26 > Drawing Dialogs [s:% > Advanced Tools Dialogs 44 >

e L Ee ] b Ed- - s A fogeartasy et

jidecd

e B dschrmtamy ot
ey Jrere ™ B R T ]
- P

-

i

Drawing > Advanced Tools > Drawing SysName Error Check
Commandline: drawingsysnameerrorcheck

Explanation

Check the drawing against the database. Checks the following:

eRetrieves all equipment from the drawing.

eChecks the drawing SysName against the database.

o|f matched the record is shown normally. If orphaned or not assigned the background color will be
changed.

Dialog Options

eShow Me - Zooms to the selected entity.
eCheck for Errors - Scans then fills the grid.

5.2.3.2.9 Add Multi-core Cable

Navigation: Referencelzs8 > Dialogs (26 > Drawing Dialogs[:s5 > Advanced Tools Dialogs [« >
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a5 Add Multicore Cable (Al Cores) * IEER

Create an Avalable cable entry for each core in the selected Cable Type appending the Pair Color Code to
the Mumber Base. You may then choose from the avalable cable records on subsequent cable assignments.

umber Bacs w | Cona Dats

Cable Manufacturer ¥ | Cable Type v

Sigral Type b
K Cancel

Drawing > Advanced Tools > Add Multi-core Cable
Commandline: mc
Several Others

Explanation

Often times we install bundled cables - cables with multiple cores. The outside jacket gets a number
and each inner core an extension identifier like: A-1001-RED. Where A-1001 is the number that
goes on the outer jacket and A-1001-RED goes on the RED core. Use the Add Multi-core Cable
tool to create a record in the database for each core in the Cable Type. The CableNo field will
have the full number and the CableNoPrefix field will have the number base. All cores will be
marked Available for use. You can then assign one or all or any of them during the normal Cable
Number Assignment process. You must have Verbose Cable Assignment checked in order to
assign cores in a multi-core cable. Otherwise you will get the next number default.

Dialog Options

eNumber Base - This is the part that goes into the Cable No Prefix field.
eCable Type - Only Cable Types that are flagged as Multi-core will show here.
«Signal Type

5.2.3.2.10 Cable Error Check

Navigation: Referencelzs > Dialogs % > Drawing Dialogs [} > Advanced Tools Dialogs [ >
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s | : IEN
Hande | Erorbesssgs Cabletin Sresys SN SACLas IR DestSys Destin Destlos DestiCor
¥ | e ok i 2 e ok 0 0 0 0 0 o WG
b0, Sho | REF-1001- REF-1001- 5501 BLK-01 ROOM 110.4 B VOA-01 In ROGM 110.4 B
DA-1015- D015« 2G01 AEGA1 ROOM 110.4 B Erbedder-01 AES 103 1.1 B
i Sho | Not Assgned Cables 5G-01 D-BARS ROOM 110.4 B WPE-01 A-17 ROOM 1M0.4 B
4 Sho | REF-1002- REF-1002- VOA01 oUT.1 ROOM 110.4 B RTR-01 REF Location
4 She [ w1017 w1017 VDAO1 QUT.2 ROOM 110.4 B NTRAOL REF ROOM 180.2 B
4 Sho | v-1008- w-1018- VOA-1 OUT.3 ROOM 110.4 B WTR-02 REF ROOM 110.3 B
V-1019- w1018 VOA-01 QUT.4 ROOM 110.4 B VTR0 REF ROOM 110.3 B
L Sha | w1000 W L0 VDA OUT.5 ROOM 110.4 B NTR 04 REF ROOM 180.3 B
4 Sho | Not Assgned Cables VOA-01 OUT.& ROOM 110,94 B Syshiame hame Loca tion Cory
Nat Apmgned Catles VoA uT.7? ROOM 1104 B Syihlame ey Lash ton Cary
) Sho | Mot Assigned Cables VDAL oUT.8 ROOM 110.4 B Syshiame e Location Cory
4 Sho | DA-1016- Ot~ 116 Sh-01 ARSH2 ROOM 1104 B Embedder-01 AES 104 1651 B -
Regard 1af 30 £ L

Source Ponier Dot Pyt Meads attenbon ' Wineiere on Top Check Ervors Mow Choge

Mudti Cable, This cheda anly the frit cable in & multrelational cabie. Al gthers Say show up o sppeanng in db only.

Drawing > Advanced Tools > Drawing Error Check
Commandline: dec

Explanation

Check the drawing against the database. Checks the following:

eRetrieves all cables from the drawing.

eChecks the drawing Cable against the database.

oIf matched the record is shown normally. If orphaned or not assigned the background color will be

changed.

Dialog Options

Item Description

Show Me Zooms to the selected entity

Check for Errors  Scans then fills the grid.
5.2.3.2.11 Auto Block

Navigation: Referencelzs5 > Dialogs % > Drawing Dialogs [ > Advanced Tools Dialogs [« >
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Bl Autostiock = n

This fusction places lunctional blocks in the acthe deawing, You have the chowe of using the
170 deled i the Equipment Libeary (shows all availabibe ports), o shawing only these ports
in use in the Cables tablke, In sither case you will b presented with the Sysieses from the
the Equipment List. You can apply filtees to the displiyed Sysit On the

Bas | Advarwed

Ireerton Font 0.0

Hertrontal Seacng (040 34 5 | Mmdieue Colen Courd 0|
e Praject Dl Tette Szl Typed 12 Deglay
& Lime These Oeplay Sethy
o A | Ermor phease enber 8 SgnaiType -
Display A W ADE
& Funcben/_| Conoept || Front Pa’_) Plan Viey W Ot
Corcept Front P Psn ey W7
Ditpday BreSprerces (17 100 0L e
W 13
Bedy 'Waith 50 | 2 ¥ 30
= W
P Sgacng LA A A
P Wiciehy 00 | = W ADAT -
Sort by Display Order Dl Saectian Gelect M

Drawing > Advanced Tools > Auto Block
Commandline: ab

Explanation

The Auto Block tool automatically places functional blocks in the drawing. This tool requires that
the Project Systems table be populated.

Possible Uses
eAdd functional blocks after creating SysNames from Rack Builder drawings.

oCreate overall systems views.
oCreate drawings from imported data.

Related Topics:
Auto Block tool. [ b

Dialog Options

eThe [Basic] tab allows you to determine which systems to add to the drawing.
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&l AutoBlock

Basic Advanced

Get All Data From Cables Database
Filter

10XL-01 @ ROOM 110,2
AMU-01 @ ROOM 110,2
Cmon-01 @ 109
Cmon-02 @ 109

Cmon-03 & 112
Cmon-04 @ 112

CPU-01 @ 109

CPU-02 @ 112

DMEDR-01 @ 109.1
DMEDR-02 @ 112.1
EDMOMN-01 @ ROOM 110,2
EOMOM-02 @ ROOM 110..3

Chedk All Clear All

This function places functional blocks in the active drawing. You have the choice of using the
I/0 defined in the Equipment Library (shows all avaiillable ports), or showing only those ports
in use in the Cables table. In either case you will be presented with the SysNames from the
the Equipment List. You can apply filters to narrow the displayed SysNames. On the

Check Selected

> IEN

+ | x
~
W
Uncheck Selected
QK Cancel

oFilter - Filters the list by your criteria.

The Advanced Tab
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%1 AutoBlock 2 IEH

This function places functional blocks in the active drawing. You have the choice of using the
I/0 defined in the Equipment Library (shows all avaiillable ports), or showing only those ports
in use in the Cables table. In either case you will be presented with the SysNames from the
the Equipment List. You can apply filters to narrow the displayed SysNames. On the

Basic Advanced

Insertion Point 0,0

Harizontal Spading (DU) 24| & | Maximum Column Count 0|5
Use Project Display Setting Signal Types to Display
® Lse Th Display Setti
R w*| Error please enter a SignalType L]
Display As: 7 ALD R
#®) Function! ) Concept( ) FrontPal_! Plan Viev w'| Out
Concept(_) Front Pal_ Plan Viev | ?
: w| _ null
Display Preferences (1,100 DU) —
W 13594b
Body Width 500 | & v 310
_ . = v/ 4fsc
Pin Spacding 100 | o 7 AC-3
Fin Width 200 : w'| ADAT hd
Sort by Display Order Clear Selection Select all
Ok Cancel

einsertion Point - The point we start from.

eHorizontal Spacing DU - How far apart horizontally. The vertical spacing is defined by the height of the
highest block in the row.

eMaximum Column Count - How many columns horizontally.

eGet Port Data From Cables Database - Select this option to search the cables database for port info instead
of the global equipment database. This will effectively show only those ports to which we have attached cables.

eDisplay As - How to display the blocks.
eDisplay Preferences - If Functional Block or Concept block is selected then set basic display parameters.
eSignal Types to Display - Filter ports by the selected signal types.

5.2.3.2.12 Ratsnest

Navigation: Referencelzs% > Dialogs 2% > Drawing Dialogs[ss% > Advanced Tools Dialogs [ >
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5l ratenest + IEEE

This function pulls cable data rom the Cables table and keoks into the actie drawing to
s i the sourte and destination ports exist in the drawing; i found a cable s placed
betwesn the ports. The result looks e a giant atsmeest. Looking at the mtsnest you
can tell which devices nesd to be repositioned to better display the data. You an move
thi blocks and in 50 deing the cables will be rerouted and deaned up. Altemately you

can use the [Cheanup] button to reroute all cables, Filet apphes & et Uo each oomer of
every cable in drawing

Aats bt Cearup Cables Fillet il Catoles
Ratznest e IO E ] Fillet,
o Shenw Calbie Musterd Anvond Ot Caibied Rades 0.25|2
Clear AN Catles

Drawing > Advanced Tools > Ratsnest
Commandline: rn

Explanation

The Ratsnest tool works in conjunction with the Auto Block tool.
*Get the cables collection.

¢Get the SysName>Port info from the drawing.
eFind matches.

eDrawing straight-line cables.

How it works:

HANL | SEMA
e SO [t SOH004
(s} S0 2 BAC | WIDEC

SO0
ViDEO M BNC
VIDEQDZ | BNC 3071
VIDEDH 03 BHC ‘LT
SRVRO08 Sy
ocabon Elevation Locaior

Possible Uses
oCreate overall systems views.
oCreate drawings from imported data.

Dialog Options
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(5l Ratsnest + EER

This Fusnction pills cable data irom the Cables table and keoks into te actiee drawing to
s i the soiroe snd destination ports exgl in the drvwing: @ found a cable &

betweesn the ports. The result looks ke a giant atsnest. Looking at the ratsnest you
can bell which devices need to be repositioned to better display the data. You cn move
thi blscks and in 50 deing the cables will be rerouted and deaned up. Altemately you

can use the [Cleanup] button to reroube all cables, Fillst apples & fillet to each oomer of
every cable in drawing.

Ruats Pt Ceanup Cables Pt Al Catles
Fatsnest Cnpngp Fillat
o Shav Calbie Mol Aol Ot Calbiled Rt 0.35|2
Clear ANl Cabies

Careed

oThis tool has three sections. The Rats Nest section does the work of placing the cables in the
drawing as defined in the Cables database.

o[Ratsnest] - Run the utility to place the cables.
eShow Cable Numbers - With or without cable numbers.

o[Clear All Cables] - Removes ALL cables from the drawing. Not just ratsnested cables. This will
remove ALL.

e[Cleanup] - Applies the auto-router to all cables in the drawing.
eAvoid Other Cables - Auto-router avoids other cables on cleanup.
o[Fillet] - Applies fillets to ALL cables in the drawing.

eDistance - Fillet distance in 100/DU.

5.2.3.2.13 WireCADify Block

Navigation: Referencel2ss > Dialogs [+ > Drawing Dialogs[ss5 > Advanced Tools Dialogs[«z5) >

K Map Existing Attribates to WirsCAD Attrbutes + IEN

Veur Aot Hase ehage 3 Ve AT Hame

b | Syatiame
[ ipapmen Siamee
S Pt i Larvat:
Lacaben
Alan
et Manufacturer
Creaned e
Equermentif
v VTR-01
et ST
e $INPUT
IHPUT_AME | . YTR-01

Saroe My Seitngs o Cancel

Drawing > Advanced Tools > WireCADify Block
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Commandline: wirecadifyblock
Explanation

Occasionally you will want to use the geometry of a non-WireCAD generated CAD block. In
order to do this you will need to give the necessary attribute set to the CAD block so that it can
function in WireCAD as a working assignable entity.

Steps
eStart the command.
eSelect a standard CAD block. It must be a block and not exploded entities.
sFollow the directions in the dialog to complete the process of adding the WireCAD attribute set
to the CAD block.

Possible Uses
eUse existing CAD drawings and work with WireCAD to move the drawing forward.
oCreate custom appearance.

Dialog Options

eAttribute Map Grid - Map your attribute to WireCAD's.

eDescriptor Locations - Reposition the base WireCAD attributes using the Descriptor Locations
map.

eHide All - Add all the WireCAD attributes but hide them from view.

eShow Default - Show the default attribute set.

ePreview - Preview of the merged block.

5.2.3.2.14 Add Connection Point

Navigation: Referencelzs > Dialogss26 > Drawing Dialogs [s% > Advanced Tools Dialogs |5 >
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&l add Connection Point to Existing Block (Insert) + IEN
Port Name ity Port tame|
Signal Type VED w
Cornector (Cable End) BHC -
»F Port Is Inpaut Lashead Tt Hesghvt {1100 D) 0%
Show Labls
) Port Name | Connector

w Inchudse Geometry

) Crcle Squane Trianghe X
Geemetry Size X (1100 0U) 10| 5 | Geometry Size Y (1/100 DU} w5
Line: Widith 115

"

Drawing > Advanced Tools > Add Connection Point
Commandline: addconnectionpoint

Explanation

If you need to place a connection point (a point to which you can connect a WireCAD cable).
You can use this tool.

You must use this tool on blocks that have the WireCAD attribute set.

Steps
eStart the command.
eSelect a WireCAD block or a block that you have run the WireCADify command on.

eSelect the geometric point at which the connection point will appear. This should be something
that is easy to snap a WireCAD wire to.

sFollow the directions in the dialog to complete the process of adding the WireCAD attribute set
to the CAD block.

Possible Uses

eUse existing CAD drawings and work with WireCAD to move the drawing forward.
oCreate custom appearance.

Manuiachurer
Equipmentiams

L Eysname .
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Dialog Options

ePort Name, Signal Type, Connector (Cable End), Label Text Height, Show Labels
ePort is Input - This will determine which side the label appears on.
eInclude Geometry - Display something to snap to.

5.2.3.2.15 Cable Connection Exists

Navigation: Referencel2ss > Dialogs [+ > Drawing Dialogs[ss5 > Advanced Tools Dialogs[«z5) >

VTR02 ik BT
x i)
MON-L L2
VTR0 A-1004- g swn
RGOM IR ROOM TT02.55

Action
") Meva Mot Mumber
W) Ehl #asmng rusmier ".3 A 100

Slect Exitng Avadable i _ — — 1 Add Multi=cone Cabies
i) Thes catie rumbser exsts n s progect I

CableTypeMaru | BELDERN v CableType LB01A L
SigraType [T .
MamedPath * Length o=
Integrabor
Liserl Liser2
Lser3 Lserd
Sheet MACHINE_ROOM. dwg
‘Wendor 1 * Vendor 2 L]
s e = Q0000 D005 Show Me Lipdate Canel

Not directly callable
Commandline: none

Explanation
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The standard cable number assignment process is a multi-step process. One of the checks that is
performed is to see if the ports to which we have attached our cable are already assigned to some
other cable in the database. If they are found to exist in the database this dialog is shown indicating
whether it is the source or the destination that is in question. Bear in mind that multiple records
might meet this criteria; hence the grid.

There are legitimate instances where this dialog will be shown and your choice requested:

oY cable - The first assignment will proceed without error. The second will show this dialog
indicating that the source exists. As it should. You have a choice regarding numbering in this case.
Do you duplicate the existing number with a new record in the database or request the new number.
eOne-To-Many - see above.

eMany-To-One - Inverse of above. You will see the destination exists.

o|f you land multiple cable on the same port to parallel the connection.

Pay close attention if you are presented with this dialog. It is catching a common mistake before it
gets to your run sheet.

Prerequisites
At least one cable record in the Cables database.

Related Topics:
How To: Assign a Cable[ s
How To: Assign Multiple Cables [+

5.2.3.2.16 Add Spare Cable

x1 =

Cable Type: = <+ Signal Type: - +
Left Side Right Side
Location: * <+ || Location: - <+
Connector: * <+ || Connector: - <+
Count: 15
Geometry
Show Location Show Connector
Show Cable Type Show Cable Mumber(s)

Color by Signal Type

Draw Polyline Cancel
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Drawing > Advanced Tools > Add Spare Cable(s)
Commandline: AddSpareCables

Explanation

Add a cable entry to the database and add a polyline to the drawing to represent the spare(s).

Steps
eStart the command.
o Enter the Cable Type and Signal Type.
eEnter the source and destination locations and connectors
eEnter the count of spare cables to add.

CONF RM DOW-1014- / DV-10158- LIVEL RK
BNC 11834 BNC
360 SYSTEMS
Imags Server 2K
|r FREN ‘1
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5.2.3.2.17 Error Check Pointers

'fI Pointer Error Check [Paste Test.DWG] [} X
SrcHandle Message Src Sysname Src Alias Src Location SrcPort Src DWG O... |Dest Handle Dest Sysname | Dest Alias DestLocation |DestPort Dest DWG
Q Show Me | OK DCIOH:001 Digital Cinem. 2312:2M:Proj... AUTOMATIO Paste Test.D.. v Q Show Me | FIRESH:001 Shielded 4-W 2312:2M:Proj... RJ451 Paste Test.D. -
Q Show Me  OK BLUDAN:001 BSS AUDIOD... | 2312:2M:Proj... BLU link Paste Test.D.. | |v Q ShowMe  CP950:652 DOLBY CP950A | 2312:2M:Proj... DOLBY ATMO... | Paste Test.D...
Q Show Me | OK HDDAZ2:654 CRESTRONH... | 2312:2M:Proj... HDMI Paste Test.D.. v Q ShowMe  HD70RX:655 CRESTONHD... | 2312:2M:Proj... HDMI Paste Test.D.
Q ShowMe | OK CP950:652 DOLBY CP950A  2312:2M:Proj... HDMI IN Paste Test.D v Q Show Me | HDDA2:654 CRESTRONH... | 2312:2M:Proj... HDMI 1 Paste Test.D.
Q ShowMe OK DCIOH:001 Digital Cinem. 2312:2M:Proj... HDMIIN Paste Test.D v Q Show Me HDDA2:654 CRESTRONH... | 2312:2M:Proj... HDMI 2 Paste Test.D..
Q ShowMe | OK DCIOH:001 Digital Cinem. 23%2’\:!’@ LINE INPUT [... Paste TestD.. |v Q Show Me  CP950:652 DOLBY CP950A | 2312:2M:Proj... HI Paste Test.D..
Q Show Me | OK ULXDQ4:002 Quad-Chann 2312:2M:Proj...  Antenna A Paste Test.D v Q ShowMe  ULXDQ4:001 Quad-Chann 2312:2M:Proj... | Antenna B Paste Test.D.
Q ShowMe | OK ULXDQ4:002 Quad-Chann 2312:2M:Proj...  Antenna B Paste Test.D v q Show Me | ULXDQ4:001 Quad-Chann 2312:2M:Proj... Antenna A Paste Test.D.
Q, showMe Unable tofin.. SysName Alias Location Name Paste Test.D... Q, showMe
Q, showMe Unable tofin... SysName Alias Location Name Paste Test.D... Q, showMe
Q showMe Unabletofin.. Syshame Alias Location Name Paste Test.D... Q showMe
Q, showMe Unable tofin.. SysName Alias Location Name Paste Test.D Q, showMe
Q, showMe Unable tofin.. SysName Alias Location Name Paste Test.D... Q, showMe
Q, showMe Unable tofin... SysName Alias Location MName Paste Test.D... Q, showMe
Vv Checking: Destination Side Pointers
Q Show Me | OK NSW1:002 CISCO NETW... | 2312:2M:Proj... Power RACK 002.D Q ShowMe | 20PDU:002 POWER STRIP | 2312:2M:Proj... | (Circuit A) Ou... | Paste Test.D..
Q ShowMe | OK NWS2:002 NETGEAR NE 2312:2M:Proj... POWER RACK 002.D Q Show Me | 20PDU:002 POWER STRIP | 2312:2M:Proj... (Circuit A) Ou...  Paste Test.D
Q ShowMe | OK R-969A-002 TTPATCHBAY  2312:2M:Proj... TOP 29 RACK 002.D q Show Me | QIOL40:019 4CHLINE OU... | 2312:2M:Proj... LINE OUT CH 1 | Paste Test.D.
Q Show Me  OK R-969A-002 TT PATCHBAY | 2312:2M:Proj... TOP 30 RACK 002.D Q ShowMe | QIOL40:019 4CHLINE OU... | 2312:2M:Proj... |LINE OUT CH 2 | Paste Test.D...
Q Show Me | OK R-969A-002 TT PATCHBAY | 2312:2M:Proj... TOP 31 RACK 002.D Q ShowMe  QIOL40:019 4CHLINE OU... | 2312:2M:Proj... LINEOUT CH 3 | Paste Test.D...
Q ShowMe | OK R-965A-002 TT PATCHBAY | 2312:2M:Proj... TOP 32 RACK 002.D Q Show Me | QIOL40:019 4CHLINE OU... | 2312:2M:Proj... LINE OUT CH 4 | Paste Test.D.
Q ShowMe | OK R-969A-002 TT PATCHBAY  2312:2M:Proj... TOP 33 RACK 002.D q Show Me | QIOL40:020 4CHLINE OU... | 2312:2M:Proj... LINE OUT CH 1 | Paste Test.D.
Q Show Me  OK R-969A-002 TTPATCHBAY | 2312:2M:Proj... TOP 34 RACK 002.D Q ShowMe | QIOL40:020 4CHLINE OU... | 2312:2M:Proj... |LINE OUT CH 2 | Paste Test.D...
Q showMe OK R-969A-002 TT PATCHBAY | 2312:2M:Proj... TOP 35 RACK 002.D Q  showMe  QIOL40:020 4 CHLINE QU...| 2312:2M:Proj... | LINEOUT CH 3 | Paste Test.D... |~
Window On Top Cancel

Drawing > Advanced Tools > Pointer Operations > Error Check Pointers ...
Commandline: ecp

Explanation
Error check the linkage between pointers. Properly linked pointers are paired and pointed to
each other. This tool checks only the linkage as follows:
e The source side pointer is linked to the destination side pointer.
¢ The destination side pointer is linked to the source side pointer.
e The pointer generations match.

The error check function does not test:

o Whether the source port is properly linked to the source pointer.

o Whether the destination port is properly linked to the destination pointer.

o Whether the source and destination is properly inserted in the project cables database.

Controls

Grid - Displays the results.

Columns
Show Me - Zoom the pointer into view on the source side.
Message - Displays the result. Possible results are:
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e 0K - It's all good. Both sides are linked properly.

e The pointer is not properly linked in both directions - The pointer is linked to one pointer in one
direction and another in another direction.

e Unable to find other end of the pointer set - Can'tfind the other set, either because the pointer is
not linked yet or the other end cannot be found.

e Unable to get other side pointer connection point data - Can't get the other side connection point
data. This message will probably never show unless a custom pointer is not properly configured.

e The pointer is self linked - This condition is rarely found and difficult to create.

e Pointer version generations do not match - This condition occurs when pointers from different
generations are linked. This condition is difficult to create.

OnSheet - Displays a check mark if the Src Drawing and Dest Drawing are the same.
Show Me - Zoom the pointer into view on the source side.

The remainder of the fields are self explanatory.

5.2.3.3 Plan View and Layout Tools Dialogs

Navigation: Referencel[2: > Dialogs |26 > Drawing Dialogs [ >

The following set of tools is targeted at the plan view space.
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5.2.3.3.1 Take Offs

Navigation: Referencelzs > Dialogs(s26 > Drawing Dialogs/ss% > Plan View and Layout Tools
Dialogs| 401 >
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Drawing > Plan View and Layout Tools > Take Offs
Commandline: showtakeoffs

Explanation

Often we need to count items in the plan view space for quoting or other purposes. The Take
Offs tool facilitates this process by filtering the drawing for specific entity types on specific layers
then counting those instances.

Possible Uses
eQuote preparation.
eTrouble-shooting.

Related Topics:
How to Pull a Take-offl+s2)

Dialog Options

ePrint - Print the grid.

eExport - Export the grid.

eLayer - What layer are we searching for the selected entity type(s).

oEntity Types - What entity type(s) are we searching for.

eGenerate - Do It! The results will be displayed in the grid.

eCount - Count the items in the list. The results will be displayed in the right-hand list.
eltemHandle ShowMe - Zooms to show the item in the drawing.

elgnorelnCount - Ignore me when counting.

5.2.3.3.1.1 Spare Cable

Navigation: Referencelzs > Dialogs[s26 > Drawing Dialogs[s% > Plan View and Layout Tools
Dialogs[+h > Take Offs[«h >
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&l Add Spare(s) * EN
Cabls Type: BELDEN-11894 W 4 | Sgnal Type: 1394 LA
Left Side Right Side
Lecation: | 1061 v & Locabion: 109,14 bl bt
Connectorz | 14" w 4 Conneclor: |14 LA
Count: s
Gegmaty
| Show Locaton | Shioww Connecior
«| Show Cable Type o) Shew Cablle Mumber (5)
| Color by Sagnal Type
Drany Pobyiine Cancel

Advanced Tools > Add Spare Cable(s)
Commandline: AddSpareCables

Explanation

Place geometry in the drawing and cable(s) in the Cables database that represent spare cables.

The following images represent the above settings in both drawing and the Cables database.

1 FW-1011-/ FW-1015- 1
15/ 15/ 15/
1/4" 18008 174"
BELDEN 18008 FW-1011- PreWire PreWlire 1/4" 1 PreWire PreWire
BELDEN 18008 FW-1012- PreWire PreWlire 1/4" 1 PreWire PreWire
BELDEN 18008 FW-1013- PreWire PreWlire 1/4" 1 PreWire PreWire
BELDEN 1800B FW-1014- PreWire PreWire 1/4" 1 PreWire PreWire
BELDEN 1800B FW-1015- PreWire PreWire 1/4" 1 PreWire PreWire

M4 4 Record1of238 b WM — & /x4 »
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Prerequisites
At least one drawing

Related Topics:
How To: Add a Spare Cable[+s5

5.2.3.3.2 Location Boundary

Navigation: Referencelz8 > Dialogs[:=h > Drawing Dialogs[= > Plan View and Layout Tools
Dialogs 401 >

B Lot Beudany Feoqairtied * IEEH

s
s el by

el P i, Trus
oo Lasgie

Drawing > PlanView and Layout Tools > Location Boundary
Commandline: pw

Explanation

Define geometric boundaries for locations important to the design. For example we would want to
know where on the drawing the Machine Room is but not necessarily the kitchen (unless part of our
cable ends up in the kitchen).

Prerequisites
1.Source and destination Location Boundaries placed in the Plan View space.

Related Topics:
How To: Place a Location Boundary [+s8)

Operation

1.Start the tool.

2.Select a text entity with the name of the location to pre populate the dialog.
3.Set the location type and geometry type.

4.Draw the boundary

5.Done. Lather, rinse, repeat.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

Related Topics:
None

Dialog Options

eName - The location name. Either from the selected entity or entered directly or selected.
eLocation Kind - Select the level of the location that you are drawing a boundary for.
eAutomatically Nest Locations - Searches the drawing for containing boundaries and formats a
nested location string. The creates an entry in the Locations table if not found.

eBoundary Entity - Boundaries must be a closed polyline of some sort.

eShow Name in LineType - Creates a new LineType with the name of the location and renders
boundary entity with the new LineType.

5.2.3.3.3 Draw Backbone (ENT Only)

Navigation: Referencelz# > Dialogs[s} > Drawing Dialogs[= > Plan View and Layout Tools

Dialogs 4701 >
11 A Rackbons Segrent - - EE
Errisereit
e
o ew Bl Bachbeee I | 1001 2 | BO1OGL L Entigy Rradlabie:
Teom Cable Type LAE 2 To
Lacaition Piter £l e Ty Ol Locaton Fiter w
Padch Panel I | VTR0 QROCM 3307 |w | Paich Panel I VTR 0T @ACOM 130.7 |4
A phater ety Brvadabie thar by
Fame  Type  Com | FromTa [T Lo |FeomT
» BE oT
L ARG ' L)
ML | AE i
s ™ e R
CTERET. i
s - MDA D R
MONL MD s A-4000- o ] AU
ot G LT A1 3 vi & A
[ R
i1 ol ] [ [T ] R
..... o m ] -
TRECO | Wl
:
ET N [] 0503 Y e 108
. g
r Caarwd

Drawing > PlanView and Layout Tools > Draw Backbone
Commandline: none

Explanation

Backbones are collections of cable/fiber that are contained in a single jacket that run from one
location to another and are typically sized for growth. An example might be a fiber optic cable that
contains 288 fiber cores that runs from building A to building B. We know that initially we will not
use all 288 fibers and have planned for growth. As the facility needs change the usage of the
backbone's fibers change.
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WireCAD maintains backbones just like any multi-core cable with the exception that the Cables
table record is flagged IsBackBone = true.
WireCAD will create a cable record for every core in the Cable Type used.

Prerequisites
1.SysNames assigned to the panels/equipment to which you will attach the ends of the Backbone.
2.Multi-core Cable Type representative of the Backbone.

Operation

This tool allows you to draw geometry in the Plan View space that represents the path of the
Backbone. The process requires the following steps:

1.Draw the polyline that represents the backbone.

2.If locations boundaries are found in the drawing the source and destination locations will be used.
Otherwise you will be prompted to define a location for each end.

3.Next you will be presented with the New Backbone tool where you will select the source and
destination panels/ports and the cable type.

4 .Clicking [OK] will build a record in the Cables table for each core in the multi-core cable type.
5.The polyline length populate the cable record Length field.

Related Topics:
How To: Create a New Backbonelz1h

Dialog Options

eNew Backbone - Select whether we are creating a new number or assigning existing unused core.
eBackbone ID - The Backbone number. This will be formatted based on the Project Backbone
Format setting.

eUse Existing Available - Pick a Backbone that has available cores.

eLocation Filter - Filter the list by location if the list is long and noisy.

eFrom Panel Info, To Panel Info - Select the panel. The ports will be shown in the list.

eCable Type - Select the Cable Type.

5.2.3.3.4 Draw Cable

Navigation: Referencelz > Dialogs[s} > Drawing Dialogs/s5 > Plan View and Layout Tools
Dialogs 4701 >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

I New Cabie * IEN

Cable Type Manu | W Cabie Type w
Sourcs Informanon Destnanen Informaman
ol Sysname w |+ Dest Sys Sysname ¥ 4
RCAn - DestPn v
SR Lewr LisEater Dest Lo Lot
SAE Lo Dt Canet
L akas O5T kas

Irasiy ator Thest

Sgral Tyoe: | Lengi

L ] Uker

Userd Userd

Cable o

o Cancel

Drawing > PlanView and Layout Tools > Draw Backbone
Commandline: pwdc

Explanation

This tool allows you to draw a cable in Plan View space that is assigned to the Cables table.

Prerequisites
1.SysNamed source and destination equipment placed in the Plan View space or:
2.Source and destination Location Boundaries placed in the Plan View space.

Operation

This tool allows you to draw geometry in the Plan View space that represents the path of the cable.
The process requires the following steps:

1.Start the tool.

2.Select the source SysNamed equipment.

3.Select the destination SysNamed equipment.

4 Place the points in the polyline to finalize the appearance.

Related Topics:
Draw Cables| s31

Dialog Options

eCable No - Click the [...] button to generate a cable number.

5.2.3.3.5 Populate Cables

Navigation: Referencelzs > Dialogs[:} > Drawing Dialogs[=% > Plan View and Layout Tools
Dialogs 4701 >
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= 3

| Group cables from fto same location into & single ine
Must connect to existing equipment in the drawing
»| Ignore cables that come and go to the same location
~*| Flag if other end i not found
Polyline Bulge Factor 0.2 5

Drawing > PlanView and Layout Tools > Populate Cables
Commandline: popc

Explanation

This tool pulls the cables from the Cables table into the drawing. The assumption with this tool is
that you will use it after you have done your functional drawings and assigned cable numbers and
SysNames.

Prerequisites

1.SysNamed source and destination equipment placed in the Plan View space or:
2.Source and destination Location Boundaries placed in the Plan View space.
3.Cable data in the Cables table that matches the placed equipment or locations.

Operation
1.Start the tool.
2.Select options.

3.Click [OK] to run.

Related Topics:
How To: Populate Cables in Plan View/s%

Dialog Options

oGroup Cables - Collapse cables that go from the same source and destination SysName or
Location into a single polyline with hash marks to indicate how many cables are represented by the
one polyline.

eMust connect to equipment in the drawing - Only connect to plan view SysNamed equipment.
elgnore cables that come and go to the same location

oFlag if other is not found - Draw a pointer out to the un-found equipment.

ePolyline Bulge Factor - Non zero for arced cables.
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5.2.3.3.6 Draw Prewire

Navigation: Referencelzs% > Dialogs[:6 > Drawing Dialogs[5 > Plan View and Layout Tools
Dialogs|4701 >

5l Prewire Info + N

Prewive: cables works only il jou have  Catle Trmes -
aided boca e boundanes b pour plar

i drawing. 1F you hivg acided Sl Tvpe: w
Swildamarg yous can upe Sam s sl bt

e locatons are rot opbioral Hiewer Maarry?

=T
o
L Devpce:
Akd Path to Mamed Paths Tabie

Haie Maresd Path

o Carmel

Drawing > PlanView and Layout Tools > Draw Prewire Cable
Commandline: pw

Explanation

This tool allows you to draw geometry in the drawing that represents cables that have not yet had
their functions assigned. The only thing we know about these cables is the locations from which
they start and end and the Cable Type. A record will be added to the Cables table based on the
count defined. The record is marked Available and PreWIRE. Prewire cables can be automatically
consumed later if the Automatically Consume Prewire [se5) setting is checked.

Prerequisites
1.Source and destination Location Boundaries placed in the Plan View space.

Operation

1.Start the tool.
2.Fill in the form.
3.Draw the cable path.

Related Topics:
How To: Draw a Prewire Cable in PlanView/sh

Dialog Options

eCable Type - Select the Cable Type.
eSignal Type - Select the Signal Type.
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eHow Many - How many wires of this type take this path. A record will be created for each.
eLength Divisor - We will divide the length of the polyline by this value and place that info in the
Length field of the record. For example, say your Drawing Unit = 1 inch and you want the length in
the Length field to be displayed in feet. Your Length Divisor would be 12.

eCreate Named Path - Create an entry in the Named Paths table with the name provided and
length of the polyline.

5.2.3.3.7 Populate Equipment

Navigation: Referencelzs > Dialogs[:28 > Drawing Dialogs[5 > Plan View and Layout Tools
Dialogs| 401 >

There is no Ul for this function

Drawing > PlanView and Layout Tools > Populate Equipment
Commandline: pope

Explanation

This tool pulls the Plan View version of the equipment from the Equipment List. The assumption with
this tool is that you will use it after you have done your functional drawings and assigned cable
numbers and SysNames.

This tool relies on the Plan View File in the device definition to know what to place.

sz Ture [ ——
Aok s

It relies on Location Boundaries in the drawing to know where to place it.

Jo e e T — N enree !

! , RACKS
| ——1—1
| |
| MACHINE ROOM
= | | 110
DULING | i« | | _

08 PANELS,
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If the Plan View File is blank the Project Default Plan View File will be placed if the Location
Boundary is found:
Application Menu > Settings [Project][Basic][Default Plan View Block File]

Default Plan View Block Fie: WELOCHS % Plan View \equipment12x 12.dwg

Prerequisites

1.SysNamed equipment preferably with an associated Plan View File in the global Equipment
Library.

2.Location Boundaries placed in the drawing.

Operation
1.Start the tool.
2.A message box will explain the operation of the function. Click [OK]. The tool will run.

3.At completion the tool will report the number of placed items.

Related Topics:
None

5.2.4 Data Dialogs

Navigation: Referencelzs > Dialogs sz >

The following is a collection of dialogs that may be presented while in the Data or Grid environment.
5.2.4.1 New Location

Navigation: Referencelzs > Dialogs!s2 > Data Dialogs |+ >

Bl Add Location(s) + IEN
CATOU v Conk

B w | Coad

Flatr W | Cowrl

LE. v Courl

Rk Coark

Cresriprban

Qualified Location
CGranlifiod Locaton L Canoed

Database > Locations [New]
Commandline: none

Explanation

This tool is used to create entries in the project Locations look-up table.
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Prerequisites
1.None

Operation

1.Start the tool.

2.Enter the data in the fields as desired.

3.Verify the Qualified Location looks acceptable (its the part that the rest of WireCAD uses).
4.Click [Add].

Related Topics:

Locations Look-up table[sh
Locations form reference s
Defining Locations [ oh

Dialog Options

eCampus - Enter the Campus name if applicable. If there are multiple numbered campuses you
can increment the Count field to append a number and create multiple records for each.

eBuilding - Enter the Building name if applicable. If there are multiple numbered buildings you can
increment the Count field to append a number and create multiple records for each.

eFloor - Enter the Floor name if applicable. If there are multiple numbered Floors you can
increment the Count field to append a number and create multiple records for each.

eRoom - Enter the Room name if applicable. If there are multiple numbered Rooms you can
increment the Count field to append a number and create multiple records for each.

eRack - Enter the Rack name if applicable. If there are multiple numbered Racks you can
increment the Count field to append a number and create multiple records for each.

*Qualified Location - This is the important part. The Qualified Location is a concatenation of all
the used fields. The fields are merely and organizational construct for you. WireCAD will use the
Qualified Location throughout the application.

Example

In the following example we will add two locations using different approaches to achieve the same
result.
eEnter the data across all fields:
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&l Add Location(s) : IEE
Campus LA w | Count 1B
Buldng | THE FACTORY » | Count 1|5
Floor MATM v | Count i
Room MR « | Count 1|
Rack pkc-10] Courit 11
Descriptan

Qualified Location
LA.THE FACTORY  MAIN, MR RK-10 Add Camcel

eEnter the data in a single field:

&l Add Location(s) 7 IEN
Campus LA ¥ | Counk 1 :
Building THE FACTORY w | Count 15
Floor MAIN w | Count il
Room MR v | Count 1=
Rack Ri-10] Count 1
Desoription
Qualified Location
LA THE FACTORY.MAIN, MR RE-10 Add Cancel

As you can see from the above examples the Qualified Location is the same for both. It does not
matter which approach you take.

5.2.4.2 New Cable

Navigation: Referencelzs8 > Dialogs/:2% > Data Dialogs| " >
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¥ Hew Cable + IEE

Cabls Type Mars | W | Cable Type W
Seuree Information Destintion Information
ERE Sys Sysname w 4 Dest S5 Sysname 4
SREC PN w Dest Pin w
SRE Lac Lacaton Dest Lo LA
SRL Conn Dest Corn
SR Alas DST Alas

Integrator Sheet

Signal Type » | Length

Lser 1 Liser2

Liger3 Liseerd

Cable Mo

[+ 4 Cancel

Database > Cables
Commandline: cg

Explanation

This tool allows you to manually create a Cable in the Cables table.

Prerequisites
1.SysNamed source and destination equipment in the Equipment List.

Operation

1.Start the tool.

2.Select the source SysNamed equipment.

3.Select the destination SysNamed equipment.

4 Click the [...] button on the Cable No field to generate a Cable Number.

Dialog Options

eCable Type

eSource Information - Set the source info.

eDestination Information - Set the destination info.

eCable No - Click the [...] button to generate a cable number.

5.2.4.3 Save Cable Type As

Navigation: Referencelzs > Dialogs!s2 > Data Dialogs |+ >
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il save 1828A As: z IER

PR v
New Cable Type | 18284
Ok Cancel

Database > Cable Type - File > Save As
Commandline: showcabletypesgrid

Explanation

Create another entry in the CableTypes database record by copying the source record into a new
destination record with a new Manufacturer and Cable Type.
Controls

eManufacturer - Select a Manufacturer.
eNew Cable Type - Name the new Cable Type.

5.2.4.4 New Manufacturer

Navigation: Referencelzs > Dialogs!s2 > Data Dialogs |+ >

Add Manufacturer T X

Wanfa: tur érhlame |
ManufactureriD

DetsplayInEquipment [ ]
DisplayInCableTypes [ ]
ManfachurerWebdGite

Manufacturerimage kg image data

Database > Manufacturers [File > New]
Commandline: none

Explanation
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This tool allows you to create a new Manufacturer in the Global Equipment database.

Dialog Options

eManufacturer Name

eManufacturerID - Should match the Manufacturer Name field.

eDisplaylnEquipment - Show this Manufacturer in the Equipment Library.
eDisplaylnCableTypes - Show this Manufacturer in the Cable Types grid.

eWebsite

eImage - Right-click and select Load from the context menu to add a Manufacturer logo.

5.2.4.5 New Equipment Wizard
Navigation: Referencel2s% > Dialogs/+% > Data Dialogs|+" >

&1 new Equipment i = |
Mew Equipment
Who Makes It and What's it Called
Marufacturer ™ W |
EquepmenSiame Model Part bumbes ®

Desaripton™
Syehinme Profic®

= = Regured

Mt > Cancel

Database > Equipment [File > New]
Commandline: none

Explanation

This tool allows you to create a new Equipment definition in the Global Equipment database.

Related Topics:
How to Add Equipment/ e

Dialog Options
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eManufacturer - Select the Manufacturer. Clicking the [...] button opens the New Manufacturer |«
dialog.

sEquipmentName/Model/Part Number - Name it.

eDescription - Describe it.

eSysName Prefix - Be brief.

eFront Panel File - Pointer to the front panel file. Must reside in the %BLOCKS% support path.
ePlan View File - Pointer to the Plan View file. Must reside in the %BLOCKS% support path.
eImage - Right-click and select Load from the context menu to add a image.

esCategories, Synonyms - This is for you. Create categories and synonyms.

eAbbreviation, Accessory Of - Not really used yet.

5.2.4.6 New Cable Type

Navigation: Referencelze > Dialogs |2 > Data Dialogs|+h >

0|8

R = -

Myrulsoune 0 w | Cobies Type oF P

Descrpiion

Cable Char T Cables 00 =
Caie A bl Bty bl
Cable Vepghtt v | SRandard Lengsh

CoreCanducter Configuraton

Shaidirg w | loulE Care
Cordarter Court Bncksing Sackdis)
Defaui Cove Fiber Made: w

Cilor Cade Apgles Ta;

o inns A

Database > Cable Types [File > New]
Commandline: showcabletypesgrid

Explanation

This tool adds a new Cable Type to the Global Equipment database. Cable Types may be either
single or multi-core and have different shielding configurations. WireCAD projects use the multi-
core core color code if any as the descriptor when identifying multi-core cables. The Cable Type
Name and Manufacturer are used in the Cable record. All other fields are maintained for reference
of the designing engineer.

More About Multi-core Cable Types
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WireCAD can create multi-core cable types at two different levels of detail:
eCore level.
eConductor level.

Cores have conductors. Conductors being the base unit. Most people using WireCAD will not
document down to the conductor level but rather the Core level.

8

Prerequisites
1.None

Related Topics:
Create a New Cable Typel ¢

Dialog Options

eSave

eManufacturelD - Select a manufacturer. Only Manufacturers that are flagged as
DisplaylnCabletypes appear in this list.

eCable Type or P/N - The name by which this cable type shall be known.

eDescription - A description for posterity.

eCable Char Z - Characteristic Impedance.

eCable OD - Outside Diameter.

eCable Gauge - Gauge.

eCable Rating - Rating.

eCable Weight, Standard Length - Standard put up length and weight.

Core/Conductor Configuration

eShielding - Shielding determines how many conductors.

¢ Is Multi-core - Flag this Cable Type as multi-core.

eCore Count - How many cores.

eConductors per Core - Usually one.

eConductor Count Including Shield(s) - Set automatically based on the core/conductor counts
and the Shielding configuration.

eDefault Core/Fiber Mode - SM/MM.

oeColor Code Applies To - Apply a color code to the conductors, cores or not.

5.2.4.7 Synchronize Global Databases

Navigation: Reference[2e > Dialogs ! > Data Dialogs|+h >

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

¥ sync Equipment Databases T IEN
fymehrorae st an eetrrnal eguprmen! databone

Basic | Advanced

Current Global Database: (VIsTAmm)
Remobe database type and location

+ Cliabase 5 perver bases

Het: Authentication
Cataloge W el ADGoOSE QUDmETt L Wiretd Atherbeaten
Tiest Connechon L Panme:
Fasgerd:
» Import Enpiwt Bichr e bional
w Remember Settngs e Cangel

Database > Sync Global Database ..
Commandline: sync

Explanation

This tool allows you to sync two Global Databases. The current Global Database will be
synchronized with the database you select in this dialog. The local and remote database may be
either SQL Server of VISTADB. You may import, export or sync with respect to the current Global
Database. An Import would collect data from the remote database and import it to the local Global
Database.

Prerequisites
1.Two Global Databases. The currently active one and a remote one.

Related Topics:
Sync Basics [+eh

Dialog Options

esExternal Database Location

eDatabase is Server Based - Enter the host information and login. Otherwise browse to the
location of the WireCADGIobalEquipment.vdb3 file.

eImport - With respect to the current Global Database. This would import data into the current
Global Database.

eExport - With respect to the current Global Database. This would export data into the external
Global Database.

eBidirectional - Sync the two.

Advanced Settings
eWhich collections to include - By default you would want to sync all collections.
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5.2.4.8 Combine Circuits (CMS Only)

Navigation: Referencelze > Dialogs |26 > Data Dialogs|+h >

Menu: Database > Circuits

Default command line shortcut: cmscg
Related Project Settings:

Circuit Status Items

Product Level: CMS

Click Tools > Combine Circuits.

WireCAD CMS tools support the concept of combining circuits. Circuits to be combined must have
the same Strand Count. The Circuit Name/Number of the Circuit that is being appended or inserted
will be discarded.

L, s T o
This Crous iy
4 33 Strandl Comink: 4 - FIBER CIROUET
& Aopmren to e
::-' -:-1:—.“-. Coanks 4 - FIER CIROMT

oThis Circuit - The Circuit Name/Number of the circuit that will be appended or inserted into
another circuit. This circuit Name/Number will be discarded if successfully appended or inserted.
eAppends To - The Circuit Name/Number of the circuit that will be appended to.

eInserts Into - The Circuit Name/Number of the circuit that will be inserted into.

eBefore - Before this SysName.

eAfter - After this SysName.

eInsert Jumpers if Necessary - It is possible to create collections of cables in a circuit that do not
interconnect. If you do not select this option you will create collection of cables that do not
interconnect.

ePreview
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¥ Combine Crouts + EEE
L sbbamie, atesl e
This Crout 010 -

Dirouts 0010 Skand Counts 4 - FIBER CIROUTT

# Aoperes (L3 w
Circuit: 0L Strerd Counts 4 - FIBER CIRCUIT

Ik

T = —— g — g —— e — W —— W —— G ——
L P B T T e T I e e G S :.]

Fa e}
=

5.2.4.9 Expression Builder

Navigation: Referencelz: > Dialogs |2 > Data Dialogs| " >

! T EEX
Expresson | Test Object

Fromtypen
Exptie

(1=1) them set propertyMame = value else propertyMame = otherValue

Ay i Tt e L

Coruirsl Ewndy

e plev s
Pankdl LinZ

Database > Any
Commandline: varies

Explanation

This tool allows you to manipulate data using the Expression Engine.
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For more information on Expression Syntax]zoh.

Expression Tab

ePrototypes - Select from a number of pre-formatted expressions. Then replace the variables as
appropriate.

esExpression - Enter your expression to evaluate here.

¢[Clear] - Clears the Expression.

o[Apply to Test Object] - A prototype collection object is loaded into the property window of the
Test Object tab. Clicking this button applies the Expression to the test object data. You will want
to edit the Test Object data before executing this command so that you have a meaningful test.
eLeft List - Variables, operators and fields to apply to the expression.

eRight List - Detail variables, operators and fields. Double-clicking a item here will insert it into the
Expression window at the caret.

¢[OK] - Do it to the data in the grid.

Test Object Tab

eProperty Window - Displays a prototype of the grid collection item. Edit this to have test data on
which to apply your Expression when the [Apply to Test Object] button is clicked.

5.2.4.10 Find and Replace

Navigation: Referencelzs8 > Dialogs 26 > Data Dialogs| " >

% : IEN

Find and Replace

Find and Replace tool will searchs the current selection (if any).

Find:
Find Options Contains v | |w| Ignore Read Only Columns
Replace With:
Find Mext Cancel
Database > Any

Commandline: varies

Explanation

This tool allows you to find and replace string within the open grid.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

Searches the current selection if any. If not, searches the whole grid.

Related Topics:
Grid Basics| «1

Controls

eFind - Search Text.

eFind Options -

Contains - Any or whole Find string exists.

MatchCase - Any or whole Find string matches case sensitive.

Exact - Whole string matches exactly.

elgnore Read Only Columns - Searches only columns that can be edited.
eReplace With - Replace the found part with this.

eFind - Search and highlight the first found instance.

eReplace - Do the replace the found instance.

eFind and Replace All - Do it to all found instances.

5.2.4.11 New Next Number

Navigation: Referencelzs > Dialogs /% > Data Dialogs| 4" >

%l Now Next Number 2 n

Sequence Key || bt Numbser 1| o | Context al v

Database > Next Numbers - File > New
Commandline: nn

Explanation

Add a new Next Number item. Next Numbers are normally added automatically but if you need to
take control and add your own.
Next Numbers use a Sequence Key and an integer within a context.

Example

Say our cable number is V-1001. V is the Sequence Key and 1001 is the integer Next Number in
the Context of Cables.

or:

Our SysName is SRVR-101. SRVR becomes the Sequence Key and 101 the Next Number in the
Context of SysNames.

Related Topics:

Grid Basics| +
Next Numbers[+H
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Controls

eSequence Key - What is the part we are sequencing on.
eNext Number - Integer next number.

eContext -

All

Backbones

Circuits

Cables

SysNames

5.2.4.12 Attach Document

Navigation: Referencelzs8 > Dialogs 26 > Data Dialogs| " >

&l Attach Document i x|
Eile |
Descriobion
oK | Cancel

Database > Most
Commandline: varies

Explanation

Many of the grids in WireCAD support Attached Documents. The document can be of any file type.
The document is stored in the database as a Binary Large Object (BLOB). Attached document can

be launched from the grid by clicking the hyperlink. The document will be opened by the system
reader of the stored file type.

rBaser | LocaTon Bevation  MSTCAM 1. BLACKMAGIC TERFAEN
Dooumernits Cﬂlﬁ:bﬁﬂ_
Qe Mo Desoripbon DocLamsertSise CreatedBy CreatedOn Mz et in
o —— Some Descriptive Text 112 KE chis_000 12 16/2016 1262016
M AFRY e B Flaca®me AT AN R ASVRMALE TROO ALEY

Related Topics:
Grid Basics| 1
Next Numbers [ 8

Controls
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sFile - Browse to the file to attach by clicking the [...] button.
eDescription - More words.
5.2.4.13 Database Host Settings

Navigation: Referencels > Dialogs!s2 > Data Dialogs| s >
H Database Host Login Info T X

We cannot reach the project database
Database server responded with: Cannot open database ™ "requested by the

login. The login failed,
g;; Login failed for user B

Basic | Advanced

These are settinas that routinelv chanoe when a database is miorated

Host Mame
D IUze Windows Security
User Mame

Password

Test Connection Ok Cancel

Project > Open Project Fails
Commandline: op

Explanation

The only reason you will see this dialog is that you have attempted to open a SQL project where the
database server is unreachable or has actively refused our connection.
Here you have a chance to fix Host and User login Info.

Basic Info [TAB]

Host Name - The fully qualified path to your SQL Server. In some cases your configuration will
require you to append the instance name. This can be something like: MyHost\SQLExpress where
MyHost is the host name and SQLExpress is the instance.
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Use Windows Security - Sets whether you will connect with Windows Security. Doing so disables
the User Name and Password fields as Window takes over.

UserName - Determined by the database administrator and should have been provided to you.
Password - Determined by the database administrator and should have been provided to you.

If you are the database administrator you will need to create a Login and map that login to the

various databases.
It is beyond the scope of this manual to discuss database administration.

Advanced Info [TAB]
H Database Host Login Info T X

We cannot reach the project database
Database server responded with: Cannot open database Tl oool 11" requested by the

login. The login failed.
gjp Login failed for user ©7 7 i i

........................

Basic | Advanced:

These setting rarelv chanoe and should onlv be edited if vou are sure this is the orooertv that has chanoed

Database Mame

Schema Mame (may not be required by your host) I

Test Connection oK Cancel

Database Name - This is the name of the database to which you are connecting on the server. If
you are using a cloud service it may be the same for all your projects. Normally it is the project
name with spaces replaced by underscores.

Schema Name - This is normally empty or dbo. If you are using a cloud service like Azure SQL it

will be the project name with spaces replaced by underscores.

¢[Test Connection] - make sure that this returns that you can successfully connect to the
database before clicking [OK].

Related Topics:
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5.2.4.14 Filter Editor

Navigation: Referencel[2# > Dialogs ! > Data Dialogs|+h >

Fiter Equipment

el D
[Akges] Bebgeek vtk (]

Apply Cancel

Various
Commandline: none

Explanation

The filter editor allows you to create filter criteria base on the collection fields combined with a
logical operator and a value.

Click the [+] button to add another complex condition.

Related Topic

BOM Generator/ssh
AutoBlock [ 12h)

How To: Filter Reports [

5.2.4.15 New Todo

Navigation: Reference[2# > Dialogs[} > Data Dialogs|+h >
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&l New Todo List Ttem * IEE

Them |

Desaription

Assigned To 5.t
Pricaity L
Status W
Expected Completion Date b
Completed Date L

Ok Cancel

Database > Project > Todo - File > New
Database > Project > Equipment List - Todo
Database > Project > Cables - Todo
Database > Project > Drawings - Todo
Commandline: varies

Explanation

Create a new Todo List item. When launched from the following grids it will associate the Todo List
item with the selected record(s):

eEquipment List.

eCables.

eDrawings.

Related Topics:
Todo List[ssh Settings
Todo List Grid|ssh
Grid Basics|

Controls

eltem - Words.

eDescription - More words.

eAssigned To - Who is to do it.

ePriority - Set the urgency.

eStatus - Where are we at in the process.

eExpected Completion Date - When are we expecting this done by.
eCompleted Date - When did we get it done.

You can see the Todo List items in the Todo List grid and in the associated grids:
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Syeae s Avalable [y Bewptas Adas Ml Epspetriiase Pl Syeamoilhe’ |

» B 11EREPE fp i IRORAEEM S SYSTEMS e S P

ExpecindCo . Completediote St Ermaedity Ereatotn Mooty ecdifendCn
b |Dodteeting |Dofometrg Fredfiea = - LN - - = dhri 000 0RO = dvn 000 e -
11:0080 P v it e She i i NP | WS SYSTRES Bt Somranr R Teps

5.2.4.16 Ripple Choice

Navigation: Referencels > Dialogs|s2 > Data Dialogs| s >

You bawe made changes that Bely impadt other demsngn and distaboses, WireCAD can now rpple the changes scoas
B drarig 1ot and allfected databsanies.

Full Bipple, Soad chvick 58 O pwirsyi. Thes b W safesl bul Lokbirk reird besd

o Bl . ot s e ey W e B i - e ) ety il "Bt Pl B e e b e i, e B
Ex-arches durcien o e Eoumend: s Cabien grels

# puck Figppla. Searchan onby Su irdbmed drawenga tor asch e

i o2 ] Pl ol ey g ] 0 P Tl [ 4] W ] e o i

Post Save - Rackbuilder Drawings, Equipment List, Cables table, Locations table
Commandline: varies

Explanation

Something has changed that potentially effects data in other drawings and databases. This is your
chance to update those other entities in other places.

Controls

oFull Ripple - Search all drawings for the changed items and update.

*Quick Ripple - Search only indexed drawings. If the indexes are up to date this can significantly
reduce ripple time.

oYes - Do it!

eNo - Don't Do It!

eCancel - Do nothing.

Related Topics:
Save and Ripple[+

5.2.4.17 Add/Edit Via (CMS Only)

Navigation: Reference[2# > Dialogs[s > Data Dialogs|+h >
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&l Adding vias to 5 cable(s) ?

Idx

Name
Description
Type

Location w |+  Elevaton

0K Cancel

Database > Backbones then Tools > New Via
Commandline: none

Explanation

WireCAD ENT supports the concept of VIAS. Vias are waypoints or appearances of Backbones as
they make their way from starting point to ending point. VIAS can be used to list all of the pullboxes
or manholes that a backbone appears in. They can also be used to indicate splice points.

VIAS are an ordered list that is attached to the Backbone. The Idx field determines list order.

m TR T4 FTRAND 3™ FIER Pt 0} P ACME- G =] (=] A AT BMLI LD 53 RO ) A
8 R 24 STRANKGI T FIRER e o LR MoM1E M [F] BluainE AMBUDG D11 RO B4 wA
Wad Coller o By P Cables
5 & famt e g T Lt SN [ Lol
T
1] A MY B
BRI MARHOLE 2
m [r il i T4 STRAND 3 FINER POCOES. 00 L B OG- 16 TS [orrl AR MU LD 337 ROOM S0 A

VIAS can be shown in the the following visualizations:

g 1) el

s AMBAMTCRLE 1

AIA AL MANHOLE |

(=4 ]

VIAS shown in the Circuits visualizer
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VIAS shown in the Riser visualization

-

Backbone from panel to panel Via Manhole 1 and Manhole 2

Prerequisites
1.At least one Backbone in the database.

Related Topics:
New Backbones|zh
Backbones Visualization Settings[z15
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Circuits Visualization Settings|2:0)
Backbone Display/s:%1in Calibrated Drawing

Dialog Options

All of the following are optional except the ldx field.
eldx - the position in the list of VIAS.

eName - Optional name of the VIA.

eDescription - Optional description of the VIA.
eType - Optional type of the VIA.

eLocation - Optional location of the VIA.
eElevation - Optional elevation of the VIA.

ePorts - Optional ports of the VIA.

5.2.4.18 New Blind Patch

Navigation: Referencelzs8 > Dialogs /2% > Data Dialogs| " >

xl

® Named Equipment (Syshame) W

Customer Furnished Equipment (CFE)

O Cancel

File > New from the Blind Patches Tool
Commandline: none

Explanation

Used to select the FromSys value in the Blind Patches tool. Select either a named piece of
equipment or create a new CFE piece of equipment with a Manufacturer and Model name.

NOTE: CFE equipment will not appear in the Equipment List.

Prerequisites

1.At least two Backbones in the database.

2.You must first select a ToSys from the dropdown.

3.Select the row to add a Blind Patch to or if Duplex Jumper is selected click the top row.

Related Topics:

Blind Patch Tool Explanation [2281

How To: Create a Blind Patch/22h

How To: Discover Circuits from Blind Patches[22h
How To: Make a Real Circuit from Blind Patches 225
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Blind Patch form

5.2.4.19 Titleblock Manager

X1 Project Title Block Manager " -] a]x
Titleblock Manager

Cow B @ &b & H

Remove Rename SaveBlock As | Edit Company Edit Client | AllManual AllOn Update Active
Blodk Info Info Open Drawing Mow

=]

o

Page Borders Attributes
fwcD Tag String Attribute Value String Constant Update Mode
» BIG_TITLE UseStringConstant MEWS PCR 2022 OnDrawingCpen =

Scale UseStringConstant NTS OnDrawingOpen
DATE S UseStringConstant OnDrawingOpen
ISSUED 5 UseStringConstant OnDrawingOpen
5 UseStringConstant OnDrawingOpen

% DATE 4 UseStringConstant OnDrawingCpen
ISSUED 4 UseStringConstant OnDrawingCpen
4 UseStringConstant OnDrawingOpen
DATE 3 UseStringConstant OnDrawingOpen
ISSUED 3 UseStringConstant OnDrawingOpen
3 UseStringConstant OnDrawingOpen
DATE 2 UseStringConstant OnDrawingCpen
ISSUED 2 UseStringConstant OnDrawingOpen
2 UseStringConstant OnDrawingOpen
DATE 1 UseStringConstant 03/22 OnDrawingOpen
ISSUED 1 UseStringConstant IMIT OnDrawingOpen
1 UseStringConstant 1] OnDrawingCpen
Checked By: UseStringConstant CEH OnDrawingOpen
Drawn By: UseStringConstant BLW OnDrawingOpen
Sheet Mone SHEET OnDrawingOpen
Drawing # DrawingFileMame OnDrawingOpen
REW LspStrinaConstant n OnDrawinaCinen -
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Explanation
The Titleblock Manager tool associates the attributes of a titleblock with variables or string
constants.

Menu Items

[Add] - Add a titleblock to the list of Page Border blocks.

[Remove] - Remove the selected block from the list of Page Border blocks.

[Rename Block] - Rename the selected block in the list of Page Border blocks.

[Save Block As] - Create a copy of the selected block with a new name in the list of Page Border
blocks.

[Edit Company Info] - Open the Company Infolssh settings panel.

[Edit Client Info] - Open the Account Info[s:b dialog.

[All Manual] - Set the Update Mode for all attributes to Manual mode. In Manual mode the
titleblock is only updated when you open the TitleBlock Manager dialog and click the [Update
Active Drawing Now] button.

[All on Open] - Set the Update Mode for all attributes to OnDrawingOpen mode. In
OnDrawingOpen mode the attributes that are flagged as OnDrawingOpen will be updated when
the drawing is opened.

[Update Active Drawing Now] - Do it!

Variables

Most of these are self explanatory. Those that are not will be defined.

None - Do nothing

ProjectName

ProjectDescription

ProjectLeadPerson

ProjectInfoUserl - Userl field from the Application Menu>Project Info form.
ProjectInfoUser2 - User2 field from the Application Menu>Project Info form.
ProjectInfoUser3 - User3 field from the Application Menu>Project Info form.
ProjectInfoUser4 - User4 field from the Application Menu>Project Info form.
ProjectPath

ProjectCreationDate

ProjectModifiedDate

CurrentProjectRevision

See this fggmﬂih.

DrawingName

DrawingFileName - file name with extension.
DrawingFileNameAndPath

DrawinglLayoutName - the layout where the Page Border lives.
DrawingCreationDate

DrawingModifiedDate

DrawingUserl - Userl from the Drawings table.
DrawingUser2

DrawingUser3

DrawingUser4

DrawingUser5

DrawingUser6

DrawingUser?7

DrawingUsers8

DrawingUser9

e DrawingUserle
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DrawingUseril

DrawingUserl2

DrawingShort - the Short description from the Drawings table.
Drawinglong - the Long description from the Drawings table.
DrawingFSCM

DrawingNumber

Date and Time

DateTimeNow - The current date and time as right now.
DateShort - The short date as of now.
DateLong - The long date as of now.

Environment

UserName - The environment User Name.

Strings

UseStringConstant - Use the data from the String Constant field.

See this settings Qanelﬂg5.

CompanyName - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyAddressl - Addressl from the Application Settings[Application]>Organization
settings panel.

CompanyAddress2 - Address2 from the Application Settings[Application]>Organization
settings panel.

CompanyCity - City from the Application Settings[Application]>Organization settings panel.
CompanyState - State from the Application Settings[Application]>Organization settings
panel.

CompanyPostalCode - Zipcode from the Application Settings[Application]>Organization
settings panel.

CompanyPhone - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyWebsite - Company Name from the Application Settings[Application]>Organization
settings panel.

CompanyCountry - Company Name from the Application Settings[Application]>Organization
settings panel.

See this dialogls.

ClientAccountName - Account Name from the Application Menu>Account Info dialog.
ClientContactName - Contact Name from the Application Menu>Account Info dialog.
ClientAddressl - Addressl from the Application Menu>Account Info dialog.
ClientAddress2 - Address2 from the Application Menu>Account Info dialog.
ClientCity - City from the Application Menu>Account Info dialog.

ClientState - State from the Application Menu>Account Info dialog.
ClientPostalCode - Zipcode from the Application Menu>Account Info dialog.
ClientPhone - Phone from the Application Menu>Account Info dialog.

ClientFax - Fax from the Application Menu>Account Info dialog.

ClientWebsite - Website from the Application Menu>Account Info dialog.
ClientEmail - Email from the Application Menu>Account Info dialog.
ClientInfoUserl - Userl from the Application Menu>Account Info dialog.
ClientInfoUser2 - User2 from the Application Menu>Account Info dialog.
ClientInfoUser3 - User3 from the Application Menu>Account Info dialog.
ClientInfoUserd4 - User4 from the Application Menu>Account Info dialog.

5.2.5 Report Dialogs

Navigation: Referencelz:% > Dialogs sz >
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Dialogs associated with report designer.
5.2.5.1 New Report Wizard

Navigation: Referencel[2# > Dialogs |2 > Report Dialogs| s >

Welcome to the Reports Wizard

This veizard il create & reter report with dats-heund contnols
| o display informaition from the dataset you spexify.
e
-

= Ok Nt b5 conEruaE

Beport Type
Starcard Report

® Ll Rt

Cancel Neat »

Reports > New with Wizard ...
Commandline: rw

Explanation

Create a new report using the New Report Wizard.

NOTE: We recommend that you find an existing report that is close to what you are looking for and
modify that after saving it with your name. It will save you time and effort.

Prerequisites
1.0pen Project

Operation

1.Start the tool.

2.Step through the wizard

3.Finish the wizard.

4 Edit the report in the designer to finalize it.

Related Topics:
Creating Reports/ 75

5.2.5.2 Scan for Discrepancies

Navigation: Referencelzs > Dialogs /s > Report Dialogs| s >

See the section on Index Grids[sh
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5.2.5.3 Report Manifest Editor

Navigation: Referencelzs > Dialogs |26 > Report Dialogs| s >

MirkPeraes M Wes  RepoiDesgre et Dot Seiecio

TR0 Opmiarnl e, Manfest Creator + IEl

L reraot
Eapert Mt s ool Credar one e repert. Ta be ¢fTecmer vouw el reted ned
far b - o el 1 BT el e L g L 105 Thaees Canelaes e i e vinr
gt e e el St e F e dam Folder il e 1o
B e I
Cagbon

Pasatn Info from -

1 rit
SR mianifest
T e
g file =
g Fosier
=, - L
Gomall b g -
W M Cables VDM _Cables .
Lt By ierie 5
Imstalation Reporty
e Lmage o ko b bt et Gt £ t5vm £ 0P S ki
¥Ear Sheet Lix17
. e

L e || Saew | Camco

Report > Smart Tag
Commandline: none

Explanation

If your Report Show Mode = Gallery the gallery items will display:
ePreview bitmap.

eLarge bitmap when hovering over the gallery item.

eCaption text.

eDescriptive text.

eTooltip text.

When the gallery loads it searches for a manifest file with the same name as the report file.
Example:

MyReport.repx - report file.

MyReport.xml - manifest file.

Make sure that the manifest file name matches the report name and that they are in the same
directory.

If the manifest file does not exist the stock bitmap is shown and the file name is used as a caption.
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Prerequisites
A custom report.

Related Topics:
Report Show Mode = Gallery[ssh

oFile Name - the name of the report repx file.

eCaption - gallery item caption.

eDescription - gallery item description.

eTooltip - text when hovering over the gallery item.

eSmall Image -

eLarge Image - displayed when the gallery is expanded and the item is hovered.

o e i i i T T i
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——
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5.2.6  Plugins Dialogs

Navigation: Referencel2s > Dialogss26 >

The following sections relate to plugins that register dialogs for editing. These are plugins included
with WireCAD. Other plugins may register dialogs that do not appear here.

5.2.6.1 Plugin Manager

Navigation: Referencel2# > Dialogs [+ > Plugins Dialogs =% >
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Bl Pugin Marager T
. R Loaded Plugne (thepe plagine have ol regeteresd ot least ore button on the qull: Load
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[t

Plugins>Plugin Manager
Commandline: pim

Explanation

The WireCAD Plugin Manager shows:
el 0aded plugins.

eUnloaded plugins.

eAutomatically Discovered plugins.
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B Pugin Manager * IEN
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Only Enabled plugins are eligible to load/unload. Disabled plugins will not show here.

WireCAD Plugin Types

WireCAD has facility for two types of plugin:

1.Auto-discovered plugins. These plugins register themselves on application startup. They may or
may not include a graphical user interface element.

2.Registered plugins. These plugins register themselves via a plugin manifest file located in the C:
\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins\*.wpi. Registered plugins may
place a button somewhere in the WireCAD workspace, register a corresponding Commandline
shortcut, and may respond to WireCAD events.

Related Topics:

Included Plugins [+

WireCAD Software Development Kit (SDK)[ s/
Enable/Disable Plugins 5

Dialog Options

eLoad - Loads the selected plugin from the Unloaded Plugins grid. This function does not apply to
the Automatically Discovered plugins.

eUnload - Unloads the selected plugin from the Loaded Plugins grid. This function does not apply
to the Automatically Discovered plugins.

eRescan and Reload All - Unloads then rescans and reloads all plugins. Applies to all plugins.

Plugin Creation

eAdd/Edit Pl info (*.wpi) - Show the Add or Edit Plugins dialog to work with WireCAD Plugin
Info files (wpi).
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oEdit Plugin Code - Open your IDE to edit code. You will be prompted to enter a path to the IDE
exe file.

5.2.6.2 Script Editor/Runner

Navigation: Referencel2s > Dialogs s > Plugins Dialogs s >

® .
Fite Edt  Forest 9
J & 38 N W oW Window on Tep . w

Explanation
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Often times there are operations that you find yourself repeating some thing or process endlessly.
Scripts are a good way to automate those processes. There are many example scripts to browse
through and see how they work. Example scripts can be found at:
c:\users\public\documents\WireCAD\WireCAD9\scripts\*.cs

NOTE: Scripts that run in WireCAD MUST have the following method signature or they will not
execute:

using System;

using System.Data;

using System.Text;

using System.Windows.Forms;

using System.Diagnostics;

using System.Reflection;

using WireCAD;

using WireCAD.Interfaces;

//You may add additional using statements as needed but the listed ones are the minimum.

public class Script
{

public static void Run (Workspace ws)

{
//do your stuff here

Possible Uses

1.Title block filling.
2.New Drawing creation.
3.Database cleanup.

Usages
1.Launch the tool.
2.File>Open an example script. (c:\users\public\documents\WireCAD\WireCADX\Scripts\).
3.Read the comments (they are the ones proceeded by //).
4.Tweak the script to suit your needs.
5.Run it by clicking the [RUN] button
B‘ -

6.Fix any compiler errors. Lather, rinse, repeat.

Dialog Options

eNew - Creates a new script with the necessary method signature.

eOpen - Opens a .cs file to run.

eComment - Comment out your selection. Useful for hiding code from the compiler without deleting
it.

eUn Comment - Un comment your selection.

eIndent, Out dent
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eRun - If the Error List is empty then Do It. If it fails it will tell you why in the Compiler Output
window.

"

eWindow On Top - Make this the topmost window always.
oError List - Design time scripting syntax errors.
eCompiler Output - Run time compiler and script execution errors, as well as Trace messages.

5.2.7 PDF Viewer Dialogs

Navigation: Referencel2s > Dialogsse6 >

The following is dialogs associated with PDF Viewer.
5.2.7.1 PDF Print Preview
Navigation: Referencel[2# > Dialogs[s} > PDF Viewer Dialogs|[s:H >

[ (Proter Mame: MACHINE ROOM pdn) *
Fliot Margins
'i: =m C' inches
Top-  |1008D Bomtom 10060 |

Lek:  [00000 | mgn (D000 |
UpsdeDown | | Conter To Pager
Dvicral akiesrs
) Potrat  (8) Landscape
Wurberdl Copies: 1 |3

FPaper

22 !:ia:

L

EA Custom (89,516 H4 97| mm

]
Periar Lins: 1 ]

Drawing Unks: 05537179
B Scaleta it
Dripmd Options
[ Back and Whie ||| Por Assigrment
[ Goeyucae [ A bt

Frirg Arma
(W) Berts ) Window |y Pk

Prevrm (il sons Saye bo file =
O Patid @Rl Lpdate B [roF_ -] ESsebi S

Project Explorer > Double-click PDF File [Print]
Commandline: None

Explanation
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This is the Print Preview Dialog for the PDF Viewer. It's pretty standard so we won't enumerate
all the controls here.

Prerequisites
1.At least one pdf file saved in the project drawings path.

5.2.8  Map Tool Dialogs

Navigation: Referencelzs > Dialogss26 >

For information on the Map tool see this topic|seo.
5.2.8.1 ID GPS Locations
Navigation: Referencelz: > Dialogs |2 > Map Tool Dialogs s >

RB0 & )

Campa Budrg Moo B B Thandfodt . apor

Mapping Tools > Tools > ID GPS Locations
Commandline: none

Alternately from the Map tool:
Tools > ID GPS Locations

Explanation

This form is used to pick points from a drawing or map and associate them with the select Location
record.

This tool only works with DWG drawings that have been calibrated to the GPS coordinate system or
with the Map tool[ s
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Controls

New: Open the New Locations 4 dialog.

Save: Commit your changes to the Locations| s table of the project database.

Close: Close this form without saving.

Copy Selected Down: Copy the data from the top cell(s) down overwriting any data in the cell(s)
below.

Pick >: Dismiss this dialog and select a point from the drawing or map. The GPS coordinate will be
entered in each of the selected rows.

Zoom Show Selected Text: (drawings only) text entities in the drawing that match the text of the
currently focused cell.

Show Me: Finds the GPS coordinate in the drawing and places a Location Marker. Then zooms the
marker into view.

Leave Location Marker: Sets whether a location marker as determined by the settings is placed at
the pick point.

Related Topics:
How To: Show Location Markers in the Map Tool |z
How To: Associate GPS LAT, LON with your Locations |25

5.2.8.2 Print Preview
Navigation: Referencelz: > Dialogs |z > Map Tool Dialogs s >

= —_ -

Menu: File > Print
Explanation

The print preview dialog can be used to send the current map view to the printer or exported to
several file formats.
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Controls

Document Section

Open - Open a saved *.prnx file for printing.
Save - Save a *.prnx file for printing later.

Print Section

Print - Open the Printer dialog to set the current printer, page size, number of copies, etc.

Quick Print - Do it now.

Options - Open a dialog to set the image fit properties and what visual elements to include in the
printed output.

Header / Footer - Open a dialog to set the document header and footer.

Page Setup Section

Scale - Set the scale of the document or fit it to a number of pages.

Margins - Set the document margins. Alternately you can drag a margin indicator line to resize it.
Orientation - Set portrait or landscape mode.

Size - Set the page size. Sizes are based on the current printer.

Navigation Section

Find - Find text within the document.
Thumbnails - Show the Thumbnails tool panel.
Page Navigation - First, Previous, Next, Last. Move around the pages.

Zoom Section

Mouse Pointer Tool - Enable the mouse pointer.
Pan Hand Tool - Enable the panning tool.
Magnifier Tool - Enable the magnifier tool.

Many Page Selector - Set the number of pages in the viewer.
Zoom Out - Zoom the display out.

Zoom Numeric - Zoom to a specific numeric percentage value.
Zoom In - Zoom the display in.

Page Background Section

Page Color - Set the color of the background.
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Watermark - Open a dialog to set a watermark for the document. The watermark can be text,
image, or both.

Export Section

Both the [Export To] function and the [Email As] functions support the following formats:

PDF Fibe
Adobe Portable Docment Format

77771 HTML File
L) Web Page

75 MHT File
L Singls Fle Web Page

(Rf3 RTF File
L) Rich Text Fonmat

XLS File
Merosaft Exoel 2000-2003 Workbook

XL5X File
Mecrosofit Excel 2007 Workbook

Image File
BME, GIF, JPEG, PNG, TIFF, BMF, WMF
5.3 Forms

Navigation: Referencelzs >

Forms differ from dialogs in that they occupy the full client docking area of the main window. Only
one form may be active at a time. That form may host other dialogs.

5.3.1 Application Menu Forms

Navigation: Referencelzs > Forms/si1 >

The forms in this section are specific to the Application Menu.

5.3.1.1 Project Information

Navigation: Referencel[2e% > Forms[s" > Application Menu Forms s >
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Application Menu > Project Information
Commandline: Project Info

Explanation

This form contains the basic project information and status. Project name and description here will
show up in the reporting engine and can be used elsewhere. The CurrentProjectRevision field
populates the Cables and SysNames grid when an edit is made or a new record added the value
here will populate there.

The Project Checked-out status can be shown modified here.

Project File Info Tab

Read only look at the PROJECT_NAME.wc6plf file.

Related Projects Tab

Here you can Add/Edit/Remove related projects. Related projects show in the Project Explorer
(read-only) and can warn if duplicate SysNames and Cable Numbers are about to be used.

5.3.1.2 Permissions Grid

Navigation: Referencelzs8 > Forms/[s" > Application Menu Forms| s >
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Application Menu > Security Tools > Permissions Viewer
Commandline: none

Explanation

This grid shows the different permissions groups and collection permissions.
This grid is read only and only visible if you are a member of a group with administrator privileges.

5.3.2 Global Data Forms

Navigation: Referencel2s > Forms/[sih >

The forms in this section are specific to the Global Equipment Database.
5.3.2.1 Manufacturers Grid

Navigation: Referencelzs > Forms[si71 > Global Data Forms|s: >
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Database > Manufacturers
Commandline: man

Explanation

This tool provides access to the Manufacturers table of the Global Equipment database. The grid
is hierarchical. The [+] buttons may be expanded to show related equipment.
Deletes here cascade, deleting any equipment that is associated with the Manufacturer.

Prerequisites
1.There is at least one Manufacturer added to the Global Equipment database.

Related Topics:
Grid Basics| +
How To: Add Manufacturers[«5

Form Options

eNew - Show the New Manufacturers dialog |45

eAttach Document ... - Any document may be attached to any record. This is a handy place to
store manufacturer data sheets, images and such.

eRemove Duplicates - This function scans the table for duplicate Manufacturer Names. If found
the following occurs:

All equipment is rolled up under the top instance of the manufacturer.

All other instances are deleted.

The collection is saved.

NOTE: a safety valve exists where if the Manufacturer is flagged to DisplaylnCableTypes the
function is ignored.

5.3.2.2 Equipment Grid

Navigation: Reference[ze > Forms[si" > Global Data Forms|si% >
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Database > Equipment
Commandline: eg

Explanation

This tool provides access to the Equipment table of the Global Equipment database. The grid is
hierarchical. The [+] buttons may be expanded to show related Inputs and Outputs.
Deletes here cascade, deleting any 1/O associated with the Equipment.

Prerequisites
1.There is at least one Manufacturer added to the Global Equipment database.
2.There is at least one Equipment definition added to the Equipment table.

Related Topics:
Grid Basics| 1
How To: Add Equipment/ ¢

Form Options

eNew - Show the New Equipment Wizard [«s5.

eAttach Document ... - Any document may be attached to any record. This is a handy place to
store manufacturer data sheets, images and such.

eClean - This function scans the table for Equipment with no I/O. If found the following occurs:

The Equipment definition is deleted.

The collection is saved.

eTransfer to Different Manufacturer - Allows movement of the selected device to a different
Manufacturer.

Select Manufacturer =

Sebect Manufactirer to move selected egugement to

5.3.2.3 Default Signal Types Grid

Navigation: Referencelzs% > Forms/s" > Global Data Forms s >

mmCommEm §

.......

.......

‘ECEEEE0E
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Database > Default Signal Types
Commandline: st

Explanation

This tool provides access to the Default Signal Types table of the Global Equipment database.
Many of the default display behaviors originate here, for instance:

eThe color of pins on a block.

eThe color of cables.

eThe Cable Type associated with the Signal Type.

eThe Cable Number prefix.

These values are preempted by the Project Signal Types/s:h grid which has priority. If signal type
information is required by the application it first looks to the project, then to the default.

Prerequisites
1.None

Related Topics:

Signal Types| s5
Grid Basics|

Form Options

eNew - There is no New button on this grid. The New Record Row appears at the top of the grid:

e Sl ¥ e, e et

eRename /0 Signal Types - Rename the Signal Type in this grid and all 1/O in the global
database.

eRebuild Signal Types from 1/O - This function scans the Inputs and Output for Signal Types
then:

Checks existing in this grid.

Add if not found.

Collection is saved.

5.3.2.4 Connectors Grid

Navigation: Referencelzs > Forms[si71 > Global Data Forms|s: >
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Database > Connectors
Commandline: ¢cn

Explanation

This tool provides access to the Connectors table of the Global Equipment database.

Prerequisites
1.None

Related Topics:
Grid Basics| 43

Form Options

eNew - There is no New button on this grid. The New Record Row appears at the top of the grid:

e o= et ez ¥ e, e et

eRename I/O Connector Types - Rename the Connector in this grid and all I/O in the database.
5.3.2.5 Cable Types Grid

Navigation: Referencelzs > Forms[si71 > Global Data Forms|s:% >

i
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Database > Cable Types
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Commandline: ShowCableTypesGrid

Explanation

This tool provides access to the Cable Types table of the Global Equipment database. The grid
is hierarchical. Clicking the [+] button will display a child grid of the ConductorsCollection for that
record if any.

Prerequisites
1.None

Related Topics:
Grid Basics|
How to Add a New Cable Typel sh

Form Options

eNew - Shows the New Cable Type/+«h dialog.
5.3.2.6 Color Codes Grid

Navigation: Referencel[zet > Forms[si" > Global Data Forms|s: >

Project Explorer > Color Codes
Commandline: showcolorcodesgrid

Explanation

This tool provides access to the Color Codes table of the Global Equipment database.

Prerequisites
1.None

Related Topics:
Grid Basics| 43
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5.3.2.7 Pinouts

Navigation: Referencelzs8 > Forms/[s1 > Global Data Forms /s >

Database > Pinouts
Commandline: po

Explanation

This tool provides access to the Pinouts table of the Global Equipment database. The concept of
the Pinouts tool is to create a data set that describes two connectors and the conductors between
them. The Cable Type data needs to have conductor level data. The data may be attached at the
project level to a cable. The data can also be churned into a preview.

D |3 | F| 2| o

Lististerrs, Ekirrluin Lemaiteon, Elimratuiry

[B] Te [B] - BELDEN - 1503A - Black

Prerequisites
1.None

Related Topics:
Grid Basics| +

Form Detail Tab Options
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eSelect Existing Pinout Profile - Select a named pinout to fill the grid and subsequent preview.
eShow More Detail

ePreserve Pin Order When Creating Preview, Ortho Conductors - How is the Preview created.
ePinout Grid

s v - R

Froeutn - Gt < e

...... . S

Clicking the File > New button enables the New tab. From here you enter the overall data for the
pinout. The Left-hand and Right-hand connectors conductor counts, etc. Once the pinout is created
you can edit the detail in the Detail tab.

Form New Tab Options

oL eft hand Connector Info -Enter the connector type, pin profile (if any) and count.

eCable Type - Select the Cable Type. Remember this type must have conductor level data. Core
Level data alone will not suffice here.

*Right hand Connector Info - Enter the connector type, pin profile (if any) and count.

Click File > Save to commit your changes and switch back to the grid view.

5.3.3  Project Data Forms

Navigation: Referencelzs > Forms/[si1 >

The forms in this section are specific to the Project Database.

5.3.3.1 Backbone Grid (CMS ONLY)

Navigation: Referencelzs% > Forms/s" > Project Data Forms sz >
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Databases > Backbones
Commandline: bbg

Explanation

This is the Backbones view and includes a visualizer that can produce both ladder diagrams and
riser diagrams.

Here you can view and search Backbone data. You can also set the Status of a Backbone.

Prerequisites
Backbones created in the project database.

Related Topics:

New Backbone/z1H1
Backbone Preview Settings /25
Backbones| )

Grid Basics|

5.3.3.2 Blind Patch Form (CMS ONLY)

Navigation: Reference[2# > Forms[sh > Project Data Forms| % >

------
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]

Project Explorer > Project Databases > Blind Patches
Commandline: ShowBlindPatchTool
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Explanation

This is the Blind Patch tool that allows you to document your patches without knowing the whole
circuit. Once the patches (jumpers) are documented you can use the Discover tool to find what is
patched to what. If you find a discovered circuit to be complete you can use the Make Circuit
command to create a real circuit and remove the Blind Patches from this list.

The form is tabbed. The [Blind Patch] tab (shown above) provides a data entry grid where you can
add/edit/delete Blind Patches. The second tab (shown below) is used to Discover/Preview/Make
Circuit(s) from your Blind Patches.

\\\\\\ Bl Pabch Coast = 3, Crcuits Fowred feom Bl iFsiches = 3

Prerequisites
At least two Backbones

Related Topics:

Blind Patch Tool Explanation 225

How To: Create a Blind Patch/22h

How To: Discover Circuits from Blind Patches[22h
How To: Make a Real Circuit from Blind Patches 220

Form Options:

Menus
New: Create a new From SysName for the selected record based on the Simplex/Duplex option
and the selected ToSys.

Save: Commit the changes to the database.
Delete: Delete the selected record(s). This function will delete single records for Simplex patches
and two records for Duplex patches.

Discover Circuits: Search the blind patches and find all possible connections to make a circuit.
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Preview Selected: When checked will cause a preview to be generated whenever the discovered
circuit grid record is changed.
Make Circuit: Creates a real circuit from the data of the selected record.

Blind Patch tab

Select Patch Panel (SysName): Select the patch panel that you will jumper to.
Simplex/Duplex Jumper: Select whether the jumper needs one record or two.
Data Grid: Use this grid to select/add/edit/delete Blind Patches

Discover Circuits from Blind Patches tab

Preview: Shows the circuit preview of the selected circuit.
Discovered Blind Patch Circuits Grid: Shows the found circuits.
Status: Shows the counts of Blind Patches and found circuits.

5.3.3.3 Circuits Grid (CMS ONLY)

Navigation: Referencelzs% > Forms[s" > Project Data Forms s >

Databases > Circuits
Commandline: circ

Explanation

This is the Circuits view. Circuits are collections of cables. In most cases they include jumpers
between panels and Backbones. Circuits consist of a set of ordered elements and a strand count.
This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer
associated with this grid will create a functional diagram of the selected Circuit.
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Prerequisites
Creation of at least one Circuit

Related Topics:
Circuits| 22
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Circuits Preview Settings|2sh
Combine Circuits [ 245
Grid Basics| 41

5.3.3.4 New Circuit (CMS ONLY)

Navigation: Reference[2# > Forms[s:h > Project Data Forms|s# >
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Database > Circuits [File > New]
Commandline: none

Explanation

This tool provides a means by which to create a new circuit. Circuits can either be assembled
manually or automatically. Creating circuits manually involves selecting each jumper and backbone
segment. To create a circuit automatically you define the first and last jumper and hand it off to the
Path Finder tool which will find and present candidate routes.

Prerequisites
1.Backbones added.

Related Topics:
New Circuit/2:8)

5.3.3.5 New Backbone (CMS ONLY)

Navigation: Referencelzs% > Forms[sh > Project Data Forms s >
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Database > Backbones [File > New]
Commandline: none

Explanation

Create a new Backbone.

Prerequisites
1.None

Related Topics:
Backbones Grid [s26)
Backbones| 2161

Grid Basics| 1

5.3.3.6 Project Signal Types Grid

Navigation: Reference[2# > Forms[s:h > Project Data Forms|s# >

.......
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.......
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Database > Project Signal Types
Commandline: st

Explanation

This tool provides access to the Project Signal Types table of the Project database. Many of the
default display behaviors originate here, for instance:

eThe color of pins on a block.

eThe color of cables.

eThe Cable Type associated with the Signal Type.

eThe Cable Number prefix.

These values preempt the Default Signal Typeslsh grid. This grid has priority. If signal type
information is required by the application it first looks to the project, then to the default.

Prerequisites
1.None

Related Topics:

Signal Types| 55
Grid Basics| +

Form Options

eRename /O Signal Types - Rename the Signal Type in this grid and all 1/O in the global
database.

sRebuild Signal Types from 1/O - This function scans the Inputs and Output for Signal Types
then:

Checks existing in this grid.

Add if not found.

Collection is saved.

5.3.3.7 Equipment List

Navigation: Referencelzs8 > Forms/[si1 > Project Data Forms sz >
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Databases > Equipment List
Commandline: sys

Explanation
This is the main Equipment List of all SysNames in the project. You can edit and ripple your
changes from here.

This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer
associated with this grid will create a system snapshot of the selected SysName.
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Prerequisites
Assigned SysNames

Related Topics:

Assign SysName/ 5

Grid Basics| 1

How To: Use the Equipment List Visualizer[ &

Data Tab Options

eSearch - Search the collection for the search term.

oFind All - Clear the search field and return all records.

*Ripple List - Changes you have made that may need to be rippled across the drawing set. The
ripple will occur after you save the grid to the database.
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Tools

eAttach Document - Any document can be attached to any record. This is useful for storing data
sheets, test data, and images.

oSlurp Locations - Collect all location data from the Equipment List and populate the Locations
table with it.

L s

Visualization Tab Options

eTerminal - Select the terminal to which we will attach the cables.

sVertical Pin Spacing 1/100 DU - How far apart vertically are the ports.

eUse Last Display Order if Set

eUse Last Saved Appearance - Where is the SysName label positioned with reference to the end
points of the polyline that represents the cable.

eBody Width -

ePort Data Source - Pull the port data from the Equipment Library which will show all available
ports as defined in the Equipment Library or pull port data from the Cable table which will show
only ports which have cables attached.
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5.3.3.8 Cables

Navigation: Referencelze > Forms[si/1 > Project Data Forms|s# >
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Databases > Cables
Commandline: cg

Explanation

This is the main Cables table view. You can print, export and edit this view. Some fields are marked
read only because they inherit their data from other tables. Changes to those fields should be done
in the other tables then rippled into this table.

This grid contains a Visualizer that lets you see the data in graphical form. The Visualizer
associated with this grid will create a Ladder diagram of the selected cables.
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Prerequisites
Cable numbers assigned in a drawing.

Related Topics:

New Cable[ s
Grid Basics| s

Data Tab Options

eSearch - Search the collection for the search term.
eFind All - Clear the search field and return all records.
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*Ripple List - Changes you have made that may need to be rippled across the drawing set. The
ripple will occur after you save the grid to the database.

eExpert Mode - Removes the read-only flags and puts the grid in a completely editable state. Not
for beginners.

eAdd Many - Only available in Expert Mode this tool adds blank records to the table that you can
edit as a spreadsheet.

Tools

eRepair Equipment List - Scans the Cables table for SysNames then compares with the
Equipment List. Missing SysNames are then added to the Equipment List.

eAttach Document - Any document can be attached to any record. This is useful for storing data
sheets, test data, and images.

Visualization Tab Options

eTerminal - Not yet implemented.

eCable Number Text Height

eVertical Spacing 1/100 DU - How far apart vertically are the cables.

eCenter Label Offset - Where is the center label positioned with reference to the center of the
polyline that represents the cable.

eSysName Label Offset - Where is the SysName label positioned with reference to the end points
of the polyline that represents the cable.

eSysName Text Height - The text height of the SysName label.

ePort Info Format String - The following variables can be used along with the /n new line
character to format the port info:

{0}SysName

{1}Port

{2}Location

{3}Alias

{4}Connector

{5}Cable Number

{6}Cable Manufacturer

{7}Cable Type
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Example:

Assume that the SysName is VTR-01. The PortName is VID-OUT and the Location is RK-10 The
following Port Info Format string:

{0}>{1}@{2}

Will produce the result:

VTR-01>VID-OUT@RK-10

eCable Text Format String - The following variables can be used along with the /n new line
character to format the Cable Text:

{0}Cable Number

{1}Cable Manufacturer

{2}Cable Type

{3}Length

{4}Sheet

eLocation Marker Spacing - How far apart horizontally the vertical location markers are spaced.
eLocation Marker Text Hit, Location Marker Color, Location Marker Pen Width, SysName
Rotation Angle

eShow Dot Direction Color - Display a green dot on the source side and a red dot on the
destination side of the cable.

eShow SysNames

eColor By Signal Type - Inherit cable color by Signal Type or set a single color for all cables.
eCollapse Multi-core Cables to Single Line - Multi-core cables are represented by many records
in the Cables table. You can choose to display a cable for each or collapse to a single cable.
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5.3.3.9 Locations

Navigation: Reference[z# > Forms[s:h > Project Data Forms|s# >
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Databases > Locations
Commandline: showprojectlocationsgrid

Explanation

This is the main Locations table view. You can print, export and edit this view. Changes to this grid
can be rippled throughout the project.
Remember that the only bit of data WireCAD actually uses from this grid is the QualifiedLocation.

Prerequisites
None

Related Topics:
New Location Dialog|+sh
Grid Basics| 1

5.3.3.10 Named Paths

Navigation: Referencelzs > Forms|[si/1> Project Data Forms| s >
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Databases > Named Paths
Commandline: shownamedpathsgrid

Explanation

The Named Paths grid is an organizational tool to keep track of key distances. We name a path
and give it a distance and other factors to determine. You can use it as a reference, as well as a
length calculator in the Assign Cable Numbers dialog.

Prerequisites
None

Related Topics:

Assign Cables/4h
Grid Basics| 4

5.3.3.11 ToDo

Navigation: Referencelzs8 > Forms/s" > Project Data Forms sz >
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Databases > Todo List
Commandline: tdl

Explanation

A To Do list. You can define the data that fills the following drop downs in the Todo List Settings [ss)
panel:

eAssignees

eStatuses

ePriorities

Prerequisites
An active project.

Related Topics:
Todo List Settings|ssh
Grid Basics| 1

5.3.3.12 Drawings

Navigation: Reference[2# > Forms[sh > Project Data Forms| % >
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Project Explorer> Project Databases > Drawings
Commandline: sdg

Explanation

This is the list of drawings in the Project\Drawings folder tree. The following changes in the
Drawings table have occurred in WireCAD v8 and forward:

e¢The DrawingsPath has changed from absolute to relative.

e¢The tool now scans for and lists pdf files.

oIf the project database is SQLAzure the dwg and pdf files are embedded in the database for
portability if the project settings Folder Sync/[«8is enabled.

NOTE: to rename a drawing use the function in the Project Explorer. Right-click a closed drawing
and select the context menu item Rename Drawing.

Prerequisites
An active project.

Related Topics:
Grid Basics| 43

5.3.3.13 Index Grids

Navigation: Referencelzs% > Forms[s" > Project Data Forms s >

More Information
Understanding Indexes %
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5.3.3.13.1 Unassigned Cables

Navigation: Referencelze8 > Forms[si71 > Project Data Forms|s# > Index Grids s+ >
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Database > Index Grids > Unassigned Cables
Commandline: ShowUnassignedCablesGrid

Explanation

Any Cable that does not yet have a number to this index by drawing.
As you approach the end of a project this grid should be empty.

5.3.3.13.2 Unassigned SysNames

Navigation: Referencelze8 > Forms[si71 > Project Data Forms|s# > Index Grids /s >

Database > Index Grids > Unassigned SysNames
Commandline: ShowUnassignedSysNamedGrid

Explanation
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Any equipment that does not yet have a SysName and add it to this index by drawing.
As you approach the end of a project this grid should be empty.

5.3.3.13.3 Cables by Drawing
Navigation: Referencel2s% > Forms/[sh > Project Data Forms s > Index Grids[s} >
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Database > Index Grids > Cables by Drawing
Commandline: ShowCablesbyDrawingGrid

Explanation

Any Cable that has a number and corresponding entry in the Cables database is added to this
index by drawing.

5.3.3.13.4 SysNames by Drawing

Navigation: Referencel[ze8 > Forms[si71 > Project Data Forms|[s# > Index Grids /s >

HREE

Database > Index Grids > SysNames by Drawing
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Commandline: ShowSysNamesbyDrawingGrid

Explanation

Any equipment that has a SysName and corresponding entry in the Equipment List is added to
this index by drawing.

5.3.3.13.5 Cables by SysName

Navigation: Reference[2# > Forms[s:" > Project Data Forms|[s# > Index Grids|[ssh >
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Database > Index Grids > Cables by SysName
Commandline: ShowCablesbySysNameGrid

Explanation

Any Cable that has a number and corresponding entry in the Cables database and where both
ends of the Cable have valid entries in the Equipment List will be added to this index.

5.3.3.13.6 Orphaned Cables

Navigation: Reference[2e% > Forms[s17 > Project Data Forms|[s# > Index Grids /s >
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Database > Index Grids > Orphaned Cables
Commandline: ShowOrphanedCablesGrid

Explanation

Any Cable with a number but no corresponding entry in the Cables database will be added to this
index by drawing.
As you approach the end of a project this grid should be empty.

5.3.3.13.7 Orphaned SysNames

Navigation: Referencel[2# > Forms[si7 > Project Data Forms|s# > Index Grids /s >
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Database > Index Grids > Orphaned SysNames
Commandline: ShowOrphanedSysNamesGrid

Explanation

Any equipment with a SysName but no corresponding entry in the Equipment List will be added to
this index by drawing.
As you approach the end of a project this grid should be empty.

5.3.3.14 Import Project Data

Navigation: Referencelzs8 > Forms[s" > Project Data Forms sz >
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Database > Import Tool
Commandline: it

Explanation

This tool imports data from a text delimited file into the various databases based on your initial
selection.

There are three modes available for selection in this form:
1.Import SysName data. This tool attempts to import data into the project Equipment List and the
Global Equipment Library.

ol Didaltarias

L S

[—
Sy [

2.Import Cables data. This tool attempts to import data into the Cables table and the Equipment
List.

i,

& ¢

Pt Proptet
Cabiss Sruema

3.Hybrid import. This tool attempts to import data into the Cables, Equipment List and Global
Equipment Library.
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Global Database

The process leads you through file selection
Column Mapping

Data validation

Import.

Prerequisites
One of the import templates with your incoming data.

Related Topics:
None

5.3.3.15 Discrepancies

Navigation: Referencelzs > Forms[si71 > Project Data Forms| s >
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Project Explorer > Project > Discrepancies
Commandline: dr
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Explanation

This function is provided for legacy purposes. These functions have been replaced by the index
grids.

There is one instance where the discrepancy report is used.

If a ripple is initiated in a multi-user install and another user has the drawing open. The ripple
cannot update the drawing.

A record is added to the discrepancy report. Use the Sync Equipment function.

Prerequisites

Related Topics:
Sync Equipment with Database| 35

5.3.3.16 Next Numbers Grid

Navigation: Reference[2# > Forms[sh > Project Data Forms|s# >

Menu: Database > Next Numbers
Default command line shortcut: NN
Related Project Settings:

None

Product Level: ALL

The Next Numbers Grid will show you the next available Cable number based on your Cable
Number Format /2. To access the Next Numbers Tool, type nx in the command line prompt.

This grid will show you both Backbone Cable Numbers as well as Standard Cable Numbers. As
you progress through your project, these numbers will change.

To edit these numbers (such as in the event of deleted Backbones) simply click in the Next Number
box and fill in the desired number. Be sure that you are not entering a number that is already in use.
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g [ | . - T®mA |
sB>0 " o B ... % 1T WireCAD

Note: Yours will look different as the Next Numbers grid will automatically create entries for each
new sequence used by the application.

5.3.3.17 Project Rules

Navigation: Referencelze > Forms[si/1 > Project Data Forms|s# >

StartPage X | ProjectRules = X

Explanation
Context Expression Desaription Execution Order

v

* Click here to

»  AssignCableMoAssignafterEdit (SignalType ='sDI' &&Length>100) then set CableType = ... )
AssignSyshameAssigrBeforeEdit (1=1) set User1 = 'SomeValuerdefsgsdurfar’ Some Testing 0
AssignSyshameAssidnfterEdit (1=1) setUser1 = ‘Fred' Some Testing

W4 4 Record Lof3 » B oM — & /X

Progress Bar
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Menu: Project Explorer - Project Databases > Rules
Default command line shortcut: ShowProjectRules
Related Project Settings:

Project>Settings[Project Rules] Enable Project Rules
Product Level: ALL

WireCAD 10 allows you to define project specific rules.
There are four contexts in which rules will be evaluated. Rules are contained in the Project Rules
grid.

A Rule consists of:

1.The Expression to evaluate.

2.The Context in which to evaluate the expression.

3.The ExecutionOrder. If multiple rules are defined to evaluate within the same Context they will
be evaluated in the ExecutionOrder order.

4.A Description of the rule.

Rule Contexts:

1.AssignCableNoAssignBeforeEdit - executed during a new Cable Number Assignment or
existing Cable Number Edit before the dialog is shown.

2.AssignCableNoAssignAfterEdit - as above but after the user has clicked Save on the dialog or
if Verbose Cable No Assignment = false then during the Cable save process.
3.AssignSysNameAssignBeforeEdit - executed during a new SysName Assignment or existing
SysName Edit before the dialog is shown.

4 AssignSysNameAssidnAfterEdit - as above but after the user has clicked Save on the dialog or
if Verbose SysName Assignment = false then during the SysName save process.

Related Topics:

Project Rules 205
Rule Syntax| 2o

5.3.4 Report Forms

Navigation: Referencelzs8 > Forms/[sih >

The forms in this section are specific to the Reporting Engine.
5.3.4.1 Print Preview
Navigation: Reference[2e% > Forms[sh > Report Forms[ssh >

Visible only when the active environment is a report.
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Explanation

This is the default view that loads when a report is loaded. From here you can determine the
number of pages to print and to which device.

Form Options

eSave - Save the rendered document to the native print document format (.prnx). NOTE: this is the
rendered document not the report design. The report design can only be saved from the Report
Designer tab.

The remainder of the controls are obvious.

5.3.4.2 HTML View
Navigation: Referencelzs > Forms[si/1 > Report Forms[ssh >

Visible only when the active environment is a report.

5. Dbt 1 EadeR 1. B . Dubms L. By

Explanation
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This is the report rendered to html. The controls are self-explanatory.
5.3.4.3 Report Designer

Navigation: Referencel2et > Forms[s:7 > Report Forms[ssh >

Visible only when the active environment is a report.
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Explanation

Here we design the report. The menus are obvious so we won't bother. What may not be obvious
the Banded Report design and the Smart Tag. Smart Tags will be displayed on entities that are
selected (if available) like so:

ME

%J.illi . [CableNo] B
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|
i
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|
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Smart tags can be expanded to show entity specify settings. Here we see properties specific to the

Detail Band:
v [ Pl © Detail Tasks B

Edit and Riecrder Bands..

Teet Fields [Colectian)
Mult-Column Mode | Use Column Width -
Multi-Column Layout First Across, then Dawn -

Column Count 1 =

Codumn Width 180

Codumn Spadng o

Formatting Rudes {Colecton) aan
Page Break Hicine -

i i
Keep Together
o j

Related Topics:
A discussion on report design can be found here[ 7.

5.3.4.4 Toolbox
Navigation: Reference[z > Forms[s1h > Report Forms[ssh >

Visible only when the Report Designer Tab is active.
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Standard Controls
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Any of these tools can be added to the report under design.

Controls

ePointer - Stop drawing and revert the mouse to a Selection tool.

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD




Reference

eLabel - The most common tool. Can be used to display static text or if the text is held in square
braces[]. For example: a label with the caption S:[SRCSys]>[SRCPin] will render
S:SomeSrcSys>SomeSrcPin once for every record in the collection.

eCheck Box - A Check Box is used to display True/False or Checked/Unchecked/Indeterminate
values in a report.

eRich Text - The Rich Text control allows you to display formatted text in your report. It can
represent static or dynamic text, or both. In addition to the capability to embed plain text into your
report (using the Label control), you may need to display RTF or HTML content as well. WireCAD
does not use RTF or HTML natively but there is no reason you could not put formatted text in a
user field.

ePicture Box - Picture Box is used to embed static (stored along with the report definition) or
dynamic (obtained from a data source) images into a report. It can display images of various file
formats: BMP, JPG, JPEG, GIF, TIF, TIFF, PNG, ICO, DIB, RLE, JPE, JFIF, EMF, WMF.

ePanel - The Panel control is a container that frames separate report controls to allow them to be
easily moved, copied and pasted, and visually unites them in the report preview (with borders or a
uniform color background).

eTable - The Table is used to display tabular information in a report. Note: Table reports should not
be confused with hierarchical master-detail reports or cross-tab reports. You can create two tables
simultaneously, e.g., one for showing column titles in the Page Header, and the other for showing
regular information in the Detail band.

eLine - The Line control draws a line of a specified direction, style, width and color. It can be used
for both decoration and visual separation of a report's sections. Note that the Line cannot cross
bands.

eShape - The reporting engine provides you with the capability to embed shapes into your reports.
You can simply add any Shape control to a report, choose one of the available shape types, and
then print or export this report. The following shapes are available:

Arrow

Brace

Bracket

Cross

Ellipse

Line

Polygon

Rectangle

Star

eBar Code - A Bar Code object. The supported bar code types are:

1D Barcode Types 2D Barcode Types
Codabar ECC200 - Data Matrix
Code 11 (USD-8) GS1- Data Matrix
Code 39 (USD-3) Intelligent Mail
Code 39 Extended PDF417

Code 93 QR Code

Code 93 Extended

Code 128

EAN 8

EAN 13

GS1-128 - EAN-128 (UCC)
GS1 - DataBar
Industrial 2 of 5
Interleaved 2 of 5
Matrix 2 of 5
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MSI - Plessey

PostNet

UPC Shipping Container
Symbol (ITF-14)

UPC Supplemental 2

UPC Supplemental 5
UPC-A

UPC-EOQ

UPC-E1

oZip Code - The Zip Code control transforms its content into a zip code. To specify the text for the
control, use the ZipCode. Text property. Note that the Zip Code control can only display numeric
characters and dashes. Other characters are displayed as empty zip boxes.
eChart - The Chart control visualizes the series of points using the available 2D chart types or 3D
chart types. The chart type is defined via the View property of a series. And, a single chart can
display multiple series, if their view types are compatible. A Chart contains multiple visual elements
(diagram, axes, titles, labels, strips, constant lines, etc.) and, when any of these elements is
selected, its properties are shown in the Property Grid.
eGauge - The Gauge control provides you with the capability to embed graphical gauges into your
report.
eSparkline - The Sparkline control displays a compact chart that is commonly used to reflect the
flow of data for every row in a report.
*Pivot Grid - The Pivot Grid allows you to create a pivot table, an Excel-inspired data visualization
application for multi-dimensional data analysis. Using the Pivot Grid, large amounts of data can be
summarized and represented in a cross-tabular format that can be sorted and filtered. Also, since
the Pivot Grid provides customization you can freely change the layout of the report based on your
analysis requirements, using simple drag-and-drop operations. It also supports drill-down (to view
the underlying data for calculated cells).
eSub-Report - The Sub-Report control is used to embed reports into each other; this allows you to
create Master/Detail reports (reports with hierarchically linked data).
eTable of Contents - The Table of Contents control allows you to provide your report with a table
of contents that reflects the hierarchical structure of the report bookmarks.
ePage Info - The Page Info is used to display auxiliary information on report pages, such as date,
time, page numbers or user name.
ePage Break - The Page Break control's sole purpose is to insert a page delimiter at any point
within a report. This control is visually represented by a short line, attached to the report's left
margin. The Page Break control is useful when you need to insert a page break between controls
within a report band - for example, to divide subreports, so that the second subreport starts printing
on a new page. You can also insert a Page Break before or after a specific report band using the
Band.PageBreak property.
eCross-band Line, Cross-band Box - Cross-band controls are used to draw lines and rectangles
through several bands, as opposed to Line and Shape controls that can be used only within a
single band. The following two cross-band controls are available:
Cross-band Line allows for the drawing of vertical lines, which are not restricted to a particular
band. For example, it can be used to emphasize a report section consisting of multiple band areas.
Cross-band Box allows for the drawing of rectangles through several bands. It can be used to
encompass a report section consisting of multiple band areas.

5.3.4.5 Cable Data Selector
Navigation: Referencel2s% > Forms[sh > Report Forms[ssh >

Visible only when the active environment is a report.
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Explanation

This tool allows you to pick and choose which cable records to print without having to create a
complex filter. Simply select the records to print in the Select This field and set the number of
copies to print then click the [Apply] button.

Controls

eReload - Reloads the data. All current selections are cleared then the data is reloaded from the
Cables table.

eClear All - Uncheck all.

eSelect All - Check all.

eCopies - Number of copies to print.

ePad with Empty Records - Useful when trying to use a label on a sheet of labels that has already
had some use.

eApply - Do it!

5.3.4.6 Bill of Materials Generator
Navigation: Referencel[2# > Forms[s:h > Report Forms[ssh >
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i

Reports > Generate Bill of Materials
Commandline: bom

Explanation

Before a Bill of Materials (BOM) report can display data, that data must first be generated. We
generate Bill of Materials data with a Snapshot Name. The report that you run will group by
Snapshot Name.

You can choose which items to count in the BOM and refine your counts by creating filters.

One of the most common misunderstandings with the BOM generator is how it deals with cable
lengths. The generator sums all lengths of a given Cable Type. But what if you have specified a pre
made cable of 2 meter length? In this case we don't want to total the length but rather the quantity.
To handle pre-made cables take the following steps:

1.Create a new Cable Typel[? with the cable length in the name. For example: an off the shelf 2
meter HDMI cable might be named: OTS HDMI 2m. This will show up in the Cable Type field of the
Cables table and further in your BOM.

2.When entering the cable Length for pre made cables enter the Length as 1.

In the BOM you will then see a count of your OTS HDMI 2m cables.

Prerequisites
1.You will need an active project with SysNames and Cable data.

Related Topics:
Grid Basics|

Form Options
eSnapshot Name - Name is something unique that you will remember. Preset by the Default BOM
Snapshot Name in the Project Settings panel.

eInclude Equipment, Include Cable Types, Include Connector Types - What to include.
oFilter Equipment - Apply a filter to the set. Click the [...]
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5.3.5 PDF Viewer

Navigation: Referencelzs > Forms/si1 >

Visible only when the active environment is a pdf document.
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Explanation

This is the built in PDF viewer. Any pdf file placed in the project\Drawings\ folder tree can easily be
previewed by double-clicking it in the Project Explorer.

Controls
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¢Open PDF - Open another pdf.
Print - Shows the PDF preview dialog. [

ePage Navigation

oFind - Shows the find text panel.

5.3.6  Plugins Forms

Navigation: Referencel2s > Forms/si >

The following sections relate to plugins that register forms for editing. These are plugins included
with WireCAD. Other plugins may register forms that do not appear here.

5.3.6.1

Translation Manager

Navigation: Reference[2# > Forms[s:h > Plugins Forms [ss5 >

KeyString
% | e

WireCAD
UserSettings.ml
SupportPaths
Group

Checked
Unchecked
Loaded Plugins:
PRO

Copyright 2000-2009 Holbrook Enterprises, Inc.

Serial Number: - Trial

Info

Lubing up the engine room
Lubing up the engine room ....
AutoSave In: {0}
(Unassigned Ttems)

(all 1tems)

Custom {0}
layoutControl1

Junctions

Start Cable

Cable Drawing Properties
Preview:

True

layoutControl3

X Feeder Distance:

Y Feed Distance:

Hor Extension:

Output (Source)
Wi 4 4 Record 7of 8062 » M W — &

Explanation

en fr
Wb o0e
WireCAD

UserSettings xml
SuppertPaths

Group

Checked

Unchecked

Loaded Plugins:

PRO

Copyright 2000-2015 Holbrook Enterprises, Inc.
Serial Number: - Trial

Info

Lubing up the engine room
Lubing up the engine room ...
AutoSave In: {0}
(Unassigned Ttems)

(2l Items)

Custom {0}
layoutControl1

Junctions

Start Cable

Cable Drawing Properties
Preview:

True

IayoutControl3

X Feeder Distance:

¥ Feed Distance:

Hor Extension:

Output (Source)

All visible text strings in WireCAD are contained in dictionary that is
Manager. The current Ul culture is queried for a string. If not found the English (en) version is

returned.

CalledBy
o ~

WireCAD. Translation. wel ayoutl ocalizer

WireCAD. Translation. wcEditorLocalizer

WireCAD. Translation. wcEditorLocalizer

WireCAD. frmSplash.labelControl 1. Text

WireCAD. frmSplash. biMode. Text

WireCAD. frmSplash. IblCopyright. Text

WireCAD. frmSplash IbISN Text

WireCAD. frmSplash. Iblinfo. Text

WireCAD. frmSplash

WireCAD.Workspace

WireCAD.frmMain

WireCAD. Translation. wcBarLocalizer

WireCAD. Translation. wcBarLocalizer

WireCAD. Translation. wcBarLocalizer
WireCAD.ucDranCables loJunctions. Text
WireCAD.ucDranCables layoutControlGroup16. Text
WireCAD.ucDranCables. simpleButton5. Text
WireCAD ucDranCables gePrefs. Text
WireCAD.ucDranCables layoutControlGroup 17.Text
WireCAD.ucDranCables.raManyToManyDb, Text
WireCAD.ucDranCables layoutControl3. Text
WireCAD,.ucDrawCables. layoutControlltem31. Text
WireCAD .ucDranCables.layoutContralltem22. Text
WireCAD.ucDranCables layoutControlltem24, Text
WireCAD.ucDranCables.geSrc. Text v

editable via the Translation

You can right-click a column header and select the KeyString column to show the base en string
that the program searches from.

NOTE: Some forms and dialogs only get their text strings on program start so changes here will not
be visible to all areas of the application until you restart WireCAD.
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Possible Uses
1.Translate WireCAD into a different language.
2.Change user column names and labels in the application to aid your process.

See Also
How to Translate a Form Caption/sh

Form Options

eCurrent Culture is - The culture of your machine. If no translation exists, WireCAD defaults to the
en (English) language.

eSelect Language To Translate - Selects the language to edit in the right-hand column.

eShow Context - Select to display a column showing the primary context in which the string or
message appears.

5.3.7 Map Tool

Navigation: Referencelzs > Forms/si1 >

WireCAD Enterprise provides a world map tool.
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Explanation

The Map tool within WireCAD can be used to associate your Locations table entries to specific
GPS coordinates.

Once the Locations table entries have been associated with corresponding GPS coordinates we
can automatically place:

eLocation Markers

ePanel Markers
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eBackbone Markers

To associate the Location records with specific points on the map use the Tools > ID GPS
Locations st tool.

5.4 Tool Panels

Navigation: Reference|z: >

Tool Panels differ from Forms and Dialogs in that they are windows that can be docked to the
edges of the main application window.

Tool panels are used to present logical groups of controls. Tool panels can be shown/hidden from
the View>Tool Panels>Pane Name menu.

Tool panels can be docked together or undocked. To Undock a tool panel drag its tab page. As you
move near a docking target a hint will be shown. Tool Panels will dock based on the hint you click.
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5.4.1 Project Explorer

Navigation: Referencel2s% > Tool Panels seh >
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& Enter text to search Find
=
% Item Status
» | |+ [] Global Databases
-
= Equipment Library...
= Default Signal Types
-_n = Cable Types
%T = Connectors
< - .
rED = Permissions
= Color Codes
i Pinouts
' | |+ [ Projects %
o)
= + [ ] sql to azure 1
. oﬂ New Drawing...
Open Drawing(s)
= [ ] Project Drawings
R barny.DWG Awaiting Revi
R fred1.DWG (Complete)
R MACHINE_ROOM1.dwg Needs Attentil
R SysName Size Test.DWG In Progress

= [ ] SQL Project Databases

Project Signal Types
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Project Explorer << r x
s B S & e

Find

Ttem Preview Status Checked... Checked OutBy  Description Revison  Path
]
+ [ Global Databases

§% Equipment Library...
Default Signal Types

Jau0dx3 paloig ¥

pud Yo

Cable Types
Connectors
Permissions

maip uejd [

Color Codes
Pinouts
- [ Project
+ [ News Production Control Demo.
°R New Drawing....
[ Open Drawing(s)
+ [ Project Drawings
~ [ titieblock

C:\sers),

saquone L

IS EEE@E@

[N

A weD.dwg

O

\praing

MAIN TITLE PAGE

A (ritle).dwg (Complete) (m| 0 \Drawing

‘TABLE OF CONTENTS
A (Toc).DWG [m] 0 \Drawing.

AUDIO INTERCONNECT

A AUDIO.DWG [m] 0 \Drawing

SERVICE PANELS INTERCONNECT

A BSP 1LDWG i [m] 0 \Drawing

CABLE PULL LADDER DIAGRAMS

Project Explorer (Expanded)

View > Tool Panels > Project Explorer
Commandline: none

Explanation

This is the main access point to the project. From here you can:
*Open global database grids.

¢Open drawing(s).

*Open Project Database grids.

Open the Map Tool. (ENT only).

eRename drawings.

Related Topics:
New Project[ 78
Show Report Mode|ssh

Prerequisites
In order to see project related information you will first have to open a project.

Tool Panel Options
Open Project Folder - Show the current project folder in a windows folder browser.

Project Properties - Show the Project Info (s form.
Refresh - Refresh the Project Explorer.
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Equipment Library - Show the Equipment Library [ 5.
Show Drawing Preview Image - Shows the preview image in the Preview column. Hiding loads the
Project Explorer faster.

Expand the Project Explorer tool panel to the right to see additional columns that you can view and

edit.
Project Explorer = | B 4
. i B 'S &= | ®
el
o
[
T Enter text to search Find
!.:II_
I
= Item
=
- = Permissions =
= (Color Codes
Pinouts

PUd Yo

v |:| Project

» [ ] Mews Production Control Demo

Project Explorer Expand Button

Tool Panel Context Menu Options

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Reference

-

WireCAD v10,

Refresh
Collapse All Drawing ltems
Expand All [tems

Open Drawing
Open All Drawings
Open Drawing Read Only

Check In All Drawings
Check In Drawing

Revert (Title).dwg <<

Prune Archive
Show Path

Open Project Folder

Customize Explorer Columns . ..

Mew
Eename

Delete

Show Trash Folder

Restore ltem from Trash

Empty Trash
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Menu Items

Refresh - Reload the Project Explorer
Collapse All Drawing Items - Collapse all the drawing nodes to display one drawings folder.
Expand All Items - Show all items.

Open Drawing - Open the focused node (if it is a drawing).
Open All Drawing - Open all project drawings.
Open Drawing Read Only - Open the focused node (if it is a drawing) - read only.

Check In All Drawings -
Check In Drawing -

Revert (Title).dwg << > -
Prune Archive -

Show Path -
Open Projec Folder -
Custom Explorer Columns... -

New>Folder -
New>Drawing ... -
New>Report -
Rename -

Delete -

Show Trash Folder -
Restore Item from Trash -
Empty Trash -

Remove All Empty Folders -

5.4.2 Draw Cables

Navigation: Referencelzs8 > Tool Panels seh >
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View > Tool Panels > Draw Cables
Commandline: none

Explanation

The Draw Cables tool panel is only active when the current environment is a drawing. This tool
allows you draw several different types of cables:

eOne-to-One| #4) - One output to one input.

eOne-to-Many| 3 - One outputs to many inputs.

oMany-to-Onem - Many outputs to one input.

eMany-to-Many/ s - Many outputs to many inputs.

eTerminal on the Left[ 31 - Drag a Terminal into the drawing and drop it on a connection point in the
drawing. This will place the terminal on the left hand side of the block.

eTerminal on the Right[ «} Drag a Terminal into the drawing and drop it on a connection point in the
drawing. This will place the terminal on the right hand side of the block.

eWorking with Pointers| o).

Prerequisites
Requires and open drawing.

Related Topics:
Draw Cables| ¢21

5.4.3 Drawing Properties

Navigation: Referencel2# > Tool Panels s >

View > Tool Panels > Drawing Properties
Commandline: none

Explanation
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Provides access to the drawing properties. If no selection set exists in the drawing the general
document properties are presented. If a selection exists then the common properties of all items in
the selection set are displayed for edit. You may also select a single item from the selection set and
edit all of its properties.

Prerequisites
An open drawing.

Related Topics:
None

Tool Panel Options

eSelected Object - This combo box displays the selected object and allows you to select individual
items from the drop down.

Drawing Properties L X
I ez LIl Q,

4 Items)
4 Items
vdPalyline

vdText

vdText

vdInsert 360_SYST-Image_Sevi
Misic

FadeEffect i

eProperty grid - The properties displayed here will all have property editors that are specific to the

entity type.
Sort/Group/Display Descriptions/Search toolbar buttons
L 22 |@| Q

5.4.4 Find

Navigation: Referencelzs8 > Tool Panels seh >
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View > Tool Panels > Find and Replace
Commandline: none

Explanation

Find and replace text found in any drawing and in editable fields of the project databases. The found
list will tell you the context in which the searched text appears.

NOTE: found text may occur in an invisible attribute.

Changing a port name on a device using the Find and Replace tool requires that you change the
text in the following contexts:

eThe visible attribute.

eThe invisible CP_IN or CP_OUT attribute string. This is a pipe delimited string that contains the
name|conn|type. You must change the name portion of this.

eAny records that exist in the Project Cables table that reference that port.

Prerequisites
An active project

Related Topics:
None

Tool Panel Options

oFind - The text to search for.

¢[X] - Clear the Find text.

eSearch Active Drawing - Only look in the active drawing.

eSearch All Project Drawings - Search every project drawing.

eShow File - Show file name if any of the context in which the item is found.
eShow Item Type - Is it a text entity in a drawing or a field in a database.
eResults -
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L B B

o[Select All] - Selects all items in the results window.

o[Clear Selection] - De-selects all items in the results window.
eReplace With - The text to replace the found text with.
o[Replace Selected] - Initiate the replacement.

e[Cancel] - Cancels the current search.

o[Find] - Initiate the search.

5.4.5 Plan View

Navigation: Referencelzs% > Tool Panels st >

View > Tool Panels > Plan View
Commandline: none

Explanation
This tool panel provides three tabs. Each tab houses a gallery of Plan View blocks. The tabs are:
oAll Plan View Files - Enumerates the %BLOCKS%\Plan View Files\ folder tree presenting a

preview of each dwg file. Each sub folder will be added as a gallery group and items in that folder
added to the group.
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eProject Plan View Items - Provides a gallery item for each SysName in the Equipment List. If
the SysName's equipment definition has an empty Plan View File, the project Default Plan View
File is presented.

eEquipment Library Plan View Files - Shows all Equipment Library items that have data in the
Plan View File field.

Prerequisites
An open project.
An open drawing.

Tool Panel Options

ePlace with Rotation and Scale - If checked then when placing the selected item in the drawing
you will be prompted to scale the X, Y, Z and set the Rotation angle.
ePlan View Galleries - Click an item to add it to the drawing. Then place (and scale/rotate).

5.4.6 Favorites

Navigation: Reference[2# > Tool Panels [sh >

T iy
EErrEe
E

View > Tool Panels > Favorites
Commandline: none

Explanation

Often times we find ourselves creating the same block or circuit configuration over and over. These
times are a great candidate for a Favorite. Creating a Favorite stores the item(s) as a block in the
OS in one of three places:

eGlobal - Saves in the %BLOCKS%\Favorites path and may be visible to other user with the same
support path.

eUser - Saves to your user profile. Visible only to you.

eProject - Saves in the Project\Favorites folder for use by anyone with access to the project.
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Prerequisites
A drawing with the block or configuration you want to save as a Favorite.
A drawing into which you wish to place a Favorite.

Tool Panel Options

eExplode - If you have grouped a system together that includes multiple blocks and cables into a
single block. It will need to be exploded back one level to expose the individual WireCAD objects.
eScale

eList - Double-click to add to the current drawing.

5.4.7 Command Line

Navigation: Referencelzs > Tool Panels ssh >

X Expcutrg Commardt Open P0F - C: Lsors Puble Decumesis Gt 5 St Oe ssings Bt L pcf
™ e eyt Pl e o T i Do e i sty 8 W e e DR by, iy

i Caloulanon) 4

View > Tool Panels > Command Line
Commandline: none

Explanation

The Command Line interface to the application. Here you can view a history of commands and
enter commands directly. All commands entered must be executed by clicking the [Enter] key.

Prerequisites
None

Related Topics:
My Space Bar is my Enter Key/ s

Dialog Options

eCommand History - What went before.
eCommand Prompt - What the application is expecting of you. If no job is running or no input is
expected from you it will read: Command:

¥ Mo AutoSave Meeded : testl.dwg
| Mo AutoSave Needed : Test2.dwg

Command: |

Otherwise it will prompt you for some action:

X Mo AutoSave Meeded : testl.dwg
| Mo AutoSave Needed : Test2.dwg

Select the Source

eCommand Line - Enter the command here.
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eCalculator
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Weriting Plugins

6 Writing Plugins

INTRODUCTION The examples can be found at: C:
users\public\documents\WireCAD\WireCAD9\WireCAD
SDK\Examples Welcome to the WireCAD SDK examples. These
examples show you how t

INTRODUCTION

The examples can be found at:
C:\users\public\documents\WireCAD\WireCAD9\WireCAD SDK\Examples

Welcome to the WireCAD SDK examples. These examples show you how to
interact, via your own code, with WireCAD. These examples assume that
you understand the basics of C# programming syntax and structure

(the examples are in C# but you may use any .NET programming language
that you are comfortable with).

If you do not understand it don't let that deter you. It is really

very easy to understand. Microsoft has tons of examples. Just get on

the web.

If you have WireCAD SDK specific questions email support@wirecad.com
along with as much code as you can and an explanation of what you are
trying to do. We will try to help. If you need more help or if you are
developing a commercial plugin for WireCAD you may want to consider
purchasing custom programming services from us.

Please call the office for more information.

Getting Started
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You will want to download a .net ready integrated development environment(IDE)
like Visual Studio for c# or SharpDevelop. Visual Studio has free versions.
SharpDevelop is an open source.

We recommend the Visual Studio for the ability to attach a debugger to your
running process. Also use the WireCADv9Templatelnstaller.vsix to install several
starter projects in Visual Studio that you can use from the File>New Project wizard.

The first place to go with any programming effort is the ubiquitous
"Hello World" example in the Basic folder.

NOTE: there are two types of WireCAD plugin.

1. The automatically discovered (AD) plugin that loads silently

and may or may not interact with the user.

2. Plugins that require a WireCAD .wpi manifest file that describes

where the plugin can be found, how to call it, what icon to display and on

which toolbar or menu, etc. Both plugins implement the WireCAD.IPlugin interface.

AD plugins are named YourPluginName.Plugin.DIl and are placed in the
C:\users\public\documents\WireCAD\WireCAD9\\bin folder.

Standard WireCAD plugins have no naming requirements
but must be accompanied by a .wpi file in the
C:\users\public\documents\WireCAD\WireCAD9\Plugins\Active Plugins folder.

To create a wpi file you can use the utility in Plugins>Plugin Manager [New PI Info]

Take some time to read through the code. The interface is very simple,
yet you can access most of the WireCAD object model including drawing,
data access, grids, GUI, reports, etc.

You can also create your own forms and functions to interact with the
WireCAD objects.

THIRD PARTY LIBRARIES

WIRECAD USES THIRD PARTY LIBRARIES THAT MAY REQUIRE YOU TO PURCHASE
DEVELOPER

COPIES. PLEASE DO NOT IGNORE THIS STATEMENT. THESE ARE GREAT LIBRARIES AND
IF YOU ARE PLANNING TO DEVELOP A COMMERCIAL PLUGIN FOR WIRECAD YOU WILL
WANT

TO HAVE THEM. If you are developing a small project or line of business function

for your own use you may not need to purchase licenses. Here is an example:

If you want your plugin to have the same look and feel, or create a custom form

with the same gridview or treeview as WireCAD you will need

to purchase the Developer Express library. If you are developing a custom form

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Weriting Plugins

that needs to show its own drawing engine you will need to purchase the
VectorDraw developer framework. If, on the other hand, you are able to use

the WireCAD baseforms object, are happy with the WinForms controls and can
develop using the WireCAD drawing engine then you can get started without
spending a dime.

BUILDING YOUR FIRST PLUGIN

STEPS:

1. Open your IDE

2. Click File>Open Project or Solution and browse to the basic hello world.csproj

project file in the examples\basic\hello world folder

3. Click Build>Build Solution (Ctrl+Shft+B) to build the project.

4. Check that the file C:\Users\Public\Documents\WireCAD\WireCAD9\bin\helloworld.plugin.dll
exists. If it does not then you need to check the project build path in the project properties
section and point it to the WireCAD bin folder above.

If you get any reference errors check Project>Hello World Properties... [Reference Paths]
section
points to C:\Users\Public\Documents\WireCAD\WireCAD9\bin\. If it does not then modify
it and make sure that your reference errors disappear.
5. You now need to force WireCAD to load the shiny new plugin.
Either relaunch WireCAD (tedious) or click Plugins>Plugin Manager ... then
click the [Rescan and Reload All Plugins] button. Make sure that the helloworld.plugin
appears in the Auto Discovered Plugins list.
6. Now enter hw in the commandline and click [Enter]. This will launch the command that
the plugin registered in its Load() method.
7. Make some changes and click Build>Build Solution (Ctrl+Shft+B) to build the project again.
If your changes are outside the load() method you will not need to force a reload.
Just call the command again by typing hw in the commandline and click [Enter].

There you have it. You have just built your first WireCAD plugin. Now go forth and do more!

DEBUGGING YOUR PLUGIN

Invariably you will need to stop the execution of your plugin and examine the variables
and logic structure to figure out why it is not working as you expect.

The following instructions assume you are using the Visual Studio IDE for C#. Further, that
you have built your project and made sure it is loading in the WireCAD plugin framework by
looking at the loaded plugins list in Plugins>Plugin Manager...

NOTE: The following will work for anything other than the initial Load() method. To debug that
read on.
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Steps:

1. Open your project in the Visual Studio IDE.

2. Run WireCAD.

3. In VS click Debug>Attach to Process...

4. Select WireCAD9.exe.

5. Place a breakpoint in the code where you want to stop execution. Do this by clicking in the
gutter of the text editor(very left hand edge. A red dot will appear).

6. Execute your command. The debugger will pause at the line and highlight the paused line.
In the interface you will find two very helpful tool windows - Locals and Autos. These windows
list the variables in play at the time of the breakpoint.

7. On the IDE Debug menu you will find commands to continue execution:

1. Continue - runs from the break point until it hits the next breakpoint if any.

2. Step Into - continues execution of the next line. If the next line calls another function
you will be stepped into that function.

3. Step Over - continues execution of the next line. If the next line calls another function
that function will execute in its entirety and you will step to the next line in the current
code block.

While you cannot edit and continue you will be able to understand the changes you need to make
to fix the issue you are having.
8. Stop the debugger. Fix your code. Lather, rinse, repeat.

DEBUGGING THE LOAD() METHOD OF THE IPLUGINCORE
INTERFACE

The load method or the HasPermissionToRun methods of the IPluginCore interface require some
special consideration if we are to debug them. The reason for this is that the WireCAD loading
process will call these methods before we have a chance to attach the debugger to the process.

This section will outline two approaches:

1 - PAUSE EXECUTION USING MESSAGEBOX

Place a MessageBox.Show("Pause"); command in the Load or the HasPermissionToRun
method.

This modal dialog will pause execution for you to attach the debugger as shown above.

like this:

/// <summary>
/// This is called when the plugin is loaded at application start
/// </summary>
/// <param name="ws">Singleton WireCAD Workspace object</param>
public void Load(IWorkspace ws)
{
MessageBox.Show ("Pausing plugin load so you can attach the debugger");
....... Your code here

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Weriting Plugins

2 - START WIRECAD IN THE DEBUGGER PROCESS

The other approach is to start WireCAD in the debugger from your project. While this seams like a
good approach it suffers from a major drawback. When you want to fix your code you must stop the
debugging session. Since WireCAD is running in the same process it will stop as well. Thus
requiring

you to start WireCAD every time you want to make a fix.

Steps:
1. Open your project in the IDE.
2. Close WireCAD.
3. Open the Project Properties window - Project>YourProjectName Properties...
4. Select the Debug section.
5. Select the Start External Program radio button.
6. Browse to the WireCAD9.exe at: C:
\Users\Public\Documents\WireCAD\WireCAD9\bin\WireCAD9.exe
7. Place your breakpoint.
8. Click Debug>Start Debugging (F5).
This will start the debugging session by launching WireCAD first. As WireCAD loads it will
eventually
come to your Load() method and hit your breakpoint.

When you are finished with your examination close WireCAD and let it shutdown. Ending the
debugging

session with the Debug>Stop Debugging (Shift+F5) acts like Kill Process and will not allow
WireCAD

to store session state.

ADDITIONAL RESOURCES

C# is the language of choice for developing in WireCAD. There are tons of resources
online to learn this language.

For WireCAD specific issues:

www.wirecad.com/wiki

support@wirecad.com

Please don't submit support tickets for SDK issues. Use the support email.

Developer Express is the library we use for many of the Ul elements. They have
a brilliant web site with documentation and support. If you are going to go

deep on WireCAD development you will probably want to purchase a license.
www.developerexpress.com

VectorDraw is the drawing engine we use. While their site is minimal they do offer

registered developers lots of sample code.
www.vdraw.com

WireCAD v10.1 User Manual © 2025 Holbrook Enterprises, Inc. - WireCAD



Weriting Plugins

for a full api listing visit:
for the main WireCAD9.exe:
https://www.wirecad.com/api/90/exe/index.html

for the global data access layer:
http://www.wirecad.com/api/90/globaldal/index.html

for the project data access layer:
http://www.wirecad.com/api/90/projectdal/index.htmi

6.1 Hello World

Navigation: Writing Plugins|ss1 >

Every programming effort starts with the ubiquitous "Hello World" example. This example is meant
to provide just enough information to show the framework and produce an output.

Please note that in C# comments are preceded by //.

using System;

using System.Collections.Generic;
using System.Ling;

using System.Text;

using System.Windows.Forms;
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using VectorDraw.Professional.vdFigures;
using VectorDraw.Professional.vdObjects;
using WireCAD;

using WireCAD.Interfaces;

using WireCAD.Translation;

namespace hello world

{

public class MyPlugin: IPluginCore
{
#region Fields
//Place your field level variables here
CommandInfo ci = null;

#endregion

#region Properties
//Place your Properties Here

#endregion

#region IPluginCore Members

public bool HasPermissionToRun (IWorkspace ws, Identity id)
{

return true;

}

public void Load(IWorkspace ws)
{

ci = new CommandInfol();

ci.Assembly = "helloworld.plugin.dll";
ci.NameSpaceAndClass = "hello world.MyPlugin";
ci.MethodName = "HelloWorld";

ci.CommandLongName = "Hello World Demo";

ci.CommandAlt = "hello";
//The shortcut
ci.ShortCut = "hw";

ws.Commands.RegisterCommand (ci) ;
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public void Unload (IWorkspace ws)

{

ws.Commands.UnRegisterCommand (ci) ;

}

#endregion

#region Static Methods

public static void HelloWorld(Workspace ws)
{

MessageBox.Show ("Hello World");

Forml f = new Forml () ;
f.ShowDialog() ;

ws.MainForm.CommandLine.AppendHistory ("Hello World");

if (!Commands.IsActiveDrawing (ws, true))

{
//no active drawing so return
return;

if (DialogResult.No == MessageBox.Show (
"Would you like us to add some text to the active drawing?",
"WireCAD SDK",MessageBoxButtons.YesNo)) return;

vdText text = new vdText () ;

text.SetUnRegisterDocument (ws.ActiveDrawing) ;

text.setDocumentDefaults () ;

text.TextString = "hello world";
text.InsertionPoint = new VectorDraw.Geometry.gPoint (0,0,0);
text.Height = .25;

vdColor colorRed = new vdColor();
colorRed.SetUnRegisterDocument (ws.ActiveDrawing) ;
colorRed.Palette = ws.ActiveDrawing.Palette;
colorRed.FromRGB (255,0,0) ;

text.PenColor = colorRed;
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ws.ActiveDrawing.ActivelLayOut.Entities.AddItem(text) ;

ws.ActiveDrawing.Redraw (true) ;

}

#endregion
}
}

6.2 Getting Started
Navigation: Writing Plugins|szs) >

The following assumes that you have installed either Visual Studio 2017 or 2019.

Run the WireCADv10.0Tem platesinstaller.vsix template installer from C:
\Users\Public\Documents\WireCAD\WireCAD10\WireCAD SDK\Visual Studio Templates
Installer\WireCADv10.0ProjectTemplatesinstaller.vsix.

Launch Visual Studio

Study the examples by loading the All Project solution:
C:\Users\Public\Documents\WireCAD\WireCAD10\WireCAD SDK\Examples\All Projects.sIn

When you want to create a new project to start your own plugin follow these steps:

Your First Plugin Project

1.Click [File] > [New Project]

Ve By ] w

2.Select one of the C# WireCAD Project Templates
3.Name it something meaningful.
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4.Click [OK] and a new solution will be created for you with all the necessary references and
interface files.

5.Now start coding!

6.Click F5 to build your project and make sure that it builds and copies to c:
\users\public\documents\WireCAD\W ireCAD 10\bin\YourPluginName.dll. If it does not build check to
make sure that the Project Properties - Reference Paths section has a pointer to the above path.
7.1f you are using a wpi file make sure that it is edited to point it to your dll and method and that you
have copied it to c:\users\public\documents\WireCAD\WireCAD10\Plugins\Active Plugins folder.
Relaunch WireCAD or click [Rescan and Reload] from the WireCAD Plugin Manager to make
WireCAD load your plugin.

6.3 Registering Your Plugin
Navigation: Writing Plugins|[s7#1 >

Menu: Plugins>Plugin Manager[Add/Edit Pl Info]
Default command line shortcut: none

Assuming your plugin requires user input to launch it, ie. it does not respond to an event. You will
want to register your command with the application.

WireCAD uses an information file (wpi - WireCAD Plugin Info) to describe a command and to tell
the application how to execute the command.

WireCAD looks for these files in the c:
\users\public\documents\WireCAD\WireCAD10\plugins\Active Plugins

Commands can be executed directly from the Commandline or from a button on a menu bar.

In order to register your command you must, at minimum, set up the Commandline arguments.
Toolbar buttons are optional. To edit a wpi file use the editor.
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&1 Plugin Manager

AssemblyNameAndPath

» | WireCAD. Archiver 1.Plugin, Version=10.0.0.0, C...
WireCAD.Favorites.Plugin, Version=10.0.0.0, C...
WireCAD, Library.ExtraShapes.Plugin, Version=...
WireCAD.TitleBlockManager. 10.Plugin, Version=...

Loaded Plugins (these plugins have all registered at least one button on the gui):

Load

Name Description Copyright Website Author T

» | All Block Extractor Extracts All Bloc... Copyright 2008-... www.wirecad.com Holbrook Enterpr... »
Batch Plotter Batch Plotter Utll... Copyright 2009-... www.wirecad.com WireCAD Rescan and Reload Al
Block File Fixer Changes entities... Copyright 2009-... www.wirecad.com Holbrook Enterpr Plugin Creation:
BrotherPTouch Brother P-Touch  Copyright 2009 ... www.wirecad.com Holbrook Enterpr...
DWG Diff Drawing Diff Tool = Copyright 2004-... www.wirecad.com Holbrook Enterpr... jAdd/Edit P1 Info (*.wpl ﬁ\e)_f‘
PatchVerx Patchbay Design... Copyright 2009 ... www.wirecad.com Holbrook Enterpr... Edit Plugin Code
WireCAD. Archive 1 Archive Proiects... Coovriht 2000-... www.wirecad.com Holbrook Enteror... ¥

A Unloaded Plugins:
Name Description Author Website Copyright

Auto Discovered Plugins (Silent load - may or may not have gui elements)

NameSpaceDotClass1

Exit

% os Add Or Edit Plugins ?7 X
b B8 B8
New Open Save Exit
File [F ~
Name | Description
Author Holbrook Enterprises, Inc. Website www.wirecad.com
Copyright Copyright 2000-2016 Holbrook Enterprises, Inc. All Rights Reserved
Button Info
Tool Tip Caption
Ribbon Page v | Ribbon Page Group v
Button Bitmap No image data
Command Line and Assembly Info
Command Line Long Name Command Line Short Name
Command Line Alt Assembly Name And Path
MName Space Dot Class Static Method Name v

Information: -
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Controls

eName, Description, Author, Website, Copyright - Self explanatory.

Button Info

eTool Tip - Text displayed when mouse hovers over the button.

eCaption - The button caption.

eRibbon Page - Select a page or create your own.

eRibbon Page Group - Select a page group or create your own.

eButton Bitmap - bitmap image. 16x16 for a small button 32x32 for a large one.

Command Line and Assembly Info

eLong Name - The display name of your command.

eShort Name - The shortcut.

oAlt - Shorter less descriptive.

eAssembly Name - The name and fully qualified path of your dll. If no path we will search the
\WireCADXx\bin directory.

eNamespace Dot Class - YourNameSpace.YourClass where your function is located.

oStatic Method Name - The static void method name of your function. This must have the proper
signature as follows:

public static void YourFunctionName (WorkSpace ws)

Using the above example the Static Method Name would be: YourFunctionName

NOTE: if you use the WireCAD Plugin temglate@ a static method with the proper signature will be
created for you. You will need to rename it to be something meaningful.
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